Aveva.Pdms.Maths.Geometry

AVEVA Maths / Geometry .NET Public Interface

Aveva.Pdms.Maths.Geometry Namespace

Namespace hierarchy

Classes

Class | Description
D2Angle | Class definition for an angle An object of this class represents an angle. The angle can be specified either in radians or degrees, and it can be queried in either units (irrespective of the units that were used to specify it). The functions sin() cos() belonging to this class have the property that when the angle is close to some integer multiple of PI/2 radians (90 degrees), the result is EXACTLY 0.0 , 1.0 or -1.0 as appropriate. The tolerance used for the test can be specified, but otherwise defaults to 1.0e-6 radians. Some operators are also defined.
D2Arc | A directed arc class An arc can run either anticlockwise or clockwise from the start to the end angle. The direction is defined by the user. Input angles will be normalized to lie between 0 and 2pi If start and end angles are EXACTLY EQUAL then the arc will be treated as a FULL CIRCLE. All Angles are measured anticlockwise from the x axis.
D2Circle | A 2-D Circle N.B. all ANGLES measured ANTI-CLOCKWISE from X-AXIS
D2DivideLine | A 2-D Line Class, With normal n and dist d, point x is: on the line if: n.x + d = 0 above the line if: n.x + d > 0 Alternative format is (a,b;c) - point (x,y) is above the line if: ax + by + c > 0 The normal (as stored internally) always has magnitude 1.
D2FiniteLine | Finite line
D2IrregularCartesianGrid | Class definition of a an Irregular Cartesian Grid. The members of this class are: 1) a mthOrientedPlane representing the origin and orientation of the grid, 2) a validity flag, 3) an array containing the x spacings for the grid definition, and 4) an array containing the y spacings for the grid definition. The x and y spacings must be non-zero and positive for this type of grid to be valid. Empty vectors will result in an invalid grid.
D2IrregularPolarGrid | Class definition of a an Irregular Polar Grid. An invalid grid will occur if any radii value is negative. If either the angular or radial vectors are empty a valid grid is defined, however, if both the angular and radial vectors are empty an invalid grid is defined.
D2Limits | 2-D Limits Box
D2Line | 2 D Line class
D2Matrix | 2x2 matrix This matrix class can represent a 2x2 matrix of douuble precision quantities. The elements are indexed from (zero,zero).
D2Point | D2Point - a 2-D point class
D2PolyLine | 2-D polyline sequence of straight line segments connected end to end
D2Profile | 2-D profile This class represents a sequence of spans connected end to end. Each span is either a finite straight line or a circular arc. The number of nodes for a profile is always one more than the number of spans. A closed profile is represented by having the last node equal to the first. The constructors (apart from the copy constructor) generate an 'open-ended' profile consisting of a single node and with no spans. (If the first node is not known when the constructor is invoked, it can be set later by calling setNode() .) The function addSpan() should be called succesively to extend an open-ended profile one span at a time. The function close() may be called to add the final span for what is to be a closed profile.
D2RegularCartesianGrid | Class definition of a Regular Cartesian Grid. The x and y spacings must be non-zero and positive for this type of grid to be valid.
D2Span | Span class - consists of a line or arc, and is used by D2Profile
D2Transform | D2Transform - solid body transformations
D2Vector | 2-D vector class
D3Arc | A directed 3-D arc
D3FiniteLine | Finite line in 3D space
D3Limits | 3-D limits This object can be in one of 2 states: - unset: origin at ( DBL_MAX, DBL_MAX, DBL_MAX) extent at (-DBL_MAX, -DBL_MAX, -DBL_MAX) - set: xMin <= xMax, yMin <= yMax, zMin <= zMax
D3Line | Finite, Semi-infinite or infinite line in 3D space
D3Matrix | 3x3 matrix This matrix class can represent a 3x3 matrix of double recision quantities. The elements are indexed from (zero,zero,zero).
D3OrientedPlane | Class definition for an oriented plane This class is intended for use as a local coordinate system so that plane coordinate geometry can be performed. Conceptually it has a one-to-one correspondence with PDMS's orientated plane. Apart from its direct use for the 2-d geometry constructor, it is intended that arcs, planar curves and lines in 3-d are reduced to 2-d via mth2<obj>(const mth3<obj>, const D3OrientedPlane); To create the plane you need to supply an origin (D3Point) and two axes u,v - both D3Vector. The plane normal is then defined by u x v. This class always creates a plane with right-handed orthonormal axes. An internal flag is set if the data is invalid (e.g. the input vectors are null or colinear) and an attempt to use an invalid class will result in an assertion failure. Applications should use the 'inValid()' method to preemptively trap this condition. A cast to a D3Plane exists so that geometric operations on a D3Plane will also work on an D3OrientedPlane; you can also cast to a D3Transform.
D3Plane | A 3-D Plane Class (with double values) With normal n and dist d, point x is: on the plane if: n.x + d = 0 above the plane if: n.x + d > 0 Alternative format is (a,b,c;d) - point (x,y,z) is above the plane if: ax + by + cz + d > 0 normal always has magnitude 1.
D3Point | 3D Point class
D3Transform | D3Transform - solid body transformations
D3Vector | 3D Vector class

Interfaces

Interface | Description
D2PointFactory | D2PointFactory

Enumerations

Enumeration | Description
D2Angle.angleUnits | enum to define units as radians or degrees
D2Line.LTYPE | four possible line types
D3Line.LTYPE | four possible line types
©AVEVA Solutions Ltd 2007


D2Angle Class

Class definition for an angle An object of this class represents an angle. The angle can be specified either in radians or degrees, and it can be queried in either units (irrespective of the units that were used to specify it). The functions sin() cos() belonging to this class have the property that when the angle is close to some integer multiple of PI/2 radians (90 degrees), the result is EXACTLY 0.0 , 1.0 or -1.0 as appropriate. The tolerance used for the test can be specified, but otherwise defaults to 1.0e-6 radians. Some operators are also defined.

For a list of all members of this type, see D2Angle Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2Angle

public abstract class D2Angle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2Angle Members | Aveva.Pdms.Maths.Geometry Namespace


D2Angle Members

D2Angle overview

Public Static Methods

Create Overloaded. default angle

Public Static Operators

Addition Operator | invoked by a1 + a2
Equality Operator | invoked by left == right - true if angles are exactly the same
Inequality Operator | invoked by left != right - true if angles not exactly the same
Multiplication Operator | invoked by s * a1
Subtraction Operator | invoked by a1 - a2

Public Instance Methods

Add | Add two angles
Clone | Deep copy
Cos | Overloaded. Return cosine of angle
Cosec | Gets the tangent of the angle through the argument. If false is returned then the argument will contain DBL_MAX (defined in float.h); if true is returned the argument contains the cosecant of the angle.
Cotan | Gets the cotangent of the angle through the argument. If false is returned then the argument will contain DBL_MAX (defined in float.h); if true is returned the argument contains the cotangent of the angle.
Degrees | Overloaded. set angle given in degrees
Equals | Overloaded. override system equals method
GetHashCode | override system gethashcode method
GetType (inherited from Object) | Gets the Type of the current instance.
Multiply | Multiply angle by given value
Normalize | reset angle_ to be in range 0 - 2Pi
NormDegrees | return angle in the range [0,360]
NormRadians | return angle in the range [0,2Pi]
Radians | Overloaded. set angle given in radians
Sec | Gets the secant of the angle through the argument. If false is returned then the argument will contain DBL_MAX (defined in float.h); if true is returned the argument contains the secant of the angle.
Sin | Overloaded. Return sine of angle
Subtract | Subtract two angle
Tan | Gets the tangent of the angle through the argument. If false is returned then the argument will contain DBL_MAX (defined in float.h); if true is returned the argument contains the tangent of the angle.
ToString | Returns a string describing the contents of the D2Angle

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle Methods

The methods of the D2Angle class are listed below. For a complete list of D2Angle class members, see the D2Angle Members topic.

Public Static Methods

Create Overloaded. default angle

Public Instance Methods

Add | Add two angles
Clone | Deep copy
Cos | Overloaded. Return cosine of angle
Cosec | Gets the tangent of the angle through the argument. If false is returned then the argument will contain DBL_MAX (defined in float.h); if true is returned the argument contains the cosecant of the angle.
Cotan | Gets the cotangent of the angle through the argument. If false is returned then the argument will contain DBL_MAX (defined in float.h); if true is returned the argument contains the cotangent of the angle.
Degrees | Overloaded. set angle given in degrees
Equals | Overloaded. override system equals method
GetHashCode | override system gethashcode method
GetType (inherited from Object) | Gets the Type of the current instance.
Multiply | Multiply angle by given value
Normalize | reset angle_ to be in range 0 - 2Pi
NormDegrees | return angle in the range [0,360]
NormRadians | return angle in the range [0,2Pi]
Radians | Overloaded. set angle given in radians
Sec | Gets the secant of the angle through the argument. If false is returned then the argument will contain DBL_MAX (defined in float.h); if true is returned the argument contains the secant of the angle.
Sin | Overloaded. Return sine of angle
Subtract | Subtract two angle
Tan | Gets the tangent of the angle through the argument. If false is returned then the argument will contain DBL_MAX (defined in float.h); if true is returned the argument contains the tangent of the angle.
ToString | Returns a string describing the contents of the D2Angle

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.Add Method

Add two angles

public abstract D2Angle Add(
D2Angle a2
);

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.Clone Method

Deep copy

public abstract D2Angle Clone();

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


Cos Method

AVEVA Maths / Geometry .NET Public Interface

D2Angle.Cos Method

Return cosine of angle

Overload List

Return cosine of angle

public abstract double Cos();

return cosine of angle. angles within delta of 0, PI/2, PI 3PI/2 2PI (or multiples thereof) will return exactly 1, 0, -1 0 1 respectively

public abstract double Cos(double);

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.Cos Method ()

Return cosine of angle

public abstract double Cos();

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Cos Overload List


D2Angle.Cos Method (Double)

return cosine of angle. angles within delta of 0, PI/2, PI 3PI/2 2PI (or multiples thereof) will return exactly 1, 0, -1 0 1 respectively

public abstract double Cos(
double delta
);

Parameters

delta

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Cos Overload List


D2Angle.Cosec Method

Gets the tangent of the angle through the argument. If false is returned then the argument will contain DBL_MAX (defined in float.h); if true is returned the argument contains the cosecant of the angle.

public abstract bool Cosec(
ref double d
);

Parameters

d

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.Cotan Method

Gets the cotangent of the angle through the argument. If false is returned then the argument will contain DBL_MAX (defined in float.h); if true is returned the argument contains the cotangent of the angle.

public abstract bool Cotan(
ref double d
);

Parameters

d

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2Angle.Create Method

default angle

Overload List

default angle

public static D2Angle Create();

copy constructor

public static D2Angle Create(D2Angle);

Construct an angle as a proportion: a = (1-prop)*a1 + prop*a2

public static D2Angle Create(D2Angle,D2Angle,double);

Construct an angle from a 2-d vector

public static D2Angle Create(D2Vector);

Create from angle (in radians)

public static D2Angle Create(double);

input D2Angle::rads if ang is in degrees input D2Angle::degs if ang is in degrees

public static D2Angle Create(double,angleUnits);

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.Create Method ()

default angle

public static D2Angle Create();

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Create Overload List


D2Angle.Create Method (D2Angle)

copy constructor

public static D2Angle Create(
D2Angle ang
);

Parameters

ang

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Create Overload List


D2Angle.Create Method (D2Angle, D2Angle, Double)

Construct an angle as a proportion: a = (1-prop)*a1 + prop*a2

public static D2Angle Create(
D2Angle a1,
D2Angle a2,
double prop
);

Parameters

a1
a2
prop

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Create Overload List


D2Angle.Create Method (D2Vector)

Construct an angle from a 2-d vector

public static D2Angle Create(
D2Vector vec
);

Parameters

vec

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Create Overload List


D2Angle.Create Method (Double)

Create from angle (in radians)

public static D2Angle Create(
double ang
);

Parameters

ang

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Create Overload List


D2Angle.Create Method (Double, angleUnits)

input D2Angle::rads if ang is in degrees input D2Angle::degs if ang is in degrees

public static D2Angle Create(
double ang,
angleUnits units
);

Parameters

ang
units

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Create Overload List


Degrees Method

AVEVA Maths / Geometry .NET Public Interface

D2Angle.Degrees Method

returns angle in degrees

Overload List

returns angle in degrees

public abstract double Degrees();

set angle given in degrees

public abstract void Degrees(double);

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.Degrees Method ()

returns angle in degrees

public abstract double Degrees();

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Degrees Overload List


D2Angle.Degrees Method (Double)

set angle given in degrees

public abstract void Degrees(
double ang
);

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Degrees Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2Angle.Equals Method

override system equals method

Overload List

override system equals method

public abstract bool Equals(D2Angle);

true if angles same within tolerance delta, where delta is measured in RADIANS

public abstract bool Equals(D2Angle,double);

override system equals method

public override bool Equals(object);

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.Equals Method (D2Angle)

override system equals method

public abstract bool Equals(
D2Angle a
);

Parameters

a

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Equals Overload List


D2Angle.Equals Method (D2Angle, Double)

true if angles same within tolerance delta, where delta is measured in RADIANS

public abstract bool Equals(
D2Angle a,
double delta
);

Parameters

a
delta

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Equals Overload List


D2Angle.Equals Method (Object)

override system equals method

public override bool Equals(
object a
);

Parameters

a

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Equals Overload List


D2Angle.GetHashCode Method

override system gethashcode method

public override int GetHashCode();

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.Multiply Method

Multiply angle by given value

public abstract D2Angle Multiply(
double s
);

Parameters

s

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.Normalize Method

reset angle_ to be in range 0 - 2Pi

public abstract void Normalize();

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.NormDegrees Method

return angle in the range [0,360]

public abstract double NormDegrees();

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.NormRadians Method

return angle in the range [0,2Pi]

public abstract double NormRadians();

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


Radians Method

AVEVA Maths / Geometry .NET Public Interface

D2Angle.Radians Method

returns angle in radians

Overload List

returns angle in radians

public abstract double Radians();

set angle given in radians

public abstract void Radians(double);

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.Radians Method ()

returns angle in radians

public abstract double Radians();

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Radians Overload List


D2Angle.Radians Method (Double)

set angle given in radians

public abstract void Radians(
double ang
);

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Radians Overload List


D2Angle.Sec Method

Gets the secant of the angle through the argument. If false is returned then the argument will contain DBL_MAX (defined in float.h); if true is returned the argument contains the secant of the angle.

public abstract bool Sec(
ref double d
);

Parameters

d

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


Sin Method

AVEVA Maths / Geometry .NET Public Interface

D2Angle.Sin Method

Return sine of angle

Overload List

Return sine of angle

public abstract double Sin();

return sine of angle. angles within delta of 0, PI/2, PI 3PI/2 2PI (or multiples thereof) will return exactly 0, 1, 0 -1 0 respectively

public abstract double Sin(double);

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.Sin Method ()

Return sine of angle

public abstract double Sin();

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Sin Overload List


D2Angle.Sin Method (Double)

return sine of angle. angles within delta of 0, PI/2, PI 3PI/2 2PI (or multiples thereof) will return exactly 0, 1, 0 -1 0 respectively

public abstract double Sin(
double delta
);

Parameters

delta

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Angle.Sin Overload List


D2Angle.Subtract Method

Subtract two angle

public abstract D2Angle Subtract(
D2Angle a2
);

Parameters

a2

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.Tan Method

Gets the tangent of the angle through the argument. If false is returned then the argument will contain DBL_MAX (defined in float.h); if true is returned the argument contains the tangent of the angle.

public abstract bool Tan(
ref double d
);

Parameters

d

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.ToString Method

Returns a string describing the contents of the D2Angle

public abstract string ToString();

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle Operators

The operators of the D2Angle class are listed below. For a complete list of D2Angle class members, see the D2Angle Members topic.

Public Static Operators

Addition Operator | invoked by a1 + a2
Equality Operator | invoked by left == right - true if angles are exactly the same
Inequality Operator | invoked by left != right - true if angles not exactly the same
Multiplication Operator | invoked by s * a1
Subtraction Operator | invoked by a1 - a2

See Also

D2Angle Class | D2Angle Members | Aveva.Pdms.Maths.Geometry Namespace


D2Angle Addition Operator

invoked by a1 + a2

public static D2Angle operator +(
D2Angle a1,
D2Angle a2
);

Parameters

a1
a2

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle Equality Operator

invoked by left == right - true if angles are exactly the same

public static bool operator ==(
D2Angle left,
D2Angle right
);

Parameters

left
right

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle Inequality Operator

invoked by left != right - true if angles not exactly the same

public static bool operator !=(
D2Angle left,
D2Angle right
);

Parameters

left
right

Return Value

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle Multiplication Operator

invoked by s * a1

public static D2Angle operator *(
D2Angle a1,
double s
);

Parameters

a1
s

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle Subtraction Operator

invoked by a1 - a2

public static D2Angle operator -(
D2Angle a1,
D2Angle a2
);

Parameters

a1
a2

See Also

D2Angle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Angle.angleUnits Enumeration

enum to define units as radians or degrees

public enum D2Angle.angleUnits

Members

Member Name | Description
rads | Radians
degs | Degrees

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

Aveva.Pdms.Maths.Geometry Namespace


D2Arc Class

A directed arc class An arc can run either anticlockwise or clockwise from the start to the end angle. The direction is defined by the user. Input angles will be normalized to lie between 0 and 2pi If start and end angles are EXACTLY EQUAL then the arc will be treated as a FULL CIRCLE. All Angles are measured anticlockwise from the x axis.

For a list of all members of this type, see D2Arc Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2Arc

public abstract class D2Arc

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2Arc Members | Aveva.Pdms.Maths.Geometry Namespace


D2Arc Members

D2Arc overview

Public Static Methods

Create Overloaded. Create default arc

Public Static Operators

Equality Operator | equality operator
Inequality Operator | inequality operator

Public Instance Properties

Radius Property to set/get radius of arc

Public Instance Methods

Anticlockwise | Overloaded. set the direction the arc takes from start to end ( input "true" implies anticlockwise)
Bulge | returns the bulge factor of the arc. +ve for anticlockwise arc and -ve for clockwise arc (returns DBL_MAX for a full circle.)
Centre | Overloaded. set centre of arc to given x, y values
Clockwise | Overloaded. set the direction the arc takes from start to end ( input "true" implies clockwise)
Clone |
Degrees | Overloaded. Returns a point on the circumference of the arc circle, at the specified angle
End | returns the end of the arc
EndAngle | Returns end angle in D2Angle
EndDegrees | Overloaded. set end angle
EndRadians | Overloaded. set end angle
EndTangent | Returns the vector of the end tangent
Equals | Overloaded. Returns true if arcs are equal
From3Points | Reconstruct the arc to pass from the start point to the end point and go THROUGH the thru Point. Returns TRUE if succesful. The three Points must NOT be collinear otherwise the function will return FALSE and the arc will remain unchanged.
GetHashCode | override system default gethashcode method
GetType (inherited from Object) | Gets the Type of the current instance.
Height | returns chord height
Intersects | Overloaded. Returns true if the finite line and the arc intersect
IsCircle | True if the arc is a circle i.e. EXACT EQUALITY of start and END ANGLES
IsConcentric | Overloaded. True if two arcs have saem centre
LeftTangentPoint | return via argument the point on the arc circle that lies on a line that is tangential to the arc circle and passes through point p. LeftTangentPoint lies to the LEFT of the line from p to circle centre. TRUE if p lies more than 1.E-6 outside the circle. FALSE if p lies within the circle or less than 1.E-6 outside.
Length | Returns the length of the arc
MoveBy | Overloaded. Move arc by x and y values
NearestPoint | returns the nearest point to "p" on the length of arc.
NearestPointToOrigin | returns the nearest point to origin on the length of arc.
OnArc | Overloaded. Returns true if point is on arc
Radians | Overloaded. Returns a point on the circumference of the arc circle, at the specified angle
RightTangentPoint | return via argument the point on the arc circle that lies on a line that is tangential to the arc circle and passes through point p. RightTangentPoint lies to the RIGHT of the line from p to circle centre. TRUE if p lies more than 1.E-6 outside the circle. FALSE if p lies within the circle or less than 1.E-6 outside.
RotateByDegrees | Overloaded. Rotate arc around origin by given angle
RotateByRadians | Overloaded. Rotate arc by given angle around origin
SpanAngle | Return D2Angle of span
SpanDegrees | Return span in degrees -ve for a clockwise arc, +ve otherwise If start and end angles are EXACTLY the same the arc will be treated as a full circle => span = 360
SpanRadians | Return span in radians -ve for a clockwise arc, +ve otherwise If start and end angles are EXACTLY the same the arc will be treated as a full circle => span = 2pi
Start | returns the start of the arc
StartAngle | Returns start angle in D2Angle
StartDegrees | Overloaded. set start angle
StartRadians | Overloaded. Set the start angle. Angles are normalized to be in the range 0 to 2Pi The arc will be treated as a FULL CIRCLE if the START and END ANGLES are EXACTLY the SAME.
StartTangent | Returns the vector of the start tangent
TangentDegrees | returns the direction of the tangent to the arc at the point lying at the supplied angle on the arc circle. The vector returned follow the "sense" of the arc.
TangentRadians | returns the direction of the tangent to the arc at the point lying at the supplied angle on the arc circle. The vector returned follow the "sense" of the arc.
ToString | Returns a string describing the contents of the D2Arc
WithinSpan | return true if the point is within the span of the arc
WithinSpanDegrees | Return true if angle is within span of the arc
WithinSpanRadians | return TRUE if angle is within the span of the arc

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc Properties

The properties of the D2Arc class are listed below. For a complete list of D2Arc class members, see the D2Arc Members topic.

Public Instance Properties

Radius Property to set/get radius of arc

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


Radius Property

AVEVA Maths / Geometry .NET Public Interface

D2Arc.Radius Property

Property to set/get radius of arc

public abstract double Radius {get; set;}

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc Methods

The methods of the D2Arc class are listed below. For a complete list of D2Arc class members, see the D2Arc Members topic.

Public Static Methods

Create Overloaded. Create default arc

Public Instance Methods

Anticlockwise | Overloaded. set the direction the arc takes from start to end ( input "true" implies anticlockwise)
Bulge | returns the bulge factor of the arc. +ve for anticlockwise arc and -ve for clockwise arc (returns DBL_MAX for a full circle.)
Centre | Overloaded. set centre of arc to given x, y values
Clockwise | Overloaded. set the direction the arc takes from start to end ( input "true" implies clockwise)
Clone |
Degrees | Overloaded. Returns a point on the circumference of the arc circle, at the specified angle
End | returns the end of the arc
EndAngle | Returns end angle in D2Angle
EndDegrees | Overloaded. set end angle
EndRadians | Overloaded. set end angle
EndTangent | Returns the vector of the end tangent
Equals | Overloaded. Returns true if arcs are equal
From3Points | Reconstruct the arc to pass from the start point to the end point and go THROUGH the thru Point. Returns TRUE if succesful. The three Points must NOT be collinear otherwise the function will return FALSE and the arc will remain unchanged.
GetHashCode | override system default gethashcode method
GetType (inherited from Object) | Gets the Type of the current instance.
Height | returns chord height
Intersects | Overloaded. Returns true if the finite line and the arc intersect
IsCircle | True if the arc is a circle i.e. EXACT EQUALITY of start and END ANGLES
IsConcentric | Overloaded. True if two arcs have saem centre
LeftTangentPoint | return via argument the point on the arc circle that lies on a line that is tangential to the arc circle and passes through point p. LeftTangentPoint lies to the LEFT of the line from p to circle centre. TRUE if p lies more than 1.E-6 outside the circle. FALSE if p lies within the circle or less than 1.E-6 outside.
Length | Returns the length of the arc
MoveBy | Overloaded. Move arc by x and y values
NearestPoint | returns the nearest point to "p" on the length of arc.
NearestPointToOrigin | returns the nearest point to origin on the length of arc.
OnArc | Overloaded. Returns true if point is on arc
Radians | Overloaded. Returns a point on the circumference of the arc circle, at the specified angle
RightTangentPoint | return via argument the point on the arc circle that lies on a line that is tangential to the arc circle and passes through point p. RightTangentPoint lies to the RIGHT of the line from p to circle centre. TRUE if p lies more than 1.E-6 outside the circle. FALSE if p lies within the circle or less than 1.E-6 outside.
RotateByDegrees | Overloaded. Rotate arc around origin by given angle
RotateByRadians | Overloaded. Rotate arc by given angle around origin
SpanAngle | Return D2Angle of span
SpanDegrees | Return span in degrees -ve for a clockwise arc, +ve otherwise If start and end angles are EXACTLY the same the arc will be treated as a full circle => span = 360
SpanRadians | Return span in radians -ve for a clockwise arc, +ve otherwise If start and end angles are EXACTLY the same the arc will be treated as a full circle => span = 2pi
Start | returns the start of the arc
StartAngle | Returns start angle in D2Angle
StartDegrees | Overloaded. set start angle
StartRadians | Overloaded. Set the start angle. Angles are normalized to be in the range 0 to 2Pi The arc will be treated as a FULL CIRCLE if the START and END ANGLES are EXACTLY the SAME.
StartTangent | Returns the vector of the start tangent
TangentDegrees | returns the direction of the tangent to the arc at the point lying at the supplied angle on the arc circle. The vector returned follow the "sense" of the arc.
TangentRadians | returns the direction of the tangent to the arc at the point lying at the supplied angle on the arc circle. The vector returned follow the "sense" of the arc.
ToString | Returns a string describing the contents of the D2Arc
WithinSpan | return true if the point is within the span of the arc
WithinSpanDegrees | Return true if angle is within span of the arc
WithinSpanRadians | return TRUE if angle is within the span of the arc

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


Anticlockwise Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.Anticlockwise Method

Return true if sense is clockwise

Overload List

Return true if sense is clockwise

public abstract bool Anticlockwise();

set the direction the arc takes from start to end ( input "true" implies anticlockwise)

public abstract void Anticlockwise(bool);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.Anticlockwise Method ()

Return true if sense is clockwise

public abstract bool Anticlockwise();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Anticlockwise Overload List


D2Arc.Anticlockwise Method (Boolean)

set the direction the arc takes from start to end ( input "true" implies anticlockwise)

public abstract void Anticlockwise(
bool anti
);

Parameters

anti
True for anticlockwise

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Anticlockwise Overload List


D2Arc.Bulge Method

returns the bulge factor of the arc. +ve for anticlockwise arc and -ve for clockwise arc (returns DBL_MAX for a full circle.)

public abstract double Bulge();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


Centre Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.Centre Method

returns the centre of the arc circle

Overload List

returns the centre of the arc circle

public abstract D2Point Centre();

set the centre of arc to given point

public abstract void Centre(D2Point);

set centre of arc to given x, y values

public abstract void Centre(double,double);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.Centre Method ()

returns the centre of the arc circle

public abstract D2Point Centre();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Centre Overload List


D2Arc.Centre Method (D2Point)

set the centre of arc to given point

public abstract void Centre(
D2Point p
);

Parameters

p

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Centre Overload List


D2Arc.Centre Method (Double, Double)

set centre of arc to given x, y values

public abstract void Centre(
double x,
double y
);

Parameters

x
y

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Centre Overload List


Clockwise Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.Clockwise Method

Return true if sense of arc is anticlockwise

Overload List

Return true if sense of arc is anticlockwise

public abstract bool Clockwise();

set the direction the arc takes from start to end ( input "true" implies clockwise)

public abstract void Clockwise(bool);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.Clockwise Method ()

Return true if sense of arc is anticlockwise

public abstract bool Clockwise();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Clockwise Overload List


D2Arc.Clockwise Method (Boolean)

set the direction the arc takes from start to end ( input "true" implies clockwise)

public abstract void Clockwise(
bool clock
);

Parameters

clock
True for clockwise

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Clockwise Overload List


D2Arc.Clone Method

public abstract D2Arc Clone();

Return Value

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.Create Method

Create default arc

Overload List

Create default arc

public static D2Arc Create();

Create copy of arc

public static D2Arc Create(D2Arc);

construct an arc with start, mid and end point.

public static D2Arc Create(D2Point,D2Point,D2Point);

construct from two points and a bulge factor. The "sense" of the arc is carried by the sign of the bulge factor. +ve bulge => anticlockwise.

public static D2Arc Create(D2Point,D2Point,double);

Construct an arc from D2Angles

public static D2Arc Create(D2Point,double,D2Angle,D2Angle,bool);

Construct an arc from centre, radius, start and end points. Default is anticlockwise

public static D2Arc Create(D2Point,double,D2Point,D2Point);

Construct an arc from centre, radius, start and end points. Uses angles of points wrt centre to construct start and end angles. if start (end) point == centre point then start (end) angle will be set to 0 The arc will be treated as a FULL CIRCLE if the START and END angles are EXACTLY the same.

public static D2Arc Create(D2Point,double,D2Point,D2Point,bool);

Construct an arc from centre point,radius, start and end angles. Default is anticlockwise

public static D2Arc Create(D2Point,double,double,double);

Construct an arc from centre point,radius, start and end angles. By default, the arc will be made in the anticlockwise direction The arc will be treated as a FULL CIRCLE if the START and END angles are exactly the same.

public static D2Arc Create(D2Point,double,double,double,bool);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.Create Method ()

Create default arc

public static D2Arc Create();

Return Value

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Create Overload List


D2Arc.Create Method (D2Arc)

Create copy of arc

public static D2Arc Create(
D2Arc arc
);

Parameters

arc

Return Value

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Create Overload List


D2Arc.Create Method (D2Point, D2Point, D2Point)

construct an arc with start, mid and end point.

public static D2Arc Create(
D2Point start,
D2Point mid,
D2Point end
);

Parameters

start
mid
end

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Create Overload List


D2Arc.Create Method (D2Point, D2Point, Double)

construct from two points and a bulge factor. The "sense" of the arc is carried by the sign of the bulge factor. +ve bulge => anticlockwise.

public static D2Arc Create(
D2Point start,
D2Point end,
double bulge
);

Parameters

start
end
bulge

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Create Overload List


D2Arc.Create Method (D2Point, Double, D2Angle, D2Angle, Boolean)

Construct an arc from D2Angles

public static D2Arc Create(
D2Point centre,
double radius,
D2Angle startAngle,
D2Angle endAngle,
bool anticlock
);

Parameters

centre
radius
startAngle
endAngle
anticlock

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Create Overload List


D2Arc.Create Method (D2Point, Double, D2Point, D2Point)

Construct an arc from centre, radius, start and end points. Default is anticlockwise

public static D2Arc Create(
D2Point centre,
double radius,
D2Point start,
D2Point end
);

Parameters

centre
radius
start
end

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Create Overload List


D2Arc.Create Method (D2Point, Double, D2Point, D2Point, Boolean)

Construct an arc from centre, radius, start and end points. Uses angles of points wrt centre to construct start and end angles. if start (end) point == centre point then start (end) angle will be set to 0 The arc will be treated as a FULL CIRCLE if the START and END angles are EXACTLY the same.

public static D2Arc Create(
D2Point centre,
double radius,
D2Point start,
D2Point end,
bool anticlock
);

Parameters

centre
radius
start
end
anticlock

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Create Overload List


D2Arc.Create Method (D2Point, Double, Double, Double)

Construct an arc from centre point,radius, start and end angles. Default is anticlockwise

public static D2Arc Create(
D2Point centre,
double radius,
double startRadians,
double endRadians
);

Parameters

centre
radius
startRadians
endRadians

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Create Overload List


D2Arc.Create Method (D2Point, Double, Double, Double, Boolean)

Construct an arc from centre point,radius, start and end angles. By default, the arc will be made in the anticlockwise direction The arc will be treated as a FULL CIRCLE if the START and END angles are exactly the same.

public static D2Arc Create(
D2Point centre,
double radius,
double startRadians,
double endRadians,
bool anticlock
);

Parameters

centre
radius
startRadians
endRadians
anticlock

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Create Overload List


Degrees Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.Degrees Method

angle of pt wrt centre of arc measured anticlockwise from the x direction

Overload List

angle of pt wrt centre of arc measured anticlockwise from the x direction

public abstract double Degrees(D2Point);

Returns a point on the circumference of the arc circle, at the specified angle

public abstract D2Point Degrees(double);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.Degrees Method (D2Point)

angle of pt wrt centre of arc measured anticlockwise from the x direction

public abstract double Degrees(
D2Point p
);

Parameters

p
Reference point

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Degrees Overload List


D2Arc.Degrees Method (Double)

Returns a point on the circumference of the arc circle, at the specified angle

public abstract D2Point Degrees(
double degs
);

Parameters

degs

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Degrees Overload List


D2Arc.End Method

returns the end of the arc

public abstract D2Point End();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.EndAngle Method

Returns end angle in D2Angle

public abstract D2Angle EndAngle();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


EndDegrees Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.EndDegrees Method

Returns end angle in degrees

Overload List

Returns end angle in degrees

public abstract double EndDegrees();

set end angle

public abstract void EndDegrees(double);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.EndDegrees Method ()

Returns end angle in degrees

public abstract double EndDegrees();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.EndDegrees Overload List


D2Arc.EndDegrees Method (Double)

set end angle

public abstract void EndDegrees(
double degs
);

Parameters

degs
angle in degrees

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.EndDegrees Overload List


EndRadians Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.EndRadians Method

Returns end angle in radians

Overload List

Returns end angle in radians

public abstract double EndRadians();

set end angle

public abstract void EndRadians(double);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.EndRadians Method ()

Returns end angle in radians

public abstract double EndRadians();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.EndRadians Overload List


D2Arc.EndRadians Method (Double)

set end angle

public abstract void EndRadians(
double rads
);

Parameters

rads
angle in radians

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.EndRadians Overload List


D2Arc.EndTangent Method

Returns the vector of the end tangent

public abstract D2Vector EndTangent();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.Equals Method

Returns true if arcs are equal

Overload List

Returns true if arcs are equal

public abstract bool Equals(D2Arc);

returns TRUE if start points, end points, and centre points all match to within distance "tol". The "senses" of the arcs must also be the same.

public abstract bool Equals(D2Arc,double);

override system default equals method

public override bool Equals(object);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.Equals Method (D2Arc)

Returns true if arcs are equal

public abstract bool Equals(
D2Arc a
);

Parameters

a

Return Value

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Equals Overload List


D2Arc.Equals Method (D2Arc, Double)

returns TRUE if start points, end points, and centre points all match to within distance "tol". The "senses" of the arcs must also be the same.

public abstract bool Equals(
D2Arc a,
double tol
);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Equals Overload List


D2Arc.Equals Method (Object)

override system default equals method

public override bool Equals(
object a
);

Parameters

a

Return Value

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Equals Overload List


D2Arc.From3Points Method

Reconstruct the arc to pass from the start point to the end point and go THROUGH the thru Point. Returns TRUE if succesful. The three Points must NOT be collinear otherwise the function will return FALSE and the arc will remain unchanged.

public abstract bool From3Points(
D2Point start,
D2Point thru,
D2Point end
);

Parameters

start
thru
end

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.GetHashCode Method

override system default gethashcode method

public override int GetHashCode();

Return Value

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.Height Method

returns chord height

public abstract double Height();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


Intersects Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.Intersects Method

Returns TRUE if the two arc circles intersect. If they intersect p1 and p2 will be set to the intersection points- otherwisae p1 and p2 will remain unchanged. N.B. Use the "onArc" function to discover if these intersection points lie on your length of arc.

Overload List

Returns TRUE if the two arc circles intersect. If they intersect p1 and p2 will be set to the intersection points- otherwisae p1 and p2 will remain unchanged. N.B. Use the "onArc" function to discover if these intersection points lie on your length of arc.

public abstract bool Intersects(D2Arc,D2Point,D2Point);

Returns true if the finite line and the arc intersect

public abstract bool Intersects(D2FiniteLine,D2Point,D2Point);

Returns TRUE if the INFINITELY EXTENDED line and the arc circle intersect. If they intersect p1 and p2 will be set to the intersection points- otherwisae p1 and p2 will remain unchanged. N.B. Use the "onArc" and "onLine" functions to discover if these intersection point lie on your length of arc, or your bounded line.

public abstract bool Intersects(D2Line,D2Point,D2Point);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.Intersects Method (D2Arc, D2Point, D2Point)

Returns TRUE if the two arc circles intersect. If they intersect p1 and p2 will be set to the intersection points- otherwisae p1 and p2 will remain unchanged. N.B. Use the "onArc" function to discover if these intersection points lie on your length of arc.

public abstract bool Intersects(
D2Arc arc,
D2Point p1,
D2Point p2
);

Parameters

arc
p1
First intersection point
p2
Second intersection point

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Intersects Overload List


D2Arc.Intersects Method (D2FiniteLine, D2Point, D2Point)

Returns true if the finite line and the arc intersect

public abstract bool Intersects(
D2FiniteLine line,
D2Point p1,
D2Point p2
);

Parameters

line
p1
p2

Return Value

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Intersects Overload List


D2Arc.Intersects Method (D2Line, D2Point, D2Point)

Returns TRUE if the INFINITELY EXTENDED line and the arc circle intersect. If they intersect p1 and p2 will be set to the intersection points- otherwisae p1 and p2 will remain unchanged. N.B. Use the "onArc" and "onLine" functions to discover if these intersection point lie on your length of arc, or your bounded line.

public abstract bool Intersects(
D2Line line,
D2Point p1,
D2Point p2
);

Parameters

line
p1
First intersection point
p2
Second intersection point

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Intersects Overload List


D2Arc.IsCircle Method

True if the arc is a circle i.e. EXACT EQUALITY of start and END ANGLES

public abstract bool IsCircle();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


IsConcentric Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.IsConcentric Method

True if two arcs have saem centre

Overload List

True if two arcs have saem centre

public abstract bool IsConcentric(D2Arc);

True if the two arcs have the same centre, within tolerance

public abstract bool IsConcentric(D2Arc,double);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.IsConcentric Method (D2Arc)

True if two arcs have saem centre

public abstract bool IsConcentric(
D2Arc arc
);

Parameters

arc

Return Value

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.IsConcentric Overload List


D2Arc.IsConcentric Method (D2Arc, Double)

True if the two arcs have the same centre, within tolerance

public abstract bool IsConcentric(
D2Arc arc,
double tol
);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.IsConcentric Overload List


D2Arc.LeftTangentPoint Method

return via argument the point on the arc circle that lies on a line that is tangential to the arc circle and passes through point p. LeftTangentPoint lies to the LEFT of the line from p to circle centre. TRUE if p lies more than 1.E-6 outside the circle. FALSE if p lies within the circle or less than 1.E-6 outside.

public abstract bool LeftTangentPoint(
D2Point p,
D2Point tanPoint
);

Parameters

p
Reference point
tanPoint
Returned Point on Tangent

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.Length Method

Returns the length of the arc

public abstract double Length();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


MoveBy Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.MoveBy Method

move the arc by the offset specified by given vector

Overload List

move the arc by the offset specified by given vector

public abstract void MoveBy(D2Vector);

Move arc by x and y values

public abstract void MoveBy(double,double);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.MoveBy Method (D2Vector)

move the arc by the offset specified by given vector

public abstract void MoveBy(
D2Vector vec
);

Parameters

vec

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.MoveBy Overload List


D2Arc.MoveBy Method (Double, Double)

Move arc by x and y values

public abstract void MoveBy(
double x,
double y
);

Parameters

x
y

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.MoveBy Overload List


D2Arc.NearestPoint Method

returns the nearest point to "p" on the length of arc.

public abstract D2Point NearestPoint(
D2Point p
);

Parameters

p

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.NearestPointToOrigin Method

returns the nearest point to origin on the length of arc.

public abstract D2Point NearestPointToOrigin();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


OnArc Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.OnArc Method

Returns true if point is on arc

Overload List

Returns true if point is on arc

public abstract bool OnArc(D2Point);

returns true if point lies within tolerance distance of the arc

public abstract bool OnArc(D2Point,double);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.OnArc Method (D2Point)

Returns true if point is on arc

public abstract bool OnArc(
D2Point p
);

Parameters

p

Return Value

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.OnArc Overload List


D2Arc.OnArc Method (D2Point, Double)

returns true if point lies within tolerance distance of the arc

public abstract bool OnArc(
D2Point p,
double tol
);

Parameters

p
Reference point
tol
Tolerance

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.OnArc Overload List


Radians Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.Radians Method

angle of pt wrt centre of arc measured anticlockwise from the x direction

Overload List

angle of pt wrt centre of arc measured anticlockwise from the x direction

public abstract double Radians(D2Point);

Returns a point on the circumference of the arc circle, at the specified angle

public abstract D2Point Radians(double);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.Radians Method (D2Point)

angle of pt wrt centre of arc measured anticlockwise from the x direction

public abstract double Radians(
D2Point p
);

Parameters

p
Reference point

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Radians Overload List


D2Arc.Radians Method (Double)

Returns a point on the circumference of the arc circle, at the specified angle

public abstract D2Point Radians(
double rads
);

Parameters

rads

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.Radians Overload List


D2Arc.RightTangentPoint Method

return via argument the point on the arc circle that lies on a line that is tangential to the arc circle and passes through point p. RightTangentPoint lies to the RIGHT of the line from p to circle centre. TRUE if p lies more than 1.E-6 outside the circle. FALSE if p lies within the circle or less than 1.E-6 outside.

public abstract bool RightTangentPoint(
D2Point p,
D2Point tanPoint
);

Parameters

p
tanPoint

Return Value

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


RotateByDegrees Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.RotateByDegrees Method

Rotate arc around origin by given angle

Overload List

Rotate arc around origin by given angle

public abstract void RotateByDegrees(double);

Rotate arc by given angle around given pivot point

public abstract void RotateByDegrees(double,D2Point);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.RotateByDegrees Method (Double)

Rotate arc around origin by given angle

public abstract void RotateByDegrees(
double degrees
);

Parameters

degrees
angle in degrees

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.RotateByDegrees Overload List


D2Arc.RotateByDegrees Method (Double, D2Point)

Rotate arc by given angle around given pivot point

public abstract void RotateByDegrees(
double degrees,
D2Point pivot
);

Parameters

degrees
angle in degrees
pivot

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.RotateByDegrees Overload List


RotateByRadians Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.RotateByRadians Method

Rotate arc by given angle around origin

Overload List

Rotate arc by given angle around origin

public abstract void RotateByRadians(double);

Rotate arc by given angle around given pivot point

public abstract void RotateByRadians(double,D2Point);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.RotateByRadians Method (Double)

Rotate arc by given angle around origin

public abstract void RotateByRadians(
double radians
);

Parameters

radians
angle in radians

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.RotateByRadians Overload List


D2Arc.RotateByRadians Method (Double, D2Point)

Rotate arc by given angle around given pivot point

public abstract void RotateByRadians(
double radians,
D2Point pivot
);

Parameters

radians
angle in radians
pivot

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.RotateByRadians Overload List


D2Arc.SpanAngle Method

Return D2Angle of span

public abstract D2Angle SpanAngle();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.SpanDegrees Method

Return span in degrees -ve for a clockwise arc, +ve otherwise If start and end angles are EXACTLY the same the arc will be treated as a full circle => span = 360

public abstract double SpanDegrees();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.SpanRadians Method

Return span in radians -ve for a clockwise arc, +ve otherwise If start and end angles are EXACTLY the same the arc will be treated as a full circle => span = 2pi

public abstract double SpanRadians();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.Start Method

returns the start of the arc

public abstract D2Point Start();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.StartAngle Method

Returns start angle in D2Angle

public abstract D2Angle StartAngle();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


StartDegrees Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.StartDegrees Method

Returns start angle in degrees

Overload List

Returns start angle in degrees

public abstract double StartDegrees();

set start angle

public abstract void StartDegrees(double);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.StartDegrees Method ()

Returns start angle in degrees

public abstract double StartDegrees();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.StartDegrees Overload List


D2Arc.StartDegrees Method (Double)

set start angle

public abstract void StartDegrees(
double degs
);

Parameters

degs
angle in degrees

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.StartDegrees Overload List


StartRadians Method

AVEVA Maths / Geometry .NET Public Interface

D2Arc.StartRadians Method

Returns start angle in radians

Overload List

Returns start angle in radians

public abstract double StartRadians();

Set the start angle. Angles are normalized to be in the range 0 to 2Pi The arc will be treated as a FULL CIRCLE if the START and END ANGLES are EXACTLY the SAME.

public abstract void StartRadians(double);

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.StartRadians Method ()

Returns start angle in radians

public abstract double StartRadians();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.StartRadians Overload List


D2Arc.StartRadians Method (Double)

Set the start angle. Angles are normalized to be in the range 0 to 2Pi The arc will be treated as a FULL CIRCLE if the START and END ANGLES are EXACTLY the SAME.

public abstract void StartRadians(
double rads
);

Parameters

rads

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D2Arc.StartRadians Overload List


D2Arc.StartTangent Method

Returns the vector of the start tangent

public abstract D2Vector StartTangent();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.TangentDegrees Method

returns the direction of the tangent to the arc at the point lying at the supplied angle on the arc circle. The vector returned follow the "sense" of the arc.

public abstract D2Vector TangentDegrees(
double degs
);

Parameters

degs
angle in degrees

Return Value

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.TangentRadians Method

returns the direction of the tangent to the arc at the point lying at the supplied angle on the arc circle. The vector returned follow the "sense" of the arc.

public abstract D2Vector TangentRadians(
double rads
);

Parameters

rads
Angle in radians

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.ToString Method

Returns a string describing the contents of the D2Arc

public abstract string ToString();

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.WithinSpan Method

return true if the point is within the span of the arc

public abstract bool WithinSpan(
D2Point p
);

Parameters

p

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.WithinSpanDegrees Method

Return true if angle is within span of the arc

public abstract bool WithinSpanDegrees(
double degs
);

Parameters

degs
angle in degrees

Return Value

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc.WithinSpanRadians Method

return TRUE if angle is within the span of the arc

public abstract bool WithinSpanRadians(
double rads
);

Parameters

rads

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc Operators

The operators of the D2Arc class are listed below. For a complete list of D2Arc class members, see the D2Arc Members topic.

Public Static Operators

Equality Operator | equality operator
Inequality Operator | inequality operator

See Also

D2Arc Class | D2Arc Members | Aveva.Pdms.Maths.Geometry Namespace


D2Arc Equality Operator

equality operator

public static bool operator ==(
D2Arc left,
D2Arc right
);

Parameters

left
right

Return Value

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Arc Inequality Operator

inequality operator

public static bool operator !=(
D2Arc left,
D2Arc right
);

Parameters

left
right

Return Value

See Also

D2Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle Class

A 2-D Circle N.B. all ANGLES measured ANTI-CLOCKWISE from X-AXIS

For a list of all members of this type, see D2Circle Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2Circle

public abstract class D2Circle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2Circle Members | Aveva.Pdms.Maths.Geometry Namespace


D2Circle Members

D2Circle overview

Public Static Methods

Create Overloaded. Default circle - centre [0,0] radius = 1.

Public Static Operators

Equality Operator | true if centre and radius values of both circles match EXACTLY
Inequality Operator | true if centre or radius values of both circles do not match EXACTLY

Public Instance Properties

Area | Property - area (read only)
Circumference | Circumference - read only
Diameter | Property - diameter
Radius | Property - radius

Public Instance Methods

box | return limits box that just encloses the circle
Centre | Overloaded. set the centre point
Clone | deep copy
Degrees | Overloaded. return point on circumference at angle given in degrees
DistanceFromCentre | return distance of point p from centre of circle
DistanceFromEdge | return distance of point p from perimeter of circle returns -ve if point is inside circle, +ve otherwise.
Encloses | Overloaded. true if given circle c lies inside object circle
Equals | Overloaded. test for equality
From3Points | reset the circle centre and radius to pass through the three given points. returns TRUE if successful returns FALSE if unsuccessful i.e. 2 points too close together or all points on same line Circle will remain unchanged if FALSE is returned.
GetHashCode | override gethashcode
GetType (inherited from Object) | Gets the Type of the current instance.
Intersects | Overloaded. Returns intersection points if result is true TRUE if circle circ intersects the circle. FALSE if point of closest approach of line to the centre point is > radius. No tolerance used.
LeftTangentPoint | return via argument the point on the circle that lies on a line that is tangential to the circle and passes through point p. LeftTangentPoint lies to the LEFT of the line from p to circle centre. TRUE if p lies more than 1.E-6 outside the circle. FALSE if p lies within the circle or less than 1.E-6 outside.
MirrorX | Overloaded. Reflect in X about pivot
MirrorY | Overloaded. Reflect in Y about pivot
MoveBy | Move the centre point
OnCircle | Overloaded. Return true if point lies on circumference
pointNearCentre | Overloaded. Returns the point on the finiteline that lies closest to the centre of the circle.
Radians | Overloaded. return point on circumference at angle given in rads
RightTangentPoint | return via argument the point on the circle that lies on a line that is tangential to the circle and passes through point p. RightTangentPoint lies to the RIGHT of the line from p to circle centre. TRUE if p lies more than 1.E-6 outside the circle. FALSE if p lies within the circle or less than 1.E-6 outside.
RotateByDegrees | Overloaded. Rotate the circle about a pivot point
RotateByRadians | Overloaded. Rotate the circle about the pivot point
ScaleBy | Overloaded. scale circle about pivot
ToString | Returns a string describing the contents of the D2Circle

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle Properties

The properties of the D2Circle class are listed below. For a complete list of D2Circle class members, see the D2Circle Members topic.

Public Instance Properties

Area | Property - area (read only)
Circumference | Circumference - read only
Diameter | Property - diameter
Radius | Property - radius

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


Area Property

AVEVA Maths / Geometry .NET Public Interface

D2Circle.Area Property

Property - area (read only)

public abstract double Area {get;}

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


Circumference Property

AVEVA Maths / Geometry .NET Public Interface

D2Circle.Circumference Property

Circumference - read only

public abstract double Circumference {get;}

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


Diameter Property

AVEVA Maths / Geometry .NET Public Interface

D2Circle.Diameter Property

Property - diameter

public abstract double Diameter {get; set;}

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


Radius Property

AVEVA Maths / Geometry .NET Public Interface

D2Circle.Radius Property

Property - radius

public abstract double Radius {get; set;}

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle Methods

The methods of the D2Circle class are listed below. For a complete list of D2Circle class members, see the D2Circle Members topic.

Public Static Methods

Create Overloaded. Default circle - centre [0,0] radius = 1.

Public Instance Methods

box | return limits box that just encloses the circle
Centre | Overloaded. set the centre point
Clone | deep copy
Degrees | Overloaded. return point on circumference at angle given in degrees
DistanceFromCentre | return distance of point p from centre of circle
DistanceFromEdge | return distance of point p from perimeter of circle returns -ve if point is inside circle, +ve otherwise.
Encloses | Overloaded. true if given circle c lies inside object circle
Equals | Overloaded. test for equality
From3Points | reset the circle centre and radius to pass through the three given points. returns TRUE if successful returns FALSE if unsuccessful i.e. 2 points too close together or all points on same line Circle will remain unchanged if FALSE is returned.
GetHashCode | override gethashcode
GetType (inherited from Object) | Gets the Type of the current instance.
Intersects | Overloaded. Returns intersection points if result is true TRUE if circle circ intersects the circle. FALSE if point of closest approach of line to the centre point is > radius. No tolerance used.
LeftTangentPoint | return via argument the point on the circle that lies on a line that is tangential to the circle and passes through point p. LeftTangentPoint lies to the LEFT of the line from p to circle centre. TRUE if p lies more than 1.E-6 outside the circle. FALSE if p lies within the circle or less than 1.E-6 outside.
MirrorX | Overloaded. Reflect in X about pivot
MirrorY | Overloaded. Reflect in Y about pivot
MoveBy | Move the centre point
OnCircle | Overloaded. Return true if point lies on circumference
pointNearCentre | Overloaded. Returns the point on the finiteline that lies closest to the centre of the circle.
Radians | Overloaded. return point on circumference at angle given in rads
RightTangentPoint | return via argument the point on the circle that lies on a line that is tangential to the circle and passes through point p. RightTangentPoint lies to the RIGHT of the line from p to circle centre. TRUE if p lies more than 1.E-6 outside the circle. FALSE if p lies within the circle or less than 1.E-6 outside.
RotateByDegrees | Overloaded. Rotate the circle about a pivot point
RotateByRadians | Overloaded. Rotate the circle about the pivot point
ScaleBy | Overloaded. scale circle about pivot
ToString | Returns a string describing the contents of the D2Circle

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.box Method

return limits box that just encloses the circle

public abstract D2Limits box();

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


Centre Method

AVEVA Maths / Geometry .NET Public Interface

D2Circle.Centre Method

Return centre point

Overload List

Return centre point

public abstract D2Point Centre();

set the centre point

public abstract void Centre(D2Point);

set the centre point

public abstract void Centre(double,double);

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.Centre Method ()

Return centre point

public abstract D2Point Centre();

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Centre Overload List


D2Circle.Centre Method (D2Point)

set the centre point

public abstract void Centre(
D2Point p
);

Parameters

p

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Centre Overload List


D2Circle.Centre Method (Double, Double)

set the centre point

public abstract void Centre(
double x,
double y
);

Parameters

x
y

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Centre Overload List


D2Circle.Clone Method

deep copy

public abstract D2Circle Clone();

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2Circle.Create Method

Default circle - centre [0,0] radius = 1.

Overload List

Default circle - centre [0,0] radius = 1.

public static D2Circle Create();

Copy constructor

public static D2Circle Create(D2Circle);

construct from centre point and a point on the circumference

public static D2Circle Create(D2Point,D2Point);

Construct from two points on circumference and a bulge factor N.B. IF bulgeFactor is ZERO a value of 1 will be used instead SO CHECK YOUR BULGE FACTOR BEFOREHAND!!

public static D2Circle Create(D2Point,D2Point,double);

Create circle from centre and radius N.B. negative radii will be made positive

public static D2Circle Create(D2Point,double);

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.Create Method ()

Default circle - centre [0,0] radius = 1.

public static D2Circle Create();

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Create Overload List


D2Circle.Create Method (D2Circle)

Copy constructor

public static D2Circle Create(
D2Circle circ
);

Parameters

circ

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Create Overload List


D2Circle.Create Method (D2Point, D2Point)

construct from centre point and a point on the circumference

public static D2Circle Create(
D2Point centre,
D2Point p
);

Parameters

centre
p

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Create Overload List


D2Circle.Create Method (D2Point, D2Point, Double)

Construct from two points on circumference and a bulge factor N.B. IF bulgeFactor is ZERO a value of 1 will be used instead SO CHECK YOUR BULGE FACTOR BEFOREHAND!!

public static D2Circle Create(
D2Point p,
D2Point q,
double bulgeFactor
);

Parameters

p
q
bulgeFactor

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Create Overload List


D2Circle.Create Method (D2Point, Double)

Create circle from centre and radius N.B. negative radii will be made positive

public static D2Circle Create(
D2Point centre,
double radius
);

Parameters

centre
radius

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Create Overload List


Degrees Method

AVEVA Maths / Geometry .NET Public Interface

D2Circle.Degrees Method

return angle (in degs) of point p wrt centre of circle

Overload List

return angle (in degs) of point p wrt centre of circle

public abstract double Degrees(D2Point);

return point on circumference at angle given in degrees

public abstract D2Point Degrees(double);

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.Degrees Method (D2Point)

return angle (in degs) of point p wrt centre of circle

public abstract double Degrees(
D2Point p
);

Parameters

p

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Degrees Overload List


D2Circle.Degrees Method (Double)

return point on circumference at angle given in degrees

public abstract D2Point Degrees(
double degs
);

Parameters

degs

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Degrees Overload List


D2Circle.DistanceFromCentre Method

return distance of point p from centre of circle

public abstract double DistanceFromCentre(
D2Point p
);

Parameters

p

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.DistanceFromEdge Method

return distance of point p from perimeter of circle returns -ve if point is inside circle, +ve otherwise.

public abstract double DistanceFromEdge(
D2Point p
);

Parameters

p

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


Encloses Method

AVEVA Maths / Geometry .NET Public Interface

D2Circle.Encloses Method

true if given circle c lies inside object circle

Overload List

true if given circle c lies inside object circle

public abstract bool Encloses(D2Circle);

true if point lies ON or IN circle

public abstract bool Encloses(D2Point);

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.Encloses Method (D2Circle)

true if given circle c lies inside object circle

public abstract bool Encloses(
D2Circle c
);

Parameters

c

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Encloses Overload List


D2Circle.Encloses Method (D2Point)

true if point lies ON or IN circle

public abstract bool Encloses(
D2Point p
);

Parameters

p
Reference point

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Encloses Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2Circle.Equals Method

test for equality

Overload List

test for equality

public abstract bool Equals(D2Circle);

override equals

public override bool Equals(object);

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.Equals Method (D2Circle)

test for equality

public abstract bool Equals(
D2Circle c
);

Parameters

c

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Equals Overload List


D2Circle.Equals Method (Object)

override equals

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Equals Overload List


D2Circle.From3Points Method

reset the circle centre and radius to pass through the three given points. returns TRUE if successful returns FALSE if unsuccessful i.e. 2 points too close together or all points on same line Circle will remain unchanged if FALSE is returned.

public abstract bool From3Points(
D2Point p1,
D2Point p2,
D2Point p3
);

Parameters

p1
p2
p3

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.GetHashCode Method

override gethashcode

public override int GetHashCode();

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


Intersects Method

AVEVA Maths / Geometry .NET Public Interface

D2Circle.Intersects Method

Returns intersection points if result is true TRUE if circle circ intersects the circle. FALSE if point of closest approach of line to the centre point is > radius. No tolerance used.

Overload List

Returns intersection points if result is true TRUE if circle circ intersects the circle. FALSE if point of closest approach of line to the centre point is > radius. No tolerance used.

public abstract bool Intersects(D2Circle,D2Point,D2Point);

Returns intersection points if result is true TRUE if finiteline intersects the circle. FALSE if point of closest approach of line to the centre point is > radius. No tolerance used.

public abstract bool Intersects(D2FiniteLine,D2Point,D2Point);

Returns intersection points if result is true Input line is treated as INFINITELY EXTENDED Use "onLine" methods of line classes to determine if intersection points lie on the finite/seminfinite lines to within your desired tolerance. TRUE if line/circle intersects the circle. FALSE if point of closest approach of line to the centre point is > radius. No tolerance used.

public abstract bool Intersects(D2Line,D2Point,D2Point);

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.Intersects Method (D2Circle, D2Point, D2Point)

Returns intersection points if result is true TRUE if circle circ intersects the circle. FALSE if point of closest approach of line to the centre point is > radius. No tolerance used.

public abstract bool Intersects(
D2Circle circ,
D2Point p1,
D2Point p2
);

Parameters

circ
p1
p2

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Intersects Overload List


D2Circle.Intersects Method (D2FiniteLine, D2Point, D2Point)

Returns intersection points if result is true TRUE if finiteline intersects the circle. FALSE if point of closest approach of line to the centre point is > radius. No tolerance used.

public abstract bool Intersects(
D2FiniteLine FiniteLine,
D2Point p1,
D2Point p2
);

Parameters

FiniteLine
p1
p2

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Intersects Overload List


D2Circle.Intersects Method (D2Line, D2Point, D2Point)

Returns intersection points if result is true Input line is treated as INFINITELY EXTENDED Use "onLine" methods of line classes to determine if intersection points lie on the finite/seminfinite lines to within your desired tolerance. TRUE if line/circle intersects the circle. FALSE if point of closest approach of line to the centre point is > radius. No tolerance used.

public abstract bool Intersects(
D2Line line,
D2Point p1,
D2Point p2
);

Parameters

line
p1
p2

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Intersects Overload List


D2Circle.LeftTangentPoint Method

return via argument the point on the circle that lies on a line that is tangential to the circle and passes through point p. LeftTangentPoint lies to the LEFT of the line from p to circle centre. TRUE if p lies more than 1.E-6 outside the circle. FALSE if p lies within the circle or less than 1.E-6 outside.

public abstract bool LeftTangentPoint(
D2Point p,
D2Point tanPoint
);

Parameters

p
tanPoint

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


MirrorX Method

AVEVA Maths / Geometry .NET Public Interface

D2Circle.MirrorX Method

Reflect in X about origin

Overload List

Reflect in X about origin

public abstract void MirrorX();

Reflect in X about pivot

public abstract void MirrorX(D2Point);

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.MirrorX Method ()

Reflect in X about origin

public abstract void MirrorX();

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.MirrorX Overload List


D2Circle.MirrorX Method (D2Point)

Reflect in X about pivot

public abstract void MirrorX(
D2Point pivot
);

Parameters

pivot

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.MirrorX Overload List


MirrorY Method

AVEVA Maths / Geometry .NET Public Interface

D2Circle.MirrorY Method

Reflect in Y about origin

Overload List

Reflect in Y about origin

public abstract void MirrorY();

Reflect in Y about pivot

public abstract void MirrorY(D2Point);

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.MirrorY Method ()

Reflect in Y about origin

public abstract void MirrorY();

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.MirrorY Overload List


D2Circle.MirrorY Method (D2Point)

Reflect in Y about pivot

public abstract void MirrorY(
D2Point pivot
);

Parameters

pivot

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.MirrorY Overload List


D2Circle.MoveBy Method

Move the centre point

public abstract void MoveBy(
D2Vector v
);

Parameters

v

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


OnCircle Method

AVEVA Maths / Geometry .NET Public Interface

D2Circle.OnCircle Method

Return true if point lies on circumference

Overload List

Return true if point lies on circumference

public abstract bool OnCircle(D2Point);

Return true if point lies on circumference (within tolerance)

public abstract bool OnCircle(D2Point,double);

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.OnCircle Method (D2Point)

Return true if point lies on circumference

public abstract bool OnCircle(
D2Point p
);

Parameters

p
Reference point

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.OnCircle Overload List


D2Circle.OnCircle Method (D2Point, Double)

Return true if point lies on circumference (within tolerance)

public abstract bool OnCircle(
D2Point p,
double tol
);

Parameters

p
Reference point
tol

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.OnCircle Overload List


pointNearCentre Method

AVEVA Maths / Geometry .NET Public Interface

D2Circle.pointNearCentre Method

Returns the point on the finiteline that lies closest to the centre of the circle.

Overload List

Returns the point on the finiteline that lies closest to the centre of the circle.

public abstract D2Point pointNearCentre(D2FiniteLine);

Input line is treated as INFINITELY EXTENDED Returns the point on the infinitely extended line that lies closest to the centre of the circle. Use the onLine functions of the line classes to determine if the returned point lies on your line to within your desired tolerance

public abstract D2Point pointNearCentre(D2Line);

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.pointNearCentre Method (D2FiniteLine)

Returns the point on the finiteline that lies closest to the centre of the circle.

public abstract D2Point pointNearCentre(
D2FiniteLine FiniteLine
);

Parameters

FiniteLine

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.pointNearCentre Overload List


D2Circle.pointNearCentre Method (D2Line)

Input line is treated as INFINITELY EXTENDED Returns the point on the infinitely extended line that lies closest to the centre of the circle. Use the onLine functions of the line classes to determine if the returned point lies on your line to within your desired tolerance

public abstract D2Point pointNearCentre(
D2Line line
);

Parameters

line

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.pointNearCentre Overload List


Radians Method

AVEVA Maths / Geometry .NET Public Interface

D2Circle.Radians Method

return angle (in rads) of point p wrt centre of circle

Overload List

return angle (in rads) of point p wrt centre of circle

public abstract double Radians(D2Point);

return point on circumference at angle given in rads

public abstract D2Point Radians(double);

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.Radians Method (D2Point)

return angle (in rads) of point p wrt centre of circle

public abstract double Radians(
D2Point p
);

Parameters

p

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Radians Overload List


D2Circle.Radians Method (Double)

return point on circumference at angle given in rads

public abstract D2Point Radians(
double rads
);

Parameters

rads

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.Radians Overload List


D2Circle.RightTangentPoint Method

return via argument the point on the circle that lies on a line that is tangential to the circle and passes through point p. RightTangentPoint lies to the RIGHT of the line from p to circle centre. TRUE if p lies more than 1.E-6 outside the circle. FALSE if p lies within the circle or less than 1.E-6 outside.

public abstract bool RightTangentPoint(
D2Point p,
D2Point tanPoint
);

Parameters

p
Reference point
tanPoint
Returned point on tangent

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


RotateByDegrees Method

AVEVA Maths / Geometry .NET Public Interface

D2Circle.RotateByDegrees Method

Rotate the circle about the origin

Overload List

Rotate the circle about the origin

public abstract void RotateByDegrees(double);

Rotate the circle about a pivot point

public abstract void RotateByDegrees(double,D2Point);

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.RotateByDegrees Method (Double)

Rotate the circle about the origin

public abstract void RotateByDegrees(
double ang
);

Parameters

ang

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.RotateByDegrees Overload List


D2Circle.RotateByDegrees Method (Double, D2Point)

Rotate the circle about a pivot point

public abstract void RotateByDegrees(
double ang,
D2Point pivot
);

Parameters

ang
pivot

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.RotateByDegrees Overload List


RotateByRadians Method

AVEVA Maths / Geometry .NET Public Interface

D2Circle.RotateByRadians Method

Rotate the circle about the origin

Overload List

Rotate the circle about the origin

public abstract void RotateByRadians(double);

Rotate the circle about the pivot point

public abstract void RotateByRadians(double,D2Point);

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.RotateByRadians Method (Double)

Rotate the circle about the origin

public abstract void RotateByRadians(
double ang
);

Parameters

ang

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.RotateByRadians Overload List


D2Circle.RotateByRadians Method (Double, D2Point)

Rotate the circle about the pivot point

public abstract void RotateByRadians(
double ang,
D2Point pivot
);

Parameters

ang
pivot

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.RotateByRadians Overload List


ScaleBy Method

AVEVA Maths / Geometry .NET Public Interface

D2Circle.ScaleBy Method

scale centre point and radius

Overload List

scale centre point and radius

public abstract void ScaleBy(double);

scale circle about pivot

public abstract void ScaleBy(double,D2Point);

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle.ScaleBy Method (Double)

scale centre point and radius

public abstract void ScaleBy(
double s
);

Parameters

s

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.ScaleBy Overload List


D2Circle.ScaleBy Method (Double, D2Point)

scale circle about pivot

public abstract void ScaleBy(
double s,
D2Point pivot
);

Parameters

s
pivot

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace | D2Circle.ScaleBy Overload List


D2Circle.ToString Method

Returns a string describing the contents of the D2Circle

public abstract string ToString();

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle Operators

The operators of the D2Circle class are listed below. For a complete list of D2Circle class members, see the D2Circle Members topic.

Public Static Operators

Equality Operator | true if centre and radius values of both circles match EXACTLY
Inequality Operator | true if centre or radius values of both circles do not match EXACTLY

See Also

D2Circle Class | D2Circle Members | Aveva.Pdms.Maths.Geometry Namespace


D2Circle Equality Operator

true if centre and radius values of both circles match EXACTLY

public static bool operator ==(
D2Circle left,
D2Circle right
);

Parameters

left
right

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2Circle Inequality Operator

true if centre or radius values of both circles do not match EXACTLY

public static bool operator !=(
D2Circle left,
D2Circle right
);

Parameters

left
right

Return Value

See Also

D2Circle Class | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine Class

A 2-D Line Class, With normal n and dist d, point x is: on the line if: n.x + d = 0 above the line if: n.x + d > 0 Alternative format is (a,b;c) - point (x,y) is above the line if: ax + by + c > 0 The normal (as stored internally) always has magnitude 1.

For a list of all members of this type, see D2DivideLine Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2DivideLine

public abstract class D2DivideLine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2DivideLine Members | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine Members

D2DivideLine overview

Public Static Methods

Create Overloaded. Default divide line

Public Static Operators

Equality Operator | True if left == right
Inequality Operator | True if left != right

Public Instance Methods

Clone | deep copy
Ddistance | Return distance form given point
Equals | Overloaded. Test for equality
GetA | Return x value of line
GetB | Return Y value of line
GetC | Return distance from the origin
GetHashCode | override gethashcode
GetNormal | Return the unit vector normal to the line
GetOffset | Return offset of the divided line
GetType (inherited from Object) | Gets the Type of the current instance.
SetValue | Overloaded. Set the normal and point on line
Side | Return which side of the line the point is: 1=above, 0=on, -1=below
ToString | Returns a string describing the contents of the D2DivideLine

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine Methods

The methods of the D2DivideLine class are listed below. For a complete list of D2DivideLine class members, see the D2DivideLine Members topic.

Public Static Methods

Create Overloaded. Default divide line

Public Instance Methods

Clone | deep copy
Ddistance | Return distance form given point
Equals | Overloaded. Test for equality
GetA | Return x value of line
GetB | Return Y value of line
GetC | Return distance from the origin
GetHashCode | override gethashcode
GetNormal | Return the unit vector normal to the line
GetOffset | Return offset of the divided line
GetType (inherited from Object) | Gets the Type of the current instance.
SetValue | Overloaded. Set the normal and point on line
Side | Return which side of the line the point is: 1=above, 0=on, -1=below
ToString | Returns a string describing the contents of the D2DivideLine

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine.Clone Method

deep copy

public abstract D2DivideLine Clone();

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2DivideLine.Create Method

Default divide line

Overload List

Default divide line

public static D2DivideLine Create();

Copy constructor

public static D2DivideLine Create(D2DivideLine);

Construct from a vector through the origin

public static D2DivideLine Create(D2Vector);

Construct from a vector and a point

public static D2DivideLine Create(D2Vector,D2Point);

Construct from a vector and a distance from origin

public static D2DivideLine Create(D2Vector,double);

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine.Create Method ()

Default divide line

public static D2DivideLine Create();

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2DivideLine.Create Overload List


D2DivideLine.Create Method (D2DivideLine)

Copy constructor

public static D2DivideLine Create(
D2DivideLine line
);

Parameters

line

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2DivideLine.Create Overload List


D2DivideLine.Create Method (D2Vector)

Construct from a vector through the origin

public static D2DivideLine Create(
D2Vector norm
);

Parameters

norm

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2DivideLine.Create Overload List


D2DivideLine.Create Method (D2Vector, D2Point)

Construct from a vector and a point

public static D2DivideLine Create(
D2Vector norm,
D2Point pt
);

Parameters

norm
pt

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2DivideLine.Create Overload List


D2DivideLine.Create Method (D2Vector, Double)

Construct from a vector and a distance from origin

public static D2DivideLine Create(
D2Vector norm,
double d
);

Parameters

norm
d

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2DivideLine.Create Overload List


D2DivideLine.Ddistance Method

Return distance form given point

public abstract double Ddistance(
D2Point pt
);

Parameters

pt

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2DivideLine.Equals Method

Test for equality

Overload List

Test for equality

public abstract bool Equals(D2DivideLine);

override equals method

public override bool Equals(object);

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine.Equals Method (D2DivideLine)

Test for equality

public abstract bool Equals(
D2DivideLine d2
);

Parameters

d2

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2DivideLine.Equals Overload List


D2DivideLine.Equals Method (Object)

override equals method

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2DivideLine.Equals Overload List


D2DivideLine.GetA Method

Return x value of line

public abstract double GetA();

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine.GetB Method

Return Y value of line

public abstract double GetB();

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine.GetC Method

Return distance from the origin

public abstract double GetC();

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine.GetHashCode Method

override gethashcode

public override int GetHashCode();

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine.GetNormal Method

Return the unit vector normal to the line

public abstract D2Vector GetNormal();

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine.GetOffset Method

Return offset of the divided line

public abstract double GetOffset();

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


SetValue Method

AVEVA Maths / Geometry .NET Public Interface

D2DivideLine.SetValue Method

Set the value of the normal to the plane

Overload List

Set the value of the normal to the plane

public abstract void SetValue(D2Vector);

Set the normal and point on line

public abstract void SetValue(D2Vector,D2Point);

Set the normal and the distance values

public abstract void SetValue(D2Vector,double);

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine.SetValue Method (D2Vector)

Set the value of the normal to the plane

public abstract void SetValue(
D2Vector norm
);

Parameters

norm

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2DivideLine.SetValue Overload List


D2DivideLine.SetValue Method (D2Vector, D2Point)

Set the normal and point on line

public abstract void SetValue(
D2Vector norm,
D2Point pt
);

Parameters

norm
pt

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2DivideLine.SetValue Overload List


D2DivideLine.SetValue Method (D2Vector, Double)

Set the normal and the distance values

public abstract void SetValue(
D2Vector norm,
double d
);

Parameters

norm
d

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2DivideLine.SetValue Overload List


D2DivideLine.Side Method

Return which side of the line the point is: 1=above, 0=on, -1=below

public abstract int Side(
D2Point pt,
double tol
);

Parameters

pt
tol

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine.ToString Method

Returns a string describing the contents of the D2DivideLine

public abstract string ToString();

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine Operators

The operators of the D2DivideLine class are listed below. For a complete list of D2DivideLine class members, see the D2DivideLine Members topic.

Public Static Operators

Equality Operator | True if left == right
Inequality Operator | True if left != right

See Also

D2DivideLine Class | D2DivideLine Members | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine Equality Operator

True if left == right

public static bool operator ==(
D2DivideLine left,
D2DivideLine right
);

Parameters

left
right

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2DivideLine Inequality Operator

True if left != right

public static bool operator !=(
D2DivideLine left,
D2DivideLine right
);

Parameters

left
right

Return Value

See Also

D2DivideLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine Class

Finite line

For a list of all members of this type, see D2FiniteLine Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2FiniteLine

public abstract class D2FiniteLine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2FiniteLine Members | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine Members

D2FiniteLine overview

Public Static Methods

Create Overloaded. Default constructor

Public Static Operators

Equality Operator | test for equality
Inequality Operator | test for inequality

Public Instance Methods

Antiparallel | Overloaded. Returns true if lines point in OPPOSITE DIRECTIONS (to default tolerance)
Box | Return 2-D limits box that encloses line
CheckLength | Overloaded. Returns true if length is greater than default tolerance
Clone |
Direction | Return direction vector of line (end - start)
DistanceFrom | Overloaded. Returns shortest distance from finite line to finite line Returns 0 if lines cross
DistanceFromOrigin | Returns the shortest distance from finite line to origin
End | Overloaded. Set coordinates of end point
Equals | Overloaded. Test for equality
GetHashCode | required override of GetHashCode() when we define operator ==
GetType (inherited from Object) | Gets the Type of the current instance.
InterPoint | Returns an intermediate point along the line proportion t from start (note - it'll be off the end if |t| > 1)
Intersects | Returns TRUE if lines are not parallel or anti parallel and both lines are of meaningful length (>1.E-6). Intersection point is returned through argument but is unchanged for non-intersecting lines. The Intersection point returned is the point the lines would cross if they were BOTH INFINITE. use the onLine(D2Point, double tol) method to determine if this intersection lies on one or both lines (within tolerance) N.B. use return value to check for intersection otherwise you'll get confused when lines really do cross at input value of "intersection" point
Length | Return length of line
Middle | Return mid point of the finite line
MirrorX | Overloaded. Reflect line about Y using pivot point
MirrorY | Overloaded. Reflect line about Y using pivot point
MoveBy | Move line by vector
NearestPoint | Return point on finite line closes to the given point
NearestPointToOrigin | Returns point on finite line closest to origin
OnLine | Overloaded. Returns true if point is on line (within default tolerance)
Parallel | Overloaded. Returns true if lines point in the SAME DIRECTION (to default tolerance)
PerpendicularDistance | Returns the Distance of the given point from the perpendicularPoint() calculated using NearestPoint function .
PerpendicularPoint | Returns the point on the INFINITELY EXTENDED line from which a perpendicular line can be dropped onto the given point
PolarAngleInRadians | Returns the polar angle of direction of line (in radians)
Reverse | Swap start and end points
RotateByDegrees | Overloaded. Rotate line about pivot point by given amount (in degrees)
RotateByRadians | Overloaded. Rotate line about pivot point by given angle (in radians)
ScaleBy | Overloaded. Scale by given amount about pivot point
SetValues | Overloaded. Set start and end points
Start | Overloaded. Set coordinates of start point
ToString | Returns a string describing the contents of the D2FiniteLine
TValue | Distance of point p from start point of line in the direction of the line. The distance is returned in units such that one line length = 1 unit.
UnitDirection | Return unit vector of direction of line
UValue | Distance of point p from start point of line in the direction normal to the line. The distance is returned in units such that one line length = 1 unit. +ve value => point p lies to left of line -ve value => point p lies to right of line

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine Methods

The methods of the D2FiniteLine class are listed below. For a complete list of D2FiniteLine class members, see the D2FiniteLine Members topic.

Public Static Methods

Create Overloaded. Default constructor

Public Instance Methods

Antiparallel | Overloaded. Returns true if lines point in OPPOSITE DIRECTIONS (to default tolerance)
Box | Return 2-D limits box that encloses line
CheckLength | Overloaded. Returns true if length is greater than default tolerance
Clone |
Direction | Return direction vector of line (end - start)
DistanceFrom | Overloaded. Returns shortest distance from finite line to finite line Returns 0 if lines cross
DistanceFromOrigin | Returns the shortest distance from finite line to origin
End | Overloaded. Set coordinates of end point
Equals | Overloaded. Test for equality
GetHashCode | required override of GetHashCode() when we define operator ==
GetType (inherited from Object) | Gets the Type of the current instance.
InterPoint | Returns an intermediate point along the line proportion t from start (note - it'll be off the end if |t| > 1)
Intersects | Returns TRUE if lines are not parallel or anti parallel and both lines are of meaningful length (>1.E-6). Intersection point is returned through argument but is unchanged for non-intersecting lines. The Intersection point returned is the point the lines would cross if they were BOTH INFINITE. use the onLine(D2Point, double tol) method to determine if this intersection lies on one or both lines (within tolerance) N.B. use return value to check for intersection otherwise you'll get confused when lines really do cross at input value of "intersection" point
Length | Return length of line
Middle | Return mid point of the finite line
MirrorX | Overloaded. Reflect line about Y using pivot point
MirrorY | Overloaded. Reflect line about Y using pivot point
MoveBy | Move line by vector
NearestPoint | Return point on finite line closes to the given point
NearestPointToOrigin | Returns point on finite line closest to origin
OnLine | Overloaded. Returns true if point is on line (within default tolerance)
Parallel | Overloaded. Returns true if lines point in the SAME DIRECTION (to default tolerance)
PerpendicularDistance | Returns the Distance of the given point from the perpendicularPoint() calculated using NearestPoint function .
PerpendicularPoint | Returns the point on the INFINITELY EXTENDED line from which a perpendicular line can be dropped onto the given point
PolarAngleInRadians | Returns the polar angle of direction of line (in radians)
Reverse | Swap start and end points
RotateByDegrees | Overloaded. Rotate line about pivot point by given amount (in degrees)
RotateByRadians | Overloaded. Rotate line about pivot point by given angle (in radians)
ScaleBy | Overloaded. Scale by given amount about pivot point
SetValues | Overloaded. Set start and end points
Start | Overloaded. Set coordinates of start point
ToString | Returns a string describing the contents of the D2FiniteLine
TValue | Distance of point p from start point of line in the direction of the line. The distance is returned in units such that one line length = 1 unit.
UnitDirection | Return unit vector of direction of line
UValue | Distance of point p from start point of line in the direction normal to the line. The distance is returned in units such that one line length = 1 unit. +ve value => point p lies to left of line -ve value => point p lies to right of line

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


Antiparallel Method

AVEVA Maths / Geometry .NET Public Interface

D2FiniteLine.Antiparallel Method

Returns true if lines point in OPPOSITE DIRECTIONS (to default tolerance)

Overload List

Returns true if lines point in OPPOSITE DIRECTIONS (to default tolerance)

public abstract bool Antiparallel(D2FiniteLine);

Returns true if lines point in OPPOSITE DIRECTIONS (to given tolerance)

public abstract bool Antiparallel(D2FiniteLine,double);

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.Antiparallel Method (D2FiniteLine)

Returns true if lines point in OPPOSITE DIRECTIONS (to default tolerance)

public abstract bool Antiparallel(
D2FiniteLine fline
);

Parameters

fline

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.Antiparallel Overload List


D2FiniteLine.Antiparallel Method (D2FiniteLine, Double)

Returns true if lines point in OPPOSITE DIRECTIONS (to given tolerance)

public abstract bool Antiparallel(
D2FiniteLine fline,
double tolerance
);

Parameters

fline
tolerance

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.Antiparallel Overload List


D2FiniteLine.Box Method

Return 2-D limits box that encloses line

public abstract D2Limits Box();

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


CheckLength Method

AVEVA Maths / Geometry .NET Public Interface

D2FiniteLine.CheckLength Method

Returns true if length is greater than default tolerance

Overload List

Returns true if length is greater than default tolerance

public abstract bool CheckLength();

Returns true if length is greater than given tolerance

public abstract bool CheckLength(double);

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.CheckLength Method ()

Returns true if length is greater than default tolerance

public abstract bool CheckLength();

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.CheckLength Overload List


D2FiniteLine.CheckLength Method (Double)

Returns true if length is greater than given tolerance

public abstract bool CheckLength(
double tolerance
);

Parameters

tolerance

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.CheckLength Overload List


D2FiniteLine.Clone Method

public abstract D2FiniteLine Clone();

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2FiniteLine.Create Method

Default constructor

Overload List

Default constructor

public static D2FiniteLine Create();

Copy finiteline

public static D2FiniteLine Create(D2FiniteLine);

construct from start and end points

public static D2FiniteLine Create(D2Point,D2Point);

construct from start and end coordinates

public static D2FiniteLine Create(double,double,double,double);

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.Create Method ()

Default constructor

public static D2FiniteLine Create();

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.Create Overload List


D2FiniteLine.Create Method (D2FiniteLine)

Copy finiteline

public static D2FiniteLine Create(
D2FiniteLine fline
);

Parameters

fline

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.Create Overload List


D2FiniteLine.Create Method (D2Point, D2Point)

construct from start and end points

public static D2FiniteLine Create(
D2Point start,
D2Point end
);

Parameters

start
end

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.Create Overload List


D2FiniteLine.Create Method (Double, Double, Double, Double)

construct from start and end coordinates

public static D2FiniteLine Create(
double x1,
double y1,
double x2,
double y2
);

Parameters

x1
y1
x2
y2

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.Create Overload List


D2FiniteLine.Direction Method

Return direction vector of line (end - start)

public abstract D2Vector Direction();

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


DistanceFrom Method

AVEVA Maths / Geometry .NET Public Interface

D2FiniteLine.DistanceFrom Method

Returns shortest distance from finite line to finite line Returns 0 if lines cross

Overload List

Returns shortest distance from finite line to finite line Returns 0 if lines cross

public abstract double DistanceFrom(D2FiniteLine);

Returns the shortest distance from finit line to given point.

public abstract double DistanceFrom(D2Point);

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.DistanceFrom Method (D2FiniteLine)

Returns shortest distance from finite line to finite line Returns 0 if lines cross

public abstract double DistanceFrom(
D2FiniteLine fline
);

Parameters

fline
Finite line

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.DistanceFrom Overload List


D2FiniteLine.DistanceFrom Method (D2Point)

Returns the shortest distance from finit line to given point.

public abstract double DistanceFrom(
D2Point p
);

Parameters

p

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.DistanceFrom Overload List


D2FiniteLine.DistanceFromOrigin Method

Returns the shortest distance from finite line to origin

public abstract double DistanceFromOrigin();

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


End Method

AVEVA Maths / Geometry .NET Public Interface

D2FiniteLine.End Method

Return end point of the finite line

Overload List

Return end point of the finite line

public abstract D2Point End();

Set end point

public abstract void End(D2Point);

Set coordinates of end point

public abstract void End(double,double);

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.End Method ()

Return end point of the finite line

public abstract D2Point End();

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.End Overload List


D2FiniteLine.End Method (D2Point)

Set end point

public abstract void End(
D2Point beta
);

Parameters

beta

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.End Overload List


D2FiniteLine.End Method (Double, Double)

Set coordinates of end point

public abstract void End(
double x,
double y
);

Parameters

x
y

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.End Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2FiniteLine.Equals Method

Test for equality

Overload List

Test for equality

public abstract bool Equals(D2FiniteLine);

required override of Equals() when we define operator ==

public override bool Equals(object);

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.Equals Method (D2FiniteLine)

Test for equality

public abstract bool Equals(
D2FiniteLine d2
);

Parameters

d2

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.Equals Overload List


D2FiniteLine.Equals Method (Object)

required override of Equals() when we define operator ==

public override bool Equals(
object a
);

Parameters

a

Return Value

bool

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.Equals Overload List


D2FiniteLine.GetHashCode Method

required override of GetHashCode() when we define operator ==

public override int GetHashCode();

Return Value

int

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.InterPoint Method

Returns an intermediate point along the line proportion t from start (note - it'll be off the end if |t| > 1)

public abstract D2Point InterPoint(
double t
);

Parameters

t

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.Intersects Method

Returns TRUE if lines are not parallel or anti parallel and both lines are of meaningful length (>1.E-6). Intersection point is returned through argument but is unchanged for non-intersecting lines. The Intersection point returned is the point the lines would cross if they were BOTH INFINITE. use the onLine(D2Point, double tol) method to determine if this intersection lies on one or both lines (within tolerance) N.B. use return value to check for intersection otherwise you'll get confused when lines really do cross at input value of "intersection" point

public abstract bool Intersects(
D2FiniteLine line,
D2Point intersection
);

Parameters

line
intersection

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.Length Method

Return length of line

public abstract double Length();

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.Middle Method

Return mid point of the finite line

public abstract D2Point Middle();

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


MirrorX Method

AVEVA Maths / Geometry .NET Public Interface

D2FiniteLine.MirrorX Method

Reflect line about origin in X

Overload List

Reflect line about origin in X

public abstract void MirrorX();

Reflect line about Y using pivot point

public abstract void MirrorX(D2Point);

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.MirrorX Method ()

Reflect line about origin in X

public abstract void MirrorX();

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.MirrorX Overload List


D2FiniteLine.MirrorX Method (D2Point)

Reflect line about Y using pivot point

public abstract void MirrorX(
D2Point pivot
);

Parameters

pivot

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.MirrorX Overload List


MirrorY Method

AVEVA Maths / Geometry .NET Public Interface

D2FiniteLine.MirrorY Method

Reflect line about origin in Y

Overload List

Reflect line about origin in Y

public abstract void MirrorY();

Reflect line about Y using pivot point

public abstract void MirrorY(D2Point);

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.MirrorY Method ()

Reflect line about origin in Y

public abstract void MirrorY();

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.MirrorY Overload List


D2FiniteLine.MirrorY Method (D2Point)

Reflect line about Y using pivot point

public abstract void MirrorY(
D2Point pivot
);

Parameters

pivot

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.MirrorY Overload List


D2FiniteLine.MoveBy Method

Move line by vector

public abstract void MoveBy(
D2Vector v
);

Parameters

v

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.NearestPoint Method

Return point on finite line closes to the given point

public abstract D2Point NearestPoint(
D2Point point
);

Parameters

point

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.NearestPointToOrigin Method

Returns point on finite line closest to origin

public abstract D2Point NearestPointToOrigin();

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


OnLine Method

AVEVA Maths / Geometry .NET Public Interface

D2FiniteLine.OnLine Method

Returns true if point is on line (within default tolerance)

Overload List

Returns true if point is on line (within default tolerance)

public abstract bool OnLine(D2Point);

Returns true if point is on line (within given tolerance)

public abstract bool OnLine(D2Point,double);

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.OnLine Method (D2Point)

Returns true if point is on line (within default tolerance)

public abstract bool OnLine(
D2Point p
);

Parameters

p

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.OnLine Overload List


D2FiniteLine.OnLine Method (D2Point, Double)

Returns true if point is on line (within given tolerance)

public abstract bool OnLine(
D2Point p,
double tolp
);

Parameters

p
tolp

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.OnLine Overload List


Parallel Method

AVEVA Maths / Geometry .NET Public Interface

D2FiniteLine.Parallel Method

Returns true if lines point in the SAME DIRECTION (to default tolerance)

Overload List

Returns true if lines point in the SAME DIRECTION (to default tolerance)

public abstract bool Parallel(D2FiniteLine);

Returns true if lines point in the SAME DIRECTION (to given tolerance)

public abstract bool Parallel(D2FiniteLine,double);

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.Parallel Method (D2FiniteLine)

Returns true if lines point in the SAME DIRECTION (to default tolerance)

public abstract bool Parallel(
D2FiniteLine fline
);

Parameters

fline

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.Parallel Overload List


D2FiniteLine.Parallel Method (D2FiniteLine, Double)

Returns true if lines point in the SAME DIRECTION (to given tolerance)

public abstract bool Parallel(
D2FiniteLine fline,
double tolerance
);

Parameters

fline
tolerance

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.Parallel Overload List


D2FiniteLine.PerpendicularDistance Method

Returns the Distance of the given point from the perpendicularPoint() calculated using NearestPoint function .

public abstract double PerpendicularDistance(
D2Point point
);

Parameters

point

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.PerpendicularPoint Method

Returns the point on the INFINITELY EXTENDED line from which a perpendicular line can be dropped onto the given point

public abstract D2Point PerpendicularPoint(
D2Point point
);

Parameters

point

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.PolarAngleInRadians Method

Returns the polar angle of direction of line (in radians)

public abstract double PolarAngleInRadians();

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.Reverse Method

Swap start and end points

public abstract void Reverse();

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


RotateByDegrees Method

AVEVA Maths / Geometry .NET Public Interface

D2FiniteLine.RotateByDegrees Method

Rotate line about origin by given angle (in degrees)

Overload List

Rotate line about origin by given angle (in degrees)

public abstract void RotateByDegrees(double);

Rotate line about pivot point by given amount (in degrees)

public abstract void RotateByDegrees(double,D2Point);

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.RotateByDegrees Method (Double)

Rotate line about origin by given angle (in degrees)

public abstract void RotateByDegrees(
double ang
);

Parameters

ang

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.RotateByDegrees Overload List


D2FiniteLine.RotateByDegrees Method (Double, D2Point)

Rotate line about pivot point by given amount (in degrees)

public abstract void RotateByDegrees(
double ang,
D2Point pivot
);

Parameters

ang
pivot

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.RotateByDegrees Overload List


RotateByRadians Method

AVEVA Maths / Geometry .NET Public Interface

D2FiniteLine.RotateByRadians Method

Rotate line about origin by given angle in radians

Overload List

Rotate line about origin by given angle in radians

public abstract void RotateByRadians(double);

Rotate line about pivot point by given angle (in radians)

public abstract void RotateByRadians(double,D2Point);

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.RotateByRadians Method (Double)

Rotate line about origin by given angle in radians

public abstract void RotateByRadians(
double ang
);

Parameters

ang

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.RotateByRadians Overload List


D2FiniteLine.RotateByRadians Method (Double, D2Point)

Rotate line about pivot point by given angle (in radians)

public abstract void RotateByRadians(
double ang,
D2Point pivot
);

Parameters

ang
pivot

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.RotateByRadians Overload List


ScaleBy Method

AVEVA Maths / Geometry .NET Public Interface

D2FiniteLine.ScaleBy Method

Scale uniformly by given amount

Overload List

Scale uniformly by given amount

public abstract void ScaleBy(double);

Scale by given amount about pivot point

public abstract void ScaleBy(double,D2Point);

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.ScaleBy Method (Double)

Scale uniformly by given amount

public abstract void ScaleBy(
double s
);

Parameters

s

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.ScaleBy Overload List


D2FiniteLine.ScaleBy Method (Double, D2Point)

Scale by given amount about pivot point

public abstract void ScaleBy(
double s,
D2Point pivot
);

Parameters

s
pivot

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.ScaleBy Overload List


SetValues Method

AVEVA Maths / Geometry .NET Public Interface

D2FiniteLine.SetValues Method

Set start and end points

Overload List

Set start and end points

public abstract void SetValues(D2Point,D2Point);

Set corrdinates of start and end points

public abstract void SetValues(double,double,double,double);

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.SetValues Method (D2Point, D2Point)

Set start and end points

public abstract void SetValues(
D2Point alpha,
D2Point beta
);

Parameters

alpha
beta

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.SetValues Overload List


D2FiniteLine.SetValues Method (Double, Double, Double, Double)

Set corrdinates of start and end points

public abstract void SetValues(
double x1,
double y1,
double x2,
double y2
);

Parameters

x1
y1
x2
y2

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.SetValues Overload List


Start Method

AVEVA Maths / Geometry .NET Public Interface

D2FiniteLine.Start Method

return start point of the finite line

Overload List

return start point of the finite line

public abstract D2Point Start();

Set start point

public abstract void Start(D2Point);

Set coordinates of start point

public abstract void Start(double,double);

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.Start Method ()

return start point of the finite line

public abstract D2Point Start();

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.Start Overload List


D2FiniteLine.Start Method (D2Point)

Set start point

public abstract void Start(
D2Point alpha
);

Parameters

alpha

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.Start Overload List


D2FiniteLine.Start Method (Double, Double)

Set coordinates of start point

public abstract void Start(
double x,
double y
);

Parameters

x
y

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2FiniteLine.Start Overload List


D2FiniteLine.ToString Method

Returns a string describing the contents of the D2FiniteLine

public abstract string ToString();

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.TValue Method

Distance of point p from start point of line in the direction of the line. The distance is returned in units such that one line length = 1 unit.

public abstract double TValue(
D2Point p
);

Parameters

p
Reference point

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.UnitDirection Method

Return unit vector of direction of line

public abstract D2Vector UnitDirection();

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine.UValue Method

Distance of point p from start point of line in the direction normal to the line. The distance is returned in units such that one line length = 1 unit. +ve value => point p lies to left of line -ve value => point p lies to right of line

public abstract double UValue(
D2Point p
);

Parameters

p

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine Operators

The operators of the D2FiniteLine class are listed below. For a complete list of D2FiniteLine class members, see the D2FiniteLine Members topic.

Public Static Operators

Equality Operator | test for equality
Inequality Operator | test for inequality

See Also

D2FiniteLine Class | D2FiniteLine Members | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine Equality Operator

test for equality

public static bool operator ==(
D2FiniteLine left,
D2FiniteLine right
);

Parameters

left
right

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2FiniteLine Inequality Operator

test for inequality

public static bool operator !=(
D2FiniteLine left,
D2FiniteLine right
);

Parameters

left
right

Return Value

See Also

D2FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid Class

Class definition of a an Irregular Cartesian Grid. The members of this class are: 1) a mthOrientedPlane representing the origin and orientation of the grid, 2) a validity flag, 3) an array containing the x spacings for the grid definition, and 4) an array containing the y spacings for the grid definition. The x and y spacings must be non-zero and positive for this type of grid to be valid. Empty vectors will result in an invalid grid.

For a list of all members of this type, see D2IrregularCartesianGrid Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2IrregularCartesianGrid

public abstract class D2IrregularCartesianGrid

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2IrregularCartesianGrid Members | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid Members

D2IrregularCartesianGrid overview

Public Static Methods

Create Overloaded. Default constructor

Public Static Operators

Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right

Public Instance Methods

Clone | Returns a deep copy of the D2IrregularCartesianGrid
Equals | Overloaded. test for equality
GetGridPoint | Returns point at grid intersection (i,j).
GetHashCode |
GetPlane | Returns the plane of the grid
GetType (inherited from Object) | Gets the Type of the current instance.
GetXLimit | returns the grid limit in x
GetXSpacings | Returns the array of x spacings
GetYLimit | returns the grid limit in y
GetYSpacings | Returns the array of spacings in y
GridValidity | Returns fales if if grid has a null or negative spacing value.
LocateControlPoint | Locates control point for use in snapping routines.
SetData | Set plane and x/y spacings
SetXSpacings | Set an array of spacings in x
SetYSpacings | Set an array of spacings in y
SnapToCentre | Returns nearest grid centre point to given point p
SnapToPoint | Returns nearest grid point to given point p.
ToString | Returns a string describing the values of the D2IrregularCartesianGrid

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid Methods

The methods of the D2IrregularCartesianGrid class are listed below. For a complete list of D2IrregularCartesianGrid class members, see the D2IrregularCartesianGrid Members topic.

Public Static Methods

Create Overloaded. Default constructor

Public Instance Methods

Clone | Returns a deep copy of the D2IrregularCartesianGrid
Equals | Overloaded. test for equality
GetGridPoint | Returns point at grid intersection (i,j).
GetHashCode |
GetPlane | Returns the plane of the grid
GetType (inherited from Object) | Gets the Type of the current instance.
GetXLimit | returns the grid limit in x
GetXSpacings | Returns the array of x spacings
GetYLimit | returns the grid limit in y
GetYSpacings | Returns the array of spacings in y
GridValidity | Returns fales if if grid has a null or negative spacing value.
LocateControlPoint | Locates control point for use in snapping routines.
SetData | Set plane and x/y spacings
SetXSpacings | Set an array of spacings in x
SetYSpacings | Set an array of spacings in y
SnapToCentre | Returns nearest grid centre point to given point p
SnapToPoint | Returns nearest grid point to given point p.
ToString | Returns a string describing the values of the D2IrregularCartesianGrid

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.Clone Method

Returns a deep copy of the D2IrregularCartesianGrid

public abstract D2IrregularCartesianGrid Clone();

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2IrregularCartesianGrid.Create Method

Default constructor

Overload List

Default constructor

public static D2IrregularCartesianGrid Create();

Copy constructor

public static D2IrregularCartesianGrid Create(D2IrregularCartesianGrid);

Create from a grid on a D3oriented plane

public static D2IrregularCartesianGrid Create(D3OrientedPlane,double[],double[]);

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.Create Method ()

Default constructor

public static D2IrregularCartesianGrid Create();

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace | D2IrregularCartesianGrid.Create Overload List


D2IrregularCartesianGrid.Create Method (D2IrregularCartesianGrid)

Copy constructor

public static D2IrregularCartesianGrid Create(
D2IrregularCartesianGrid g
);

Parameters

g

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace | D2IrregularCartesianGrid.Create Overload List


D2IrregularCartesianGrid.Create Method (D3OrientedPlane, Double[], Double[])

Create from a grid on a D3oriented plane

public static D2IrregularCartesianGrid Create(
D3OrientedPlane p,
double[] xs,
double[] ys
);

Parameters

p
xs
ys

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace | D2IrregularCartesianGrid.Create Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2IrregularCartesianGrid.Equals Method

test for equality

Overload List

test for equality

public abstract bool Equals(D2IrregularCartesianGrid);

public override bool Equals(object);

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.Equals Method (D2IrregularCartesianGrid)

test for equality

public abstract bool Equals(
D2IrregularCartesianGrid g
);

Parameters

g

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace | D2IrregularCartesianGrid.Equals Overload List


D2IrregularCartesianGrid.Equals Method (Object)

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace | D2IrregularCartesianGrid.Equals Overload List


D2IrregularCartesianGrid.GetGridPoint Method

Returns point at grid intersection (i,j).

public abstract bool GetGridPoint(
int i,
int j,
D2Point p
);

Parameters

i
j
p

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.GetPlane Method

Returns the plane of the grid

public abstract D3OrientedPlane GetPlane();

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.GetXLimit Method

returns the grid limit in x

public abstract double GetXLimit();

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.GetXSpacings Method

Returns the array of x spacings

public abstract double[] GetXSpacings();

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.GetYLimit Method

returns the grid limit in y

public abstract double GetYLimit();

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.GetYSpacings Method

Returns the array of spacings in y

public abstract double[] GetYSpacings();

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.GridValidity Method

Returns fales if if grid has a null or negative spacing value.

public abstract bool GridValidity();

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.LocateControlPoint Method

Locates control point for use in snapping routines.

public abstract void LocateControlPoint(
D2Point p,
ref int i,
ref int j
);

Parameters

p
i
j

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.SetData Method

Set plane and x/y spacings

public abstract void SetData(
D3OrientedPlane plane,
double[] xs,
double[] ys
);

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.SetXSpacings Method

Set an array of spacings in x

public abstract void SetXSpacings(
double[] x
);

Parameters

x

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.SetYSpacings Method

Set an array of spacings in y

public abstract void SetYSpacings(
double[] y
);

Parameters

y

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.SnapToCentre Method

Returns nearest grid centre point to given point p

public abstract bool SnapToCentre(
D2Point p,
D2Point c
);

Parameters

p
c

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.SnapToPoint Method

Returns nearest grid point to given point p.

public abstract bool SnapToPoint(
D2Point p,
D2Point ps
);

Parameters

p
ps

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid.ToString Method

Returns a string describing the values of the D2IrregularCartesianGrid

public abstract string ToString();

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid Operators

The operators of the D2IrregularCartesianGrid class are listed below. For a complete list of D2IrregularCartesianGrid class members, see the D2IrregularCartesianGrid Members topic.

Public Static Operators

Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right

See Also

D2IrregularCartesianGrid Class | D2IrregularCartesianGrid Members | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid Equality Operator

invoked by left == right

public static bool operator ==(
D2IrregularCartesianGrid left,
D2IrregularCartesianGrid right
);

Parameters

left
right

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularCartesianGrid Inequality Operator

invoked by left != right

public static bool operator !=(
D2IrregularCartesianGrid left,
D2IrregularCartesianGrid right
);

Parameters

left
right

Return Value

See Also

D2IrregularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid Class

Class definition of a an Irregular Polar Grid. An invalid grid will occur if any radii value is negative. If either the angular or radial vectors are empty a valid grid is defined, however, if both the angular and radial vectors are empty an invalid grid is defined.

For a list of all members of this type, see D2IrregularPolarGrid Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2IrregularPolarGrid

public abstract class D2IrregularPolarGrid

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2IrregularPolarGrid Members | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid Members

D2IrregularPolarGrid overview

Public Static Methods

Create Overloaded. default constructor with empty grid

Public Static Operators

Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right

Public Instance Methods

Clone | Returns a deep copy of the D2IrregularPolarGrid
Equals | Overloaded. Test for equality
GetAngles | Returns an array of angular spacings of the grid
GetGridPoint | Returns point at grid with angle index =i,radius index = j
GetHashCode |
GetPlane | Returns the plane of the grid
GetRadii | Returns an array of radial spacings of the grid
GetType (inherited from Object) | Gets the Type of the current instance.
GridValidity | Returns false if grid has a negative or null spacing value
LocateControlPoint | Locates control point for use in snapping routines.
SetAngles | Sets the angular spacings to values in given array
SetData | Set the plans, radial and angular spacings of the grid
SetRadii | Sets the radial spacings to values in given array
SnapToCentre | Returns nearest centre point in grid to given point
SnapToPoint | Returns point on grid nearest to given point p
ToString | Returns a string describing the values of the D2IrregularPolarGrid

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid Methods

The methods of the D2IrregularPolarGrid class are listed below. For a complete list of D2IrregularPolarGrid class members, see the D2IrregularPolarGrid Members topic.

Public Static Methods

Create Overloaded. default constructor with empty grid

Public Instance Methods

Clone | Returns a deep copy of the D2IrregularPolarGrid
Equals | Overloaded. Test for equality
GetAngles | Returns an array of angular spacings of the grid
GetGridPoint | Returns point at grid with angle index =i,radius index = j
GetHashCode |
GetPlane | Returns the plane of the grid
GetRadii | Returns an array of radial spacings of the grid
GetType (inherited from Object) | Gets the Type of the current instance.
GridValidity | Returns false if grid has a negative or null spacing value
LocateControlPoint | Locates control point for use in snapping routines.
SetAngles | Sets the angular spacings to values in given array
SetData | Set the plans, radial and angular spacings of the grid
SetRadii | Sets the radial spacings to values in given array
SnapToCentre | Returns nearest centre point in grid to given point
SnapToPoint | Returns point on grid nearest to given point p
ToString | Returns a string describing the values of the D2IrregularPolarGrid

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid.Clone Method

Returns a deep copy of the D2IrregularPolarGrid

public abstract D2IrregularPolarGrid Clone();

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2IrregularPolarGrid.Create Method

default constructor with empty grid

Overload List

default constructor with empty grid

public static D2IrregularPolarGrid Create();

Copy grid

public static D2IrregularPolarGrid Create(D2IrregularPolarGrid);

Create a grid from given angles/spacings on given plane

public static D2IrregularPolarGrid Create(D3OrientedPlane,double[],double[]);

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid.Create Method ()

default constructor with empty grid

public static D2IrregularPolarGrid Create();

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace | D2IrregularPolarGrid.Create Overload List


D2IrregularPolarGrid.Create Method (D2IrregularPolarGrid)

Copy grid

public static D2IrregularPolarGrid Create(
D2IrregularPolarGrid g
);

Parameters

g

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace | D2IrregularPolarGrid.Create Overload List


D2IrregularPolarGrid.Create Method (D3OrientedPlane, Double[], Double[])

Create a grid from given angles/spacings on given plane

public static D2IrregularPolarGrid Create(
D3OrientedPlane p,
double[] radius,
double[] angles
);

Parameters

p
radius
angles

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace | D2IrregularPolarGrid.Create Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2IrregularPolarGrid.Equals Method

Test for equality

Overload List

Test for equality

public abstract bool Equals(D2IrregularPolarGrid);

public override bool Equals(object);

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid.Equals Method (D2IrregularPolarGrid)

Test for equality

public abstract bool Equals(
D2IrregularPolarGrid g
);

Parameters

g

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace | D2IrregularPolarGrid.Equals Overload List


D2IrregularPolarGrid.Equals Method (Object)

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace | D2IrregularPolarGrid.Equals Overload List


D2IrregularPolarGrid.GetAngles Method

Returns an array of angular spacings of the grid

public abstract double[] GetAngles();

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid.GetGridPoint Method

Returns point at grid with angle index =i,radius index = j

public abstract bool GetGridPoint(
int i,
int j,
D2Point p
);

Parameters

i
j
p

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid.GetPlane Method

Returns the plane of the grid

public abstract D3OrientedPlane GetPlane();

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid.GetRadii Method

Returns an array of radial spacings of the grid

public abstract double[] GetRadii();

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid.GridValidity Method

Returns false if grid has a negative or null spacing value

public abstract bool GridValidity();

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid.LocateControlPoint Method

Locates control point for use in snapping routines.

public abstract void LocateControlPoint(
D2Point p,
ref int i,
ref int j
);

Parameters

p
i
j

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid.SetAngles Method

Sets the angular spacings to values in given array

public abstract void SetAngles(
double[] angles
);

Parameters

angles

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid.SetData Method

Set the plans, radial and angular spacings of the grid

public abstract void SetData(
D3OrientedPlane plane,
double[] radius,
double[] angles
);

Parameters

plane
radius
angles

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid.SetRadii Method

Sets the radial spacings to values in given array

public abstract void SetRadii(
double[] radius
);

Parameters

radius

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid.SnapToCentre Method

Returns nearest centre point in grid to given point

public abstract bool SnapToCentre(
D2Point p,
D2Point c
);

Parameters

p
c

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid.SnapToPoint Method

Returns point on grid nearest to given point p

public abstract bool SnapToPoint(
D2Point p,
D2Point ps
);

Parameters

p
ps

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid.ToString Method

Returns a string describing the values of the D2IrregularPolarGrid

public abstract string ToString();

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid Operators

The operators of the D2IrregularPolarGrid class are listed below. For a complete list of D2IrregularPolarGrid class members, see the D2IrregularPolarGrid Members topic.

Public Static Operators

Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right

See Also

D2IrregularPolarGrid Class | D2IrregularPolarGrid Members | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid Equality Operator

invoked by left == right

public static bool operator ==(
D2IrregularPolarGrid left,
D2IrregularPolarGrid right
);

Parameters

left
right

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2IrregularPolarGrid Inequality Operator

invoked by left != right

public static bool operator !=(
D2IrregularPolarGrid left,
D2IrregularPolarGrid right
);

Parameters

left
right

Return Value

See Also

D2IrregularPolarGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits Class

2-D Limits Box

For a list of all members of this type, see D2Limits Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2Limits

public abstract class D2Limits

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2Limits Members | Aveva.Pdms.Maths.Geometry Namespace


D2Limits Members

D2Limits overview

Public Static Methods

Create Overloaded. Create zero size limits box

Public Static Operators

Equality Operator | test for equality
Inequality Operator | test for inequality

Public Instance Methods

Area | Return area of box
Clear | Set box to unset
Clone |
ContainsPoint | Returns true if given point is within the box
ContainsPointToTol | Returns true if given point is within the box, within tolerance
Equals | Overloaded. Returns true if equal within default tolerance
Exits | Point where line exits the box, and which side of box
ExpandBy | Overloaded. Expand box by vector
ExpandToInclude | Overloaded. Expand to include anothe box
GetBase | Min value of Y
GetBL | Bottom left corner
GetBR | Bottom right corner
GetCentre | Mid point of box
GetExtent | Extent of box
GetHashCode | override system gethashcode method
GetHeight | size in Y direction
GetLeft | Min value of X
GetMaxSize | Max of height and width
GetMaxX | Max value of X
GetMaxY | Max value of Y
GetMinSize | Min of width and height
GetMinX | Min value of X
GetMinY | Min value of Y
GetRight | Max value of X
GetTL | Top left corner
GetTop | max value of Y
GetTR | Top right corner
GetType (inherited from Object) | Gets the Type of the current instance.
GetWidth | size in X direction
InsetBy | Overloaded. Inset box by vector (opposite to expand)
Intersect | boolean set-op
Intersects | True if boxes overlap
IsUnset | Test for unset
Merge | Returns box which enclose both
MirrorX | Overloaded. Reflect in X about pivot
MirrorY | Overloaded. Reflect in Y about pivot
MoveBy | Move box by given vector
ScaleBy | Overloaded. Scale about pivot point
SetCornerExtent | Set corner and direction of box
SetCorners | Set two opposite corners
ToString | Returns a string describing the contents of the D2Line

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits Methods

The methods of the D2Limits class are listed below. For a complete list of D2Limits class members, see the D2Limits Members topic.

Public Static Methods

Create Overloaded. Create zero size limits box

Public Instance Methods

Area | Return area of box
Clear | Set box to unset
Clone |
ContainsPoint | Returns true if given point is within the box
ContainsPointToTol | Returns true if given point is within the box, within tolerance
Equals | Overloaded. Returns true if equal within default tolerance
Exits | Point where line exits the box, and which side of box
ExpandBy | Overloaded. Expand box by vector
ExpandToInclude | Overloaded. Expand to include anothe box
GetBase | Min value of Y
GetBL | Bottom left corner
GetBR | Bottom right corner
GetCentre | Mid point of box
GetExtent | Extent of box
GetHashCode | override system gethashcode method
GetHeight | size in Y direction
GetLeft | Min value of X
GetMaxSize | Max of height and width
GetMaxX | Max value of X
GetMaxY | Max value of Y
GetMinSize | Min of width and height
GetMinX | Min value of X
GetMinY | Min value of Y
GetRight | Max value of X
GetTL | Top left corner
GetTop | max value of Y
GetTR | Top right corner
GetType (inherited from Object) | Gets the Type of the current instance.
GetWidth | size in X direction
InsetBy | Overloaded. Inset box by vector (opposite to expand)
Intersect | boolean set-op
Intersects | True if boxes overlap
IsUnset | Test for unset
Merge | Returns box which enclose both
MirrorX | Overloaded. Reflect in X about pivot
MirrorY | Overloaded. Reflect in Y about pivot
MoveBy | Move box by given vector
ScaleBy | Overloaded. Scale about pivot point
SetCornerExtent | Set corner and direction of box
SetCorners | Set two opposite corners
ToString | Returns a string describing the contents of the D2Line

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.Area Method

Return area of box

public abstract double Area();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.Clear Method

Set box to unset

public abstract void Clear();

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.Clone Method

public abstract D2Limits Clone();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.ContainsPoint Method

Returns true if given point is within the box

public abstract bool ContainsPoint(
D2Point p
);

Parameters

p

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.ContainsPointToTol Method

Returns true if given point is within the box, within tolerance

public abstract bool ContainsPointToTol(
D2Point p,
double tol
);

Parameters

p
tol

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2Limits.Create Method

Create zero size limits box

Overload List

Create zero size limits box

public static D2Limits Create();

Copy constructor

public static D2Limits Create(D2Limits);

Create limits box at given point

public static D2Limits Create(D2Point);

Create cube between given points

public static D2Limits Create(D2Point,D2Point);

Create limits cube from given point with given extent

public static D2Limits Create(D2Point,D2Vector);

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.Create Method ()

Create zero size limits box

public static D2Limits Create();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.Create Overload List


D2Limits.Create Method (D2Limits)

Copy constructor

public static D2Limits Create(
D2Limits r
);

Parameters

r

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.Create Overload List


D2Limits.Create Method (D2Point)

Create limits box at given point

public static D2Limits Create(
D2Point p
);

Parameters

p

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.Create Overload List


D2Limits.Create Method (D2Point, D2Point)

Create cube between given points

public static D2Limits Create(
D2Point min,
D2Point max
);

Parameters

min
max

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.Create Overload List


D2Limits.Create Method (D2Point, D2Vector)

Create limits cube from given point with given extent

public static D2Limits Create(
D2Point p,
D2Vector extent
);

Parameters

p
extent

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.Create Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2Limits.Equals Method

Returns true if equal within default tolerance

Overload List

Returns true if equal within default tolerance

public abstract bool Equals(D2Limits);

Returns true if equal within given tolerance

public abstract bool Equals(D2Limits,double);

override system equals method

public override bool Equals(object);

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.Equals Method (D2Limits)

Returns true if equal within default tolerance

public abstract bool Equals(
D2Limits limits
);

Parameters

limits

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.Equals Overload List


D2Limits.Equals Method (D2Limits, Double)

Returns true if equal within given tolerance

public abstract bool Equals(
D2Limits limits,
double delta
);

Parameters

limits
delta

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.Equals Overload List


D2Limits.Equals Method (Object)

override system equals method

public override bool Equals(
object a
);

Parameters

a

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.Equals Overload List


D2Limits.Exits Method

Point where line exits the box, and which side of box

public abstract D2Point Exits(
D2Point start,
D2Vector direction,
ref int SideOfRect
);

Parameters

start
direction
SideOfRect
Left for 1, top for 2, right for 3, bottom for 4

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


ExpandBy Method

AVEVA Maths / Geometry .NET Public Interface

D2Limits.ExpandBy Method

Expand box by vector

Overload List

Expand box by vector

public abstract void ExpandBy(D2Vector);

Expand box by given amount in all directions constant margin - may be neg

public abstract void ExpandBy(double);

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.ExpandBy Method (D2Vector)

Expand box by vector

public abstract void ExpandBy(
D2Vector v
);

Parameters

v

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.ExpandBy Overload List


D2Limits.ExpandBy Method (Double)

Expand box by given amount in all directions constant margin - may be neg

public abstract void ExpandBy(
double delta
);

Parameters

delta

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.ExpandBy Overload List


ExpandToInclude Method

AVEVA Maths / Geometry .NET Public Interface

D2Limits.ExpandToInclude Method

Expand to include anothe box

Overload List

Expand to include anothe box

public abstract void ExpandToInclude(D2Limits);

Expand box to include point

public abstract void ExpandToInclude(D2Point);

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.ExpandToInclude Method (D2Limits)

Expand to include anothe box

public abstract void ExpandToInclude(
D2Limits limits
);

Parameters

limits

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.ExpandToInclude Overload List


D2Limits.ExpandToInclude Method (D2Point)

Expand box to include point

public abstract void ExpandToInclude(
D2Point p
);

Parameters

p

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.ExpandToInclude Overload List


D2Limits.GetBase Method

Min value of Y

public abstract double GetBase();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetBL Method

Bottom left corner

public abstract D2Point GetBL();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetBR Method

Bottom right corner

public abstract D2Point GetBR();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetCentre Method

Mid point of box

public abstract D2Point GetCentre();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetExtent Method

Extent of box

public abstract D2Vector GetExtent();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetHashCode Method

override system gethashcode method

public override int GetHashCode();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetHeight Method

size in Y direction

public abstract double GetHeight();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetLeft Method

Min value of X

public abstract double GetLeft();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetMaxSize Method

Max of height and width

public abstract double GetMaxSize();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetMaxX Method

Max value of X

public abstract double GetMaxX();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetMaxY Method

Max value of Y

public abstract double GetMaxY();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetMinSize Method

Min of width and height

public abstract double GetMinSize();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetMinX Method

Min value of X

public abstract double GetMinX();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetMinY Method

Min value of Y

public abstract double GetMinY();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetRight Method

Max value of X

public abstract double GetRight();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetTL Method

Top left corner

public abstract D2Point GetTL();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetTop Method

max value of Y

public abstract double GetTop();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetTR Method

Top right corner

public abstract D2Point GetTR();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.GetWidth Method

size in X direction

public abstract double GetWidth();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


InsetBy Method

AVEVA Maths / Geometry .NET Public Interface

D2Limits.InsetBy Method

Inset box by vector (opposite to expand)

Overload List

Inset box by vector (opposite to expand)

public abstract void InsetBy(D2Vector);

Inset box by given amount(opposite to expand)

public abstract void InsetBy(double);

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.InsetBy Method (D2Vector)

Inset box by vector (opposite to expand)

public abstract void InsetBy(
D2Vector dext
);

Parameters

dext

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.InsetBy Overload List


D2Limits.InsetBy Method (Double)

Inset box by given amount(opposite to expand)

public abstract void InsetBy(
double delta
);

Parameters

delta

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.InsetBy Overload List


D2Limits.Intersect Method

boolean set-op

public abstract D2Limits Intersect(
D2Limits limits
);

Parameters

limits

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.Intersects Method

True if boxes overlap

public abstract bool Intersects(
D2Limits limits
);

Parameters

limits

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.IsUnset Method

Test for unset

public abstract bool IsUnset();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.Merge Method

Returns box which enclose both

public abstract D2Limits Merge(
D2Limits limits
);

Parameters

limits

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


MirrorX Method

AVEVA Maths / Geometry .NET Public Interface

D2Limits.MirrorX Method

Reflect in X about origin

Overload List

Reflect in X about origin

public abstract void MirrorX();

Reflect in X about pivot

public abstract void MirrorX(D2Point);

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.MirrorX Method ()

Reflect in X about origin

public abstract void MirrorX();

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.MirrorX Overload List


D2Limits.MirrorX Method (D2Point)

Reflect in X about pivot

public abstract void MirrorX(
D2Point pivot
);

Parameters

pivot

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.MirrorX Overload List


MirrorY Method

AVEVA Maths / Geometry .NET Public Interface

D2Limits.MirrorY Method

Reflect in Y about origin

Overload List

Reflect in Y about origin

public abstract void MirrorY();

Reflect in Y about pivot

public abstract void MirrorY(D2Point);

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.MirrorY Method ()

Reflect in Y about origin

public abstract void MirrorY();

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.MirrorY Overload List


D2Limits.MirrorY Method (D2Point)

Reflect in Y about pivot

public abstract void MirrorY(
D2Point pivot
);

Parameters

pivot

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.MirrorY Overload List


D2Limits.MoveBy Method

Move box by given vector

public abstract void MoveBy(
D2Vector v
);

Parameters

v

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


ScaleBy Method

AVEVA Maths / Geometry .NET Public Interface

D2Limits.ScaleBy Method

Uniform scaling about centre

Overload List

Uniform scaling about centre

public abstract void ScaleBy(double);

Scale about pivot point

public abstract void ScaleBy(double,D2Point);

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.ScaleBy Method (Double)

Uniform scaling about centre

public abstract void ScaleBy(
double s
);

Parameters

s

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.ScaleBy Overload List


D2Limits.ScaleBy Method (Double, D2Point)

Scale about pivot point

public abstract void ScaleBy(
double s,
D2Point pivot
);

Parameters

s
pivot

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D2Limits.ScaleBy Overload List


D2Limits.SetCornerExtent Method

Set corner and direction of box

public abstract void SetCornerExtent(
D2Point p,
D2Vector ext
);

Parameters

p
ext

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.SetCorners Method

Set two opposite corners

public abstract void SetCorners(
D2Point p1,
D2Point p2
);

Parameters

p1
p2

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits.ToString Method

Returns a string describing the contents of the D2Line

public abstract string ToString();

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits Operators

The operators of the D2Limits class are listed below. For a complete list of D2Limits class members, see the D2Limits Members topic.

Public Static Operators

Equality Operator | test for equality
Inequality Operator | test for inequality

See Also

D2Limits Class | D2Limits Members | Aveva.Pdms.Maths.Geometry Namespace


D2Limits Equality Operator

test for equality

public static bool operator ==(
D2Limits left,
D2Limits right
);

Parameters

left
right

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Limits Inequality Operator

test for inequality

public static bool operator !=(
D2Limits left,
D2Limits right
);

Parameters

left
right

Return Value

See Also

D2Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line Class

2 D Line class

For a list of all members of this type, see D2Line Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2Line

public abstract class D2Line

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2Line Members | Aveva.Pdms.Maths.Geometry Namespace


D2Line Members

D2Line overview

Public Static Methods

Create Overloaded. default constructor

Public Static Operators

Equality Operator | test for equality
Inequality Operator | test for inequality

Public Instance Methods

Antiparallel | Overloaded. true if lines are anti parallel
CheckLength | Overloaded. Returns true if distance between start and end points is greater than default tolerance
Clone | Create clone
Direction | Returns direction vector of line
DistanceFrom | Overloaded. returns shortest straight line distance between a line and a FiniteLine
DistanceFromOrigin | Returns shortest straight line distance between line and origin
End | Overloaded. set end coordinates
Equals | Overloaded. test for equality
GetHashCode | required override of GetHashCode() when we define operator ==
GetType (inherited from Object) | Gets the Type of the current instance.
InterPoint | Returns point on line, ratio t between start and end
Intersects | Returns TRUE if lines are not parallel (or anti parallel) and both lines are of meaningful length (>1.E-6). Intersection point is returned through argument but is unchanged when FALSE is RETURNed. The Intersection point returned is the point the lines would cross if they were BOTH INFINITELY EXTENDED. Use the "onLine(D2Point, double tol=1.E-6)" method to determine if this intersection lies on one or both lines (within tolerance). N.B. use return value to check for intersection otherwise you'll get confused if lines really do cross at input value of "intersection" point
IsFinite | Returns true for a line with a start and an end
IsInfinite | true for bi-directionally infinite lines only
IsSemiInfinite | true for semi-infinite lines (one end only)
IsSemiWithEnd | true for semi-infinite line with an end point
IsSemiWithStart | true for semi-infinite line with a start point
Length | returns non-negative distance between start_ and end_ points. Always finite since the start and end points are used to define the direction of the line for (semi) infinite lines and not the extent.
LineType | Overloaded. set line type: possibilities are - D2Line::finite D2Line::infinite D2Line::semiWithStart D2Line::semiWithEnd
LTypeToString | Convert linetype to string
MirrorX | Overloaded. Reflect in X about y=x coord of pivot
MirrorY | Overloaded. Reflect about y = x coordinate of pivot
MoveBy | shift the start and end points
NearestPoint | Returns point on line nearest given point "point"
NearestPointToOrigin | Returns point on line closest to origin.
OnLine | Overloaded. trus if point is on line
Parallel | Overloaded. true if lines are parallel
PerpendicularDistance | Returns the Distance of the arg point from the perpendicularPoint calculated using Perpendicluar Point method.
PerpendicularPoint | Returns the point on the INFINITELY EXTENDED line from which a perpendicular line can be dropped onto the given point
PolarAngleInRadians | Polar angle of direction of line
Reverse | swap start and end points
RotateByDegrees | Overloaded. Rotate line about pivot by angle in degrees
RotateByRadians | Overloaded. rotate line about pivot by angle in radians
ScaleBy | Overloaded. Scale by given amount about pivot
SetValues | Overloaded. set start and end points
Start | Overloaded. set start coordinates
ToString | Returns a string describing the contents of the D2Line
TValue | Distance of point p from start point of line in the direction of the line. The distance is returned in units such that one line length = 1 unit.
UnitDirection | Returns unit vector of line
UValue | Distance of point p from start point of line in the direction normal to the line. The distance is returned in units such that one line length = 1 unit. +ve value => point p lies to left of line -ve value => point p lies to right of line

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line Methods

The methods of the D2Line class are listed below. For a complete list of D2Line class members, see the D2Line Members topic.

Public Static Methods

Create Overloaded. default constructor

Public Instance Methods

Antiparallel | Overloaded. true if lines are anti parallel
CheckLength | Overloaded. Returns true if distance between start and end points is greater than default tolerance
Clone | Create clone
Direction | Returns direction vector of line
DistanceFrom | Overloaded. returns shortest straight line distance between a line and a FiniteLine
DistanceFromOrigin | Returns shortest straight line distance between line and origin
End | Overloaded. set end coordinates
Equals | Overloaded. test for equality
GetHashCode | required override of GetHashCode() when we define operator ==
GetType (inherited from Object) | Gets the Type of the current instance.
InterPoint | Returns point on line, ratio t between start and end
Intersects | Returns TRUE if lines are not parallel (or anti parallel) and both lines are of meaningful length (>1.E-6). Intersection point is returned through argument but is unchanged when FALSE is RETURNed. The Intersection point returned is the point the lines would cross if they were BOTH INFINITELY EXTENDED. Use the "onLine(D2Point, double tol=1.E-6)" method to determine if this intersection lies on one or both lines (within tolerance). N.B. use return value to check for intersection otherwise you'll get confused if lines really do cross at input value of "intersection" point
IsFinite | Returns true for a line with a start and an end
IsInfinite | true for bi-directionally infinite lines only
IsSemiInfinite | true for semi-infinite lines (one end only)
IsSemiWithEnd | true for semi-infinite line with an end point
IsSemiWithStart | true for semi-infinite line with a start point
Length | returns non-negative distance between start_ and end_ points. Always finite since the start and end points are used to define the direction of the line for (semi) infinite lines and not the extent.
LineType | Overloaded. set line type: possibilities are - D2Line::finite D2Line::infinite D2Line::semiWithStart D2Line::semiWithEnd
LTypeToString | Convert linetype to string
MirrorX | Overloaded. Reflect in X about y=x coord of pivot
MirrorY | Overloaded. Reflect about y = x coordinate of pivot
MoveBy | shift the start and end points
NearestPoint | Returns point on line nearest given point "point"
NearestPointToOrigin | Returns point on line closest to origin.
OnLine | Overloaded. trus if point is on line
Parallel | Overloaded. true if lines are parallel
PerpendicularDistance | Returns the Distance of the arg point from the perpendicularPoint calculated using Perpendicluar Point method.
PerpendicularPoint | Returns the point on the INFINITELY EXTENDED line from which a perpendicular line can be dropped onto the given point
PolarAngleInRadians | Polar angle of direction of line
Reverse | swap start and end points
RotateByDegrees | Overloaded. Rotate line about pivot by angle in degrees
RotateByRadians | Overloaded. rotate line about pivot by angle in radians
ScaleBy | Overloaded. Scale by given amount about pivot
SetValues | Overloaded. set start and end points
Start | Overloaded. set start coordinates
ToString | Returns a string describing the contents of the D2Line
TValue | Distance of point p from start point of line in the direction of the line. The distance is returned in units such that one line length = 1 unit.
UnitDirection | Returns unit vector of line
UValue | Distance of point p from start point of line in the direction normal to the line. The distance is returned in units such that one line length = 1 unit. +ve value => point p lies to left of line -ve value => point p lies to right of line

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


Antiparallel Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.Antiparallel Method

true if lines are anti parallel

Overload List

true if lines are anti parallel

public abstract bool Antiparallel(D2Line);

true if lines are anti parallel to within given angular tolerance (radians)

public abstract bool Antiparallel(D2Line,double);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.Antiparallel Method (D2Line)

true if lines are anti parallel

public abstract bool Antiparallel(
D2Line line
);

Parameters

line

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Antiparallel Overload List


D2Line.Antiparallel Method (D2Line, Double)

true if lines are anti parallel to within given angular tolerance (radians)

public abstract bool Antiparallel(
D2Line line,
double tol
);

Parameters

line
tol

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Antiparallel Overload List


CheckLength Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.CheckLength Method

Returns true if distance between start and end points is greater than default tolerance

Overload List

Returns true if distance between start and end points is greater than default tolerance

public abstract bool CheckLength();

Returns true if distance between start and end points is greater than minLength

public abstract bool CheckLength(double);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.CheckLength Method ()

Returns true if distance between start and end points is greater than default tolerance

public abstract bool CheckLength();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.CheckLength Overload List


D2Line.CheckLength Method (Double)

Returns true if distance between start and end points is greater than minLength

public abstract bool CheckLength(
double minLength
);

Parameters

minLength

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.CheckLength Overload List


D2Line.Clone Method

Create clone

public abstract D2Line Clone();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.Create Method

default constructor

Overload List

default constructor

public static D2Line Create();

Construct a line from given FiniteLine

public static D2Line Create(D2FiniteLine,LTYPE);

Construct a finite line through given points

public static D2Line Create(D2Point,D2Point);

Construct line of given type passing through given points

public static D2Line Create(D2Point,D2Point,LTYPE);

Construct a line from given position and in given direction

public static D2Line Create(D2Point,D2Vector);

Construct line of given type trhough given point in given direction

public static D2Line Create(D2Point,D2Vector,LTYPE);

Construct a finite line through given x,y coordinates

public static D2Line Create(double,double,double,double);

Construct line of given type through given x, y coordinates

public static D2Line Create(double,double,double,double,LTYPE);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.Create Method ()

default constructor

public static D2Line Create();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Create Overload List


D2Line.Create Method (D2FiniteLine, LTYPE)

Construct a line from given FiniteLine

public static D2Line Create(
D2FiniteLine fLine,
LTYPE type
);

Parameters

fLine
type

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Create Overload List


D2Line.Create Method (D2Point, D2Point)

Construct a finite line through given points

public static D2Line Create(
D2Point start,
D2Point end
);

Parameters

start
end

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Create Overload List


D2Line.Create Method (D2Point, D2Point, LTYPE)

Construct line of given type passing through given points

public static D2Line Create(
D2Point start,
D2Point end,
LTYPE type
);

Parameters

start
end
type
infinite, semiWithStart, semiWithEnd, finite

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Create Overload List


D2Line.Create Method (D2Point, D2Vector)

Construct a line from given position and in given direction

public static D2Line Create(
D2Point start,
D2Vector dir
);

Parameters

start
dir

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Create Overload List


D2Line.Create Method (D2Point, D2Vector, LTYPE)

Construct line of given type trhough given point in given direction

public static D2Line Create(
D2Point start,
D2Vector dir,
LTYPE type
);

Parameters

start
dir
type
infinite, semiWithStart, semiWithEnd, finite

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Create Overload List


D2Line.Create Method (Double, Double, Double, Double)

Construct a finite line through given x,y coordinates

public static D2Line Create(
double x1,
double y1,
double x2,
double y2
);

Parameters

x1
y1
x2
y2

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Create Overload List


D2Line.Create Method (Double, Double, Double, Double, LTYPE)

Construct line of given type through given x, y coordinates

public static D2Line Create(
double x1,
double y1,
double x2,
double y2,
LTYPE type
);

Parameters

x1
y1
x2
y2
type
infinite, semiWithStart, semiWithEnd, finite

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Create Overload List


D2Line.Direction Method

Returns direction vector of line

public abstract D2Vector Direction();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


DistanceFrom Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.DistanceFrom Method

returns shortest straight line distance between a line and a FiniteLine

Overload List

returns shortest straight line distance between a line and a FiniteLine

public abstract double DistanceFrom(D2FiniteLine);

Returns shortest straight line distance between two lines

public abstract double DistanceFrom(D2Line);

returns shortest straight line distance between line and point

public abstract double DistanceFrom(D2Point);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.DistanceFrom Method (D2FiniteLine)

returns shortest straight line distance between a line and a FiniteLine

public abstract double DistanceFrom(
D2FiniteLine FiniteLine
);

Parameters

FiniteLine

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.DistanceFrom Overload List


D2Line.DistanceFrom Method (D2Line)

Returns shortest straight line distance between two lines

public abstract double DistanceFrom(
D2Line line
);

Parameters

line

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.DistanceFrom Overload List


D2Line.DistanceFrom Method (D2Point)

returns shortest straight line distance between line and point

public abstract double DistanceFrom(
D2Point point
);

Parameters

point

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.DistanceFrom Overload List


D2Line.DistanceFromOrigin Method

Returns shortest straight line distance between line and origin

public abstract double DistanceFromOrigin();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


End Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.End Method

Return end point

Overload List

Return end point

public abstract D2Point End();

set end point

public abstract void End(D2Point);

set end coordinates

public abstract void End(double,double);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.End Method ()

Return end point

public abstract D2Point End();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.End Overload List


D2Line.End Method (D2Point)

set end point

public abstract void End(
D2Point p
);

Parameters

p

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.End Overload List


D2Line.End Method (Double, Double)

set end coordinates

public abstract void End(
double x,
double y
);

Parameters

x
y

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.End Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.Equals Method

test for equality

Overload List

test for equality

public abstract bool Equals(D2Line);

required override of Equals() when we define operator ==

public override bool Equals(object);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.Equals Method (D2Line)

test for equality

public abstract bool Equals(
D2Line d2
);

Parameters

d2

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Equals Overload List


D2Line.Equals Method (Object)

required override of Equals() when we define operator ==

public override bool Equals(
object a
);

Parameters

a

Return Value

bool

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Equals Overload List


D2Line.GetHashCode Method

required override of GetHashCode() when we define operator ==

public override int GetHashCode();

Return Value

int

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.InterPoint Method

Returns point on line, ratio t between start and end

public abstract D2Point InterPoint(
double t
);

Parameters

t

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.Intersects Method

Returns TRUE if lines are not parallel (or anti parallel) and both lines are of meaningful length (>1.E-6). Intersection point is returned through argument but is unchanged when FALSE is RETURNed. The Intersection point returned is the point the lines would cross if they were BOTH INFINITELY EXTENDED. Use the "onLine(D2Point, double tol=1.E-6)" method to determine if this intersection lies on one or both lines (within tolerance). N.B. use return value to check for intersection otherwise you'll get confused if lines really do cross at input value of "intersection" point

public abstract bool Intersects(
D2Line line,
D2Point intersection
);

Parameters

line
intersection

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.IsFinite Method

Returns true for a line with a start and an end

public abstract bool IsFinite();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.IsInfinite Method

true for bi-directionally infinite lines only

public abstract bool IsInfinite();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.IsSemiInfinite Method

true for semi-infinite lines (one end only)

public abstract bool IsSemiInfinite();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.IsSemiWithEnd Method

true for semi-infinite line with an end point

public abstract bool IsSemiWithEnd();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.IsSemiWithStart Method

true for semi-infinite line with a start point

public abstract bool IsSemiWithStart();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.Length Method

returns non-negative distance between start_ and end_ points. Always finite since the start and end points are used to define the direction of the line for (semi) infinite lines and not the extent.

public abstract double Length();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


LineType Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.LineType Method

Return line type

Overload List

Return line type

public abstract LTYPE LineType();

set line type: possibilities are - D2Line::finite D2Line::infinite D2Line::semiWithStart D2Line::semiWithEnd

public abstract void LineType(LTYPE);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.LineType Method ()

Return line type

public abstract LTYPE LineType();

Return Value

infinite, semiWithStart, semiWithEnd, finite

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.LineType Overload List


D2Line.LineType Method (LTYPE)

set line type: possibilities are - D2Line::finite D2Line::infinite D2Line::semiWithStart D2Line::semiWithEnd

public abstract void LineType(
LTYPE type
);

Parameters

type

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.LineType Overload List


D2Line.LTypeToString Method

Convert linetype to string

public abstract string LTypeToString(
LTYPE lt
);

Parameters

lt

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


MirrorX Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.MirrorX Method

Reflect in X about origin

Overload List

Reflect in X about origin

public abstract void MirrorX();

Reflect in X about y=x coord of pivot

public abstract void MirrorX(D2Point);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.MirrorX Method ()

Reflect in X about origin

public abstract void MirrorX();

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.MirrorX Overload List


D2Line.MirrorX Method (D2Point)

Reflect in X about y=x coord of pivot

public abstract void MirrorX(
D2Point pivot
);

Parameters

pivot

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.MirrorX Overload List


MirrorY Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.MirrorY Method

Relect in Y about origin

Overload List

Relect in Y about origin

public abstract void MirrorY();

Reflect about y = x coordinate of pivot

public abstract void MirrorY(D2Point);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.MirrorY Method ()

Relect in Y about origin

public abstract void MirrorY();

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.MirrorY Overload List


D2Line.MirrorY Method (D2Point)

Reflect about y = x coordinate of pivot

public abstract void MirrorY(
D2Point pivot
);

Parameters

pivot

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.MirrorY Overload List


D2Line.MoveBy Method

shift the start and end points

public abstract void MoveBy(
D2Vector v
);

Parameters

v

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.NearestPoint Method

Returns point on line nearest given point "point"

public abstract D2Point NearestPoint(
D2Point point
);

Parameters

point

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.NearestPointToOrigin Method

Returns point on line closest to origin.

public abstract D2Point NearestPointToOrigin();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


OnLine Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.OnLine Method

trus if point is on line

Overload List

trus if point is on line

public abstract bool OnLine(D2Point);

true if given point is within distance "tol" of line

public abstract bool OnLine(D2Point,double);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.OnLine Method (D2Point)

trus if point is on line

public abstract bool OnLine(
D2Point p
);

Parameters

p

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.OnLine Overload List


D2Line.OnLine Method (D2Point, Double)

true if given point is within distance "tol" of line

public abstract bool OnLine(
D2Point p,
double tol
);

Parameters

p
tol

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.OnLine Overload List


Parallel Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.Parallel Method

true if lines are parallel

Overload List

true if lines are parallel

public abstract bool Parallel(D2Line);

true if lines are parallel to within given angular tolerance (radians)

public abstract bool Parallel(D2Line,double);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.Parallel Method (D2Line)

true if lines are parallel

public abstract bool Parallel(
D2Line line
);

Parameters

line

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Parallel Overload List


D2Line.Parallel Method (D2Line, Double)

true if lines are parallel to within given angular tolerance (radians)

public abstract bool Parallel(
D2Line line,
double tol
);

Parameters

line
tol

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Parallel Overload List


D2Line.PerpendicularDistance Method

Returns the Distance of the arg point from the perpendicularPoint calculated using Perpendicluar Point method.

public abstract double PerpendicularDistance(
D2Point point
);

Parameters

point

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.PerpendicularPoint Method

Returns the point on the INFINITELY EXTENDED line from which a perpendicular line can be dropped onto the given point

public abstract D2Point PerpendicularPoint(
D2Point point
);

Parameters

point

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.PolarAngleInRadians Method

Polar angle of direction of line

public abstract double PolarAngleInRadians();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.Reverse Method

swap start and end points

public abstract void Reverse();

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


RotateByDegrees Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.RotateByDegrees Method

Rotate line about origin by angle in degrees

Overload List

Rotate line about origin by angle in degrees

public abstract void RotateByDegrees(double);

Rotate line about pivot by angle in degrees

public abstract void RotateByDegrees(double,D2Point);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.RotateByDegrees Method (Double)

Rotate line about origin by angle in degrees

public abstract void RotateByDegrees(
double ang
);

Parameters

ang

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.RotateByDegrees Overload List


D2Line.RotateByDegrees Method (Double, D2Point)

Rotate line about pivot by angle in degrees

public abstract void RotateByDegrees(
double ang,
D2Point pivot
);

Parameters

ang
pivot

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.RotateByDegrees Overload List


RotateByRadians Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.RotateByRadians Method

rotate line about origin by angle in radians

Overload List

rotate line about origin by angle in radians

public abstract void RotateByRadians(double);

rotate line about pivot by angle in radians

public abstract void RotateByRadians(double,D2Point);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.RotateByRadians Method (Double)

rotate line about origin by angle in radians

public abstract void RotateByRadians(
double ang
);

Parameters

ang

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.RotateByRadians Overload List


D2Line.RotateByRadians Method (Double, D2Point)

rotate line about pivot by angle in radians

public abstract void RotateByRadians(
double ang,
D2Point pivot
);

Parameters

ang
pivot

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.RotateByRadians Overload List


ScaleBy Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.ScaleBy Method

Scale uniformly by given amount

Overload List

Scale uniformly by given amount

public abstract void ScaleBy(double);

Scale by given amount about pivot

public abstract void ScaleBy(double,D2Point);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.ScaleBy Method (Double)

Scale uniformly by given amount

public abstract void ScaleBy(
double s
);

Parameters

s

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.ScaleBy Overload List


D2Line.ScaleBy Method (Double, D2Point)

Scale by given amount about pivot

public abstract void ScaleBy(
double s,
D2Point pivot
);

Parameters

s
pivot

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.ScaleBy Overload List


SetValues Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.SetValues Method

set start and end points

Overload List

set start and end points

public abstract void SetValues(D2Point,D2Point);

set start and end coordinates

public abstract void SetValues(double,double,double,double);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.SetValues Method (D2Point, D2Point)

set start and end points

public abstract void SetValues(
D2Point start,
D2Point end
);

Parameters

start
end

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.SetValues Overload List


D2Line.SetValues Method (Double, Double, Double, Double)

set start and end coordinates

public abstract void SetValues(
double x1,
double y1,
double x2,
double y2
);

Parameters

x1
y1
x2
y2

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.SetValues Overload List


Start Method

AVEVA Maths / Geometry .NET Public Interface

D2Line.Start Method

Return start point

Overload List

Return start point

public abstract D2Point Start();

set start point

public abstract void Start(D2Point);

set start coordinates

public abstract void Start(double,double);

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.Start Method ()

Return start point

public abstract D2Point Start();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Start Overload List


D2Line.Start Method (D2Point)

set start point

public abstract void Start(
D2Point p
);

Parameters

p

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Start Overload List


D2Line.Start Method (Double, Double)

set start coordinates

public abstract void Start(
double x,
double y
);

Parameters

x
y

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace | D2Line.Start Overload List


D2Line.ToString Method

Returns a string describing the contents of the D2Line

public abstract string ToString();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.TValue Method

Distance of point p from start point of line in the direction of the line. The distance is returned in units such that one line length = 1 unit.

public abstract double TValue(
D2Point p
);

Parameters

p

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.UnitDirection Method

Returns unit vector of line

public abstract D2Vector UnitDirection();

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.UValue Method

Distance of point p from start point of line in the direction normal to the line. The distance is returned in units such that one line length = 1 unit. +ve value => point p lies to left of line -ve value => point p lies to right of line

public abstract double UValue(
D2Point p
);

Parameters

p

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line Operators

The operators of the D2Line class are listed below. For a complete list of D2Line class members, see the D2Line Members topic.

Public Static Operators

Equality Operator | test for equality
Inequality Operator | test for inequality

See Also

D2Line Class | D2Line Members | Aveva.Pdms.Maths.Geometry Namespace


D2Line Equality Operator

test for equality

public static bool operator ==(
D2Line left,
D2Line right
);

Parameters

left
right

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line Inequality Operator

test for inequality

public static bool operator !=(
D2Line left,
D2Line right
);

Parameters

left
right

Return Value

See Also

D2Line Class | Aveva.Pdms.Maths.Geometry Namespace


D2Line.LTYPE Enumeration

four possible line types

public enum D2Line.LTYPE

Members

Member Name | Description
infinite | Infinite line
semiWithStart | Semi-infinite line with start point
semiWithEnd | Semi-infinite line with end point
finite | Finite line

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

Aveva.Pdms.Maths.Geometry Namespace


D2Matrix Class

2x2 matrix This matrix class can represent a 2x2 matrix of douuble precision quantities. The elements are indexed from (zero,zero).

For a list of all members of this type, see D2Matrix Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2Matrix

public abstract class D2Matrix

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2Matrix Members | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix Members

D2Matrix overview

Public Static Methods

Create Overloaded. Default Constructor

Public Static Operators

Addition Operator | invoked by m1+m2 - add corresponding elements.
Division Operator | invoked by m1/scalar - divide each element by a scalar
Equality Operator | The equality operator. It returns true if all the components are exactly equal (it does not use a tolerance).
Inequality Operator | The inequality operator. It returns true if NOT all the components are exactly equal (it does not use a tolerance).
Multiplication Operator | Overloaded. invoked by m1 * m2 - Matrix multiplication
Subtraction Operator | invoked by m1-m2 - subtract corresponding element.

Public Instance Methods

Add | Add two matrices
AsArray4 | return matrix as a vector
BeIdentity | clear matrix to be an identity matrix.
BeZero | clear to zeros
Clone | deep copy
Determinant | Returns the determinate of the matrix
Divide | Divide matrix by scalar value
Equals | Overloaded. Returns true if matrix values are within fl_TOLERANCE of each othe
Get | return matrix element. (N.B i and j are 0 or 1)
GetHashCode | required override of GetHashCode() when we define operator ==
GetInverse | true for non-singular matrices Inverse matrix returned through in result.
GetType (inherited from Object) | Gets the Type of the current instance.
Inverse | return inverse matrix - returns null matrix if the original matrix is singular
Invert | invert matrix if non-singular (return false otherwise)
IsIdentity | True if matrix is identity matrix
IsOrthogonal | True if matrix is orthogonal (within tolerance)
IsSingular | True for singular matrices Result predicts failure of getInverse() inverse() and invert()
Multiply | Overloaded. Multiply elements of matrix by scalar value
RotateByDegrees | rotate matrix by given angle in degrees
RotateByRadians | rotate matrix by given angle in radians
SetValue | Set value of element (i,j)
SetValues | Set value of matrix elements to values in vesctor (row order)
Subtract | Subtract matrix from this one
ToString | Returns string containing details of the matrix
Transpose | Return transpose of matrix

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix Methods

The methods of the D2Matrix class are listed below. For a complete list of D2Matrix class members, see the D2Matrix Members topic.

Public Static Methods

Create Overloaded. Default Constructor

Public Instance Methods

Add | Add two matrices
AsArray4 | return matrix as a vector
BeIdentity | clear matrix to be an identity matrix.
BeZero | clear to zeros
Clone | deep copy
Determinant | Returns the determinate of the matrix
Divide | Divide matrix by scalar value
Equals | Overloaded. Returns true if matrix values are within fl_TOLERANCE of each othe
Get | return matrix element. (N.B i and j are 0 or 1)
GetHashCode | required override of GetHashCode() when we define operator ==
GetInverse | true for non-singular matrices Inverse matrix returned through in result.
GetType (inherited from Object) | Gets the Type of the current instance.
Inverse | return inverse matrix - returns null matrix if the original matrix is singular
Invert | invert matrix if non-singular (return false otherwise)
IsIdentity | True if matrix is identity matrix
IsOrthogonal | True if matrix is orthogonal (within tolerance)
IsSingular | True for singular matrices Result predicts failure of getInverse() inverse() and invert()
Multiply | Overloaded. Multiply elements of matrix by scalar value
RotateByDegrees | rotate matrix by given angle in degrees
RotateByRadians | rotate matrix by given angle in radians
SetValue | Set value of element (i,j)
SetValues | Set value of matrix elements to values in vesctor (row order)
Subtract | Subtract matrix from this one
ToString | Returns string containing details of the matrix
Transpose | Return transpose of matrix

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.Add Method

Add two matrices

public abstract D2Matrix Add(
D2Matrix m2
);

Parameters

m2

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.AsArray4 Method

return matrix as a vector

public abstract double[] AsArray4();

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.BeIdentity Method

clear matrix to be an identity matrix.

public abstract void BeIdentity();

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.BeZero Method

clear to zeros

public abstract void BeZero();

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.Clone Method

deep copy

public abstract D2Matrix Clone();

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2Matrix.Create Method

Default Constructor

Overload List

Default Constructor

public static D2Matrix Create();

Copy D2Matrix

public static D2Matrix Create(D2Matrix);

Construct a diagonal matrix with value diag along diagonal

public static D2Matrix Create(double);

Construct a 4x4 matrix with given values (by row)

public static D2Matrix Create(double[]);

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.Create Method ()

Default Constructor

public static D2Matrix Create();

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D2Matrix.Create Overload List


D2Matrix.Create Method (D2Matrix)

Copy D2Matrix

public static D2Matrix Create(
D2Matrix matrix
);

Parameters

matrix

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D2Matrix.Create Overload List


D2Matrix.Create Method (Double)

Construct a diagonal matrix with value diag along diagonal

public static D2Matrix Create(
double diag
);

Parameters

diag

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D2Matrix.Create Overload List


D2Matrix.Create Method (Double[])

Construct a 4x4 matrix with given values (by row)

public static D2Matrix Create(
double[] v
);

Parameters

v

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D2Matrix.Create Overload List


D2Matrix.Determinant Method

Returns the determinate of the matrix

public abstract double Determinant();

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.Divide Method

Divide matrix by scalar value

public abstract D2Matrix Divide(
double scalar
);

Parameters

scalar

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2Matrix.Equals Method

Returns true if matrix values are within fl_TOLERANCE of each othe

Overload List

Returns true if matrix values are within fl_TOLERANCE of each othe

public abstract bool Equals(D2Matrix);

Returns true if matrix values are within delta of each other

public abstract bool Equals(D2Matrix,double);

override test for equality

public override bool Equals(object);

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.Equals Method (D2Matrix)

Returns true if matrix values are within fl_TOLERANCE of each othe

public abstract bool Equals(
D2Matrix matrix
);

Parameters

matrix

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D2Matrix.Equals Overload List


D2Matrix.Equals Method (D2Matrix, Double)

Returns true if matrix values are within delta of each other

public abstract bool Equals(
D2Matrix matrix,
double delta
);

Parameters

matrix
delta

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D2Matrix.Equals Overload List


D2Matrix.Equals Method (Object)

override test for equality

public override bool Equals(
object a
);

Parameters

a

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D2Matrix.Equals Overload List


D2Matrix.Get Method

return matrix element. (N.B i and j are 0 or 1)

public abstract double Get(
int i,
int j
);

Parameters

i
j

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.GetHashCode Method

required override of GetHashCode() when we define operator ==

public override int GetHashCode();

Return Value

int

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.GetInverse Method

true for non-singular matrices Inverse matrix returned through in result.

public abstract bool GetInverse(
D2Matrix result
);

Parameters

result

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.Inverse Method

return inverse matrix - returns null matrix if the original matrix is singular

public abstract D2Matrix Inverse();

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.Invert Method

invert matrix if non-singular (return false otherwise)

public abstract bool Invert();

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.IsIdentity Method

True if matrix is identity matrix

public abstract bool IsIdentity();

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.IsOrthogonal Method

True if matrix is orthogonal (within tolerance)

public abstract bool IsOrthogonal(
double tol
);

Parameters

tol

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.IsSingular Method

True for singular matrices Result predicts failure of getInverse() inverse() and invert()

public abstract bool IsSingular();

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


Multiply Method

AVEVA Maths / Geometry .NET Public Interface

D2Matrix.Multiply Method

Multiply matrix by another

Overload List

Multiply matrix by another

public abstract D2Matrix Multiply(D2Matrix);

Multiply matrix by a vector

public abstract D2Vector Multiply(D2Vector);

Multiply elements of matrix by scalar value

public abstract D2Matrix Multiply(double);

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.Multiply Method (D2Matrix)

Multiply matrix by another

public abstract D2Matrix Multiply(
D2Matrix m2
);

Parameters

m2

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D2Matrix.Multiply Overload List


D2Matrix.Multiply Method (D2Vector)

Multiply matrix by a vector

public abstract D2Vector Multiply(
D2Vector v2
);

Parameters

v2

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D2Matrix.Multiply Overload List


D2Matrix.Multiply Method (Double)

Multiply elements of matrix by scalar value

public abstract D2Matrix Multiply(
double scalar
);

Parameters

scalar

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D2Matrix.Multiply Overload List


D2Matrix.RotateByDegrees Method

rotate matrix by given angle in degrees

public abstract void RotateByDegrees(
double degrees
);

Parameters

degrees

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.RotateByRadians Method

rotate matrix by given angle in radians

public abstract void RotateByRadians(
double radians
);

Parameters

radians

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.SetValue Method

Set value of element (i,j)

public abstract void SetValue(
int i,
int j,
double x
);

Parameters

i
j
x

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.SetValues Method

Set value of matrix elements to values in vesctor (row order)

public abstract void SetValues(
double[] v
);

Parameters

v

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.Subtract Method

Subtract matrix from this one

public abstract D2Matrix Subtract(
D2Matrix m2
);

Parameters

m2

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.ToString Method

Returns string containing details of the matrix

public abstract string ToString();

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix.Transpose Method

Return transpose of matrix

public abstract D2Matrix Transpose();

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix Operators

The operators of the D2Matrix class are listed below. For a complete list of D2Matrix class members, see the D2Matrix Members topic.

Public Static Operators

Addition Operator | invoked by m1+m2 - add corresponding elements.
Division Operator | invoked by m1/scalar - divide each element by a scalar
Equality Operator | The equality operator. It returns true if all the components are exactly equal (it does not use a tolerance).
Inequality Operator | The inequality operator. It returns true if NOT all the components are exactly equal (it does not use a tolerance).
Multiplication Operator | Overloaded. invoked by m1 * m2 - Matrix multiplication
Subtraction Operator | invoked by m1-m2 - subtract corresponding element.

See Also

D2Matrix Class | D2Matrix Members | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix Addition Operator

invoked by m1+m2 - add corresponding elements.

public static D2Matrix operator +(
D2Matrix m1,
D2Matrix m2
);

Parameters

m1
m2

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix Division Operator

invoked by m1/scalar - divide each element by a scalar

public static D2Matrix operator /(
D2Matrix m1,
double scalar
);

Parameters

m1
scalar

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix Equality Operator

The equality operator. It returns true if all the components are exactly equal (it does not use a tolerance).

public static bool operator ==(
D2Matrix left,
D2Matrix right
);

Parameters

left
right

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix Inequality Operator

The inequality operator. It returns true if NOT all the components are exactly equal (it does not use a tolerance).

public static bool operator !=(
D2Matrix left,
D2Matrix right
);

Parameters

left
right

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix Multiplication Operator

invoked by m1 * m2 - Matrix multiplication

Overload List

invoked by m1 * m2 - Matrix multiplication

public static D2Matrix Multiplication Operator(D2Matrix,D2Matrix);

invoked by scalar * m1 - multiply each element by the scalar

public static D2Matrix Multiplication Operator(D2Matrix,double);

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Matrix Multiplication Operator

invoked by m1 * m2 - Matrix multiplication

public static D2Matrix operator *(
D2Matrix m1,
D2Matrix m2
);

Parameters

m1
m2

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D2MatrixMultiplication Operator Overload List


D2Matrix Multiplication Operator

invoked by scalar * m1 - multiply each element by the scalar

public static D2Matrix operator *(
D2Matrix m1,
double scalar
);

Parameters

m1
scalar

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D2MatrixMultiplication Operator Overload List


D2Matrix Subtraction Operator

invoked by m1-m2 - subtract corresponding element.

public static D2Matrix operator -(
D2Matrix m1,
D2Matrix m2
);

Parameters

m1
m2

Return Value

See Also

D2Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point Class

D2Point - a 2-D point class

For a list of all members of this type, see D2Point Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2Point

public abstract class D2Point

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2Point Members | Aveva.Pdms.Maths.Geometry Namespace


D2Point Members

D2Point overview

Public Static Methods

Create Overloaded. Create a D2Point from two coordinate values

Public Static Operators

Addition Operator | Create a point p = p1 + v
Equality Operator | invoked by left == right
Inequality Operator | Invoked by left != right
Subtraction Operator | Overloaded. Create a vector v = p1 + p2

Public Instance Properties

X | set/get X coordinate
Y | set/get Y coordinate

Public Instance Methods

Add | Point = this + vector v2
AsVector | explicit conversion to D2Vector
BottomPoint | Returns the bottom-most of two points (min Y)
Clone |
Ddistance | Overloaded. Return distance from given point
Equals | Overloaded. Points are within fl_TOLERANCE of each other
GetHashCode | required override of GetHashCode() when we define operator ==
GetType (inherited from Object) | Gets the Type of the current instance.
LeftPoint | Returns the left-most of two points (min X)
MidPoint | Returns the mid point between two points
MirrorX | Overloaded. Mirror X about pivot
MirrorY | Overloaded. Mirror Y about pivot
MoveBy | Overloaded. Offset by given vector
MoveTo | Move point to given x, y coordinates
NearestPoint | Return whichever of a and b is nearest
Parse | Creates a D2Point from a string of the format:"xxx,yyy"
RightPoint | Returns the right-most of two points (max X)
RotateByDegrees | Overloaded. about pivot
RotateByRadians | Overloaded. about pivot
ScaleBy | Overloaded. Scale about pivot
SetXY | Set x and y coordinates
Subtract | Overloaded. Vector which is the difference between two points
TopPoint | Returns the top-most of two points (max Y)
ToString | Returns a string describing the contents of the D2Point

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point Properties

The properties of the D2Point class are listed below. For a complete list of D2Point class members, see the D2Point Members topic.

Public Instance Properties

X | set/get X coordinate
Y | set/get Y coordinate

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


X Property

AVEVA Maths / Geometry .NET Public Interface

D2Point.X Property

set/get X coordinate

public abstract double X {get; set;}

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


Y Property

AVEVA Maths / Geometry .NET Public Interface

D2Point.Y Property

set/get Y coordinate

public abstract double Y {get; set;}

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point Methods

The methods of the D2Point class are listed below. For a complete list of D2Point class members, see the D2Point Members topic.

Public Static Methods

Create Overloaded. Create a D2Point from two coordinate values

Public Instance Methods

Add | Point = this + vector v2
AsVector | explicit conversion to D2Vector
BottomPoint | Returns the bottom-most of two points (min Y)
Clone |
Ddistance | Overloaded. Return distance from given point
Equals | Overloaded. Points are within fl_TOLERANCE of each other
GetHashCode | required override of GetHashCode() when we define operator ==
GetType (inherited from Object) | Gets the Type of the current instance.
LeftPoint | Returns the left-most of two points (min X)
MidPoint | Returns the mid point between two points
MirrorX | Overloaded. Mirror X about pivot
MirrorY | Overloaded. Mirror Y about pivot
MoveBy | Overloaded. Offset by given vector
MoveTo | Move point to given x, y coordinates
NearestPoint | Return whichever of a and b is nearest
Parse | Creates a D2Point from a string of the format:"xxx,yyy"
RightPoint | Returns the right-most of two points (max X)
RotateByDegrees | Overloaded. about pivot
RotateByRadians | Overloaded. about pivot
ScaleBy | Overloaded. Scale about pivot
SetXY | Set x and y coordinates
Subtract | Overloaded. Vector which is the difference between two points
TopPoint | Returns the top-most of two points (max Y)
ToString | Returns a string describing the contents of the D2Point

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.Add Method

Point = this + vector v2

public abstract D2Point Add(
D2Vector v2
);

Parameters

v2

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.AsVector Method

explicit conversion to D2Vector

public abstract D2Vector AsVector();

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.BottomPoint Method

Returns the bottom-most of two points (min Y)

public D2Point BottomPoint(
D2Point a,
D2Point b
);

Parameters

a
b

Return Value

D2Point

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.Clone Method

public abstract D2Point Clone();

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2Point.Create Method

Create a D2Point from two coordinate values

Overload List

Create a D2Point from two coordinate values

public static D2Point Create();

Copy a D2Point

public static D2Point Create(D2Point);

Create a D2Point from two coordinate values

public static D2Point Create(double,double);

Create a D2Point from an array of 2 doubles

public static D2Point Create(double[]);

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.Create Method ()

Create a D2Point from two coordinate values

public static D2Point Create();

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.Create Overload List


D2Point.Create Method (D2Point)

Copy a D2Point

public static D2Point Create(
D2Point p
);

Parameters

p

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.Create Overload List


D2Point.Create Method (Double, Double)

Create a D2Point from two coordinate values

public static D2Point Create(
double x,
double y
);

Parameters

x
y

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.Create Overload List


D2Point.Create Method (Double[])

Create a D2Point from an array of 2 doubles

public static D2Point Create(
double[] v
);

Parameters

v
2 dimension array of doubles

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.Create Overload List


Ddistance Method

AVEVA Maths / Geometry .NET Public Interface

D2Point.Ddistance Method

Return distance from given point

Overload List

Return distance from given point

public abstract double Ddistance(D2Point);

Distance between two points

public double Ddistance(D2Point,D2Point);

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.Ddistance Method (D2Point)

Return distance from given point

public abstract double Ddistance(
D2Point b
);

Parameters

b

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.Ddistance Overload List


D2Point.Ddistance Method (D2Point, D2Point)

Distance between two points

public double Ddistance(
D2Point a,
D2Point b
);

Parameters

a
b

Return Value

double

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.Ddistance Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2Point.Equals Method

Points are within fl_TOLERANCE of each other

Overload List

Points are within fl_TOLERANCE of each other

public abstract bool Equals(D2Point);

Points are within delta of each other

public abstract bool Equals(D2Point,double);

required override of Equals() when we define operator ==

public override bool Equals(object);

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.Equals Method (D2Point)

Points are within fl_TOLERANCE of each other

public abstract bool Equals(
D2Point p2
);

Parameters

p2

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.Equals Overload List


D2Point.Equals Method (D2Point, Double)

Points are within delta of each other

public abstract bool Equals(
D2Point p2,
double delta
);

Parameters

p2
delta

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.Equals Overload List


D2Point.Equals Method (Object)

required override of Equals() when we define operator ==

public override bool Equals(
object a
);

Parameters

a

Return Value

true if equal

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.Equals Overload List


D2Point.GetHashCode Method

required override of GetHashCode() when we define operator ==

public override int GetHashCode();

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.LeftPoint Method

Returns the left-most of two points (min X)

public D2Point LeftPoint(
D2Point a,
D2Point b
);

Parameters

a
b

Return Value

D2Point

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.MidPoint Method

Returns the mid point between two points

public D2Point MidPoint(
D2Point a,
D2Point b
);

Parameters

a
b

Return Value

D2Point

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


MirrorX Method

AVEVA Maths / Geometry .NET Public Interface

D2Point.MirrorX Method

Mirror X about origin

Overload List

Mirror X about origin

public abstract void MirrorX();

Mirror X about pivot

public abstract void MirrorX(D2Point);

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.MirrorX Method ()

Mirror X about origin

public abstract void MirrorX();

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.MirrorX Overload List


D2Point.MirrorX Method (D2Point)

Mirror X about pivot

public abstract void MirrorX(
D2Point pivot
);

Parameters

pivot

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.MirrorX Overload List


MirrorY Method

AVEVA Maths / Geometry .NET Public Interface

D2Point.MirrorY Method

Mirror Y about origin

Overload List

Mirror Y about origin

public abstract void MirrorY();

Mirror Y about pivot

public abstract void MirrorY(D2Point);

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.MirrorY Method ()

Mirror Y about origin

public abstract void MirrorY();

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.MirrorY Overload List


D2Point.MirrorY Method (D2Point)

Mirror Y about pivot

public abstract void MirrorY(
D2Point pivot
);

Parameters

pivot

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.MirrorY Overload List


MoveBy Method

AVEVA Maths / Geometry .NET Public Interface

D2Point.MoveBy Method

Offset by given vector

Overload List

Offset by given vector

public abstract void MoveBy(D2Vector);

Offset by given x,y values

public abstract void MoveBy(double,double);

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.MoveBy Method (D2Vector)

Offset by given vector

public abstract void MoveBy(
D2Vector v
);

Parameters

v

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.MoveBy Overload List


D2Point.MoveBy Method (Double, Double)

Offset by given x,y values

public abstract void MoveBy(
double x,
double y
);

Parameters

x
y

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.MoveBy Overload List


D2Point.MoveTo Method

Move point to given x, y coordinates

public abstract void MoveTo(
double x,
double y
);

Parameters

x
y

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.NearestPoint Method

Return whichever of a and b is nearest

public abstract D2Point NearestPoint(
D2Point a,
D2Point b
);

Parameters

a
b

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.Parse Method

Creates a D2Point from a string of the format:"xxx,yyy"

public abstract D2Point Parse(
string str
);

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.RightPoint Method

Returns the right-most of two points (max X)

public D2Point RightPoint(
D2Point a,
D2Point b
);

Parameters

a
b

Return Value

D2Point

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


RotateByDegrees Method

AVEVA Maths / Geometry .NET Public Interface

D2Point.RotateByDegrees Method

about origin in degrees

Overload List

about origin in degrees

public abstract void RotateByDegrees(double);

about pivot

public abstract void RotateByDegrees(double,D2Point);

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.RotateByDegrees Method (Double)

about origin in degrees

public abstract void RotateByDegrees(
double angle
);

Parameters

angle

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.RotateByDegrees Overload List


D2Point.RotateByDegrees Method (Double, D2Point)

about pivot

public abstract void RotateByDegrees(
double angle,
D2Point pivot
);

Parameters

angle
pivot

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.RotateByDegrees Overload List


RotateByRadians Method

AVEVA Maths / Geometry .NET Public Interface

D2Point.RotateByRadians Method

about origin in radians

Overload List

about origin in radians

public abstract void RotateByRadians(double);

about pivot

public abstract void RotateByRadians(double,D2Point);

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.RotateByRadians Method (Double)

about origin in radians

public abstract void RotateByRadians(
double angle
);

Parameters

angle

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.RotateByRadians Overload List


D2Point.RotateByRadians Method (Double, D2Point)

about pivot

public abstract void RotateByRadians(
double angle,
D2Point pivot
);

Parameters

angle
pivot

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.RotateByRadians Overload List


ScaleBy Method

AVEVA Maths / Geometry .NET Public Interface

D2Point.ScaleBy Method

Scale about origin

Overload List

Scale about origin

public abstract void ScaleBy(double);

Scale about pivot

public abstract void ScaleBy(double,D2Point);

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.ScaleBy Method (Double)

Scale about origin

public abstract void ScaleBy(
double s
);

Parameters

s

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.ScaleBy Overload List


D2Point.ScaleBy Method (Double, D2Point)

Scale about pivot

public abstract void ScaleBy(
double s,
D2Point pivot
);

Parameters

s
pivot

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.ScaleBy Overload List


D2Point.SetXY Method

Set x and y coordinates

public abstract void SetXY(
double x,
double y
);

Parameters

x
y

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


Subtract Method

AVEVA Maths / Geometry .NET Public Interface

D2Point.Subtract Method

Vector which is the difference between two points

Overload List

Vector which is the difference between two points

public abstract D2Vector Subtract(D2Point);

Point = this -vector v2

public abstract D2Point Subtract(D2Vector);

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.Subtract Method (D2Point)

Vector which is the difference between two points

public abstract D2Vector Subtract(
D2Point p2
);

Parameters

p2

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.Subtract Overload List


D2Point.Subtract Method (D2Vector)

Point = this -vector v2

public abstract D2Point Subtract(
D2Vector v2
);

Parameters

v2

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2Point.Subtract Overload List


D2Point.TopPoint Method

Returns the top-most of two points (max Y)

public D2Point TopPoint(
D2Point a,
D2Point b
);

Parameters

a
b

Return Value

D2Point

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point.ToString Method

Returns a string describing the contents of the D2Point

public abstract string ToString();

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point Operators

The operators of the D2Point class are listed below. For a complete list of D2Point class members, see the D2Point Members topic.

Public Static Operators

Addition Operator | Create a point p = p1 + v
Equality Operator | invoked by left == right
Inequality Operator | Invoked by left != right
Subtraction Operator | Overloaded. Create a vector v = p1 + p2

See Also

D2Point Class | D2Point Members | Aveva.Pdms.Maths.Geometry Namespace


D2Point Addition Operator

Create a point p = p1 + v

public static D2Point operator +(
D2Point p1,
D2Vector v
);

Parameters

p1
v

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point Equality Operator

invoked by left == right

public static bool operator ==(
D2Point left,
D2Point right
);

Parameters

left
right

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point Inequality Operator

Invoked by left != right

public static bool operator !=(
D2Point left,
D2Point right
);

Parameters

left
right

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point Subtraction Operator

Create a vector v = p1 + p2

Overload List

Create a vector v = p1 + p2

public static D2Vector Subtraction Operator(D2Point,D2Point);

Create a point p = p1 - v

public static D2Point Subtraction Operator(D2Point,D2Vector);

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace


D2Point Subtraction Operator

Create a vector v = p1 + p2

public static D2Vector operator -(
D2Point p1,
D2Point p2
);

Parameters

p1
p2

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2PointSubtraction Operator Overload List


D2Point Subtraction Operator

Create a point p = p1 - v

public static D2Point operator -(
D2Point p1,
D2Vector v
);

Parameters

p1
v

Return Value

See Also

D2Point Class | Aveva.Pdms.Maths.Geometry Namespace | D2PointSubtraction Operator Overload List


D2PointFactory Interface

D2PointFactory

public interface D2PointFactory

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine Class

2-D polyline sequence of straight line segments connected end to end

For a list of all members of this type, see D2PolyLine Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2PolyLine

public abstract class D2PolyLine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2PolyLine Members | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine Members

D2PolyLine overview

Public Static Methods

Create Overloaded. Null constructor

Public Static Operators

Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right

Public Instance Methods

AddPolyLine | Add a new polyline to the end
AddVertex | Donate a vertex (heap allocated)
Clone | deep copy
Equals | Overloaded. test for equality
First | Return the start point
GetHashCode | overrides gethashcode
GetType (inherited from Object) | Gets the Type of the current instance.
HasNoVertices | Return true if there are no vertices
InsertVertexAt | Add a new vertex at position i
Last | Return the end point
MinMaxBox | Return a bounding box
MoveBy | Move the whole polyline by given x,y offsets
NumberOfVertices | Return the number of vertices on the polyline
RemoveAll | Remove all spans from the polyline
RemoveLastVertex | Remove the last vertex
Reverse | Reverse the direction of the polyline
RotateBy | Rotate polyline about origin
SelfIntersecting | Returns true if one span of the polyline intersects another
SetVertex | Set the ith vertex to the given point
ToString | Returns a string describing the contents of the polyline
Vertex | Return the position of the ith vertex

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine Methods

The methods of the D2PolyLine class are listed below. For a complete list of D2PolyLine class members, see the D2PolyLine Members topic.

Public Static Methods

Create Overloaded. Null constructor

Public Instance Methods

AddPolyLine | Add a new polyline to the end
AddVertex | Donate a vertex (heap allocated)
Clone | deep copy
Equals | Overloaded. test for equality
First | Return the start point
GetHashCode | overrides gethashcode
GetType (inherited from Object) | Gets the Type of the current instance.
HasNoVertices | Return true if there are no vertices
InsertVertexAt | Add a new vertex at position i
Last | Return the end point
MinMaxBox | Return a bounding box
MoveBy | Move the whole polyline by given x,y offsets
NumberOfVertices | Return the number of vertices on the polyline
RemoveAll | Remove all spans from the polyline
RemoveLastVertex | Remove the last vertex
Reverse | Reverse the direction of the polyline
RotateBy | Rotate polyline about origin
SelfIntersecting | Returns true if one span of the polyline intersects another
SetVertex | Set the ith vertex to the given point
ToString | Returns a string describing the contents of the polyline
Vertex | Return the position of the ith vertex

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.AddPolyLine Method

Add a new polyline to the end

public abstract D2PolyLine AddPolyLine(
D2PolyLine line
);

Parameters

line

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.AddVertex Method

Donate a vertex (heap allocated)

public abstract void AddVertex(
D2Point vertex
);

Parameters

vertex

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.Clone Method

deep copy

public abstract D2PolyLine Clone();

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2PolyLine.Create Method

Null constructor

Overload List

Null constructor

public static D2PolyLine Create();

Copy a polyLine

public static D2PolyLine Create(D2PolyLine);

Construct a polyline with size elements

public static D2PolyLine Create(int);

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.Create Method ()

Null constructor

public static D2PolyLine Create();

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2PolyLine.Create Overload List


D2PolyLine.Create Method (D2PolyLine)

Copy a polyLine

public static D2PolyLine Create(
D2PolyLine line
);

Parameters

line

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2PolyLine.Create Overload List


D2PolyLine.Create Method (Int32)

Construct a polyline with size elements

public static D2PolyLine Create(
int size
);

Parameters

size

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2PolyLine.Create Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2PolyLine.Equals Method

test for equality

Overload List

test for equality

public abstract bool Equals(D2PolyLine);

override equals

public override bool Equals(object);

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.Equals Method (D2PolyLine)

test for equality

public abstract bool Equals(
D2PolyLine d2
);

Parameters

d2

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2PolyLine.Equals Overload List


D2PolyLine.Equals Method (Object)

override equals

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace | D2PolyLine.Equals Overload List


D2PolyLine.First Method

Return the start point

public abstract D2Point First();

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.GetHashCode Method

overrides gethashcode

public override int GetHashCode();

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.HasNoVertices Method

Return true if there are no vertices

public abstract bool HasNoVertices();

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.InsertVertexAt Method

Add a new vertex at position i

public abstract void InsertVertexAt(
int i,
D2Point vertex
);

Parameters

i
vertex

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.Last Method

Return the end point

public abstract D2Point Last();

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.MinMaxBox Method

Return a bounding box

public abstract D2Limits MinMaxBox();

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.MoveBy Method

Move the whole polyline by given x,y offsets

public abstract void MoveBy(
double dx,
double dy
);

Parameters

dx
dy

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.NumberOfVertices Method

Return the number of vertices on the polyline

public abstract int NumberOfVertices();

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.RemoveAll Method

Remove all spans from the polyline

public abstract void RemoveAll();

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.RemoveLastVertex Method

Remove the last vertex

public abstract void RemoveLastVertex();

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.Reverse Method

Reverse the direction of the polyline

public abstract void Reverse();

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.RotateBy Method

Rotate polyline about origin

public abstract void RotateBy(
double angle
);

Parameters

angle

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.SelfIntersecting Method

Returns true if one span of the polyline intersects another

public abstract bool SelfIntersecting();

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.SetVertex Method

Set the ith vertex to the given point

public abstract void SetVertex(
int i,
D2Point point
);

Parameters

i
point

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.ToString Method

Returns a string describing the contents of the polyline

public abstract string ToString();

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine.Vertex Method

Return the position of the ith vertex

public abstract D2Point Vertex(
int i
);

Parameters

i

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine Operators

The operators of the D2PolyLine class are listed below. For a complete list of D2PolyLine class members, see the D2PolyLine Members topic.

Public Static Operators

Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right

See Also

D2PolyLine Class | D2PolyLine Members | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine Equality Operator

invoked by left == right

public static bool operator ==(
D2PolyLine left,
D2PolyLine right
);

Parameters

left
right

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2PolyLine Inequality Operator

invoked by left != right

public static bool operator !=(
D2PolyLine left,
D2PolyLine right
);

Parameters

left
right

Return Value

See Also

D2PolyLine Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile Class

2-D profile This class represents a sequence of spans connected end to end. Each span is either a finite straight line or a circular arc. The number of nodes for a profile is always one more than the number of spans. A closed profile is represented by having the last node equal to the first. The constructors (apart from the copy constructor) generate an 'open-ended' profile consisting of a single node and with no spans. (If the first node is not known when the constructor is invoked, it can be set later by calling setNode() .) The function addSpan() should be called succesively to extend an open-ended profile one span at a time. The function close() may be called to add the final span for what is to be a closed profile.

For a list of all members of this type, see D2Profile Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2Profile

public abstract class D2Profile

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2Profile Members | Aveva.Pdms.Maths.Geometry Namespace


D2Profile Members

D2Profile overview

Public Static Methods

Create Overloaded. Default constructor. constructs an 'open-ended' profile consisting of a single node at (0,0) and with no spans

Public Static Operators

Equality Operator | left == right
Inequality Operator | left != right

Public Instance Methods

AddSpan | Add a span to end to given point with given bulge factor
Area | Return the area enclosed by the profile
Clone | Creates a deep copy of the D2Profile
Close | Overloaded. Close the span with a straight line (bulge = 0)
Equals | Overloaded. test for equality
GetAllSpans | Return a vector containing all the spans
GetApproxPolyLine | Return a polyline which approximates the profile
GetBulge | Return the ith bulge factor
GetFirstNode | Return the first node
GetHashCode |
GetLastNode | Return the last node
GetNode | Return the i'th node
GetSpan | Return the i'th span
GetType (inherited from Object) | Gets the Type of the current instance.
MinMaxBox | Return limits box of profile
MirrorX | Overloaded. Reflect profile in X about pivot
MirrorY | Overloaded. Reflect profile in Y about pivot
MoveBy | Move the profile along the given vector
NumberOfBulges | Return number of bulges in profile
NumberOfNodes | Return number of nodes in profile
NumberOfSpans | Return number of spans in profile
Reverse | Reverse direction of profile
RotateBy | Overloaded. Rotate the profile about the pivot by given angle
ScaleBy | Overloaded. Scale profile by given amount about pivot
SetBulge | Set the i'th bulge factor to given value
SetNode | Set the ith node to the given point
ToString | Returns a string describing the contents of the D2profile
WithoutDuplicatePoints | Return a new profile which is a copy of this profile but without any duplicate points

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile Methods

The methods of the D2Profile class are listed below. For a complete list of D2Profile class members, see the D2Profile Members topic.

Public Static Methods

Create Overloaded. Default constructor. constructs an 'open-ended' profile consisting of a single node at (0,0) and with no spans

Public Instance Methods

AddSpan | Add a span to end to given point with given bulge factor
Area | Return the area enclosed by the profile
Clone | Creates a deep copy of the D2Profile
Close | Overloaded. Close the span with a straight line (bulge = 0)
Equals | Overloaded. test for equality
GetAllSpans | Return a vector containing all the spans
GetApproxPolyLine | Return a polyline which approximates the profile
GetBulge | Return the ith bulge factor
GetFirstNode | Return the first node
GetHashCode |
GetLastNode | Return the last node
GetNode | Return the i'th node
GetSpan | Return the i'th span
GetType (inherited from Object) | Gets the Type of the current instance.
MinMaxBox | Return limits box of profile
MirrorX | Overloaded. Reflect profile in X about pivot
MirrorY | Overloaded. Reflect profile in Y about pivot
MoveBy | Move the profile along the given vector
NumberOfBulges | Return number of bulges in profile
NumberOfNodes | Return number of nodes in profile
NumberOfSpans | Return number of spans in profile
Reverse | Reverse direction of profile
RotateBy | Overloaded. Rotate the profile about the pivot by given angle
ScaleBy | Overloaded. Scale profile by given amount about pivot
SetBulge | Set the i'th bulge factor to given value
SetNode | Set the ith node to the given point
ToString | Returns a string describing the contents of the D2profile
WithoutDuplicatePoints | Return a new profile which is a copy of this profile but without any duplicate points

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.AddSpan Method

Add a span to end to given point with given bulge factor

public abstract void AddSpan(
double bulge,
D2Point node
);

Parameters

bulge
node

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.Area Method

Return the area enclosed by the profile

public abstract double Area();

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.Clone Method

Creates a deep copy of the D2Profile

public abstract D2Profile Clone();

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


Close Method

AVEVA Maths / Geometry .NET Public Interface

D2Profile.Close Method

Close the span with a straight line (bulge = 0)

Overload List

Close the span with a straight line (bulge = 0)

public abstract void Close();

Close the profile with a span with given bulge

public abstract void Close(double);

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.Close Method ()

Close the span with a straight line (bulge = 0)

public abstract void Close();

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.Close Overload List


D2Profile.Close Method (Double)

Close the profile with a span with given bulge

public abstract void Close(
double bulge
);

Parameters

bulge

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.Close Overload List


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2Profile.Create Method

Default constructor. constructs an 'open-ended' profile consisting of a single node at (0,0) and with no spans

Overload List

Default constructor. constructs an 'open-ended' profile consisting of a single node at (0,0) and with no spans

public static D2Profile Create();

Create an open-ended profile with a single node and no spans

public static D2Profile Create(D2Point);

constructs an 'open-ended' profile consisting of a single node and with no spans; for efficiency, the argument 'nspans' can be used to reserve space internally for the appropriate number of spans (it is not an error if the value is not correct)

public static D2Profile Create(D2Point,int);

Copy a profile

public static D2Profile Create(D2Profile);

Construct a profile with space for nspans spans

public static D2Profile Create(int);

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.Create Method ()

Default constructor. constructs an 'open-ended' profile consisting of a single node at (0,0) and with no spans

public static D2Profile Create();

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.Create Overload List


D2Profile.Create Method (D2Point)

Create an open-ended profile with a single node and no spans

public static D2Profile Create(
D2Point node
);

Parameters

node

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.Create Overload List


D2Profile.Create Method (D2Point, Int32)

constructs an 'open-ended' profile consisting of a single node and with no spans; for efficiency, the argument 'nspans' can be used to reserve space internally for the appropriate number of spans (it is not an error if the value is not correct)

public static D2Profile Create(
D2Point node,
int nspans
);

Parameters

node
nspans

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.Create Overload List


D2Profile.Create Method (D2Profile)

Copy a profile

public static D2Profile Create(
D2Profile pro
);

Parameters

pro

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.Create Overload List


D2Profile.Create Method (Int32)

Construct a profile with space for nspans spans

public static D2Profile Create(
int nspans
);

Parameters

nspans

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.Create Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2Profile.Equals Method

test for equality

Overload List

test for equality

public abstract bool Equals(D2Profile);

public override bool Equals(object);

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.Equals Method (D2Profile)

test for equality

public abstract bool Equals(
D2Profile d2
);

Parameters

d2

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.Equals Overload List


D2Profile.Equals Method (Object)

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.Equals Overload List


D2Profile.GetAllSpans Method

Return a vector containing all the spans

public abstract D2Span[] GetAllSpans();

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.GetApproxPolyLine Method

Return a polyline which approximates the profile

public abstract D2PolyLine GetApproxPolyLine(
double tol
);

Parameters

tol

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.GetBulge Method

Return the ith bulge factor

public abstract double GetBulge(
int i
);

Parameters

i

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.GetFirstNode Method

Return the first node

public abstract D2Point GetFirstNode();

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.GetLastNode Method

Return the last node

public abstract D2Point GetLastNode();

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.GetNode Method

Return the i'th node

public abstract D2Point GetNode(
int i
);

Parameters

i

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.GetSpan Method

Return the i'th span

public abstract D2Span GetSpan(
int i
);

Parameters

i

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.MinMaxBox Method

Return limits box of profile

public abstract D2Limits MinMaxBox();

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


MirrorX Method

AVEVA Maths / Geometry .NET Public Interface

D2Profile.MirrorX Method

Reflect profile in X about origin

Overload List

Reflect profile in X about origin

public abstract void MirrorX();

Reflect profile in X about pivot

public abstract void MirrorX(D2Point);

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.MirrorX Method ()

Reflect profile in X about origin

public abstract void MirrorX();

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.MirrorX Overload List


D2Profile.MirrorX Method (D2Point)

Reflect profile in X about pivot

public abstract void MirrorX(
D2Point pivot
);

Parameters

pivot

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.MirrorX Overload List


MirrorY Method

AVEVA Maths / Geometry .NET Public Interface

D2Profile.MirrorY Method

Reflect profile in Y about origin

Overload List

Reflect profile in Y about origin

public abstract void MirrorY();

Reflect profile in Y about pivot

public abstract void MirrorY(D2Point);

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.MirrorY Method ()

Reflect profile in Y about origin

public abstract void MirrorY();

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.MirrorY Overload List


D2Profile.MirrorY Method (D2Point)

Reflect profile in Y about pivot

public abstract void MirrorY(
D2Point pivot
);

Parameters

pivot

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.MirrorY Overload List


D2Profile.MoveBy Method

Move the profile along the given vector

public abstract void MoveBy(
D2Vector v
);

Parameters

v

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.NumberOfBulges Method

Return number of bulges in profile

public abstract int NumberOfBulges();

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.NumberOfNodes Method

Return number of nodes in profile

public abstract int NumberOfNodes();

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.NumberOfSpans Method

Return number of spans in profile

public abstract int NumberOfSpans();

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.Reverse Method

Reverse direction of profile

public abstract void Reverse();

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


RotateBy Method

AVEVA Maths / Geometry .NET Public Interface

D2Profile.RotateBy Method

Rotate profile about the origin by given angle

Overload List

Rotate profile about the origin by given angle

public abstract void RotateBy(double);

Rotate the profile about the pivot by given angle

public abstract void RotateBy(double,D2Point);

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.RotateBy Method (Double)

Rotate profile about the origin by given angle

public abstract void RotateBy(
double angle
);

Parameters

angle

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.RotateBy Overload List


D2Profile.RotateBy Method (Double, D2Point)

Rotate the profile about the pivot by given angle

public abstract void RotateBy(
double angle,
D2Point pivot
);

Parameters

angle
pivot

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.RotateBy Overload List


ScaleBy Method

AVEVA Maths / Geometry .NET Public Interface

D2Profile.ScaleBy Method

Scale profile uniformly by given amount

Overload List

Scale profile uniformly by given amount

public abstract void ScaleBy(double);

Scale profile by given amount about pivot

public abstract void ScaleBy(double,D2Point);

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.ScaleBy Method (Double)

Scale profile uniformly by given amount

public abstract void ScaleBy(
double s
);

Parameters

s

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.ScaleBy Overload List


D2Profile.ScaleBy Method (Double, D2Point)

Scale profile by given amount about pivot

public abstract void ScaleBy(
double s,
D2Point pivot
);

Parameters

s
pivot

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace | D2Profile.ScaleBy Overload List


D2Profile.SetBulge Method

Set the i'th bulge factor to given value

public abstract void SetBulge(
int i,
double bulge
);

Parameters

i
bulge

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.SetNode Method

Set the ith node to the given point

public abstract void SetNode(
int i,
D2Point node
);

Parameters

i
node

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.ToString Method

Returns a string describing the contents of the D2profile

public abstract string ToString();

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile.WithoutDuplicatePoints Method

Return a new profile which is a copy of this profile but without any duplicate points

public abstract D2Profile WithoutDuplicatePoints();

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile Operators

The operators of the D2Profile class are listed below. For a complete list of D2Profile class members, see the D2Profile Members topic.

Public Static Operators

Equality Operator | left == right
Inequality Operator | left != right

See Also

D2Profile Class | D2Profile Members | Aveva.Pdms.Maths.Geometry Namespace


D2Profile Equality Operator

left == right

public static bool operator ==(
D2Profile left,
D2Profile right
);

Parameters

left
right

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2Profile Inequality Operator

left != right

public static bool operator !=(
D2Profile left,
D2Profile right
);

Parameters

left
right

Return Value

See Also

D2Profile Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid Class

Class definition of a Regular Cartesian Grid. The x and y spacings must be non-zero and positive for this type of grid to be valid.

For a list of all members of this type, see D2RegularCartesianGrid Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2RegularCartesianGrid

public abstract class D2RegularCartesianGrid

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2RegularCartesianGrid Members | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid Members

D2RegularCartesianGrid overview

Public Static Methods

Create Overloaded. Default constructor of an empty grid

Public Static Operators

Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right

Public Instance Methods

Clone | Returns a deep copy of the D2RegularCartesianGrid
Equals | Overloaded. check for equality
GetGridPoint | Returns point at grid intersection (i,j).
GetHashCode |
GetPlane | Returns the plane of the grid
GetType (inherited from Object) | Gets the Type of the current instance.
GetXSpacing | Returns the X spacing of the grid
GetYSpacing | Returns the Y spacing of the grid
GridValidity | Return true if grid is valid
LocateControlPoint | Locates control point for use in snapping routines
SetData | Returns the plane of the grid, and the x/y spacings
SetXSpacing | Set the X spacing of the grid to given value
SetYSpacing | Set the y spacing of the grid to given value
SnapToCentre | Returns centre of grid closest to given point
SnapToPoint | Returns point on grid closest to given point
ToString | Returns a string describing the values of the D2RegularCartesianGrid

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid Methods

The methods of the D2RegularCartesianGrid class are listed below. For a complete list of D2RegularCartesianGrid class members, see the D2RegularCartesianGrid Members topic.

Public Static Methods

Create Overloaded. Default constructor of an empty grid

Public Instance Methods

Clone | Returns a deep copy of the D2RegularCartesianGrid
Equals | Overloaded. check for equality
GetGridPoint | Returns point at grid intersection (i,j).
GetHashCode |
GetPlane | Returns the plane of the grid
GetType (inherited from Object) | Gets the Type of the current instance.
GetXSpacing | Returns the X spacing of the grid
GetYSpacing | Returns the Y spacing of the grid
GridValidity | Return true if grid is valid
LocateControlPoint | Locates control point for use in snapping routines
SetData | Returns the plane of the grid, and the x/y spacings
SetXSpacing | Set the X spacing of the grid to given value
SetYSpacing | Set the y spacing of the grid to given value
SnapToCentre | Returns centre of grid closest to given point
SnapToPoint | Returns point on grid closest to given point
ToString | Returns a string describing the values of the D2RegularCartesianGrid

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid.Clone Method

Returns a deep copy of the D2RegularCartesianGrid

public abstract D2RegularCartesianGrid Clone();

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2RegularCartesianGrid.Create Method

Default constructor of an empty grid

Overload List

Default constructor of an empty grid

public static D2RegularCartesianGrid Create();

Copy regular cartesian grid

public static D2RegularCartesianGrid Create(D2RegularCartesianGrid);

Construct an infinite grid from an oriented plane and x,y spacings

public static D2RegularCartesianGrid Create(D3OrientedPlane,double,double);

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid.Create Method ()

Default constructor of an empty grid

public static D2RegularCartesianGrid Create();

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace | D2RegularCartesianGrid.Create Overload List


D2RegularCartesianGrid.Create Method (D2RegularCartesianGrid)

Copy regular cartesian grid

public static D2RegularCartesianGrid Create(
D2RegularCartesianGrid g
);

Parameters

g

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace | D2RegularCartesianGrid.Create Overload List


D2RegularCartesianGrid.Create Method (D3OrientedPlane, Double, Double)

Construct an infinite grid from an oriented plane and x,y spacings

public static D2RegularCartesianGrid Create(
D3OrientedPlane plane,
double x_spacing,
double y_spacing
);

Parameters

plane
x_spacing
y_spacing

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace | D2RegularCartesianGrid.Create Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2RegularCartesianGrid.Equals Method

check for equality

Overload List

check for equality

public abstract bool Equals(D2RegularCartesianGrid);

public override bool Equals(object);

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid.Equals Method (D2RegularCartesianGrid)

check for equality

public abstract bool Equals(
D2RegularCartesianGrid g
);

Parameters

g

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace | D2RegularCartesianGrid.Equals Overload List


D2RegularCartesianGrid.Equals Method (Object)

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace | D2RegularCartesianGrid.Equals Overload List


D2RegularCartesianGrid.GetGridPoint Method

Returns point at grid intersection (i,j).

public abstract bool GetGridPoint(
int i,
int j,
D2Point p
);

Parameters

i
j
p

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid.GetPlane Method

Returns the plane of the grid

public abstract D3OrientedPlane GetPlane();

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid.GetXSpacing Method

Returns the X spacing of the grid

public abstract double GetXSpacing();

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid.GetYSpacing Method

Returns the Y spacing of the grid

public abstract double GetYSpacing();

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid.GridValidity Method

Return true if grid is valid

public abstract bool GridValidity();

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid.LocateControlPoint Method

Locates control point for use in snapping routines

public abstract void LocateControlPoint(
D2Point p,
ref int i,
ref int j
);

Parameters

p
i
j

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid.SetData Method

Returns the plane of the grid, and the x/y spacings

public abstract void SetData(
D3OrientedPlane plane,
double xs,
double ys
);

Parameters

plane
xs
ys

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid.SetXSpacing Method

Set the X spacing of the grid to given value

public abstract void SetXSpacing(
double x
);

Parameters

x

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid.SetYSpacing Method

Set the y spacing of the grid to given value

public abstract void SetYSpacing(
double y
);

Parameters

y

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid.SnapToCentre Method

Returns centre of grid closest to given point

public abstract bool SnapToCentre(
D2Point p,
D2Point c
);

Parameters

p
c

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid.SnapToPoint Method

Returns point on grid closest to given point

public abstract bool SnapToPoint(
D2Point p,
D2Point sp
);

Parameters

p
sp

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid.ToString Method

Returns a string describing the values of the D2RegularCartesianGrid

public abstract string ToString();

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid Operators

The operators of the D2RegularCartesianGrid class are listed below. For a complete list of D2RegularCartesianGrid class members, see the D2RegularCartesianGrid Members topic.

Public Static Operators

Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right

See Also

D2RegularCartesianGrid Class | D2RegularCartesianGrid Members | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid Equality Operator

invoked by left == right

public static bool operator ==(
D2RegularCartesianGrid left,
D2RegularCartesianGrid right
);

Parameters

left
right

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2RegularCartesianGrid Inequality Operator

invoked by left != right

public static bool operator !=(
D2RegularCartesianGrid left,
D2RegularCartesianGrid right
);

Parameters

left
right

Return Value

See Also

D2RegularCartesianGrid Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span Class

Span class - consists of a line or arc, and is used by D2Profile

For a list of all members of this type, see D2Span Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2Span

public abstract class D2Span

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2Span Members | Aveva.Pdms.Maths.Geometry Namespace


D2Span Members

D2Span overview

Public Static Methods

Create Overloaded. default span

Public Static Operators

Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right

Public Instance Methods

Clone | Creates a deep copy of the D2Span
Complement | Convert the span into the complementary arc
Equals | Overloaded. test for equality
EvaluateDeriv | Return the tangent on span which is at point proportion uarg from start
EvaluatePoint | Return a point on span which is proportion uarg from start
FacetToTol | approximate polygon
GetAlpha0 | Return the angular position of the start of the span
GetAlpha1 | Return the angular position of the end of the span
GetApproxPolyLine | Convert arc to polylines
GetApproxPolyLineInSteps | Convert arc to polylines
GetAreaUnder | Return the area under the span
GetBulge | Return the bulge factor
GetCentre | Return the centre point of the span
GetEndNearest | Return the end of the span which is nearest to the given point
GetFirst | Return the first point on the span
GetFirstX | Return the X coordinate of the start point of the span
GetFirstY | Return the Y coordinate of the start point of the span
GetHashCode |
GetLast | Return the last point of the span
GetLastX | Return the X coordinate of the last point of the span
GetLastY | Return the Y coordinate of the last point of the span
GetLength | Return the length of the span
GetMidPoint | Return the mid point of the span
GetRadius | Return the radius of the span
GetType (inherited from Object) | Gets the Type of the current instance.
IsNull | Return true if span is empty
IsStraight | returns true if the bulge ratio has a magnitude less than 0.0000306 ; i.e. the angle is less than 0.0001224 radians (0.007013 degrees)
LeadsSmoothlyTo | returns true if the directions at the end of the local span and at the start of the span named "next" are within 0.001414 radians (0.08103 degrees) of each other
MinMaxBox | Return containment box
MoveBy | Move span by given vector
Offset | Incremental move of span
Reverse | Reverse direction of span
RotateBy | Overloaded. Rotate the span by given angle about pivot
SetBulge | Set the bulge factor of the span
SetFirst | Set the position of the start of the arc
SetLast | Set the position of the end of the arc
SetValue | Set start, end positions and bulge factor
ToString | Returns a string describing the contents of the D2Span

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span Methods

The methods of the D2Span class are listed below. For a complete list of D2Span class members, see the D2Span Members topic.

Public Static Methods

Create Overloaded. default span

Public Instance Methods

Clone | Creates a deep copy of the D2Span
Complement | Convert the span into the complementary arc
Equals | Overloaded. test for equality
EvaluateDeriv | Return the tangent on span which is at point proportion uarg from start
EvaluatePoint | Return a point on span which is proportion uarg from start
FacetToTol | approximate polygon
GetAlpha0 | Return the angular position of the start of the span
GetAlpha1 | Return the angular position of the end of the span
GetApproxPolyLine | Convert arc to polylines
GetApproxPolyLineInSteps | Convert arc to polylines
GetAreaUnder | Return the area under the span
GetBulge | Return the bulge factor
GetCentre | Return the centre point of the span
GetEndNearest | Return the end of the span which is nearest to the given point
GetFirst | Return the first point on the span
GetFirstX | Return the X coordinate of the start point of the span
GetFirstY | Return the Y coordinate of the start point of the span
GetHashCode |
GetLast | Return the last point of the span
GetLastX | Return the X coordinate of the last point of the span
GetLastY | Return the Y coordinate of the last point of the span
GetLength | Return the length of the span
GetMidPoint | Return the mid point of the span
GetRadius | Return the radius of the span
GetType (inherited from Object) | Gets the Type of the current instance.
IsNull | Return true if span is empty
IsStraight | returns true if the bulge ratio has a magnitude less than 0.0000306 ; i.e. the angle is less than 0.0001224 radians (0.007013 degrees)
LeadsSmoothlyTo | returns true if the directions at the end of the local span and at the start of the span named "next" are within 0.001414 radians (0.08103 degrees) of each other
MinMaxBox | Return containment box
MoveBy | Move span by given vector
Offset | Incremental move of span
Reverse | Reverse direction of span
RotateBy | Overloaded. Rotate the span by given angle about pivot
SetBulge | Set the bulge factor of the span
SetFirst | Set the position of the start of the arc
SetLast | Set the position of the end of the arc
SetValue | Set start, end positions and bulge factor
ToString | Returns a string describing the contents of the D2Span

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.Clone Method

Creates a deep copy of the D2Span

public abstract D2Span Clone();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.Complement Method

Convert the span into the complementary arc

public abstract void Complement();

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2Span.Create Method

default span

Overload List

default span

public static D2Span Create();

Create from 3 points

public static D2Span Create(D2Point,D2Point,D2Point);

Create from start and end points, and a bulge factor

public static D2Span Create(D2Point,double,D2Point);

copy constructor

public static D2Span Create(D2Span);

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.Create Method ()

default span

public static D2Span Create();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace | D2Span.Create Overload List


D2Span.Create Method (D2Point, D2Point, D2Point)

Create from 3 points

public static D2Span Create(
D2Point a,
D2Point b,
D2Point c
);

Parameters

a
b
c

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace | D2Span.Create Overload List


D2Span.Create Method (D2Point, Double, D2Point)

Create from start and end points, and a bulge factor

public static D2Span Create(
D2Point p,
double b,
D2Point q
);

Parameters

p
b
q

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace | D2Span.Create Overload List


D2Span.Create Method (D2Span)

copy constructor

public static D2Span Create(
D2Span a
);

Parameters

a

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace | D2Span.Create Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2Span.Equals Method

test for equality

Overload List

test for equality

public abstract bool Equals(D2Span);

public override bool Equals(object);

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.Equals Method (D2Span)

test for equality

public abstract bool Equals(
D2Span d2
);

Parameters

d2

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace | D2Span.Equals Overload List


D2Span.Equals Method (Object)

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace | D2Span.Equals Overload List


D2Span.EvaluateDeriv Method

Return the tangent on span which is at point proportion uarg from start

public abstract D2Vector EvaluateDeriv(
double uarg
);

Parameters

uarg
Value between 0 1nd 1

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.EvaluatePoint Method

Return a point on span which is proportion uarg from start

public abstract D2Point EvaluatePoint(
double uarg
);

Parameters

uarg
Value between 0 and 1

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.FacetToTol Method

approximate polygon

public abstract D2PolyLine FacetToTol(
double tol
);

Parameters

tol

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetAlpha0 Method

Return the angular position of the start of the span

public abstract double GetAlpha0();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetAlpha1 Method

Return the angular position of the end of the span

public abstract double GetAlpha1();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetApproxPolyLine Method

Convert arc to polylines

public abstract D2PolyLine GetApproxPolyLine(
double tol
);

Parameters

tol

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetApproxPolyLineInSteps Method

Convert arc to polylines

public abstract D2PolyLine GetApproxPolyLineInSteps(
int nSteps
);

Parameters

nSteps

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetAreaUnder Method

Return the area under the span

public abstract double GetAreaUnder();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetBulge Method

Return the bulge factor

public abstract double GetBulge();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetCentre Method

Return the centre point of the span

public abstract D2Point GetCentre();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetEndNearest Method

Return the end of the span which is nearest to the given point

public abstract D2Point GetEndNearest(
D2Point p
);

Parameters

p
Reference point

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetFirst Method

Return the first point on the span

public abstract D2Point GetFirst();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetFirstX Method

Return the X coordinate of the start point of the span

public abstract double GetFirstX();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetFirstY Method

Return the Y coordinate of the start point of the span

public abstract double GetFirstY();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetLast Method

Return the last point of the span

public abstract D2Point GetLast();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetLastX Method

Return the X coordinate of the last point of the span

public abstract double GetLastX();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetLastY Method

Return the Y coordinate of the last point of the span

public abstract double GetLastY();

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetLength Method

Return the length of the span

public abstract double GetLength();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetMidPoint Method

Return the mid point of the span

public abstract D2Point GetMidPoint();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.GetRadius Method

Return the radius of the span

public abstract double GetRadius();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.IsNull Method

Return true if span is empty

public abstract bool IsNull();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.IsStraight Method

returns true if the bulge ratio has a magnitude less than 0.0000306 ; i.e. the angle is less than 0.0001224 radians (0.007013 degrees)

public abstract bool IsStraight();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.LeadsSmoothlyTo Method

returns true if the directions at the end of the local span and at the start of the span named "next" are within 0.001414 radians (0.08103 degrees) of each other

public abstract bool LeadsSmoothlyTo(
D2Span next
);

Parameters

next

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.MinMaxBox Method

Return containment box

public abstract D2Limits MinMaxBox();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.MoveBy Method

Move span by given vector

public abstract void MoveBy(
D2Vector v
);

Parameters

v

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.Offset Method

Incremental move of span

public abstract void Offset(
double dist
);

Parameters

dist

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.Reverse Method

Reverse direction of span

public abstract void Reverse();

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


RotateBy Method

AVEVA Maths / Geometry .NET Public Interface

D2Span.RotateBy Method

Rotate span by given angle about the origin

Overload List

Rotate span by given angle about the origin

public abstract void RotateBy(double);

Rotate the span by given angle about pivot

public abstract void RotateBy(double,D2Point);

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.RotateBy Method (Double)

Rotate span by given angle about the origin

public abstract void RotateBy(
double angle
);

Parameters

angle

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace | D2Span.RotateBy Overload List


D2Span.RotateBy Method (Double, D2Point)

Rotate the span by given angle about pivot

public abstract void RotateBy(
double angle,
D2Point pivot
);

Parameters

angle
pivot

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace | D2Span.RotateBy Overload List


D2Span.SetBulge Method

Set the bulge factor of the span

public abstract void SetBulge(
double b
);

Parameters

b

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.SetFirst Method

Set the position of the start of the arc

public abstract void SetFirst(
D2Point p
);

Parameters

p

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.SetLast Method

Set the position of the end of the arc

public abstract void SetLast(
D2Point p
);

Parameters

p

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.SetValue Method

Set start, end positions and bulge factor

public abstract void SetValue(
D2Point s,
double b,
D2Point e
);

Parameters

s
b
e

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span.ToString Method

Returns a string describing the contents of the D2Span

public abstract string ToString();

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span Operators

The operators of the D2Span class are listed below. For a complete list of D2Span class members, see the D2Span Members topic.

Public Static Operators

Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right

See Also

D2Span Class | D2Span Members | Aveva.Pdms.Maths.Geometry Namespace


D2Span Equality Operator

invoked by left == right

public static bool operator ==(
D2Span left,
D2Span right
);

Parameters

left
right

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Span Inequality Operator

invoked by left != right

public static bool operator !=(
D2Span left,
D2Span right
);

Parameters

left
right

Return Value

See Also

D2Span Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform Class

D2Transform - solid body transformations

For a list of all members of this type, see D2Transform Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2Transform

public abstract class D2Transform

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2Transform Members | Aveva.Pdms.Maths.Geometry Namespace


D2Transform Members

D2Transform overview

Public Static Methods

Create Overloaded. Default

Public Static Operators

Equality Operator | true if transforms match exactly
Inequality Operator | true if transforms do not match exactly
Multiplication Operator | resultant transform is equivalent to apply both tranformations.

Public Instance Methods

AsArray6 | return transformation as an array of number
BeIdentity | set transform to be a null rotation and null shift
Clone | deep copy
Determinant | return determinant of rotation matrix
Equals | Overloaded. Test for equality
GetHashCode | gethashcode
GetInverse | finds inverse transformation - returns "true" and sets result if successful; returns false and result remains unaltered for a singular rotation matrix
GetRot | return rotation matrix
GetShift | return shift part of transformation
GetType (inherited from Object) | Gets the Type of the current instance.
Inverse | Return inverse transformation - returns null transformation if the original transformation is singular
Invert | invert transformation - returns "true" if successful; returns false and remains unaltered in the case of a singular transformation
IsIdentity | true if rotation is Identity matrix (ie no rotation) AND shift is zero
IsOrthogonal | TRUE if rotation matrix is Orthogonal (within tolerance)
IsSingular | result predicts failure of getInverse()/inverse()/invert()
Map | Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - point posFrom is mapped onto posTo, and - vector vecFrom is mapped onto vecTo.
MapOriXTo | Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - the origin is mapped onto pos, and - the x-axis is mapped onto vec.
MoveBy | Overloaded. add v vector to shift vector of the transform
Multiply | Overloaded. Multiply two transforms
RotateByDegrees | rotate transformation (rotation matrix and shift vector) by given number of degrees
RotateByRadians | rotate transformation (rotation matrix and shift vector) by given number of radians
SetValues | set transform from an array of 6 numbers ( rotation(4) followed by shift(2) )
TakeToXAxis | Make the transform take the given vector to the x axis
TakeToYAxis | Make the transform take the given vector to the y axis
ToString | Returns a string describing the contents of the D2Transform

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform Methods

The methods of the D2Transform class are listed below. For a complete list of D2Transform class members, see the D2Transform Members topic.

Public Static Methods

Create Overloaded. Default

Public Instance Methods

AsArray6 | return transformation as an array of number
BeIdentity | set transform to be a null rotation and null shift
Clone | deep copy
Determinant | return determinant of rotation matrix
Equals | Overloaded. Test for equality
GetHashCode | gethashcode
GetInverse | finds inverse transformation - returns "true" and sets result if successful; returns false and result remains unaltered for a singular rotation matrix
GetRot | return rotation matrix
GetShift | return shift part of transformation
GetType (inherited from Object) | Gets the Type of the current instance.
Inverse | Return inverse transformation - returns null transformation if the original transformation is singular
Invert | invert transformation - returns "true" if successful; returns false and remains unaltered in the case of a singular transformation
IsIdentity | true if rotation is Identity matrix (ie no rotation) AND shift is zero
IsOrthogonal | TRUE if rotation matrix is Orthogonal (within tolerance)
IsSingular | result predicts failure of getInverse()/inverse()/invert()
Map | Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - point posFrom is mapped onto posTo, and - vector vecFrom is mapped onto vecTo.
MapOriXTo | Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - the origin is mapped onto pos, and - the x-axis is mapped onto vec.
MoveBy | Overloaded. add v vector to shift vector of the transform
Multiply | Overloaded. Multiply two transforms
RotateByDegrees | rotate transformation (rotation matrix and shift vector) by given number of degrees
RotateByRadians | rotate transformation (rotation matrix and shift vector) by given number of radians
SetValues | set transform from an array of 6 numbers ( rotation(4) followed by shift(2) )
TakeToXAxis | Make the transform take the given vector to the x axis
TakeToYAxis | Make the transform take the given vector to the y axis
ToString | Returns a string describing the contents of the D2Transform

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.AsArray6 Method

return transformation as an array of number

public abstract double[] AsArray6();

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.BeIdentity Method

set transform to be a null rotation and null shift

public abstract void BeIdentity();

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.Clone Method

deep copy

public abstract D2Transform Clone();

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2Transform.Create Method

Default

Overload List

Default

public static D2Transform Create();

Construct a transform from rotation matrix and shift vector

public static D2Transform Create(D2Matrix,D2Vector);

Copy constructor

public static D2Transform Create(D2Transform);

Construct a transfrom from given 6 values (by row)

public static D2Transform Create(double[]);

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.Create Method ()

Default

public static D2Transform Create();

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D2Transform.Create Overload List


D2Transform.Create Method (D2Matrix, D2Vector)

Construct a transform from rotation matrix and shift vector

public static D2Transform Create(
D2Matrix theRot,
D2Vector theShift
);

Parameters

theRot
theShift

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D2Transform.Create Overload List


D2Transform.Create Method (D2Transform)

Copy constructor

public static D2Transform Create(
D2Transform transform
);

Parameters

transform

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D2Transform.Create Overload List


D2Transform.Create Method (Double[])

Construct a transfrom from given 6 values (by row)

public static D2Transform Create(
double[] v
);

Parameters

v

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D2Transform.Create Overload List


D2Transform.Determinant Method

return determinant of rotation matrix

public abstract double Determinant();

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2Transform.Equals Method

Test for equality

Overload List

Test for equality

public abstract bool Equals(D2Transform);

equals method

public override bool Equals(object);

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.Equals Method (D2Transform)

Test for equality

public abstract bool Equals(
D2Transform d2
);

Parameters

d2

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D2Transform.Equals Overload List


D2Transform.Equals Method (Object)

equals method

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D2Transform.Equals Overload List


D2Transform.GetHashCode Method

gethashcode

public override int GetHashCode();

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.GetInverse Method

finds inverse transformation - returns "true" and sets result if successful; returns false and result remains unaltered for a singular rotation matrix

public abstract bool GetInverse(
D2Transform result
);

Parameters

result

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.GetRot Method

return rotation matrix

public abstract D2Matrix GetRot();

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.GetShift Method

return shift part of transformation

public abstract D2Vector GetShift();

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.Inverse Method

Return inverse transformation - returns null transformation if the original transformation is singular

public abstract D2Transform Inverse();

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.Invert Method

invert transformation - returns "true" if successful; returns false and remains unaltered in the case of a singular transformation

public abstract bool Invert();

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.IsIdentity Method

true if rotation is Identity matrix (ie no rotation) AND shift is zero

public abstract bool IsIdentity();

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.IsOrthogonal Method

TRUE if rotation matrix is Orthogonal (within tolerance)

public abstract bool IsOrthogonal(
double tol
);

Parameters

tol

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.IsSingular Method

result predicts failure of getInverse()/inverse()/invert()

public abstract bool IsSingular();

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.Map Method

Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - point posFrom is mapped onto posTo, and - vector vecFrom is mapped onto vecTo.

public abstract bool Map(
D2Point posFrom,
D2Point posTo,
D2Vector vecFrom,
D2Vector vecTo
);

Parameters

posFrom
posTo
vecFrom
vecTo

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.MapOriXTo Method

Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - the origin is mapped onto pos, and - the x-axis is mapped onto vec.

public abstract bool MapOriXTo(
D2Point pos,
D2Vector vec
);

Parameters

pos
vec

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


MoveBy Method

AVEVA Maths / Geometry .NET Public Interface

D2Transform.MoveBy Method

add v vector to shift vector of the transform

Overload List

add v vector to shift vector of the transform

public abstract void MoveBy(D2Vector);

add (x,y) vector to shift vector of the transform

public abstract void MoveBy(double,double);

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.MoveBy Method (D2Vector)

add v vector to shift vector of the transform

public abstract void MoveBy(
D2Vector v
);

Parameters

v

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D2Transform.MoveBy Overload List


D2Transform.MoveBy Method (Double, Double)

add (x,y) vector to shift vector of the transform

public abstract void MoveBy(
double x,
double y
);

Parameters

x
y

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D2Transform.MoveBy Overload List


Multiply Method

AVEVA Maths / Geometry .NET Public Interface

D2Transform.Multiply Method

Multiply two transforms

Overload List

Multiply two transforms

public abstract D2Limits Multiply(D2Limits);

Multiply two transforms

public abstract D2Point Multiply(D2Point);

Multiply two transforms

public abstract D2Transform Multiply(D2Transform);

Multiply two transforms

public abstract D2Vector Multiply(D2Vector);

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.Multiply Method (D2Limits)

Multiply two transforms

public abstract D2Limits Multiply(
D2Limits lim2
);

Parameters

lim2

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D2Transform.Multiply Overload List


D2Transform.Multiply Method (D2Point)

Multiply two transforms

public abstract D2Point Multiply(
D2Point p2
);

Parameters

p2

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D2Transform.Multiply Overload List


D2Transform.Multiply Method (D2Transform)

Multiply two transforms

public abstract D2Transform Multiply(
D2Transform t2
);

Parameters

t2

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D2Transform.Multiply Overload List


D2Transform.Multiply Method (D2Vector)

Multiply two transforms

public abstract D2Vector Multiply(
D2Vector v2
);

Parameters

v2

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D2Transform.Multiply Overload List


D2Transform.RotateByDegrees Method

rotate transformation (rotation matrix and shift vector) by given number of degrees

public abstract void RotateByDegrees(
double degrees
);

Parameters

degrees

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.RotateByRadians Method

rotate transformation (rotation matrix and shift vector) by given number of radians

public abstract void RotateByRadians(
double radians
);

Parameters

radians

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.SetValues Method

set transform from an array of 6 numbers ( rotation(4) followed by shift(2) )

public abstract void SetValues(
double[] v
);

Parameters

v

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.TakeToXAxis Method

Make the transform take the given vector to the x axis

public abstract void TakeToXAxis(
D2Vector v
);

Parameters

v

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.TakeToYAxis Method

Make the transform take the given vector to the y axis

public abstract void TakeToYAxis(
D2Vector v
);

Parameters

v

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform.ToString Method

Returns a string describing the contents of the D2Transform

public abstract string ToString();

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform Operators

The operators of the D2Transform class are listed below. For a complete list of D2Transform class members, see the D2Transform Members topic.

Public Static Operators

Equality Operator | true if transforms match exactly
Inequality Operator | true if transforms do not match exactly
Multiplication Operator | resultant transform is equivalent to apply both tranformations.

See Also

D2Transform Class | D2Transform Members | Aveva.Pdms.Maths.Geometry Namespace


D2Transform Equality Operator

true if transforms match exactly

public static bool operator ==(
D2Transform left,
D2Transform right
);

Parameters

left
right

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform Inequality Operator

true if transforms do not match exactly

public static bool operator !=(
D2Transform left,
D2Transform right
);

Parameters

left
right

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Transform Multiplication Operator

resultant transform is equivalent to apply both tranformations.

public static D2Transform operator *(
D2Transform t1,
D2Transform t
);

Parameters

t1
t

Return Value

See Also

D2Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector Class

2-D vector class

For a list of all members of this type, see D2Vector Members.

System.Object
Aveva.Pdms.Maths.Geometry.D2Vector

public abstract class D2Vector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D2Vector Members | Aveva.Pdms.Maths.Geometry Namespace


D2Vector Members

D2Vector overview

Public Static Fields

D2DOWN | static constant - in negative Y direction
D2LEFT | static constant - in negative X directiov
D2RIGHT | static constants - in positive X direction
D2UP | static constant - in positive Y direction

Public Static Methods

Create Overloaded. Create a default D2Vector

Public Static Operators

Addition Operator | Invoked by v1+v2
Division Operator | invoked by v1/d
Equality Operator | Invoked by left== right (exact equality)
Inequality Operator | Invoked by left != right (exact inequality)
Multiplication Operator | invoked by v1d
Subtraction Operator | invoked by v1-v2
Unary Negation Operator | invoked by -v

Public Instance Properties

X | property to set/get X coordinate of vector
Y | property to set/get Y coordinate

Public Instance Methods

Add | Add two vectors
Angle | return angle between vectors in radians; range: -pi to pi
Antiparallel | Overloaded. Returns true if vectors are in opposite direction
AsPoint | Return vector as a point
Clone |
Cross | Returns cross product
Divide | Divid vector by given value
Dot | Returns dot product
Equals | Overloaded. Return true if vectors are same
GetHashCode | override gethashcode
GetType (inherited from Object) | Gets the Type of the current instance.
GetUnit | returns unit magnitude equivalent vector; returns (0,0) if original is (0,0)
IsZero | Return true if both X and Y are zero
Magnitude | magnitude of vector
MirrorX | Mirror in X
MirrorY | Mirror in Y
Multiply | Multiply vector by given value
NearestAxis | get unit vector of axis which is closest
Negate | Negate a vector
Parallel | Overloaded. Returns true if vectors are in same direction
Parse | Creates a D2Vector from a string of the format:"xxx,yyy"
Perpendicular | Overloaded. Returns true if vectors are perpendicular
PolarAngle | Return polarAngle between 0.0 and fl_TWO_PI"
Rotate90 | rotate 90 degrees
RotateByDegrees | rotate vector by angle given in degrees
RotateByRadians | rotate vector by angle given in radians
ScaleBy | Scale x and y uniformly
SetXY | Set X and Y coordinates
Subtract | Subtract two vectors
ToString | Returns a string describing the contents of the D2Vector

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector Fields

The fields of the D2Vector class are listed below. For a complete list of D2Vector class members, see the D2Vector Members topic.

Public Static Fields

D2DOWN | static constant - in negative Y direction
D2LEFT | static constant - in negative X directiov
D2RIGHT | static constants - in positive X direction
D2UP | static constant - in positive Y direction

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.D2DOWN Field

static constant - in negative Y direction

public static D2Vector D2DOWN;

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.D2LEFT Field

static constant - in negative X directiov

public static D2Vector D2LEFT;

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.D2RIGHT Field

static constants - in positive X direction

public static D2Vector D2RIGHT;

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.D2UP Field

static constant - in positive Y direction

public static D2Vector D2UP;

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector Properties

The properties of the D2Vector class are listed below. For a complete list of D2Vector class members, see the D2Vector Members topic.

Public Instance Properties

X | property to set/get X coordinate of vector
Y | property to set/get Y coordinate

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


X Property

AVEVA Maths / Geometry .NET Public Interface

D2Vector.X Property

property to set/get X coordinate of vector

public abstract double X {get; set;}

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


Y Property

AVEVA Maths / Geometry .NET Public Interface

D2Vector.Y Property

property to set/get Y coordinate

public abstract double Y {get; set;}

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector Methods

The methods of the D2Vector class are listed below. For a complete list of D2Vector class members, see the D2Vector Members topic.

Public Static Methods

Create Overloaded. Create a default D2Vector

Public Instance Methods

Add | Add two vectors
Angle | return angle between vectors in radians; range: -pi to pi
Antiparallel | Overloaded. Returns true if vectors are in opposite direction
AsPoint | Return vector as a point
Clone |
Cross | Returns cross product
Divide | Divid vector by given value
Dot | Returns dot product
Equals | Overloaded. Return true if vectors are same
GetHashCode | override gethashcode
GetType (inherited from Object) | Gets the Type of the current instance.
GetUnit | returns unit magnitude equivalent vector; returns (0,0) if original is (0,0)
IsZero | Return true if both X and Y are zero
Magnitude | magnitude of vector
MirrorX | Mirror in X
MirrorY | Mirror in Y
Multiply | Multiply vector by given value
NearestAxis | get unit vector of axis which is closest
Negate | Negate a vector
Parallel | Overloaded. Returns true if vectors are in same direction
Parse | Creates a D2Vector from a string of the format:"xxx,yyy"
Perpendicular | Overloaded. Returns true if vectors are perpendicular
PolarAngle | Return polarAngle between 0.0 and fl_TWO_PI"
Rotate90 | rotate 90 degrees
RotateByDegrees | rotate vector by angle given in degrees
RotateByRadians | rotate vector by angle given in radians
ScaleBy | Scale x and y uniformly
SetXY | Set X and Y coordinates
Subtract | Subtract two vectors
ToString | Returns a string describing the contents of the D2Vector

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.Add Method

Add two vectors

public abstract D2Vector Add(
D2Vector v2
);

Parameters

v2

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.Angle Method

return angle between vectors in radians; range: -pi to pi

public abstract double Angle(
D2Vector v
);

Parameters

v

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


Antiparallel Method

AVEVA Maths / Geometry .NET Public Interface

D2Vector.Antiparallel Method

Returns true if vectors are in opposite direction

Overload List

Returns true if vectors are in opposite direction

public abstract bool Antiparallel(D2Vector);

returns true if vectors are in opposite direction, within delta

public abstract bool Antiparallel(D2Vector,double);

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.Antiparallel Method (D2Vector)

Returns true if vectors are in opposite direction

public abstract bool Antiparallel(
D2Vector v
);

Parameters

v

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D2Vector.Antiparallel Overload List


D2Vector.Antiparallel Method (D2Vector, Double)

returns true if vectors are in opposite direction, within delta

public abstract bool Antiparallel(
D2Vector v,
double delta
);

Parameters

v
delta

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D2Vector.Antiparallel Overload List


D2Vector.AsPoint Method

Return vector as a point

public abstract D2Point AsPoint();

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.Clone Method

public abstract D2Vector Clone();

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D2Vector.Create Method

Create a default D2Vector

Overload List

Create a default D2Vector

public static D2Vector Create();

Create a D2Vector from 2 D2Points

public static D2Vector Create(D2Point,D2Point);

Create a vector as a copy of another

public static D2Vector Create(D2Vector);

Create a D2Vector from two coordinate values

public static D2Vector Create(double,double);

Create a D2Vector from an array of 2 doubles

public static D2Vector Create(double[]);

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.Create Method ()

Create a default D2Vector

public static D2Vector Create();

Return Value

D2Vector

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D2Vector.Create Overload List


D2Vector.Create Method (D2Point, D2Point)

Create a D2Vector from 2 D2Points

public static D2Vector Create(
D2Point a,
D2Point b
);

Parameters

a
b

Return Value

D2Vector

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D2Vector.Create Overload List


D2Vector.Create Method (D2Vector)

Create a vector as a copy of another

public static D2Vector Create(
D2Vector v
);

Parameters

v

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D2Vector.Create Overload List


D2Vector.Create Method (Double, Double)

Create a D2Vector from two coordinate values

public static D2Vector Create(
double x,
double y
);

Parameters

x
y

Return Value

D2Vector

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D2Vector.Create Overload List


D2Vector.Create Method (Double[])

Create a D2Vector from an array of 2 doubles

public static D2Vector Create(
double[] v
);

Parameters

v

Return Value

D2Vector

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D2Vector.Create Overload List


D2Vector.Cross Method

Returns cross product

public abstract double Cross(
D2Vector v
);

Parameters

v

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.Divide Method

Divid vector by given value

public abstract D2Vector Divide(
double d
);

Parameters

d

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.Dot Method

Returns dot product

public abstract double Dot(
D2Vector v
);

Parameters

v

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D2Vector.Equals Method

Return true if vectors are same

Overload List

Return true if vectors are same

public abstract bool Equals(D2Vector);

Return true if vectors are equal within given delta length

public abstract bool Equals(D2Vector,double);

Return true if vectors are equla within given delta angle and given delta length of each other

public abstract bool Equals(D2Vector,double,double);

Override equals

public override bool Equals(object);

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.Equals Method (D2Vector)

Return true if vectors are same

public abstract bool Equals(
D2Vector v
);

Parameters

v

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D2Vector.Equals Overload List


D2Vector.Equals Method (D2Vector, Double)

Return true if vectors are equal within given delta length

public abstract bool Equals(
D2Vector v,
double deltaMag
);

Parameters

v
deltaMag

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D2Vector.Equals Overload List


D2Vector.Equals Method (D2Vector, Double, Double)

Return true if vectors are equla within given delta angle and given delta length of each other

public abstract bool Equals(
D2Vector v,
double deltaMag,
double deltaAng
);

Parameters

v
deltaMag
deltaAng

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D2Vector.Equals Overload List


D2Vector.Equals Method (Object)

Override equals

public override bool Equals(
object a
);

Parameters

a

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D2Vector.Equals Overload List


D2Vector.GetHashCode Method

override gethashcode

public override int GetHashCode();

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.GetUnit Method

returns unit magnitude equivalent vector; returns (0,0) if original is (0,0)

public abstract D2Vector GetUnit();

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.IsZero Method

Return true if both X and Y are zero

public abstract bool IsZero();

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.Magnitude Method

magnitude of vector

public abstract double Magnitude();

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.MirrorX Method

Mirror in X

public abstract void MirrorX();

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.MirrorY Method

Mirror in Y

public abstract void MirrorY();

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.Multiply Method

Multiply vector by given value

public abstract D2Vector Multiply(
double d
);

Parameters

d

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.NearestAxis Method

get unit vector of axis which is closest

public abstract D2Vector NearestAxis();

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.Negate Method

Negate a vector

public abstract D2Vector Negate();

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


Parallel Method

AVEVA Maths / Geometry .NET Public Interface

D2Vector.Parallel Method

Returns true if vectors are in same direction

Overload List

Returns true if vectors are in same direction

public abstract bool Parallel(D2Vector);

return true if vectors are in same direction, within delta

public abstract bool Parallel(D2Vector,double);

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.Parallel Method (D2Vector)

Returns true if vectors are in same direction

public abstract bool Parallel(
D2Vector v
);

Parameters

v

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D2Vector.Parallel Overload List


D2Vector.Parallel Method (D2Vector, Double)

return true if vectors are in same direction, within delta

public abstract bool Parallel(
D2Vector v,
double delta
);

Parameters

v
delta

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D2Vector.Parallel Overload List


D2Vector.Parse Method

Creates a D2Vector from a string of the format:"xxx,yyy"

public abstract D2Vector Parse(
string str
);

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


Perpendicular Method

AVEVA Maths / Geometry .NET Public Interface

D2Vector.Perpendicular Method

Returns true if vectors are perpendicular

Overload List

Returns true if vectors are perpendicular

public abstract bool Perpendicular(D2Vector);

Returns true if vectors are perpendicular within delta

public abstract bool Perpendicular(D2Vector,double);

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.Perpendicular Method (D2Vector)

Returns true if vectors are perpendicular

public abstract bool Perpendicular(
D2Vector v
);

Parameters

v

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D2Vector.Perpendicular Overload List


D2Vector.Perpendicular Method (D2Vector, Double)

Returns true if vectors are perpendicular within delta

public abstract bool Perpendicular(
D2Vector v,
double delta
);

Parameters

v
delta

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D2Vector.Perpendicular Overload List


D2Vector.PolarAngle Method

Return polarAngle between 0.0 and fl_TWO_PI"

public abstract double PolarAngle();

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.Rotate90 Method

rotate 90 degrees

public abstract void Rotate90();

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.RotateByDegrees Method

rotate vector by angle given in degrees

public abstract void RotateByDegrees(
double degrees
);

Parameters

degrees

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.RotateByRadians Method

rotate vector by angle given in radians

public abstract void RotateByRadians(
double radians
);

Parameters

radians

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.ScaleBy Method

Scale x and y uniformly

public abstract void ScaleBy(
double s
);

Parameters

s
scale factor

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.SetXY Method

Set X and Y coordinates

public abstract void SetXY(
double x,
double y
);

Parameters

x
y

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.Subtract Method

Subtract two vectors

public abstract D2Vector Subtract(
D2Vector v2
);

Parameters

v2

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector.ToString Method

Returns a string describing the contents of the D2Vector

public abstract string ToString();

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector Operators

The operators of the D2Vector class are listed below. For a complete list of D2Vector class members, see the D2Vector Members topic.

Public Static Operators

Addition Operator | Invoked by v1+v2
Division Operator | invoked by v1/d
Equality Operator | Invoked by left== right (exact equality)
Inequality Operator | Invoked by left != right (exact inequality)
Multiplication Operator | invoked by v1d
Subtraction Operator | invoked by v1-v2
Unary Negation Operator | invoked by -v

See Also

D2Vector Class | D2Vector Members | Aveva.Pdms.Maths.Geometry Namespace


D2Vector Addition Operator

Invoked by v1+v2

public static D2Vector operator +(
D2Vector v1,
D2Vector v2
);

Parameters

v1
v2

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector Division Operator

invoked by v1/d

public static D2Vector operator /(
D2Vector v1,
double d
);

Parameters

v1
d

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector Equality Operator

Invoked by left== right (exact equality)

public static bool operator ==(
D2Vector left,
D2Vector right
);

Parameters

left
right

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector Inequality Operator

Invoked by left != right (exact inequality)

public static bool operator !=(
D2Vector left,
D2Vector right
);

Parameters

left
right

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector Multiplication Operator

invoked by v1d

public static D2Vector operator *(
D2Vector v1,
double d
);

Parameters

v1
d

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector Subtraction Operator

invoked by v1-v2

public static D2Vector operator -(
D2Vector v1,
D2Vector v2
);

Parameters

v1
v2

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D2Vector Unary Negation Operator

invoked by -v

public static D2Vector operator -(
D2Vector v
);

Parameters

v

Return Value

See Also

D2Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc Class

A directed 3-D arc

For a list of all members of this type, see D3Arc Members.

System.Object
Aveva.Pdms.Maths.Geometry.D3Arc

public abstract class D3Arc

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D3Arc Members | Aveva.Pdms.Maths.Geometry Namespace


D3Arc Members

D3Arc overview

Public Static Methods

Create Overloaded. Create default arc start(0,0,0),end(0,0,0),centre(0,0,0),radius(0),

Public Static Operators

Equality Operator | equality operator
Inequality Operator | inequality operator

Public Instance Methods

Centre | Get the centre
Clone | Create a copy of a D3Arc
End | Return the end point of the arc
EndAngle | Overloaded. Set the end angle
EndTangent | Get the tangent at the end of the arc
Equals | Overloaded. Returns true if arcs are equal
GetHashCode | Override system default gethashcode method
GetType (inherited from Object) | Gets the Type of the current instance.
Intersections | Overloaded. Return true if arc intersects the given plane Intersection points are returned in pa and pb
InValid | Return true if arc is invalid
IsAnticlockwise | Return the sense of the arc
IsCircle | Returns true if the arc is a full circle
IsOnArc | Return true if point lies on arc
Mid | Return the mid point of the arc between the start and end points
OrientedPlane | Overloaded. set the oriented plane
Position | Return the position at given angle on arc
Radius | Overloaded. Set the radius
SetAnticlockwise | Set the sense of the arc
Start | Return the first point of the arc
StartAngle | Overloaded. Set the start angle
StartTangent | Get the tangent at the start of the arc
Tangent | Get the tangent at given angle on arc
TangentPoints | Return true if tangents drawn from the given point to the arc exist (The given point is projected onto the plane of the arc) The points of contact are returned in pa and pb
ToString | Returns a string describing the contents of the D3Arc

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc Methods

The methods of the D3Arc class are listed below. For a complete list of D3Arc class members, see the D3Arc Members topic.

Public Static Methods

Create Overloaded. Create default arc start(0,0,0),end(0,0,0),centre(0,0,0),radius(0),

Public Instance Methods

Centre | Get the centre
Clone | Create a copy of a D3Arc
End | Return the end point of the arc
EndAngle | Overloaded. Set the end angle
EndTangent | Get the tangent at the end of the arc
Equals | Overloaded. Returns true if arcs are equal
GetHashCode | Override system default gethashcode method
GetType (inherited from Object) | Gets the Type of the current instance.
Intersections | Overloaded. Return true if arc intersects the given plane Intersection points are returned in pa and pb
InValid | Return true if arc is invalid
IsAnticlockwise | Return the sense of the arc
IsCircle | Returns true if the arc is a full circle
IsOnArc | Return true if point lies on arc
Mid | Return the mid point of the arc between the start and end points
OrientedPlane | Overloaded. set the oriented plane
Position | Return the position at given angle on arc
Radius | Overloaded. Set the radius
SetAnticlockwise | Set the sense of the arc
Start | Return the first point of the arc
StartAngle | Overloaded. Set the start angle
StartTangent | Get the tangent at the start of the arc
Tangent | Get the tangent at given angle on arc
TangentPoints | Return true if tangents drawn from the given point to the arc exist (The given point is projected onto the plane of the arc) The points of contact are returned in pa and pb
ToString | Returns a string describing the contents of the D3Arc

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.Centre Method

Get the centre

public abstract D3Point Centre();

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.Clone Method

Create a copy of a D3Arc

public abstract D3Arc Clone();

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D3Arc.Create Method

Create default arc start(0,0,0),end(0,0,0),centre(0,0,0),radius(0),

Overload List

Create default arc start(0,0,0),end(0,0,0),centre(0,0,0),radius(0),

public static D3Arc Create();

Create copy of arc

public static D3Arc Create(D3Arc);

Create a circle from plane and radius

public static D3Arc Create(D3OrientedPlane,double);

Create arc through 3 points

public static D3Arc Create(D3Point,D3Point,D3Point);

Create an arc from a pole point, 2 points and a radius

public static D3Arc Create(D3Point,D3Point,D3Point,double);

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.Create Method ()

Create default arc start(0,0,0),end(0,0,0),centre(0,0,0),radius(0),

public static D3Arc Create();

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.Create Overload List


D3Arc.Create Method (D3Arc)

Create copy of arc

public static D3Arc Create(
D3Arc arc
);

Parameters

arc

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.Create Overload List


D3Arc.Create Method (D3OrientedPlane, Double)

Create a circle from plane and radius

public static D3Arc Create(
D3OrientedPlane plane,
double radius
);

Parameters

plane
radius

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.Create Overload List


D3Arc.Create Method (D3Point, D3Point, D3Point)

Create arc through 3 points

public static D3Arc Create(
D3Point start,
D3Point mid,
D3Point end
);

Parameters

start
mid
end

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.Create Overload List


D3Arc.Create Method (D3Point, D3Point, D3Point, Double)

Create an arc from a pole point, 2 points and a radius

public static D3Arc Create(
D3Point pole,
D3Point start,
D3Point end,
double radius
);

Parameters

pole
start
end
radius

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.Create Overload List


D3Arc.End Method

Return the end point of the arc

public abstract D3Point End();

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


EndAngle Method

AVEVA Maths / Geometry .NET Public Interface

D3Arc.EndAngle Method

Return the end angle

Overload List

Return the end angle

public abstract double EndAngle();

Set the end angle

public abstract void EndAngle(double);

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.EndAngle Method ()

Return the end angle

public abstract double EndAngle();

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.EndAngle Overload List


D3Arc.EndAngle Method (Double)

Set the end angle

public abstract void EndAngle(
double angle
);

Parameters

angle

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.EndAngle Overload List


D3Arc.EndTangent Method

Get the tangent at the end of the arc

public abstract D3Vector EndTangent();

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D3Arc.Equals Method

Returns true if arcs are equal

Overload List

Returns true if arcs are equal

public abstract bool Equals(D3Arc);

Returns TRUE if start points, end points, and centre points all match to within distance "tol". The "senses" of the arcs must also be the same.

public abstract bool Equals(D3Arc,double);

override system default equals method

public override bool Equals(object);

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.Equals Method (D3Arc)

Returns true if arcs are equal

public abstract bool Equals(
D3Arc a
);

Parameters

a

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.Equals Overload List


D3Arc.Equals Method (D3Arc, Double)

Returns TRUE if start points, end points, and centre points all match to within distance "tol". The "senses" of the arcs must also be the same.

public abstract bool Equals(
D3Arc a,
double tol
);

Parameters

a
tol

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.Equals Overload List


D3Arc.Equals Method (Object)

override system default equals method

public override bool Equals(
object a
);

Parameters

a

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.Equals Overload List


D3Arc.GetHashCode Method

Override system default gethashcode method

public override int GetHashCode();

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


Intersections Method

AVEVA Maths / Geometry .NET Public Interface

D3Arc.Intersections Method

Return true if arcs intersect Intersection points are returned in pa and pb

Overload List

Return true if arcs intersect Intersection points are returned in pa and pb

public abstract bool Intersections(D3Arc,D3Point,D3Point);

Return true if arc intersects the (finite) line (The line is projected onto the plane of the arc) Intersection points are returned in pa and pb

public abstract bool Intersections(D3FiniteLine,D3Point,D3Point);

Return true if arc intersects the given plane Intersection points are returned in pa and pb

public abstract bool Intersections(D3OrientedPlane,D3Point,D3Point);

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.Intersections Method (D3Arc, D3Point, D3Point)

Return true if arcs intersect Intersection points are returned in pa and pb

public abstract bool Intersections(
D3Arc a,
D3Point pa,
D3Point pb
);

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.Intersections Overload List


D3Arc.Intersections Method (D3FiniteLine, D3Point, D3Point)

Return true if arc intersects the (finite) line (The line is projected onto the plane of the arc) Intersection points are returned in pa and pb

public abstract bool Intersections(
D3FiniteLine lin,
D3Point pa,
D3Point pb
);

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.Intersections Overload List


D3Arc.Intersections Method (D3OrientedPlane, D3Point, D3Point)

Return true if arc intersects the given plane Intersection points are returned in pa and pb

public abstract bool Intersections(
D3OrientedPlane plan,
D3Point pa,
D3Point pb
);

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.Intersections Overload List


D3Arc.InValid Method

Return true if arc is invalid

public abstract bool InValid();

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.IsAnticlockwise Method

Return the sense of the arc

public abstract bool IsAnticlockwise();

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.IsCircle Method

Returns true if the arc is a full circle

public abstract bool IsCircle();

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.IsOnArc Method

Return true if point lies on arc

public abstract bool IsOnArc(
D3Point p
);

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.Mid Method

Return the mid point of the arc between the start and end points

public abstract D3Point Mid();

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


OrientedPlane Method

AVEVA Maths / Geometry .NET Public Interface

D3Arc.OrientedPlane Method

return the oriented plane

Overload List

return the oriented plane

public abstract D3OrientedPlane OrientedPlane();

set the oriented plane

public abstract void OrientedPlane(D3OrientedPlane);

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.OrientedPlane Method ()

return the oriented plane

public abstract D3OrientedPlane OrientedPlane();

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.OrientedPlane Overload List


D3Arc.OrientedPlane Method (D3OrientedPlane)

set the oriented plane

public abstract void OrientedPlane(
D3OrientedPlane plane
);

Parameters

plane

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.OrientedPlane Overload List


D3Arc.Position Method

Return the position at given angle on arc

public abstract D3Point Position(
double angle
);

Parameters

angle

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


Radius Method

AVEVA Maths / Geometry .NET Public Interface

D3Arc.Radius Method

Return the radius

Overload List

Return the radius

public abstract double Radius();

Set the radius

public abstract void Radius(double);

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.Radius Method ()

Return the radius

public abstract double Radius();

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.Radius Overload List


D3Arc.Radius Method (Double)

Set the radius

public abstract void Radius(
double rad
);

Parameters

rad

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.Radius Overload List


D3Arc.SetAnticlockwise Method

Set the sense of the arc

public abstract void SetAnticlockwise(
bool isAnticlock
);

Parameters

isAnticlock

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.Start Method

Return the first point of the arc

public abstract D3Point Start();

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


StartAngle Method

AVEVA Maths / Geometry .NET Public Interface

D3Arc.StartAngle Method

Return the start angle

Overload List

Return the start angle

public abstract double StartAngle();

Set the start angle

public abstract void StartAngle(double);

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.StartAngle Method ()

Return the start angle

public abstract double StartAngle();

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.StartAngle Overload List


D3Arc.StartAngle Method (Double)

Set the start angle

public abstract void StartAngle(
double angle
);

Parameters

angle

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace | D3Arc.StartAngle Overload List


D3Arc.StartTangent Method

Get the tangent at the start of the arc

public abstract D3Vector StartTangent();

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.Tangent Method

Get the tangent at given angle on arc

public abstract D3Vector Tangent(
double angle
);

Parameters

angle

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.TangentPoints Method

Return true if tangents drawn from the given point to the arc exist (The given point is projected onto the plane of the arc) The points of contact are returned in pa and pb

public abstract bool TangentPoints(
D3Point pIn,
D3Point pa,
D3Point pb
);

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc.ToString Method

Returns a string describing the contents of the D3Arc

public abstract string ToString();

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc Operators

The operators of the D3Arc class are listed below. For a complete list of D3Arc class members, see the D3Arc Members topic.

Public Static Operators

Equality Operator | equality operator
Inequality Operator | inequality operator

See Also

D3Arc Class | D3Arc Members | Aveva.Pdms.Maths.Geometry Namespace


D3Arc Equality Operator

equality operator

public static bool operator ==(
D3Arc left,
D3Arc right
);

Parameters

left
right

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3Arc Inequality Operator

inequality operator

public static bool operator !=(
D3Arc left,
D3Arc right
);

Parameters

left
right

Return Value

See Also

D3Arc Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine Class

Finite line in 3D space

For a list of all members of this type, see D3FiniteLine Members.

System.Object
Aveva.Pdms.Maths.Geometry.D3FiniteLine

public abstract class D3FiniteLine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D3FiniteLine Members | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine Members

D3FiniteLine overview

Public Static Methods

Create Overloaded. default constructor ( zero length line at origin)

Public Static Operators

Equality Operator | invoked by left == right True if start and end points match exaclty
Inequality Operator | invoked by left != right True if either start or end point does not match exactly

Public Instance Methods

Antiparallel | Overloaded. Returns True if lines point in OPPOSITE DIRECTIONS within default tolerance
AzimuthalAngleInRadians | azimuthal angle of direction vector of line measured wrt z-direction
Box | Return box that encloses line
CheckLength | Overloaded. Returns true if length is greater than default tolerance
Clone | deep copy
Coplanar | Overloaded. Returns TRUE if lines lie in the same plane Returns TRUE If lines are PARALLEL or ANTIPARALLEL. N.B. uses parallel(FiniteLine,tol) and antparallel(FiniteLine,tol) functions with given tolerance. For non-parallel lines- this routine works by finding these two vectors- A: the vector connecting the two start points B: the vector product of the two line directions If the angle between these two lines is PI radians (within default tolerance), then TRUE will be returned. If either input line is less than fl_TOLERANCE in length FALSE will be returned
Direction | return direction vector (end - start)
DistanceFrom | Shortest distance from line to point. Line treated as FINITE Returns distance from point
DistanceFromOrigin | Shortest distance from line to origin. Line treated as FINITE
End | Overloaded. set coordinate values of end point
Equals | Overloaded. Test for equality
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
InterPoint | Returns an intermediate point along the line (Note: it'll be off the end if |t| > 1)
Length | Return the length of the line
Middle | Return the mid point of the line
MirrorX | Overloaded. Mirror X about pivot
MirrorY | Overloaded. Mirror Y about pivot
MirrorZ | Overloaded. Mirror Z about pivot
MoveBy | Move line by given vector
NearestPoint | Returns point ON FINITE line nearest given point pt
NearestPointToOrigin | Returns point on line closest to origin
OnLine | Overloaded. True if point lies on the line (within default tolerance )
Parallel | Overloaded. true if lines point in the SAME DIRECTION (within default tolerance) Tolerance is max angle between the directions measured in RADIANS N.B. will return FALSE for antiparallel lines.
PerpendicularDistance | Distance of the given point from the perpendicularPoint() calculated using NearestPoint function.
PerpendicularPoint | Returns the point on the INFINITELY EXTENDED line from which a perpendicular line can be dropped onto the argument point
PolarAngleInRadians | polar angle of direction vector of line
Reverse | swap start and end points
ScaleBy | Overloaded. Scale by given value about pivot
SetValue | Overloaded. set start and end points
Start | Overloaded. set coordinate values of start
ToString | Return string containing description of D3FiniteLine
TValue | Distance of point p from start point of line in the direction of the line. The distance is returned in units such that one line length = 1 unit. So tValue > 1 -> point lies beyond end of line tValue < 0 -> point lies before start of line 0 <= tValue <= 1 -> can drop a perpendicular from line to point ie. point lies between ends of line
UnitDirection | Return unit direction vector

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine Methods

The methods of the D3FiniteLine class are listed below. For a complete list of D3FiniteLine class members, see the D3FiniteLine Members topic.

Public Static Methods

Create Overloaded. default constructor ( zero length line at origin)

Public Instance Methods

Antiparallel | Overloaded. Returns True if lines point in OPPOSITE DIRECTIONS within default tolerance
AzimuthalAngleInRadians | azimuthal angle of direction vector of line measured wrt z-direction
Box | Return box that encloses line
CheckLength | Overloaded. Returns true if length is greater than default tolerance
Clone | deep copy
Coplanar | Overloaded. Returns TRUE if lines lie in the same plane Returns TRUE If lines are PARALLEL or ANTIPARALLEL. N.B. uses parallel(FiniteLine,tol) and antparallel(FiniteLine,tol) functions with given tolerance. For non-parallel lines- this routine works by finding these two vectors- A: the vector connecting the two start points B: the vector product of the two line directions If the angle between these two lines is PI radians (within default tolerance), then TRUE will be returned. If either input line is less than fl_TOLERANCE in length FALSE will be returned
Direction | return direction vector (end - start)
DistanceFrom | Shortest distance from line to point. Line treated as FINITE Returns distance from point
DistanceFromOrigin | Shortest distance from line to origin. Line treated as FINITE
End | Overloaded. set coordinate values of end point
Equals | Overloaded. Test for equality
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
InterPoint | Returns an intermediate point along the line (Note: it'll be off the end if |t| > 1)
Length | Return the length of the line
Middle | Return the mid point of the line
MirrorX | Overloaded. Mirror X about pivot
MirrorY | Overloaded. Mirror Y about pivot
MirrorZ | Overloaded. Mirror Z about pivot
MoveBy | Move line by given vector
NearestPoint | Returns point ON FINITE line nearest given point pt
NearestPointToOrigin | Returns point on line closest to origin
OnLine | Overloaded. True if point lies on the line (within default tolerance )
Parallel | Overloaded. true if lines point in the SAME DIRECTION (within default tolerance) Tolerance is max angle between the directions measured in RADIANS N.B. will return FALSE for antiparallel lines.
PerpendicularDistance | Distance of the given point from the perpendicularPoint() calculated using NearestPoint function.
PerpendicularPoint | Returns the point on the INFINITELY EXTENDED line from which a perpendicular line can be dropped onto the argument point
PolarAngleInRadians | polar angle of direction vector of line
Reverse | swap start and end points
ScaleBy | Overloaded. Scale by given value about pivot
SetValue | Overloaded. set start and end points
Start | Overloaded. set coordinate values of start
ToString | Return string containing description of D3FiniteLine
TValue | Distance of point p from start point of line in the direction of the line. The distance is returned in units such that one line length = 1 unit. So tValue > 1 -> point lies beyond end of line tValue < 0 -> point lies before start of line 0 <= tValue <= 1 -> can drop a perpendicular from line to point ie. point lies between ends of line
UnitDirection | Return unit direction vector

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


Antiparallel Method

AVEVA Maths / Geometry .NET Public Interface

D3FiniteLine.Antiparallel Method

Returns True if lines point in OPPOSITE DIRECTIONS within default tolerance

Overload List

Returns True if lines point in OPPOSITE DIRECTIONS within default tolerance

public abstract bool Antiparallel(D3FiniteLine);

Returns True if lines point in OPPOSITE DIRECTIONS within tolerance tol in Radians

public abstract bool Antiparallel(D3FiniteLine,double);

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.Antiparallel Method (D3FiniteLine)

Returns True if lines point in OPPOSITE DIRECTIONS within default tolerance

public abstract bool Antiparallel(
D3FiniteLine f
);

Parameters

f

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.Antiparallel Overload List


D3FiniteLine.Antiparallel Method (D3FiniteLine, Double)

Returns True if lines point in OPPOSITE DIRECTIONS within tolerance tol in Radians

public abstract bool Antiparallel(
D3FiniteLine f,
double tol
);

Parameters

f
tol

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.Antiparallel Overload List


D3FiniteLine.AzimuthalAngleInRadians Method

azimuthal angle of direction vector of line measured wrt z-direction

public abstract double AzimuthalAngleInRadians();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.Box Method

Return box that encloses line

public abstract D3Limits Box();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


CheckLength Method

AVEVA Maths / Geometry .NET Public Interface

D3FiniteLine.CheckLength Method

Returns true if length is greater than default tolerance

Overload List

Returns true if length is greater than default tolerance

public abstract bool CheckLength();

True if length is greater than tol

public abstract bool CheckLength(double);

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.CheckLength Method ()

Returns true if length is greater than default tolerance

public abstract bool CheckLength();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.CheckLength Overload List


D3FiniteLine.CheckLength Method (Double)

True if length is greater than tol

public abstract bool CheckLength(
double tol
);

Parameters

tol

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.CheckLength Overload List


D3FiniteLine.Clone Method

deep copy

public abstract D3FiniteLine Clone();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


Coplanar Method

AVEVA Maths / Geometry .NET Public Interface

D3FiniteLine.Coplanar Method

Returns TRUE if lines lie in the same plane Returns TRUE If lines are PARALLEL or ANTIPARALLEL. N.B. uses parallel(FiniteLine,tol) and antparallel(FiniteLine,tol) functions with given tolerance. For non-parallel lines- this routine works by finding these two vectors- A: the vector connecting the two start points B: the vector product of the two line directions If the angle between these two lines is PI radians (within default tolerance), then TRUE will be returned. If either input line is less than fl_TOLERANCE in length FALSE will be returned

Overload List

Returns TRUE if lines lie in the same plane Returns TRUE If lines are PARALLEL or ANTIPARALLEL. N.B. uses parallel(FiniteLine,tol) and antparallel(FiniteLine,tol) functions with given tolerance. For non-parallel lines- this routine works by finding these two vectors- A: the vector connecting the two start points B: the vector product of the two line directions If the angle between these two lines is PI radians (within default tolerance), then TRUE will be returned. If either input line is less than fl_TOLERANCE in length FALSE will be returned

public abstract bool Coplanar(D3FiniteLine);

Returns TRUE if lines lie in the same plane Returns TRUE If lines are PARALLEL or ANTIPARALLEL. N.B. uses parallel(FiniteLine,tol) and antparallel(FiniteLine,tol) functions with given tolerance. For non-parallel lines- this routine works by finding these two vectors- A: the vector connecting the two start points B: the vector product of the two line directions If the angle between these two lines is PI radians (within tolerance tol), then TRUE will be returned. If either input line is less than fl_TOLERANCE in length FALSE will be returned

public abstract bool Coplanar(D3FiniteLine,double);

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.Coplanar Method (D3FiniteLine)

Returns TRUE if lines lie in the same plane Returns TRUE If lines are PARALLEL or ANTIPARALLEL. N.B. uses parallel(FiniteLine,tol) and antparallel(FiniteLine,tol) functions with given tolerance. For non-parallel lines- this routine works by finding these two vectors- A: the vector connecting the two start points B: the vector product of the two line directions If the angle between these two lines is PI radians (within default tolerance), then TRUE will be returned. If either input line is less than fl_TOLERANCE in length FALSE will be returned

public abstract bool Coplanar(
D3FiniteLine f
);

Parameters

f

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.Coplanar Overload List


D3FiniteLine.Coplanar Method (D3FiniteLine, Double)

Returns TRUE if lines lie in the same plane Returns TRUE If lines are PARALLEL or ANTIPARALLEL. N.B. uses parallel(FiniteLine,tol) and antparallel(FiniteLine,tol) functions with given tolerance. For non-parallel lines- this routine works by finding these two vectors- A: the vector connecting the two start points B: the vector product of the two line directions If the angle between these two lines is PI radians (within tolerance tol), then TRUE will be returned. If either input line is less than fl_TOLERANCE in length FALSE will be returned

public abstract bool Coplanar(
D3FiniteLine f,
double tol
);

Parameters

f
tol

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.Coplanar Overload List


Create Method

AVEVA Maths / Geometry .NET Public Interface

D3FiniteLine.Create Method

default constructor ( zero length line at origin)

Overload List

default constructor ( zero length line at origin)

public static D3FiniteLine Create();

construct from start and end points

public static D3FiniteLine Create(D3Point,D3Point);

construct from start and end coordinates

public static D3FiniteLine Create(double,double,double,double,double,double);

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.Create Method ()

default constructor ( zero length line at origin)

public static D3FiniteLine Create();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.Create Overload List


D3FiniteLine.Create Method (D3Point, D3Point)

construct from start and end points

public static D3FiniteLine Create(
D3Point start,
D3Point end
);

Parameters

start
end

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.Create Overload List


D3FiniteLine.Create Method (Double, Double, Double, Double, Double, Double)

construct from start and end coordinates

public static D3FiniteLine Create(
double x1,
double y1,
double z1,
double x2,
double y2,
double z2
);

Parameters

x1
y1
z1
x2
y2
z2

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.Create Overload List


D3FiniteLine.Direction Method

return direction vector (end - start)

public abstract D3Vector Direction();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.DistanceFrom Method

Shortest distance from line to point. Line treated as FINITE Returns distance from point

public abstract double DistanceFrom(
D3Point pt
);

Parameters

pt

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.DistanceFromOrigin Method

Shortest distance from line to origin. Line treated as FINITE

public abstract double DistanceFromOrigin();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


End Method

AVEVA Maths / Geometry .NET Public Interface

D3FiniteLine.End Method

Return the end point

Overload List

Return the end point

public abstract D3Point End();

set end point

public abstract void End(D3Point);

set coordinate values of end point

public abstract void End(double,double,double);

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.End Method ()

Return the end point

public abstract D3Point End();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.End Overload List


D3FiniteLine.End Method (D3Point)

set end point

public abstract void End(
D3Point end
);

Parameters

end

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.End Overload List


D3FiniteLine.End Method (Double, Double, Double)

set coordinate values of end point

public abstract void End(
double x,
double y,
double z
);

Parameters

x
y
z

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.End Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D3FiniteLine.Equals Method

Test for equality

Overload List

Test for equality

public abstract bool Equals(D3FiniteLine);

public override bool Equals(object);

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.Equals Method (D3FiniteLine)

Test for equality

public abstract bool Equals(
D3FiniteLine d2
);

Parameters

d2

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.Equals Overload List


D3FiniteLine.Equals Method (Object)

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.Equals Overload List


D3FiniteLine.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.InterPoint Method

Returns an intermediate point along the line (Note: it'll be off the end if |t| > 1)

public abstract D3Point InterPoint(
double t
);

Parameters

t

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.Length Method

Return the length of the line

public abstract double Length();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.Middle Method

Return the mid point of the line

public abstract D3Point Middle();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


MirrorX Method

AVEVA Maths / Geometry .NET Public Interface

D3FiniteLine.MirrorX Method

Mirror X about origin

Overload List

Mirror X about origin

public abstract void MirrorX();

Mirror X about pivot

public abstract void MirrorX(D3Point);

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.MirrorX Method ()

Mirror X about origin

public abstract void MirrorX();

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.MirrorX Overload List


D3FiniteLine.MirrorX Method (D3Point)

Mirror X about pivot

public abstract void MirrorX(
D3Point pivot
);

Parameters

pivot

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.MirrorX Overload List


MirrorY Method

AVEVA Maths / Geometry .NET Public Interface

D3FiniteLine.MirrorY Method

Mirror Y about origin

Overload List

Mirror Y about origin

public abstract void MirrorY();

Mirror Y about pivot

public abstract void MirrorY(D3Point);

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.MirrorY Method ()

Mirror Y about origin

public abstract void MirrorY();

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.MirrorY Overload List


D3FiniteLine.MirrorY Method (D3Point)

Mirror Y about pivot

public abstract void MirrorY(
D3Point pivot
);

Parameters

pivot

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.MirrorY Overload List


MirrorZ Method

AVEVA Maths / Geometry .NET Public Interface

D3FiniteLine.MirrorZ Method

Mirror Z about origin

Overload List

Mirror Z about origin

public abstract void MirrorZ();

Mirror Z about pivot

public abstract void MirrorZ(D3Point);

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.MirrorZ Method ()

Mirror Z about origin

public abstract void MirrorZ();

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.MirrorZ Overload List


D3FiniteLine.MirrorZ Method (D3Point)

Mirror Z about pivot

public abstract void MirrorZ(
D3Point pivot
);

Parameters

pivot

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.MirrorZ Overload List


D3FiniteLine.MoveBy Method

Move line by given vector

public abstract void MoveBy(
D3Vector v
);

Parameters

v

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.NearestPoint Method

Returns point ON FINITE line nearest given point pt

public abstract D3Point NearestPoint(
D3Point pt
);

Parameters

pt

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.NearestPointToOrigin Method

Returns point on line closest to origin

public abstract D3Point NearestPointToOrigin();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


OnLine Method

AVEVA Maths / Geometry .NET Public Interface

D3FiniteLine.OnLine Method

True if point lies on the line (within default tolerance )

Overload List

True if point lies on the line (within default tolerance )

public abstract bool OnLine(D3Point);

True if point lies on the line (within tolerance tol)

public abstract bool OnLine(D3Point,double);

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.OnLine Method (D3Point)

True if point lies on the line (within default tolerance )

public abstract bool OnLine(
D3Point p
);

Parameters

p

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.OnLine Overload List


D3FiniteLine.OnLine Method (D3Point, Double)

True if point lies on the line (within tolerance tol)

public abstract bool OnLine(
D3Point p,
double tol
);

Parameters

p
tol

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.OnLine Overload List


Parallel Method

AVEVA Maths / Geometry .NET Public Interface

D3FiniteLine.Parallel Method

true if lines point in the SAME DIRECTION (within default tolerance) Tolerance is max angle between the directions measured in RADIANS N.B. will return FALSE for antiparallel lines.

Overload List

true if lines point in the SAME DIRECTION (within default tolerance) Tolerance is max angle between the directions measured in RADIANS N.B. will return FALSE for antiparallel lines.

public abstract bool Parallel(D3FiniteLine);

true if lines point in the SAME DIRECTION (within tolerance tol) Tolerance is max angle between the directions measured in RADIANS N.B. will return FALSE for antiparallel lines.

public abstract bool Parallel(D3FiniteLine,double);

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.Parallel Method (D3FiniteLine)

true if lines point in the SAME DIRECTION (within default tolerance) Tolerance is max angle between the directions measured in RADIANS N.B. will return FALSE for antiparallel lines.

public abstract bool Parallel(
D3FiniteLine f
);

Parameters

f

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.Parallel Overload List


D3FiniteLine.Parallel Method (D3FiniteLine, Double)

true if lines point in the SAME DIRECTION (within tolerance tol) Tolerance is max angle between the directions measured in RADIANS N.B. will return FALSE for antiparallel lines.

public abstract bool Parallel(
D3FiniteLine f,
double tol
);

Parameters

f
tol

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.Parallel Overload List


D3FiniteLine.PerpendicularDistance Method

Distance of the given point from the perpendicularPoint() calculated using NearestPoint function.

public abstract double PerpendicularDistance(
D3Point point
);

Parameters

point

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.PerpendicularPoint Method

Returns the point on the INFINITELY EXTENDED line from which a perpendicular line can be dropped onto the argument point

public abstract D3Point PerpendicularPoint(
D3Point point
);

Parameters

point

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.PolarAngleInRadians Method

polar angle of direction vector of line

public abstract double PolarAngleInRadians();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.Reverse Method

swap start and end points

public abstract void Reverse();

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


ScaleBy Method

AVEVA Maths / Geometry .NET Public Interface

D3FiniteLine.ScaleBy Method

scale uniformly by given value

Overload List

scale uniformly by given value

public abstract void ScaleBy(double);

Scale by given value about pivot

public abstract void ScaleBy(double,D3Point);

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.ScaleBy Method (Double)

scale uniformly by given value

public abstract void ScaleBy(
double s
);

Parameters

s

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.ScaleBy Overload List


D3FiniteLine.ScaleBy Method (Double, D3Point)

Scale by given value about pivot

public abstract void ScaleBy(
double s,
D3Point pivot
);

Parameters

s
pivot

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.ScaleBy Overload List


SetValue Method

AVEVA Maths / Geometry .NET Public Interface

D3FiniteLine.SetValue Method

set start and end points

Overload List

set start and end points

public abstract void SetValue(D3Point,D3Point);

set start and end points to given coordinate values

public abstract void SetValue(double,double,double,double,double,double);

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.SetValue Method (D3Point, D3Point)

set start and end points

public abstract void SetValue(
D3Point start,
D3Point end
);

Parameters

start
end

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.SetValue Overload List


D3FiniteLine.SetValue Method (Double, Double, Double, Double, Double, Double)

set start and end points to given coordinate values

public abstract void SetValue(
double x1,
double y1,
double z1,
double x2,
double y2,
double z2
);

Parameters

x1
y1
z1
x2
y2
z2

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.SetValue Overload List


Start Method

AVEVA Maths / Geometry .NET Public Interface

D3FiniteLine.Start Method

Return the start point

Overload List

Return the start point

public abstract D3Point Start();

set start point

public abstract void Start(D3Point);

set coordinate values of start

public abstract void Start(double,double,double);

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.Start Method ()

Return the start point

public abstract D3Point Start();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.Start Overload List


D3FiniteLine.Start Method (D3Point)

set start point

public abstract void Start(
D3Point start
);

Parameters

start

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.Start Overload List


D3FiniteLine.Start Method (Double, Double, Double)

set coordinate values of start

public abstract void Start(
double x,
double y,
double z
);

Parameters

x
y
z

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace | D3FiniteLine.Start Overload List


D3FiniteLine.ToString Method

Return string containing description of D3FiniteLine

public abstract string ToString();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.TValue Method

Distance of point p from start point of line in the direction of the line. The distance is returned in units such that one line length = 1 unit. So tValue > 1 -> point lies beyond end of line tValue < 0 -> point lies before start of line 0 <= tValue <= 1 -> can drop a perpendicular from line to point ie. point lies between ends of line

public abstract double TValue(
D3Point p
);

Parameters

p

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine.UnitDirection Method

Return unit direction vector

public abstract D3Vector UnitDirection();

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine Operators

The operators of the D3FiniteLine class are listed below. For a complete list of D3FiniteLine class members, see the D3FiniteLine Members topic.

Public Static Operators

Equality Operator | invoked by left == right True if start and end points match exaclty
Inequality Operator | invoked by left != right True if either start or end point does not match exactly

See Also

D3FiniteLine Class | D3FiniteLine Members | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine Equality Operator

invoked by left == right True if start and end points match exaclty

public static bool operator ==(
D3FiniteLine left,
D3FiniteLine right
);

Parameters

left
right

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3FiniteLine Inequality Operator

invoked by left != right True if either start or end point does not match exactly

public static bool operator !=(
D3FiniteLine left,
D3FiniteLine right
);

Parameters

left
right

Return Value

See Also

D3FiniteLine Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits Class

3-D limits This object can be in one of 2 states: - unset: origin at ( DBL_MAX, DBL_MAX, DBL_MAX) extent at (-DBL_MAX, -DBL_MAX, -DBL_MAX) - set: xMin <= xMax, yMin <= yMax, zMin <= zMax

For a list of all members of this type, see D3Limits Members.

System.Object
Aveva.Pdms.Maths.Geometry.D3Limits

public abstract class D3Limits

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D3Limits Members | Aveva.Pdms.Maths.Geometry Namespace


D3Limits Members

D3Limits overview

Public Static Methods

Create Overloaded. Null constructor

Public Static Operators

Addition Operator | invoked by lim1 + lim2
Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right
Multiplication Operator | invoked by lim1 * scalar

Public Instance Properties

MaxX | Return minimum Y value of the limits
MaxY | Return maximum X value of limits
MaxZ | Return maximum Z value of limits
MinX | Property to return the minimum X value of the limits box
MinY | Return minimum Z value of the limits
MinZ | Return maximum Y value of limits

Public Instance Methods

Add | Add two limits bboxes
Clear | Set box to unset
Clone | deep copy
ContainsPoint | Returns true if given point is within limits
ContainsPointToTol | Returns true if point is within the limits box expanded by tolerance tol
Equals | Overloaded. Test for equality
ExcludesLine | Returns true if limits does not enclose the two given points
ExcludesTriangle | Returns true if limits box does not include the given three points
ExpandBy | Overloaded. Move min and max corners outwards by vector
ExpandToInclude | Overloaded. Expand the box to include specified box
GetCentre | Return point at centre of limits box
GetExtent | Return the length of the diagonal
GetHashCode | return hashcode
GetMaxSize | Return max of X size, Y size, Z size
GetMaxXYZ | Returns the maximum point
GetMinSize | Return min of X size, Ysize and Z size
GetMinXYZ | Returns the origin (minimum point)
GetType (inherited from Object) | Gets the Type of the current instance.
GetVertex | Return the corner at index i,j,k
GetXSize | Return limits size in X direction
GetXYLimits | Return a D2 Limits from X, Y of D3Limits
GetYSize | Returns limits size in Y direction
GetZSize | Returns limits size in Z direction
InsetBy | Overloaded. Move min and max corners inwards by extent
Intersect | Returns limits box which is Boolean intersection of two boxes
Intersects | Returns true if the boxes overlap
IsUnset | Returns true if limits unset
Merge | Returns limits box which contains both boxes
MirrorX | Overloaded. Mirror in X about pivot
MirrorY | Overloaded. Mirror in Y about pivot
MirrorZ | Overloaded. Mirror in Z about pivot
MoveBy | Move by given vector
Multiply | Multipl limits by a scalar value
Obscures | Returns true if this limits box encloses the given box
ScaleBy | Overloaded. Scale by s about pivot
SetCornerExtent | Set corner and size
SetCorners | Set origin to p1 and opposite corner to p2
SphericalAdjust |
ToString | Returns a string describing the contents of the limits
Volume | Return volume within box

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits Properties

The properties of the D3Limits class are listed below. For a complete list of D3Limits class members, see the D3Limits Members topic.

Public Instance Properties

MaxX | Return minimum Y value of the limits
MaxY | Return maximum X value of limits
MaxZ | Return maximum Z value of limits
MinX | Property to return the minimum X value of the limits box
MinY | Return minimum Z value of the limits
MinZ | Return maximum Y value of limits

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


MaxX Property

AVEVA Maths / Geometry .NET Public Interface

D3Limits.MaxX Property

Return minimum Y value of the limits

public abstract double MaxX {get;}

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


MaxY Property

AVEVA Maths / Geometry .NET Public Interface

D3Limits.MaxY Property

Return maximum X value of limits

public abstract double MaxY {get;}

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


MaxZ Property

AVEVA Maths / Geometry .NET Public Interface

D3Limits.MaxZ Property

Return maximum Z value of limits

public abstract double MaxZ {get;}

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


MinX Property

AVEVA Maths / Geometry .NET Public Interface

D3Limits.MinX Property

Property to return the minimum X value of the limits box

public abstract double MinX {get;}

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


MinY Property

AVEVA Maths / Geometry .NET Public Interface

D3Limits.MinY Property

Return minimum Z value of the limits

public abstract double MinY {get;}

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


MinZ Property

AVEVA Maths / Geometry .NET Public Interface

D3Limits.MinZ Property

Return maximum Y value of limits

public abstract double MinZ {get;}

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits Methods

The methods of the D3Limits class are listed below. For a complete list of D3Limits class members, see the D3Limits Members topic.

Public Static Methods

Create Overloaded. Null constructor

Public Instance Methods

Add | Add two limits bboxes
Clear | Set box to unset
Clone | deep copy
ContainsPoint | Returns true if given point is within limits
ContainsPointToTol | Returns true if point is within the limits box expanded by tolerance tol
Equals | Overloaded. Test for equality
ExcludesLine | Returns true if limits does not enclose the two given points
ExcludesTriangle | Returns true if limits box does not include the given three points
ExpandBy | Overloaded. Move min and max corners outwards by vector
ExpandToInclude | Overloaded. Expand the box to include specified box
GetCentre | Return point at centre of limits box
GetExtent | Return the length of the diagonal
GetHashCode | return hashcode
GetMaxSize | Return max of X size, Y size, Z size
GetMaxXYZ | Returns the maximum point
GetMinSize | Return min of X size, Ysize and Z size
GetMinXYZ | Returns the origin (minimum point)
GetType (inherited from Object) | Gets the Type of the current instance.
GetVertex | Return the corner at index i,j,k
GetXSize | Return limits size in X direction
GetXYLimits | Return a D2 Limits from X, Y of D3Limits
GetYSize | Returns limits size in Y direction
GetZSize | Returns limits size in Z direction
InsetBy | Overloaded. Move min and max corners inwards by extent
Intersect | Returns limits box which is Boolean intersection of two boxes
Intersects | Returns true if the boxes overlap
IsUnset | Returns true if limits unset
Merge | Returns limits box which contains both boxes
MirrorX | Overloaded. Mirror in X about pivot
MirrorY | Overloaded. Mirror in Y about pivot
MirrorZ | Overloaded. Mirror in Z about pivot
MoveBy | Move by given vector
Multiply | Multipl limits by a scalar value
Obscures | Returns true if this limits box encloses the given box
ScaleBy | Overloaded. Scale by s about pivot
SetCornerExtent | Set corner and size
SetCorners | Set origin to p1 and opposite corner to p2
SphericalAdjust |
ToString | Returns a string describing the contents of the limits
Volume | Return volume within box

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.Add Method

Add two limits bboxes

public abstract D3Limits Add(
D3Limits lim2
);

Parameters

lim2

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.Clear Method

Set box to unset

public abstract void Clear();

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.Clone Method

deep copy

public abstract D3Limits Clone();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.ContainsPoint Method

Returns true if given point is within limits

public abstract bool ContainsPoint(
D3Point p
);

Parameters

p

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.ContainsPointToTol Method

Returns true if point is within the limits box expanded by tolerance tol

public abstract bool ContainsPointToTol(
D3Point p,
double tol
);

Parameters

p
tol

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D3Limits.Create Method

Null constructor

Overload List

Null constructor

public static D3Limits Create();

Copy constructor

public static D3Limits Create(D3Limits);

Construct from origin and given point

public static D3Limits Create(D3Point);

Construct from origin and opposite corner

public static D3Limits Create(D3Point,D3Point);

Construct limits box which contains the 3 specified points

public static D3Limits Create(D3Point,D3Point,D3Point);

construct from given origin with given size

public static D3Limits Create(D3Point,D3Vector);

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.Create Method ()

Null constructor

public static D3Limits Create();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.Create Overload List


D3Limits.Create Method (D3Limits)

Copy constructor

public static D3Limits Create(
D3Limits lim
);

Parameters

lim

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.Create Overload List


D3Limits.Create Method (D3Point)

Construct from origin and given point

public static D3Limits Create(
D3Point p
);

Parameters

p

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.Create Overload List


D3Limits.Create Method (D3Point, D3Point)

Construct from origin and opposite corner

public static D3Limits Create(
D3Point p1,
D3Point p2
);

Parameters

p1
p2

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.Create Overload List


D3Limits.Create Method (D3Point, D3Point, D3Point)

Construct limits box which contains the 3 specified points

public static D3Limits Create(
D3Point p1,
D3Point p2,
D3Point p3
);

Parameters

p1
p2
p3

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.Create Overload List


D3Limits.Create Method (D3Point, D3Vector)

construct from given origin with given size

public static D3Limits Create(
D3Point p,
D3Vector extent
);

Parameters

p
extent

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.Create Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D3Limits.Equals Method

Test for equality

Overload List

Test for equality

public abstract bool Equals(D3Limits);

test objects for equality

public override bool Equals(object);

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.Equals Method (D3Limits)

Test for equality

public abstract bool Equals(
D3Limits d2
);

Parameters

d2

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.Equals Overload List


D3Limits.Equals Method (Object)

test objects for equality

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.Equals Overload List


D3Limits.ExcludesLine Method

Returns true if limits does not enclose the two given points

public abstract bool ExcludesLine(
D3Point p,
D3Point q
);

Parameters

p
q

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.ExcludesTriangle Method

Returns true if limits box does not include the given three points

public abstract bool ExcludesTriangle(
D3Point p,
D3Point q,
D3Point limits
);

Parameters

p
q
limits

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


ExpandBy Method

AVEVA Maths / Geometry .NET Public Interface

D3Limits.ExpandBy Method

Move min and max corners outwards by vector

Overload List

Move min and max corners outwards by vector

public abstract void ExpandBy(D3Vector);

Move min and max corners outwards by delta

public abstract void ExpandBy(double);

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.ExpandBy Method (D3Vector)

Move min and max corners outwards by vector

public abstract void ExpandBy(
D3Vector dext
);

Parameters

dext

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.ExpandBy Overload List


D3Limits.ExpandBy Method (Double)

Move min and max corners outwards by delta

public abstract void ExpandBy(
double delta
);

Parameters

delta

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.ExpandBy Overload List


ExpandToInclude Method

AVEVA Maths / Geometry .NET Public Interface

D3Limits.ExpandToInclude Method

Expand the box to include specified box

Overload List

Expand the box to include specified box

public abstract void ExpandToInclude(D3Limits);

Expand the box to include specified point

public abstract void ExpandToInclude(D3Point);

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.ExpandToInclude Method (D3Limits)

Expand the box to include specified box

public abstract void ExpandToInclude(
D3Limits limits
);

Parameters

limits

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.ExpandToInclude Overload List


D3Limits.ExpandToInclude Method (D3Point)

Expand the box to include specified point

public abstract void ExpandToInclude(
D3Point p
);

Parameters

p

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.ExpandToInclude Overload List


D3Limits.GetCentre Method

Return point at centre of limits box

public abstract D3Point GetCentre();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.GetExtent Method

Return the length of the diagonal

public abstract D3Vector GetExtent();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.GetHashCode Method

return hashcode

public override int GetHashCode();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.GetMaxSize Method

Return max of X size, Y size, Z size

public abstract double GetMaxSize();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.GetMaxXYZ Method

Returns the maximum point

public abstract D3Point GetMaxXYZ();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.GetMinSize Method

Return min of X size, Ysize and Z size

public abstract double GetMinSize();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.GetMinXYZ Method

Returns the origin (minimum point)

public abstract D3Point GetMinXYZ();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.GetVertex Method

Return the corner at index i,j,k

public abstract D3Point GetVertex(
int i,
int j,
int k
);

Parameters

i
j
k

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.GetXSize Method

Return limits size in X direction

public abstract double GetXSize();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.GetXYLimits Method

Return a D2 Limits from X, Y of D3Limits

public abstract D2Limits GetXYLimits();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.GetYSize Method

Returns limits size in Y direction

public abstract double GetYSize();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.GetZSize Method

Returns limits size in Z direction

public abstract double GetZSize();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


InsetBy Method

AVEVA Maths / Geometry .NET Public Interface

D3Limits.InsetBy Method

Move min and max corners inwards by extent

Overload List

Move min and max corners inwards by extent

public abstract void InsetBy(D3Vector);

Move min and max corners inwards by delta

public abstract void InsetBy(double);

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.InsetBy Method (D3Vector)

Move min and max corners inwards by extent

public abstract void InsetBy(
D3Vector extent
);

Parameters

extent

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.InsetBy Overload List


D3Limits.InsetBy Method (Double)

Move min and max corners inwards by delta

public abstract void InsetBy(
double delta
);

Parameters

delta

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.InsetBy Overload List


D3Limits.Intersect Method

Returns limits box which is Boolean intersection of two boxes

public abstract D3Limits Intersect(
D3Limits limits
);

Parameters

limits

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.Intersects Method

Returns true if the boxes overlap

public abstract bool Intersects(
D3Limits limits
);

Parameters

limits

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.IsUnset Method

Returns true if limits unset

public abstract bool IsUnset();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.Merge Method

Returns limits box which contains both boxes

public abstract D3Limits Merge(
D3Limits limits
);

Parameters

limits

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


MirrorX Method

AVEVA Maths / Geometry .NET Public Interface

D3Limits.MirrorX Method

Mirror in X about origin

Overload List

Mirror in X about origin

public abstract void MirrorX();

Mirror in X about pivot

public abstract void MirrorX(D3Point);

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.MirrorX Method ()

Mirror in X about origin

public abstract void MirrorX();

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.MirrorX Overload List


D3Limits.MirrorX Method (D3Point)

Mirror in X about pivot

public abstract void MirrorX(
D3Point pivot
);

Parameters

pivot

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.MirrorX Overload List


MirrorY Method

AVEVA Maths / Geometry .NET Public Interface

D3Limits.MirrorY Method

Mirror in Y about origin

Overload List

Mirror in Y about origin

public abstract void MirrorY();

Mirror in Y about pivot

public abstract void MirrorY(D3Point);

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.MirrorY Method ()

Mirror in Y about origin

public abstract void MirrorY();

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.MirrorY Overload List


D3Limits.MirrorY Method (D3Point)

Mirror in Y about pivot

public abstract void MirrorY(
D3Point pivot
);

Parameters

pivot

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.MirrorY Overload List


MirrorZ Method

AVEVA Maths / Geometry .NET Public Interface

D3Limits.MirrorZ Method

Mirror in Z about origin

Overload List

Mirror in Z about origin

public abstract void MirrorZ();

Mirror in Z about pivot

public abstract void MirrorZ(D3Point);

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.MirrorZ Method ()

Mirror in Z about origin

public abstract void MirrorZ();

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.MirrorZ Overload List


D3Limits.MirrorZ Method (D3Point)

Mirror in Z about pivot

public abstract void MirrorZ(
D3Point pivot
);

Parameters

pivot

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.MirrorZ Overload List


D3Limits.MoveBy Method

Move by given vector

public abstract void MoveBy(
D3Vector v
);

Parameters

v

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.Multiply Method

Multipl limits by a scalar value

public abstract D3Limits Multiply(
double scalar
);

Parameters

scalar

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.Obscures Method

Returns true if this limits box encloses the given box

public abstract bool Obscures(
D3Limits limits
);

Parameters

limits

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


ScaleBy Method

AVEVA Maths / Geometry .NET Public Interface

D3Limits.ScaleBy Method

Scale uniformly by s

Overload List

Scale uniformly by s

public abstract void ScaleBy(double);

Scale by s about pivot

public abstract void ScaleBy(double,D3Point);

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.ScaleBy Method (Double)

Scale uniformly by s

public abstract void ScaleBy(
double s
);

Parameters

s

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.ScaleBy Overload List


D3Limits.ScaleBy Method (Double, D3Point)

Scale by s about pivot

public abstract void ScaleBy(
double s,
D3Point pivot
);

Parameters

s
pivot

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace | D3Limits.ScaleBy Overload List


D3Limits.SetCornerExtent Method

Set corner and size

public abstract void SetCornerExtent(
D3Point p,
D3Vector ext
);

Parameters

p
ext

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.SetCorners Method

Set origin to p1 and opposite corner to p2

public abstract void SetCorners(
D3Point p1,
D3Point p2
);

Parameters

p1
p2

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.SphericalAdjust Method

public abstract void SphericalAdjust();

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.ToString Method

Returns a string describing the contents of the limits

public abstract string ToString();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits.Volume Method

Return volume within box

public abstract double Volume();

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits Operators

The operators of the D3Limits class are listed below. For a complete list of D3Limits class members, see the D3Limits Members topic.

Public Static Operators

Addition Operator | invoked by lim1 + lim2
Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right
Multiplication Operator | invoked by lim1 * scalar

See Also

D3Limits Class | D3Limits Members | Aveva.Pdms.Maths.Geometry Namespace


D3Limits Addition Operator

invoked by lim1 + lim2

public static D3Limits operator +(
D3Limits lim1,
D3Limits lim2
);

Parameters

lim1
lim2

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits Equality Operator

invoked by left == right

public static bool operator ==(
D3Limits left,
D3Limits right
);

Parameters

left
right

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits Inequality Operator

invoked by left != right

public static bool operator !=(
D3Limits left,
D3Limits right
);

Parameters

left
right

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Limits Multiplication Operator

invoked by lim1 * scalar

public static D3Limits operator *(
D3Limits lim1,
double scalar
);

Parameters

lim1
scalar

Return Value

See Also

D3Limits Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line Class

Finite, Semi-infinite or infinite line in 3D space

For a list of all members of this type, see D3Line Members.

System.Object
Aveva.Pdms.Maths.Geometry.D3Line

public abstract class D3Line

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D3Line Members | Aveva.Pdms.Maths.Geometry Namespace


D3Line Members

D3Line overview

Public Static Methods

Create Overloaded. Null constructor

Public Static Operators

Equality Operator | invoked by left == right. True if start,end and linetype match exactly
Inequality Operator | invoked by left != right. True if any of start, end or lineType does not match excalty

Public Instance Methods

Antiparallel | Overloaded. Returns True if lines point in OPPOSITE DIRECTIONS (within tolerance Default tolerance=1.E-6 rads)
AzimuthalAngleInRadians | Returns azimuthal angle of direction of line
CheckLength | Overloaded. Return true if distance between start and end points is greater than fl_TOLERANCE
Clone | deep copy
Coplanar | Overloaded. Returns TRUE if lines lie in the same plane Returns TRUE If lines are PARALLEL or ANTIPARALLEL. N.B. uses parallel(FiniteLine,tol) and antparallel(FiniteLine,tol) functions with given tolerance. For non-parallel lines- this routine works by finding these two vectors- A: the vector connecting the two start points B: the vector product of the two line directions If the angle between these two lines is PI radians (within default tolerance), then TRUE will be returned. If either input line is less than fl_TOLERANCE in length FALSE will be returned
Direction | Returns the direction vector of the line
DistanceFrom | returns shortest straight line distance between line and point
DistanceFromOrigin | returns shortest straight line distance between line and origin
End | Overloaded. set end coordinates of line
Equals | Overloaded. Test for exact equality
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
InterPoint | Return point on line ratio t (0<= t <= 1.0) from start
IsFinite | Returns true for line with a start and an end
IsInfinite | Return true for bi-directionally infinite lines only
IsSemiInfinite | Return true for semi-infinite lines (one end only)
IsSemiWithEnd | Return true for semi-infinite line with an end point
IsSemiWithStart | Return true for semi-infinite line with a start point
Length | Returns non-negative distance between start and end points. Always finite since the start and end points are used to define the direction of the line for (semi) infinite lines and not the extent.
LineType | Overloaded. set line type possibilities are - D3Line.finite D3Line.infinite D3Line.semiWithStart D3Line.semiWithEnd
LTypeToString | Convert line type to string
MirrorX | Overloaded. Mirror X about pivot
MirrorY | Overloaded. Mirror Y about pivot
MirrorZ | Overloaded. Mirror Z about pivot
MoveBy | shift the start and end points by vector v
NearestPoint | Return point on line nearest given point
NearestPointToOrigin | Return point on line closest to origin
OnLine | Overloaded. true if given point is within distance fl_TOLERANCE of line
Parallel | Overloaded. Returns true if lines point in the SAME DIRECTION Tolerance is max angle between the directions measured in RADIANS (Default tolerance=1.E-6 rads) N.B. will return FALSE for antiparallel lines.
PerpendicularDistance | Returns the distance of the arg point from the perpendicularPoint() calculated using previous function above.
PerpendicularPoint | Returns the point on the INFINITELY EXTENDED line from which a perpendicular line can be dropped onto the argument point
PolarAngleInRadians | Returns polar angle of direction of line
Reverse | swap start and end points (reverses direction of line) N.B. semiWithEnd becomes a semiWithStart and vice versa
ScaleBy | Overloaded. Scale coordinates by s about pivot
SetValue | Overloaded. set start and end points of line
Start | Overloaded. set start coordinates of line
ToString | Returns string describing the D3Line
TValue | Distance of point p from start point of line in the direction of the line. The distance is returned in units such that one line length = 1 unit.
UnitDirection | Returns the unit vector of the line

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line Methods

The methods of the D3Line class are listed below. For a complete list of D3Line class members, see the D3Line Members topic.

Public Static Methods

Create Overloaded. Null constructor

Public Instance Methods

Antiparallel | Overloaded. Returns True if lines point in OPPOSITE DIRECTIONS (within tolerance Default tolerance=1.E-6 rads)
AzimuthalAngleInRadians | Returns azimuthal angle of direction of line
CheckLength | Overloaded. Return true if distance between start and end points is greater than fl_TOLERANCE
Clone | deep copy
Coplanar | Overloaded. Returns TRUE if lines lie in the same plane Returns TRUE If lines are PARALLEL or ANTIPARALLEL. N.B. uses parallel(FiniteLine,tol) and antparallel(FiniteLine,tol) functions with given tolerance. For non-parallel lines- this routine works by finding these two vectors- A: the vector connecting the two start points B: the vector product of the two line directions If the angle between these two lines is PI radians (within default tolerance), then TRUE will be returned. If either input line is less than fl_TOLERANCE in length FALSE will be returned
Direction | Returns the direction vector of the line
DistanceFrom | returns shortest straight line distance between line and point
DistanceFromOrigin | returns shortest straight line distance between line and origin
End | Overloaded. set end coordinates of line
Equals | Overloaded. Test for exact equality
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
InterPoint | Return point on line ratio t (0<= t <= 1.0) from start
IsFinite | Returns true for line with a start and an end
IsInfinite | Return true for bi-directionally infinite lines only
IsSemiInfinite | Return true for semi-infinite lines (one end only)
IsSemiWithEnd | Return true for semi-infinite line with an end point
IsSemiWithStart | Return true for semi-infinite line with a start point
Length | Returns non-negative distance between start and end points. Always finite since the start and end points are used to define the direction of the line for (semi) infinite lines and not the extent.
LineType | Overloaded. set line type possibilities are - D3Line.finite D3Line.infinite D3Line.semiWithStart D3Line.semiWithEnd
LTypeToString | Convert line type to string
MirrorX | Overloaded. Mirror X about pivot
MirrorY | Overloaded. Mirror Y about pivot
MirrorZ | Overloaded. Mirror Z about pivot
MoveBy | shift the start and end points by vector v
NearestPoint | Return point on line nearest given point
NearestPointToOrigin | Return point on line closest to origin
OnLine | Overloaded. true if given point is within distance fl_TOLERANCE of line
Parallel | Overloaded. Returns true if lines point in the SAME DIRECTION Tolerance is max angle between the directions measured in RADIANS (Default tolerance=1.E-6 rads) N.B. will return FALSE for antiparallel lines.
PerpendicularDistance | Returns the distance of the arg point from the perpendicularPoint() calculated using previous function above.
PerpendicularPoint | Returns the point on the INFINITELY EXTENDED line from which a perpendicular line can be dropped onto the argument point
PolarAngleInRadians | Returns polar angle of direction of line
Reverse | swap start and end points (reverses direction of line) N.B. semiWithEnd becomes a semiWithStart and vice versa
ScaleBy | Overloaded. Scale coordinates by s about pivot
SetValue | Overloaded. set start and end points of line
Start | Overloaded. set start coordinates of line
ToString | Returns string describing the D3Line
TValue | Distance of point p from start point of line in the direction of the line. The distance is returned in units such that one line length = 1 unit.
UnitDirection | Returns the unit vector of the line

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


Antiparallel Method

AVEVA Maths / Geometry .NET Public Interface

D3Line.Antiparallel Method

Returns True if lines point in OPPOSITE DIRECTIONS (within tolerance Default tolerance=1.E-6 rads)

Overload List

Returns True if lines point in OPPOSITE DIRECTIONS (within tolerance Default tolerance=1.E-6 rads)

public abstract bool Antiparallel(D3Line);

Returns True if lines point in OPPOSITE DIRECTIONS (within tolerance in RADIANS)

public abstract bool Antiparallel(D3Line,double);

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.Antiparallel Method (D3Line)

Returns True if lines point in OPPOSITE DIRECTIONS (within tolerance Default tolerance=1.E-6 rads)

public abstract bool Antiparallel(
D3Line line
);

Parameters

line

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Antiparallel Overload List


D3Line.Antiparallel Method (D3Line, Double)

Returns True if lines point in OPPOSITE DIRECTIONS (within tolerance in RADIANS)

public abstract bool Antiparallel(
D3Line line,
double tolerance
);

Parameters

line
tolerance

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Antiparallel Overload List


D3Line.AzimuthalAngleInRadians Method

Returns azimuthal angle of direction of line

public abstract double AzimuthalAngleInRadians();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


CheckLength Method

AVEVA Maths / Geometry .NET Public Interface

D3Line.CheckLength Method

Return true if distance between start and end points is greater than fl_TOLERANCE

Overload List

Return true if distance between start and end points is greater than fl_TOLERANCE

public abstract bool CheckLength();

Return true if distance between start and end points is greater than minLength

public abstract bool CheckLength(double);

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.CheckLength Method ()

Return true if distance between start and end points is greater than fl_TOLERANCE

public abstract bool CheckLength();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.CheckLength Overload List


D3Line.CheckLength Method (Double)

Return true if distance between start and end points is greater than minLength

public abstract bool CheckLength(
double minLength
);

Parameters

minLength

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.CheckLength Overload List


D3Line.Clone Method

deep copy

public abstract D3Line Clone();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


Coplanar Method

AVEVA Maths / Geometry .NET Public Interface

D3Line.Coplanar Method

Returns TRUE if lines lie in the same plane Returns TRUE If lines are PARALLEL or ANTIPARALLEL. N.B. uses parallel(FiniteLine,tol) and antparallel(FiniteLine,tol) functions with given tolerance. For non-parallel lines- this routine works by finding these two vectors- A: the vector connecting the two start points B: the vector product of the two line directions If the angle between these two lines is PI radians (within default tolerance), then TRUE will be returned. If either input line is less than fl_TOLERANCE in length FALSE will be returned

Overload List

Returns TRUE if lines lie in the same plane Returns TRUE If lines are PARALLEL or ANTIPARALLEL. N.B. uses parallel(FiniteLine,tol) and antparallel(FiniteLine,tol) functions with given tolerance. For non-parallel lines- this routine works by finding these two vectors- A: the vector connecting the two start points B: the vector product of the two line directions If the angle between these two lines is PI radians (within default tolerance), then TRUE will be returned. If either input line is less than fl_TOLERANCE in length FALSE will be returned

public abstract bool Coplanar(D3Line);

Returns TRUE if lines lie in the same plane Returns TRUE If lines are PARALLEL or ANTIPARALLEL. N.B. uses parallel(FiniteLine,tol) and antparallel(FiniteLine,tol) functions with given tolerance. For non-parallel lines- this routine works by finding these two vectors- A: the vector connecting the two start points B: the vector product of the two line directions If the angle between these two lines is PI radians (within tolerance tol), then TRUE will be returned. If either input line is less than fl_TOLERANCE in length FALSE will be returned

public abstract bool Coplanar(D3Line,double);

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.Coplanar Method (D3Line)

Returns TRUE if lines lie in the same plane Returns TRUE If lines are PARALLEL or ANTIPARALLEL. N.B. uses parallel(FiniteLine,tol) and antparallel(FiniteLine,tol) functions with given tolerance. For non-parallel lines- this routine works by finding these two vectors- A: the vector connecting the two start points B: the vector product of the two line directions If the angle between these two lines is PI radians (within default tolerance), then TRUE will be returned. If either input line is less than fl_TOLERANCE in length FALSE will be returned

public abstract bool Coplanar(
D3Line line
);

Parameters

line

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Coplanar Overload List


D3Line.Coplanar Method (D3Line, Double)

Returns TRUE if lines lie in the same plane Returns TRUE If lines are PARALLEL or ANTIPARALLEL. N.B. uses parallel(FiniteLine,tol) and antparallel(FiniteLine,tol) functions with given tolerance. For non-parallel lines- this routine works by finding these two vectors- A: the vector connecting the two start points B: the vector product of the two line directions If the angle between these two lines is PI radians (within tolerance tol), then TRUE will be returned. If either input line is less than fl_TOLERANCE in length FALSE will be returned

public abstract bool Coplanar(
D3Line line,
double tol
);

Parameters

line
tol

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Coplanar Overload List


Create Method

AVEVA Maths / Geometry .NET Public Interface

D3Line.Create Method

Null constructor

Overload List

Null constructor

public static D3Line Create();

Construct a finite line from a D3FiniteLine

public static D3Line Create(D3FiniteLine);

Construct from a finite line D3FiniteLine and type

public static D3Line Create(D3FiniteLine,LTYPE);

Copy constructor

public static D3Line Create(D3Line);

Construct from start and end point (finite line)

public static D3Line Create(D3Point,D3Point);

Construct from start and end points and type

public static D3Line Create(D3Point,D3Point,LTYPE);

Construct from start point and direction (semi-infinite line)

public static D3Line Create(D3Point,D3Vector);

Construct from start point and direction

public static D3Line Create(D3Point,D3Vector,LTYPE);

Construct from 2 sets of coordinates (finite line)

public static D3Line Create(double,double,double,double,double,double);

Construct from 2 sets of coordinates and line type

public static D3Line Create(double,double,double,double,double,double,LTYPE);

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.Create Method ()

Null constructor

public static D3Line Create();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Create Overload List


D3Line.Create Method (D3FiniteLine)

Construct a finite line from a D3FiniteLine

public static D3Line Create(
D3FiniteLine fLine
);

Parameters

fLine

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Create Overload List


D3Line.Create Method (D3FiniteLine, LTYPE)

Construct from a finite line D3FiniteLine and type

public static D3Line Create(
D3FiniteLine fLine,
LTYPE type
);

Parameters

fLine
type

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Create Overload List


D3Line.Create Method (D3Line)

Copy constructor

public static D3Line Create(
D3Line orig
);

Parameters

orig

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Create Overload List


D3Line.Create Method (D3Point, D3Point)

Construct from start and end point (finite line)

public static D3Line Create(
D3Point start,
D3Point end
);

Parameters

start
end

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Create Overload List


D3Line.Create Method (D3Point, D3Point, LTYPE)

Construct from start and end points and type

public static D3Line Create(
D3Point start,
D3Point end,
LTYPE type
);

Parameters

start
end
type

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Create Overload List


D3Line.Create Method (D3Point, D3Vector)

Construct from start point and direction (semi-infinite line)

public static D3Line Create(
D3Point start,
D3Vector dir
);

Parameters

start
dir

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Create Overload List


D3Line.Create Method (D3Point, D3Vector, LTYPE)

Construct from start point and direction

public static D3Line Create(
D3Point start,
D3Vector dir,
LTYPE type
);

Parameters

start
dir
type

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Create Overload List


D3Line.Create Method (Double, Double, Double, Double, Double, Double)

Construct from 2 sets of coordinates (finite line)

public static D3Line Create(
double x1,
double y1,
double z1,
double x2,
double y2,
double z2
);

Parameters

x1
y1
z1
x2
y2
z2

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Create Overload List


D3Line.Create Method (Double, Double, Double, Double, Double, Double, LTYPE)

Construct from 2 sets of coordinates and line type

public static D3Line Create(
double x1,
double y1,
double z1,
double x2,
double y2,
double z2,
LTYPE type
);

Parameters

x1
y1
z1
x2
y2
z2
type

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Create Overload List


D3Line.Direction Method

Returns the direction vector of the line

public abstract D3Vector Direction();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.DistanceFrom Method

returns shortest straight line distance between line and point

public abstract double DistanceFrom(
D3Point point
);

Parameters

point

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.DistanceFromOrigin Method

returns shortest straight line distance between line and origin

public abstract double DistanceFromOrigin();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


End Method

AVEVA Maths / Geometry .NET Public Interface

D3Line.End Method

Returns position at end of line

Overload List

Returns position at end of line

public abstract D3Point End();

set end point of line

public abstract void End(D3Point);

set end coordinates of line

public abstract void End(double,double,double);

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.End Method ()

Returns position at end of line

public abstract D3Point End();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.End Overload List


D3Line.End Method (D3Point)

set end point of line

public abstract void End(
D3Point p
);

Parameters

p

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.End Overload List


D3Line.End Method (Double, Double, Double)

set end coordinates of line

public abstract void End(
double x,
double y,
double z
);

Parameters

x
y
z

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.End Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D3Line.Equals Method

Test for exact equality

Overload List

Test for exact equality

public abstract bool Equals(D3Line);

public override bool Equals(object);

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.Equals Method (D3Line)

Test for exact equality

public abstract bool Equals(
D3Line d2
);

Parameters

d2

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Equals Overload List


D3Line.Equals Method (Object)

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Equals Overload List


D3Line.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.InterPoint Method

Return point on line ratio t (0<= t <= 1.0) from start

public abstract D3Point InterPoint(
double t
);

Parameters

t

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.IsFinite Method

Returns true for line with a start and an end

public abstract bool IsFinite();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.IsInfinite Method

Return true for bi-directionally infinite lines only

public abstract bool IsInfinite();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.IsSemiInfinite Method

Return true for semi-infinite lines (one end only)

public abstract bool IsSemiInfinite();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.IsSemiWithEnd Method

Return true for semi-infinite line with an end point

public abstract bool IsSemiWithEnd();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.IsSemiWithStart Method

Return true for semi-infinite line with a start point

public abstract bool IsSemiWithStart();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.Length Method

Returns non-negative distance between start and end points. Always finite since the start and end points are used to define the direction of the line for (semi) infinite lines and not the extent.

public abstract double Length();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


LineType Method

AVEVA Maths / Geometry .NET Public Interface

D3Line.LineType Method

Return line type {infinite,semiWithStart,semiWithEnd,finite}

Overload List

Return line type {infinite,semiWithStart,semiWithEnd,finite}

public abstract LTYPE LineType();

set line type possibilities are - D3Line.finite D3Line.infinite D3Line.semiWithStart D3Line.semiWithEnd

public abstract void LineType(LTYPE);

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.LineType Method ()

Return line type {infinite,semiWithStart,semiWithEnd,finite}

public abstract LTYPE LineType();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.LineType Overload List


D3Line.LineType Method (LTYPE)

set line type possibilities are - D3Line.finite D3Line.infinite D3Line.semiWithStart D3Line.semiWithEnd

public abstract void LineType(
LTYPE type
);

Parameters

type

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.LineType Overload List


D3Line.LTypeToString Method

Convert line type to string

public abstract string LTypeToString(
LTYPE lt
);

Parameters

lt

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


MirrorX Method

AVEVA Maths / Geometry .NET Public Interface

D3Line.MirrorX Method

Mirror X about origin

Overload List

Mirror X about origin

public abstract void MirrorX();

Mirror X about pivot

public abstract void MirrorX(D3Point);

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.MirrorX Method ()

Mirror X about origin

public abstract void MirrorX();

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.MirrorX Overload List


D3Line.MirrorX Method (D3Point)

Mirror X about pivot

public abstract void MirrorX(
D3Point pivot
);

Parameters

pivot

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.MirrorX Overload List


MirrorY Method

AVEVA Maths / Geometry .NET Public Interface

D3Line.MirrorY Method

Mirroy Y about origin

Overload List

Mirroy Y about origin

public abstract void MirrorY();

Mirror Y about pivot

public abstract void MirrorY(D3Point);

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.MirrorY Method ()

Mirroy Y about origin

public abstract void MirrorY();

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.MirrorY Overload List


D3Line.MirrorY Method (D3Point)

Mirror Y about pivot

public abstract void MirrorY(
D3Point pivot
);

Parameters

pivot

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.MirrorY Overload List


MirrorZ Method

AVEVA Maths / Geometry .NET Public Interface

D3Line.MirrorZ Method

Mirror Z about origin

Overload List

Mirror Z about origin

public abstract void MirrorZ();

Mirror Z about pivot

public abstract void MirrorZ(D3Point);

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.MirrorZ Method ()

Mirror Z about origin

public abstract void MirrorZ();

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.MirrorZ Overload List


D3Line.MirrorZ Method (D3Point)

Mirror Z about pivot

public abstract void MirrorZ(
D3Point pivot
);

Parameters

pivot

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.MirrorZ Overload List


D3Line.MoveBy Method

shift the start and end points by vector v

public abstract void MoveBy(
D3Vector v
);

Parameters

v

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.NearestPoint Method

Return point on line nearest given point

public abstract D3Point NearestPoint(
D3Point pt
);

Parameters

pt

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.NearestPointToOrigin Method

Return point on line closest to origin

public abstract D3Point NearestPointToOrigin();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


OnLine Method

AVEVA Maths / Geometry .NET Public Interface

D3Line.OnLine Method

true if given point is within distance fl_TOLERANCE of line

Overload List

true if given point is within distance fl_TOLERANCE of line

public abstract bool OnLine(D3Point);

true if given point is within distance "tol" of line

public abstract bool OnLine(D3Point,double);

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.OnLine Method (D3Point)

true if given point is within distance fl_TOLERANCE of line

public abstract bool OnLine(
D3Point p
);

Parameters

p

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.OnLine Overload List


D3Line.OnLine Method (D3Point, Double)

true if given point is within distance "tol" of line

public abstract bool OnLine(
D3Point p,
double tol
);

Parameters

p
tol

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.OnLine Overload List


Parallel Method

AVEVA Maths / Geometry .NET Public Interface

D3Line.Parallel Method

Returns true if lines point in the SAME DIRECTION Tolerance is max angle between the directions measured in RADIANS (Default tolerance=1.E-6 rads) N.B. will return FALSE for antiparallel lines.

Overload List

Returns true if lines point in the SAME DIRECTION Tolerance is max angle between the directions measured in RADIANS (Default tolerance=1.E-6 rads) N.B. will return FALSE for antiparallel lines.

public abstract bool Parallel(D3Line);

Returns true if lines point in the SAME DIRECTION Tolerance is max angle between the directions measured in RADIANS N.B. will return FALSE for antiparallel lines.

public abstract bool Parallel(D3Line,double);

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.Parallel Method (D3Line)

Returns true if lines point in the SAME DIRECTION Tolerance is max angle between the directions measured in RADIANS (Default tolerance=1.E-6 rads) N.B. will return FALSE for antiparallel lines.

public abstract bool Parallel(
D3Line line
);

Parameters

line

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Parallel Overload List


D3Line.Parallel Method (D3Line, Double)

Returns true if lines point in the SAME DIRECTION Tolerance is max angle between the directions measured in RADIANS N.B. will return FALSE for antiparallel lines.

public abstract bool Parallel(
D3Line line,
double tolerance
);

Parameters

line
tolerance

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Parallel Overload List


D3Line.PerpendicularDistance Method

Returns the distance of the arg point from the perpendicularPoint() calculated using previous function above.

public abstract double PerpendicularDistance(
D3Point point
);

Parameters

point

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.PerpendicularPoint Method

Returns the point on the INFINITELY EXTENDED line from which a perpendicular line can be dropped onto the argument point

public abstract D3Point PerpendicularPoint(
D3Point point
);

Parameters

point

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.PolarAngleInRadians Method

Returns polar angle of direction of line

public abstract double PolarAngleInRadians();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.Reverse Method

swap start and end points (reverses direction of line) N.B. semiWithEnd becomes a semiWithStart and vice versa

public abstract void Reverse();

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


ScaleBy Method

AVEVA Maths / Geometry .NET Public Interface

D3Line.ScaleBy Method

Scale uniformly by value s

Overload List

Scale uniformly by value s

public abstract void ScaleBy(double);

Scale coordinates by s about pivot

public abstract void ScaleBy(double,D3Point);

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.ScaleBy Method (Double)

Scale uniformly by value s

public abstract void ScaleBy(
double s
);

Parameters

s

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.ScaleBy Overload List


D3Line.ScaleBy Method (Double, D3Point)

Scale coordinates by s about pivot

public abstract void ScaleBy(
double s,
D3Point pivot
);

Parameters

s
pivot

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.ScaleBy Overload List


SetValue Method

AVEVA Maths / Geometry .NET Public Interface

D3Line.SetValue Method

set start and end points of line

Overload List

set start and end points of line

public abstract void SetValue(D3Point,D3Point);

set start and end coordinate points of line

public abstract void SetValue(double,double,double,double,double,double);

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.SetValue Method (D3Point, D3Point)

set start and end points of line

public abstract void SetValue(
D3Point start,
D3Point end
);

Parameters

start
end

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.SetValue Overload List


D3Line.SetValue Method (Double, Double, Double, Double, Double, Double)

set start and end coordinate points of line

public abstract void SetValue(
double x1,
double y1,
double z1,
double x2,
double y2,
double z2
);

Parameters

x1
y1
z1
x2
y2
z2

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.SetValue Overload List


Start Method

AVEVA Maths / Geometry .NET Public Interface

D3Line.Start Method

Returns position at start of line

Overload List

Returns position at start of line

public abstract D3Point Start();

set start point of line

public abstract void Start(D3Point);

set start coordinates of line

public abstract void Start(double,double,double);

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.Start Method ()

Returns position at start of line

public abstract D3Point Start();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Start Overload List


D3Line.Start Method (D3Point)

set start point of line

public abstract void Start(
D3Point p
);

Parameters

p

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Start Overload List


D3Line.Start Method (Double, Double, Double)

set start coordinates of line

public abstract void Start(
double x,
double y,
double z
);

Parameters

x
y
z

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace | D3Line.Start Overload List


D3Line.ToString Method

Returns string describing the D3Line

public abstract string ToString();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.TValue Method

Distance of point p from start point of line in the direction of the line. The distance is returned in units such that one line length = 1 unit.

public abstract double TValue(
D3Point p
);

Parameters

p

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.UnitDirection Method

Returns the unit vector of the line

public abstract D3Vector UnitDirection();

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line Operators

The operators of the D3Line class are listed below. For a complete list of D3Line class members, see the D3Line Members topic.

Public Static Operators

Equality Operator | invoked by left == right. True if start,end and linetype match exactly
Inequality Operator | invoked by left != right. True if any of start, end or lineType does not match excalty

See Also

D3Line Class | D3Line Members | Aveva.Pdms.Maths.Geometry Namespace


D3Line Equality Operator

invoked by left == right. True if start,end and linetype match exactly

public static bool operator ==(
D3Line left,
D3Line right
);

Parameters

left
right

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line Inequality Operator

invoked by left != right. True if any of start, end or lineType does not match excalty

public static bool operator !=(
D3Line left,
D3Line right
);

Parameters

left
right

Return Value

See Also

D3Line Class | Aveva.Pdms.Maths.Geometry Namespace


D3Line.LTYPE Enumeration

four possible line types

public enum D3Line.LTYPE

Members

Member Name | Description
infinite | Infinite line
semiWithStart | Semi-infinite line with start point
semiWithEnd | Semi-infinite line with end point
finite | Finite line

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

Aveva.Pdms.Maths.Geometry Namespace


D3Matrix Class

3x3 matrix This matrix class can represent a 3x3 matrix of double recision quantities. The elements are indexed from (zero,zero,zero).

For a list of all members of this type, see D3Matrix Members.

System.Object
Aveva.Pdms.Maths.Geometry.D3Matrix

public abstract class D3Matrix

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D3Matrix Members | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix Members

D3Matrix overview

Public Static Methods

Create Overloaded. Default constructor

Public Static Operators

Addition Operator | invoked by m1+m2
Division Operator | invoked by m1/scalar
Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right
Multiplication Operator | invoked by m1 * m2
Subtraction Operator | invoked by m1-m2

Public Instance Methods

Add | Add given matrix to this
AsArray9 | Return the 9 values of the matrix in an array
BeIdentity | Set matrix to identity matrix
BeZero | Clear matrix to all zeros
Clone | Return a deep copy
Determinant | Returns the determinant of the matrix
Divide | Divide matrix values by scalar
Equals | Overloaded. Test for equality
GetHashCode |
GetInverse | Returns true if the matrix has an inverse, and the inverse of the matrix as an argument
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Return the value at row i, column j. Args validity checked
Inverse | Return the inverse of the matrix
Invert | Invert the matrix
IsIdentity | Returns true if the matrix is identity matrix
IsOrthogonal | Returns true if the matrix is orthogonal, within tolerance tol
IsSingular | Returns true if the matrix is singular. Result predicts failure of getInverse()/inverse()/invert()
Multiply | Overloaded. Multiply vector by matrix
RotateBy | Rotate the matrix by degX about X, degY about Y, degZ about Z
RotateX | Rotate the matrix by degrees about X
RotateY | Rotate the matrix by degrees about Y
RotateZ | Rotate the matrix by degrees about Z
SetValue | Overloaded. Set value of element at row i column j to be x
Subtract | Subtract given matrix from this
ToOrientationString |
ToString | Returns string containing details of the matrix
Transpose | Return the transpose of the matrix

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix Methods

The methods of the D3Matrix class are listed below. For a complete list of D3Matrix class members, see the D3Matrix Members topic.

Public Static Methods

Create Overloaded. Default constructor

Public Instance Methods

Add | Add given matrix to this
AsArray9 | Return the 9 values of the matrix in an array
BeIdentity | Set matrix to identity matrix
BeZero | Clear matrix to all zeros
Clone | Return a deep copy
Determinant | Returns the determinant of the matrix
Divide | Divide matrix values by scalar
Equals | Overloaded. Test for equality
GetHashCode |
GetInverse | Returns true if the matrix has an inverse, and the inverse of the matrix as an argument
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Return the value at row i, column j. Args validity checked
Inverse | Return the inverse of the matrix
Invert | Invert the matrix
IsIdentity | Returns true if the matrix is identity matrix
IsOrthogonal | Returns true if the matrix is orthogonal, within tolerance tol
IsSingular | Returns true if the matrix is singular. Result predicts failure of getInverse()/inverse()/invert()
Multiply | Overloaded. Multiply vector by matrix
RotateBy | Rotate the matrix by degX about X, degY about Y, degZ about Z
RotateX | Rotate the matrix by degrees about X
RotateY | Rotate the matrix by degrees about Y
RotateZ | Rotate the matrix by degrees about Z
SetValue | Overloaded. Set value of element at row i column j to be x
Subtract | Subtract given matrix from this
ToOrientationString |
ToString | Returns string containing details of the matrix
Transpose | Return the transpose of the matrix

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.Add Method

Add given matrix to this

public abstract D3Matrix Add(
D3Matrix m2
);

Parameters

m2

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.AsArray9 Method

Return the 9 values of the matrix in an array

public abstract double[] AsArray9();

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.BeIdentity Method

Set matrix to identity matrix

public abstract void BeIdentity();

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.BeZero Method

Clear matrix to all zeros

public abstract void BeZero();

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.Clone Method

Return a deep copy

public abstract D3Matrix Clone();

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D3Matrix.Create Method

Default constructor

Overload List

Default constructor

public static D3Matrix Create();

Copy constructor

public static D3Matrix Create(D3Matrix);

Construct a matrix with all zeros, and value diag on the diagonal

public static D3Matrix Create(double);

Constrcu matricx from given array of values (by row)

public static D3Matrix Create(double[]);

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.Create Method ()

Default constructor

public static D3Matrix Create();

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D3Matrix.Create Overload List


D3Matrix.Create Method (D3Matrix)

Copy constructor

public static D3Matrix Create(
D3Matrix matrix
);

Parameters

matrix

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D3Matrix.Create Overload List


D3Matrix.Create Method (Double)

Construct a matrix with all zeros, and value diag on the diagonal

public static D3Matrix Create(
double diag
);

Parameters

diag

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D3Matrix.Create Overload List


D3Matrix.Create Method (Double[])

Constrcu matricx from given array of values (by row)

public static D3Matrix Create(
double[] v
);

Parameters

v

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D3Matrix.Create Overload List


D3Matrix.Determinant Method

Returns the determinant of the matrix

public abstract double Determinant();

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.Divide Method

Divide matrix values by scalar

public abstract D3Matrix Divide(
double scalar
);

Parameters

scalar

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D3Matrix.Equals Method

Test for equality

Overload List

Test for equality

public abstract bool Equals(D3Matrix);

public override bool Equals(object);

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.Equals Method (D3Matrix)

Test for equality

public abstract bool Equals(
D3Matrix d2
);

Parameters

d2

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D3Matrix.Equals Overload List


D3Matrix.Equals Method (Object)

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D3Matrix.Equals Overload List


D3Matrix.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.GetInverse Method

Returns true if the matrix has an inverse, and the inverse of the matrix as an argument

public abstract bool GetInverse(
D3Matrix result
);

Parameters

result

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.GetValue Method

Return the value at row i, column j. Args validity checked

public abstract double GetValue(
int i,
int j
);

Parameters

i
j

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.Inverse Method

Return the inverse of the matrix

public abstract D3Matrix Inverse();

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.Invert Method

Invert the matrix

public abstract bool Invert();

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.IsIdentity Method

Returns true if the matrix is identity matrix

public abstract bool IsIdentity();

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.IsOrthogonal Method

Returns true if the matrix is orthogonal, within tolerance tol

public abstract bool IsOrthogonal(
double tol
);

Parameters

tol

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.IsSingular Method

Returns true if the matrix is singular. Result predicts failure of getInverse()/inverse()/invert()

public abstract bool IsSingular();

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


Multiply Method

AVEVA Maths / Geometry .NET Public Interface

D3Matrix.Multiply Method

Multuiply matrix by given matrix

Overload List

Multuiply matrix by given matrix

public abstract D3Matrix Multiply(D3Matrix);

Multiply vector by matrix

public abstract D3Vector Multiply(D3Vector);

Multiply matrix values by scalar value

public abstract D3Matrix Multiply(double);

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.Multiply Method (D3Matrix)

Multuiply matrix by given matrix

public abstract D3Matrix Multiply(
D3Matrix m2
);

Parameters

m2

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D3Matrix.Multiply Overload List


D3Matrix.Multiply Method (D3Vector)

Multiply vector by matrix

public abstract D3Vector Multiply(
D3Vector v2
);

Parameters

v2

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D3Matrix.Multiply Overload List


D3Matrix.Multiply Method (Double)

Multiply matrix values by scalar value

public abstract D3Matrix Multiply(
double scalar
);

Parameters

scalar

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D3Matrix.Multiply Overload List


D3Matrix.RotateBy Method

Rotate the matrix by degX about X, degY about Y, degZ about Z

public abstract void RotateBy(
double degX,
double degY,
double degZ
);

Parameters

degX
degY
degZ

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.RotateX Method

Rotate the matrix by degrees about X

public abstract void RotateX(
double degrees
);

Parameters

degrees

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.RotateY Method

Rotate the matrix by degrees about Y

public abstract void RotateY(
double degrees
);

Parameters

degrees

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.RotateZ Method

Rotate the matrix by degrees about Z

public abstract void RotateZ(
double degrees
);

Parameters

degrees

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


SetValue Method

AVEVA Maths / Geometry .NET Public Interface

D3Matrix.SetValue Method

Set values into matrix (by row)

Overload List

Set values into matrix (by row)

public abstract void SetValue(double[]);

Set value of element at row i column j to be x

public abstract void SetValue(int,int,double);

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.SetValue Method (Double[])

Set values into matrix (by row)

public abstract void SetValue(
double[] v
);

Parameters

v

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D3Matrix.SetValue Overload List


D3Matrix.SetValue Method (Int32, Int32, Double)

Set value of element at row i column j to be x

public abstract void SetValue(
int i,
int j,
double x
);

Parameters

i
j
x

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace | D3Matrix.SetValue Overload List


D3Matrix.Subtract Method

Subtract given matrix from this

public abstract D3Matrix Subtract(
D3Matrix m2
);

Parameters

m2

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.ToOrientationString Method

public abstract string ToOrientationString();

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.ToString Method

Returns string containing details of the matrix

public abstract string ToString();

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix.Transpose Method

Return the transpose of the matrix

public abstract D3Matrix Transpose();

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix Operators

The operators of the D3Matrix class are listed below. For a complete list of D3Matrix class members, see the D3Matrix Members topic.

Public Static Operators

Addition Operator | invoked by m1+m2
Division Operator | invoked by m1/scalar
Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right
Multiplication Operator | invoked by m1 * m2
Subtraction Operator | invoked by m1-m2

See Also

D3Matrix Class | D3Matrix Members | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix Addition Operator

invoked by m1+m2

public static D3Matrix operator +(
D3Matrix m1,
D3Matrix m2
);

Parameters

m1
m2

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix Division Operator

invoked by m1/scalar

public static D3Matrix operator /(
D3Matrix m1,
double scalar
);

Parameters

m1
scalar

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix Equality Operator

invoked by left == right

public static bool operator ==(
D3Matrix left,
D3Matrix right
);

Parameters

left
right

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix Inequality Operator

invoked by left != right

public static bool operator !=(
D3Matrix left,
D3Matrix right
);

Parameters

left
right

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix Multiplication Operator

invoked by m1 * m2

public static D3Matrix operator *(
D3Matrix m1,
D3Matrix m2
);

Parameters

m1
m2

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3Matrix Subtraction Operator

invoked by m1-m2

public static D3Matrix operator -(
D3Matrix m1,
D3Matrix m2
);

Parameters

m1
m2

Return Value

See Also

D3Matrix Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane Class

Class definition for an oriented plane This class is intended for use as a local coordinate system so that plane coordinate geometry can be performed. Conceptually it has a one-to-one correspondence with PDMS's orientated plane. Apart from its direct use for the 2-d geometry constructor, it is intended that arcs, planar curves and lines in 3-d are reduced to 2-d via mth2<obj>(const mth3<obj>, const D3OrientedPlane); To create the plane you need to supply an origin (D3Point) and two axes u,v - both D3Vector. The plane normal is then defined by u x v. This class always creates a plane with right-handed orthonormal axes. An internal flag is set if the data is invalid (e.g. the input vectors are null or colinear) and an attempt to use an invalid class will result in an assertion failure. Applications should use the 'inValid()' method to preemptively trap this condition. A cast to a D3Plane exists so that geometric operations on a D3Plane will also work on an D3OrientedPlane; you can also cast to a D3Transform.

For a list of all members of this type, see D3OrientedPlane Members.

System.Object
Aveva.Pdms.Maths.Geometry.D3OrientedPlane

public abstract class D3OrientedPlane

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D3OrientedPlane Members | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane Members

D3OrientedPlane overview

Public Static Methods

Create Overloaded. By default construct a natural right-handed plane

Public Static Operators

Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right

Public Instance Methods

AsPlane | Cast a D3OrientedPlane to a D3Plane
AsTransform | Cast a D3OrientedPlane to a D3Transform
Clone | Returns a deep copy of the D3OrientedPlane
Equals | Overloaded. test for equality
GetHashCode |
GetNormal | Get the plane normal
GetOrigin | Return the plane's origin
GetType (inherited from Object) | Gets the Type of the current instance.
GetUAxis | Return the U axis
GetVAxis | Return the V axis
InValid | Returns true if the class data if invalid
MapFromPlane | maps point in plane space to user co-ordinates
MapToPlane | maps point in user space to plane co-ordinates
OnPlane | Returns true if the given point lies on the plane
ProjectOnto | Project a point onto the plane and return the world coord
SetOrigin | Set the origin (equivalent to moveTo)
SetValues | Set the Euler angles (equivalent to rotate to)
ToLocal | Returns the D3point projected onto the 2-d plane
ToString | Returns a string describing the values of the D3OrientedPlane
ToWorld | Returns the D2_point in 3-d world

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane Methods

The methods of the D3OrientedPlane class are listed below. For a complete list of D3OrientedPlane class members, see the D3OrientedPlane Members topic.

Public Static Methods

Create Overloaded. By default construct a natural right-handed plane

Public Instance Methods

AsPlane | Cast a D3OrientedPlane to a D3Plane
AsTransform | Cast a D3OrientedPlane to a D3Transform
Clone | Returns a deep copy of the D3OrientedPlane
Equals | Overloaded. test for equality
GetHashCode |
GetNormal | Get the plane normal
GetOrigin | Return the plane's origin
GetType (inherited from Object) | Gets the Type of the current instance.
GetUAxis | Return the U axis
GetVAxis | Return the V axis
InValid | Returns true if the class data if invalid
MapFromPlane | maps point in plane space to user co-ordinates
MapToPlane | maps point in user space to plane co-ordinates
OnPlane | Returns true if the given point lies on the plane
ProjectOnto | Project a point onto the plane and return the world coord
SetOrigin | Set the origin (equivalent to moveTo)
SetValues | Set the Euler angles (equivalent to rotate to)
ToLocal | Returns the D3point projected onto the 2-d plane
ToString | Returns a string describing the values of the D3OrientedPlane
ToWorld | Returns the D2_point in 3-d world

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.AsPlane Method

Cast a D3OrientedPlane to a D3Plane

public abstract D3Plane AsPlane();

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.AsTransform Method

Cast a D3OrientedPlane to a D3Transform

public abstract D3Transform AsTransform();

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.Clone Method

Returns a deep copy of the D3OrientedPlane

public abstract D3OrientedPlane Clone();

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D3OrientedPlane.Create Method

By default construct a natural right-handed plane

Overload List

By default construct a natural right-handed plane

public static D3OrientedPlane Create();

Copy a OrientedPlane

public static D3OrientedPlane Create(D3OrientedPlane);

Construct from a plane

public static D3OrientedPlane Create(D3Plane);

Construct plane from origin, u axis and v axis

public static D3OrientedPlane Create(D3Point,D3Vector,D3Vector);

Construct a D3OrientedPlane from a point and three Euler angles

public static D3OrientedPlane Create(D3Point,double,double,double);

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.Create Method ()

By default construct a natural right-handed plane

public static D3OrientedPlane Create();

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace | D3OrientedPlane.Create Overload List


D3OrientedPlane.Create Method (D3OrientedPlane)

Copy a OrientedPlane

public static D3OrientedPlane Create(
D3OrientedPlane p
);

Parameters

p

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace | D3OrientedPlane.Create Overload List


D3OrientedPlane.Create Method (D3Plane)

Construct from a plane

public static D3OrientedPlane Create(
D3Plane plane
);

Parameters

plane

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace | D3OrientedPlane.Create Overload List


D3OrientedPlane.Create Method (D3Point, D3Vector, D3Vector)

Construct plane from origin, u axis and v axis

public static D3OrientedPlane Create(
D3Point origin,
D3Vector u,
D3Vector v
);

Parameters

origin
u
v

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace | D3OrientedPlane.Create Overload List


D3OrientedPlane.Create Method (D3Point, Double, Double, Double)

Construct a D3OrientedPlane from a point and three Euler angles

public static D3OrientedPlane Create(
D3Point origin,
double e1,
double e2,
double e3
);

Parameters

origin
e1
e2
e3

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace | D3OrientedPlane.Create Overload List


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D3OrientedPlane.Equals Method

test for equality

Overload List

test for equality

public abstract bool Equals(D3OrientedPlane);

public override bool Equals(object);

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.Equals Method (D3OrientedPlane)

test for equality

public abstract bool Equals(
D3OrientedPlane p
);

Parameters

p

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace | D3OrientedPlane.Equals Overload List


D3OrientedPlane.Equals Method (Object)

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace | D3OrientedPlane.Equals Overload List


D3OrientedPlane.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.GetNormal Method

Get the plane normal

public abstract D3Vector GetNormal();

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.GetOrigin Method

Return the plane's origin

public abstract D3Point GetOrigin();

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.GetUAxis Method

Return the U axis

public abstract D3Vector GetUAxis();

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.GetVAxis Method

Return the V axis

public abstract D3Vector GetVAxis();

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.InValid Method

Returns true if the class data if invalid

public abstract bool InValid();

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.MapFromPlane Method

maps point in plane space to user co-ordinates

public abstract D3Point MapFromPlane(
D3Point pt
);

Parameters

pt

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.MapToPlane Method

maps point in user space to plane co-ordinates

public abstract D3Point MapToPlane(
D3Point pt
);

Parameters

pt

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.OnPlane Method

Returns true if the given point lies on the plane

public abstract bool OnPlane(
D3Point pt
);

Parameters

pt

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.ProjectOnto Method

Project a point onto the plane and return the world coord

public abstract D3Point ProjectOnto(
D3Point p
);

Parameters

p

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.SetOrigin Method

Set the origin (equivalent to moveTo)

public abstract void SetOrigin(
D3Point ori
);

Parameters

ori

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.SetValues Method

Set the Euler angles (equivalent to rotate to)

public abstract void SetValues(
double e1,
double e2,
double e3
);

Parameters

e1
e2
e3

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.ToLocal Method

Returns the D3point projected onto the 2-d plane

public abstract D2Point ToLocal(
D3Point p
);

Parameters

p

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.ToString Method

Returns a string describing the values of the D3OrientedPlane

public abstract string ToString();

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane.ToWorld Method

Returns the D2_point in 3-d world

public abstract D3Point ToWorld(
D2Point p
);

Parameters

p

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane Operators

The operators of the D3OrientedPlane class are listed below. For a complete list of D3OrientedPlane class members, see the D3OrientedPlane Members topic.

Public Static Operators

Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right

See Also

D3OrientedPlane Class | D3OrientedPlane Members | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane Equality Operator

invoked by left == right

public static bool operator ==(
D3OrientedPlane left,
D3OrientedPlane right
);

Parameters

left
right

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3OrientedPlane Inequality Operator

invoked by left != right

public static bool operator !=(
D3OrientedPlane left,
D3OrientedPlane right
);

Parameters

left
right

Return Value

See Also

D3OrientedPlane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane Class

A 3-D Plane Class (with double values) With normal n and dist d, point x is: on the plane if: n.x + d = 0 above the plane if: n.x + d > 0 Alternative format is (a,b,c;d) - point (x,y,z) is above the plane if: ax + by + cz + d > 0 normal always has magnitude 1.

For a list of all members of this type, see D3Plane Members.

System.Object
Aveva.Pdms.Maths.Geometry.D3Plane

public abstract class D3Plane

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D3Plane Members | Aveva.Pdms.Maths.Geometry Namespace


D3Plane Members

D3Plane overview

Public Static Methods

Create Overloaded. Default constructor

Public Static Operators

Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right

Public Instance Methods

Clone | deep copy
Ddistance | Return the distance of the given point from the plane
Equals | Overloaded. test for equality
GetA | Returns the X direction of the normal to the plane
GetB | Return the Y direction of the normal to the plane
GetC | Return the Z direction of the normal to the plane
GetD | Return the offset of the plane from the origin
GetHashCode |
GetIntersectionWithLine | Return the point at the intersection of the line and the plane. Returns false if they do not intersect
GetNormal | Return the vector normal to the plane
GetOffset | Return the offset of the plane from the origin
GetType (inherited from Object) | Gets the Type of the current instance.
SetValue | Overloaded. Set the normal and a point on the plane
Side | Return which side of the line the point lies on
ToString | Return a string containing details of the plane

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane Methods

The methods of the D3Plane class are listed below. For a complete list of D3Plane class members, see the D3Plane Members topic.

Public Static Methods

Create Overloaded. Default constructor

Public Instance Methods

Clone | deep copy
Ddistance | Return the distance of the given point from the plane
Equals | Overloaded. test for equality
GetA | Returns the X direction of the normal to the plane
GetB | Return the Y direction of the normal to the plane
GetC | Return the Z direction of the normal to the plane
GetD | Return the offset of the plane from the origin
GetHashCode |
GetIntersectionWithLine | Return the point at the intersection of the line and the plane. Returns false if they do not intersect
GetNormal | Return the vector normal to the plane
GetOffset | Return the offset of the plane from the origin
GetType (inherited from Object) | Gets the Type of the current instance.
SetValue | Overloaded. Set the normal and a point on the plane
Side | Return which side of the line the point lies on
ToString | Return a string containing details of the plane

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane.Clone Method

deep copy

public abstract D3Plane Clone();

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D3Plane.Create Method

Default constructor

Overload List

Default constructor

public static D3Plane Create();

Copy constructor

public static D3Plane Create(D3Plane);

Construct a plane from a normal vector and a point

public static D3Plane Create(D3Vector,D3Point);

Construct a plane from a normal vector and an offset

public static D3Plane Create(D3Vector,double);

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane.Create Method ()

Default constructor

public static D3Plane Create();

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace | D3Plane.Create Overload List


D3Plane.Create Method (D3Plane)

Copy constructor

public static D3Plane Create(
D3Plane plane
);

Parameters

plane

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace | D3Plane.Create Overload List


D3Plane.Create Method (D3Vector, D3Point)

Construct a plane from a normal vector and a point

public static D3Plane Create(
D3Vector norm,
D3Point pt
);

Parameters

norm
pt

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace | D3Plane.Create Overload List


D3Plane.Create Method (D3Vector, Double)

Construct a plane from a normal vector and an offset

public static D3Plane Create(
D3Vector norm,
double d
);

Parameters

norm
d

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace | D3Plane.Create Overload List


D3Plane.Ddistance Method

Return the distance of the given point from the plane

public abstract double Ddistance(
D3Point pt
);

Parameters

pt

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D3Plane.Equals Method

test for equality

Overload List

test for equality

public abstract bool Equals(D3Plane);

public override bool Equals(object);

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane.Equals Method (D3Plane)

test for equality

public abstract bool Equals(
D3Plane d2
);

Parameters

d2

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace | D3Plane.Equals Overload List


D3Plane.Equals Method (Object)

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace | D3Plane.Equals Overload List


D3Plane.GetA Method

Returns the X direction of the normal to the plane

public abstract double GetA();

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane.GetB Method

Return the Y direction of the normal to the plane

public abstract double GetB();

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane.GetC Method

Return the Z direction of the normal to the plane

public abstract double GetC();

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane.GetD Method

Return the offset of the plane from the origin

public abstract double GetD();

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane.GetIntersectionWithLine Method

Return the point at the intersection of the line and the plane. Returns false if they do not intersect

public abstract bool GetIntersectionWithLine(
D3Point linePt,
D3Vector lineDir,
D3Point intersectionPoint
);

Parameters

linePt
lineDir
intersectionPoint

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane.GetNormal Method

Return the vector normal to the plane

public abstract D3Vector GetNormal();

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane.GetOffset Method

Return the offset of the plane from the origin

public abstract double GetOffset();

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


SetValue Method

AVEVA Maths / Geometry .NET Public Interface

D3Plane.SetValue Method

Set the normal and a point on the plane

Overload List

Set the normal and a point on the plane

public abstract void SetValue(D3Vector,D3Point);

Set normal and offset values

public abstract void SetValue(D3Vector,double);

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane.SetValue Method (D3Vector, D3Point)

Set the normal and a point on the plane

public abstract void SetValue(
D3Vector norm,
D3Point pt
);

Parameters

norm
pt

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace | D3Plane.SetValue Overload List


D3Plane.SetValue Method (D3Vector, Double)

Set normal and offset values

public abstract void SetValue(
D3Vector norm,
double d
);

Parameters

norm
d

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace | D3Plane.SetValue Overload List


D3Plane.Side Method

Return which side of the line the point lies on

public abstract int Side(
D3Point pt,
double tol
);

Parameters

pt
tol

Return Value

1=above, 0=on, -1=below

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane.ToString Method

Return a string containing details of the plane

public abstract string ToString();

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane Operators

The operators of the D3Plane class are listed below. For a complete list of D3Plane class members, see the D3Plane Members topic.

Public Static Operators

Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right

See Also

D3Plane Class | D3Plane Members | Aveva.Pdms.Maths.Geometry Namespace


D3Plane Equality Operator

invoked by left == right

public static bool operator ==(
D3Plane left,
D3Plane right
);

Parameters

left
right

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Plane Inequality Operator

invoked by left != right

public static bool operator !=(
D3Plane left,
D3Plane right
);

Parameters

left
right

Return Value

See Also

D3Plane Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point Class

3D Point class

For a list of all members of this type, see D3Point Members.

System.Object
Aveva.Pdms.Maths.Geometry.D3Point

public abstract class D3Point

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D3Point Members | Aveva.Pdms.Maths.Geometry Namespace


D3Point Members

D3Point overview

Public Static Methods

Create Overloaded. Default constructor

Public Static Operators

Addition Operator | invoked by p1 + v1
Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right
Subtraction Operator | Overloaded. invoked by p1-p2

Public Instance Properties

X | set/get X coordinate
Y | set/get Y coordinate
Z | set/get Z coordinate

Public Instance Methods

Add | Add a point to a vector to create new point
AsD2Point | Convert to 2D point
AsVector | explicit conversion to D3Vector
Clone | Deep copy
Ddistance | Returns the distance from the given point
Equals | Overloaded. Returns TRUE if p is within default distance of object point
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MirrorX | Overloaded. Set to position mirror X about pivot
MirrorY | Overloaded. Set to position mirror Y about pivot
MirrorZ | Overloaded. Set to position mirror Z about pivot
MoveBy | Overloaded. Move point by given delata values
MoveTo | Move point to absolute position x,y,z
Parse | Creates a D3Point from a string of the format:"xxx,yyy,zzz" (opposite of ToString)
ScaleBy | Overloaded. Scale about pivot
SetXYZ | Set x,y,z coordinate values
Subtract | Overloaded. Subtract two points to get a vector
ToString | Returns a string describing the contents of the D3Point
WithinTolerance | Returns true if point p is within Tolerance tol of this point

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point Properties

The properties of the D3Point class are listed below. For a complete list of D3Point class members, see the D3Point Members topic.

Public Instance Properties

X | set/get X coordinate
Y | set/get Y coordinate
Z | set/get Z coordinate

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


X Property

AVEVA Maths / Geometry .NET Public Interface

D3Point.X Property

set/get X coordinate

public abstract double X {get; set;}

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


Y Property

AVEVA Maths / Geometry .NET Public Interface

D3Point.Y Property

set/get Y coordinate

public abstract double Y {get; set;}

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


Z Property

AVEVA Maths / Geometry .NET Public Interface

D3Point.Z Property

set/get Z coordinate

public abstract double Z {get; set;}

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point Methods

The methods of the D3Point class are listed below. For a complete list of D3Point class members, see the D3Point Members topic.

Public Static Methods

Create Overloaded. Default constructor

Public Instance Methods

Add | Add a point to a vector to create new point
AsD2Point | Convert to 2D point
AsVector | explicit conversion to D3Vector
Clone | Deep copy
Ddistance | Returns the distance from the given point
Equals | Overloaded. Returns TRUE if p is within default distance of object point
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
MirrorX | Overloaded. Set to position mirror X about pivot
MirrorY | Overloaded. Set to position mirror Y about pivot
MirrorZ | Overloaded. Set to position mirror Z about pivot
MoveBy | Overloaded. Move point by given delata values
MoveTo | Move point to absolute position x,y,z
Parse | Creates a D3Point from a string of the format:"xxx,yyy,zzz" (opposite of ToString)
ScaleBy | Overloaded. Scale about pivot
SetXYZ | Set x,y,z coordinate values
Subtract | Overloaded. Subtract two points to get a vector
ToString | Returns a string describing the contents of the D3Point
WithinTolerance | Returns true if point p is within Tolerance tol of this point

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point.Add Method

Add a point to a vector to create new point

public abstract D3Point Add(
D3Vector v1
);

Parameters

v1

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point.AsD2Point Method

Convert to 2D point

public abstract D2Point AsD2Point();

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point.AsVector Method

explicit conversion to D3Vector

public abstract D3Vector AsVector();

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point.Clone Method

Deep copy

public abstract D3Point Clone();

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D3Point.Create Method

Default constructor

Overload List

Default constructor

public static D3Point Create();

Copy a D3Point

public static D3Point Create(D3Point);

Construct a D3Point from 3 coordinates

public static D3Point Create(double,double,double);

Construct a D3Point from an array of 3 coordinates

public static D3Point Create(double[]);

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point.Create Method ()

Default constructor

public static D3Point Create();

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.Create Overload List


D3Point.Create Method (D3Point)

Copy a D3Point

public static D3Point Create(
D3Point p
);

Parameters

p

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.Create Overload List


D3Point.Create Method (Double, Double, Double)

Construct a D3Point from 3 coordinates

public static D3Point Create(
double x,
double y,
double z
);

Parameters

x
y
z

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.Create Overload List


D3Point.Create Method (Double[])

Construct a D3Point from an array of 3 coordinates

public static D3Point Create(
double[] v
);

Parameters

v

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.Create Overload List


D3Point.Ddistance Method

Returns the distance from the given point

public abstract double Ddistance(
D3Point b
);

Parameters

b

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D3Point.Equals Method

Returns TRUE if p is within default distance of object point

Overload List

Returns TRUE if p is within default distance of object point

public abstract bool Equals(D3Point);

Returns TRUE if p is within distance delta of object point

public abstract bool Equals(D3Point,double);

public override bool Equals(object);

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point.Equals Method (D3Point)

Returns TRUE if p is within default distance of object point

public abstract bool Equals(
D3Point p
);

Parameters

p

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.Equals Overload List


D3Point.Equals Method (D3Point, Double)

Returns TRUE if p is within distance delta of object point

public abstract bool Equals(
D3Point p,
double delta
);

Parameters

p
delta

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.Equals Overload List


D3Point.Equals Method (Object)

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.Equals Overload List


D3Point.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


MirrorX Method

AVEVA Maths / Geometry .NET Public Interface

D3Point.MirrorX Method

Set to position mirror X about origin

Overload List

Set to position mirror X about origin

public abstract void MirrorX();

Set to position mirror X about pivot

public abstract void MirrorX(D3Point);

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point.MirrorX Method ()

Set to position mirror X about origin

public abstract void MirrorX();

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.MirrorX Overload List


D3Point.MirrorX Method (D3Point)

Set to position mirror X about pivot

public abstract void MirrorX(
D3Point pivot
);

Parameters

pivot

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.MirrorX Overload List


MirrorY Method

AVEVA Maths / Geometry .NET Public Interface

D3Point.MirrorY Method

Set to position mirror Y about origin

Overload List

Set to position mirror Y about origin

public abstract void MirrorY();

Set to position mirror Y about pivot

public abstract void MirrorY(D3Point);

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point.MirrorY Method ()

Set to position mirror Y about origin

public abstract void MirrorY();

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.MirrorY Overload List


D3Point.MirrorY Method (D3Point)

Set to position mirror Y about pivot

public abstract void MirrorY(
D3Point pivot
);

Parameters

pivot

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.MirrorY Overload List


MirrorZ Method

AVEVA Maths / Geometry .NET Public Interface

D3Point.MirrorZ Method

Set to position with mirror Z about origin

Overload List

Set to position with mirror Z about origin

public abstract void MirrorZ();

Set to position mirror Z about pivot

public abstract void MirrorZ(D3Point);

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point.MirrorZ Method ()

Set to position with mirror Z about origin

public abstract void MirrorZ();

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.MirrorZ Overload List


D3Point.MirrorZ Method (D3Point)

Set to position mirror Z about pivot

public abstract void MirrorZ(
D3Point pivot
);

Parameters

pivot

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.MirrorZ Overload List


MoveBy Method

AVEVA Maths / Geometry .NET Public Interface

D3Point.MoveBy Method

Move along the specified vector

Overload List

Move along the specified vector

public abstract void MoveBy(D3Vector);

Move point by given delata values

public abstract void MoveBy(double,double,double);

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point.MoveBy Method (D3Vector)

Move along the specified vector

public abstract void MoveBy(
D3Vector v
);

Parameters

v

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.MoveBy Overload List


D3Point.MoveBy Method (Double, Double, Double)

Move point by given delata values

public abstract void MoveBy(
double x,
double y,
double z
);

Parameters

x
y
z

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.MoveBy Overload List


D3Point.MoveTo Method

Move point to absolute position x,y,z

public abstract void MoveTo(
double x,
double y,
double z
);

Parameters

x
y
z

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point.Parse Method

Creates a D3Point from a string of the format:"xxx,yyy,zzz" (opposite of ToString)

public abstract D3Point Parse(
string str
);

Parameters

str

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


ScaleBy Method

AVEVA Maths / Geometry .NET Public Interface

D3Point.ScaleBy Method

Scale uniformly about origin

Overload List

Scale uniformly about origin

public abstract void ScaleBy(double);

Scale about pivot

public abstract void ScaleBy(double,D3Point);

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point.ScaleBy Method (Double)

Scale uniformly about origin

public abstract void ScaleBy(
double s
);

Parameters

s

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.ScaleBy Overload List


D3Point.ScaleBy Method (Double, D3Point)

Scale about pivot

public abstract void ScaleBy(
double s,
D3Point pivot
);

Parameters

s
pivot

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.ScaleBy Overload List


D3Point.SetXYZ Method

Set x,y,z coordinate values

public abstract void SetXYZ(
double x,
double y,
double z
);

Parameters

x
y
z

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


Subtract Method

AVEVA Maths / Geometry .NET Public Interface

D3Point.Subtract Method

Subtract two points to get a vector

Overload List

Subtract two points to get a vector

public abstract D3Vector Subtract(D3Point);

Subtract a vector from apoint to create new point

public abstract D3Point Subtract(D3Vector);

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point.Subtract Method (D3Point)

Subtract two points to get a vector

public abstract D3Vector Subtract(
D3Point p1
);

Parameters

p1

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.Subtract Overload List


D3Point.Subtract Method (D3Vector)

Subtract a vector from apoint to create new point

public abstract D3Point Subtract(
D3Vector v1
);

Parameters

v1

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3Point.Subtract Overload List


D3Point.ToString Method

Returns a string describing the contents of the D3Point

public abstract string ToString();

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point.WithinTolerance Method

Returns true if point p is within Tolerance tol of this point

public abstract bool WithinTolerance(
D3Point p,
double tol
);

Parameters

p
tol

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point Operators

The operators of the D3Point class are listed below. For a complete list of D3Point class members, see the D3Point Members topic.

Public Static Operators

Addition Operator | invoked by p1 + v1
Equality Operator | invoked by left == right
Inequality Operator | invoked by left != right
Subtraction Operator | Overloaded. invoked by p1-p2

See Also

D3Point Class | D3Point Members | Aveva.Pdms.Maths.Geometry Namespace


D3Point Addition Operator

invoked by p1 + v1

public static D3Point operator +(
D3Point p1,
D3Vector v1
);

Parameters

p1
v1

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point Equality Operator

invoked by left == right

public static bool operator ==(
D3Point left,
D3Point right
);

Parameters

left
right

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point Inequality Operator

invoked by left != right

public static bool operator !=(
D3Point left,
D3Point right
);

Parameters

left
right

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point Subtraction Operator

invoked by p1-p2

Overload List

invoked by p1-p2

public static D3Vector Subtraction Operator(D3Point,D3Point);

invoked by p1-v1

public static D3Point Subtraction Operator(D3Point,D3Vector);

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace


D3Point Subtraction Operator

invoked by p1-p2

public static D3Vector operator -(
D3Point p1,
D3Point p2
);

Parameters

p1
p2

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3PointSubtraction Operator Overload List


D3Point Subtraction Operator

invoked by p1-v1

public static D3Point operator -(
D3Point p1,
D3Vector v1
);

Parameters

p1
v1

Return Value

See Also

D3Point Class | Aveva.Pdms.Maths.Geometry Namespace | D3PointSubtraction Operator Overload List


D3Transform Class

D3Transform - solid body transformations

For a list of all members of this type, see D3Transform Members.

System.Object
Aveva.Pdms.Maths.Geometry.D3Transform

public abstract class D3Transform

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D3Transform Members | Aveva.Pdms.Maths.Geometry Namespace


D3Transform Members

D3Transform overview

Public Static Methods

Create Overloaded. Default constructor

Public Static Operators

Equality Operator | invoked by left==right
Inequality Operator | invoked by left != right
Multiplication Operator | invoked by t1*t2

Public Instance Methods

AsArray12 | Returns array containing rotation matrix (in column order) and shift
BeIdentity | Set the transform to be the identity transform
Clone | Deep copy
Determinant | Return the determinant of the rotation matrix
Equals | Overloaded. Test for equality
GetHashCode |
GetInverse | calculate inverse transformation - returns "true" and sets result if successful; returns false and result remains unaltered in the case of a singular transformation
GetRot | Return the rotation matrix
GetShift | Return the shift vector
GetType (inherited from Object) | Gets the Type of the current instance.
Inverse | Invert the transform
Invert | invert transformation - returns "true" if successful; returns false and remains unaltered in the case of a singular transformation
IsIdentity | Return true if this is an identity transform
IsOrthogonal | Return true if the rotation matrix is orthogonal
IsSingular | Returns true if determinant is zero
Map | Overloaded. Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - point posFrom is mapped onto posTo, - vector vec1From is mapped onto vec1To, and - vector vec2From is mapped as closely as is possible onto vec2To.
MapOriXTo | Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - the origin is mapped onto pos, and - the x-axis is mapped onto vec.
MapOriXYTo | Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - the origin is mapped onto pos, - the x-axis is mapped onto vec1, and - the y-axis is mapped as closely as is possible onto vec2
MoveBy | Overloaded. Apply relative shift by given vector
Multiply | Overloaded. Transform given limits box
RotateBy | Rotate about X,Y,Z
RotateX | apply rotation in X by pre-multiplication
RotateY | apply rotation in Y by pre-multiplication
RotateZ | apply rotation in Z by pre-multiplication
SetRotation | Set rotation matrix
SetShift | Set shift vector
SetValue | Set matrix and shift from array of 12 values
TakeToZAxis | Make the transformation take the given vector to the z axis
ToString | Return a string containing details of the transform
Transform | Apply transformation to a plane. Works for any non-singular transformation, including a non-orthogonal transformation (i.e. with scaling/shearing/reflection).

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform Methods

The methods of the D3Transform class are listed below. For a complete list of D3Transform class members, see the D3Transform Members topic.

Public Static Methods

Create Overloaded. Default constructor

Public Instance Methods

AsArray12 | Returns array containing rotation matrix (in column order) and shift
BeIdentity | Set the transform to be the identity transform
Clone | Deep copy
Determinant | Return the determinant of the rotation matrix
Equals | Overloaded. Test for equality
GetHashCode |
GetInverse | calculate inverse transformation - returns "true" and sets result if successful; returns false and result remains unaltered in the case of a singular transformation
GetRot | Return the rotation matrix
GetShift | Return the shift vector
GetType (inherited from Object) | Gets the Type of the current instance.
Inverse | Invert the transform
Invert | invert transformation - returns "true" if successful; returns false and remains unaltered in the case of a singular transformation
IsIdentity | Return true if this is an identity transform
IsOrthogonal | Return true if the rotation matrix is orthogonal
IsSingular | Returns true if determinant is zero
Map | Overloaded. Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - point posFrom is mapped onto posTo, - vector vec1From is mapped onto vec1To, and - vector vec2From is mapped as closely as is possible onto vec2To.
MapOriXTo | Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - the origin is mapped onto pos, and - the x-axis is mapped onto vec.
MapOriXYTo | Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - the origin is mapped onto pos, - the x-axis is mapped onto vec1, and - the y-axis is mapped as closely as is possible onto vec2
MoveBy | Overloaded. Apply relative shift by given vector
Multiply | Overloaded. Transform given limits box
RotateBy | Rotate about X,Y,Z
RotateX | apply rotation in X by pre-multiplication
RotateY | apply rotation in Y by pre-multiplication
RotateZ | apply rotation in Z by pre-multiplication
SetRotation | Set rotation matrix
SetShift | Set shift vector
SetValue | Set matrix and shift from array of 12 values
TakeToZAxis | Make the transformation take the given vector to the z axis
ToString | Return a string containing details of the transform
Transform | Apply transformation to a plane. Works for any non-singular transformation, including a non-orthogonal transformation (i.e. with scaling/shearing/reflection).

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.AsArray12 Method

Returns array containing rotation matrix (in column order) and shift

public abstract double[] AsArray12();

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.BeIdentity Method

Set the transform to be the identity transform

public abstract void BeIdentity();

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.Clone Method

Deep copy

public abstract D3Transform Clone();

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D3Transform.Create Method

Default constructor

Overload List

Default constructor

public static D3Transform Create();

Construct a transform from a rotation matrix and a shift vector

public static D3Transform Create(D3Matrix,D3Vector);

Copy constructor

public static D3Transform Create(D3Transform);

Construct a transform from an array of 12 values (in column order)

public static D3Transform Create(double[]);

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.Create Method ()

Default constructor

public static D3Transform Create();

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D3Transform.Create Overload List


D3Transform.Create Method (D3Matrix, D3Vector)

Construct a transform from a rotation matrix and a shift vector

public static D3Transform Create(
D3Matrix theRot,
D3Vector theShift
);

Parameters

theRot
theShift

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D3Transform.Create Overload List


D3Transform.Create Method (D3Transform)

Copy constructor

public static D3Transform Create(
D3Transform transform
);

Parameters

transform

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D3Transform.Create Overload List


D3Transform.Create Method (Double[])

Construct a transform from an array of 12 values (in column order)

public static D3Transform Create(
double[] array12
);

Parameters

array12

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D3Transform.Create Overload List


D3Transform.Determinant Method

Return the determinant of the rotation matrix

public abstract double Determinant();

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D3Transform.Equals Method

Test for equality

Overload List

Test for equality

public abstract bool Equals(D3Transform);

public override bool Equals(object);

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.Equals Method (D3Transform)

Test for equality

public abstract bool Equals(
D3Transform d2
);

Parameters

d2

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D3Transform.Equals Overload List


D3Transform.Equals Method (Object)

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D3Transform.Equals Overload List


D3Transform.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.GetInverse Method

calculate inverse transformation - returns "true" and sets result if successful; returns false and result remains unaltered in the case of a singular transformation

public abstract bool GetInverse(
D3Transform result
);

Parameters

result

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.GetRot Method

Return the rotation matrix

public abstract D3Matrix GetRot();

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.GetShift Method

Return the shift vector

public abstract D3Vector GetShift();

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.Inverse Method

Invert the transform

public abstract D3Transform Inverse();

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.Invert Method

invert transformation - returns "true" if successful; returns false and remains unaltered in the case of a singular transformation

public abstract bool Invert();

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.IsIdentity Method

Return true if this is an identity transform

public abstract bool IsIdentity();

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.IsOrthogonal Method

Return true if the rotation matrix is orthogonal

public abstract bool IsOrthogonal(
double tol
);

Parameters

tol

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.IsSingular Method

Returns true if determinant is zero

public abstract bool IsSingular();

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


Map Method

AVEVA Maths / Geometry .NET Public Interface

D3Transform.Map Method

Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - point posFrom is mapped onto posTo, and - vector vecFrom is mapped onto vecTo.

Overload List

Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - point posFrom is mapped onto posTo, and - vector vecFrom is mapped onto vecTo.

public abstract bool Map(D3Point,D3Point,D3Vector,D3Vector);

Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - point posFrom is mapped onto posTo, - vector vec1From is mapped onto vec1To, and - vector vec2From is mapped as closely as is possible onto vec2To.

public abstract bool Map(D3Point,D3Point,D3Vector,D3Vector,D3Vector,D3Vector);

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.Map Method (D3Point, D3Point, D3Vector, D3Vector)

Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - point posFrom is mapped onto posTo, and - vector vecFrom is mapped onto vecTo.

public abstract bool Map(
D3Point posFrom,
D3Point posTo,
D3Vector vecFrom,
D3Vector vecTo
);

Parameters

posFrom
posTo
vecFrom
vecTo

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D3Transform.Map Overload List


D3Transform.Map Method (D3Point, D3Point, D3Vector, D3Vector, D3Vector, D3Vector)

Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - point posFrom is mapped onto posTo, - vector vec1From is mapped onto vec1To, and - vector vec2From is mapped as closely as is possible onto vec2To.

public abstract bool Map(
D3Point posFrom,
D3Point posTo,
D3Vector vec1From,
D3Vector vec1To,
D3Vector vec2From,
D3Vector vec2To
);

Parameters

posFrom
posTo
vec1From
vec1To
vec2From
vec2To

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D3Transform.Map Overload List


D3Transform.MapOriXTo Method

Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - the origin is mapped onto pos, and - the x-axis is mapped onto vec.

public abstract bool MapOriXTo(
D3Point pos,
D3Vector vec
);

Parameters

pos
vec

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.MapOriXYTo Method

Sets the transformation to represent a simple rotation and shift (i.e. no scaling, shearing or reflection) such that: - the origin is mapped onto pos, - the x-axis is mapped onto vec1, and - the y-axis is mapped as closely as is possible onto vec2

public abstract bool MapOriXYTo(
D3Point pos,
D3Vector vec1,
D3Vector vec2
);

Parameters

pos
vec1
vec2

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


MoveBy Method

AVEVA Maths / Geometry .NET Public Interface

D3Transform.MoveBy Method

Apply relative shift by given vector

Overload List

Apply relative shift by given vector

public abstract void MoveBy(D3Vector);

Apply relative shift by given x,y,z values

public abstract void MoveBy(double,double,double);

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.MoveBy Method (D3Vector)

Apply relative shift by given vector

public abstract void MoveBy(
D3Vector v
);

Parameters

v

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D3Transform.MoveBy Overload List


D3Transform.MoveBy Method (Double, Double, Double)

Apply relative shift by given x,y,z values

public abstract void MoveBy(
double x,
double y,
double z
);

Parameters

x
y
z

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D3Transform.MoveBy Overload List


Multiply Method

AVEVA Maths / Geometry .NET Public Interface

D3Transform.Multiply Method

Transform given limits box

Overload List

Transform given limits box

public abstract D3Limits Multiply(D3Limits);

Transform given point

public abstract D3Point Multiply(D3Point);

Multiply two transformations

public abstract D3Transform Multiply(D3Transform);

Transform given vector

public abstract D3Vector Multiply(D3Vector);

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.Multiply Method (D3Limits)

Transform given limits box

public abstract D3Limits Multiply(
D3Limits lim1
);

Parameters

lim1

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D3Transform.Multiply Overload List


D3Transform.Multiply Method (D3Point)

Transform given point

public abstract D3Point Multiply(
D3Point p2
);

Parameters

p2

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D3Transform.Multiply Overload List


D3Transform.Multiply Method (D3Transform)

Multiply two transformations

public abstract D3Transform Multiply(
D3Transform m2
);

Parameters

m2

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D3Transform.Multiply Overload List


D3Transform.Multiply Method (D3Vector)

Transform given vector

public abstract D3Vector Multiply(
D3Vector v2
);

Parameters

v2

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace | D3Transform.Multiply Overload List


D3Transform.RotateBy Method

Rotate about X,Y,Z

public abstract void RotateBy(
double degX,
double degY,
double degZ
);

Parameters

degX
degY
degZ

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.RotateX Method

apply rotation in X by pre-multiplication

public abstract void RotateX(
double degrees
);

Parameters

degrees

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.RotateY Method

apply rotation in Y by pre-multiplication

public abstract void RotateY(
double degrees
);

Parameters

degrees

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.RotateZ Method

apply rotation in Z by pre-multiplication

public abstract void RotateZ(
double degrees
);

Parameters

degrees

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.SetRotation Method

Set rotation matrix

public abstract void SetRotation(
D3Matrix m
);

Parameters

m

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.SetShift Method

Set shift vector

public abstract void SetShift(
D3Vector v
);

Parameters

v

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.SetValue Method

Set matrix and shift from array of 12 values

public abstract void SetValue(
double[] v
);

Parameters

v

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.TakeToZAxis Method

Make the transformation take the given vector to the z axis

public abstract void TakeToZAxis(
D3Vector v
);

Parameters

v

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.ToString Method

Return a string containing details of the transform

public abstract string ToString();

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform.Transform Method

Apply transformation to a plane. Works for any non-singular transformation, including a non-orthogonal transformation (i.e. with scaling/shearing/reflection).

public abstract bool Transform(
D3Plane plane
);

Parameters

plane

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform Operators

The operators of the D3Transform class are listed below. For a complete list of D3Transform class members, see the D3Transform Members topic.

Public Static Operators

Equality Operator | invoked by left==right
Inequality Operator | invoked by left != right
Multiplication Operator | invoked by t1*t2

See Also

D3Transform Class | D3Transform Members | Aveva.Pdms.Maths.Geometry Namespace


D3Transform Equality Operator

invoked by left==right

public static bool operator ==(
D3Transform left,
D3Transform right
);

Parameters

left
right

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform Inequality Operator

invoked by left != right

public static bool operator !=(
D3Transform left,
D3Transform right
);

Parameters

left
right

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Transform Multiplication Operator

invoked by t1*t2

public static D3Transform operator *(
D3Transform t1,
D3Transform t2
);

Parameters

t1
t2

Return Value

See Also

D3Transform Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector Class

3D Vector class

For a list of all members of this type, see D3Vector Members.

System.Object
Aveva.Pdms.Maths.Geometry.D3Vector

public abstract class D3Vector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Maths.Geometry

Assembly: Aveva.Pdms.Maths.Geometry (in Aveva.Pdms.Maths.Geometry.dll)

See Also

D3Vector Members | Aveva.Pdms.Maths.Geometry Namespace


D3Vector Members

D3Vector overview

Public Static Fields

D3DOWN | static constant - down
D3EAST | static constant - east
D3NORTH | static constant - north
D3SOUTH | static constant - south
D3UP | static constant - up
D3WEST | static constant - west

Public Static Methods

Create Overloaded. Default constructor - Creates a D3Vector with default values (0.0,0.0,0.0)

Public Static Operators

Addition Operator | invoked by v1 + v2
Division Operator | Invoked by v1 / v2
Equality Operator | invoked by left == right (exact equality)
Inequality Operator | invoked by left != right
Multiplication Operator | Invoked by v1*v2
Subtraction Operator | Invoked by v1 - v2
Unary Negation Operator | Invoked by -v

Public Instance Properties

X | property to set/get X coordinate of vector
Y | property to set/get Y coordinate
Z | property to set/get Z coordinate of vector

Public Instance Methods

Add | Add two vectors
Angle | Return the angle of the vector (in degrees)
Antiparallel | Overloaded. Returns true if vectors are parallel (within default tolerance) and in the opposite direction
ApproxProject | Return an approximate projection onto z =0 plane
AsPoint | Explicit conversion of vector to D3Point
Clone | Returns a deep copy of the vector
Cross | Return the cross product
Divide | Divide vector by a scalar value
Dot | Return the dot product
Equals | Overloaded. Returns true if vectors are equal within default tolerance of size and angle
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
GetUnit | Returns unit magnitude equivalent vector; returns (0,0,0) if original is (0,0,0)
IsZero | Returns true if x=y=z=0
Magnitude | Return the length of the vector
Multiply | Multiply vector by a scalar value
NearestAxis | Get unit vector of axis which is closest
Negate | Negate the vector
Parallel | Overloaded. Returns true if vectors are parallel (within default tolerance) and in the same direction
Parse | Returns a D3Vector constructed from a string of form "xxx,yyy,zzz" (opposite of ToString)
Perpendicular | Overloaded. Returns true if vectors are perpendicular (within default tolerance)
ProjectOntoLine | Returns vector which is a projection of this vector onto given line
ProjectOntoPlane | Returns vector which is projection of this vector onto given plane
ScaleBy | Scale x,y,z uniformly by scalar value
SetXYZ | set x,y,z coordinates
Subtract | Subtract two vectors
ToString | Returns a string describing the values of the D3Vector

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector Fields

The fields of the D3Vector class are listed below. For a complete list of D3Vector class members, see the D3Vector Members topic.

Public Static Fields

D3DOWN | static constant - down
D3EAST | static constant - east
D3NORTH | static constant - north
D3SOUTH | static constant - south
D3UP | static constant - up
D3WEST | static constant - west

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.D3DOWN Field

static constant - down

public static D3Vector D3DOWN;

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.D3EAST Field

static constant - east

public static D3Vector D3EAST;

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.D3NORTH Field

static constant - north

public static D3Vector D3NORTH;

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.D3SOUTH Field

static constant - south

public static D3Vector D3SOUTH;

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.D3UP Field

static constant - up

public static D3Vector D3UP;

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.D3WEST Field

static constant - west

public static D3Vector D3WEST;

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector Properties

The properties of the D3Vector class are listed below. For a complete list of D3Vector class members, see the D3Vector Members topic.

Public Instance Properties

X | property to set/get X coordinate of vector
Y | property to set/get Y coordinate
Z | property to set/get Z coordinate of vector

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


X Property

AVEVA Maths / Geometry .NET Public Interface

D3Vector.X Property

property to set/get X coordinate of vector

public abstract double X {get; set;}

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


Y Property

AVEVA Maths / Geometry .NET Public Interface

D3Vector.Y Property

property to set/get Y coordinate

public abstract double Y {get; set;}

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


Z Property

AVEVA Maths / Geometry .NET Public Interface

D3Vector.Z Property

property to set/get Z coordinate of vector

public abstract double Z {get; set;}

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector Methods

The methods of the D3Vector class are listed below. For a complete list of D3Vector class members, see the D3Vector Members topic.

Public Static Methods

Create Overloaded. Default constructor - Creates a D3Vector with default values (0.0,0.0,0.0)

Public Instance Methods

Add | Add two vectors
Angle | Return the angle of the vector (in degrees)
Antiparallel | Overloaded. Returns true if vectors are parallel (within default tolerance) and in the opposite direction
ApproxProject | Return an approximate projection onto z =0 plane
AsPoint | Explicit conversion of vector to D3Point
Clone | Returns a deep copy of the vector
Cross | Return the cross product
Divide | Divide vector by a scalar value
Dot | Return the dot product
Equals | Overloaded. Returns true if vectors are equal within default tolerance of size and angle
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
GetUnit | Returns unit magnitude equivalent vector; returns (0,0,0) if original is (0,0,0)
IsZero | Returns true if x=y=z=0
Magnitude | Return the length of the vector
Multiply | Multiply vector by a scalar value
NearestAxis | Get unit vector of axis which is closest
Negate | Negate the vector
Parallel | Overloaded. Returns true if vectors are parallel (within default tolerance) and in the same direction
Parse | Returns a D3Vector constructed from a string of form "xxx,yyy,zzz" (opposite of ToString)
Perpendicular | Overloaded. Returns true if vectors are perpendicular (within default tolerance)
ProjectOntoLine | Returns vector which is a projection of this vector onto given line
ProjectOntoPlane | Returns vector which is projection of this vector onto given plane
ScaleBy | Scale x,y,z uniformly by scalar value
SetXYZ | set x,y,z coordinates
Subtract | Subtract two vectors
ToString | Returns a string describing the values of the D3Vector

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.Add Method

Add two vectors

public abstract D3Vector Add(
D3Vector v2
);

Parameters

v2

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.Angle Method

Return the angle of the vector (in degrees)

public abstract double Angle(
D3Vector v
);

Parameters

v

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


Antiparallel Method

AVEVA Maths / Geometry .NET Public Interface

D3Vector.Antiparallel Method

Returns true if vectors are parallel (within default tolerance) and in the opposite direction

Overload List

Returns true if vectors are parallel (within default tolerance) and in the opposite direction

public abstract bool Antiparallel(D3Vector);

Returns true if vectors are parallel (within given tolerance) and in the opposite direction

public abstract bool Antiparallel(D3Vector,double);

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.Antiparallel Method (D3Vector)

Returns true if vectors are parallel (within default tolerance) and in the opposite direction

public abstract bool Antiparallel(
D3Vector v
);

Parameters

v

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D3Vector.Antiparallel Overload List


D3Vector.Antiparallel Method (D3Vector, Double)

Returns true if vectors are parallel (within given tolerance) and in the opposite direction

public abstract bool Antiparallel(
D3Vector v,
double tol
);

Parameters

v
tol

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D3Vector.Antiparallel Overload List


D3Vector.ApproxProject Method

Return an approximate projection onto z =0 plane

public abstract void ApproxProject(
ref int ix,
ref int iy
);

Parameters

ix
iy

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.AsPoint Method

Explicit conversion of vector to D3Point

public abstract D3Point AsPoint();

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.Clone Method

Returns a deep copy of the vector

public abstract D3Vector Clone();

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


Create Method

AVEVA Maths / Geometry .NET Public Interface

D3Vector.Create Method

Default constructor - Creates a D3Vector with default values (0.0,0.0,0.0)

Overload List

Default constructor - Creates a D3Vector with default values (0.0,0.0,0.0)

public static D3Vector Create();

Creates a 3d vector from point pa to point pb

public static D3Vector Create(D3Point,D3Point);

Copies a D3Vector

public static D3Vector Create(D3Vector);

Creates a 3d vector with coordinates x,y,z

public static D3Vector Create(double,double,double);

Creates a 3d vector with coordinates from array v

public static D3Vector Create(double[]);

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.Create Method ()

Default constructor - Creates a D3Vector with default values (0.0,0.0,0.0)

public static D3Vector Create();

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D3Vector.Create Overload List


D3Vector.Create Method (D3Point, D3Point)

Creates a 3d vector from point pa to point pb

public static D3Vector Create(
D3Point pa,
D3Point pb
);

Parameters

pa
pb

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D3Vector.Create Overload List


D3Vector.Create Method (D3Vector)

Copies a D3Vector

public static D3Vector Create(
D3Vector v
);

Parameters

v

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D3Vector.Create Overload List


D3Vector.Create Method (Double, Double, Double)

Creates a 3d vector with coordinates x,y,z

public static D3Vector Create(
double x,
double y,
double z
);

Parameters

x
y
z

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D3Vector.Create Overload List


D3Vector.Create Method (Double[])

Creates a 3d vector with coordinates from array v

public static D3Vector Create(
double[] v
);

Parameters

v

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D3Vector.Create Overload List


D3Vector.Cross Method

Return the cross product

public abstract D3Vector Cross(
D3Vector v
);

Parameters

v

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.Divide Method

Divide vector by a scalar value

public abstract D3Vector Divide(
double d
);

Parameters

d

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.Dot Method

Return the dot product

public abstract double Dot(
D3Vector v
);

Parameters

v

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


Equals Method

AVEVA Maths / Geometry .NET Public Interface

D3Vector.Equals Method

Returns true if vectors are equal within default tolerance of size and angle

Overload List

Returns true if vectors are equal within default tolerance of size and angle

public abstract bool Equals(D3Vector);

Returns true if vectors are equal within given tolerance of size and default angle tolerance

public abstract bool Equals(D3Vector,double);

Returns true if vectors are equal within given tolerance of size and angle

public abstract bool Equals(D3Vector,double,double);

public override bool Equals(object);

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.Equals Method (D3Vector)

Returns true if vectors are equal within default tolerance of size and angle

public abstract bool Equals(
D3Vector v
);

Parameters

v

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D3Vector.Equals Overload List


D3Vector.Equals Method (D3Vector, Double)

Returns true if vectors are equal within given tolerance of size and default angle tolerance

public abstract bool Equals(
D3Vector v,
double deltaMag
);

Parameters

v
deltaMag

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D3Vector.Equals Overload List


D3Vector.Equals Method (D3Vector, Double, Double)

Returns true if vectors are equal within given tolerance of size and angle

public abstract bool Equals(
D3Vector v,
double deltaMag,
double deltaAng
);

Parameters

v
deltaMag
deltaAng

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D3Vector.Equals Overload List


D3Vector.Equals Method (Object)

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D3Vector.Equals Overload List


D3Vector.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.GetUnit Method

Returns unit magnitude equivalent vector; returns (0,0,0) if original is (0,0,0)

public abstract D3Vector GetUnit();

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.IsZero Method

Returns true if x=y=z=0

public abstract bool IsZero();

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.Magnitude Method

Return the length of the vector

public abstract double Magnitude();

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.Multiply Method

Multiply vector by a scalar value

public abstract D3Vector Multiply(
double d
);

Parameters

d

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.NearestAxis Method

Get unit vector of axis which is closest

public abstract D3Vector NearestAxis();

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.Negate Method

Negate the vector

public abstract D3Vector Negate();

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


Parallel Method

AVEVA Maths / Geometry .NET Public Interface

D3Vector.Parallel Method

Returns true if vectors are parallel (within default tolerance) and in the same direction

Overload List

Returns true if vectors are parallel (within default tolerance) and in the same direction

public abstract bool Parallel(D3Vector);

Returns true if vectors are parallel (within given tolerance) and in the same direction

public abstract bool Parallel(D3Vector,double);

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.Parallel Method (D3Vector)

Returns true if vectors are parallel (within default tolerance) and in the same direction

public abstract bool Parallel(
D3Vector v
);

Parameters

v

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D3Vector.Parallel Overload List


D3Vector.Parallel Method (D3Vector, Double)

Returns true if vectors are parallel (within given tolerance) and in the same direction

public abstract bool Parallel(
D3Vector v,
double tol
);

Parameters

v
tol

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D3Vector.Parallel Overload List


D3Vector.Parse Method

Returns a D3Vector constructed from a string of form "xxx,yyy,zzz" (opposite of ToString)

public abstract D3Vector Parse(
string str
);

Parameters

str

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


Perpendicular Method

AVEVA Maths / Geometry .NET Public Interface

D3Vector.Perpendicular Method

Returns true if vectors are perpendicular (within default tolerance)

Overload List

Returns true if vectors are perpendicular (within default tolerance)

public abstract bool Perpendicular(D3Vector);

Returns true if vectors are perpendicular (within given tolerance)

public abstract bool Perpendicular(D3Vector,double);

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.Perpendicular Method (D3Vector)

Returns true if vectors are perpendicular (within default tolerance)

public abstract bool Perpendicular(
D3Vector v
);

Parameters

v

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D3Vector.Perpendicular Overload List


D3Vector.Perpendicular Method (D3Vector, Double)

Returns true if vectors are perpendicular (within given tolerance)

public abstract bool Perpendicular(
D3Vector v,
double delta
);

Parameters

v
delta

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace | D3Vector.Perpendicular Overload List


D3Vector.ProjectOntoLine Method

Returns vector which is a projection of this vector onto given line

public abstract D3Vector ProjectOntoLine(
D3Vector line
);

Parameters

line

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.ProjectOntoPlane Method

Returns vector which is projection of this vector onto given plane

public abstract D3Vector ProjectOntoPlane(
D3Vector normal
);

Parameters

normal

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.ScaleBy Method

Scale x,y,z uniformly by scalar value

public abstract void ScaleBy(
double s
);

Parameters

s

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.SetXYZ Method

set x,y,z coordinates

public abstract void SetXYZ(
double x,
double y,
double z
);

Parameters

x
y
z

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.Subtract Method

Subtract two vectors

public abstract D3Vector Subtract(
D3Vector v2
);

Parameters

v2

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector.ToString Method

Returns a string describing the values of the D3Vector

public abstract string ToString();

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector Operators

The operators of the D3Vector class are listed below. For a complete list of D3Vector class members, see the D3Vector Members topic.

Public Static Operators

Addition Operator | invoked by v1 + v2
Division Operator | Invoked by v1 / v2
Equality Operator | invoked by left == right (exact equality)
Inequality Operator | invoked by left != right
Multiplication Operator | Invoked by v1*v2
Subtraction Operator | Invoked by v1 - v2
Unary Negation Operator | Invoked by -v

See Also

D3Vector Class | D3Vector Members | Aveva.Pdms.Maths.Geometry Namespace


D3Vector Addition Operator

invoked by v1 + v2

public static D3Vector operator +(
D3Vector v1,
D3Vector v2
);

Parameters

v1
v2

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector Division Operator

Invoked by v1 / v2

public static D3Vector operator /(
D3Vector v1,
double d
);

Parameters

v1
d

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector Equality Operator

invoked by left == right (exact equality)

public static bool operator ==(
D3Vector left,
D3Vector right
);

Parameters

left
right

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector Inequality Operator

invoked by left != right

public static bool operator !=(
D3Vector left,
D3Vector right
);

Parameters

left
right

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector Multiplication Operator

Invoked by v1*v2

public static D3Vector operator *(
D3Vector v1,
double d
);

Parameters

v1
d

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector Subtraction Operator

Invoked by v1 - v2

public static D3Vector operator -(
D3Vector v1,
D3Vector v2
);

Parameters

v1
v2

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


D3Vector Unary Negation Operator

Invoked by -v

public static D3Vector operator -(
D3Vector v
);

Parameters

v

Return Value

See Also

D3Vector Class | Aveva.Pdms.Maths.Geometry Namespace


Aveva.Pdms.Maths.GeometryHierarchy

AVEVA Maths / Geometry .NET Public Interface

Aveva.Pdms.Maths.Geometry Hierarchy

System.Object
Aveva.Pdms.Maths.Geometry.D2Angle
Aveva.Pdms.Maths.Geometry.D2Arc
Aveva.Pdms.Maths.Geometry.D2Circle
Aveva.Pdms.Maths.Geometry.D2DivideLine
Aveva.Pdms.Maths.Geometry.D2FiniteLine
Aveva.Pdms.Maths.Geometry.D2IrregularCartesianGrid
Aveva.Pdms.Maths.Geometry.D2IrregularPolarGrid
Aveva.Pdms.Maths.Geometry.D2Limits
Aveva.Pdms.Maths.Geometry.D2Line
Aveva.Pdms.Maths.Geometry.D2Matrix
Aveva.Pdms.Maths.Geometry.D2Point
Aveva.Pdms.Maths.Geometry.D2PointFactory
Aveva.Pdms.Maths.Geometry.D2PolyLine
Aveva.Pdms.Maths.Geometry.D2Profile
Aveva.Pdms.Maths.Geometry.D2RegularCartesianGrid
Aveva.Pdms.Maths.Geometry.D2Span
Aveva.Pdms.Maths.Geometry.D2Transform
Aveva.Pdms.Maths.Geometry.D2Vector
Aveva.Pdms.Maths.Geometry.D3Arc
Aveva.Pdms.Maths.Geometry.D3FiniteLine
Aveva.Pdms.Maths.Geometry.D3Limits
Aveva.Pdms.Maths.Geometry.D3Line
Aveva.Pdms.Maths.Geometry.D3Matrix
Aveva.Pdms.Maths.Geometry.D3OrientedPlane
Aveva.Pdms.Maths.Geometry.D3Plane
Aveva.Pdms.Maths.Geometry.D3Point
Aveva.Pdms.Maths.Geometry.D3Transform
Aveva.Pdms.Maths.Geometry.D3Vector
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aveva.Pdms.Maths.Geometry.D2Angle.angleUnits
Aveva.Pdms.Maths.Geometry.D2Line.LTYPE
Aveva.Pdms.Maths.Geometry.D3Line.LTYPE

See Also

Aveva.Pdms.Maths.Geometry Namespace