Aveva.Pdms.Design

AVEVA Design .NET Public Interface

Aveva.Pdms.Design Namespace

Namespace hierarchy

Classes

Class | Description
Aid | PML Aid interface
©AVEVA Solutions Ltd 2007


Aid Class

PML Aid interface

For a list of all members of this type, see Aid Members.

System.Object
Aveva.Pdms.Design.Aid

public abstract class Aid

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Design

Assembly: Aveva.Pdms.Design (in Aveva.Pdms.Design.dll)

See Also

Aid Members | Aveva.Pdms.Design Namespace


Aid Members

Aid overview

Public Static Methods

ClearPipeProductionTags
UnenhanceAll

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Aid Class | Aveva.Pdms.Design Namespace


Aid Methods

The methods of the Aid class are listed below. For a complete list of Aid class members, see the Aid Members topic.

Public Static Methods

ClearPipeProductionTags
UnenhanceAll

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also


Aid.ClearPipeProductionTags Method

public static void ClearPipeProductionTags(
int inumb
);

Parameters

inumb

See Also


Aid.UnenhanceAll Method

public static void UnenhanceAll();

See Also


Aveva.Pdms.DesignHierarchy

AVEVA Design .NET Public Interface

Aveva.Pdms.Design Hierarchy

System.Object
Aveva.Pdms.Design.Aid

See Also

Aveva.Pdms.Design Namespace

©AVEVA Solutions Ltd 2007