Aveva.PDMS.Database.Filters

AVEVA Database Filters .NET Public Interface

Aveva.PDMS.Database.Filters Namespace

Namespace hierarchy

Classes

Class | Description
AndFilter | AND two or more filters.
AssemblyPlanningFilter | Summary description for AssemblyPlanningFliter.
AttributeCompoundFilter | This class does any of AND, OR, NOT AND, NOT ALL. CLASS IS UNDER REVIEW- DO NOT USE
AttributeFalseFilter | Tests if a boolean attribute value is valid and false
AttributeLikeFilter | Returns true if attribute value matches given string, allowing for wild characters. Wild characters are '*' for mutiple wild characters and '?' for a single wild charcter. //These are consistent with PML. CLASS IS UNDER REVIEW- DO NOT USE
AttributeListFilter | Filter to compare an attribute against a list of potential values.
AttributeRangeFilter | Filter to test if attribute is in a given range. CLASS IS UNDER REVIEW- DO NOT USE
AttributeRefFilter | Filter to test if a ref attribute value matches a given value
AttributeTrueFilter | Returns true if boolean attribute is valid and true
AttributeValueFilter | General filter to test whether the value of any type of attribute matches a given value CLASS IS UNDER REVIEW- DO NOT USE
BaseAttributeFilter | Abstract Base Class for attribute filters CLASS IS UNDER REVIEW- DO NOT USE
BaseFilter | This is the base class for element filters. Derived classes must implement new versions of Valid(), ScanBelow() and Clone(). The main use of filters is when scanning the database hierarchy looking for elements of a particular criteria. e.g. all Branches.
BelowFilter | Filter to test if element is below an element for which the given filter is true.
BelowOrAtFilter | Filter to test if element is below or at an element for which the given filter is true.
BelowOrAtType | Filter to test if element is at or below given element types.
BelowType | As for the Below filter, but more efficient in the case where we want to test on type only
CompoundFilter | Filter designed specifically for use in the explorer. It is composed of the following - list of filters for elements to show - list of filters for elements to skip - list of filters for elements to hide if there are no 'show' or 'showDescendants then ALL elements considered to be shown.
DBElementCollection | Class to iterate through the database hierarchy returning the elements that match the supplied filter. The scan starts at a given element. If no filter is given, then all elements below the start element are returned. The actual iteration is done via an enumerator.
DBElementEnumerator | Enumerator to iterate through a scan defined by the DBElementCollection class.
DBTypeFilter | Returns true if DB is of a given type
DraftAdminFilter | Specific Filter to be used by the explorer for Draft Admin users.
DraftFilter | Specific Filter to be used by the explorer for Draft DBs.
ElementTreeNavigator | Class to navigate a Dabacon tree taking into account the given filters. It allows the scan to continue at any point in the tree. The class is for use by the Explorer. The tree view presented is compressed to remove any 'skipped' elements.
EquipmentFilter | Specific Filter to be used by the explorer when designing equipment.
FalseFilter | Filter that always returns false.
FieldIntFilter | Returns true if DbElementType integer field is valid and equal to val
FieldTrueFilter | Filter to return true if Element type field is valid and true
HangerFilter | Specific Filter to be used by the explorer when designing hangers.
HideBelowFilter | Filter to hide all elements below an element of a given type. e.g. hide all elements below a group. It returns true if not an element to hide. Used by the explorer.
HideFilter | Filter to hide elements of given type. i.e. returns true if not an element to hide. Used by the explorer. If an element is hidden, its descendents will also be hidden.
InvisibleFilter | Filter for determining visibility in explorer.
OrFilter | Class to 'OR' together two or more existing filters.
PipingFilter | Specific Filter to be used by the explorer for elements relevant to a piping Engineer.
SchematicElectricalFilter | Specific Filter to be used by the explorer for doing electricals.
SchematicHVACFilter | Specific Filter to be used by the explorer for doing schematic hvac.
SchematicPipingFilter | Specific Filter to be used by the explorer for doing schematic pipes.
ShowDescendants | Filter to show elements of given type plus ascendants and descendants. Class is used by the Explorer.
ShowFilter | Filter to show elements of given type plus ancestors. When testing ancestors, the filter checks that valid descendants. actually exist rather than possibly exist. Class is used by the explorer.
SkipFilter | Filter to skip elements of given type. i.e. returns true if not an element to skip. Class is used by the explorer to flatten the tree view. If an element is skipped, its descendents will NOT be skipped.
StructuralFilter | Specific Filter to be used by the explorer for elements relevant to a structural Engineer.
SystemFilter | Specific Filter to be used by the explorer on the system DB.
TrueFilter | Filter that always returns true.
TypeFilter | Tests whether an element is of a given type. The class makes ensures that only valid parts of the database are returned in the ScanBelow() method. This is important for performance.

Enumerations

Enumeration | Description
BooleanOperator |
TestOperator |
©AVEVA Solutions Ltd 2007


AndFilter Class

AND two or more filters.

For a list of all members of this type, see AndFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.AndFilter

public class AndFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

AndFilter Members | Aveva.PDMS.Database.Filters Namespace


AndFilter Members

AndFilter overview

Public Instance Constructors

AndFilter Overloaded. Initializes a new instance of the AndFilter class.

Public Instance Properties

filters | list of current filters
First | First filter in AND list
Second | Second filter in AND list

Public Instance Methods

Add | Add another filter to AND list
Clone | Copy filter
Equals | Equality test
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Get hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove | Remove filter from AND list
ScanBelow | Return true if we need to scan below this element. This can be returned false to optimise the scan.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | Evaluate filter for given element

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace


AndFilter Constructor

Default constructor

Overload List

Default constructor

public AndFilter();

Construct from two existing filters

public AndFilter(BaseFilter,BaseFilter);

Construct from a list of filters

public AndFilter(BaseFilter[]);

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace


AndFilter Constructor ()

Default constructor

public AndFilter();

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace | AndFilter Constructor Overload List


AndFilter Constructor (BaseFilter, BaseFilter)

Construct from two existing filters

public AndFilter(
BaseFilter filter1,
BaseFilter filter2
);

Parameters

filter1
filter2

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace | AndFilter Constructor Overload List


AndFilter Constructor (BaseFilter[])

Construct from a list of filters

public AndFilter(
BaseFilter[] filts
);

Parameters

filts

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace | AndFilter Constructor Overload List


AndFilter Properties

The properties of the AndFilter class are listed below. For a complete list of AndFilter class members, see the AndFilter Members topic.

Public Instance Properties

filters | list of current filters
First | First filter in AND list
Second | Second filter in AND list

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace


filters Property

AVEVA Database Filters .NET Public Interface

AndFilter.filters Property

list of current filters

public BaseFilter[] filters {get;}

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace


First Property

AVEVA Database Filters .NET Public Interface

AndFilter.First Property

First filter in AND list

public BaseFilter First {get;}

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace


Second Property

AVEVA Database Filters .NET Public Interface

AndFilter.Second Property

Second filter in AND list

public BaseFilter Second {get;}

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace


AndFilter Methods

The methods of the AndFilter class are listed below. For a complete list of AndFilter class members, see the AndFilter Members topic.

Public Instance Methods

Add | Add another filter to AND list
Clone | Copy filter
Equals | Equality test
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Get hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove | Remove filter from AND list
ScanBelow | Return true if we need to scan below this element. This can be returned false to optimise the scan.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | Evaluate filter for given element

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace


AndFilter.Add Method

Add another filter to AND list

public void Add(
BaseFilter filt
);

Parameters

filt

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace


AndFilter.Clone Method

Copy filter

public override object Clone();

Return Value

Implements

ICloneable.Clone

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace


AndFilter.Equals Method

Equality test

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace


AndFilter.GetHashCode Method

Get hash value

public override int GetHashCode();

Return Value

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace


AndFilter.Remove Method

Remove filter from AND list

public void Remove(
BaseFilter filt
);

Parameters

filt

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace


AndFilter.ScanBelow Method

Return true if we need to scan below this element. This can be returned false to optimise the scan.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
Current Element

Return Value

Result of whether to scan below or not

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace


AndFilter.Valid Method

Evaluate filter for given element

public override bool Valid(
DbElement ele
);

Parameters

ele
Element to test filter on

Return Value

Result of evaluating filter against element

See Also

AndFilter Class | Aveva.PDMS.Database.Filters Namespace


AssemblyPlanningFilter Class

Summary description for AssemblyPlanningFliter.

For a list of all members of this type, see AssemblyPlanningFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.AssemblyPlanningFilter

public class AssemblyPlanningFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

AssemblyPlanningFilter Members | Aveva.PDMS.Database.Filters Namespace


AssemblyPlanningFilter Members

AssemblyPlanningFilter overview

Public Instance Constructors

AssemblyPlanningFilter Constructor Initializes a new instance of the AssemblyPlanningFilter class.

Public Instance Methods

Clone |
Equals |
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow |
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid |

See Also

AssemblyPlanningFilter Class | Aveva.PDMS.Database.Filters Namespace


AssemblyPlanningFilter Constructor

Initializes a new instance of the AssemblyPlanningFilter class.

public AssemblyPlanningFilter();

See Also

AssemblyPlanningFilter Class | Aveva.PDMS.Database.Filters Namespace


AssemblyPlanningFilter Methods

The methods of the AssemblyPlanningFilter class are listed below. For a complete list of AssemblyPlanningFilter class members, see the AssemblyPlanningFilter Members topic.

Public Instance Methods

Clone |
Equals |
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow |
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid |

See Also

AssemblyPlanningFilter Class | Aveva.PDMS.Database.Filters Namespace


AssemblyPlanningFilter.Clone Method

public override object Clone();

Implements

ICloneable.Clone

See Also

AssemblyPlanningFilter Class | Aveva.PDMS.Database.Filters Namespace


AssemblyPlanningFilter.Equals Method

public override bool Equals(
object o
);

See Also

AssemblyPlanningFilter Class | Aveva.PDMS.Database.Filters Namespace


AssemblyPlanningFilter.GetHashCode Method

public override int GetHashCode();

See Also

AssemblyPlanningFilter Class | Aveva.PDMS.Database.Filters Namespace


AssemblyPlanningFilter.ScanBelow Method

public override bool ScanBelow(
DbElement ele
);

See Also

AssemblyPlanningFilter Class | Aveva.PDMS.Database.Filters Namespace


AssemblyPlanningFilter.Valid Method

public override bool Valid(
DbElement ele
);

See Also

AssemblyPlanningFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeCompoundFilter Class

This class does any of AND, OR, NOT AND, NOT ALL. CLASS IS UNDER REVIEW- DO NOT USE

For a list of all members of this type, see AttributeCompoundFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.AttributeCompoundFilter

public class AttributeCompoundFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

AttributeCompoundFilter Members | Aveva.PDMS.Database.Filters Namespace


AttributeCompoundFilter Members

AttributeCompoundFilter overview

Public Instance Constructors

AttributeCompoundFilter Constructor Construct the instance passing an initial filter and an operation

Public Instance Methods

AddTest | Add further filter to list
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString |
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeCompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeCompoundFilter Constructor

Construct the instance passing an initial filter and an operation

public AttributeCompoundFilter(
BaseFilter test,
BooleanOperator op
);

Parameters

test
existing filter
op
operation to perform

See Also

AttributeCompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeCompoundFilter Methods

The methods of the AttributeCompoundFilter class are listed below. For a complete list of AttributeCompoundFilter class members, see the AttributeCompoundFilter Members topic.

Public Instance Methods

AddTest | Add further filter to list
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString |
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeCompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeCompoundFilter.AddTest Method

Add further filter to list

public void AddTest(
BaseFilter test
);

Parameters

test

See Also

AttributeCompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeCompoundFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

AttributeCompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeCompoundFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

AttributeCompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeCompoundFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

AttributeCompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeCompoundFilter.ScanBelow Method

Method to test whether we need to scan below given element. Always return true.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

AttributeCompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeCompoundFilter.ToString Method

public override string ToString();

See Also

AttributeCompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeCompoundFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

AttributeCompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeFalseFilter Class

Tests if a boolean attribute value is valid and false

For a list of all members of this type, see AttributeFalseFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.AttributeFalseFilter

public class AttributeFalseFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

AttributeFalseFilter Members | Aveva.PDMS.Database.Filters Namespace


AttributeFalseFilter Members

AttributeFalseFilter overview

Public Instance Constructors

AttributeFalseFilter Constructor Construct instance, passing attribute to test

Public Instance Properties

Attribute Attribute to test

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeFalseFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeFalseFilter Constructor

Construct instance, passing attribute to test

public AttributeFalseFilter(
DbAttribute att
);

Parameters

att

See Also

AttributeFalseFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeFalseFilter Properties

The properties of the AttributeFalseFilter class are listed below. For a complete list of AttributeFalseFilter class members, see the AttributeFalseFilter Members topic.

Public Instance Properties

Attribute Attribute to test

See Also

AttributeFalseFilter Class | Aveva.PDMS.Database.Filters Namespace


Attribute Property

AVEVA Database Filters .NET Public Interface

AttributeFalseFilter.Attribute Property

Attribute to test

public Aveva.Pdms.Database.DbAttribute Attribute {get; set;}

See Also

AttributeFalseFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeFalseFilter Methods

The methods of the AttributeFalseFilter class are listed below. For a complete list of AttributeFalseFilter class members, see the AttributeFalseFilter Members topic.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeFalseFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeFalseFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

AttributeFalseFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeFalseFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

AttributeFalseFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeFalseFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

AttributeFalseFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeFalseFilter.ScanBelow Method

Method to test whether we need to scan below given element. Always return true.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

AttributeFalseFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeFalseFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

AttributeFalseFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeLikeFilter Class

Returns true if attribute value matches given string, allowing for wild characters. Wild characters are '*' for mutiple wild characters and '?' for a single wild charcter. //These are consistent with PML. CLASS IS UNDER REVIEW- DO NOT USE

For a list of all members of this type, see AttributeLikeFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.BaseAttributeFilter
Aveva.PDMS.Database.Filters.AttributeLikeFilter

public class AttributeLikeFilter : BaseAttributeFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

AttributeLikeFilter Members | Aveva.PDMS.Database.Filters Namespace


AttributeLikeFilter Members

AttributeLikeFilter overview

Public Instance Constructors

AttributeLikeFilter Overloaded. Initializes a new instance of the AttributeLikeFilter class.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString |
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeLikeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeLikeFilter Constructor

Construct instance of class passing attribute to test and matching string

Overload List

Construct instance of class passing attribute to test and matching string

public AttributeLikeFilter(DbAttribute,string);

Parse string.

public AttributeLikeFilter(string);

See Also

AttributeLikeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeLikeFilter Constructor (DbAttribute, String)

Construct instance of class passing attribute to test and matching string

public AttributeLikeFilter(
DbAttribute att,
string likeString
);

Parameters

att
likeString

See Also

AttributeLikeFilter Class | Aveva.PDMS.Database.Filters Namespace | AttributeLikeFilter Constructor Overload List


AttributeLikeFilter Constructor (String)

Parse string.

public AttributeLikeFilter(
string attLikeFilter
);

Parameters

attLikeFilter

See Also

AttributeLikeFilter Class | Aveva.PDMS.Database.Filters Namespace | AttributeLikeFilter Constructor Overload List


AttributeLikeFilter Methods

The methods of the AttributeLikeFilter class are listed below. For a complete list of AttributeLikeFilter class members, see the AttributeLikeFilter Members topic.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString |
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeLikeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeLikeFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

AttributeLikeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeLikeFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

AttributeLikeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeLikeFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

AttributeLikeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeLikeFilter.ScanBelow Method

Method to test whether we need to scan below given element. Always return true.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

AttributeLikeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeLikeFilter.ToString Method

public override string ToString();

See Also

AttributeLikeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeLikeFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

AttributeLikeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeListFilter Class

Filter to compare an attribute against a list of potential values.

For a list of all members of this type, see AttributeListFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.BaseAttributeFilter
Aveva.PDMS.Database.Filters.AttributeListFilter

public class AttributeListFilter : BaseAttributeFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

AttributeListFilter Members | Aveva.PDMS.Database.Filters Namespace


AttributeListFilter Members

AttributeListFilter overview

Public Instance Constructors

AttributeListFilter Overloaded. Initializes a new instance of the AttributeListFilter class.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString | Construct string from filter
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeListFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeListFilter Constructor

Construct object from attribute and list of allowed values. CLASS IS UNDER REVIEW- DO NOT USE

Overload List

Construct object from attribute and list of allowed values. CLASS IS UNDER REVIEW- DO NOT USE

public AttributeListFilter(DbAttribute,object[]);

Parse string to produce filter

public AttributeListFilter(string);

See Also

AttributeListFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeListFilter Constructor (DbAttribute, Object[])

Construct object from attribute and list of allowed values. CLASS IS UNDER REVIEW- DO NOT USE

public AttributeListFilter(
DbAttribute att,
object[] listValues
);

Parameters

att
listValues

See Also

AttributeListFilter Class | Aveva.PDMS.Database.Filters Namespace | AttributeListFilter Constructor Overload List


AttributeListFilter Constructor (String)

Parse string to produce filter

public AttributeListFilter(
string attributeListFilter
);

Parameters

attributeListFilter

See Also

AttributeListFilter Class | Aveva.PDMS.Database.Filters Namespace | AttributeListFilter Constructor Overload List


AttributeListFilter Methods

The methods of the AttributeListFilter class are listed below. For a complete list of AttributeListFilter class members, see the AttributeListFilter Members topic.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString | Construct string from filter
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeListFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeListFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

AttributeListFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeListFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

AttributeListFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeListFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

AttributeListFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeListFilter.ScanBelow Method

Method to test whether we need to scan below given element. Always return true.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

AttributeListFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeListFilter.ToString Method

Construct string from filter

public override string ToString();

Return Value

See Also

AttributeListFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeListFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

AttributeListFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRangeFilter Class

Filter to test if attribute is in a given range. CLASS IS UNDER REVIEW- DO NOT USE

For a list of all members of this type, see AttributeRangeFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.BaseAttributeFilter
Aveva.PDMS.Database.Filters.AttributeRangeFilter

public class AttributeRangeFilter : BaseAttributeFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

AttributeRangeFilter Members | Aveva.PDMS.Database.Filters Namespace


AttributeRangeFilter Members

AttributeRangeFilter overview

Public Instance Constructors

AttributeRangeFilter Overloaded. Initializes a new instance of the AttributeRangeFilter class.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString |
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeRangeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRangeFilter Constructor

Construct instance of filter from attribute and low/high value

Overload List

Construct instance of filter from attribute and low/high value

public AttributeRangeFilter(DbAttribute,object,object);

Constructor, taking the range as a string

public AttributeRangeFilter(string);

See Also

AttributeRangeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRangeFilter Constructor (DbAttribute, Object, Object)

Construct instance of filter from attribute and low/high value

public AttributeRangeFilter(
DbAttribute att,
object lowValue,
object highValue
);

Parameters

att
lowValue
minimum
highValue
maximum

See Also

AttributeRangeFilter Class | Aveva.PDMS.Database.Filters Namespace | AttributeRangeFilter Constructor Overload List


AttributeRangeFilter Constructor (String)

Constructor, taking the range as a string

public AttributeRangeFilter(
string attRangeFilter
);

Parameters

attRangeFilter

See Also

AttributeRangeFilter Class | Aveva.PDMS.Database.Filters Namespace | AttributeRangeFilter Constructor Overload List


AttributeRangeFilter Methods

The methods of the AttributeRangeFilter class are listed below. For a complete list of AttributeRangeFilter class members, see the AttributeRangeFilter Members topic.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString |
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeRangeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRangeFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

AttributeRangeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRangeFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

AttributeRangeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRangeFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

AttributeRangeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRangeFilter.ScanBelow Method

Method to test whether we need to scan below given element. Always return true.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

AttributeRangeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRangeFilter.ToString Method

public override string ToString();

See Also

AttributeRangeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRangeFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

AttributeRangeFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRefFilter Class

Filter to test if a ref attribute value matches a given value

For a list of all members of this type, see AttributeRefFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.AttributeRefFilter

public class AttributeRefFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

AttributeRefFilter Members | Aveva.PDMS.Database.Filters Namespace


AttributeRefFilter Members

AttributeRefFilter overview

Public Instance Constructors

AttributeRefFilter Constructor Constructor taking the attribute ID and the value to match

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeRefFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRefFilter Constructor

Constructor taking the attribute ID and the value to match

public AttributeRefFilter(
DbAttribute att,
DbElement reference
);

Parameters

att
attribute
reference
value to match

See Also

AttributeRefFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRefFilter Methods

The methods of the AttributeRefFilter class are listed below. For a complete list of AttributeRefFilter class members, see the AttributeRefFilter Members topic.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeRefFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRefFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

AttributeRefFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRefFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

AttributeRefFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRefFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Parameters

Return Value

See Also

AttributeRefFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRefFilter.ScanBelow Method

Method to test whether we need to scan below given element. Always return true.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

AttributeRefFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeRefFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

AttributeRefFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeTrueFilter Class

Returns true if boolean attribute is valid and true

For a list of all members of this type, see AttributeTrueFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.AttributeTrueFilter

public class AttributeTrueFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

AttributeTrueFilter Members | Aveva.PDMS.Database.Filters Namespace


AttributeTrueFilter Members

AttributeTrueFilter overview

Public Instance Constructors

AttributeTrueFilter Constructor Constructor taking attribute ID

Public Instance Properties

Attribute Attribute to test

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeTrueFilter Constructor

Constructor taking attribute ID

public AttributeTrueFilter(
DbAttribute att
);

Parameters

att

See Also

AttributeTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeTrueFilter Properties

The properties of the AttributeTrueFilter class are listed below. For a complete list of AttributeTrueFilter class members, see the AttributeTrueFilter Members topic.

Public Instance Properties

Attribute Attribute to test

See Also

AttributeTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


Attribute Property

AVEVA Database Filters .NET Public Interface

AttributeTrueFilter.Attribute Property

Attribute to test

public Aveva.Pdms.Database.DbAttribute Attribute {get; set;}

See Also

AttributeTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeTrueFilter Methods

The methods of the AttributeTrueFilter class are listed below. For a complete list of AttributeTrueFilter class members, see the AttributeTrueFilter Members topic.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeTrueFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

AttributeTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeTrueFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

AttributeTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeTrueFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Parameters

Return Value

See Also

AttributeTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeTrueFilter.ScanBelow Method

Method to test whether we need to scan below given element. Always return true.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

AttributeTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeTrueFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

AttributeTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeValueFilter Class

General filter to test whether the value of any type of attribute matches a given value CLASS IS UNDER REVIEW- DO NOT USE

For a list of all members of this type, see AttributeValueFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.BaseAttributeFilter
Aveva.PDMS.Database.Filters.AttributeValueFilter

public class AttributeValueFilter : BaseAttributeFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

AttributeValueFilter Members | Aveva.PDMS.Database.Filters Namespace


AttributeValueFilter Members

AttributeValueFilter overview

Public Instance Constructors

AttributeValueFilter Overloaded. Initializes a new instance of the AttributeValueFilter class.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString |
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeValueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeValueFilter Constructor

Overload List

public AttributeValueFilter(DbAttribute,TestOperator,object);

public AttributeValueFilter(string);

See Also

AttributeValueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeValueFilter Constructor (DbAttribute, TestOperator, Object)

public AttributeValueFilter(
DbAttribute att,
TestOperator testOp,
object testVal
);

See Also

AttributeValueFilter Class | Aveva.PDMS.Database.Filters Namespace | AttributeValueFilter Constructor Overload List


AttributeValueFilter Constructor (String)

public AttributeValueFilter(
string attValueFilter
);

See Also

AttributeValueFilter Class | Aveva.PDMS.Database.Filters Namespace | AttributeValueFilter Constructor Overload List


AttributeValueFilter Methods

The methods of the AttributeValueFilter class are listed below. For a complete list of AttributeValueFilter class members, see the AttributeValueFilter Members topic.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always return true.
ToString |
Valid | method to return whether filter is true or false for a given element.

See Also

AttributeValueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeValueFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

AttributeValueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeValueFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

AttributeValueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeValueFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

AttributeValueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeValueFilter.ScanBelow Method

Method to test whether we need to scan below given element. Always return true.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

AttributeValueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeValueFilter.ToString Method

public override string ToString();

See Also

AttributeValueFilter Class | Aveva.PDMS.Database.Filters Namespace


AttributeValueFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

AttributeValueFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseAttributeFilter Class

Abstract Base Class for attribute filters CLASS IS UNDER REVIEW- DO NOT USE

For a list of all members of this type, see BaseAttributeFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.BaseAttributeFilter
Aveva.PDMS.Database.Filters.AttributeLikeFilter
Aveva.PDMS.Database.Filters.AttributeListFilter
Aveva.PDMS.Database.Filters.AttributeRangeFilter
Aveva.PDMS.Database.Filters.AttributeValueFilter

public abstract class BaseAttributeFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

BaseAttributeFilter Members | Aveva.PDMS.Database.Filters Namespace


BaseAttributeFilter Members

BaseAttributeFilter overview

Public Instance Constructors

BaseAttributeFilter Constructor Default constructor

Public Instance Methods

Clone (inherited from BaseFilter) | Abstract method to Copy filter
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow (inherited from BaseFilter) | abtract method to test whether we need to scan below given element. i.e. could there be elements below this one taht matches the filter. This can be used to optimise a scan. e.g. if we are looking for boxes, there is no point scanning below a branch.
ToString |
Valid (inherited from BaseFilter) | abstract method to return whether filter is true or false for a given element.

See Also

BaseAttributeFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseAttributeFilter Constructor

Default constructor

public BaseAttributeFilter();

See Also

BaseAttributeFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseAttributeFilter Methods

The methods of the BaseAttributeFilter class are listed below. For a complete list of BaseAttributeFilter class members, see the BaseAttributeFilter Members topic.

Public Instance Methods

Clone (inherited from BaseFilter) | Abstract method to Copy filter
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow (inherited from BaseFilter) | abtract method to test whether we need to scan below given element. i.e. could there be elements below this one taht matches the filter. This can be used to optimise a scan. e.g. if we are looking for boxes, there is no point scanning below a branch.
ToString |
Valid (inherited from BaseFilter) | abstract method to return whether filter is true or false for a given element.

See Also

BaseAttributeFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseAttributeFilter.ToString Method

public override string ToString();

See Also

BaseAttributeFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseFilter Class

This is the base class for element filters. Derived classes must implement new versions of Valid(), ScanBelow() and Clone(). The main use of filters is when scanning the database hierarchy looking for elements of a particular criteria. e.g. all Branches.

For a list of all members of this type, see BaseFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Derived types

public abstract class BaseFilter : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

BaseFilter Members | Aveva.PDMS.Database.Filters Namespace


BaseFilter Members

BaseFilter overview

Public Static Operators

Equality Operator | Compare filters.
Inequality Operator | Compare filters for inequality

Public Instance Constructors

BaseFilter Constructor Default constructor

Public Instance Methods

Clone | Abstract method to Copy filter
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FirstMember | Get first member for which filter is true.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Members | Return all members for which filter is true.
Next | Get next element in current list for which filter is true.
Parent | Climb up to element for which filter is true
ScanBelow | abtract method to test whether we need to scan below given element. i.e. could there be elements below this one taht matches the filter. This can be used to optimise a scan. e.g. if we are looking for boxes, there is no point scanning below a branch.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | abstract method to return whether filter is true or false for a given element.

See Also

BaseFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseFilter Constructor

Default constructor

public BaseFilter();

See Also

BaseFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseFilter Methods

The methods of the BaseFilter class are listed below. For a complete list of BaseFilter class members, see the BaseFilter Members topic.

Public Instance Methods

Clone | Abstract method to Copy filter
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FirstMember | Get first member for which filter is true.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Members | Return all members for which filter is true.
Next | Get next element in current list for which filter is true.
Parent | Climb up to element for which filter is true
ScanBelow | abtract method to test whether we need to scan below given element. i.e. could there be elements below this one taht matches the filter. This can be used to optimise a scan. e.g. if we are looking for boxes, there is no point scanning below a branch.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | abstract method to return whether filter is true or false for a given element.

See Also

BaseFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseFilter.Clone Method

Abstract method to Copy filter

public abstract object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

BaseFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseFilter.FirstMember Method

Get first member for which filter is true.

public DbElement FirstMember(
DbElement element
);

Parameters

element
current element

Return Value

first member for which filter is true

See Also

BaseFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseFilter.Members Method

Return all members for which filter is true.

public DbElement[] Members(
DbElement ele
);

Parameters

ele
current element

Return Value

members for which filter is true

See Also

BaseFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseFilter.Next Method

Get next element in current list for which filter is true.

public DbElement Next(
DbElement element
);

Parameters

element
current element

Return Value

next element for which filter is true

See Also

BaseFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseFilter.Parent Method

Climb up to element for which filter is true

public DbElement Parent(
DbElement element
);

Parameters

element
current element

Return Value

first ancestor that matches filter

See Also

BaseFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseFilter.ScanBelow Method

abtract method to test whether we need to scan below given element. i.e. could there be elements below this one taht matches the filter. This can be used to optimise a scan. e.g. if we are looking for boxes, there is no point scanning below a branch.

public abstract bool ScanBelow(
DbElement element
);

Parameters

element
current element

Return Value

whether to scan below or not

See Also

BaseFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseFilter.Valid Method

abstract method to return whether filter is true or false for a given element.

public abstract bool Valid(
DbElement element
);

Parameters

element
element to evaluate filter against

Return Value

result of avaluating filter

See Also

BaseFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseFilter Operators

The operators of the BaseFilter class are listed below. For a complete list of BaseFilter class members, see the BaseFilter Members topic.

Public Static Operators

Equality Operator | Compare filters.
Inequality Operator | Compare filters for inequality

See Also

BaseFilter Class | BaseFilter Members | Aveva.PDMS.Database.Filters Namespace


BaseFilter Equality Operator

Compare filters.

public static bool operator ==(
BaseFilter f1,
BaseFilter f2
);

Parameters

f1
f2

Return Value

See Also

BaseFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseFilter Inequality Operator

Compare filters for inequality

public static bool operator !=(
BaseFilter f1,
BaseFilter f2
);

Parameters

f1
f2

Return Value

See Also

BaseFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowFilter Class

Filter to test if element is below an element for which the given filter is true.

For a list of all members of this type, see BelowFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.BelowFilter

public class BelowFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

BelowFilter Members | Aveva.PDMS.Database.Filters Namespace


BelowFilter Members

BelowFilter overview

Public Instance Constructors

BelowFilter Constructor Construct instance of filter passing filter to use as test

Public Instance Properties

Filter Filter used for test

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | Test all ancestors against stored filter.

See Also

BelowFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowFilter Constructor

Construct instance of filter passing filter to use as test

public BelowFilter(
BaseFilter filter
);

Parameters

filter

See Also

BelowFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowFilter Properties

The properties of the BelowFilter class are listed below. For a complete list of BelowFilter class members, see the BelowFilter Members topic.

Public Instance Properties

Filter Filter used for test

See Also

BelowFilter Class | Aveva.PDMS.Database.Filters Namespace


Filter Property

AVEVA Database Filters .NET Public Interface

BelowFilter.Filter Property

Filter used for test

public BaseFilter Filter {get; set;}

See Also

BelowFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowFilter Methods

The methods of the BelowFilter class are listed below. For a complete list of BelowFilter class members, see the BelowFilter Members topic.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | Test all ancestors against stored filter.

See Also

BelowFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

BelowFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

BelowFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

BelowFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowFilter.ScanBelow Method

Method to test whether we need to scan below given element. Optimised for this class.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

BelowFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowFilter.Valid Method

Test all ancestors against stored filter.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of evaluating filter

See Also

BelowFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtFilter Class

Filter to test if element is below or at an element for which the given filter is true.

For a list of all members of this type, see BelowOrAtFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.BelowOrAtFilter

public class BelowOrAtFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

BelowOrAtFilter Members | Aveva.PDMS.Database.Filters Namespace


BelowOrAtFilter Members

BelowOrAtFilter overview

Public Instance Constructors

BelowOrAtFilter Constructor Construct instance of filter passing filter to use as test

Public Instance Properties

Filter filter to use for test

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | Test element and all ancestors against stored filter.

See Also

BelowOrAtFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtFilter Constructor

Construct instance of filter passing filter to use as test

public BelowOrAtFilter(
BaseFilter filter
);

See Also

BelowOrAtFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtFilter Properties

The properties of the BelowOrAtFilter class are listed below. For a complete list of BelowOrAtFilter class members, see the BelowOrAtFilter Members topic.

Public Instance Properties

Filter filter to use for test

See Also

BelowOrAtFilter Class | Aveva.PDMS.Database.Filters Namespace


Filter Property

AVEVA Database Filters .NET Public Interface

BelowOrAtFilter.Filter Property

filter to use for test

public BaseFilter Filter {get; set;}

See Also

BelowOrAtFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtFilter Methods

The methods of the BelowOrAtFilter class are listed below. For a complete list of BelowOrAtFilter class members, see the BelowOrAtFilter Members topic.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | Test element and all ancestors against stored filter.

See Also

BelowOrAtFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

BelowOrAtFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

BelowOrAtFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

BelowOrAtFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtFilter.ScanBelow Method

Method to test whether we need to scan below given element. Optimised for this class.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

BelowOrAtFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtFilter.Valid Method

Test element and all ancestors against stored filter.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

BelowOrAtFilter Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtType Class

Filter to test if element is at or below given element types.

For a list of all members of this type, see BelowOrAtType Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.BelowOrAtType

public class BelowOrAtType : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

BelowOrAtType Members | Aveva.PDMS.Database.Filters Namespace


BelowOrAtType Members

BelowOrAtType overview

Public Instance Constructors

BelowOrAtType Overloaded. Initializes a new instance of the BelowOrAtType class.

Public Instance Properties

types List of element types

Public Instance Methods

Add | Overloaded. Add element type to list of possibilities
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove | Remove element type from list of possibilities
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtType Constructor

Construct filter for single type

Overload List

Empty filter

public BelowOrAtType();

Construct filter for single type

public BelowOrAtType(DbElementType);

Set list of possible types

public BelowOrAtType(DbElementType[]);

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtType Constructor (DbElementType)

Construct filter for single type

public BelowOrAtType(
DbElementType type
);

Parameters

type

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace | BelowOrAtType Constructor Overload List


BelowOrAtType Constructor (DbElementType[])

Set list of possible types

public BelowOrAtType(
DbElementType[] types
);

Parameters

types

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace | BelowOrAtType Constructor Overload List


BelowOrAtType Constructor ()

Empty filter

public BelowOrAtType();

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace | BelowOrAtType Constructor Overload List


BelowOrAtType Properties

The properties of the BelowOrAtType class are listed below. For a complete list of BelowOrAtType class members, see the BelowOrAtType Members topic.

Public Instance Properties

types List of element types

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace


types Property

AVEVA Database Filters .NET Public Interface

BelowOrAtType.types Property

List of element types

public Aveva.Pdms.Database.DbElementType[] types {get;}

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtType Methods

The methods of the BelowOrAtType class are listed below. For a complete list of BelowOrAtType class members, see the BelowOrAtType Members topic.

Public Instance Methods

Add | Overloaded. Add element type to list of possibilities
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove | Remove element type from list of possibilities
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace


Add Method

AVEVA Database Filters .NET Public Interface

BelowOrAtType.Add Method

Add element type to list of possibilities

Overload List

Add element type to list of possibilities

public void Add(DbElementType);

Add list of element types to list of possibilities

public void Add(DbElementType[]);

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtType.Add Method (DbElementType)

Add element type to list of possibilities

public void Add(
DbElementType type
);

Parameters

type

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace | BelowOrAtType.Add Overload List


BelowOrAtType.Add Method (DbElementType[])

Add list of element types to list of possibilities

public void Add(
DbElementType[] types
);

Parameters

types

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace | BelowOrAtType.Add Overload List


BelowOrAtType.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtType.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtType.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtType.Remove Method

Remove element type from list of possibilities

public void Remove(
DbElementType type
);

Parameters

type

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtType.ScanBelow Method

Method to test whether we need to scan below given element. Optimised for this class.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace


BelowOrAtType.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

BelowOrAtType Class | Aveva.PDMS.Database.Filters Namespace


BelowType Class

As for the Below filter, but more efficient in the case where we want to test on type only

For a list of all members of this type, see BelowType Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.BelowType

public class BelowType : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

BelowType Members | Aveva.PDMS.Database.Filters Namespace


BelowType Members

BelowType overview

Public Instance Constructors

BelowType Overloaded. Initializes a new instance of the BelowType class.

Public Instance Properties

types list of types

Public Instance Methods

Add | Overloaded. Add type to list
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove | Remove type from list
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace


BelowType Constructor

Constructor taking single element type

Overload List

Default Constructor

public BelowType();

Constructor taking single element type

public BelowType(DbElementType);

Constructor taking list of types

public BelowType(DbElementType[]);

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace


BelowType Constructor (DbElementType)

Constructor taking single element type

public BelowType(
DbElementType type
);

Parameters

type

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace | BelowType Constructor Overload List


BelowType Constructor (DbElementType[])

Constructor taking list of types

public BelowType(
DbElementType[] types
);

Parameters

types

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace | BelowType Constructor Overload List


BelowType Constructor ()

Default Constructor

public BelowType();

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace | BelowType Constructor Overload List


BelowType Properties

The properties of the BelowType class are listed below. For a complete list of BelowType class members, see the BelowType Members topic.

Public Instance Properties

types list of types

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace


types Property

AVEVA Database Filters .NET Public Interface

BelowType.types Property

list of types

public Aveva.Pdms.Database.DbElementType[] types {get;}

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace


BelowType Methods

The methods of the BelowType class are listed below. For a complete list of BelowType class members, see the BelowType Members topic.

Public Instance Methods

Add | Overloaded. Add type to list
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove | Remove type from list
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace


Add Method

AVEVA Database Filters .NET Public Interface

BelowType.Add Method

Add type to list

Overload List

Add type to list

public void Add(DbElementType);

Add list of types to list

public void Add(DbElementType[]);

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace


BelowType.Add Method (DbElementType)

Add type to list

public void Add(
DbElementType type
);

Parameters

type

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace | BelowType.Add Overload List


BelowType.Add Method (DbElementType[])

Add list of types to list

public void Add(
DbElementType[] types
);

Parameters

types

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace | BelowType.Add Overload List


BelowType.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace


BelowType.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace


BelowType.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace


BelowType.Remove Method

Remove type from list

public void Remove(
DbElementType type
);

Parameters

type

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace


BelowType.ScanBelow Method

Method to test whether we need to scan below given element. Optimised for this class.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace


BelowType.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

BelowType Class | Aveva.PDMS.Database.Filters Namespace


BooleanOperator Enumeration

public enum BooleanOperator

Members

Member Name | Description
NOT_AND | Boolean NOT...AND.
NOT_OR | Boolean NOT...OR.
AND | Boolean AND.
OR | Boolean OR.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

Aveva.PDMS.Database.Filters Namespace


CompoundFilter Class

Filter designed specifically for use in the explorer. It is composed of the following - list of filters for elements to show - list of filters for elements to skip - list of filters for elements to hide if there are no 'show' or 'showDescendants then ALL elements considered to be shown.

For a list of all members of this type, see CompoundFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.CompoundFilter
Derived types

public class CompoundFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

CompoundFilter Members | Aveva.PDMS.Database.Filters Namespace


CompoundFilter Members

CompoundFilter overview

Public Instance Constructors

CompoundFilter Constructor default constructor

Public Instance Properties

Hides | Add a 'hide' filters
Shows | list of 'show' filters.
Skips | 'skip' filters

Public Instance Methods

AddHide | Add a 'hide' filter to list
AddShow | Add additional 'show' filter.
AddSkip | Add additional 'skip' filter.
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
RemoveHide | Remove 'hide' filter from list
RemoveShow | Remove given 'show' filter.
RemoveSkip | remove 'skip' filter from list.
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
TestSkip | Test 'skip' filters only
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


CompoundFilter Constructor

default constructor

public CompoundFilter();

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


CompoundFilter Properties

The properties of the CompoundFilter class are listed below. For a complete list of CompoundFilter class members, see the CompoundFilter Members topic.

Public Instance Properties

Hides | Add a 'hide' filters
Shows | list of 'show' filters.
Skips | 'skip' filters

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


Hides Property

AVEVA Database Filters .NET Public Interface

CompoundFilter.Hides Property

Add a 'hide' filters

public BaseFilter[] Hides {get;}

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


Shows Property

AVEVA Database Filters .NET Public Interface

CompoundFilter.Shows Property

list of 'show' filters.

public BaseFilter[] Shows {get;}

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


Skips Property

AVEVA Database Filters .NET Public Interface

CompoundFilter.Skips Property

'skip' filters

public BaseFilter[] Skips {get;}

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


CompoundFilter Methods

The methods of the CompoundFilter class are listed below. For a complete list of CompoundFilter class members, see the CompoundFilter Members topic.

Public Instance Methods

AddHide | Add a 'hide' filter to list
AddShow | Add additional 'show' filter.
AddSkip | Add additional 'skip' filter.
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
RemoveHide | Remove 'hide' filter from list
RemoveShow | Remove given 'show' filter.
RemoveSkip | remove 'skip' filter from list.
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
TestSkip | Test 'skip' filters only
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


CompoundFilter.AddHide Method

Add a 'hide' filter to list

public void AddHide(
BaseFilter filt
);

Parameters

filt

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


CompoundFilter.AddShow Method

Add additional 'show' filter.

public void AddShow(
BaseFilter filt
);

Parameters

filt

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


CompoundFilter.AddSkip Method

Add additional 'skip' filter.

public void AddSkip(
BaseFilter filt
);

Parameters

filt

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


CompoundFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


CompoundFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


CompoundFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


CompoundFilter.RemoveHide Method

Remove 'hide' filter from list

public void RemoveHide(
BaseFilter filt
);

Parameters

filt

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


CompoundFilter.RemoveShow Method

Remove given 'show' filter.

public void RemoveShow(
BaseFilter filt
);

Parameters

filt

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


CompoundFilter.RemoveSkip Method

remove 'skip' filter from list.

public void RemoveSkip(
BaseFilter filt
);

Parameters

filt

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


CompoundFilter.ScanBelow Method

Method to test whether we need to scan below given element. Optimised for this class.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


CompoundFilter.TestSkip Method

Test 'skip' filters only

public bool TestSkip(
DbElement ele
);

Parameters

ele

Return Value

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


CompoundFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

CompoundFilter Class | Aveva.PDMS.Database.Filters Namespace


DBElementCollection Class

Class to iterate through the database hierarchy returning the elements that match the supplied filter. The scan starts at a given element. If no filter is given, then all elements below the start element are returned. The actual iteration is done via an enumerator.

For a list of all members of this type, see DBElementCollection Members.

System.Object
Aveva.PDMS.Database.Filters.DBElementCollection

public class DBElementCollection : IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

DBElementCollection Members | Aveva.PDMS.Database.Filters Namespace


DBElementCollection Members

DBElementCollection overview

Public Instance Constructors

DBElementCollection Overloaded. Initializes a new instance of the DBElementCollection class.

Public Instance Properties

Filter | filter to be applied
IncludeRoot | Flag to denotr if to return the root element as aprt of the collection

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Return enumerator into the database. This enumerator can then be used to do the actual iteration.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DBElementCollection Class | Aveva.PDMS.Database.Filters Namespace


DBElementCollection Constructor

Default constructor

Overload List

Default constructor

public DBElementCollection();

Constructor taking a root element

public DBElementCollection(DbElement);

Constructor taking root element and a filter

public DBElementCollection(DbElement,BaseFilter);

See Also

DBElementCollection Class | Aveva.PDMS.Database.Filters Namespace


DBElementCollection Constructor ()

Default constructor

public DBElementCollection();

See Also

DBElementCollection Class | Aveva.PDMS.Database.Filters Namespace | DBElementCollection Constructor Overload List


DBElementCollection Constructor (DbElement)

Constructor taking a root element

public DBElementCollection(
DbElement root
);

Parameters

root

See Also

DBElementCollection Class | Aveva.PDMS.Database.Filters Namespace | DBElementCollection Constructor Overload List


DBElementCollection Constructor (DbElement, BaseFilter)

Constructor taking root element and a filter

public DBElementCollection(
DbElement root,
BaseFilter filt
);

Parameters

root
filt

See Also

DBElementCollection Class | Aveva.PDMS.Database.Filters Namespace | DBElementCollection Constructor Overload List


DBElementCollection Properties

The properties of the DBElementCollection class are listed below. For a complete list of DBElementCollection class members, see the DBElementCollection Members topic.

Public Instance Properties

Filter | filter to be applied
IncludeRoot | Flag to denotr if to return the root element as aprt of the collection

See Also

DBElementCollection Class | Aveva.PDMS.Database.Filters Namespace


Filter Property

AVEVA Database Filters .NET Public Interface

DBElementCollection.Filter Property

filter to be applied

public BaseFilter Filter {get; set;}

See Also

DBElementCollection Class | Aveva.PDMS.Database.Filters Namespace


IncludeRoot Property

AVEVA Database Filters .NET Public Interface

DBElementCollection.IncludeRoot Property

Flag to denotr if to return the root element as aprt of the collection

public bool IncludeRoot {get; set;}

See Also

DBElementCollection Class | Aveva.PDMS.Database.Filters Namespace


DBElementCollection Methods

The methods of the DBElementCollection class are listed below. For a complete list of DBElementCollection class members, see the DBElementCollection Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Return enumerator into the database. This enumerator can then be used to do the actual iteration.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DBElementCollection Class | Aveva.PDMS.Database.Filters Namespace


DBElementCollection.GetEnumerator Method

Return enumerator into the database. This enumerator can then be used to do the actual iteration.

public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

DBElementCollection Class | Aveva.PDMS.Database.Filters Namespace


DBElementEnumerator Class

Enumerator to iterate through a scan defined by the DBElementCollection class.

For a list of all members of this type, see DBElementEnumerator Members.

System.Object
Aveva.PDMS.Database.Filters.DBElementEnumerator

public class DBElementEnumerator : IEnumerator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

DBElementEnumerator Members | Aveva.PDMS.Database.Filters Namespace


DBElementEnumerator Members

DBElementEnumerator overview

Public Instance Properties

CountSoFar | number of elements passing filter so far
Current | return element at current position.
Scanned | Total number of elements the the enumerator naviagated over, regardless of whether they satisfied the filter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Move to next element that satisfies the filter.
Reset | Reset enumerator to start of scan.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DBElementEnumerator Class | Aveva.PDMS.Database.Filters Namespace


DBElementEnumerator Properties

The properties of the DBElementEnumerator class are listed below. For a complete list of DBElementEnumerator class members, see the DBElementEnumerator Members topic.

Public Instance Properties

CountSoFar | number of elements passing filter so far
Current | return element at current position.
Scanned | Total number of elements the the enumerator naviagated over, regardless of whether they satisfied the filter.

See Also

DBElementEnumerator Class | Aveva.PDMS.Database.Filters Namespace


CountSoFar Property

AVEVA Database Filters .NET Public Interface

DBElementEnumerator.CountSoFar Property

number of elements passing filter so far

public int CountSoFar {get;}

See Also

DBElementEnumerator Class | Aveva.PDMS.Database.Filters Namespace


Current Property

AVEVA Database Filters .NET Public Interface

DBElementEnumerator.Current Property

return element at current position.

public object Current {get;}

Implements

IEnumerator.Current

See Also

DBElementEnumerator Class | Aveva.PDMS.Database.Filters Namespace


Scanned Property

AVEVA Database Filters .NET Public Interface

DBElementEnumerator.Scanned Property

Total number of elements the the enumerator naviagated over, regardless of whether they satisfied the filter.

public int Scanned {get;}

See Also

DBElementEnumerator Class | Aveva.PDMS.Database.Filters Namespace


DBElementEnumerator Methods

The methods of the DBElementEnumerator class are listed below. For a complete list of DBElementEnumerator class members, see the DBElementEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext | Move to next element that satisfies the filter.
Reset | Reset enumerator to start of scan.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DBElementEnumerator Class | Aveva.PDMS.Database.Filters Namespace


DBElementEnumerator.MoveNext Method

Move to next element that satisfies the filter.

public bool MoveNext();

Return Value

Implements

IEnumerator.MoveNext

See Also

DBElementEnumerator Class | Aveva.PDMS.Database.Filters Namespace


DBElementEnumerator.Reset Method

Reset enumerator to start of scan.

public void Reset();

Implements

IEnumerator.Reset

See Also

DBElementEnumerator Class | Aveva.PDMS.Database.Filters Namespace


DBTypeFilter Class

Returns true if DB is of a given type

For a list of all members of this type, see DBTypeFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.DBTypeFilter

public class DBTypeFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

DBTypeFilter Members | Aveva.PDMS.Database.Filters Namespace


DBTypeFilter Members

DBTypeFilter overview

Public Instance Constructors

DBTypeFilter Constructor Constructor taking a DB type

Public Instance Properties

Type DB type

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always returns true.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

DBTypeFilter Class | Aveva.PDMS.Database.Filters Namespace


DBTypeFilter Constructor

Constructor taking a DB type

public DBTypeFilter(
DbType type
);

Parameters

type

See Also

DBTypeFilter Class | Aveva.PDMS.Database.Filters Namespace


DBTypeFilter Properties

The properties of the DBTypeFilter class are listed below. For a complete list of DBTypeFilter class members, see the DBTypeFilter Members topic.

Public Instance Properties

Type DB type

See Also

DBTypeFilter Class | Aveva.PDMS.Database.Filters Namespace


Type Property

AVEVA Database Filters .NET Public Interface

DBTypeFilter.Type Property

DB type

public Aveva.Pdms.Database.DbType Type {get; set;}

See Also

DBTypeFilter Class | Aveva.PDMS.Database.Filters Namespace


DBTypeFilter Methods

The methods of the DBTypeFilter class are listed below. For a complete list of DBTypeFilter class members, see the DBTypeFilter Members topic.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always returns true.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

DBTypeFilter Class | Aveva.PDMS.Database.Filters Namespace


DBTypeFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

DBTypeFilter Class | Aveva.PDMS.Database.Filters Namespace


DBTypeFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

DBTypeFilter Class | Aveva.PDMS.Database.Filters Namespace


DBTypeFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

DBTypeFilter Class | Aveva.PDMS.Database.Filters Namespace


DBTypeFilter.ScanBelow Method

Method to test whether we need to scan below given element. Always returns true.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

DBTypeFilter Class | Aveva.PDMS.Database.Filters Namespace


DBTypeFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

DBTypeFilter Class | Aveva.PDMS.Database.Filters Namespace


DraftAdminFilter Class

Specific Filter to be used by the explorer for Draft Admin users.

For a list of all members of this type, see DraftAdminFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.CompoundFilter
Aveva.PDMS.Database.Filters.DraftAdminFilter

public class DraftAdminFilter : CompoundFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

DraftAdminFilter Members | Aveva.PDMS.Database.Filters Namespace


DraftAdminFilter Members

DraftAdminFilter overview

Public Instance Constructors

DraftAdminFilter Constructor Default constructor

Public Instance Properties

Hides (inherited from CompoundFilter) | Add a 'hide' filters
Shows (inherited from CompoundFilter) | list of 'show' filters.
Skips (inherited from CompoundFilter) | 'skip' filters

Public Instance Methods

AddHide (inherited from CompoundFilter) | Add a 'hide' filter to list
AddShow (inherited from CompoundFilter) | Add additional 'show' filter.
AddSkip (inherited from CompoundFilter) | Add additional 'skip' filter.
Clone (inherited from CompoundFilter) | method to Copy filter
Equals (inherited from CompoundFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from CompoundFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
RemoveHide (inherited from CompoundFilter) | Remove 'hide' filter from list
RemoveShow (inherited from CompoundFilter) | Remove given 'show' filter.
RemoveSkip (inherited from CompoundFilter) | remove 'skip' filter from list.
ScanBelow (inherited from CompoundFilter) | Method to test whether we need to scan below given element. Optimised for this class.
TestSkip (inherited from CompoundFilter) | Test 'skip' filters only
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid (inherited from CompoundFilter) | method to return whether filter is true or false for a given element.

See Also

DraftAdminFilter Class | Aveva.PDMS.Database.Filters Namespace


DraftAdminFilter Constructor

Default constructor

public DraftAdminFilter();

See Also

DraftAdminFilter Class | Aveva.PDMS.Database.Filters Namespace


DraftFilter Class

Specific Filter to be used by the explorer for Draft DBs.

For a list of all members of this type, see DraftFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.CompoundFilter
Aveva.PDMS.Database.Filters.DraftFilter

public class DraftFilter : CompoundFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

DraftFilter Members | Aveva.PDMS.Database.Filters Namespace


DraftFilter Members

DraftFilter overview

Public Instance Constructors

DraftFilter Constructor Default constructor

Public Instance Properties

Hides (inherited from CompoundFilter) | Add a 'hide' filters
Shows (inherited from CompoundFilter) | list of 'show' filters.
Skips (inherited from CompoundFilter) | 'skip' filters

Public Instance Methods

AddHide (inherited from CompoundFilter) | Add a 'hide' filter to list
AddShow (inherited from CompoundFilter) | Add additional 'show' filter.
AddSkip (inherited from CompoundFilter) | Add additional 'skip' filter.
Clone (inherited from CompoundFilter) | method to Copy filter
Equals (inherited from CompoundFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from CompoundFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
RemoveHide (inherited from CompoundFilter) | Remove 'hide' filter from list
RemoveShow (inherited from CompoundFilter) | Remove given 'show' filter.
RemoveSkip (inherited from CompoundFilter) | remove 'skip' filter from list.
ScanBelow (inherited from CompoundFilter) | Method to test whether we need to scan below given element. Optimised for this class.
TestSkip (inherited from CompoundFilter) | Test 'skip' filters only
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid (inherited from CompoundFilter) | method to return whether filter is true or false for a given element.

See Also

DraftFilter Class | Aveva.PDMS.Database.Filters Namespace


DraftFilter Constructor

Default constructor

public DraftFilter();

See Also

DraftFilter Class | Aveva.PDMS.Database.Filters Namespace


ElementTreeNavigator Class

Class to navigate a Dabacon tree taking into account the given filters. It allows the scan to continue at any point in the tree. The class is for use by the Explorer. The tree view presented is compressed to remove any 'skipped' elements.

For a list of all members of this type, see ElementTreeNavigator Members.

System.Object
Aveva.PDMS.Database.Filters.ElementTreeNavigator

public class ElementTreeNavigator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

ElementTreeNavigator Members | Aveva.PDMS.Database.Filters Namespace


ElementTreeNavigator Members

ElementTreeNavigator overview

Public Instance Constructors

ElementTreeNavigator Constructor Constructor taking root element and filter

Public Instance Properties

Filter | Filter to use
TopElement | root element

Public Instance Methods

DbWorldMembersInScan | Return members at world level
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FirstMemberInScan | Get the first member.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasMember | has element any members that satisfy the filter and is of given type.
HasMembers | returns true if element has members that satisfy the filter
MembersInScan | Return list of members below given element. The method also works for secondary hierarchies.
NextInScan | Get next element at this level that matches filter
Parent | First ascendant that satisfies filter
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ElementTreeNavigator Class | Aveva.PDMS.Database.Filters Namespace


ElementTreeNavigator Constructor

Constructor taking root element and filter

public ElementTreeNavigator(
DbElement ele,
CompoundFilter filter
);

Parameters

ele
filter

See Also

ElementTreeNavigator Class | Aveva.PDMS.Database.Filters Namespace


ElementTreeNavigator Properties

The properties of the ElementTreeNavigator class are listed below. For a complete list of ElementTreeNavigator class members, see the ElementTreeNavigator Members topic.

Public Instance Properties

Filter | Filter to use
TopElement | root element

See Also

ElementTreeNavigator Class | Aveva.PDMS.Database.Filters Namespace


Filter Property

AVEVA Database Filters .NET Public Interface

ElementTreeNavigator.Filter Property

Filter to use

public CompoundFilter Filter {get; set;}

See Also

ElementTreeNavigator Class | Aveva.PDMS.Database.Filters Namespace


TopElement Property

AVEVA Database Filters .NET Public Interface

ElementTreeNavigator.TopElement Property

root element

public Aveva.Pdms.Database.DbElement TopElement {get; set;}

See Also

ElementTreeNavigator Class | Aveva.PDMS.Database.Filters Namespace


ElementTreeNavigator Methods

The methods of the ElementTreeNavigator class are listed below. For a complete list of ElementTreeNavigator class members, see the ElementTreeNavigator Members topic.

Public Instance Methods

DbWorldMembersInScan | Return members at world level
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FirstMemberInScan | Get the first member.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasMember | has element any members that satisfy the filter and is of given type.
HasMembers | returns true if element has members that satisfy the filter
MembersInScan | Return list of members below given element. The method also works for secondary hierarchies.
NextInScan | Get next element at this level that matches filter
Parent | First ascendant that satisfies filter
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ElementTreeNavigator Class | Aveva.PDMS.Database.Filters Namespace


ElementTreeNavigator.DbWorldMembersInScan Method

Return members at world level

public DbElement[] DbWorldMembersInScan(
Db db
);

Parameters

db

Return Value

list of members satisfying filter

See Also

ElementTreeNavigator Class | Aveva.PDMS.Database.Filters Namespace


ElementTreeNavigator.FirstMemberInScan Method

Get the first member.

public DbElement FirstMemberInScan(
DbElement startce
);

Parameters

startce

Return Value

See Also

ElementTreeNavigator Class | Aveva.PDMS.Database.Filters Namespace


ElementTreeNavigator.HasMember Method

has element any members that satisfy the filter and is of given type.

public bool HasMember(
DbElement ele,
DbElementType eleType
);

Parameters

ele
eleType
element type to match

Return Value

See Also

ElementTreeNavigator Class | Aveva.PDMS.Database.Filters Namespace


ElementTreeNavigator.HasMembers Method

returns true if element has members that satisfy the filter

public bool HasMembers(
DbElement ele
);

Parameters

ele

Return Value

See Also

ElementTreeNavigator Class | Aveva.PDMS.Database.Filters Namespace


ElementTreeNavigator.MembersInScan Method

Return list of members below given element. The method also works for secondary hierarchies.

public DbElement[] MembersInScan(
DbElement ele
);

Parameters

ele
element

Return Value

list of members satisfying filter

See Also

ElementTreeNavigator Class | Aveva.PDMS.Database.Filters Namespace


ElementTreeNavigator.NextInScan Method

Get next element at this level that matches filter

public DbElement NextInScan(
DbElement startce
);

Parameters

startce

Return Value

See Also

ElementTreeNavigator Class | Aveva.PDMS.Database.Filters Namespace


ElementTreeNavigator.Parent Method

First ascendant that satisfies filter

public DbElement Parent(
DbElement ele
);

Parameters

ele

Return Value

See Also

ElementTreeNavigator Class | Aveva.PDMS.Database.Filters Namespace


EquipmentFilter Class

Specific Filter to be used by the explorer when designing equipment.

For a list of all members of this type, see EquipmentFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.CompoundFilter
Aveva.PDMS.Database.Filters.EquipmentFilter

public class EquipmentFilter : CompoundFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

EquipmentFilter Members | Aveva.PDMS.Database.Filters Namespace


EquipmentFilter Members

EquipmentFilter overview

Public Instance Constructors

EquipmentFilter Constructor Default constructor

Public Instance Properties

Hides (inherited from CompoundFilter) | Add a 'hide' filters
Shows (inherited from CompoundFilter) | list of 'show' filters.
Skips (inherited from CompoundFilter) | 'skip' filters

Public Instance Methods

AddHide (inherited from CompoundFilter) | Add a 'hide' filter to list
AddShow (inherited from CompoundFilter) | Add additional 'show' filter.
AddSkip (inherited from CompoundFilter) | Add additional 'skip' filter.
Clone (inherited from CompoundFilter) | method to Copy filter
Equals (inherited from CompoundFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from CompoundFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
RemoveHide (inherited from CompoundFilter) | Remove 'hide' filter from list
RemoveShow (inherited from CompoundFilter) | Remove given 'show' filter.
RemoveSkip (inherited from CompoundFilter) | remove 'skip' filter from list.
ScanBelow (inherited from CompoundFilter) | Method to test whether we need to scan below given element. Optimised for this class.
TestSkip (inherited from CompoundFilter) | Test 'skip' filters only
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid (inherited from CompoundFilter) | method to return whether filter is true or false for a given element.

See Also

EquipmentFilter Class | Aveva.PDMS.Database.Filters Namespace


EquipmentFilter Constructor

Default constructor

public EquipmentFilter();

See Also

EquipmentFilter Class | Aveva.PDMS.Database.Filters Namespace


FalseFilter Class

Filter that always returns false.

For a list of all members of this type, see FalseFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.FalseFilter

public class FalseFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

FalseFilter Members | Aveva.PDMS.Database.Filters Namespace


FalseFilter Members

FalseFilter overview

Public Instance Constructors

FalseFilter Constructor Initializes a new instance of the FalseFilter class.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Always returns 0
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always false for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | always returns false

See Also

FalseFilter Class | Aveva.PDMS.Database.Filters Namespace


FalseFilter Constructor

Initializes a new instance of the FalseFilter class.

public FalseFilter();

See Also

FalseFilter Class | Aveva.PDMS.Database.Filters Namespace


FalseFilter Methods

The methods of the FalseFilter class are listed below. For a complete list of FalseFilter class members, see the FalseFilter Members topic.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Always returns 0
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always false for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | always returns false

See Also

FalseFilter Class | Aveva.PDMS.Database.Filters Namespace


FalseFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

FalseFilter Class | Aveva.PDMS.Database.Filters Namespace


FalseFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

FalseFilter Class | Aveva.PDMS.Database.Filters Namespace


FalseFilter.GetHashCode Method

Always returns 0

public override int GetHashCode();

Return Value

See Also

FalseFilter Class | Aveva.PDMS.Database.Filters Namespace


FalseFilter.ScanBelow Method

Method to test whether we need to scan below given element. Always false for this class.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

FalseFilter Class | Aveva.PDMS.Database.Filters Namespace


FalseFilter.Valid Method

always returns false

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

FalseFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldIntFilter Class

Returns true if DbElementType integer field is valid and equal to val

For a list of all members of this type, see FieldIntFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.FieldIntFilter

public class FieldIntFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

FieldIntFilter Members | Aveva.PDMS.Database.Filters Namespace


FieldIntFilter Members

FieldIntFilter overview

Public Instance Constructors

FieldIntFilter Constructor Constructor to take field ID and value to test against

Public Instance Properties

Field Field to test

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always returns true.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

FieldIntFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldIntFilter Constructor

Constructor to take field ID and value to test against

public FieldIntFilter(
DbNounField field,
int val
);

Parameters

field
val

See Also

FieldIntFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldIntFilter Properties

The properties of the FieldIntFilter class are listed below. For a complete list of FieldIntFilter class members, see the FieldIntFilter Members topic.

Public Instance Properties

Field Field to test

See Also

FieldIntFilter Class | Aveva.PDMS.Database.Filters Namespace


Field Property

AVEVA Database Filters .NET Public Interface

FieldIntFilter.Field Property

Field to test

public Aveva.Pdms.Database.DbNounField Field {get; set;}

See Also

FieldIntFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldIntFilter Methods

The methods of the FieldIntFilter class are listed below. For a complete list of FieldIntFilter class members, see the FieldIntFilter Members topic.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always returns true.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

FieldIntFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldIntFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

FieldIntFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldIntFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

FieldIntFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldIntFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

FieldIntFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldIntFilter.ScanBelow Method

Method to test whether we need to scan below given element. Always returns true.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

FieldIntFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldIntFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

FieldIntFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldTrueFilter Class

Filter to return true if Element type field is valid and true

For a list of all members of this type, see FieldTrueFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.FieldTrueFilter

public class FieldTrueFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

FieldTrueFilter Members | Aveva.PDMS.Database.Filters Namespace


FieldTrueFilter Members

FieldTrueFilter overview

Public Instance Constructors

FieldTrueFilter Constructor Constructor taking the ElementType boolean field to test

Public Instance Properties

Field Element Type field

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always returns true.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | Returns true if field is true for given element.

See Also

FieldTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldTrueFilter Constructor

Constructor taking the ElementType boolean field to test

public FieldTrueFilter(
DbNounField field
);

Parameters

field

See Also

FieldTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldTrueFilter Properties

The properties of the FieldTrueFilter class are listed below. For a complete list of FieldTrueFilter class members, see the FieldTrueFilter Members topic.

Public Instance Properties

Field Element Type field

See Also

FieldTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


Field Property

AVEVA Database Filters .NET Public Interface

FieldTrueFilter.Field Property

Element Type field

public Aveva.Pdms.Database.DbNounField Field {get; set;}

See Also

FieldTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldTrueFilter Methods

The methods of the FieldTrueFilter class are listed below. For a complete list of FieldTrueFilter class members, see the FieldTrueFilter Members topic.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always returns true.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | Returns true if field is true for given element.

See Also

FieldTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldTrueFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

FieldTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldTrueFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

FieldTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldTrueFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

FieldTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldTrueFilter.ScanBelow Method

Method to test whether we need to scan below given element. Always returns true.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

FieldTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


FieldTrueFilter.Valid Method

Returns true if field is true for given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

FieldTrueFilter Class | Aveva.PDMS.Database.Filters Namespace


HangerFilter Class

Specific Filter to be used by the explorer when designing hangers.

For a list of all members of this type, see HangerFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.CompoundFilter
Aveva.PDMS.Database.Filters.HangerFilter

public class HangerFilter : CompoundFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

HangerFilter Members | Aveva.PDMS.Database.Filters Namespace


HangerFilter Members

HangerFilter overview

Public Instance Constructors

HangerFilter Constructor Default constructor

Public Instance Properties

Hides (inherited from CompoundFilter) | Add a 'hide' filters
Shows (inherited from CompoundFilter) | list of 'show' filters.
Skips (inherited from CompoundFilter) | 'skip' filters

Public Instance Methods

AddHide (inherited from CompoundFilter) | Add a 'hide' filter to list
AddShow (inherited from CompoundFilter) | Add additional 'show' filter.
AddSkip (inherited from CompoundFilter) | Add additional 'skip' filter.
Clone (inherited from CompoundFilter) | method to Copy filter
Equals (inherited from CompoundFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from CompoundFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
RemoveHide (inherited from CompoundFilter) | Remove 'hide' filter from list
RemoveShow (inherited from CompoundFilter) | Remove given 'show' filter.
RemoveSkip (inherited from CompoundFilter) | remove 'skip' filter from list.
ScanBelow (inherited from CompoundFilter) | Method to test whether we need to scan below given element. Optimised for this class.
TestSkip (inherited from CompoundFilter) | Test 'skip' filters only
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid (inherited from CompoundFilter) | method to return whether filter is true or false for a given element.

See Also

HangerFilter Class | Aveva.PDMS.Database.Filters Namespace


HangerFilter Constructor

Default constructor

public HangerFilter();

See Also

HangerFilter Class | Aveva.PDMS.Database.Filters Namespace


HideBelowFilter Class

Filter to hide all elements below an element of a given type. e.g. hide all elements below a group. It returns true if not an element to hide. Used by the explorer.

For a list of all members of this type, see HideBelowFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.TypeFilter
Aveva.PDMS.Database.Filters.HideBelowFilter

public class HideBelowFilter : TypeFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

HideBelowFilter Members | Aveva.PDMS.Database.Filters Namespace


HideBelowFilter Members

HideBelowFilter overview

Public Instance Constructors

HideBelowFilter Overloaded. Initializes a new instance of the HideBelowFilter class.

Public Instance Properties

types (inherited from TypeFilter) Remove element types from list for filter

Public Instance Methods

Add (inherited from TypeFilter) | Overloaded. Additional element type to filter on
Clone (inherited from TypeFilter) | method to Copy filter
Equals (inherited from TypeFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from TypeFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove (inherited from TypeFilter) | Remove element type from list for filter
ScanBelow | Method to test whether we need to scan below given element. Returns false if Valid() is false.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

HideBelowFilter Class | Aveva.PDMS.Database.Filters Namespace


HideBelowFilter Constructor

Constructor taking a single element to hide below.

Overload List

Default Constructor

public HideBelowFilter();

Constructor taking a single element to hide below.

public HideBelowFilter(DbElementType);

Constructor taking a list of elements to hide below.

public HideBelowFilter(DbElementType[]);

See Also

HideBelowFilter Class | Aveva.PDMS.Database.Filters Namespace


HideBelowFilter Constructor (DbElementType)

Constructor taking a single element to hide below.

public HideBelowFilter(
DbElementType type
);

Parameters

type

See Also

HideBelowFilter Class | Aveva.PDMS.Database.Filters Namespace | HideBelowFilter Constructor Overload List


HideBelowFilter Constructor (DbElementType[])

Constructor taking a list of elements to hide below.

public HideBelowFilter(
DbElementType[] types
);

Parameters

types

See Also

HideBelowFilter Class | Aveva.PDMS.Database.Filters Namespace | HideBelowFilter Constructor Overload List


HideBelowFilter Constructor ()

Default Constructor

public HideBelowFilter();

See Also

HideBelowFilter Class | Aveva.PDMS.Database.Filters Namespace | HideBelowFilter Constructor Overload List


HideBelowFilter Methods

The methods of the HideBelowFilter class are listed below. For a complete list of HideBelowFilter class members, see the HideBelowFilter Members topic.

Public Instance Methods

Add (inherited from TypeFilter) | Overloaded. Additional element type to filter on
Clone (inherited from TypeFilter) | method to Copy filter
Equals (inherited from TypeFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from TypeFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove (inherited from TypeFilter) | Remove element type from list for filter
ScanBelow | Method to test whether we need to scan below given element. Returns false if Valid() is false.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

HideBelowFilter Class | Aveva.PDMS.Database.Filters Namespace


HideBelowFilter.ScanBelow Method

Method to test whether we need to scan below given element. Returns false if Valid() is false.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

HideBelowFilter Class | Aveva.PDMS.Database.Filters Namespace


HideBelowFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

HideBelowFilter Class | Aveva.PDMS.Database.Filters Namespace


HideFilter Class

Filter to hide elements of given type. i.e. returns true if not an element to hide. Used by the explorer. If an element is hidden, its descendents will also be hidden.

For a list of all members of this type, see HideFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.TypeFilter
Aveva.PDMS.Database.Filters.HideFilter

public class HideFilter : TypeFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

HideFilter Members | Aveva.PDMS.Database.Filters Namespace


HideFilter Members

HideFilter overview

Public Instance Constructors

HideFilter Overloaded. Initializes a new instance of the HideFilter class.

Public Instance Properties

types (inherited from TypeFilter) Remove element types from list for filter

Public Instance Methods

Add (inherited from TypeFilter) | Overloaded. Additional element type to filter on
Clone (inherited from TypeFilter) | method to Copy filter
Equals (inherited from TypeFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from TypeFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove (inherited from TypeFilter) | Remove element type from list for filter
ScanBelow | Method to test whether we need to scan below given element. Result is as for Valid().
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

HideFilter Class | Aveva.PDMS.Database.Filters Namespace


HideFilter Constructor

Constructor taking a type to hide

Overload List

Default Constructor

public HideFilter();

Constructor taking a type to hide

public HideFilter(DbElementType);

Constructor taking a list of types to hide

public HideFilter(DbElementType[]);

See Also

HideFilter Class | Aveva.PDMS.Database.Filters Namespace


HideFilter Constructor (DbElementType)

Constructor taking a type to hide

public HideFilter(
DbElementType type
);

Parameters

type

See Also

HideFilter Class | Aveva.PDMS.Database.Filters Namespace | HideFilter Constructor Overload List


HideFilter Constructor (DbElementType[])

Constructor taking a list of types to hide

public HideFilter(
DbElementType[] types
);

Parameters

types

See Also

HideFilter Class | Aveva.PDMS.Database.Filters Namespace | HideFilter Constructor Overload List


HideFilter Constructor ()

Default Constructor

public HideFilter();

See Also

HideFilter Class | Aveva.PDMS.Database.Filters Namespace | HideFilter Constructor Overload List


HideFilter Methods

The methods of the HideFilter class are listed below. For a complete list of HideFilter class members, see the HideFilter Members topic.

Public Instance Methods

Add (inherited from TypeFilter) | Overloaded. Additional element type to filter on
Clone (inherited from TypeFilter) | method to Copy filter
Equals (inherited from TypeFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from TypeFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove (inherited from TypeFilter) | Remove element type from list for filter
ScanBelow | Method to test whether we need to scan below given element. Result is as for Valid().
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

HideFilter Class | Aveva.PDMS.Database.Filters Namespace


HideFilter.ScanBelow Method

Method to test whether we need to scan below given element. Result is as for Valid().

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

HideFilter Class | Aveva.PDMS.Database.Filters Namespace


HideFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

HideFilter Class | Aveva.PDMS.Database.Filters Namespace


InvisibleFilter Class

Filter for determining visibility in explorer.

For a list of all members of this type, see InvisibleFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.InvisibleFilter

public class InvisibleFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

InvisibleFilter Members | Aveva.PDMS.Database.Filters Namespace


InvisibleFilter Members

InvisibleFilter overview

Public Instance Constructors

InvisibleFilter Constructor Initializes a new instance of the InvisibleFilter class.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. always returns true.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | True if element is visible in explorer.

See Also

InvisibleFilter Class | Aveva.PDMS.Database.Filters Namespace


InvisibleFilter Constructor

Initializes a new instance of the InvisibleFilter class.

public InvisibleFilter();

See Also

InvisibleFilter Class | Aveva.PDMS.Database.Filters Namespace


InvisibleFilter Methods

The methods of the InvisibleFilter class are listed below. For a complete list of InvisibleFilter class members, see the InvisibleFilter Members topic.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. always returns true.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | True if element is visible in explorer.

See Also

InvisibleFilter Class | Aveva.PDMS.Database.Filters Namespace


InvisibleFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

InvisibleFilter Class | Aveva.PDMS.Database.Filters Namespace


InvisibleFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

InvisibleFilter Class | Aveva.PDMS.Database.Filters Namespace


InvisibleFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

InvisibleFilter Class | Aveva.PDMS.Database.Filters Namespace


InvisibleFilter.ScanBelow Method

Method to test whether we need to scan below given element. always returns true.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

InvisibleFilter Class | Aveva.PDMS.Database.Filters Namespace


InvisibleFilter.Valid Method

True if element is visible in explorer.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

InvisibleFilter Class | Aveva.PDMS.Database.Filters Namespace


OrFilter Class

Class to 'OR' together two or more existing filters.

For a list of all members of this type, see OrFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.OrFilter

public class OrFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

OrFilter Members | Aveva.PDMS.Database.Filters Namespace


OrFilter Members

OrFilter overview

Public Instance Constructors

OrFilter Overloaded. Initializes a new instance of the OrFilter class.

Public Instance Properties

filters | Return list of filters in OR list
First | 1st filter to OR
Second | 2nd filter to OR

Public Instance Methods

Add | Add filter to list of ORs
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove | Remove filter to list of ORs
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace


OrFilter Constructor

Default constructor

Overload List

Default constructor

public OrFilter();

constructor taking two existing filters

public OrFilter(BaseFilter,BaseFilter);

constructor taking a list of filters

public OrFilter(BaseFilter[]);

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace


OrFilter Constructor ()

Default constructor

public OrFilter();

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace | OrFilter Constructor Overload List


OrFilter Constructor (BaseFilter, BaseFilter)

constructor taking two existing filters

public OrFilter(
BaseFilter filt1,
BaseFilter filt2
);

Parameters

filt1
filt2

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace | OrFilter Constructor Overload List


OrFilter Constructor (BaseFilter[])

constructor taking a list of filters

public OrFilter(
BaseFilter[] filts
);

Parameters

filts

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace | OrFilter Constructor Overload List


OrFilter Properties

The properties of the OrFilter class are listed below. For a complete list of OrFilter class members, see the OrFilter Members topic.

Public Instance Properties

filters | Return list of filters in OR list
First | 1st filter to OR
Second | 2nd filter to OR

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace


filters Property

AVEVA Database Filters .NET Public Interface

OrFilter.filters Property

Return list of filters in OR list

public BaseFilter[] filters {get;}

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace


First Property

AVEVA Database Filters .NET Public Interface

OrFilter.First Property

1st filter to OR

public BaseFilter First {get; set;}

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace


Second Property

AVEVA Database Filters .NET Public Interface

OrFilter.Second Property

2nd filter to OR

public BaseFilter Second {get; set;}

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace


OrFilter Methods

The methods of the OrFilter class are listed below. For a complete list of OrFilter class members, see the OrFilter Members topic.

Public Instance Methods

Add | Add filter to list of ORs
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove | Remove filter to list of ORs
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace


OrFilter.Add Method

Add filter to list of ORs

public void Add(
BaseFilter filt
);

Parameters

filt

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace


OrFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace


OrFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace


OrFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace


OrFilter.Remove Method

Remove filter to list of ORs

public void Remove(
BaseFilter filt
);

Parameters

filt

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace


OrFilter.ScanBelow Method

Method to test whether we need to scan below given element. Optimised for this class.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace


OrFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

OrFilter Class | Aveva.PDMS.Database.Filters Namespace


PipingFilter Class

Specific Filter to be used by the explorer for elements relevant to a piping Engineer.

For a list of all members of this type, see PipingFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.CompoundFilter
Aveva.PDMS.Database.Filters.PipingFilter

public class PipingFilter : CompoundFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

PipingFilter Members | Aveva.PDMS.Database.Filters Namespace


PipingFilter Members

PipingFilter overview

Public Instance Constructors

PipingFilter Constructor Default constructor

Public Instance Properties

Hides (inherited from CompoundFilter) | Add a 'hide' filters
Shows (inherited from CompoundFilter) | list of 'show' filters.
Skips (inherited from CompoundFilter) | 'skip' filters

Public Instance Methods

AddHide (inherited from CompoundFilter) | Add a 'hide' filter to list
AddShow (inherited from CompoundFilter) | Add additional 'show' filter.
AddSkip (inherited from CompoundFilter) | Add additional 'skip' filter.
Clone (inherited from CompoundFilter) | method to Copy filter
Equals (inherited from CompoundFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from CompoundFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
RemoveHide (inherited from CompoundFilter) | Remove 'hide' filter from list
RemoveShow (inherited from CompoundFilter) | Remove given 'show' filter.
RemoveSkip (inherited from CompoundFilter) | remove 'skip' filter from list.
ScanBelow (inherited from CompoundFilter) | Method to test whether we need to scan below given element. Optimised for this class.
TestSkip (inherited from CompoundFilter) | Test 'skip' filters only
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid (inherited from CompoundFilter) | method to return whether filter is true or false for a given element.

See Also

PipingFilter Class | Aveva.PDMS.Database.Filters Namespace


PipingFilter Constructor

Default constructor

public PipingFilter();

See Also

PipingFilter Class | Aveva.PDMS.Database.Filters Namespace


SchematicElectricalFilter Class

Specific Filter to be used by the explorer for doing electricals.

For a list of all members of this type, see SchematicElectricalFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.CompoundFilter
Aveva.PDMS.Database.Filters.SchematicElectricalFilter

public class SchematicElectricalFilter : CompoundFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

SchematicElectricalFilter Members | Aveva.PDMS.Database.Filters Namespace


SchematicElectricalFilter Members

SchematicElectricalFilter overview

Public Instance Constructors

SchematicElectricalFilter Constructor Default constructor

Public Instance Properties

Hides (inherited from CompoundFilter) | Add a 'hide' filters
Shows (inherited from CompoundFilter) | list of 'show' filters.
Skips (inherited from CompoundFilter) | 'skip' filters

Public Instance Methods

AddHide (inherited from CompoundFilter) | Add a 'hide' filter to list
AddShow (inherited from CompoundFilter) | Add additional 'show' filter.
AddSkip (inherited from CompoundFilter) | Add additional 'skip' filter.
Clone (inherited from CompoundFilter) | method to Copy filter
Equals (inherited from CompoundFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from CompoundFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
RemoveHide (inherited from CompoundFilter) | Remove 'hide' filter from list
RemoveShow (inherited from CompoundFilter) | Remove given 'show' filter.
RemoveSkip (inherited from CompoundFilter) | remove 'skip' filter from list.
ScanBelow (inherited from CompoundFilter) | Method to test whether we need to scan below given element. Optimised for this class.
TestSkip (inherited from CompoundFilter) | Test 'skip' filters only
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid (inherited from CompoundFilter) | method to return whether filter is true or false for a given element.

See Also

SchematicElectricalFilter Class | Aveva.PDMS.Database.Filters Namespace


SchematicElectricalFilter Constructor

Default constructor

public SchematicElectricalFilter();

See Also

SchematicElectricalFilter Class | Aveva.PDMS.Database.Filters Namespace


SchematicHVACFilter Class

Specific Filter to be used by the explorer for doing schematic hvac.

For a list of all members of this type, see SchematicHVACFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.CompoundFilter
Aveva.PDMS.Database.Filters.SchematicHVACFilter

public class SchematicHVACFilter : CompoundFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

SchematicHVACFilter Members | Aveva.PDMS.Database.Filters Namespace


SchematicHVACFilter Members

SchematicHVACFilter overview

Public Instance Constructors

SchematicHVACFilter Constructor Default constructor

Public Instance Properties

Hides (inherited from CompoundFilter) | Add a 'hide' filters
Shows (inherited from CompoundFilter) | list of 'show' filters.
Skips (inherited from CompoundFilter) | 'skip' filters

Public Instance Methods

AddHide (inherited from CompoundFilter) | Add a 'hide' filter to list
AddShow (inherited from CompoundFilter) | Add additional 'show' filter.
AddSkip (inherited from CompoundFilter) | Add additional 'skip' filter.
Clone (inherited from CompoundFilter) | method to Copy filter
Equals (inherited from CompoundFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from CompoundFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
RemoveHide (inherited from CompoundFilter) | Remove 'hide' filter from list
RemoveShow (inherited from CompoundFilter) | Remove given 'show' filter.
RemoveSkip (inherited from CompoundFilter) | remove 'skip' filter from list.
ScanBelow (inherited from CompoundFilter) | Method to test whether we need to scan below given element. Optimised for this class.
TestSkip (inherited from CompoundFilter) | Test 'skip' filters only
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid (inherited from CompoundFilter) | method to return whether filter is true or false for a given element.

See Also

SchematicHVACFilter Class | Aveva.PDMS.Database.Filters Namespace


SchematicHVACFilter Constructor

Default constructor

public SchematicHVACFilter();

See Also

SchematicHVACFilter Class | Aveva.PDMS.Database.Filters Namespace


SchematicPipingFilter Class

Specific Filter to be used by the explorer for doing schematic pipes.

For a list of all members of this type, see SchematicPipingFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.CompoundFilter
Aveva.PDMS.Database.Filters.SchematicPipingFilter

public class SchematicPipingFilter : CompoundFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

SchematicPipingFilter Members | Aveva.PDMS.Database.Filters Namespace


SchematicPipingFilter Members

SchematicPipingFilter overview

Public Instance Constructors

SchematicPipingFilter Constructor Default constructor

Public Instance Properties

Hides (inherited from CompoundFilter) | Add a 'hide' filters
Shows (inherited from CompoundFilter) | list of 'show' filters.
Skips (inherited from CompoundFilter) | 'skip' filters

Public Instance Methods

AddHide (inherited from CompoundFilter) | Add a 'hide' filter to list
AddShow (inherited from CompoundFilter) | Add additional 'show' filter.
AddSkip (inherited from CompoundFilter) | Add additional 'skip' filter.
Clone (inherited from CompoundFilter) | method to Copy filter
Equals (inherited from CompoundFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from CompoundFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
RemoveHide (inherited from CompoundFilter) | Remove 'hide' filter from list
RemoveShow (inherited from CompoundFilter) | Remove given 'show' filter.
RemoveSkip (inherited from CompoundFilter) | remove 'skip' filter from list.
ScanBelow (inherited from CompoundFilter) | Method to test whether we need to scan below given element. Optimised for this class.
TestSkip (inherited from CompoundFilter) | Test 'skip' filters only
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid (inherited from CompoundFilter) | method to return whether filter is true or false for a given element.

See Also

SchematicPipingFilter Class | Aveva.PDMS.Database.Filters Namespace


SchematicPipingFilter Constructor

Default constructor

public SchematicPipingFilter();

See Also

SchematicPipingFilter Class | Aveva.PDMS.Database.Filters Namespace


ShowDescendants Class

Filter to show elements of given type plus ascendants and descendants. Class is used by the Explorer.

For a list of all members of this type, see ShowDescendants Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.ShowDescendants

public class ShowDescendants : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

ShowDescendants Members | Aveva.PDMS.Database.Filters Namespace


ShowDescendants Members

ShowDescendants overview

Public Instance Constructors

ShowDescendants Overloaded. Initializes a new instance of the ShowDescendants class.

Public Instance Properties

types Return list of types to show

Public Instance Methods

Add | Overloaded. Add extra type to show
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove | Remove type fom list to show
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace


ShowDescendants Constructor

Constructor taking type to show

Overload List

Default constructor

public ShowDescendants();

Constructor taking type to show

public ShowDescendants(DbElementType);

Construct filter with list of types to show

public ShowDescendants(DbElementType[]);

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace


ShowDescendants Constructor (DbElementType)

Constructor taking type to show

public ShowDescendants(
DbElementType type
);

Parameters

type

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace | ShowDescendants Constructor Overload List


ShowDescendants Constructor (DbElementType[])

Construct filter with list of types to show

public ShowDescendants(
DbElementType[] types
);

Parameters

types

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace | ShowDescendants Constructor Overload List


ShowDescendants Constructor ()

Default constructor

public ShowDescendants();

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace | ShowDescendants Constructor Overload List


ShowDescendants Properties

The properties of the ShowDescendants class are listed below. For a complete list of ShowDescendants class members, see the ShowDescendants Members topic.

Public Instance Properties

types Return list of types to show

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace


types Property

AVEVA Database Filters .NET Public Interface

ShowDescendants.types Property

Return list of types to show

public Aveva.Pdms.Database.DbElementType[] types {get;}

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace


ShowDescendants Methods

The methods of the ShowDescendants class are listed below. For a complete list of ShowDescendants class members, see the ShowDescendants Members topic.

Public Instance Methods

Add | Overloaded. Add extra type to show
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove | Remove type fom list to show
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace


Add Method

AVEVA Database Filters .NET Public Interface

ShowDescendants.Add Method

Add extra type to show

Overload List

Add extra type to show

public void Add(DbElementType);

Add list of types to show

public void Add(DbElementType[]);

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace


ShowDescendants.Add Method (DbElementType)

Add extra type to show

public void Add(
DbElementType type
);

Parameters

type

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace | ShowDescendants.Add Overload List


ShowDescendants.Add Method (DbElementType[])

Add list of types to show

public void Add(
DbElementType[] types
);

Parameters

types

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace | ShowDescendants.Add Overload List


ShowDescendants.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace


ShowDescendants.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace


ShowDescendants.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace


ShowDescendants.Remove Method

Remove type fom list to show

public void Remove(
DbElementType type
);

Parameters

type

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace


ShowDescendants.ScanBelow Method

Method to test whether we need to scan below given element. Optimised for this class.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace


ShowDescendants.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

ShowDescendants Class | Aveva.PDMS.Database.Filters Namespace


ShowFilter Class

Filter to show elements of given type plus ancestors. When testing ancestors, the filter checks that valid descendants. actually exist rather than possibly exist. Class is used by the explorer.

For a list of all members of this type, see ShowFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.ShowFilter

public class ShowFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

ShowFilter Members | Aveva.PDMS.Database.Filters Namespace


ShowFilter Members

ShowFilter overview

Public Instance Constructors

ShowFilter Overloaded. Initializes a new instance of the ShowFilter class.

Public Instance Properties

types Return list of types to show

Public Instance Methods

Add | Overloaded. Add extra type to show
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove | Remove type fom list to show
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace


ShowFilter Constructor

Construct filter with single element type to show

Overload List

Default constructor

public ShowFilter();

Construct filter with single element type to show

public ShowFilter(DbElementType);

Construct filter with list of types to show

public ShowFilter(DbElementType[]);

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace


ShowFilter Constructor (DbElementType)

Construct filter with single element type to show

public ShowFilter(
DbElementType type
);

Parameters

type

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace | ShowFilter Constructor Overload List


ShowFilter Constructor (DbElementType[])

Construct filter with list of types to show

public ShowFilter(
DbElementType[] types
);

Parameters

types

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace | ShowFilter Constructor Overload List


ShowFilter Constructor ()

Default constructor

public ShowFilter();

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace | ShowFilter Constructor Overload List


ShowFilter Properties

The properties of the ShowFilter class are listed below. For a complete list of ShowFilter class members, see the ShowFilter Members topic.

Public Instance Properties

types Return list of types to show

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace


types Property

AVEVA Database Filters .NET Public Interface

ShowFilter.types Property

Return list of types to show

public Aveva.Pdms.Database.DbElementType[] types {get;}

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace


ShowFilter Methods

The methods of the ShowFilter class are listed below. For a complete list of ShowFilter class members, see the ShowFilter Members topic.

Public Instance Methods

Add | Overloaded. Add extra type to show
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove | Remove type fom list to show
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace


Add Method

AVEVA Database Filters .NET Public Interface

ShowFilter.Add Method

Add extra type to show

Overload List

Add extra type to show

public void Add(DbElementType);

Add list of types to show

public void Add(DbElementType[]);

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace


ShowFilter.Add Method (DbElementType)

Add extra type to show

public void Add(
DbElementType type
);

Parameters

type

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace | ShowFilter.Add Overload List


ShowFilter.Add Method (DbElementType[])

Add list of types to show

public void Add(
DbElementType[] types
);

Parameters

types

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace | ShowFilter.Add Overload List


ShowFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace


ShowFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace


ShowFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace


ShowFilter.Remove Method

Remove type fom list to show

public void Remove(
DbElementType type
);

Parameters

type

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace


ShowFilter.ScanBelow Method

Method to test whether we need to scan below given element. Optimised for this class.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace


ShowFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

ShowFilter Class | Aveva.PDMS.Database.Filters Namespace


SkipFilter Class

Filter to skip elements of given type. i.e. returns true if not an element to skip. Class is used by the explorer to flatten the tree view. If an element is skipped, its descendents will NOT be skipped.

For a list of all members of this type, see SkipFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.TypeFilter
Aveva.PDMS.Database.Filters.SkipFilter

public class SkipFilter : TypeFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

SkipFilter Members | Aveva.PDMS.Database.Filters Namespace


SkipFilter Members

SkipFilter overview

Public Instance Constructors

SkipFilter Overloaded. Initializes a new instance of the SkipFilter class.

Public Instance Properties

types (inherited from TypeFilter) Remove element types from list for filter

Public Instance Methods

Add (inherited from TypeFilter) | Overloaded. Additional element type to filter on
Clone (inherited from TypeFilter) | method to Copy filter
Equals (inherited from TypeFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from TypeFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove (inherited from TypeFilter) | Remove element type from list for filter
ScanBelow | Method to test whether we need to scan below given element. Always true for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

SkipFilter Class | Aveva.PDMS.Database.Filters Namespace


SkipFilter Constructor

Constructor taking an element type to skip over

Overload List

Default constructor

public SkipFilter();

Constructor taking an element type to skip over

public SkipFilter(DbElementType);

Constructor taking a list of element types to skip over

public SkipFilter(DbElementType[]);

See Also

SkipFilter Class | Aveva.PDMS.Database.Filters Namespace


SkipFilter Constructor (DbElementType)

Constructor taking an element type to skip over

public SkipFilter(
DbElementType type
);

Parameters

type
element type

See Also

SkipFilter Class | Aveva.PDMS.Database.Filters Namespace | SkipFilter Constructor Overload List


SkipFilter Constructor (DbElementType[])

Constructor taking a list of element types to skip over

public SkipFilter(
DbElementType[] types
);

Parameters

types
list of types

See Also

SkipFilter Class | Aveva.PDMS.Database.Filters Namespace | SkipFilter Constructor Overload List


SkipFilter Constructor ()

Default constructor

public SkipFilter();

See Also

SkipFilter Class | Aveva.PDMS.Database.Filters Namespace | SkipFilter Constructor Overload List


SkipFilter Methods

The methods of the SkipFilter class are listed below. For a complete list of SkipFilter class members, see the SkipFilter Members topic.

Public Instance Methods

Add (inherited from TypeFilter) | Overloaded. Additional element type to filter on
Clone (inherited from TypeFilter) | method to Copy filter
Equals (inherited from TypeFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from TypeFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove (inherited from TypeFilter) | Remove element type from list for filter
ScanBelow | Method to test whether we need to scan below given element. Always true for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | method to return whether filter is true or false for a given element.

See Also

SkipFilter Class | Aveva.PDMS.Database.Filters Namespace


SkipFilter.ScanBelow Method

Method to test whether we need to scan below given element. Always true for this class.

public override bool ScanBelow(
DbElement element
);

Parameters

element
current element

Return Value

whether to scan below or not

See Also

SkipFilter Class | Aveva.PDMS.Database.Filters Namespace


SkipFilter.Valid Method

method to return whether filter is true or false for a given element.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

SkipFilter Class | Aveva.PDMS.Database.Filters Namespace


StructuralFilter Class

Specific Filter to be used by the explorer for elements relevant to a structural Engineer.

For a list of all members of this type, see StructuralFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.CompoundFilter
Aveva.PDMS.Database.Filters.StructuralFilter

public class StructuralFilter : CompoundFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

StructuralFilter Members | Aveva.PDMS.Database.Filters Namespace


StructuralFilter Members

StructuralFilter overview

Public Instance Constructors

StructuralFilter Constructor Default constructor

Public Instance Properties

Hides (inherited from CompoundFilter) | Add a 'hide' filters
Shows (inherited from CompoundFilter) | list of 'show' filters.
Skips (inherited from CompoundFilter) | 'skip' filters

Public Instance Methods

AddHide (inherited from CompoundFilter) | Add a 'hide' filter to list
AddShow (inherited from CompoundFilter) | Add additional 'show' filter.
AddSkip (inherited from CompoundFilter) | Add additional 'skip' filter.
Clone (inherited from CompoundFilter) | method to Copy filter
Equals (inherited from CompoundFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from CompoundFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
RemoveHide (inherited from CompoundFilter) | Remove 'hide' filter from list
RemoveShow (inherited from CompoundFilter) | Remove given 'show' filter.
RemoveSkip (inherited from CompoundFilter) | remove 'skip' filter from list.
ScanBelow (inherited from CompoundFilter) | Method to test whether we need to scan below given element. Optimised for this class.
TestSkip (inherited from CompoundFilter) | Test 'skip' filters only
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid (inherited from CompoundFilter) | method to return whether filter is true or false for a given element.

See Also

StructuralFilter Class | Aveva.PDMS.Database.Filters Namespace


StructuralFilter Constructor

Default constructor

public StructuralFilter();

See Also

StructuralFilter Class | Aveva.PDMS.Database.Filters Namespace


SystemFilter Class

Specific Filter to be used by the explorer on the system DB.

For a list of all members of this type, see SystemFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.CompoundFilter
Aveva.PDMS.Database.Filters.SystemFilter

public class SystemFilter : CompoundFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

SystemFilter Members | Aveva.PDMS.Database.Filters Namespace


SystemFilter Members

SystemFilter overview

Public Instance Constructors

SystemFilter Constructor Default constructor

Public Instance Properties

Hides (inherited from CompoundFilter) | Add a 'hide' filters
Shows (inherited from CompoundFilter) | list of 'show' filters.
Skips (inherited from CompoundFilter) | 'skip' filters

Public Instance Methods

AddHide (inherited from CompoundFilter) | Add a 'hide' filter to list
AddShow (inherited from CompoundFilter) | Add additional 'show' filter.
AddSkip (inherited from CompoundFilter) | Add additional 'skip' filter.
Clone (inherited from CompoundFilter) | method to Copy filter
Equals (inherited from CompoundFilter) | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode (inherited from CompoundFilter) | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
RemoveHide (inherited from CompoundFilter) | Remove 'hide' filter from list
RemoveShow (inherited from CompoundFilter) | Remove given 'show' filter.
RemoveSkip (inherited from CompoundFilter) | remove 'skip' filter from list.
ScanBelow (inherited from CompoundFilter) | Method to test whether we need to scan below given element. Optimised for this class.
TestSkip (inherited from CompoundFilter) | Test 'skip' filters only
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid (inherited from CompoundFilter) | method to return whether filter is true or false for a given element.

See Also

SystemFilter Class | Aveva.PDMS.Database.Filters Namespace


SystemFilter Constructor

Default constructor

public SystemFilter();

See Also

SystemFilter Class | Aveva.PDMS.Database.Filters Namespace


TestOperator Enumeration

public enum TestOperator

Members

Member Name | Description
None |
Equals |
NotEquals |
GreaterOrEquals |
GreaterThan |
LessOrEquals |
LessThan |

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

Aveva.PDMS.Database.Filters Namespace


TrueFilter Class

Filter that always returns true.

For a list of all members of this type, see TrueFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.TrueFilter

public class TrueFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

TrueFilter Members | Aveva.PDMS.Database.Filters Namespace


TrueFilter Members

TrueFilter overview

Public Instance Constructors

TrueFilter Constructor Initializes a new instance of the TrueFilter class.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | always returns 1
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always true for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | Method to test whether we need to scan below given element. Always true for this class.

See Also

TrueFilter Class | Aveva.PDMS.Database.Filters Namespace


TrueFilter Constructor

Initializes a new instance of the TrueFilter class.

public TrueFilter();

See Also

TrueFilter Class | Aveva.PDMS.Database.Filters Namespace


TrueFilter Methods

The methods of the TrueFilter class are listed below. For a complete list of TrueFilter class members, see the TrueFilter Members topic.

Public Instance Methods

Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | always returns 1
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
ScanBelow | Method to test whether we need to scan below given element. Always true for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | Method to test whether we need to scan below given element. Always true for this class.

See Also

TrueFilter Class | Aveva.PDMS.Database.Filters Namespace


TrueFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

TrueFilter Class | Aveva.PDMS.Database.Filters Namespace


TrueFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

TrueFilter Class | Aveva.PDMS.Database.Filters Namespace


TrueFilter.GetHashCode Method

always returns 1

public override int GetHashCode();

Return Value

See Also

TrueFilter Class | Aveva.PDMS.Database.Filters Namespace


TrueFilter.ScanBelow Method

Method to test whether we need to scan below given element. Always true for this class.

public override bool ScanBelow(
DbElement element
);

Parameters

element
current element

Return Value

whether to scan below or not

See Also

TrueFilter Class | Aveva.PDMS.Database.Filters Namespace


TrueFilter.Valid Method

Method to test whether we need to scan below given element. Always true for this class.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

TrueFilter Class | Aveva.PDMS.Database.Filters Namespace


TypeFilter Class

Tests whether an element is of a given type. The class makes ensures that only valid parts of the database are returned in the ScanBelow() method. This is important for performance.

For a list of all members of this type, see TypeFilter Members.

System.Object
Aveva.PDMS.Database.Filters.BaseFilter
Aveva.PDMS.Database.Filters.TypeFilter
Aveva.PDMS.Database.Filters.HideBelowFilter
Aveva.PDMS.Database.Filters.HideFilter
Aveva.PDMS.Database.Filters.SkipFilter

public class TypeFilter : BaseFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.PDMS.Database.Filters

Assembly: PDMSFilters (in PDMSFilters.dll)

See Also

TypeFilter Members | Aveva.PDMS.Database.Filters Namespace


TypeFilter Members

TypeFilter overview

Public Instance Constructors

TypeFilter Overloaded. Initializes a new instance of the TypeFilter class.

Public Instance Properties

types Remove element types from list for filter

Public Instance Methods

Add | Overloaded. Additional element type to filter on
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove | Remove element type from list for filter
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | returns true if elements matches valid types.

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace


TypeFilter Constructor

Basic constructor

Overload List

Basic constructor

public TypeFilter();

Constructor taking single element type

public TypeFilter(DbElementType);

Constructor taking a list of element types

public TypeFilter(DbElementType[]);

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace


TypeFilter Constructor ()

Basic constructor

public TypeFilter();

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace | TypeFilter Constructor Overload List


TypeFilter Constructor (DbElementType)

Constructor taking single element type

public TypeFilter(
DbElementType type
);

Parameters

type
element type to filter on

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace | TypeFilter Constructor Overload List


TypeFilter Constructor (DbElementType[])

Constructor taking a list of element types

public TypeFilter(
DbElementType[] types
);

Parameters

types
element types to filter on

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace | TypeFilter Constructor Overload List


TypeFilter Properties

The properties of the TypeFilter class are listed below. For a complete list of TypeFilter class members, see the TypeFilter Members topic.

Public Instance Properties

types Remove element types from list for filter

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace


types Property

AVEVA Database Filters .NET Public Interface

TypeFilter.types Property

Remove element types from list for filter

public Aveva.Pdms.Database.DbElementType[] types {get;}

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace


TypeFilter Methods

The methods of the TypeFilter class are listed below. For a complete list of TypeFilter class members, see the TypeFilter Members topic.

Public Instance Methods

Add | Overloaded. Additional element type to filter on
Clone | method to Copy filter
Equals | Equal or not
FirstMember (inherited from BaseFilter) | Get first member for which filter is true.
GetHashCode | Return hash value
GetType (inherited from Object) | Gets the Type of the current instance.
Members (inherited from BaseFilter) | Return all members for which filter is true.
Next (inherited from BaseFilter) | Get next element in current list for which filter is true.
Parent (inherited from BaseFilter) | Climb up to element for which filter is true
Remove | Remove element type from list for filter
ScanBelow | Method to test whether we need to scan below given element. Optimised for this class.
ToString (inherited from Object) | Returns a String that represents the current Object.
Valid | returns true if elements matches valid types.

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace


Add Method

AVEVA Database Filters .NET Public Interface

TypeFilter.Add Method

Additional element type to filter on

Overload List

Additional element type to filter on

public void Add(DbElementType);

Additional element types to filter on

public void Add(DbElementType[]);

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace


TypeFilter.Add Method (DbElementType)

Additional element type to filter on

public void Add(
DbElementType actualType
);

Parameters

actualType

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace | TypeFilter.Add Overload List


TypeFilter.Add Method (DbElementType[])

Additional element types to filter on

public void Add(
DbElementType[] types
);

Parameters

types
list of types

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace | TypeFilter.Add Overload List


TypeFilter.Clone Method

method to Copy filter

public override object Clone();

Return Value

copy of filter

Implements

ICloneable.Clone

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace


TypeFilter.Equals Method

Equal or not

public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace


TypeFilter.GetHashCode Method

Return hash value

public override int GetHashCode();

Return Value

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace


TypeFilter.Remove Method

Remove element type from list for filter

public void Remove(
DbElementType type
);

Parameters

type
Element type

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace


TypeFilter.ScanBelow Method

Method to test whether we need to scan below given element. Optimised for this class.

public override bool ScanBelow(
DbElement ele
);

Parameters

ele
current element

Return Value

whether to scan below or not

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace


TypeFilter.Valid Method

returns true if elements matches valid types.

public override bool Valid(
DbElement ele
);

Parameters

ele
element to evaluate filter against

Return Value

result of avaluating filter

See Also

TypeFilter Class | Aveva.PDMS.Database.Filters Namespace


BaseFilter Hierarchy

System.Object
BaseFilter
AndFilter
AssemblyPlanningFilter
AttributeCompoundFilter
AttributeFalseFilter
AttributeRefFilter
AttributeTrueFilter
BaseAttributeFilter
BelowFilter
BelowOrAtFilter
BelowOrAtType
BelowType
CompoundFilter
DBTypeFilter
FalseFilter
FieldIntFilter
FieldTrueFilter
InvisibleFilter
OrFilter
ShowDescendants
ShowFilter
TrueFilter
TypeFilter

See Also

BaseFilter Class | BaseFilter Members | Aveva.PDMS.Database.Filters Namespace


CompoundFilter Hierarchy

System.Object
BaseFilter
CompoundFilter
DraftAdminFilter
DraftFilter
EquipmentFilter
HangerFilter
PipingFilter
SchematicElectricalFilter
SchematicHVACFilter
SchematicPipingFilter
StructuralFilter
SystemFilter

See Also

CompoundFilter Class | CompoundFilter Members | Aveva.PDMS.Database.Filters Namespace


Aveva.PDMS.Database.FiltersHierarchy

AVEVA Database Filters .NET Public Interface

Aveva.PDMS.Database.Filters Hierarchy

System.Object
Aveva.PDMS.Database.Filters.BaseFilter ---- System.ICloneable
Aveva.PDMS.Database.Filters.AndFilter
Aveva.PDMS.Database.Filters.AssemblyPlanningFilter
Aveva.PDMS.Database.Filters.AttributeCompoundFilter
Aveva.PDMS.Database.Filters.AttributeFalseFilter
Aveva.PDMS.Database.Filters.AttributeRefFilter
Aveva.PDMS.Database.Filters.AttributeTrueFilter
Aveva.PDMS.Database.Filters.BaseAttributeFilter
Aveva.PDMS.Database.Filters.AttributeLikeFilter
Aveva.PDMS.Database.Filters.AttributeListFilter
Aveva.PDMS.Database.Filters.AttributeRangeFilter
Aveva.PDMS.Database.Filters.AttributeValueFilter
Aveva.PDMS.Database.Filters.BelowFilter
Aveva.PDMS.Database.Filters.BelowOrAtFilter
Aveva.PDMS.Database.Filters.BelowOrAtType
Aveva.PDMS.Database.Filters.BelowType
Aveva.PDMS.Database.Filters.CompoundFilter
Aveva.PDMS.Database.Filters.DraftAdminFilter
Aveva.PDMS.Database.Filters.DraftFilter
Aveva.PDMS.Database.Filters.EquipmentFilter
Aveva.PDMS.Database.Filters.HangerFilter
Aveva.PDMS.Database.Filters.PipingFilter
Aveva.PDMS.Database.Filters.SchematicElectricalFilter
Aveva.PDMS.Database.Filters.SchematicHVACFilter
Aveva.PDMS.Database.Filters.SchematicPipingFilter
Aveva.PDMS.Database.Filters.StructuralFilter
Aveva.PDMS.Database.Filters.SystemFilter
Aveva.PDMS.Database.Filters.DBTypeFilter
Aveva.PDMS.Database.Filters.FalseFilter
Aveva.PDMS.Database.Filters.FieldIntFilter
Aveva.PDMS.Database.Filters.FieldTrueFilter
Aveva.PDMS.Database.Filters.InvisibleFilter
Aveva.PDMS.Database.Filters.OrFilter
Aveva.PDMS.Database.Filters.ShowDescendants
Aveva.PDMS.Database.Filters.ShowFilter
Aveva.PDMS.Database.Filters.TrueFilter
Aveva.PDMS.Database.Filters.TypeFilter
Aveva.PDMS.Database.Filters.HideBelowFilter
Aveva.PDMS.Database.Filters.HideFilter
Aveva.PDMS.Database.Filters.SkipFilter
Aveva.PDMS.Database.Filters.DBElementCollection ---- System.Collections.IEnumerable
Aveva.PDMS.Database.Filters.DBElementEnumerator ---- System.Collections.IEnumerator
Aveva.PDMS.Database.Filters.ElementTreeNavigator
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aveva.PDMS.Database.Filters.BooleanOperator
Aveva.PDMS.Database.Filters.TestOperator

See Also

Aveva.PDMS.Database.Filters Namespace