Aveva.Pdms

AVEVA Application .NET Public Interface

Aveva.Pdms Namespace

Namespace hierarchy

Classes

Class | Description
PdmsApplication | Entry point for PDMS application framework
PdmsVersion | PDMS Version query.

Delegates

Delegate | Description
BeforeFinishEventHandler | BeforeFinish event handler delegate.
FinishEventHandler | Finish event handler delegate.

Enumerations

Enumeration | Description
ModuleType | PDMS Module type code.
©AVEVA Solutions Ltd 2007


BeforeFinishEventHandler Delegate

BeforeFinish event handler delegate.

public delegate void BeforeFinishEventHandler(
object sender,
EventArgs e
);

Requirements

Namespace: Aveva.Pdms

Assembly: Aveva.Pdms (in Aveva.Pdms.dll)

See Also

Aveva.Pdms Namespace


FinishEventHandler Delegate

Finish event handler delegate.

public delegate void FinishEventHandler(
object sender,
EventArgs e
);

Requirements

Namespace: Aveva.Pdms

Assembly: Aveva.Pdms (in Aveva.Pdms.dll)

See Also

Aveva.Pdms Namespace


ModuleType Enumeration

PDMS Module type code.

public enum ModuleType

Members

Member Name | Description
Dabacon |
Gml |
Gtx |
CommandProcessor |
Flayer |
Splash |
FlexLM |
PML |
NxLib |
FormsLib |
InteractionManager |
Druid |
Sgl |
AttributeDataFile |
Global |

Requirements

Namespace: Aveva.Pdms

Assembly: Aveva.Pdms (in Aveva.Pdms.dll)

See Also

Aveva.Pdms Namespace


PdmsApplication Class

Entry point for PDMS application framework

For a list of all members of this type, see PdmsApplication Members.

System.Object
Aveva.Pdms.PdmsApplication

public abstract class PdmsApplication

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms

Assembly: Aveva.Pdms (in Aveva.Pdms.dll)

See Also

PdmsApplication Members | Aveva.Pdms Namespace


PdmsApplication Members

PdmsApplication overview

Public Static Properties

GraphicsMode True if application is in graphics mode

Public Static Methods

Exit | Exit application.
Finish | Finish application.
getLicenseError | get license error
getLicenseFeature | get license feature
hasLicenseFeature | has license feature
RaiseBeforeFinished | Raise Finished event.
RaiseFinished | Raise Finished event.
Start | Start the application.
StartEventLoop | Start application activity.
StartViaCommsFile | Start the application using a Comms file.

Public Static Events

BeforeFinished | BeforeFinished event handler.
Finished | Finished event handler.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PdmsApplication Class | Aveva.Pdms Namespace


PdmsApplication Properties

The properties of the PdmsApplication class are listed below. For a complete list of PdmsApplication class members, see the PdmsApplication Members topic.

Public Static Properties

GraphicsMode True if application is in graphics mode

See Also


GraphicsMode Property

AVEVA Application .NET Public Interface

PdmsApplication.GraphicsMode Property

True if application is in graphics mode

public static bool GraphicsMode {get;}

See Also


PdmsApplication Methods

The methods of the PdmsApplication class are listed below. For a complete list of PdmsApplication class members, see the PdmsApplication Members topic.

Public Static Methods

Exit | Exit application.
Finish | Finish application.
getLicenseError | get license error
getLicenseFeature | get license feature
hasLicenseFeature | has license feature
RaiseBeforeFinished | Raise Finished event.
RaiseFinished | Raise Finished event.
Start | Start the application.
StartEventLoop | Start application activity.
StartViaCommsFile | Start the application using a Comms file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also


PdmsApplication.Exit Method

Exit application.

public static void Exit(
string message
);

Parameters

message
Exit message

See Also


PdmsApplication.Finish Method

Finish application.

public static void Finish();

See Also


PdmsApplication.getLicenseError Method

get license error

public static string getLicenseError();

Parameters

See Also


PdmsApplication.getLicenseFeature Method

get license feature

public static bool getLicenseFeature(
string feature
);

Parameters

feature

See Also


PdmsApplication.hasLicenseFeature Method

has license feature

public static bool hasLicenseFeature(
string feature
);

Parameters

feature

See Also


PdmsApplication.RaiseBeforeFinished Method

Raise Finished event.

public static void RaiseBeforeFinished(
object sender,
EventArgs e
);

Parameters

sender
Object raising the event
e
Event arguments

See Also


PdmsApplication.RaiseFinished Method

Raise Finished event.

public static void RaiseFinished(
object sender,
EventArgs e
);

Parameters

sender
Object raising the event
e
Event arguments

See Also


PdmsApplication.Start Method

Start the application.

public static void Start(
bool isGraphics,
int moduleNumber,
bool isBatch,
bool isNoConsole,
string logfile
);

Parameters

isGraphics
True if to be started in graphics mode
moduleNumber
isBatch
True is to be started in batch mode
isNoConsole
True if to be started with no console
logfile
Filename for application log file

See Also


PdmsApplication.StartEventLoop Method

Start application activity.

public static void StartEventLoop();

See Also


PdmsApplication.StartViaCommsFile Method

Start the application using a Comms file.

public static void StartViaCommsFile(
bool isGraphics,
int moduleNumber,
string moduleName
);

Parameters

isGraphics
True if to be started in graphics mode
moduleNumber
Module number
moduleName
Module name

See Also


PdmsApplication Events

The events of the PdmsApplication class are listed below. For a complete list of PdmsApplication class members, see the PdmsApplication Members topic.

Public Static Events

BeforeFinished | BeforeFinished event handler.
Finished | Finished event handler.

See Also


PdmsApplication.BeforeFinished Event

BeforeFinished event handler.

public static event BeforeFinishEventHandler BeforeFinished;

See Also


PdmsApplication.Finished Event

Finished event handler.

public static event FinishEventHandler Finished;

See Also


PdmsVersion Class

PDMS Version query.

For a list of all members of this type, see PdmsVersion Members.

System.Object
Aveva.Pdms.PdmsVersion

public abstract class PdmsVersion

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms

Assembly: Aveva.Pdms (in Aveva.Pdms.dll)

See Also

PdmsVersion Members | Aveva.Pdms Namespace


PdmsVersion Members

PdmsVersion overview

Public Static Methods

GetCompanyName | Retrieve company name PDMS is licensed to
GetCopyright | Retrieve copyright information for PDMS
GetModuleName | Retrieve the name of a PDMS module
GetModuleVersion | Retrieve the version of a PDMS module
GetName | Retrieve name of current module (i.e. VANTAGE PDMS Design)
GetShortBanner | Retrieve short banner string (i.e. qbann)
GetStatus | Retrieve any special status instructions (i.e. for pre-release builds)
GetVersion | Retrieve version number of PDMS excluding Mk (i.e. 11.6)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PdmsVersion Class | Aveva.Pdms Namespace


PdmsVersion Methods

The methods of the PdmsVersion class are listed below. For a complete list of PdmsVersion class members, see the PdmsVersion Members topic.

Public Static Methods

GetCompanyName | Retrieve company name PDMS is licensed to
GetCopyright | Retrieve copyright information for PDMS
GetModuleName | Retrieve the name of a PDMS module
GetModuleVersion | Retrieve the version of a PDMS module
GetName | Retrieve name of current module (i.e. VANTAGE PDMS Design)
GetShortBanner | Retrieve short banner string (i.e. qbann)
GetStatus | Retrieve any special status instructions (i.e. for pre-release builds)
GetVersion | Retrieve version number of PDMS excluding Mk (i.e. 11.6)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PdmsVersion Class | Aveva.Pdms Namespace


PdmsVersion.GetCompanyName Method

Retrieve company name PDMS is licensed to

public static string GetCompanyName();

Return Value

Licenced company name

See Also

PdmsVersion Class | Aveva.Pdms Namespace


PdmsVersion.GetCopyright Method

Retrieve copyright information for PDMS

public static string GetCopyright();

Return Value

Copyright text

See Also

PdmsVersion Class | Aveva.Pdms Namespace


PdmsVersion.GetModuleName Method

Retrieve the name of a PDMS module

public static string GetModuleName(
ModuleType module
);

Parameters

module
Module identifier

Return Value

Module name

See Also

PdmsVersion Class | Aveva.Pdms Namespace


PdmsVersion.GetModuleVersion Method

Retrieve the version of a PDMS module

public static string GetModuleVersion(
ModuleType module
);

Parameters

module
Module identifier

Return Value

Module version identifier

See Also

PdmsVersion Class | Aveva.Pdms Namespace


PdmsVersion.GetName Method

Retrieve name of current module (i.e. VANTAGE PDMS Design)

public static string GetName();

Return Value

Current module name

See Also

PdmsVersion Class | Aveva.Pdms Namespace


PdmsVersion.GetShortBanner Method

Retrieve short banner string (i.e. qbann)

public static string GetShortBanner();

Return Value

Banner text

See Also

PdmsVersion Class | Aveva.Pdms Namespace


PdmsVersion.GetStatus Method

Retrieve any special status instructions (i.e. for pre-release builds)

public static string GetStatus();

Return Value

Status text

See Also

PdmsVersion Class | Aveva.Pdms Namespace


PdmsVersion.GetVersion Method

Retrieve version number of PDMS excluding Mk (i.e. 11.6)

public static string GetVersion();

Return Value

PDMS version identifier

See Also

PdmsVersion Class | Aveva.Pdms Namespace


Aveva.PdmsHierarchy

AVEVA Application .NET Public Interface

Aveva.Pdms Hierarchy

System.Object
Aveva.Pdms.PdmsApplication
Aveva.Pdms.PdmsVersion
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aveva.Pdms.BeforeFinishEventHandler
Aveva.Pdms.FinishEventHandler
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aveva.Pdms.ModuleType

See Also

Aveva.Pdms Namespace