Aveva.Pdms.Standalone

AVEVA Standalone Application .NET Public Interface

Aveva.Pdms.Standalone Namespace

Namespace hierarchy

Classes

Class | Description
PdmsStandalone | Static support class for standalone Plant/Marine applications.
©AVEVA Solutions Ltd 2007


PdmsStandalone Class

Static support class for standalone Plant/Marine applications.

For a list of all members of this type, see PdmsStandalone Members.

System.Object
Aveva.Pdms.Standalone.PdmsStandalone

public class PdmsStandalone

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Standalone

Assembly: Aveva.Pdms.Standalone (in Aveva.Pdms.Standalone.dll)

See Also

PdmsStandalone Members | Aveva.Pdms.Standalone Namespace


PdmsStandalone Members

PdmsStandalone overview

Public Static Properties

MDB | Currently open MDB
Project | Currently open Project

Public Static Methods

Close | Close the project and MDB
ExitError | Overloaded. Exit with an error, displaying message
Finish | Finalise standalone application.
Open | Open a project and MDB with given user credentials
Start | Initialise standalone application.

Public Instance Constructors

PdmsStandalone Constructor Initializes a new instance of the PdmsStandalone class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PdmsStandalone Class | Aveva.Pdms.Standalone Namespace


PdmsStandalone Constructor

Initializes a new instance of the PdmsStandalone class.

public PdmsStandalone();

See Also


PdmsStandalone Properties

The properties of the PdmsStandalone class are listed below. For a complete list of PdmsStandalone class members, see the PdmsStandalone Members topic.

Public Static Properties

MDB | Currently open MDB
Project | Currently open Project

See Also


MDB Property

AVEVA Standalone Application .NET Public Interface

PdmsStandalone.MDB Property

Currently open MDB

public static Aveva.Pdms.Database.MDB MDB {get;}

See Also


Project Property

AVEVA Standalone Application .NET Public Interface

PdmsStandalone.Project Property

Currently open Project

public static Aveva.Pdms.Database.Project Project {get;}

See Also


PdmsStandalone Methods

The methods of the PdmsStandalone class are listed below. For a complete list of PdmsStandalone class members, see the PdmsStandalone Members topic.

Public Static Methods

Close | Close the project and MDB
ExitError | Overloaded. Exit with an error, displaying message
Finish | Finalise standalone application.
Open | Open a project and MDB with given user credentials
Start | Initialise standalone application.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also


PdmsStandalone.Close Method

Close the project and MDB

public static void Close();

See Also


ExitError Method

AVEVA Standalone Application .NET Public Interface

PdmsStandalone.ExitError Method

Exit with an error, displaying details on exception

Overload List

Exit with an error, displaying details on exception

public static void ExitError(Exception);

Exit with an error, displaying message

public static void ExitError(string);

See Also


PdmsStandalone.ExitError Method (Exception)

Exit with an error, displaying details on exception

public static void ExitError(
Exception ex
);

Parameters

ex
Error Exception

See Also

PdmsStandalone Class | Aveva.Pdms.Standalone Namespace | PdmsStandalone.ExitError Overload List


PdmsStandalone.ExitError Method (String)

Exit with an error, displaying message

public static void ExitError(
string sMessage
);

Parameters

sMessage
Error message

See Also

PdmsStandalone Class | Aveva.Pdms.Standalone Namespace | PdmsStandalone.ExitError Overload List


PdmsStandalone.Finish Method

Finalise standalone application.

public static void Finish();

See Also


PdmsStandalone.Open Method

Open a project and MDB with given user credentials

public static bool Open(
string sProject,
string sUser,
string sPass,
string sMdbName
);

Parameters

sProject
Project name
sUser
User name
sPass
Password
sMdbName
MDB name (no leading '/')

Return Value

True, if open was successful

See Also


PdmsStandalone.Start Method

Initialise standalone application.

public static bool Start();

Return Value

True, if initialisation is successful

See Also


Aveva.Pdms.StandaloneHierarchy

AVEVA Standalone Application .NET Public Interface

Aveva.Pdms.Standalone Hierarchy

System.Object
Aveva.Pdms.Standalone.PdmsStandalone

See Also

Aveva.Pdms.Standalone Namespace