Aveva.Pdms.Geometry

AVEVA Geometry .NET Public Interface

Aveva.Pdms.Geometry Namespace

Namespace hierarchy

Classes

Class | Description
Arc | An arc in 3d space. This is represented as a 2D arc and a given Oriented Plane. It is defined by the Oriented Plane origin as centre, a radius, start angle defined as an angular offset from the X direction of the orientation, and an end angle similarly defined.
Arc2D | Summary description for Arc2D.
Direction | Summary description for Direction.
Direction2D | Summary description for Direction2D.
LimitsBox | Summary description for LimitsBox.
LimitsBox2D | Summary description for LimitsBox2D.
Line | Summary description for Line.
Line2D | Summary description for Line2D.
LinearGrid | Summary description for PlantGrid.
LinearGrid2D | Summary description for LinearGrid2D.
Orientation | Summary description for Orientation.
Plane | Summary description for Plane.
PlantGrid | Summary description for PlantGrid.
PlantGrid2D | Summary description for PlantGrid2D.
PointVector | Summary description for PointVector.
Position | Summary description for D3Point.
Position2D | Summary description for Position2D.
RadialGrid | Summary description for RadialGrid.
RadialGrid2D | Summary description for RadialGrid2D.

Enumerations

Enumeration | Description
Axis |
Axis2D |
©AVEVA Solutions Ltd 2007


Arc Class

An arc in 3d space. This is represented as a 2D arc and a given Oriented Plane. It is defined by the Oriented Plane origin as centre, a radius, start angle defined as an angular offset from the X direction of the orientation, and an end angle similarly defined.

For a list of all members of this type, see Arc Members.

System.Object
Aveva.Pdms.Geometry.Arc

public abstract class Arc

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

Arc Members | Aveva.Pdms.Geometry Namespace


Arc Members

Arc overview

Public Static Methods

Create Overloaded. Default Arc

Public Static Operators

Equality Operator | Same Arc
Inequality Operator | Not Same Arc

Public Instance Properties

Centre | Centre
EndAngle | End angle from X axis of Orientation
Plane | OrientedPlane of arc – the arc is in the XY plane – centred on the origin of the plane
Radius | Radius
Sense | Sense: 1 = anticlockwise, 0 = clockwise
StartAngle | Start angle from X axis of Orientation

Public Instance Methods

Angle | Return the subtended angle of arc
AngleDirection | Return the direction from the centre of the arc through a point at angle degrees from the X axis
AngleTangent | Return the direction of a tangent to the arc at the angle ang from the X axis, in the sense of the arc
Chord | Return length of chord between start and end points
ChordHeight | Return height of chord between start and end points
Circle | Return Arc which is the full circle from the arc
Complement | Return the complementary Arc – the remainder of the circle
EndPosition | Position of end of arc
EndTangent | Return the direction of a tangent to the arc at the end angle, in the sense of the arc
Equals | Overloaded. Same Arc, within tolerance
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Intersections | Overloaded. Returns intersection points of arc with plane. Returns false if they do not intersect.
InValid | Return true if arc is invalid
IsCircle | Return true if arc is a full circle
IsOnArc | Return true if p is on arc
Length | Return length of arc
MoveBy | Move the centre of the arc.this distance along the Oriented Plane normal.
MoveTo | Move the centre of the arc to the new position, keeping the same orientation.
Position | Return Position on Arc which is at given angle from X axis of the orientation
Proportion | Return the position (angle from the X-axis) at ration from the start of the arc: Angle = (endAngle – startAngle) * ratio + StartAngle
SetChord | Changes the end angle so that the end position is at val distance from start position, maintaining centre and radius. Does nothing if val greater then 2*radius, or val less than 0
StartPosition | Position of start of arc
StartTangent | Return the direction of a tangent to the arc at the start angle, in the sense of the arc
TangentPoints | Overloaded. Returns the tangents between the two arcs (extended to full circles) (Note that there can be up to 4 lines returned.)
ToString | Returns Arc property values as a string

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc Properties

The properties of the Arc class are listed below. For a complete list of Arc class members, see the Arc Members topic.

Public Instance Properties

Centre | Centre
EndAngle | End angle from X axis of Orientation
Plane | OrientedPlane of arc – the arc is in the XY plane – centred on the origin of the plane
Radius | Radius
Sense | Sense: 1 = anticlockwise, 0 = clockwise
StartAngle | Start angle from X axis of Orientation

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Centre Property

AVEVA Geometry .NET Public Interface

Arc.Centre Property

Centre

public abstract Position Centre {get;}

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


EndAngle Property

AVEVA Geometry .NET Public Interface

Arc.EndAngle Property

End angle from X axis of Orientation

public abstract double EndAngle {get; set;}

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Plane Property

AVEVA Geometry .NET Public Interface

Arc.Plane Property

OrientedPlane of arc – the arc is in the XY plane – centred on the origin of the plane

public abstract Plane Plane {get; set;}

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Radius Property

AVEVA Geometry .NET Public Interface

Arc.Radius Property

Radius

public abstract double Radius {get;}

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Sense Property

AVEVA Geometry .NET Public Interface

Arc.Sense Property

Sense: 1 = anticlockwise, 0 = clockwise

public abstract bool Sense {get; set;}

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


StartAngle Property

AVEVA Geometry .NET Public Interface

Arc.StartAngle Property

Start angle from X axis of Orientation

public abstract double StartAngle {get; set;}

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc Methods

The methods of the Arc class are listed below. For a complete list of Arc class members, see the Arc Members topic.

Public Static Methods

Create Overloaded. Default Arc

Public Instance Methods

Angle | Return the subtended angle of arc
AngleDirection | Return the direction from the centre of the arc through a point at angle degrees from the X axis
AngleTangent | Return the direction of a tangent to the arc at the angle ang from the X axis, in the sense of the arc
Chord | Return length of chord between start and end points
ChordHeight | Return height of chord between start and end points
Circle | Return Arc which is the full circle from the arc
Complement | Return the complementary Arc – the remainder of the circle
EndPosition | Position of end of arc
EndTangent | Return the direction of a tangent to the arc at the end angle, in the sense of the arc
Equals | Overloaded. Same Arc, within tolerance
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Intersections | Overloaded. Returns intersection points of arc with plane. Returns false if they do not intersect.
InValid | Return true if arc is invalid
IsCircle | Return true if arc is a full circle
IsOnArc | Return true if p is on arc
Length | Return length of arc
MoveBy | Move the centre of the arc.this distance along the Oriented Plane normal.
MoveTo | Move the centre of the arc to the new position, keeping the same orientation.
Position | Return Position on Arc which is at given angle from X axis of the orientation
Proportion | Return the position (angle from the X-axis) at ration from the start of the arc: Angle = (endAngle – startAngle) * ratio + StartAngle
SetChord | Changes the end angle so that the end position is at val distance from start position, maintaining centre and radius. Does nothing if val greater then 2*radius, or val less than 0
StartPosition | Position of start of arc
StartTangent | Return the direction of a tangent to the arc at the start angle, in the sense of the arc
TangentPoints | Overloaded. Returns the tangents between the two arcs (extended to full circles) (Note that there can be up to 4 lines returned.)
ToString | Returns Arc property values as a string

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.Angle Method

Return the subtended angle of arc

public abstract double Angle();

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.AngleDirection Method

Return the direction from the centre of the arc through a point at angle degrees from the X axis

public abstract Direction AngleDirection(
double degrees
);

Parameters

degrees

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.AngleTangent Method

Return the direction of a tangent to the arc at the angle ang from the X axis, in the sense of the arc

public abstract Direction AngleTangent(
double ang
);

Parameters

ang

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.Chord Method

Return length of chord between start and end points

public abstract double Chord();

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.ChordHeight Method

Return height of chord between start and end points

public abstract double ChordHeight();

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.Circle Method

Return Arc which is the full circle from the arc

public abstract Arc Circle();

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.Complement Method

Return the complementary Arc – the remainder of the circle

public abstract Arc Complement();

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

Arc.Create Method

Default Arc

Overload List

Default Arc

public static Arc Create();

Construct an Arc from an Oriented Plane, start and end angles and radius. The Boolean antiClock is used to decide whether clockwise or anticlockwise arc is required

public static Arc Create(Plane,double,double,double,bool);

Construct an Arc passing through Positions p1 p2 and p3. The arc will have invalid state if the points are collinear.

public static Arc Create(Position,Position,Position);

Construct an Arc from two tangents (from apex to posA and apex to PosB) , centre and radius The arc will have invalid state if the points are collinear.

public static Arc Create(Position,Position,Position,double);

Construct an Arc from start and end positions, centre, and radius. The oriented plane will be determined by the centre, start and end positions. The start and end positions are used to determine the start and end angles for the arc. The Boolean antiClock is used to decide whether clockwise or anticlockwise arc is required.

public static Arc Create(Position,double,Position,Position,bool);

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.Create Method ()

Default Arc

public static Arc Create();

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace | Arc.Create Overload List


Arc.Create Method (Plane, Double, Double, Double, Boolean)

Construct an Arc from an Oriented Plane, start and end angles and radius. The Boolean antiClock is used to decide whether clockwise or anticlockwise arc is required

public static Arc Create(
Plane plane,
double radius,
double startAngle,
double endAngle,
bool antiClock
);

Parameters

plane
radius
startAngle
endAngle
antiClock

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace | Arc.Create Overload List


Arc.Create Method (Position, Position, Position)

Construct an Arc passing through Positions p1 p2 and p3. The arc will have invalid state if the points are collinear.

public static Arc Create(
Position p1,
Position p2,
Position p3
);

Parameters

p1
p2
p3

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace | Arc.Create Overload List


Arc.Create Method (Position, Position, Position, Double)

Construct an Arc from two tangents (from apex to posA and apex to PosB) , centre and radius The arc will have invalid state if the points are collinear.

public static Arc Create(
Position posA,
Position posB,
Position apex,
double radius
);

Parameters

posA
posB
apex
radius

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace | Arc.Create Overload List


Arc.Create Method (Position, Double, Position, Position, Boolean)

Construct an Arc from start and end positions, centre, and radius. The oriented plane will be determined by the centre, start and end positions. The start and end positions are used to determine the start and end angles for the arc. The Boolean antiClock is used to decide whether clockwise or anticlockwise arc is required.

public static Arc Create(
Position centre,
double radius,
Position start,
Position end,
bool antiClock
);

Parameters

centre
radius
start
end
antiClock

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace | Arc.Create Overload List


Arc.EndPosition Method

Position of end of arc

public abstract Position EndPosition();

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.EndTangent Method

Return the direction of a tangent to the arc at the end angle, in the sense of the arc

public abstract Direction EndTangent();

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Equals Method

AVEVA Geometry .NET Public Interface

Arc.Equals Method

Same Arc, within tolerance

Overload List

Same Arc, within tolerance

public abstract bool Equals(Arc);

Same Arc, within tolerance

public override bool Equals(object);

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.Equals Method (Arc)

Same Arc, within tolerance

public abstract bool Equals(
Arc arc
);

Parameters

arc

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace | Arc.Equals Overload List


Arc.Equals Method (Object)

Same Arc, within tolerance

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace | Arc.Equals Overload List


Arc.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Intersections Method

AVEVA Geometry .NET Public Interface

Arc.Intersections Method

Returns intersection points of two Arcs. Returns false if they do not intersect. Intersections will only be calculated if the arcs are defined in parallel planes. The given arc is projected onto the plane of the first.

Overload List

Returns intersection points of two Arcs. Returns false if they do not intersect. Intersections will only be calculated if the arcs are defined in parallel planes. The given arc is projected onto the plane of the first.

public abstract bool Intersections(Arc,ref Position[]);

Returns intersection points of arc with line projected onto the plane of the arc. Returns false if they do not intersect.

public abstract bool Intersections(Line,ref Position[]);

Returns intersection points of arc with plane. Returns false if they do not intersect.

public abstract bool Intersections(Plane,ref Position[]);

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.Intersections Method (Arc, Position[])

Returns intersection points of two Arcs. Returns false if they do not intersect. Intersections will only be calculated if the arcs are defined in parallel planes. The given arc is projected onto the plane of the first.

public abstract bool Intersections(
Arc a,
ref Position[] pa
);

Parameters

a
pa

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace | Arc.Intersections Overload List


Arc.Intersections Method (Line, Position[])

Returns intersection points of arc with line projected onto the plane of the arc. Returns false if they do not intersect.

public abstract bool Intersections(
Line line,
ref Position[] pa
);

Parameters

line
pa

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace | Arc.Intersections Overload List


Arc.Intersections Method (Plane, Position[])

Returns intersection points of arc with plane. Returns false if they do not intersect.

public abstract bool Intersections(
Plane plane,
ref Position[] pa
);

Parameters

plane
pa

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace | Arc.Intersections Overload List


Arc.InValid Method

Return true if arc is invalid

public abstract bool InValid();

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.IsCircle Method

Return true if arc is a full circle

public abstract bool IsCircle();

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.IsOnArc Method

Return true if p is on arc

public abstract bool IsOnArc(
Position p
);

Parameters

p

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.Length Method

Return length of arc

public abstract double Length();

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.MoveBy Method

Move the centre of the arc.this distance along the Oriented Plane normal.

public abstract void MoveBy(
double dist
);

Parameters

dist

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.MoveTo Method

Move the centre of the arc to the new position, keeping the same orientation.

public abstract void MoveTo(
Position centre
);

Parameters

centre

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.Position Method

Return Position on Arc which is at given angle from X axis of the orientation

public abstract Position Position(
double angle
);

Parameters

angle

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.Proportion Method

Return the position (angle from the X-axis) at ration from the start of the arc: Angle = (endAngle – startAngle) * ratio + StartAngle

public abstract double Proportion(
double ratio
);

Parameters

ratio

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.SetChord Method

Changes the end angle so that the end position is at val distance from start position, maintaining centre and radius. Does nothing if val greater then 2*radius, or val less than 0

public abstract void SetChord(
double val
);

Parameters

val

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.StartPosition Method

Position of start of arc

public abstract Position StartPosition();

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.StartTangent Method

Return the direction of a tangent to the arc at the start angle, in the sense of the arc

public abstract Direction StartTangent();

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


TangentPoints Method

AVEVA Geometry .NET Public Interface

Arc.TangentPoints Method

Returns the tangents between the two arcs (extended to full circles) (Note that there can be up to 4 lines returned.)

Overload List

Returns the tangents between the two arcs (extended to full circles) (Note that there can be up to 4 lines returned.)

public abstract Line[] TangentPoints(Arc);

Returns the points of tangency from the Position pos to the arc (extended to a full circle)The supplied pos is projected onto the plane of the arc.

public abstract Position[] TangentPoints(Position);

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc.TangentPoints Method (Arc)

Returns the tangents between the two arcs (extended to full circles) (Note that there can be up to 4 lines returned.)

public abstract Line[] TangentPoints(
Arc arc
);

Parameters

arc

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace | Arc.TangentPoints Overload List


Arc.TangentPoints Method (Position)

Returns the points of tangency from the Position pos to the arc (extended to a full circle)The supplied pos is projected onto the plane of the arc.

public abstract Position[] TangentPoints(
Position pos
);

Parameters

pos

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace | Arc.TangentPoints Overload List


Arc.ToString Method

Returns Arc property values as a string

public abstract string ToString();

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc Operators

The operators of the Arc class are listed below. For a complete list of Arc class members, see the Arc Members topic.

Public Static Operators

Equality Operator | Same Arc
Inequality Operator | Not Same Arc

See Also

Arc Class | Arc Members | Aveva.Pdms.Geometry Namespace


Arc Equality Operator

Same Arc

public static bool operator ==(
Arc a1,
Arc a2
);

Parameters

a1
a2

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc Inequality Operator

Not Same Arc

public static bool operator !=(
Arc a1,
Arc a2
);

Parameters

a1
a2

Return Value

See Also

Arc Class | Aveva.Pdms.Geometry Namespace


Arc2D Class

Summary description for Arc2D.

For a list of all members of this type, see Arc2D Members.

System.Object
Aveva.Pdms.Geometry.Arc2D

public abstract class Arc2D

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

Arc2D Members | Aveva.Pdms.Geometry Namespace


Arc2D Members

Arc2D overview

Public Static Methods

Create Overloaded. Create Arc2D (all values zero)

Public Static Operators

Equality Operator | Same Arc2D
Inequality Operator | Not same Arc2D

Public Instance Properties

Centre | Centre of the arc
End | End position of the arc
Radius | Redius of the arc
Sense | Sense of the arc
Start | Start position of the arc

Public Instance Methods

Angle | Return angle subtended by start and end points at centre of Arc2D
AnglePosition | Return Position2D on Arc2D which is at given angle from centre of Arc2D
Chord | Return length of chord between start and end points
ChordHeight | Return height of chord between start and end points
Circle | Return Arc2D which is the full circle from the Arc2D
Complement | Return the complementary Arc2D – the remainder of the circle
Equals | Overloaded. Same Arc2D, within tolerance
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Intersections | Overloaded. Returns intersection points of Arc2D with line. Returns false if they do not intersect
IsOnArc | Return true if p is on Arc2D
Length | Return length of Arc2D
MoveBy | Move Arc2D by given x,y values
ToString | Returns Arc2D property values in a string

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D Properties

The properties of the Arc2D class are listed below. For a complete list of Arc2D class members, see the Arc2D Members topic.

Public Instance Properties

Centre | Centre of the arc
End | End position of the arc
Radius | Redius of the arc
Sense | Sense of the arc
Start | Start position of the arc

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Centre Property

AVEVA Geometry .NET Public Interface

Arc2D.Centre Property

Centre of the arc

public abstract Position2D Centre {get; set;}

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


End Property

AVEVA Geometry .NET Public Interface

Arc2D.End Property

End position of the arc

public abstract Position2D End {get; set;}

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Radius Property

AVEVA Geometry .NET Public Interface

Arc2D.Radius Property

Redius of the arc

public abstract double Radius {get; set;}

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Sense Property

AVEVA Geometry .NET Public Interface

Arc2D.Sense Property

Sense of the arc

public abstract bool Sense {get; set;}

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Start Property

AVEVA Geometry .NET Public Interface

Arc2D.Start Property

Start position of the arc

public abstract Position2D Start {get; set;}

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D Methods

The methods of the Arc2D class are listed below. For a complete list of Arc2D class members, see the Arc2D Members topic.

Public Static Methods

Create Overloaded. Create Arc2D (all values zero)

Public Instance Methods

Angle | Return angle subtended by start and end points at centre of Arc2D
AnglePosition | Return Position2D on Arc2D which is at given angle from centre of Arc2D
Chord | Return length of chord between start and end points
ChordHeight | Return height of chord between start and end points
Circle | Return Arc2D which is the full circle from the Arc2D
Complement | Return the complementary Arc2D – the remainder of the circle
Equals | Overloaded. Same Arc2D, within tolerance
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Intersections | Overloaded. Returns intersection points of Arc2D with line. Returns false if they do not intersect
IsOnArc | Return true if p is on Arc2D
Length | Return length of Arc2D
MoveBy | Move Arc2D by given x,y values
ToString | Returns Arc2D property values in a string

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D.Angle Method

Return angle subtended by start and end points at centre of Arc2D

public abstract double Angle();

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D.AnglePosition Method

Return Position2D on Arc2D which is at given angle from centre of Arc2D

public abstract Position2D AnglePosition(
double angle
);

Parameters

angle

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D.Chord Method

Return length of chord between start and end points

public abstract double Chord();

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D.ChordHeight Method

Return height of chord between start and end points

public abstract double ChordHeight();

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D.Circle Method

Return Arc2D which is the full circle from the Arc2D

public abstract Arc2D Circle();

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D.Complement Method

Return the complementary Arc2D – the remainder of the circle

public abstract Arc2D Complement();

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

Arc2D.Create Method

Create Arc2D (all values zero)

Overload List

Create Arc2D (all values zero)

public static Arc2D Create();

Create an Arc2D from two tangents and radius

public static Arc2D Create(Line2D,Line2D,Position2D,double,bool);

Create an Arc2D passing through Position2Ds p1, p2 and p3

public static Arc2D Create(Position2D,Position2D,Position2D);

Create an Arc2D from 2 positions, centre, radius and direction

public static Arc2D Create(Position2D,double,Position2D,Position2D,bool);

Create an Arc2D from centre, radius, startangle and endangles and sense

public static Arc2D Create(Position2D,double,double,double,bool);

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D.Create Method ()

Create Arc2D (all values zero)

public static Arc2D Create();

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace | Arc2D.Create Overload List


Arc2D.Create Method (Line2D, Line2D, Position2D, Double, Boolean)

Create an Arc2D from two tangents and radius

public static Arc2D Create(
Line2D line1,
Line2D line2,
Position2D locator,
double radius,
bool anticlock
);

Parameters

line1
line2
locator
radius
anticlock

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace | Arc2D.Create Overload List


Arc2D.Create Method (Position2D, Position2D, Position2D)

Create an Arc2D passing through Position2Ds p1, p2 and p3

public static Arc2D Create(
Position2D p1,
Position2D p2,
Position2D p3
);

Parameters

p1
p2
p3

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace | Arc2D.Create Overload List


Arc2D.Create Method (Position2D, Double, Position2D, Position2D, Boolean)

Create an Arc2D from 2 positions, centre, radius and direction

public static Arc2D Create(
Position2D centre,
double radius,
Position2D start,
Position2D end,
bool anticlock
);

Parameters

centre
radius
start
end
anticlock

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace | Arc2D.Create Overload List


Arc2D.Create Method (Position2D, Double, Double, Double, Boolean)

Create an Arc2D from centre, radius, startangle and endangles and sense

public static Arc2D Create(
Position2D centre,
double radius,
double startAngle,
double endAngle,
bool anticlock
);

Parameters

centre
radius
startAngle
endAngle
anticlock

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace | Arc2D.Create Overload List


Equals Method

AVEVA Geometry .NET Public Interface

Arc2D.Equals Method

Same Arc2D, within tolerance

Overload List

Same Arc2D, within tolerance

public abstract bool Equals(Arc2D);

Same Arc2D, within tolerance

public override bool Equals(object);

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D.Equals Method (Arc2D)

Same Arc2D, within tolerance

public abstract bool Equals(
Arc2D arc
);

Parameters

arc

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace | Arc2D.Equals Overload List


Arc2D.Equals Method (Object)

Same Arc2D, within tolerance

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace | Arc2D.Equals Overload List


Arc2D.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Intersections Method

AVEVA Geometry .NET Public Interface

Arc2D.Intersections Method

Returns intersection points of two Arc2Ds. Returns false if they do not intersect

Overload List

Returns intersection points of two Arc2Ds. Returns false if they do not intersect

public abstract bool Intersections(Arc2D,ref Position2D[]);

Returns intersection points of Arc2D with line. Returns false if they do not intersect

public abstract bool Intersections(Line2D,ref Position2D[]);

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D.Intersections Method (Arc2D, Position2D[])

Returns intersection points of two Arc2Ds. Returns false if they do not intersect

public abstract bool Intersections(
Arc2D a,
ref Position2D[] pa
);

Parameters

a
pa

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace | Arc2D.Intersections Overload List


Arc2D.Intersections Method (Line2D, Position2D[])

Returns intersection points of Arc2D with line. Returns false if they do not intersect

public abstract bool Intersections(
Line2D line,
ref Position2D[] pa
);

Parameters

line
pa

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace | Arc2D.Intersections Overload List


Arc2D.IsOnArc Method

Return true if p is on Arc2D

public abstract bool IsOnArc(
Position2D p
);

Parameters

p

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D.Length Method

Return length of Arc2D

public abstract double Length();

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D.MoveBy Method

Move Arc2D by given x,y values

public abstract void MoveBy(
double x,
double y
);

Parameters

x
y

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D.ToString Method

Returns Arc2D property values in a string

public abstract string ToString();

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D Operators

The operators of the Arc2D class are listed below. For a complete list of Arc2D class members, see the Arc2D Members topic.

Public Static Operators

Equality Operator | Same Arc2D
Inequality Operator | Not same Arc2D

See Also

Arc2D Class | Arc2D Members | Aveva.Pdms.Geometry Namespace


Arc2D Equality Operator

Same Arc2D

public static bool operator ==(
Arc2D a1,
Arc2D a2
);

Parameters

a1
a2

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Arc2D Inequality Operator

Not same Arc2D

public static bool operator !=(
Arc2D a1,
Arc2D a2
);

Parameters

a1
a2

Return Value

See Also

Arc2D Class | Aveva.Pdms.Geometry Namespace


Axis Enumeration

public enum Axis

Members

Member Name | Description
EAST |
WEST |
NORTH |
SOUTH |
UP |
DOWN |

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

Aveva.Pdms.Geometry Namespace


Axis2D Enumeration

public enum Axis2D

Members

Member Name | Description
LEFT |
RIGHT |
UP |
DOWN |
X |
Y |

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

Aveva.Pdms.Geometry Namespace


Direction Class

Summary description for Direction.

For a list of all members of this type, see Direction Members.

System.Object
Aveva.Pdms.Geometry.Direction

public abstract class Direction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

Direction Members | Aveva.Pdms.Geometry Namespace


Direction Members

Direction overview

Public Static Methods

Create Overloaded. Default Direction

Public Static Operators

Equality Operator | Exact equality
Inequality Operator | Exact inequality

Public Instance Properties

East | E component
North | N component
Up | U component

Public Instance Methods

Angle | Returns the angle between the two directions
Equals | Overloaded. Same Direction, within tolerance
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
IsAntiParallel | Returns true if the two directions are parallel (in the opposite direction)
IsParallel | Returns true if the two directions are parallel (in the same direction)
Midway | Returns the direction halfway between the two directions
NearestAxis | Returns the nearest Axis
Normal | Returns a plane normal to the Direction through pos
Opposite | Returns the opposite direction
Orthogonal | Returns Direction that is orthogonal between the two directions
Parse | Converts a direction in PDMS format into a Direction object
Project | Returns the distance which is the projection of this direction onto Direction d
RotateAbout | Rotate this direction towards direction dir by amount degrees
RotateTowards | Rotate this direction towards direction dir by amount degrees
ToString | Returns Direction in PDMS Format

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction Properties

The properties of the Direction class are listed below. For a complete list of Direction class members, see the Direction Members topic.

Public Instance Properties

East | E component
North | N component
Up | U component

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


East Property

AVEVA Geometry .NET Public Interface

Direction.East Property

E component

public abstract double East {get; set;}

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


North Property

AVEVA Geometry .NET Public Interface

Direction.North Property

N component

public abstract double North {get; set;}

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Up Property

AVEVA Geometry .NET Public Interface

Direction.Up Property

U component

public abstract double Up {get; set;}

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction Methods

The methods of the Direction class are listed below. For a complete list of Direction class members, see the Direction Members topic.

Public Static Methods

Create Overloaded. Default Direction

Public Instance Methods

Angle | Returns the angle between the two directions
Equals | Overloaded. Same Direction, within tolerance
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
IsAntiParallel | Returns true if the two directions are parallel (in the opposite direction)
IsParallel | Returns true if the two directions are parallel (in the same direction)
Midway | Returns the direction halfway between the two directions
NearestAxis | Returns the nearest Axis
Normal | Returns a plane normal to the Direction through pos
Opposite | Returns the opposite direction
Orthogonal | Returns Direction that is orthogonal between the two directions
Parse | Converts a direction in PDMS format into a Direction object
Project | Returns the distance which is the projection of this direction onto Direction d
RotateAbout | Rotate this direction towards direction dir by amount degrees
RotateTowards | Rotate this direction towards direction dir by amount degrees
ToString | Returns Direction in PDMS Format

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction.Angle Method

Returns the angle between the two directions

public abstract double Angle(
Direction d
);

Parameters

d

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

Direction.Create Method

Default Direction

Overload List

Default Direction

public static Direction Create();

Create a Direction along the given axis

public static Direction Create(Axis);

Create a Direction rotated angle degrees from a1 towards a2

public static Direction Create(Axis,double,Axis);

Create a Direction rotated angle degrees from a1 towards a2, and then ang2 degrees towards a3

public static Direction Create(Axis,double,Axis,double,Axis);

Create a direction from the origin to p1

public static Direction Create(Position);

Create a Direction from p1 to p2

public static Direction Create(Position,Position);

public static Direction Create(string);

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction.Create Method ()

Default Direction

public static Direction Create();

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace | Direction.Create Overload List


Direction.Create Method (Axis)

Create a Direction along the given axis

public static Direction Create(
Axis axis
);

Parameters

axis

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace | Direction.Create Overload List


Direction.Create Method (Axis, Double, Axis)

Create a Direction rotated angle degrees from a1 towards a2

public static Direction Create(
Axis axis,
double angle,
Axis axis2
);

Parameters

axis
angle
axis2

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace | Direction.Create Overload List


Direction.Create Method (Axis, Double, Axis, Double, Axis)

Create a Direction rotated angle degrees from a1 towards a2, and then ang2 degrees towards a3

public static Direction Create(
Axis axis,
double ang1,
Axis a2,
double ang2,
Axis a3
);

Parameters

axis
ang1
a2
ang2
a3

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace | Direction.Create Overload List


Direction.Create Method (Position)

Create a direction from the origin to p1

public static Direction Create(
Position p1
);

Parameters

p1

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace | Direction.Create Overload List


Direction.Create Method (Position, Position)

Create a Direction from p1 to p2

public static Direction Create(
Position p1,
Position p2
);

Parameters

p1
p2

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace | Direction.Create Overload List


Direction.Create Method (String)

public static Direction Create(
string dirstring
);

See Also

Direction Class | Aveva.Pdms.Geometry Namespace | Direction.Create Overload List


Equals Method

AVEVA Geometry .NET Public Interface

Direction.Equals Method

Same Direction, within tolerance

Overload List

Same Direction, within tolerance

public abstract bool Equals(Direction);

Same Direction, within tolerance

public override bool Equals(object);

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction.Equals Method (Direction)

Same Direction, within tolerance

public abstract bool Equals(
Direction dir
);

Parameters

dir

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace | Direction.Equals Overload List


Direction.Equals Method (Object)

Same Direction, within tolerance

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace | Direction.Equals Overload List


Direction.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction.IsAntiParallel Method

Returns true if the two directions are parallel (in the opposite direction)

public abstract bool IsAntiParallel(
Direction d
);

Parameters

d

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction.IsParallel Method

Returns true if the two directions are parallel (in the same direction)

public abstract bool IsParallel(
Direction d
);

Parameters

d

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction.Midway Method

Returns the direction halfway between the two directions

public abstract Direction Midway(
Direction d
);

Parameters

d

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction.NearestAxis Method

Returns the nearest Axis

public abstract Axis NearestAxis();

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction.Normal Method

Returns a plane normal to the Direction through pos

public abstract Plane Normal(
Position pos
);

Parameters

pos

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction.Opposite Method

Returns the opposite direction

public abstract Direction Opposite();

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction.Orthogonal Method

Returns Direction that is orthogonal between the two directions

public abstract Direction Orthogonal(
Direction d
);

Parameters

d

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction.Parse Method

Converts a direction in PDMS format into a Direction object

public abstract Direction Parse(
string str
);

Parameters

str

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction.Project Method

Returns the distance which is the projection of this direction onto Direction d

public abstract double Project(
Direction d
);

Parameters

d

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction.RotateAbout Method

Rotate this direction towards direction dir by amount degrees

public abstract void RotateAbout(
Direction dir,
double degrees
);

Parameters

dir
degrees

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction.RotateTowards Method

Rotate this direction towards direction dir by amount degrees

public abstract void RotateTowards(
Direction dir,
double degrees
);

Parameters

dir
degrees

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction.ToString Method

Returns Direction in PDMS Format

public abstract string ToString();

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction Operators

The operators of the Direction class are listed below. For a complete list of Direction class members, see the Direction Members topic.

Public Static Operators

Equality Operator | Exact equality
Inequality Operator | Exact inequality

See Also

Direction Class | Direction Members | Aveva.Pdms.Geometry Namespace


Direction Equality Operator

Exact equality

public static bool operator ==(
Direction d1,
Direction d2
);

Parameters

d1
d2

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction Inequality Operator

Exact inequality

public static bool operator !=(
Direction d1,
Direction d2
);

Parameters

d1
d2

Return Value

See Also

Direction Class | Aveva.Pdms.Geometry Namespace


Direction2D Class

Summary description for Direction2D.

For a list of all members of this type, see Direction2D Members.

System.Object
Aveva.Pdms.Geometry.Direction2D

public abstract class Direction2D

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

Direction2D Members | Aveva.Pdms.Geometry Namespace


Direction2D Members

Direction2D overview

Public Static Methods

Create Overloaded. Create a Direction2D ( unset )

Public Static Operators

Equality Operator | Same Direction2D within tolerance
Inequality Operator | Not same Direction2D

Public Instance Properties

Right | X Component
Up | Y Component

Public Instance Methods

Angle | Returns the angle between the two Direction2Ds
Equals | Overloaded. Same Direction2D, within tolerance
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
IsAntiParallel | Returns true if the two directions are parallel (in the opposite direction)
IsParallel | Returns true if the two directions are parallel (in the same direction)
Midway | Returns the direction halfway between the two directions
NearestAxis | Returns the nearest Axis
Opposite | Returns the opposite direction
Parse | Return Direction2D object derived from a string in PDMS format
Rotate | Rotate this Direction2D by amount degrees
ToString | Returns Direction2D property values in a string

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Direction2D Properties

The properties of the Direction2D class are listed below. For a complete list of Direction2D class members, see the Direction2D Members topic.

Public Instance Properties

Right | X Component
Up | Y Component

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Right Property

AVEVA Geometry .NET Public Interface

Direction2D.Right Property

X Component

public abstract double Right {get; set;}

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Up Property

AVEVA Geometry .NET Public Interface

Direction2D.Up Property

Y Component

public abstract double Up {get; set;}

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Direction2D Methods

The methods of the Direction2D class are listed below. For a complete list of Direction2D class members, see the Direction2D Members topic.

Public Static Methods

Create Overloaded. Create a Direction2D ( unset )

Public Instance Methods

Angle | Returns the angle between the two Direction2Ds
Equals | Overloaded. Same Direction2D, within tolerance
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
IsAntiParallel | Returns true if the two directions are parallel (in the opposite direction)
IsParallel | Returns true if the two directions are parallel (in the same direction)
Midway | Returns the direction halfway between the two directions
NearestAxis | Returns the nearest Axis
Opposite | Returns the opposite direction
Parse | Return Direction2D object derived from a string in PDMS format
Rotate | Rotate this Direction2D by amount degrees
ToString | Returns Direction2D property values in a string

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Direction2D.Angle Method

Returns the angle between the two Direction2Ds

public abstract double Angle(
Direction2D d
);

Parameters

d

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

Direction2D.Create Method

Create a Direction2D ( unset )

Overload List

Create a Direction2D ( unset )

public static Direction2D Create();

Create a Direction2D along the given axis

public static Direction2D Create(Axis2D);

Create a Direction2D from the origin to p1

public static Direction2D Create(Position2D);

Create a Direction2D from p1 to p2

public static Direction2D Create(Position2D,Position2D);

Create a Direction2D rotated angle degrees from X axis

public static Direction2D Create(double);

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Direction2D.Create Method ()

Create a Direction2D ( unset )

public static Direction2D Create();

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace | Direction2D.Create Overload List


Direction2D.Create Method (Axis2D)

Create a Direction2D along the given axis

public static Direction2D Create(
Axis2D axis
);

Parameters

axis

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace | Direction2D.Create Overload List


Direction2D.Create Method (Position2D)

Create a Direction2D from the origin to p1

public static Direction2D Create(
Position2D p1
);

Parameters

p1

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace | Direction2D.Create Overload List


Direction2D.Create Method (Position2D, Position2D)

Create a Direction2D from p1 to p2

public static Direction2D Create(
Position2D p1,
Position2D p2
);

Parameters

p1
p2

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace | Direction2D.Create Overload List


Direction2D.Create Method (Double)

Create a Direction2D rotated angle degrees from X axis

public static Direction2D Create(
double angle
);

Parameters

angle

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace | Direction2D.Create Overload List


Equals Method

AVEVA Geometry .NET Public Interface

Direction2D.Equals Method

Same Direction2D, within tolerance

Overload List

Same Direction2D, within tolerance

public abstract bool Equals(Direction2D);

Same Direction2D, within tolerance

public override bool Equals(object);

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Direction2D.Equals Method (Direction2D)

Same Direction2D, within tolerance

public abstract bool Equals(
Direction2D dir
);

Parameters

dir

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace | Direction2D.Equals Overload List


Direction2D.Equals Method (Object)

Same Direction2D, within tolerance

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace | Direction2D.Equals Overload List


Direction2D.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Direction2D.IsAntiParallel Method

Returns true if the two directions are parallel (in the opposite direction)

public abstract bool IsAntiParallel(
Direction2D d
);

Parameters

d

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Direction2D.IsParallel Method

Returns true if the two directions are parallel (in the same direction)

public abstract bool IsParallel(
Direction2D d
);

Parameters

d

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Direction2D.Midway Method

Returns the direction halfway between the two directions

public abstract Direction2D Midway(
Direction2D d
);

Parameters

d

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Direction2D.NearestAxis Method

Returns the nearest Axis

public abstract Axis2D NearestAxis();

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Direction2D.Opposite Method

Returns the opposite direction

public abstract Direction2D Opposite();

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Direction2D.Parse Method

Return Direction2D object derived from a string in PDMS format

public abstract Direction2D Parse(
string str
);

Parameters

str

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Direction2D.Rotate Method

Rotate this Direction2D by amount degrees

public abstract void Rotate(
double degrees
);

Parameters

degrees

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Direction2D.ToString Method

Returns Direction2D property values in a string

public abstract string ToString();

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Direction2D Operators

The operators of the Direction2D class are listed below. For a complete list of Direction2D class members, see the Direction2D Members topic.

Public Static Operators

Equality Operator | Same Direction2D within tolerance
Inequality Operator | Not same Direction2D

See Also

Direction2D Class | Direction2D Members | Aveva.Pdms.Geometry Namespace


Direction2D Equality Operator

Same Direction2D within tolerance

public static bool operator ==(
Direction2D d1,
Direction2D d2
);

Parameters

d1
d2

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


Direction2D Inequality Operator

Not same Direction2D

public static bool operator !=(
Direction2D d1,
Direction2D d2
);

Parameters

d1
d2

Return Value

See Also

Direction2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox Class

Summary description for LimitsBox.

For a list of all members of this type, see LimitsBox Members.

System.Object
Aveva.Pdms.Geometry.LimitsBox

public abstract class LimitsBox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

LimitsBox Members | Aveva.Pdms.Geometry Namespace


LimitsBox Members

LimitsBox overview

Public Static Methods

Create Overloaded. Create LimitsBox

Public Static Operators

Equality Operator | Same LimitsBox
Inequality Operator | Not Same LimitsBox

Public Instance Properties

Maximum | Maximum corner of the LimitsBox
Minimum | Minimum corner of the LimitsBox

Public Instance Methods

Centre | Return centre point of LimitsBox
Contains | Returns true if box is entirely contained within this LimitsBox
ContainsPoint | Returns true if p is inside (not on) LimitsBox
Equals | Overloaded. Same Limitsbox
ExpandBy | Expand LimitsBox by val in all directions
ExpandToInclude | Expand LimitsBox to include pos
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Intersection | Returns LimitsBox which consists of the overlap of the two LimitsBoxes
Intersects | Returns true if LimitsBoxes intersect
Merge | Return LimitsBox that is the combination of the 2 LimitsBoxes
ToString | Returns Limits Box property values in a string
Volume | Returns the volume inside the LimitsBox

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox Properties

The properties of the LimitsBox class are listed below. For a complete list of LimitsBox class members, see the LimitsBox Members topic.

Public Instance Properties

Maximum | Maximum corner of the LimitsBox
Minimum | Minimum corner of the LimitsBox

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


Maximum Property

AVEVA Geometry .NET Public Interface

LimitsBox.Maximum Property

Maximum corner of the LimitsBox

public abstract Position Maximum {get; set;}

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


Minimum Property

AVEVA Geometry .NET Public Interface

LimitsBox.Minimum Property

Minimum corner of the LimitsBox

public abstract Position Minimum {get; set;}

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox Methods

The methods of the LimitsBox class are listed below. For a complete list of LimitsBox class members, see the LimitsBox Members topic.

Public Static Methods

Create Overloaded. Create LimitsBox

Public Instance Methods

Centre | Return centre point of LimitsBox
Contains | Returns true if box is entirely contained within this LimitsBox
ContainsPoint | Returns true if p is inside (not on) LimitsBox
Equals | Overloaded. Same Limitsbox
ExpandBy | Expand LimitsBox by val in all directions
ExpandToInclude | Expand LimitsBox to include pos
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Intersection | Returns LimitsBox which consists of the overlap of the two LimitsBoxes
Intersects | Returns true if LimitsBoxes intersect
Merge | Return LimitsBox that is the combination of the 2 LimitsBoxes
ToString | Returns Limits Box property values in a string
Volume | Returns the volume inside the LimitsBox

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox.Centre Method

Return centre point of LimitsBox

public abstract Position Centre();

Return Value

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox.Contains Method

Returns true if box is entirely contained within this LimitsBox

public abstract bool Contains(
LimitsBox box
);

Parameters

box

Return Value

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox.ContainsPoint Method

Returns true if p is inside (not on) LimitsBox

public abstract bool ContainsPoint(
Position p
);

Parameters

p

Return Value

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

LimitsBox.Create Method

Create LimitsBox

Overload List

Create LimitsBox

public static LimitsBox Create();

Createa LimitsBox with min and max corners specified by p1 and p2

public static LimitsBox Create(Position,Position);

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox.Create Method ()

Create LimitsBox

public static LimitsBox Create();

Return Value

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace | LimitsBox.Create Overload List


LimitsBox.Create Method (Position, Position)

Createa LimitsBox with min and max corners specified by p1 and p2

public static LimitsBox Create(
Position p1,
Position p2
);

Parameters

p1
p2

Return Value

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace | LimitsBox.Create Overload List


Equals Method

AVEVA Geometry .NET Public Interface

LimitsBox.Equals Method

Same Limitsbox

Overload List

Same Limitsbox

public abstract bool Equals(LimitsBox);

Same Limitsbox

public override bool Equals(object);

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox.Equals Method (LimitsBox)

Same Limitsbox

public abstract bool Equals(
LimitsBox box
);

Parameters

box

Return Value

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace | LimitsBox.Equals Overload List


LimitsBox.Equals Method (Object)

Same Limitsbox

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace | LimitsBox.Equals Overload List


LimitsBox.ExpandBy Method

Expand LimitsBox by val in all directions

public abstract void ExpandBy(
double val
);

Parameters

val

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox.ExpandToInclude Method

Expand LimitsBox to include pos

public abstract void ExpandToInclude(
Position pos
);

Parameters

pos

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox.Intersection Method

Returns LimitsBox which consists of the overlap of the two LimitsBoxes

public abstract LimitsBox Intersection(
LimitsBox box
);

Parameters

box

Return Value

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox.Intersects Method

Returns true if LimitsBoxes intersect

public abstract bool Intersects(
LimitsBox box
);

Parameters

box

Return Value

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox.Merge Method

Return LimitsBox that is the combination of the 2 LimitsBoxes

public abstract LimitsBox Merge(
LimitsBox box
);

Parameters

box

Return Value

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox.ToString Method

Returns Limits Box property values in a string

public abstract string ToString();

Return Value

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox.Volume Method

Returns the volume inside the LimitsBox

public abstract double Volume();

Return Value

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox Operators

The operators of the LimitsBox class are listed below. For a complete list of LimitsBox class members, see the LimitsBox Members topic.

Public Static Operators

Equality Operator | Same LimitsBox
Inequality Operator | Not Same LimitsBox

See Also

LimitsBox Class | LimitsBox Members | Aveva.Pdms.Geometry Namespace


LimitsBox Equality Operator

Same LimitsBox

public static bool operator ==(
LimitsBox t1,
LimitsBox t2
);

Parameters

t1
t2

Return Value

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox Inequality Operator

Not Same LimitsBox

public static bool operator !=(
LimitsBox t1,
LimitsBox t2
);

Parameters

t1
t2

Return Value

See Also

LimitsBox Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D Class

Summary description for LimitsBox2D.

For a list of all members of this type, see LimitsBox2D Members.

System.Object
Aveva.Pdms.Geometry.LimitsBox2D

public abstract class LimitsBox2D

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

LimitsBox2D Members | Aveva.Pdms.Geometry Namespace


LimitsBox2D Members

LimitsBox2D overview

Public Static Methods

Create Overloaded. Create LimitsBox2D

Public Static Operators

Equality Operator | Same LimitsBox2D within tolerance
Inequality Operator | Not same LimitsBox2D

Public Instance Properties

Maximum | Maximum corner of the LimitsBox2D
Minimum | Minimum corner of the LimitsBox2D

Public Instance Methods

Area | Returns the area inside the LimitsBox2D
Centre | Return centre point of LimitsBox2D
Contains | Returns true if box is entirely contained within this LimitsBox2D
ContainsPoint | Returns true if pos is inside (not on) LimitsBox2D
Equals | Overloaded. Same LimitsBox2D, within tolerance
ExpandBy | Expand LimitsBox by val in X and Y direction about centre
ExpandToInclude | Expand LimitsBox to include pos
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Intersection | Returns LimitsBox2D which consists of the overlap of the two LimitsBoxes
Intersects | Returns true if limits boxes intersect
Merge | Return LimitsBox2D that is the combination ot the 2 LimitsBoxes
ToString | Returns LimitsBox2D property values in a string

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D Properties

The properties of the LimitsBox2D class are listed below. For a complete list of LimitsBox2D class members, see the LimitsBox2D Members topic.

Public Instance Properties

Maximum | Maximum corner of the LimitsBox2D
Minimum | Minimum corner of the LimitsBox2D

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


Maximum Property

AVEVA Geometry .NET Public Interface

LimitsBox2D.Maximum Property

Maximum corner of the LimitsBox2D

public abstract Position2D Maximum {get; set;}

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


Minimum Property

AVEVA Geometry .NET Public Interface

LimitsBox2D.Minimum Property

Minimum corner of the LimitsBox2D

public abstract Position2D Minimum {get; set;}

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D Methods

The methods of the LimitsBox2D class are listed below. For a complete list of LimitsBox2D class members, see the LimitsBox2D Members topic.

Public Static Methods

Create Overloaded. Create LimitsBox2D

Public Instance Methods

Area | Returns the area inside the LimitsBox2D
Centre | Return centre point of LimitsBox2D
Contains | Returns true if box is entirely contained within this LimitsBox2D
ContainsPoint | Returns true if pos is inside (not on) LimitsBox2D
Equals | Overloaded. Same LimitsBox2D, within tolerance
ExpandBy | Expand LimitsBox by val in X and Y direction about centre
ExpandToInclude | Expand LimitsBox to include pos
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Intersection | Returns LimitsBox2D which consists of the overlap of the two LimitsBoxes
Intersects | Returns true if limits boxes intersect
Merge | Return LimitsBox2D that is the combination ot the 2 LimitsBoxes
ToString | Returns LimitsBox2D property values in a string

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D.Area Method

Returns the area inside the LimitsBox2D

public abstract double Area();

Return Value

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D.Centre Method

Return centre point of LimitsBox2D

public abstract Position2D Centre();

Return Value

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D.Contains Method

Returns true if box is entirely contained within this LimitsBox2D

public abstract bool Contains(
LimitsBox2D box
);

Parameters

box

Return Value

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D.ContainsPoint Method

Returns true if pos is inside (not on) LimitsBox2D

public abstract bool ContainsPoint(
Position2D pos
);

Parameters

pos

Return Value

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

LimitsBox2D.Create Method

Create LimitsBox2D

Overload List

Create LimitsBox2D

public static LimitsBox2D Create();

Create a LimitsBox2D with min and max corners specified by p1 and p2

public static LimitsBox2D Create(Position2D,Position2D);

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D.Create Method ()

Create LimitsBox2D

public static LimitsBox2D Create();

Return Value

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace | LimitsBox2D.Create Overload List


LimitsBox2D.Create Method (Position2D, Position2D)

Create a LimitsBox2D with min and max corners specified by p1 and p2

public static LimitsBox2D Create(
Position2D p1,
Position2D p2
);

Parameters

p1
p2

Return Value

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace | LimitsBox2D.Create Overload List


Equals Method

AVEVA Geometry .NET Public Interface

LimitsBox2D.Equals Method

Same LimitsBox2D, within tolerance

Overload List

Same LimitsBox2D, within tolerance

public abstract bool Equals(LimitsBox2D);

Same LimitsBox2D, within tolerance

public override bool Equals(object);

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D.Equals Method (LimitsBox2D)

Same LimitsBox2D, within tolerance

public abstract bool Equals(
LimitsBox2D limit
);

Parameters

limit

Return Value

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace | LimitsBox2D.Equals Overload List


LimitsBox2D.Equals Method (Object)

Same LimitsBox2D, within tolerance

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace | LimitsBox2D.Equals Overload List


LimitsBox2D.ExpandBy Method

Expand LimitsBox by val in X and Y direction about centre

public abstract void ExpandBy(
double val
);

Parameters

val

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D.ExpandToInclude Method

Expand LimitsBox to include pos

public abstract void ExpandToInclude(
Position2D pos
);

Parameters

pos

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D.Intersection Method

Returns LimitsBox2D which consists of the overlap of the two LimitsBoxes

public abstract LimitsBox2D Intersection(
LimitsBox2D box
);

Parameters

box

Return Value

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D.Intersects Method

Returns true if limits boxes intersect

public abstract bool Intersects(
LimitsBox2D box
);

Parameters

box

Return Value

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D.Merge Method

Return LimitsBox2D that is the combination ot the 2 LimitsBoxes

public abstract LimitsBox2D Merge(
LimitsBox2D box
);

Parameters

box

Return Value

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D.ToString Method

Returns LimitsBox2D property values in a string

public abstract string ToString();

Return Value

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D Operators

The operators of the LimitsBox2D class are listed below. For a complete list of LimitsBox2D class members, see the LimitsBox2D Members topic.

Public Static Operators

Equality Operator | Same LimitsBox2D within tolerance
Inequality Operator | Not same LimitsBox2D

See Also

LimitsBox2D Class | LimitsBox2D Members | Aveva.Pdms.Geometry Namespace


LimitsBox2D Equality Operator

Same LimitsBox2D within tolerance

public static bool operator ==(
LimitsBox2D t1,
LimitsBox2D t2
);

Parameters

t1
t2

Return Value

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


LimitsBox2D Inequality Operator

Not same LimitsBox2D

public static bool operator !=(
LimitsBox2D t1,
LimitsBox2D t2
);

Parameters

t1
t2

Return Value

See Also

LimitsBox2D Class | Aveva.Pdms.Geometry Namespace


Line Class

Summary description for Line.

For a list of all members of this type, see Line Members.

System.Object
Aveva.Pdms.Geometry.Line

public abstract class Line

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

Line Members | Aveva.Pdms.Geometry Namespace


Line Members

Line overview

Public Static Methods

Create Overloaded. Null Constructor

Public Static Operators

Equality Operator | Same Line
Inequality Operator | Not Same Line

Public Instance Properties

End | [get] Returns Null if this is an infinite line [set] Setting the end position turns an unbounded line into a semi-bounded line, and a semi-bounded-with-start line into a bounded line
Start | [get] Returns Null if this is an infinite line [set] Setting the start position turns an unbounded line into a semi-bounded line, and a semi-bounded-with-end line into a bounded line.

Public Instance Methods

Direction | Returns the direction of the line
Distance | Overloaded. Returns the minimum distance from pos
DoesOverlap | Returns true if lines overlap
DoesUnion | Returns true if lines can be unioned
Equals | Overloaded. Same line
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Intersection | Overloaded. Return intersection point of the line with Pplane plane. Returns Null if they do not intersect.
Intersections | Return intersection points of the line with Arc arc..
Intersects | Return true if lines intersect.
IsBounded | Return true if both start and end Positions are set.
IsOnLine | Returns true if p is on the line (and within the bounds if it is bounded )
IsParallel | Returns true if two lines are parallel
IsSemiBoundedAtEnd | Return true if end position is set, but start position is not.
IsSemiBoundedAtStart | Return true if start position is set, but end position is not.
Length | Returns the length of the line if it is bounded, otherwise -1
NearestPoint | Return Position on a line which is the projection of pos onto line. If the line is bounded, the nearest point may be either the start or end point if the projection is beyond the bounds.
Overlap | Returns the overlapping line of two parallel bounded lines, all position projected onto original line. If the lines are not parallel, returns Null. For unbounded lines returns the first Line.
Parallel | Overloaded. Return line which is parallel to this line and offset from it in Direction dir by amount offset
Perpendicular | Return line which is perpendicular to this line and passes through point p
Proportion | Return the Position at ratio along the line from the Start Position. ratio > 0 returns value off end of line, ratio less than zero value before start of line.Unbounded lines return Null
Reverse | Reverse the start and end positions and/or direction of the line
ToString | Returns Line property values as a string
Union | Returns the union of two parallel bounded Lines, all positions are projected onto original Line. If the lines are not parallel, returns Null. For unbounded lines returns the first Line

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line Properties

The properties of the Line class are listed below. For a complete list of Line class members, see the Line Members topic.

Public Instance Properties

End | [get] Returns Null if this is an infinite line [set] Setting the end position turns an unbounded line into a semi-bounded line, and a semi-bounded-with-start line into a bounded line
Start | [get] Returns Null if this is an infinite line [set] Setting the start position turns an unbounded line into a semi-bounded line, and a semi-bounded-with-end line into a bounded line.

See Also

Line Class | Aveva.Pdms.Geometry Namespace


End Property

AVEVA Geometry .NET Public Interface

Line.End Property

[get] Returns Null if this is an infinite line [set] Setting the end position turns an unbounded line into a semi-bounded line, and a semi-bounded-with-start line into a bounded line

public abstract Position End {get; set;}

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Start Property

AVEVA Geometry .NET Public Interface

Line.Start Property

[get] Returns Null if this is an infinite line [set] Setting the start position turns an unbounded line into a semi-bounded line, and a semi-bounded-with-end line into a bounded line.

public abstract Position Start {get; set;}

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line Methods

The methods of the Line class are listed below. For a complete list of Line class members, see the Line Members topic.

Public Static Methods

Create Overloaded. Null Constructor

Public Instance Methods

Direction | Returns the direction of the line
Distance | Overloaded. Returns the minimum distance from pos
DoesOverlap | Returns true if lines overlap
DoesUnion | Returns true if lines can be unioned
Equals | Overloaded. Same line
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Intersection | Overloaded. Return intersection point of the line with Pplane plane. Returns Null if they do not intersect.
Intersections | Return intersection points of the line with Arc arc..
Intersects | Return true if lines intersect.
IsBounded | Return true if both start and end Positions are set.
IsOnLine | Returns true if p is on the line (and within the bounds if it is bounded )
IsParallel | Returns true if two lines are parallel
IsSemiBoundedAtEnd | Return true if end position is set, but start position is not.
IsSemiBoundedAtStart | Return true if start position is set, but end position is not.
Length | Returns the length of the line if it is bounded, otherwise -1
NearestPoint | Return Position on a line which is the projection of pos onto line. If the line is bounded, the nearest point may be either the start or end point if the projection is beyond the bounds.
Overlap | Returns the overlapping line of two parallel bounded lines, all position projected onto original line. If the lines are not parallel, returns Null. For unbounded lines returns the first Line.
Parallel | Overloaded. Return line which is parallel to this line and offset from it in Direction dir by amount offset
Perpendicular | Return line which is perpendicular to this line and passes through point p
Proportion | Return the Position at ratio along the line from the Start Position. ratio > 0 returns value off end of line, ratio less than zero value before start of line.Unbounded lines return Null
Reverse | Reverse the start and end positions and/or direction of the line
ToString | Returns Line property values as a string
Union | Returns the union of two parallel bounded Lines, all positions are projected onto original Line. If the lines are not parallel, returns Null. For unbounded lines returns the first Line

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

Line.Create Method

Null Constructor

Overload List

Null Constructor

public static Line Create();

Create an unbounded Line through p in given direction. Note that Position p is not defined as either the start or end.

public static Line Create(Direction,Position);

Create a bounded Line from start to end.

public static Line Create(Position,Position);

Create a bounded Line between two coordinates

public static Line Create(double,double,double,double,double,double);

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.Create Method ()

Null Constructor

public static Line Create();

Parameters

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace | Line.Create Overload List


Line.Create Method (Direction, Position)

Create an unbounded Line through p in given direction. Note that Position p is not defined as either the start or end.

public static Line Create(
Direction dir,
Position p
);

Parameters

dir
p

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace | Line.Create Overload List


Line.Create Method (Position, Position)

Create a bounded Line from start to end.

public static Line Create(
Position start,
Position end
);

Parameters

start
end

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace | Line.Create Overload List


Line.Create Method (Double, Double, Double, Double, Double, Double)

Create a bounded Line between two coordinates

public static Line Create(
double x1,
double y1,
double z1,
double x2,
double y2,
double z2
);

Parameters

x1
y1
z1
x2
y2
z2

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace | Line.Create Overload List


Line.Direction Method

Returns the direction of the line

public abstract Direction Direction();

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Distance Method

AVEVA Geometry .NET Public Interface

Line.Distance Method

Returns the minimum distance from line

Overload List

Returns the minimum distance from line

public abstract double Distance(Line);

Returns the minimum distance from pos

public abstract double Distance(Position);

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.Distance Method (Line)

Returns the minimum distance from line

public abstract double Distance(
Line line
);

Parameters

line

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace | Line.Distance Overload List


Line.Distance Method (Position)

Returns the minimum distance from pos

public abstract double Distance(
Position pos
);

Parameters

pos

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace | Line.Distance Overload List


Line.DoesOverlap Method

Returns true if lines overlap

public abstract bool DoesOverlap(
Line l1
);

Parameters

l1

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.DoesUnion Method

Returns true if lines can be unioned

public abstract bool DoesUnion(
Line l1
);

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Equals Method

AVEVA Geometry .NET Public Interface

Line.Equals Method

Same line

Overload List

Same line

public abstract bool Equals(Line);

Same line

public override bool Equals(object);

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.Equals Method (Line)

Same line

public abstract bool Equals(
Line line
);

Parameters

line

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace | Line.Equals Overload List


Line.Equals Method (Object)

Same line

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace | Line.Equals Overload List


Line.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Intersection Method

AVEVA Geometry .NET Public Interface

Line.Intersection Method

Return intersection point of two lines. Returns Null if they do not intersect.

Overload List

Return intersection point of two lines. Returns Null if they do not intersect.

public abstract Position Intersection(Line);

Return intersection point of the line with Pplane plane. Returns Null if they do not intersect.

public abstract Position Intersection(Plane);

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.Intersection Method (Line)

Return intersection point of two lines. Returns Null if they do not intersect.

public abstract Position Intersection(
Line line
);

Parameters

line

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace | Line.Intersection Overload List


Line.Intersection Method (Plane)

Return intersection point of the line with Pplane plane. Returns Null if they do not intersect.

public abstract Position Intersection(
Plane plane
);

Parameters

plane

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace | Line.Intersection Overload List


Line.Intersections Method

Return intersection points of the line with Arc arc..

public abstract Position[] Intersections(
Arc arc
);

Parameters

arc

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.Intersects Method

Return true if lines intersect.

public abstract bool Intersects(
Line line
);

Parameters

line

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.IsBounded Method

Return true if both start and end Positions are set.

public abstract bool IsBounded();

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.IsOnLine Method

Returns true if p is on the line (and within the bounds if it is bounded )

public abstract bool IsOnLine(
Position p
);

Parameters

p

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.IsParallel Method

Returns true if two lines are parallel

public abstract bool IsParallel(
Line line
);

Parameters

line

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.IsSemiBoundedAtEnd Method

Return true if end position is set, but start position is not.

public abstract bool IsSemiBoundedAtEnd();

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.IsSemiBoundedAtStart Method

Return true if start position is set, but end position is not.

public abstract bool IsSemiBoundedAtStart();

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.Length Method

Returns the length of the line if it is bounded, otherwise -1

public abstract double Length();

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.NearestPoint Method

Return Position on a line which is the projection of pos onto line. If the line is bounded, the nearest point may be either the start or end point if the projection is beyond the bounds.

public abstract Position NearestPoint(
Position pos
);

Parameters

pos

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.Overlap Method

Returns the overlapping line of two parallel bounded lines, all position projected onto original line. If the lines are not parallel, returns Null. For unbounded lines returns the first Line.

public abstract Line Overlap(
Line line
);

Parameters

line

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Parallel Method

AVEVA Geometry .NET Public Interface

Line.Parallel Method

Return line which is parallel to this line and offset from it in Direction dir by amount offset

Overload List

Return line which is parallel to this line and offset from it in Direction dir by amount offset

public abstract Line Parallel(Direction,double);

Return line which is parallel to this line and passes through point p

public abstract Line Parallel(Position);

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.Parallel Method (Direction, Double)

Return line which is parallel to this line and offset from it in Direction dir by amount offset

public abstract Line Parallel(
Direction dir,
double offset
);

Parameters

dir
offset

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace | Line.Parallel Overload List


Line.Parallel Method (Position)

Return line which is parallel to this line and passes through point p

public abstract Line Parallel(
Position p
);

Parameters

p

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace | Line.Parallel Overload List


Line.Perpendicular Method

Return line which is perpendicular to this line and passes through point p

public abstract Line Perpendicular(
Position p
);

Parameters

p

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.Proportion Method

Return the Position at ratio along the line from the Start Position. ratio > 0 returns value off end of line, ratio less than zero value before start of line.Unbounded lines return Null

public abstract Position Proportion(
double ratio
);

Parameters

ratio

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.Reverse Method

Reverse the start and end positions and/or direction of the line

public abstract void Reverse();

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.ToString Method

Returns Line property values as a string

public abstract string ToString();

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line.Union Method

Returns the union of two parallel bounded Lines, all positions are projected onto original Line. If the lines are not parallel, returns Null. For unbounded lines returns the first Line

public abstract Line Union(
Line line
);

Parameters

line

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line Operators

The operators of the Line class are listed below. For a complete list of Line class members, see the Line Members topic.

Public Static Operators

Equality Operator | Same Line
Inequality Operator | Not Same Line

See Also

Line Class | Line Members | Aveva.Pdms.Geometry Namespace


Line Equality Operator

Same Line

public static bool operator ==(
Line t1,
Line t2
);

Parameters

t1
t2

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line Inequality Operator

Not Same Line

public static bool operator !=(
Line t1,
Line t2
);

Parameters

t1
t2

Return Value

See Also

Line Class | Aveva.Pdms.Geometry Namespace


Line2D Class

Summary description for Line2D.

For a list of all members of this type, see Line2D Members.

System.Object
Aveva.Pdms.Geometry.Line2D

public abstract class Line2D

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

Line2D Members | Aveva.Pdms.Geometry Namespace


Line2D Members

Line2D overview

Public Static Methods

Create Overloaded. Create Line2D (unset value)

Public Static Operators

Equality Operator | /// Same Line2D
Inequality Operator | Not same Line2D

Public Instance Properties

Direction | Direction of line
End | [get] Returns Unset Position if this is an infinite line
Start | [get] Returns Unset Position if this is an infinite line

Public Instance Methods

Distance | Overloaded. Returns the minimum distance from pos
Equals | Overloaded. Same Line2D
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Intersects | Return true if lines intersect.
IsBounded | Return true if start or end Positions are set
IsOnLine | Returns true if p is on the line (and within the bounds if it is bounded )
IsSemiBoundedAtEnd | Return true if end position is set, but start position is not.
IsSemiBoundedAtStart | Return true if start position is set, but end position is not.
Length | Returns the length of the Line2D if it is bounded, otherwise -1
NearestPoint | Return Position2D on a line which is the projection of p onto line. Note that if the line is bounded, the nearest point may be either the start or end point if the projection is beyond the bounds.
Proportion | Return the Position2D at ratio along the line from the Start Position2D. ratio > 0 returns value off end of line, ratio less than 0 return value before start of line. Unbounded lines return Unset Position2D
ToString | Returns Line2D property values in a string

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D Properties

The properties of the Line2D class are listed below. For a complete list of Line2D class members, see the Line2D Members topic.

Public Instance Properties

Direction | Direction of line
End | [get] Returns Unset Position if this is an infinite line
Start | [get] Returns Unset Position if this is an infinite line

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Direction Property

AVEVA Geometry .NET Public Interface

Line2D.Direction Property

Direction of line

public abstract Direction2D Direction {get; set;}

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


End Property

AVEVA Geometry .NET Public Interface

Line2D.End Property

[get] Returns Unset Position if this is an infinite line

public abstract Position2D End {get; set;}

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Start Property

AVEVA Geometry .NET Public Interface

Line2D.Start Property

[get] Returns Unset Position if this is an infinite line

public abstract Position2D Start {get; set;}

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D Methods

The methods of the Line2D class are listed below. For a complete list of Line2D class members, see the Line2D Members topic.

Public Static Methods

Create Overloaded. Create Line2D (unset value)

Public Instance Methods

Distance | Overloaded. Returns the minimum distance from pos
Equals | Overloaded. Same Line2D
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Intersects | Return true if lines intersect.
IsBounded | Return true if start or end Positions are set
IsOnLine | Returns true if p is on the line (and within the bounds if it is bounded )
IsSemiBoundedAtEnd | Return true if end position is set, but start position is not.
IsSemiBoundedAtStart | Return true if start position is set, but end position is not.
Length | Returns the length of the Line2D if it is bounded, otherwise -1
NearestPoint | Return Position2D on a line which is the projection of p onto line. Note that if the line is bounded, the nearest point may be either the start or end point if the projection is beyond the bounds.
Proportion | Return the Position2D at ratio along the line from the Start Position2D. ratio > 0 returns value off end of line, ratio less than 0 return value before start of line. Unbounded lines return Unset Position2D
ToString | Returns Line2D property values in a string

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

Line2D.Create Method

Create Line2D (unset value)

Overload List

Create Line2D (unset value)

public static Line2D Create();

Create an unbounded Line2D through p in given direction

public static Line2D Create(Direction2D,Position2D);

Create a bounded Line2D from start to end.

public static Line2D Create(Position2D,Position2D);

Create a Line2D between two coordinates

public static Line2D Create(double,double,double,double);

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D.Create Method ()

Create Line2D (unset value)

public static Line2D Create();

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace | Line2D.Create Overload List


Line2D.Create Method (Direction2D, Position2D)

Create an unbounded Line2D through p in given direction

public static Line2D Create(
Direction2D dir,
Position2D p
);

Parameters

dir
p

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace | Line2D.Create Overload List


Line2D.Create Method (Position2D, Position2D)

Create a bounded Line2D from start to end.

public static Line2D Create(
Position2D start,
Position2D end
);

Parameters

start
end

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace | Line2D.Create Overload List


Line2D.Create Method (Double, Double, Double, Double)

Create a Line2D between two coordinates

public static Line2D Create(
double x1,
double y1,
double x2,
double y2
);

Parameters

x1
y1
x2
y2

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace | Line2D.Create Overload List


Distance Method

AVEVA Geometry .NET Public Interface

Line2D.Distance Method

Returns the minimum distance from line

Overload List

Returns the minimum distance from line

public abstract double Distance(Line2D);

Returns the minimum distance from pos

public abstract double Distance(Position2D);

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D.Distance Method (Line2D)

Returns the minimum distance from line

public abstract double Distance(
Line2D line
);

Parameters

line

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace | Line2D.Distance Overload List


Line2D.Distance Method (Position2D)

Returns the minimum distance from pos

public abstract double Distance(
Position2D pos
);

Parameters

pos

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace | Line2D.Distance Overload List


Equals Method

AVEVA Geometry .NET Public Interface

Line2D.Equals Method

Same Line2D

Overload List

Same Line2D

public abstract bool Equals(Line2D);

Same Line2D

public override bool Equals(object);

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D.Equals Method (Line2D)

Same Line2D

public abstract bool Equals(
Line2D line
);

Parameters

line

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace | Line2D.Equals Overload List


Line2D.Equals Method (Object)

Same Line2D

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace | Line2D.Equals Overload List


Line2D.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D.Intersects Method

Return true if lines intersect.

public abstract bool Intersects(
Line2D line
);

Parameters

line

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D.IsBounded Method

Return true if start or end Positions are set

public abstract bool IsBounded();

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D.IsOnLine Method

Returns true if p is on the line (and within the bounds if it is bounded )

public abstract bool IsOnLine(
Position2D p
);

Parameters

p

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D.IsSemiBoundedAtEnd Method

Return true if end position is set, but start position is not.

public abstract bool IsSemiBoundedAtEnd();

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D.IsSemiBoundedAtStart Method

Return true if start position is set, but end position is not.

public abstract bool IsSemiBoundedAtStart();

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D.Length Method

Returns the length of the Line2D if it is bounded, otherwise -1

public abstract double Length();

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D.NearestPoint Method

Return Position2D on a line which is the projection of p onto line. Note that if the line is bounded, the nearest point may be either the start or end point if the projection is beyond the bounds.

public abstract Position2D NearestPoint(
Position2D p
);

Parameters

p

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D.Proportion Method

Return the Position2D at ratio along the line from the Start Position2D. ratio > 0 returns value off end of line, ratio less than 0 return value before start of line. Unbounded lines return Unset Position2D

public abstract Position2D Proportion(
double ratio
);

Parameters

ratio

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D.ToString Method

Returns Line2D property values in a string

public abstract string ToString();

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D Operators

The operators of the Line2D class are listed below. For a complete list of Line2D class members, see the Line2D Members topic.

Public Static Operators

Equality Operator | /// Same Line2D
Inequality Operator | Not same Line2D

See Also

Line2D Class | Line2D Members | Aveva.Pdms.Geometry Namespace


Line2D Equality Operator

/// Same Line2D

public static bool operator ==(
Line2D t1,
Line2D t2
);

Parameters

t1
t2

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


Line2D Inequality Operator

Not same Line2D

public static bool operator !=(
Line2D t1,
Line2D t2
);

Parameters

t1
t2

Return Value

See Also

Line2D Class | Aveva.Pdms.Geometry Namespace


LinearGrid Class

Summary description for PlantGrid.

For a list of all members of this type, see LinearGrid Members.

System.Object
Aveva.Pdms.Geometry.LinearGrid

public abstract class LinearGrid

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

LinearGrid Members | Aveva.Pdms.Geometry Namespace


LinearGrid Members

LinearGrid overview

Public Static Methods

Create Overloaded. Create LinearGrid (Unset)

Public Static Operators

Equality Operator | Same LinearGrid
Inequality Operator | Not Same LinearGrid

Public Instance Properties

Orientation | Orientation of the grid
Position | Origin of the grid
XSpacing | Spacing between grid lines in X direction
YSpacing | Spacing between lines in Y direction

Public Instance Methods

Equals | Overloaded. Same LinearGrid
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
GridPoint | Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin.
internalCreate | Overloaded. Create a LinearGrid
Offset2D | Return the 2D position mapped onto the grid plane in terms of an XY offset from the grid plane origin
Plane | Return Plane of the grid
Snap | Overloaded. Returns nearest grid intersection point to the intersection of line with the plane of the grid
SnapToCentre | Overloaded. Return the nearest mesh cell centre point to to the intersection of line with the plane of the grid
ToString | Returns LinearGrid property values in a string

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


LinearGrid Properties

The properties of the LinearGrid class are listed below. For a complete list of LinearGrid class members, see the LinearGrid Members topic.

Public Instance Properties

Orientation | Orientation of the grid
Position | Origin of the grid
XSpacing | Spacing between grid lines in X direction
YSpacing | Spacing between lines in Y direction

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


Orientation Property

AVEVA Geometry .NET Public Interface

LinearGrid.Orientation Property

Orientation of the grid

public abstract Orientation Orientation {get; set;}

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


Position Property

AVEVA Geometry .NET Public Interface

LinearGrid.Position Property

Origin of the grid

public abstract Position Position {get; set;}

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


XSpacing Property

AVEVA Geometry .NET Public Interface

LinearGrid.XSpacing Property

Spacing between grid lines in X direction

public abstract double XSpacing {get; set;}

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


YSpacing Property

AVEVA Geometry .NET Public Interface

LinearGrid.YSpacing Property

Spacing between lines in Y direction

public abstract double YSpacing {get; set;}

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


LinearGrid Methods

The methods of the LinearGrid class are listed below. For a complete list of LinearGrid class members, see the LinearGrid Members topic.

Public Static Methods

Create Overloaded. Create LinearGrid (Unset)

Public Instance Methods

Equals | Overloaded. Same LinearGrid
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
GridPoint | Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin.
internalCreate | Overloaded. Create a LinearGrid
Offset2D | Return the 2D position mapped onto the grid plane in terms of an XY offset from the grid plane origin
Plane | Return Plane of the grid
Snap | Overloaded. Returns nearest grid intersection point to the intersection of line with the plane of the grid
SnapToCentre | Overloaded. Return the nearest mesh cell centre point to to the intersection of line with the plane of the grid
ToString | Returns LinearGrid property values in a string

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

LinearGrid.Create Method

Create LinearGrid (Unset)

Overload List

Create LinearGrid (Unset)

public static LinearGrid Create();

Create a LinearGrid

public static LinearGrid Create(Position,Orientation,double,double);

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


LinearGrid.Create Method ()

Create LinearGrid (Unset)

public static LinearGrid Create();

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace | LinearGrid.Create Overload List


LinearGrid.Create Method (Position, Orientation, Double, Double)

Create a LinearGrid

public static LinearGrid Create(
Position pos,
Orientation ori,
double xspacing,
double yspacing
);

Parameters

pos
ori
xspacing
yspacing

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace | LinearGrid.Create Overload List


Equals Method

AVEVA Geometry .NET Public Interface

LinearGrid.Equals Method

Same LinearGrid

Overload List

Same LinearGrid

public abstract bool Equals(LinearGrid);

Same LinearGrid

public override bool Equals(object);

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


LinearGrid.Equals Method (LinearGrid)

Same LinearGrid

public abstract bool Equals(
LinearGrid lg
);

Parameters

lg

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace | LinearGrid.Equals Overload List


LinearGrid.Equals Method (Object)

Same LinearGrid

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace | LinearGrid.Equals Overload List


LinearGrid.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


LinearGrid.GridPoint Method

Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin.

public abstract Position GridPoint(
int ix,
int iy
);

Parameters

ix
iy

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


internalCreate Method

AVEVA Geometry .NET Public Interface

LinearGrid.internalCreate Method

Create LinearGrid (Unset)

Overload List

Create LinearGrid (Unset)

public abstract LinearGrid internalCreate();

Create a LinearGrid

public abstract LinearGrid internalCreate(Position,Orientation,double,double);

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


LinearGrid.internalCreate Method ()

Create LinearGrid (Unset)

public abstract LinearGrid internalCreate();

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace | LinearGrid.internalCreate Overload List


LinearGrid.internalCreate Method (Position, Orientation, Double, Double)

Create a LinearGrid

public abstract LinearGrid internalCreate(
Position pos,
Orientation ori,
double xspacing,
double yspacing
);

Parameters

pos
ori
xspacing
yspacing

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace | LinearGrid.internalCreate Overload List


LinearGrid.Offset2D Method

Return the 2D position mapped onto the grid plane in terms of an XY offset from the grid plane origin

public abstract Position2D Offset2D(
Position pos
);

Parameters

pos

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


LinearGrid.Plane Method

Return Plane of the grid

public abstract Plane Plane();

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


Snap Method

AVEVA Geometry .NET Public Interface

LinearGrid.Snap Method

Returns nearest grid intersection point to the intersection of line with the plane of the grid

Overload List

Returns nearest grid intersection point to the intersection of line with the plane of the grid

public abstract Position Snap(Line);

Returns nearest grid intersection point to pos

public abstract Position Snap(Position);

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


LinearGrid.Snap Method (Line)

Returns nearest grid intersection point to the intersection of line with the plane of the grid

public abstract Position Snap(
Line line
);

Parameters

line

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace | LinearGrid.Snap Overload List


LinearGrid.Snap Method (Position)

Returns nearest grid intersection point to pos

public abstract Position Snap(
Position pos
);

Parameters

pos

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace | LinearGrid.Snap Overload List


SnapToCentre Method

AVEVA Geometry .NET Public Interface

LinearGrid.SnapToCentre Method

Return the nearest mesh cell centre point to to the intersection of line with the plane of the grid

Overload List

Return the nearest mesh cell centre point to to the intersection of line with the plane of the grid

public abstract Position SnapToCentre(Line);

Return the nearest mesh cell centre point to pos in the grid plane

public abstract Position SnapToCentre(Position);

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


LinearGrid.SnapToCentre Method (Line)

Return the nearest mesh cell centre point to to the intersection of line with the plane of the grid

public abstract Position SnapToCentre(
Line line
);

Parameters

line

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace | LinearGrid.SnapToCentre Overload List


LinearGrid.SnapToCentre Method (Position)

Return the nearest mesh cell centre point to pos in the grid plane

public abstract Position SnapToCentre(
Position pos
);

Parameters

pos

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace | LinearGrid.SnapToCentre Overload List


LinearGrid.ToString Method

Returns LinearGrid property values in a string

public abstract string ToString();

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


LinearGrid Operators

The operators of the LinearGrid class are listed below. For a complete list of LinearGrid class members, see the LinearGrid Members topic.

Public Static Operators

Equality Operator | Same LinearGrid
Inequality Operator | Not Same LinearGrid

See Also

LinearGrid Class | LinearGrid Members | Aveva.Pdms.Geometry Namespace


LinearGrid Equality Operator

Same LinearGrid

public static bool operator ==(
LinearGrid lg1,
LinearGrid lg2
);

Parameters

lg1
lg2

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


LinearGrid Inequality Operator

Not Same LinearGrid

public static bool operator !=(
LinearGrid lg1,
LinearGrid lg2
);

Parameters

lg1
lg2

Return Value

See Also

LinearGrid Class | Aveva.Pdms.Geometry Namespace


LinearGrid2D Class

Summary description for LinearGrid2D.

For a list of all members of this type, see LinearGrid2D Members.

System.Object
Aveva.Pdms.Geometry.LinearGrid2D

public abstract class LinearGrid2D

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

LinearGrid2D Members | Aveva.Pdms.Geometry Namespace


LinearGrid2D Members

LinearGrid2D overview

Public Static Methods

Create Overloaded. Create LinearGrid2D

Public Static Operators

Equality Operator | Same LinearGrid2D within tolerance
Inequality Operator | Not same LinearGrid2D

Public Instance Properties

Position | Origin of the grid
XSpacing | Spacing between grid lines in X direction
YSpacing | Spacing between grid lines in Y direction

Public Instance Methods

Equals | Overloaded. Same LinearGrid2D
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
GridPoint | Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin.
Snap | Returns nearest grid intersection point to pos
SnapToCentre | Return the nearest mesh cell centre point to pos in the grid plane
ToString | Returns LinearGrid2D property values in a string

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace


LinearGrid2D Properties

The properties of the LinearGrid2D class are listed below. For a complete list of LinearGrid2D class members, see the LinearGrid2D Members topic.

Public Instance Properties

Position | Origin of the grid
XSpacing | Spacing between grid lines in X direction
YSpacing | Spacing between grid lines in Y direction

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace


Position Property

AVEVA Geometry .NET Public Interface

LinearGrid2D.Position Property

Origin of the grid

public abstract Position2D Position {get; set;}

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace


XSpacing Property

AVEVA Geometry .NET Public Interface

LinearGrid2D.XSpacing Property

Spacing between grid lines in X direction

public abstract double XSpacing {get; set;}

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace


YSpacing Property

AVEVA Geometry .NET Public Interface

LinearGrid2D.YSpacing Property

Spacing between grid lines in Y direction

public abstract double YSpacing {get; set;}

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace


LinearGrid2D Methods

The methods of the LinearGrid2D class are listed below. For a complete list of LinearGrid2D class members, see the LinearGrid2D Members topic.

Public Static Methods

Create Overloaded. Create LinearGrid2D

Public Instance Methods

Equals | Overloaded. Same LinearGrid2D
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
GridPoint | Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin.
Snap | Returns nearest grid intersection point to pos
SnapToCentre | Return the nearest mesh cell centre point to pos in the grid plane
ToString | Returns LinearGrid2D property values in a string

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

LinearGrid2D.Create Method

Create LinearGrid2D

Overload List

Create LinearGrid2D

public static LinearGrid2D Create();

Create a LinearGrid2D

public static LinearGrid2D Create(Position2D,double,double);

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace


LinearGrid2D.Create Method ()

Create LinearGrid2D

public static LinearGrid2D Create();

Return Value

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace | LinearGrid2D.Create Overload List


LinearGrid2D.Create Method (Position2D, Double, Double)

Create a LinearGrid2D

public static LinearGrid2D Create(
Position2D pos,
double xspacing,
double yspacing
);

Parameters

pos
xspacing
yspacing

Return Value

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace | LinearGrid2D.Create Overload List


Equals Method

AVEVA Geometry .NET Public Interface

LinearGrid2D.Equals Method

Same LinearGrid2D

Overload List

Same LinearGrid2D

public abstract bool Equals(LinearGrid2D);

Same LinearGrid2D

public override bool Equals(object);

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace


LinearGrid2D.Equals Method (LinearGrid2D)

Same LinearGrid2D

public abstract bool Equals(
LinearGrid2D lg
);

Parameters

lg

Return Value

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace | LinearGrid2D.Equals Overload List


LinearGrid2D.Equals Method (Object)

Same LinearGrid2D

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace | LinearGrid2D.Equals Overload List


LinearGrid2D.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace


LinearGrid2D.GridPoint Method

Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin.

public abstract Position2D GridPoint(
int ix,
int iy
);

Parameters

ix
iy

Return Value

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace


LinearGrid2D.Snap Method

Returns nearest grid intersection point to pos

public abstract Position2D Snap(
Position2D pos
);

Parameters

pos

Return Value

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace


LinearGrid2D.SnapToCentre Method

Return the nearest mesh cell centre point to pos in the grid plane

public abstract Position2D SnapToCentre(
Position2D pos
);

Parameters

pos

Return Value

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace


LinearGrid2D.ToString Method

Returns LinearGrid2D property values in a string

public abstract string ToString();

Return Value

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace


LinearGrid2D Operators

The operators of the LinearGrid2D class are listed below. For a complete list of LinearGrid2D class members, see the LinearGrid2D Members topic.

Public Static Operators

Equality Operator | Same LinearGrid2D within tolerance
Inequality Operator | Not same LinearGrid2D

See Also

LinearGrid2D Class | LinearGrid2D Members | Aveva.Pdms.Geometry Namespace


LinearGrid2D Equality Operator

Same LinearGrid2D within tolerance

public static bool operator ==(
LinearGrid2D lg1,
LinearGrid2D lg2
);

Parameters

lg1
lg2

Return Value

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace


LinearGrid2D Inequality Operator

Not same LinearGrid2D

public static bool operator !=(
LinearGrid2D lg1,
LinearGrid2D lg2
);

Parameters

lg1
lg2

Return Value

See Also

LinearGrid2D Class | Aveva.Pdms.Geometry Namespace


Orientation Class

Summary description for Orientation.

For a list of all members of this type, see Orientation Members.

System.Object
Aveva.Pdms.Geometry.Orientation

public abstract class Orientation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

Orientation Members | Aveva.Pdms.Geometry Namespace


Orientation Members

Orientation overview

Public Static Methods

Create Overloaded. Create a default Orientation

Public Static Operators

Equality Operator | Same Orientation
Inequality Operator | Not Same Orientation

Public Instance Properties

AboutX | Rotation angle about X
AboutY | Rotation angle about Y
AboutZ | Rotation angle about Z

Public Instance Methods

Absolute | Return absolute orientation from local Orientation ori.
AbsoluteDirection | Return absolute Direction from local Direction dir.
AbsolutePosition | Return absolute Position from local Position pos
Equals | Overloaded. Same Orientation
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Local | Return local Orientation from absolute Orientation ori
LocalDirection | Return local Direction from absolute Direction dir
LocalPosition | Return local Position from absolute Position pos
Rotate | Overloaded. Rotate the orientation by degrees about global Direction dir
RotateLocal | Overloaded. Rotate around local Direction ldir1 so that local Direction ldir2 is as close as possible to absolute Direction adir. Return the angle of rotation
RotateTo | Rotate about axis1 so that axis2 points in given direction, and return the angle of rotation
ToString | Returns Orientation in PDMS Format
XDir | Returns the X component as a Direction
YDir | Returns the Y component as a Direction
ZDir | Returns the Z component as a Direction

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation Properties

The properties of the Orientation class are listed below. For a complete list of Orientation class members, see the Orientation Members topic.

Public Instance Properties

AboutX | Rotation angle about X
AboutY | Rotation angle about Y
AboutZ | Rotation angle about Z

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


AboutX Property

AVEVA Geometry .NET Public Interface

Orientation.AboutX Property

Rotation angle about X

public abstract double AboutX {get;}

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


AboutY Property

AVEVA Geometry .NET Public Interface

Orientation.AboutY Property

Rotation angle about Y

public abstract double AboutY {get;}

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


AboutZ Property

AVEVA Geometry .NET Public Interface

Orientation.AboutZ Property

Rotation angle about Z

public abstract double AboutZ {get;}

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation Methods

The methods of the Orientation class are listed below. For a complete list of Orientation class members, see the Orientation Members topic.

Public Static Methods

Create Overloaded. Create a default Orientation

Public Instance Methods

Absolute | Return absolute orientation from local Orientation ori.
AbsoluteDirection | Return absolute Direction from local Direction dir.
AbsolutePosition | Return absolute Position from local Position pos
Equals | Overloaded. Same Orientation
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Local | Return local Orientation from absolute Orientation ori
LocalDirection | Return local Direction from absolute Direction dir
LocalPosition | Return local Position from absolute Position pos
Rotate | Overloaded. Rotate the orientation by degrees about global Direction dir
RotateLocal | Overloaded. Rotate around local Direction ldir1 so that local Direction ldir2 is as close as possible to absolute Direction adir. Return the angle of rotation
RotateTo | Rotate about axis1 so that axis2 points in given direction, and return the angle of rotation
ToString | Returns Orientation in PDMS Format
XDir | Returns the X component as a Direction
YDir | Returns the Y component as a Direction
ZDir | Returns the Z component as a Direction

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation.Absolute Method

Return absolute orientation from local Orientation ori.

public abstract Orientation Absolute(
Orientation ori
);

Parameters

ori

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation.AbsoluteDirection Method

Return absolute Direction from local Direction dir.

public abstract Direction AbsoluteDirection(
Direction dir
);

Parameters

dir

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation.AbsolutePosition Method

Return absolute Position from local Position pos

public abstract Position AbsolutePosition(
Position pos
);

Parameters

pos

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

Orientation.Create Method

Create a default Orientation

Overload List

Create a default Orientation

public static Orientation Create();

Create an Orientation

public static Orientation Create(Direction,Direction);

public static Orientation Create(string);

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation.Create Method ()

Create a default Orientation

public static Orientation Create();

Parameters

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace | Orientation.Create Overload List


Orientation.Create Method (Direction, Direction)

Create an Orientation

public static Orientation Create(
Direction xDir,
Direction yDir
);

Parameters

xDir
yDir

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace | Orientation.Create Overload List


Orientation.Create Method (String)

public static Orientation Create(
string oristring
);

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace | Orientation.Create Overload List


Equals Method

AVEVA Geometry .NET Public Interface

Orientation.Equals Method

Same Orientation

Overload List

Same Orientation

public abstract bool Equals(Orientation);

Same Orientation

public override bool Equals(object);

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation.Equals Method (Orientation)

Same Orientation

public abstract bool Equals(
Orientation orientation
);

Parameters

orientation

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace | Orientation.Equals Overload List


Orientation.Equals Method (Object)

Same Orientation

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace | Orientation.Equals Overload List


Orientation.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation.Local Method

Return local Orientation from absolute Orientation ori

public abstract Orientation Local(
Orientation ori
);

Parameters

ori

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation.LocalDirection Method

Return local Direction from absolute Direction dir

public abstract Direction LocalDirection(
Direction dir
);

Parameters

dir

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation.LocalPosition Method

Return local Position from absolute Position pos

public abstract Position LocalPosition(
Position pos
);

Parameters

pos

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Rotate Method

AVEVA Geometry .NET Public Interface

Orientation.Rotate Method

Rotate the orientation by degrees about global Axis axis

Overload List

Rotate the orientation by degrees about global Axis axis

public abstract void Rotate(Axis,double);

Rotate the orientation by degrees about global Direction dir

public abstract void Rotate(Direction,double);

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation.Rotate Method (Axis, Double)

Rotate the orientation by degrees about global Axis axis

public abstract void Rotate(
Axis axis,
double degrees
);

Parameters

axis
degrees

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace | Orientation.Rotate Overload List


Orientation.Rotate Method (Direction, Double)

Rotate the orientation by degrees about global Direction dir

public abstract void Rotate(
Direction dir,
double degrees
);

Parameters

dir
degrees

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace | Orientation.Rotate Overload List


RotateLocal Method

AVEVA Geometry .NET Public Interface

Orientation.RotateLocal Method

Rotate the orientation by degrees about local Axis axis

Overload List

Rotate the orientation by degrees about local Axis axis

public abstract void RotateLocal(Axis,double);

Rotate around local Direction ldir1 so that local Direction ldir2 is as close as possible to absolute Direction adir. Return the angle of rotation

public abstract double RotateLocal(Direction,Direction,Direction);

Rotate the orientation by degrees about local Direction dir

public abstract void RotateLocal(Direction,double);

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation.RotateLocal Method (Axis, Double)

Rotate the orientation by degrees about local Axis axis

public abstract void RotateLocal(
Axis axis,
double degrees
);

Parameters

axis
degrees

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace | Orientation.RotateLocal Overload List


Orientation.RotateLocal Method (Direction, Direction, Direction)

Rotate around local Direction ldir1 so that local Direction ldir2 is as close as possible to absolute Direction adir. Return the angle of rotation

public abstract double RotateLocal(
Direction ldir1,
Direction ldir2,
Direction adir
);

Parameters

ldir1
ldir2
adir

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace | Orientation.RotateLocal Overload List


Orientation.RotateLocal Method (Direction, Double)

Rotate the orientation by degrees about local Direction dir

public abstract void RotateLocal(
Direction dir,
double degrees
);

Parameters

dir
degrees

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace | Orientation.RotateLocal Overload List


Orientation.RotateTo Method

Rotate about axis1 so that axis2 points in given direction, and return the angle of rotation

public abstract double RotateTo(
Axis axis1,
Axis axis2,
Direction dir
);

Parameters

axis1
axis2
dir

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation.ToString Method

Returns Orientation in PDMS Format

public abstract string ToString();

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation.XDir Method

Returns the X component as a Direction

public abstract Direction XDir();

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation.YDir Method

Returns the Y component as a Direction

public abstract Direction YDir();

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation.ZDir Method

Returns the Z component as a Direction

public abstract Direction ZDir();

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation Operators

The operators of the Orientation class are listed below. For a complete list of Orientation class members, see the Orientation Members topic.

Public Static Operators

Equality Operator | Same Orientation
Inequality Operator | Not Same Orientation

See Also

Orientation Class | Orientation Members | Aveva.Pdms.Geometry Namespace


Orientation Equality Operator

Same Orientation

public static bool operator ==(
Orientation p1,
Orientation p2
);

Parameters

p1
p2

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Orientation Inequality Operator

Not Same Orientation

public static bool operator !=(
Orientation p1,
Orientation p2
);

Parameters

p1
p2

Return Value

See Also

Orientation Class | Aveva.Pdms.Geometry Namespace


Plane Class

Summary description for Plane.

For a list of all members of this type, see Plane Members.

System.Object
Aveva.Pdms.Geometry.Plane

public abstract class Plane

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

Plane Members | Aveva.Pdms.Geometry Namespace


Plane Members

Plane overview

Public Static Methods

Create Overloaded. Create default plane

Public Static Operators

Equality Operator | Same Plane, within tolerance
Inequality Operator | Not same Plane

Public Instance Properties

Orientation
Position

Public Instance Methods

Equals | Overloaded. Same Plane
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
internalCreate | Overloaded. Create a plane through pos with normal dir
Intersection | Overloaded. Returns the intersection point of this plane with pl1 and pl2. Returns Null if they do not intersect
Intersections | Returns the set of intersections with the plane and the Arc arc.
Line | Returns a line of length val along the normal of the plane
Near | Returns the nearest Position on the plane to pos
Normal | Return the Z component of the Orientation, uses standard PDMS method of obtaining X and Y components.
PointVector | Returns a PointVector positioned at the origin of the plane and along the direction of the normal of the plane
Position3D | Returns Position of pos2 offset from the plane origin
ToString | Return Plane property values as a string
Towards | Modifies the orientation so that the normal is directed towards the position pos.
XYOffset | Returns the position mapped onto the plane in terms of an XY offset from the plane origin

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane Properties

The properties of the Plane class are listed below. For a complete list of Plane class members, see the Plane Members topic.

Public Instance Properties

Orientation
Position

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Orientation Property

AVEVA Geometry .NET Public Interface

Plane.Orientation Property

public abstract Orientation Orientation {get; set;}

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Position Property

AVEVA Geometry .NET Public Interface

Plane.Position Property

public abstract Position Position {get; set;}

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane Methods

The methods of the Plane class are listed below. For a complete list of Plane class members, see the Plane Members topic.

Public Static Methods

Create Overloaded. Create default plane

Public Instance Methods

Equals | Overloaded. Same Plane
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
internalCreate | Overloaded. Create a plane through pos with normal dir
Intersection | Overloaded. Returns the intersection point of this plane with pl1 and pl2. Returns Null if they do not intersect
Intersections | Returns the set of intersections with the plane and the Arc arc.
Line | Returns a line of length val along the normal of the plane
Near | Returns the nearest Position on the plane to pos
Normal | Return the Z component of the Orientation, uses standard PDMS method of obtaining X and Y components.
PointVector | Returns a PointVector positioned at the origin of the plane and along the direction of the normal of the plane
Position3D | Returns Position of pos2 offset from the plane origin
ToString | Return Plane property values as a string
Towards | Modifies the orientation so that the normal is directed towards the position pos.
XYOffset | Returns the position mapped onto the plane in terms of an XY offset from the plane origin

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

Plane.Create Method

Create default plane

Overload List

Create default plane

public static Plane Create();

Create a plane through pos with normal dir

public static Plane Create(Direction,Position);

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane.Create Method ()

Create default plane

public static Plane Create();

Parameters

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace | Plane.Create Overload List


Plane.Create Method (Direction, Position)

Create a plane through pos with normal dir

public static Plane Create(
Direction d1,
Position pos
);

Parameters

d1
pos

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace | Plane.Create Overload List


Equals Method

AVEVA Geometry .NET Public Interface

Plane.Equals Method

Same Plane

Overload List

Same Plane

public abstract bool Equals(Plane);

Same Plane

public override bool Equals(object);

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane.Equals Method (Plane)

Same Plane

public abstract bool Equals(
Plane plane
);

Parameters

plane

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace | Plane.Equals Overload List


Plane.Equals Method (Object)

Same Plane

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace | Plane.Equals Overload List


Plane.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


internalCreate Method

AVEVA Geometry .NET Public Interface

Plane.internalCreate Method

Create default plane

Overload List

Create default plane

public abstract Plane internalCreate();

Create a plane through pos with normal dir

public abstract Plane internalCreate(Direction,Position);

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane.internalCreate Method ()

Create default plane

public abstract Plane internalCreate();

Parameters

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace | Plane.internalCreate Overload List


Plane.internalCreate Method (Direction, Position)

Create a plane through pos with normal dir

public abstract Plane internalCreate(
Direction d1,
Position pos
);

Parameters

d1
pos

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace | Plane.internalCreate Overload List


Intersection Method

AVEVA Geometry .NET Public Interface

Plane.Intersection Method

Returns the intersection of the plane with the line lin (infinitely extended )

Overload List

Returns the intersection of the plane with the line lin (infinitely extended )

public abstract Position Intersection(Line);

Returns an unbounded line, which is the intersection line of this plane with pl1. Returns Null if they do not intersect.

public abstract Line Intersection(Plane);

Returns the intersection point of this plane with pl1 and pl2. Returns Null if they do not intersect

public abstract Position Intersection(Plane,Plane);

Returns the intersection of the plane with the direction of pv.

public abstract Position Intersection(PointVector);

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane.Intersection Method (Line)

Returns the intersection of the plane with the line lin (infinitely extended )

public abstract Position Intersection(
Line lin
);

Parameters

lin

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace | Plane.Intersection Overload List


Plane.Intersection Method (Plane)

Returns an unbounded line, which is the intersection line of this plane with pl1. Returns Null if they do not intersect.

public abstract Line Intersection(
Plane pl1
);

Parameters

pl1

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace | Plane.Intersection Overload List


Plane.Intersection Method (Plane, Plane)

Returns the intersection point of this plane with pl1 and pl2. Returns Null if they do not intersect

public abstract Position Intersection(
Plane pl1,
Plane pl2
);

Parameters

pl1
pl2

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace | Plane.Intersection Overload List


Plane.Intersection Method (PointVector)

Returns the intersection of the plane with the direction of pv.

public abstract Position Intersection(
PointVector pv
);

Parameters

pv

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace | Plane.Intersection Overload List


Plane.Intersections Method

Returns the set of intersections with the plane and the Arc arc.

public abstract Position[] Intersections(
Arc arc
);

Parameters

arc

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane.Line Method

Returns a line of length val along the normal of the plane

public abstract Line Line(
double val
);

Parameters

val

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane.Near Method

Returns the nearest Position on the plane to pos

public abstract Position Near(
Position pos
);

Parameters

pos

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane.Normal Method

Return the Z component of the Orientation, uses standard PDMS method of obtaining X and Y components.

public abstract Direction Normal();

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane.PointVector Method

Returns a PointVector positioned at the origin of the plane and along the direction of the normal of the plane

public abstract PointVector PointVector();

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane.Position3D Method

Returns Position of pos2 offset from the plane origin

public abstract Position Position3D(
Position2D pos2
);

Parameters

pos2

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane.ToString Method

Return Plane property values as a string

public abstract string ToString();

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane.Towards Method

Modifies the orientation so that the normal is directed towards the position pos.

public abstract void Towards(
Position pos
);

Parameters

pos

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane.XYOffset Method

Returns the position mapped onto the plane in terms of an XY offset from the plane origin

public abstract Position2D XYOffset(
Position pos
);

Parameters

pos

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane Operators

The operators of the Plane class are listed below. For a complete list of Plane class members, see the Plane Members topic.

Public Static Operators

Equality Operator | Same Plane, within tolerance
Inequality Operator | Not same Plane

See Also

Plane Class | Plane Members | Aveva.Pdms.Geometry Namespace


Plane Equality Operator

Same Plane, within tolerance

public static bool operator ==(
Plane p1,
Plane p2
);

Parameters

p1
p2

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


Plane Inequality Operator

Not same Plane

public static bool operator !=(
Plane p1,
Plane p2
);

Parameters

p1
p2

Return Value

See Also

Plane Class | Aveva.Pdms.Geometry Namespace


PlantGrid Class

Summary description for PlantGrid.

For a list of all members of this type, see PlantGrid Members.

System.Object
Aveva.Pdms.Geometry.PlantGrid

public abstract class PlantGrid

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

PlantGrid Members | Aveva.Pdms.Geometry Namespace


PlantGrid Members

PlantGrid overview

Public Static Methods

Create Overloaded. Create PlantGrid

Public Static Operators

Equality Operator | Same PlantGrid
Inequality Operator | Not same PlantGrid

Public Instance Properties

Orientation | Orientation of the grid
Position | Origin of the grid
XSpacing | Spacings between grid lines in X direction
YSpacing | Spacings between lines in Y direction

Public Instance Methods

Equals | Overloaded. same PlantGrid
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
GridPoint | Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin..
internalCreate | Overloaded. create PlantGrid
IsInGridBounds | Returns true if pos is within the grid
Plane | Return Plane of the grid
Snap | Overloaded. Returns nearest grid intersection point to the intersection of line with the plane of the grid
SnapToCentre | Overloaded. Return the nearest mesh cell centre point to to the intersection of line with the plane of the grid
ToString | Returns PlantGrid property values in a string
XSize | Maximum size in the X direction
YSize | Maximum size in the Y direction

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


PlantGrid Properties

The properties of the PlantGrid class are listed below. For a complete list of PlantGrid class members, see the PlantGrid Members topic.

Public Instance Properties

Orientation | Orientation of the grid
Position | Origin of the grid
XSpacing | Spacings between grid lines in X direction
YSpacing | Spacings between lines in Y direction

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


Orientation Property

AVEVA Geometry .NET Public Interface

PlantGrid.Orientation Property

Orientation of the grid

public abstract Orientation Orientation {get; set;}

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


Position Property

AVEVA Geometry .NET Public Interface

PlantGrid.Position Property

Origin of the grid

public abstract Position Position {get; set;}

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


XSpacing Property

AVEVA Geometry .NET Public Interface

PlantGrid.XSpacing Property

Spacings between grid lines in X direction

public abstract double[] XSpacing {get; set;}

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


YSpacing Property

AVEVA Geometry .NET Public Interface

PlantGrid.YSpacing Property

Spacings between lines in Y direction

public abstract double[] YSpacing {get; set;}

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


PlantGrid Methods

The methods of the PlantGrid class are listed below. For a complete list of PlantGrid class members, see the PlantGrid Members topic.

Public Static Methods

Create Overloaded. Create PlantGrid

Public Instance Methods

Equals | Overloaded. same PlantGrid
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
GridPoint | Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin..
internalCreate | Overloaded. create PlantGrid
IsInGridBounds | Returns true if pos is within the grid
Plane | Return Plane of the grid
Snap | Overloaded. Returns nearest grid intersection point to the intersection of line with the plane of the grid
SnapToCentre | Overloaded. Return the nearest mesh cell centre point to to the intersection of line with the plane of the grid
ToString | Returns PlantGrid property values in a string
XSize | Maximum size in the X direction
YSize | Maximum size in the Y direction

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

PlantGrid.Create Method

Create PlantGrid

Overload List

Create PlantGrid

public static PlantGrid Create();

Create PlantGrid

public static PlantGrid Create(Position,Orientation,double[],double[]);

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


PlantGrid.Create Method ()

Create PlantGrid

public static PlantGrid Create();

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace | PlantGrid.Create Overload List


PlantGrid.Create Method (Position, Orientation, Double[], Double[])

Create PlantGrid

public static PlantGrid Create(
Position pos,
Orientation ori,
double[] xspacings,
double[] yspacings
);

Parameters

pos
ori
xspacings
yspacings

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace | PlantGrid.Create Overload List


Equals Method

AVEVA Geometry .NET Public Interface

PlantGrid.Equals Method

same PlantGrid

Overload List

same PlantGrid

public abstract bool Equals(PlantGrid);

Same PlantGrid

public override bool Equals(object);

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


PlantGrid.Equals Method (PlantGrid)

same PlantGrid

public abstract bool Equals(
PlantGrid pg
);

Parameters

pg

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace | PlantGrid.Equals Overload List


PlantGrid.Equals Method (Object)

Same PlantGrid

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace | PlantGrid.Equals Overload List


PlantGrid.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


PlantGrid.GridPoint Method

Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin..

public abstract Position GridPoint(
int ix,
int iy
);

Parameters

ix
iy

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


internalCreate Method

AVEVA Geometry .NET Public Interface

PlantGrid.internalCreate Method

create PlantGrid

Overload List

create PlantGrid

public abstract PlantGrid internalCreate();

create PlantGrid

public abstract PlantGrid internalCreate(Position,Orientation,double[],double[]);

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


PlantGrid.internalCreate Method ()

create PlantGrid

public abstract PlantGrid internalCreate();

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace | PlantGrid.internalCreate Overload List


PlantGrid.internalCreate Method (Position, Orientation, Double[], Double[])

create PlantGrid

public abstract PlantGrid internalCreate(
Position pos,
Orientation ori,
double[] xspacings,
double[] yspacings
);

Parameters

pos
ori
xspacings
yspacings

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace | PlantGrid.internalCreate Overload List


PlantGrid.IsInGridBounds Method

Returns true if pos is within the grid

public abstract bool IsInGridBounds(
Position pos
);

Parameters

pos

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


PlantGrid.Plane Method

Return Plane of the grid

public abstract Plane Plane();

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


Snap Method

AVEVA Geometry .NET Public Interface

PlantGrid.Snap Method

Returns nearest grid intersection point to the intersection of line with the plane of the grid

Overload List

Returns nearest grid intersection point to the intersection of line with the plane of the grid

public abstract Position Snap(Line);

Returns nearest grid intersection point to pos

public abstract Position Snap(Position);

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


PlantGrid.Snap Method (Line)

Returns nearest grid intersection point to the intersection of line with the plane of the grid

public abstract Position Snap(
Line line
);

Parameters

line

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace | PlantGrid.Snap Overload List


PlantGrid.Snap Method (Position)

Returns nearest grid intersection point to pos

public abstract Position Snap(
Position pos
);

Parameters

pos

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace | PlantGrid.Snap Overload List


SnapToCentre Method

AVEVA Geometry .NET Public Interface

PlantGrid.SnapToCentre Method

Return the nearest mesh cell centre point to to the intersection of line with the plane of the grid

Overload List

Return the nearest mesh cell centre point to to the intersection of line with the plane of the grid

public abstract Position SnapToCentre(Line);

Return the nearest mesh cell centre point to pos in the grid plane

public abstract Position SnapToCentre(Position);

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


PlantGrid.SnapToCentre Method (Line)

Return the nearest mesh cell centre point to to the intersection of line with the plane of the grid

public abstract Position SnapToCentre(
Line line
);

Parameters

line

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace | PlantGrid.SnapToCentre Overload List


PlantGrid.SnapToCentre Method (Position)

Return the nearest mesh cell centre point to pos in the grid plane

public abstract Position SnapToCentre(
Position pos
);

Parameters

pos

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace | PlantGrid.SnapToCentre Overload List


PlantGrid.ToString Method

Returns PlantGrid property values in a string

public abstract string ToString();

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


PlantGrid.XSize Method

Maximum size in the X direction

public abstract double XSize();

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


PlantGrid.YSize Method

Maximum size in the Y direction

public abstract double YSize();

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


PlantGrid Operators

The operators of the PlantGrid class are listed below. For a complete list of PlantGrid class members, see the PlantGrid Members topic.

Public Static Operators

Equality Operator | Same PlantGrid
Inequality Operator | Not same PlantGrid

See Also

PlantGrid Class | PlantGrid Members | Aveva.Pdms.Geometry Namespace


PlantGrid Equality Operator

Same PlantGrid

public static bool operator ==(
PlantGrid pg1,
PlantGrid pg2
);

Parameters

pg1
pg2

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


PlantGrid Inequality Operator

Not same PlantGrid

public static bool operator !=(
PlantGrid pg1,
PlantGrid pg2
);

Parameters

pg1
pg2

Return Value

See Also

PlantGrid Class | Aveva.Pdms.Geometry Namespace


PlantGrid2D Class

Summary description for PlantGrid2D.

For a list of all members of this type, see PlantGrid2D Members.

System.Object
Aveva.Pdms.Geometry.PlantGrid2D

public abstract class PlantGrid2D

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

PlantGrid2D Members | Aveva.Pdms.Geometry Namespace


PlantGrid2D Members

PlantGrid2D overview

Public Static Methods

Create Overloaded. Create PlantGrid2D

Public Static Operators

Equality Operator | Same PlantGrid2D
Inequality Operator | Not same PlantGrid2D

Public Instance Properties

Position | Origin of the grid
XSpacing | Spacings between grid lines in X direction
YSpacing | Spacings between lines in Y direction

Public Instance Methods

Equals | Overloaded. Same PlantGrid2D
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
GridPoint | Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin.
IsInGridBounds | Returns true if pos is within the grid
Snap | Returns nearest grid intersection point to pos
SnapToCentre | Return the nearest mesh cell centre point to pos in the grid plane
ToString | Returns PlantGrid2D property values in a string
XSize | Maximum size in the X direction
YSize | Maximum size in the Y direction

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


PlantGrid2D Properties

The properties of the PlantGrid2D class are listed below. For a complete list of PlantGrid2D class members, see the PlantGrid2D Members topic.

Public Instance Properties

Position | Origin of the grid
XSpacing | Spacings between grid lines in X direction
YSpacing | Spacings between lines in Y direction

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


Position Property

AVEVA Geometry .NET Public Interface

PlantGrid2D.Position Property

Origin of the grid

public abstract Position2D Position {get; set;}

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


XSpacing Property

AVEVA Geometry .NET Public Interface

PlantGrid2D.XSpacing Property

Spacings between grid lines in X direction

public abstract double[] XSpacing {get; set;}

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


YSpacing Property

AVEVA Geometry .NET Public Interface

PlantGrid2D.YSpacing Property

Spacings between lines in Y direction

public abstract double[] YSpacing {get; set;}

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


PlantGrid2D Methods

The methods of the PlantGrid2D class are listed below. For a complete list of PlantGrid2D class members, see the PlantGrid2D Members topic.

Public Static Methods

Create Overloaded. Create PlantGrid2D

Public Instance Methods

Equals | Overloaded. Same PlantGrid2D
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
GridPoint | Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin.
IsInGridBounds | Returns true if pos is within the grid
Snap | Returns nearest grid intersection point to pos
SnapToCentre | Return the nearest mesh cell centre point to pos in the grid plane
ToString | Returns PlantGrid2D property values in a string
XSize | Maximum size in the X direction
YSize | Maximum size in the Y direction

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

PlantGrid2D.Create Method

Create PlantGrid2D

Overload List

Create PlantGrid2D

public static PlantGrid2D Create();

Create a PlantGrid2D

public static PlantGrid2D Create(Position2D,double[],double[]);

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


PlantGrid2D.Create Method ()

Create PlantGrid2D

public static PlantGrid2D Create();

Return Value

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace | PlantGrid2D.Create Overload List


PlantGrid2D.Create Method (Position2D, Double[], Double[])

Create a PlantGrid2D

public static PlantGrid2D Create(
Position2D pos,
double[] xspacings,
double[] yspacings
);

Parameters

pos
xspacings
yspacings

Return Value

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace | PlantGrid2D.Create Overload List


Equals Method

AVEVA Geometry .NET Public Interface

PlantGrid2D.Equals Method

Same PlantGrid2D

Overload List

Same PlantGrid2D

public abstract bool Equals(PlantGrid2D);

Same PlantGrid2D

public override bool Equals(object);

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


PlantGrid2D.Equals Method (PlantGrid2D)

Same PlantGrid2D

public abstract bool Equals(
PlantGrid2D pg
);

Parameters

pg

Return Value

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace | PlantGrid2D.Equals Overload List


PlantGrid2D.Equals Method (Object)

Same PlantGrid2D

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace | PlantGrid2D.Equals Overload List


PlantGrid2D.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


PlantGrid2D.GridPoint Method

Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin.

public abstract Position2D GridPoint(
int ix,
int iy
);

Parameters

ix
iy

Return Value

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


PlantGrid2D.IsInGridBounds Method

Returns true if pos is within the grid

public abstract bool IsInGridBounds(
Position2D pos
);

Parameters

pos

Return Value

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


PlantGrid2D.Snap Method

Returns nearest grid intersection point to pos

public abstract Position2D Snap(
Position2D pos
);

Parameters

pos

Return Value

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


PlantGrid2D.SnapToCentre Method

Return the nearest mesh cell centre point to pos in the grid plane

public abstract Position2D SnapToCentre(
Position2D pos
);

Parameters

pos

Return Value

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


PlantGrid2D.ToString Method

Returns PlantGrid2D property values in a string

public abstract string ToString();

Return Value

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


PlantGrid2D.XSize Method

Maximum size in the X direction

public abstract double XSize();

Return Value

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


PlantGrid2D.YSize Method

Maximum size in the Y direction

public abstract double YSize();

Return Value

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


PlantGrid2D Operators

The operators of the PlantGrid2D class are listed below. For a complete list of PlantGrid2D class members, see the PlantGrid2D Members topic.

Public Static Operators

Equality Operator | Same PlantGrid2D
Inequality Operator | Not same PlantGrid2D

See Also

PlantGrid2D Class | PlantGrid2D Members | Aveva.Pdms.Geometry Namespace


PlantGrid2D Equality Operator

Same PlantGrid2D

public static bool operator ==(
PlantGrid2D pg1,
PlantGrid2D pg2
);

Parameters

pg1
pg2

Return Value

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


PlantGrid2D Inequality Operator

Not same PlantGrid2D

public static bool operator !=(
PlantGrid2D pg1,
PlantGrid2D pg2
);

Parameters

pg1
pg2

Return Value

See Also

PlantGrid2D Class | Aveva.Pdms.Geometry Namespace


PointVector Class

Summary description for PointVector.

For a list of all members of this type, see PointVector Members.

System.Object
Aveva.Pdms.Geometry.PointVector

public abstract class PointVector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

PointVector Members | Aveva.Pdms.Geometry Namespace


PointVector Members

PointVector overview

Public Static Methods

Create Overloaded. Default PointVector

Public Static Operators

Equality Operator | Same PointVector
Inequality Operator | Not same PointVector

Public Instance Properties

Direction | Direction of PointVector
Position | Origin of PointVector

Public Instance Methods

Equals | Overloaded. Same PointVector
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Line | Returns an unbounded line from the origin and direction of the PointVector
Offset | Offset the PointVector by val in its direction
Plane | Returns plane through the origin and with normal in the direction of the PointVector
ToString | Returns PointVector in PDMS Format
Towards | Change the direction of the PointVector to point towards pos

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace


PointVector Properties

The properties of the PointVector class are listed below. For a complete list of PointVector class members, see the PointVector Members topic.

Public Instance Properties

Direction | Direction of PointVector
Position | Origin of PointVector

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace


Direction Property

AVEVA Geometry .NET Public Interface

PointVector.Direction Property

Direction of PointVector

public abstract Direction Direction {get; set;}

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace


Position Property

AVEVA Geometry .NET Public Interface

PointVector.Position Property

Origin of PointVector

public abstract Position Position {get; set;}

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace


PointVector Methods

The methods of the PointVector class are listed below. For a complete list of PointVector class members, see the PointVector Members topic.

Public Static Methods

Create Overloaded. Default PointVector

Public Instance Methods

Equals | Overloaded. Same PointVector
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
Line | Returns an unbounded line from the origin and direction of the PointVector
Offset | Offset the PointVector by val in its direction
Plane | Returns plane through the origin and with normal in the direction of the PointVector
ToString | Returns PointVector in PDMS Format
Towards | Change the direction of the PointVector to point towards pos

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

PointVector.Create Method

Default PointVector

Overload List

Default PointVector

public static PointVector Create();

Create a pointVector at pos with direction dir

public static PointVector Create(Position,Direction);

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace


PointVector.Create Method ()

Default PointVector

public static PointVector Create();

Parameters

Return Value

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace | PointVector.Create Overload List


PointVector.Create Method (Position, Direction)

Create a pointVector at pos with direction dir

public static PointVector Create(
Position pos,
Direction dir
);

Parameters

pos
dir

Return Value

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace | PointVector.Create Overload List


Equals Method

AVEVA Geometry .NET Public Interface

PointVector.Equals Method

Same PointVector

Overload List

Same PointVector

public abstract bool Equals(PointVector);

Same PointVector

public override bool Equals(object);

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace


PointVector.Equals Method (PointVector)

Same PointVector

public abstract bool Equals(
PointVector pointvector
);

Parameters

pointvector

Return Value

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace | PointVector.Equals Overload List


PointVector.Equals Method (Object)

Same PointVector

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace | PointVector.Equals Overload List


PointVector.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace


PointVector.Line Method

Returns an unbounded line from the origin and direction of the PointVector

public abstract Line Line();

Return Value

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace


PointVector.Offset Method

Offset the PointVector by val in its direction

public abstract void Offset(
double val
);

Return Value

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace


PointVector.Plane Method

Returns plane through the origin and with normal in the direction of the PointVector

public abstract Plane Plane();

Return Value

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace


PointVector.ToString Method

Returns PointVector in PDMS Format

public abstract string ToString();

Return Value

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace


PointVector.Towards Method

Change the direction of the PointVector to point towards pos

public abstract void Towards(
Position pos
);

Parameters

pos

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace


PointVector Operators

The operators of the PointVector class are listed below. For a complete list of PointVector class members, see the PointVector Members topic.

Public Static Operators

Equality Operator | Same PointVector
Inequality Operator | Not same PointVector

See Also

PointVector Class | PointVector Members | Aveva.Pdms.Geometry Namespace


PointVector Equality Operator

Same PointVector

public static bool operator ==(
PointVector p1,
PointVector p2
);

Parameters

p1
p2

Return Value

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace


PointVector Inequality Operator

Not same PointVector

public static bool operator !=(
PointVector p1,
PointVector p2
);

Parameters

p1
p2

Return Value

See Also

PointVector Class | Aveva.Pdms.Geometry Namespace


Position Class

Summary description for D3Point.

For a list of all members of this type, see Position Members.

System.Object
Aveva.Pdms.Geometry.Position

public abstract class Position

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

Position Members | Aveva.Pdms.Geometry Namespace


Position Members

Position overview

Public Static Methods

Create Overloaded. Creates a Position at (0,0,0)

Public Static Operators

Equality Operator | Same Position, within tolerance
Inequality Operator | Not same Position

Public Instance Properties

X | X cooridnate
Y | Y Coordinate
Z | Z cooridnate

Public Instance Methods

Angle | Return the angle between p1 and p2 about this Position
Distance | Overloaded. Distance to the nearest point on the (infinitely extended) Line line
Equals | Overloaded. Same Position, within tolerance
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
MidPoint | Return Position at midpoint between this Position and
MoveBy | Overloaded. Offset by val in direction dir
Parse | Return Position object derived from a string in PDMS format
Position2D | Overloaded. Return the 2D position which is the position projected onto Plane plane
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Position Class | Aveva.Pdms.Geometry Namespace


Position Properties

The properties of the Position class are listed below. For a complete list of Position class members, see the Position Members topic.

Public Instance Properties

X | X cooridnate
Y | Y Coordinate
Z | Z cooridnate

See Also

Position Class | Aveva.Pdms.Geometry Namespace


X Property

AVEVA Geometry .NET Public Interface

Position.X Property

X cooridnate

public abstract double X {get; set;}

See Also

Position Class | Aveva.Pdms.Geometry Namespace


Y Property

AVEVA Geometry .NET Public Interface

Position.Y Property

Y Coordinate

public abstract double Y {get; set;}

See Also

Position Class | Aveva.Pdms.Geometry Namespace


Z Property

AVEVA Geometry .NET Public Interface

Position.Z Property

Z cooridnate

public abstract double Z {get; set;}

See Also

Position Class | Aveva.Pdms.Geometry Namespace


Position Methods

The methods of the Position class are listed below. For a complete list of Position class members, see the Position Members topic.

Public Static Methods

Create Overloaded. Creates a Position at (0,0,0)

Public Instance Methods

Angle | Return the angle between p1 and p2 about this Position
Distance | Overloaded. Distance to the nearest point on the (infinitely extended) Line line
Equals | Overloaded. Same Position, within tolerance
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
MidPoint | Return Position at midpoint between this Position and
MoveBy | Overloaded. Offset by val in direction dir
Parse | Return Position object derived from a string in PDMS format
Position2D | Overloaded. Return the 2D position which is the position projected onto Plane plane
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Position Class | Aveva.Pdms.Geometry Namespace


Position.Angle Method

Return the angle between p1 and p2 about this Position

public abstract double Angle(
Position p1,
Position p2
);

Parameters

p1
p2

Return Value

See Also

Position Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

Position.Create Method

Creates a Position at (0,0,0)

Overload List

Creates a Position at (0,0,0)

public static Position Create();

Creates a Position at coordinates (x,y,z)

public static Position Create(double,double,double);

public static Position Create(string);

See Also

Position Class | Aveva.Pdms.Geometry Namespace


Position.Create Method ()

Creates a Position at (0,0,0)

public static Position Create();

Return Value

See Also

Position Class | Aveva.Pdms.Geometry Namespace | Position.Create Overload List


Position.Create Method (Double, Double, Double)

Creates a Position at coordinates (x,y,z)

public static Position Create(
double x,
double y,
double z
);

Parameters

x
y
z

Return Value

See Also

Position Class | Aveva.Pdms.Geometry Namespace | Position.Create Overload List


Position.Create Method (String)

public static Position Create(
string postring
);

See Also

Position Class | Aveva.Pdms.Geometry Namespace | Position.Create Overload List


Distance Method

AVEVA Geometry .NET Public Interface

Position.Distance Method

Distance to the nearest point on the (infinitely extended) Line line

Overload List

Distance to the nearest point on the (infinitely extended) Line line

public abstract double Distance(Line);

Distance to the nearest point on the Plane plane

public abstract double Distance(Plane);

Distance from Position p

public abstract double Distance(Position);

See Also

Position Class | Aveva.Pdms.Geometry Namespace


Position.Distance Method (Line)

Distance to the nearest point on the (infinitely extended) Line line

public abstract double Distance(
Line line
);

Parameters

line

Return Value

See Also

Position Class | Aveva.Pdms.Geometry Namespace | Position.Distance Overload List


Position.Distance Method (Plane)

Distance to the nearest point on the Plane plane

public abstract double Distance(
Plane plane
);

Parameters

plane

Return Value

See Also

Position Class | Aveva.Pdms.Geometry Namespace | Position.Distance Overload List


Position.Distance Method (Position)

Distance from Position p

public abstract double Distance(
Position p
);

Parameters

p

Return Value

See Also

Position Class | Aveva.Pdms.Geometry Namespace | Position.Distance Overload List


Equals Method

AVEVA Geometry .NET Public Interface

Position.Equals Method

Same Position, within tolerance

Overload List

Same Position, within tolerance

public abstract bool Equals(Position);

Same Position, within tolerance

public override bool Equals(object);

See Also

Position Class | Aveva.Pdms.Geometry Namespace


Position.Equals Method (Position)

Same Position, within tolerance

public abstract bool Equals(
Position p
);

Parameters

p

Return Value

See Also

Position Class | Aveva.Pdms.Geometry Namespace | Position.Equals Overload List


Position.Equals Method (Object)

Same Position, within tolerance

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

Position Class | Aveva.Pdms.Geometry Namespace | Position.Equals Overload List


Position.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

Position Class | Aveva.Pdms.Geometry Namespace


Position.MidPoint Method

Return Position at midpoint between this Position and

public abstract Position MidPoint(
Position p
);

Parameters

p

Return Value

See Also

Position Class | Aveva.Pdms.Geometry Namespace


MoveBy Method

AVEVA Geometry .NET Public Interface

Position.MoveBy Method

Offset by val in direction dir

Overload List

Offset by val in direction dir

public abstract void MoveBy(Direction,double);

Offset by given amount

public abstract void MoveBy(double,double,double);

See Also

Position Class | Aveva.Pdms.Geometry Namespace


Position.MoveBy Method (Direction, Double)

Offset by val in direction dir

public abstract void MoveBy(
Direction dir,
double val
);

Parameters

dir
val

See Also

Position Class | Aveva.Pdms.Geometry Namespace | Position.MoveBy Overload List


Position.MoveBy Method (Double, Double, Double)

Offset by given amount

public abstract void MoveBy(
double x,
double y,
double z
);

Parameters

x
y
z

See Also

Position Class | Aveva.Pdms.Geometry Namespace | Position.MoveBy Overload List


Position.Parse Method

Return Position object derived from a string in PDMS format

public abstract Position Parse(
string str
);

Parameters

str

Return Value

See Also

Position Class | Aveva.Pdms.Geometry Namespace


Position2D Method

AVEVA Geometry .NET Public Interface

Position.Position2D Method

Return 2d position calculated from the X,Y values of the Position object

Overload List

Return 2d position calculated from the X,Y values of the Position object

public abstract Position2D Position2D();

Return the 2D position which is the position projected onto Plane plane

public abstract Position2D Position2D(Plane);

See Also

Position Class | Aveva.Pdms.Geometry Namespace


Position.Position2D Method ()

Return 2d position calculated from the X,Y values of the Position object

public abstract Position2D Position2D();

Return Value

See Also

Position Class | Aveva.Pdms.Geometry Namespace | Position.Position2D Overload List


Position.Position2D Method (Plane)

Return the 2D position which is the position projected onto Plane plane

public abstract Position2D Position2D(
Plane plane
);

Parameters

plane

Return Value

See Also

Position Class | Aveva.Pdms.Geometry Namespace | Position.Position2D Overload List


Position Operators

The operators of the Position class are listed below. For a complete list of Position class members, see the Position Members topic.

Public Static Operators

Equality Operator | Same Position, within tolerance
Inequality Operator | Not same Position

See Also

Position Class | Position Members | Aveva.Pdms.Geometry Namespace


Position Equality Operator

Same Position, within tolerance

public static bool operator ==(
Position p1,
Position p2
);

Parameters

p1
p2

Return Value

See Also

Position Class | Aveva.Pdms.Geometry Namespace


Position Inequality Operator

Not same Position

public static bool operator !=(
Position p1,
Position p2
);

Parameters

p1
p2

Return Value

See Also

Position Class | Aveva.Pdms.Geometry Namespace


Position2D Class

Summary description for Position2D.

For a list of all members of this type, see Position2D Members.

System.Object
Aveva.Pdms.Geometry.Position2D

public abstract class Position2D

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

Position2D Members | Aveva.Pdms.Geometry Namespace


Position2D Members

Position2D overview

Public Static Methods

Create Overloaded. Create Position2D (all values zero)

Public Static Operators

Equality Operator | Same Position2D
Inequality Operator | Not Same Position2D

Public Instance Properties

X | X component of position
Y | Y component of position

Public Instance Methods

Angle | Return the angle between p1 and p2 about this Position
Distance | Distance from Position2D p
Equals | Overloaded. Same Position2D, within tolerance
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
MidPoint | Return Position at midpoint between this Position and p
MoveBy | Overloaded. Move Position2D by offset in direction dir
Near | Returns true if this position is near p within the given range
Parse | Return Position2D object derived from a string in PDMS format
Position3D | Return a point in 3D space, using the given Plane
Size | Distance of this position from origin along direction dir
ToString | Returns Position2D property values in a string

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Position2D Properties

The properties of the Position2D class are listed below. For a complete list of Position2D class members, see the Position2D Members topic.

Public Instance Properties

X | X component of position
Y | Y component of position

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


X Property

AVEVA Geometry .NET Public Interface

Position2D.X Property

X component of position

public abstract double X {get; set;}

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Y Property

AVEVA Geometry .NET Public Interface

Position2D.Y Property

Y component of position

public abstract double Y {get; set;}

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Position2D Methods

The methods of the Position2D class are listed below. For a complete list of Position2D class members, see the Position2D Members topic.

Public Static Methods

Create Overloaded. Create Position2D (all values zero)

Public Instance Methods

Angle | Return the angle between p1 and p2 about this Position
Distance | Distance from Position2D p
Equals | Overloaded. Same Position2D, within tolerance
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
MidPoint | Return Position at midpoint between this Position and p
MoveBy | Overloaded. Move Position2D by offset in direction dir
Near | Returns true if this position is near p within the given range
Parse | Return Position2D object derived from a string in PDMS format
Position3D | Return a point in 3D space, using the given Plane
Size | Distance of this position from origin along direction dir
ToString | Returns Position2D property values in a string

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Position2D.Angle Method

Return the angle between p1 and p2 about this Position

public abstract double Angle(
Position2D p1,
Position2D p2
);

Parameters

p1
p2

Return Value

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

Position2D.Create Method

Create Position2D (all values zero)

Overload List

Create Position2D (all values zero)

public static Position2D Create();

Create a Position2D from x, y coordinates

public static Position2D Create(double,double);

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Position2D.Create Method ()

Create Position2D (all values zero)

public static Position2D Create();

Return Value

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace | Position2D.Create Overload List


Position2D.Create Method (Double, Double)

Create a Position2D from x, y coordinates

public static Position2D Create(
double x,
double y
);

Parameters

x
y

Return Value

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace | Position2D.Create Overload List


Position2D.Distance Method

Distance from Position2D p

public abstract double Distance(
Position2D p
);

Parameters

p

Return Value

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Equals Method

AVEVA Geometry .NET Public Interface

Position2D.Equals Method

Same Position2D, within tolerance

Overload List

Same Position2D, within tolerance

public abstract bool Equals(Position2D);

Same Position2D, within tolerance

public override bool Equals(object);

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Position2D.Equals Method (Position2D)

Same Position2D, within tolerance

public abstract bool Equals(
Position2D p
);

Parameters

p

Return Value

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace | Position2D.Equals Overload List


Position2D.Equals Method (Object)

Same Position2D, within tolerance

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace | Position2D.Equals Overload List


Position2D.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Position2D.MidPoint Method

Return Position at midpoint between this Position and p

public abstract Position2D MidPoint(
Position2D p
);

Parameters

p

Return Value

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


MoveBy Method

AVEVA Geometry .NET Public Interface

Position2D.MoveBy Method

Move Position2D by offset in direction dir

Overload List

Move Position2D by offset in direction dir

public abstract void MoveBy(Direction2D,double);

Move Position2D by given x,y values

public abstract void MoveBy(double,double);

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Position2D.MoveBy Method (Direction2D, Double)

Move Position2D by offset in direction dir

public abstract void MoveBy(
Direction2D dir,
double offset
);

Parameters

dir
offset

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace | Position2D.MoveBy Overload List


Position2D.MoveBy Method (Double, Double)

Move Position2D by given x,y values

public abstract void MoveBy(
double X,
double Y
);

Parameters

X
Y

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace | Position2D.MoveBy Overload List


Position2D.Near Method

Returns true if this position is near p within the given range

public abstract bool Near(
Position2D p,
double range
);

Parameters

p
range

Return Value

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Position2D.Parse Method

Return Position2D object derived from a string in PDMS format

public abstract Position2D Parse(
string str
);

Parameters

str

Return Value

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Position2D.Position3D Method

Return a point in 3D space, using the given Plane

public abstract Position Position3D(
Plane plane
);

Parameters

plane

Return Value

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Position2D.Size Method

Distance of this position from origin along direction dir

public abstract double Size(
Direction2D dir
);

Parameters

dir

Return Value

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Position2D.ToString Method

Returns Position2D property values in a string

public abstract string ToString();

Return Value

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Position2D Operators

The operators of the Position2D class are listed below. For a complete list of Position2D class members, see the Position2D Members topic.

Public Static Operators

Equality Operator | Same Position2D
Inequality Operator | Not Same Position2D

See Also

Position2D Class | Position2D Members | Aveva.Pdms.Geometry Namespace


Position2D Equality Operator

Same Position2D

public static bool operator ==(
Position2D t1,
Position2D t2
);

Parameters

t1
t2

Return Value

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


Position2D Inequality Operator

Not Same Position2D

public static bool operator !=(
Position2D t1,
Position2D t2
);

Parameters

t1
t2

Return Value

See Also

Position2D Class | Aveva.Pdms.Geometry Namespace


RadialGrid Class

Summary description for RadialGrid.

For a list of all members of this type, see RadialGrid Members.

System.Object
Aveva.Pdms.Geometry.RadialGrid

public abstract class RadialGrid

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

RadialGrid Members | Aveva.Pdms.Geometry Namespace


RadialGrid Members

RadialGrid overview

Public Static Methods

Create Overloaded. Create RadialGrid

Public Static Operators

Equality Operator | Same RadialGrid
Inequality Operator | Not same RadialGrid

Public Instance Properties

Angles | Angular spacing from X axis
Orientation | Orientation of the grid
Position | Origin of the grid
Radii | Radii of the grid

Public Instance Methods

Equals | Overloaded. Same RadialGrid
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
GridPoint | Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin.
internalCreate | Overloaded. Create a RadialGrid
RadialPosition | Return the nearest grid position of the given radius and angle
Snap | Overloaded. Returns nearest grid intersection point to the intersection of line with the plane of the grid
ToString | Returns RadialGrid property values in a string

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


RadialGrid Properties

The properties of the RadialGrid class are listed below. For a complete list of RadialGrid class members, see the RadialGrid Members topic.

Public Instance Properties

Angles | Angular spacing from X axis
Orientation | Orientation of the grid
Position | Origin of the grid
Radii | Radii of the grid

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


Angles Property

AVEVA Geometry .NET Public Interface

RadialGrid.Angles Property

Angular spacing from X axis

public abstract double[] Angles {get; set;}

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


Orientation Property

AVEVA Geometry .NET Public Interface

RadialGrid.Orientation Property

Orientation of the grid

public abstract Orientation Orientation {get; set;}

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


Position Property

AVEVA Geometry .NET Public Interface

RadialGrid.Position Property

Origin of the grid

public abstract Position Position {get; set;}

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


Radii Property

AVEVA Geometry .NET Public Interface

RadialGrid.Radii Property

Radii of the grid

public abstract double[] Radii {get; set;}

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


RadialGrid Methods

The methods of the RadialGrid class are listed below. For a complete list of RadialGrid class members, see the RadialGrid Members topic.

Public Static Methods

Create Overloaded. Create RadialGrid

Public Instance Methods

Equals | Overloaded. Same RadialGrid
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
GridPoint | Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin.
internalCreate | Overloaded. Create a RadialGrid
RadialPosition | Return the nearest grid position of the given radius and angle
Snap | Overloaded. Returns nearest grid intersection point to the intersection of line with the plane of the grid
ToString | Returns RadialGrid property values in a string

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

RadialGrid.Create Method

Create RadialGrid

Overload List

Create RadialGrid

public static RadialGrid Create();

Create a RadialGrid

public static RadialGrid Create(Position,Orientation,double[],double[]);

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


RadialGrid.Create Method ()

Create RadialGrid

public static RadialGrid Create();

Return Value

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace | RadialGrid.Create Overload List


RadialGrid.Create Method (Position, Orientation, Double[], Double[])

Create a RadialGrid

public static RadialGrid Create(
Position pos,
Orientation ori,
double[] angles,
double[] radii
);

Parameters

pos
ori
angles
radii

Return Value

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace | RadialGrid.Create Overload List


Equals Method

AVEVA Geometry .NET Public Interface

RadialGrid.Equals Method

Same RadialGrid

Overload List

Same RadialGrid

public abstract bool Equals(RadialGrid);

Same RadialGrid

public override bool Equals(object);

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


RadialGrid.Equals Method (RadialGrid)

Same RadialGrid

public abstract bool Equals(
RadialGrid rg
);

Parameters

rg

Return Value

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace | RadialGrid.Equals Overload List


RadialGrid.Equals Method (Object)

Same RadialGrid

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace | RadialGrid.Equals Overload List


RadialGrid.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


RadialGrid.GridPoint Method

Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin.

public abstract Position GridPoint(
int ix,
int iy
);

Parameters

ix
iy

Return Value

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


internalCreate Method

AVEVA Geometry .NET Public Interface

RadialGrid.internalCreate Method

Create a RadialGrid

Overload List

Create a RadialGrid

public abstract RadialGrid internalCreate();

Create a RadialGrid

public abstract RadialGrid internalCreate(Position,Orientation,double[],double[]);

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


RadialGrid.internalCreate Method ()

Create a RadialGrid

public abstract RadialGrid internalCreate();

Return Value

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace | RadialGrid.internalCreate Overload List


RadialGrid.internalCreate Method (Position, Orientation, Double[], Double[])

Create a RadialGrid

public abstract RadialGrid internalCreate(
Position pos,
Orientation ori,
double[] angles,
double[] radii
);

Parameters

pos
ori
angles
radii

Return Value

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace | RadialGrid.internalCreate Overload List


RadialGrid.RadialPosition Method

Return the nearest grid position of the given radius and angle

public abstract Position RadialPosition(
double radius,
double angle
);

Parameters

radius
angle

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


Snap Method

AVEVA Geometry .NET Public Interface

RadialGrid.Snap Method

Returns nearest grid intersection point to the intersection of line with the plane of the grid

Overload List

Returns nearest grid intersection point to the intersection of line with the plane of the grid

public abstract Position Snap(Line);

Returns nearest grid intersection point to pos

public abstract Position Snap(Position);

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


RadialGrid.Snap Method (Line)

Returns nearest grid intersection point to the intersection of line with the plane of the grid

public abstract Position Snap(
Line line
);

Parameters

line

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace | RadialGrid.Snap Overload List


RadialGrid.Snap Method (Position)

Returns nearest grid intersection point to pos

public abstract Position Snap(
Position pos
);

Parameters

pos

Return Value

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace | RadialGrid.Snap Overload List


RadialGrid.ToString Method

Returns RadialGrid property values in a string

public abstract string ToString();

Return Value

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


RadialGrid Operators

The operators of the RadialGrid class are listed below. For a complete list of RadialGrid class members, see the RadialGrid Members topic.

Public Static Operators

Equality Operator | Same RadialGrid
Inequality Operator | Not same RadialGrid

See Also

RadialGrid Class | RadialGrid Members | Aveva.Pdms.Geometry Namespace


RadialGrid Equality Operator

Same RadialGrid

public static bool operator ==(
RadialGrid rg1,
RadialGrid rg2
);

Parameters

rg1
rg2

Return Value

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


RadialGrid Inequality Operator

Not same RadialGrid

public static bool operator !=(
RadialGrid rg1,
RadialGrid rg2
);

Parameters

rg1
rg2

Return Value

See Also

RadialGrid Class | Aveva.Pdms.Geometry Namespace


RadialGrid2D Class

Summary description for RadialGrid2D.

For a list of all members of this type, see RadialGrid2D Members.

System.Object
Aveva.Pdms.Geometry.RadialGrid2D

public abstract class RadialGrid2D

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Geometry

Assembly: Aveva.Pdms.Geometry (in Aveva.Pdms.Geometry.dll)

See Also

RadialGrid2D Members | Aveva.Pdms.Geometry Namespace


RadialGrid2D Members

RadialGrid2D overview

Public Static Methods

Create Overloaded. Create RadialGrid2D

Public Static Operators

Equality Operator | Same RadialGrid2D within tolerance
Inequality Operator | Not same RadialGrid2D

Public Instance Properties

Angles | Angular spacing from X axis
Position | Origin of the grid
Radii | Radii of the grid

Public Instance Methods

Equals | Overloaded. Same RadialGrid2D
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
GridPoint | Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin.
RadialPosition | Return the nearest grid position of the given radius and angle
Snap | Returns nearest grid intersection point to pos
ToString | Returns RadialGrid2D property values in a string

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace


RadialGrid2D Properties

The properties of the RadialGrid2D class are listed below. For a complete list of RadialGrid2D class members, see the RadialGrid2D Members topic.

Public Instance Properties

Angles | Angular spacing from X axis
Position | Origin of the grid
Radii | Radii of the grid

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace


Angles Property

AVEVA Geometry .NET Public Interface

RadialGrid2D.Angles Property

Angular spacing from X axis

public abstract double[] Angles {get; set;}

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace


Position Property

AVEVA Geometry .NET Public Interface

RadialGrid2D.Position Property

Origin of the grid

public abstract Position2D Position {get; set;}

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace


Radii Property

AVEVA Geometry .NET Public Interface

RadialGrid2D.Radii Property

Radii of the grid

public abstract double[] Radii {get; set;}

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace


RadialGrid2D Methods

The methods of the RadialGrid2D class are listed below. For a complete list of RadialGrid2D class members, see the RadialGrid2D Members topic.

Public Static Methods

Create Overloaded. Create RadialGrid2D

Public Instance Methods

Equals | Overloaded. Same RadialGrid2D
GetHashCode | A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections
GetType (inherited from Object) | Gets the Type of the current instance.
GridPoint | Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin.
RadialPosition | Return the nearest grid position of the given radius and angle
Snap | Returns nearest grid intersection point to pos
ToString | Returns RadialGrid2D property values in a string

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace


Create Method

AVEVA Geometry .NET Public Interface

RadialGrid2D.Create Method

Create RadialGrid2D

Overload List

Create RadialGrid2D

public static RadialGrid2D Create();

Create a RadialGrid2D

public static RadialGrid2D Create(Position2D,double[],double[]);

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace


RadialGrid2D.Create Method ()

Create RadialGrid2D

public static RadialGrid2D Create();

Return Value

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace | RadialGrid2D.Create Overload List


RadialGrid2D.Create Method (Position2D, Double[], Double[])

Create a RadialGrid2D

public static RadialGrid2D Create(
Position2D pos,
double[] angles,
double[] radii
);

Parameters

pos
angles
radii

Return Value

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace | RadialGrid2D.Create Overload List


Equals Method

AVEVA Geometry .NET Public Interface

RadialGrid2D.Equals Method

Same RadialGrid2D

Overload List

Same RadialGrid2D

public abstract bool Equals(RadialGrid2D);

Same RadialGrid2D

public override bool Equals(object);

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace


RadialGrid2D.Equals Method (RadialGrid2D)

Same RadialGrid2D

public abstract bool Equals(
RadialGrid2D rg
);

Parameters

rg

Return Value

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace | RadialGrid2D.Equals Overload List


RadialGrid2D.Equals Method (Object)

Same RadialGrid2D

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace | RadialGrid2D.Equals Overload List


RadialGrid2D.GetHashCode Method

A hash method is used to quickly generate a hash code, which is an int that corresponds to the value of an object. Hash codes allow C# to store objects more efficiently in collections

public override int GetHashCode();

Return Value

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace


RadialGrid2D.GridPoint Method

Returns the position at the (ix,iy) intersection of the grid. If ix or iy are negative, refers to intersections before the origin.

public abstract Position2D GridPoint(
int ix,
int iy
);

Parameters

ix
iy

Return Value

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace


RadialGrid2D.RadialPosition Method

Return the nearest grid position of the given radius and angle

public abstract Position2D RadialPosition(
double radius,
double angle
);

Parameters

radius
angle

Return Value

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace


RadialGrid2D.Snap Method

Returns nearest grid intersection point to pos

public abstract Position2D Snap(
Position2D pos
);

Parameters

pos

Return Value

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace


RadialGrid2D.ToString Method

Returns RadialGrid2D property values in a string

public abstract string ToString();

Return Value

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace


RadialGrid2D Operators

The operators of the RadialGrid2D class are listed below. For a complete list of RadialGrid2D class members, see the RadialGrid2D Members topic.

Public Static Operators

Equality Operator | Same RadialGrid2D within tolerance
Inequality Operator | Not same RadialGrid2D

See Also

RadialGrid2D Class | RadialGrid2D Members | Aveva.Pdms.Geometry Namespace


RadialGrid2D Equality Operator

Same RadialGrid2D within tolerance

public static bool operator ==(
RadialGrid2D rg1,
RadialGrid2D rg2
);

Parameters

rg1
rg2

Return Value

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace


RadialGrid2D Inequality Operator

Not same RadialGrid2D

public static bool operator !=(
RadialGrid2D rg1,
RadialGrid2D rg2
);

Parameters

rg1
rg2

Return Value

See Also

RadialGrid2D Class | Aveva.Pdms.Geometry Namespace


Aveva.Pdms.GeometryHierarchy

AVEVA Geometry .NET Public Interface

Aveva.Pdms.Geometry Hierarchy

System.Object
Aveva.Pdms.Geometry.Arc
Aveva.Pdms.Geometry.Arc2D
Aveva.Pdms.Geometry.Direction
Aveva.Pdms.Geometry.Direction2D
Aveva.Pdms.Geometry.LimitsBox
Aveva.Pdms.Geometry.LimitsBox2D
Aveva.Pdms.Geometry.Line
Aveva.Pdms.Geometry.Line2D
Aveva.Pdms.Geometry.LinearGrid
Aveva.Pdms.Geometry.LinearGrid2D
Aveva.Pdms.Geometry.Orientation
Aveva.Pdms.Geometry.Plane
Aveva.Pdms.Geometry.PlantGrid
Aveva.Pdms.Geometry.PlantGrid2D
Aveva.Pdms.Geometry.PointVector
Aveva.Pdms.Geometry.Position
Aveva.Pdms.Geometry.Position2D
Aveva.Pdms.Geometry.RadialGrid
Aveva.Pdms.Geometry.RadialGrid2D
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aveva.Pdms.Geometry.Axis
Aveva.Pdms.Geometry.Axis2D

See Also

Aveva.Pdms.Geometry Namespace