Aveva.Pdms.Utilities.CommandLine

AVEVA Utilities .NET Public Interface

Aveva.Pdms.Utilities.CommandLine Namespace

Namespace hierarchy

Classes

Class | Description
Command | Interface to PDMS command line and PML variables. AVEVA USE ONLY.
©AVEVA Solutions Ltd 2007


Command Class

Interface to PDMS command line and PML variables. AVEVA USE ONLY.

For a list of all members of this type, see Command Members.

System.Object
Aveva.Pdms.Utilities.CommandLine.Command

public abstract class Command

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Utilities.CommandLine

Assembly: Aveva.Pdms.Utilities (in Aveva.Pdms.Utilities.dll)

See Also

Command Members | Aveva.Pdms.Utilities.CommandLine Namespace


Command Members

Command overview

Public Static Methods

CreateCommand | Create a PDMS command.
FormRefresh | Refresh PML forms
Update | Update forms to reflect changes made. The database changes event will be fired at this point.

Public Instance Properties

CommandString | Command text
Error | Error that occurred as a result of invoking command
Result | Result of command, as would be output on the command line.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPMLVariableBoolean | Get value of PML boolean variable
GetPMLVariableReal | Get value of PML floating point variable
GetPMLVariableString | Get value of PML string variable
GetType (inherited from Object) | Gets the Type of the current instance.
Queue |
Run | Invoke Command
RunInPdms | Invoke command outputting error in PDMS rather than returning error
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Command Class | Aveva.Pdms.Utilities.CommandLine Namespace


Command Properties

The properties of the Command class are listed below. For a complete list of Command class members, see the Command Members topic.

Public Instance Properties

CommandString | Command text
Error | Error that occurred as a result of invoking command
Result | Result of command, as would be output on the command line.

See Also

Command Class | Aveva.Pdms.Utilities.CommandLine Namespace


CommandString Property

AVEVA Utilities .NET Public Interface

Command.CommandString Property

Command text

public abstract string CommandString {get; set;}

See Also

Command Class | Aveva.Pdms.Utilities.CommandLine Namespace


Error Property

AVEVA Utilities .NET Public Interface

Command.Error Property

Error that occurred as a result of invoking command

public abstract Aveva.Pdms.Utilities.Messaging.PdmsMessage Error {get;}

See Also

Command Class | Aveva.Pdms.Utilities.CommandLine Namespace


Result Property

AVEVA Utilities .NET Public Interface

Command.Result Property

Result of command, as would be output on the command line.

public abstract string Result {get;}

See Also

Command Class | Aveva.Pdms.Utilities.CommandLine Namespace


Command Methods

The methods of the Command class are listed below. For a complete list of Command class members, see the Command Members topic.

Public Static Methods

CreateCommand | Create a PDMS command.
FormRefresh | Refresh PML forms
Update | Update forms to reflect changes made. The database changes event will be fired at this point.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPMLVariableBoolean | Get value of PML boolean variable
GetPMLVariableReal | Get value of PML floating point variable
GetPMLVariableString | Get value of PML string variable
GetType (inherited from Object) | Gets the Type of the current instance.
Queue |
Run | Invoke Command
RunInPdms | Invoke command outputting error in PDMS rather than returning error
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Command Class | Aveva.Pdms.Utilities.CommandLine Namespace


Command.CreateCommand Method

Create a PDMS command.

public static Command CreateCommand(
string commandString
);

Parameters

commandString
Command text

Return Value

Command object

See Also

Command Class | Aveva.Pdms.Utilities.CommandLine Namespace


Command.FormRefresh Method

Refresh PML forms

public static void FormRefresh();

See Also

Command Class | Aveva.Pdms.Utilities.CommandLine Namespace


Command.GetPMLVariableBoolean Method

Get value of PML boolean variable

public abstract bool GetPMLVariableBoolean(
string name
);

Parameters

name

Return Value

See Also

Command Class | Aveva.Pdms.Utilities.CommandLine Namespace


Command.GetPMLVariableReal Method

Get value of PML floating point variable

public abstract double GetPMLVariableReal(
string name
);

Parameters

name

Return Value

See Also

Command Class | Aveva.Pdms.Utilities.CommandLine Namespace


Command.GetPMLVariableString Method

Get value of PML string variable

public abstract string GetPMLVariableString(
string name
);

Parameters

name

Return Value

See Also

Command Class | Aveva.Pdms.Utilities.CommandLine Namespace


Command.Queue Method

public abstract void Queue();

See Also

Command Class | Aveva.Pdms.Utilities.CommandLine Namespace


Command.Run Method

Invoke Command

public abstract bool Run();

Return Value

See Also

Command Class | Aveva.Pdms.Utilities.CommandLine Namespace


Command.RunInPdms Method

Invoke command outputting error in PDMS rather than returning error

public abstract bool RunInPdms();

Return Value

See Also

Command Class | Aveva.Pdms.Utilities.CommandLine Namespace


Command.Update Method

Update forms to reflect changes made. The database changes event will be fired at this point.

public static void Update();

See Also

Command Class | Aveva.Pdms.Utilities.CommandLine Namespace


Aveva.Pdms.Utilities.Messaging

AVEVA Utilities .NET Public Interface

Aveva.Pdms.Utilities.Messaging Namespace

Namespace hierarchy

Classes

Class | Description
PdmsException | Exception handling class. All PDMS exceptions should throw a PdmsException object.
PdmsMessage | PDMS application message. Every message is identified by a module number and message number. The messages are defined in separate message files. Each nessage may have a nimber of substitutions denoted by '$x' in the message. These substitutions are filled at run time.

Interfaces

Interface | Description
IMessage | Interface IMessage.

Delegates

Delegate | Description
MessageConvert |


IMessage Interface

Interface IMessage.

For a list of all members of this type, see IMessage Members.

public interface IMessage

Requirements

Namespace: Aveva.Pdms.Utilities.Messaging

Assembly: Aveva.Pdms.Utilities (in Aveva.Pdms.Utilities.dll)

See Also

IMessage Members | Aveva.Pdms.Utilities.Messaging Namespace


IMessage Members

IMessage overview

Public Instance Methods

PassObjectToCPP Pass object through to C++.

See Also

IMessage Interface | Aveva.Pdms.Utilities.Messaging Namespace


IMessage Methods

The methods of the IMessage interface are listed below. For a complete list of IMessage interface members, see the IMessage Members topic.

Public Instance Methods

PassObjectToCPP Pass object through to C++.

See Also

IMessage Interface | Aveva.Pdms.Utilities.Messaging Namespace


IMessage.PassObjectToCPP Method

Pass object through to C++.

void PassObjectToCPP(
int pos,
PdmsMessage message
);

Parameters

pos
Position index ??
message
Associated message

See Also

IMessage Interface | Aveva.Pdms.Utilities.Messaging Namespace


MessageConvert Delegate

public delegate IMessage MessageConvert(
int pos,
PdmsMessage msg
);

Requirements

Namespace: Aveva.Pdms.Utilities.Messaging

Assembly: Aveva.Pdms.Utilities (in Aveva.Pdms.Utilities.dll)

See Also

Aveva.Pdms.Utilities.Messaging Namespace


PdmsException Class

Exception handling class. All PDMS exceptions should throw a PdmsException object.

For a list of all members of this type, see PdmsException Members.

System.Object
System.Exception
System.ApplicationException
Aveva.Pdms.Utilities.Messaging.PdmsException

public abstract class PdmsException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Utilities.Messaging

Assembly: Aveva.Pdms.Utilities (in Aveva.Pdms.Utilities.dll)

See Also

PdmsException Members | Aveva.Pdms.Utilities.Messaging Namespace


PdmsException Members

PdmsException overview

Public Instance Properties

Error | error associated with exception
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
Output | Output Error associated with exception
ToString | Convert to string

See Also

PdmsException Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsException Properties

The properties of the PdmsException class are listed below. For a complete list of PdmsException class members, see the PdmsException Members topic.

Public Instance Properties

Error | error associated with exception
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

PdmsException Class | Aveva.Pdms.Utilities.Messaging Namespace


Error Property

AVEVA Utilities .NET Public Interface

PdmsException.Error Property

error associated with exception

public abstract PdmsMessage Error {get;}

See Also

PdmsException Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsException Methods

The methods of the PdmsException class are listed below. For a complete list of PdmsException class members, see the PdmsException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
Output | Output Error associated with exception
ToString | Convert to string

See Also

PdmsException Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsException.Output Method

Output Error associated with exception

public abstract void Output();

See Also

PdmsException Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsException.ToString Method

Convert to string

public abstract string ToString();

Return Value

See Also

PdmsException Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage Class

PDMS application message. Every message is identified by a module number and message number. The messages are defined in separate message files. Each nessage may have a nimber of substitutions denoted by '$x' in the message. These substitutions are filled at run time.

For a list of all members of this type, see PdmsMessage Members.

System.Object
Aveva.Pdms.Utilities.Messaging.PdmsMessage

public abstract class PdmsMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Utilities.Messaging

Assembly: Aveva.Pdms.Utilities (in Aveva.Pdms.Utilities.dll)

See Also

PdmsMessage Members | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage Members

PdmsMessage overview

Public Static Methods

AddElementDelegate | Add in delegate to cope with Elements- AVEVA USE ONLY.
AddHashDelegate | Add in delegate to cope with attributes, nouns- AVEVA USE ONLY.
CreateMessage | Creates a PDMS message.
FlushPmlErrors | AVEVA USE ONLY
GetLastError | AVEVA USE ONLY
Output | Output a list of messages, filling in any substitutions
ResetErrorOccurred | AVEVA USE ONLY
SaveLastError | AVEVA USE ONLY

Public Instance Properties

MessageNumber | message number.
ModuleNumber | module number for message.

Public Instance Methods

EmbedMessage | Embed a message within this message.
EmbedMessages | Embed a list of messages within this message.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble | Get real substitution.
GetElement | Get Element substitution.
GetHash | Get attribute or element type substitution.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt | Get integer substitution.
GetName | Get text substitution.
GetType (inherited from Object) | Gets the Type of the current instance.
MessageText | Obtains message text, filling in any substitutions.
OutputError | Output message as an error, filling in any substitutions.
Reset | Unset all substitutions and remove embedded messages.
RetrieveEmbeddedMessages | Retrieve embedded messages.
SetDouble | Set real substitutions.
SetElement | Set Element substitutions.
SetHash | Set attribute or element type substitutions.
SetInt | Set integer substitutions.
SetName | Set text substitutions.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage Properties

The properties of the PdmsMessage class are listed below. For a complete list of PdmsMessage class members, see the PdmsMessage Members topic.

Public Instance Properties

MessageNumber | message number.
ModuleNumber | module number for message.

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


MessageNumber Property

AVEVA Utilities .NET Public Interface

PdmsMessage.MessageNumber Property

message number.

public abstract int MessageNumber {get;}

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


ModuleNumber Property

AVEVA Utilities .NET Public Interface

PdmsMessage.ModuleNumber Property

module number for message.

public abstract int ModuleNumber {get;}

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage Methods

The methods of the PdmsMessage class are listed below. For a complete list of PdmsMessage class members, see the PdmsMessage Members topic.

Public Static Methods

AddElementDelegate | Add in delegate to cope with Elements- AVEVA USE ONLY.
AddHashDelegate | Add in delegate to cope with attributes, nouns- AVEVA USE ONLY.
CreateMessage | Creates a PDMS message.
FlushPmlErrors | AVEVA USE ONLY
GetLastError | AVEVA USE ONLY
Output | Output a list of messages, filling in any substitutions
ResetErrorOccurred | AVEVA USE ONLY
SaveLastError | AVEVA USE ONLY

Public Instance Methods

EmbedMessage | Embed a message within this message.
EmbedMessages | Embed a list of messages within this message.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDouble | Get real substitution.
GetElement | Get Element substitution.
GetHash | Get attribute or element type substitution.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInt | Get integer substitution.
GetName | Get text substitution.
GetType (inherited from Object) | Gets the Type of the current instance.
MessageText | Obtains message text, filling in any substitutions.
OutputError | Output message as an error, filling in any substitutions.
Reset | Unset all substitutions and remove embedded messages.
RetrieveEmbeddedMessages | Retrieve embedded messages.
SetDouble | Set real substitutions.
SetElement | Set Element substitutions.
SetHash | Set attribute or element type substitutions.
SetInt | Set integer substitutions.
SetName | Set text substitutions.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.AddElementDelegate Method

Add in delegate to cope with Elements- AVEVA USE ONLY.

public static void AddElementDelegate(
MessageConvert dele
);

Parameters

dele

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.AddHashDelegate Method

Add in delegate to cope with attributes, nouns- AVEVA USE ONLY.

public static void AddHashDelegate(
MessageConvert dele
);

Parameters

dele

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.CreateMessage Method

Creates a PDMS message.

public static PdmsMessage CreateMessage(
int module,
int messagenum
);

Parameters

module
messagenum

Return Value

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.EmbedMessage Method

Embed a message within this message.

public abstract void EmbedMessage(
PdmsMessage message
);

Parameters

message

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.EmbedMessages Method

Embed a list of messages within this message.

public abstract void EmbedMessages(
PdmsMessage[] messages
);

Parameters

messages

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.FlushPmlErrors Method

AVEVA USE ONLY

public static void FlushPmlErrors();

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.GetDouble Method

Get real substitution.

public abstract double GetDouble(
int pos
);

Parameters

pos
substitution number

Return Value

double value

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.GetElement Method

Get Element substitution.

public abstract IMessage GetElement(
int pos
);

Parameters

pos
substitution number

Return Value

element

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.GetHash Method

Get attribute or element type substitution.

public abstract IMessage GetHash(
int pos
);

Parameters

pos
substitution number

Return Value

attribute / element type

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.GetInt Method

Get integer substitution.

public abstract int GetInt(
int pos
);

Parameters

pos
substitution number

Return Value

integer value

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.GetLastError Method

AVEVA USE ONLY

public static PdmsMessage GetLastError();

Return Value

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.GetName Method

Get text substitution.

public abstract string GetName(
int pos
);

Parameters

pos
substitution number

Return Value

text value

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.MessageText Method

Obtains message text, filling in any substitutions.

public abstract string MessageText();

Return Value

message text

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.Output Method

Output a list of messages, filling in any substitutions

public static void Output(
PdmsMessage[] messages
);

Parameters

messages

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.OutputError Method

Output message as an error, filling in any substitutions.

public abstract void OutputError();

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.Reset Method

Unset all substitutions and remove embedded messages.

public abstract void Reset();

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.ResetErrorOccurred Method

AVEVA USE ONLY

public static void ResetErrorOccurred();

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.RetrieveEmbeddedMessages Method

Retrieve embedded messages.

public abstract PdmsMessage[] RetrieveEmbeddedMessages();

Return Value

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.SaveLastError Method

AVEVA USE ONLY

public static void SaveLastError(
bool save
);

Parameters

save

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.SetDouble Method

Set real substitutions.

public abstract void SetDouble(
int pos,
double val
);

Parameters

pos
substitution number
val
double value

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.SetElement Method

Set Element substitutions.

public abstract void SetElement(
int pos,
IMessage ele
);

Parameters

pos
substitution number
ele
element

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.SetHash Method

Set attribute or element type substitutions.

public abstract void SetHash(
int pos,
IMessage att
);

Parameters

pos
substitution number
att
attribute or element type

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.SetInt Method

Set integer substitutions.

public abstract void SetInt(
int pos,
int val
);

Parameters

pos
substitution number
val
integer value

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


PdmsMessage.SetName Method

Set text substitutions.

public abstract void SetName(
int pos,
object val
);

Parameters

pos
substitution number
val
object, yielding text

See Also

PdmsMessage Class | Aveva.Pdms.Utilities.Messaging Namespace


Aveva.Pdms.Utilities.StringUtilities

AVEVA Utilities .NET Public Interface

Aveva.Pdms.Utilities.StringUtilities Namespace

Namespace hierarchy

Classes

Class | Description
Hash | Provides access to hash and dehash methods


Hash Class

Provides access to hash and dehash methods

For a list of all members of this type, see Hash Members.

System.Object
Aveva.Pdms.Utilities.StringUtilities.Hash

public abstract class Hash

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Utilities.StringUtilities

Assembly: Aveva.Pdms.Utilities (in Aveva.Pdms.Utilities.dll)

See Also

Hash Members | Aveva.Pdms.Utilities.StringUtilities Namespace


Hash Members

Hash overview

Public Static Methods

CreateHash Create a PDMS Hash command.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
hashValueToString |
stringToHashValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Hash Class | Aveva.Pdms.Utilities.StringUtilities Namespace


Hash Methods

The methods of the Hash class are listed below. For a complete list of Hash class members, see the Hash Members topic.

Public Static Methods

CreateHash Create a PDMS Hash command.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
hashValueToString |
stringToHashValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Hash Class | Aveva.Pdms.Utilities.StringUtilities Namespace


Hash.CreateHash Method

Create a PDMS Hash command.

public static Hash CreateHash();

Return Value

Hash object

See Also

Hash Class | Aveva.Pdms.Utilities.StringUtilities Namespace


Hash.hashValueToString Method

public abstract string hashValueToString(
int Number
);

See Also

Hash Class | Aveva.Pdms.Utilities.StringUtilities Namespace


Hash.stringToHashValue Method

public abstract int stringToHashValue(
string s
);

See Also

Hash Class | Aveva.Pdms.Utilities.StringUtilities Namespace


Aveva.Pdms.Utilities.Tracing

AVEVA Utilities .NET Public Interface

Aveva.Pdms.Utilities.Tracing Namespace

Namespace hierarchy

Classes

Class | Description
PdmsTrace | PDMS application tracing control. This class includes facilities to output trace statements, monitor CPU, and retrieving the current trace entry stack. Trace entry/exit is done via the TraceEntry class.
TraceEntry | Class to do subroutine entry and exit trace. The object should be created on the first line off a method. The Dispose method must be called(implicitly or explicitly) on method exit.

Enumerations

Enumeration | Description
TraceNumber | Trace Number enumeration.


PdmsTrace Class

PDMS application tracing control. This class includes facilities to output trace statements, monitor CPU, and retrieving the current trace entry stack. Trace entry/exit is done via the TraceEntry class.

For a list of all members of this type, see PdmsTrace Members.

System.Object
Aveva.Pdms.Utilities.Tracing.PdmsTrace

public abstract class PdmsTrace

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Utilities.Tracing

Assembly: Aveva.Pdms.Utilities (in Aveva.Pdms.Utilities.dll)

See Also

PdmsTrace Members | Aveva.Pdms.Utilities.Tracing Namespace


PdmsTrace Members

PdmsTrace overview

Public Static Properties

CPUTraceStarted | Indicates if CPU monitoring is on or not
Enabled | Enable or disable tracing
TraceLog | Log file for trace.

Public Static Methods

GetTraceback | Get current stack of trace entries
GetTraceFlag | Get value of specified trace flag
SetTraceFlag | Set value of specified trace flag
StartCPUTrace | Turn on CPU recording (suppressing trace output)
StopCPUTrace | Turn off CPU recording, outputting results. Standard trace output will be reactivated.
TestFlag | Test if trace flag is non zero
TestFlagBit | Test if bit value for trace flag is set.
Trace | Overloaded. Output values as trace converting via 'ToString'. Trace output should always be conditional on a trace flag value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace


PdmsTrace Properties

The properties of the PdmsTrace class are listed below. For a complete list of PdmsTrace class members, see the PdmsTrace Members topic.

Public Static Properties

CPUTraceStarted | Indicates if CPU monitoring is on or not
Enabled | Enable or disable tracing
TraceLog | Log file for trace.

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace


CPUTraceStarted Property

AVEVA Utilities .NET Public Interface

PdmsTrace.CPUTraceStarted Property

Indicates if CPU monitoring is on or not

public static bool CPUTraceStarted {get;}

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace


Enabled Property

AVEVA Utilities .NET Public Interface

PdmsTrace.Enabled Property

Enable or disable tracing

public static bool Enabled {get; set;}

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace


TraceLog Property

AVEVA Utilities .NET Public Interface

PdmsTrace.TraceLog Property

Log file for trace.

public static string TraceLog {get; set;}

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace


PdmsTrace Methods

The methods of the PdmsTrace class are listed below. For a complete list of PdmsTrace class members, see the PdmsTrace Members topic.

Public Static Methods

GetTraceback | Get current stack of trace entries
GetTraceFlag | Get value of specified trace flag
SetTraceFlag | Set value of specified trace flag
StartCPUTrace | Turn on CPU recording (suppressing trace output)
StopCPUTrace | Turn off CPU recording, outputting results. Standard trace output will be reactivated.
TestFlag | Test if trace flag is non zero
TestFlagBit | Test if bit value for trace flag is set.
Trace | Overloaded. Output values as trace converting via 'ToString'. Trace output should always be conditional on a trace flag value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace


PdmsTrace.GetTraceback Method

Get current stack of trace entries

public static string GetTraceback(
bool outputToConsole
);

Parameters

outputToConsole
Output or not

Return Value

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace


PdmsTrace.GetTraceFlag Method

Get value of specified trace flag

public static int GetTraceFlag(
TraceNumber traceNumber
);

Parameters

traceNumber
trace number

Return Value

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace


PdmsTrace.SetTraceFlag Method

Set value of specified trace flag

public static void SetTraceFlag(
TraceNumber traceNumber,
int value
);

Parameters

traceNumber
trace number
value
new value to set trace number to

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace


PdmsTrace.StartCPUTrace Method

Turn on CPU recording (suppressing trace output)

public static void StartCPUTrace();

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace


PdmsTrace.StopCPUTrace Method

Turn off CPU recording, outputting results. Standard trace output will be reactivated.

public static string StopCPUTrace(
bool outputToConsole
);

Parameters

outputToConsole
output or not

Return Value

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace


PdmsTrace.TestFlag Method

Test if trace flag is non zero

public static bool TestFlag(
TraceNumber traceNumber
);

Parameters

traceNumber
trace number

Return Value

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace


PdmsTrace.TestFlagBit Method

Test if bit value for trace flag is set.

public static bool TestFlagBit(
TraceNumber traceNumber,
int bit
);

Parameters

traceNumber
trace number
bit
bit number

Return Value

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace


Trace Method

AVEVA Utilities .NET Public Interface

PdmsTrace.Trace Method

Output values as trace converting via 'ToString'. Trace output should always be conditional on a trace flag value.

Overload List

Output values as trace converting via 'ToString'. Trace output should always be conditional on a trace flag value.

public static void Trace(ArrayList);

Output value as trace converting via 'ToString'. Trace output should always be conditional on a trace flag value.

public static void Trace(object);

Output string as trace. Trace output should always be conditional on a trace flag value.

public static void Trace(string);

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace


PdmsTrace.Trace Method (ArrayList)

Output values as trace converting via 'ToString'. Trace output should always be conditional on a trace flag value.

public static void Trace(
ArrayList list
);

Parameters

list

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace | PdmsTrace.Trace Overload List


PdmsTrace.Trace Method (Object)

Output value as trace converting via 'ToString'. Trace output should always be conditional on a trace flag value.

public static void Trace(
object val
);

Parameters

val

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace | PdmsTrace.Trace Overload List


PdmsTrace.Trace Method (String)

Output string as trace. Trace output should always be conditional on a trace flag value.

public static void Trace(
string val
);

Parameters

val

See Also

PdmsTrace Class | Aveva.Pdms.Utilities.Tracing Namespace | PdmsTrace.Trace Overload List


TraceEntry Class

Class to do subroutine entry and exit trace. The object should be created on the first line off a method. The Dispose method must be called(implicitly or explicitly) on method exit.

For a list of all members of this type, see TraceEntry Members.

System.Object
Aveva.Pdms.Utilities.Tracing.TraceEntry

public abstract class TraceEntry : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Utilities.Tracing

Assembly: Aveva.Pdms.Utilities (in Aveva.Pdms.Utilities.dll)

See Also

TraceEntry Members | Aveva.Pdms.Utilities.Tracing Namespace


TraceEntry Members

TraceEntry overview

Public Static Methods

Enter Create trace entry object.

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TraceEntry Class | Aveva.Pdms.Utilities.Tracing Namespace


TraceEntry Methods

The methods of the TraceEntry class are listed below. For a complete list of TraceEntry class members, see the TraceEntry Members topic.

Public Static Methods

Enter Create trace entry object.

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TraceEntry Class | Aveva.Pdms.Utilities.Tracing Namespace


TraceEntry.Dispose Method

public abstract void Dispose();

Implements

IDisposable.Dispose

See Also

TraceEntry Class | Aveva.Pdms.Utilities.Tracing Namespace


TraceEntry.Enter Method

Create trace entry object.

public static TraceEntry Enter(
string routineName,
TraceNumber traceNumber
);

Parameters

routineName
name to be output
traceNumber
trace number to test against before outputting entry trace

Return Value

See Also

TraceEntry Class | Aveva.Pdms.Utilities.Tracing Namespace


TraceNumber Enumeration

Trace Number enumeration.

public enum TraceNumber

Members

Member Name | Description
TRACE_ACTION | Trace actions, as now
TRACE_ACTIONLAYER | Trace ACTIONLAYER entry and exit
TRACE_ADMIN_DETAIL | Additional trace information in Admin
TRACE_ADMIN_GTIGS | Information about GTIGS use in Admin
TRACE_ADMIN_RCF | Integrity checking in RCF1
TRACE_APPLICATION | Trace Application entry and exit
TRACE_ATTLIB | DBLAYER/ATTLIB tracing
TRACE_BASICLAYER | Trace BASICLAYER entry and exit
TRACE_BOXLIB | entry and exit trace in BOXLIB
TRACE_BRW | Binary read/write routines BASICLAYER/BRW
TRACE_CACHELAYER_ADDITIONAL | additional tracing in CACHELAYER
TRACE_CACHELAYER_STEELWORK | steelwork tracing in CACHELAYER
TRACE_CLASHLAYER | Clash layer tracing
TRACE_CLASHLAYER_MORE | Clash layer tracing
TRACE_CLASHLAYER_REPORT | Clash layer tracing
TRACE_CMPLIB_EXTRA | Comparator additional output
TRACE_COPYLIB | BASICLAYER data copying routines
TRACE_CVLIB_EXTRA | Comparator additional output
TRACE_DABACON | Trace DABACON routines
TRACE_DABERR_TRACEBACK | Output traceback on DABACON errors
TRACE_DB_INTEGRITY | Database integrity checking in Admin
TRACE_DB_OPEN | Show information on database opening if >2
TRACE_DBLAYER | Trace DBLAYER entry and exit
TRACE_DEFAULT | Default trace flag for the trace system
TRACE_DESIGN_FORCE_GML | force use of GML even for non-holy primitives
TRACE_DESIGN_RECONNECT | trace reconnection of entities
TRACE_DESIGN_SPECIALS | Design special cases
TRACE_DRAFT_AUTOTEXT | Draft automatic text system
TRACE_DRAFT_PICTURE | Trace Draft Picture file creation
TRACE_EVENTLAYER | EVENTLAYER - graphical interaction
TRACE_EXIT | Trace exit from routines
TRACE_EXPRLIB_REINIT | re-initialise EXPRLIB at start of each expression
TRACE_FECS | FECS conversion routines
TRACE_FILEHANDLING | Low level File handling
TRACE_FIXACTIONS | Escape route for ham fisted program testers
TRACE_FLEXLM | calls to FLEXLM routines
TRACE_FM | Forms and menus trace flag
TRACE_FUNCLAYER | Trace FUNCLAYER entry and exit
TRACE_INTLAYER | INTLAYER - forms & menus syntax
TRACE_ISODRAW | ISODRAW Trace flags
TRACE_ISOLAYER | ISOLAYER tracing
TRACE_ISOLAYER_UTIL | ISOLAYER utilities
TRACE_MAP | map maintenance
TRACE_MATHLIB | BASICLAYER MATHLIB routines
TRACE_MDB_COPY | Copying of databases in MDBLIB
TRACE_MEMORY_CHECK | Checks memory in CHKSTK
TRACE_MESSAGE | Message system
TRACE_MODULE_SWITCH | Module switching trace
TRACE_NESTED_TMPL | Allow nested templates in Design
TRACE_NOUNLIB | DBLAYER/NOUNLIB trace
TRACE_NXLIB | NXLIB trace
TRACE_PADDLAYER | Control PADDLAYER output
TRACE_PADDLAYER_CHANGEADC | PADDLAYER/CHANGEADC_SRC
TRACE_PADDLAYER_DIMENSIONS | Tracing of PADDLAYER dimensions
TRACE_PADDLAYER_IDS | display ids
TRACE_PADDLAYER_VIEWS | View updating
TRACE_PART_NUMBER | Design part numbering trace
TRACE_PML | PML
TRACE_RESTRICTED | Restricted syntax enable flag
TRACE_ROUTER | ROUTER trace
TRACE_SELECT | selection tracing
TRACE_SELECT_EXPR | Print selection expression
TRACE_SGL | SGL
TRACE_SHOW_BOXLIB | output box limits from BOXLIB/DBBOXLIB
TRACE_SHOW_EXPRESSION | show expression stack before execution
TRACE_SHOW_MAPLIB | Parameters in Spatial map routines
TRACE_SHOW_UDA | UDA system trace
TRACE_SPATIAL_MAP_INSTANCE | item being mapped
TRACE_SPOOL_NUMBER | Design spool numbering trace
TRACE_SPOOLER | Module SPOOLER
TRACE_SYSTEM_DB | Show information on system database if >1
TRACE_WIGWAM_WARN_NOIGNORE | Do not ignore Wigwam warnings

Requirements

Namespace: Aveva.Pdms.Utilities.Tracing

Assembly: Aveva.Pdms.Utilities (in Aveva.Pdms.Utilities.dll)

See Also

Aveva.Pdms.Utilities.Tracing Namespace


Aveva.Pdms.Utilities.Undo

AVEVA Utilities .NET Public Interface

Aveva.Pdms.Utilities.Undo Namespace

Namespace hierarchy

Classes

Class | Description
UndoCaretaker | This class registers any UndoSubscribers
UndoSubscriber | The UndoSubscriber class is the base class for components that participate in the undo system. To particpate in the undo system, a new class must be derived from UndoSubscriber. An instance of the class must then be registered in the system via the UndoCaretaker class. For each instance registered, the methods will be invoked as follows: For a start transaction- GetStartState() will be invoked. For a end transaction- GetEndState() will be invoked. For a undo- RestoreStartState() will be invoked. For a redo- RestoreEndState() will be invoked. The states returned by GetStartState, GetEndState will be managed by the undo system
UndoTransaction | This class is used to: a) Start and end an UndoTransaction transaction b) Static method to Clear all transactions c) Static method to denote that a significant event is about to happen


UndoCaretaker Class

This class registers any UndoSubscribers

For a list of all members of this type, see UndoCaretaker Members.

System.Object
Aveva.Pdms.Utilities.Undo.UndoCaretaker

public abstract class UndoCaretaker

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Utilities.Undo

Assembly: Aveva.Pdms.Utilities (in Aveva.Pdms.Utilities.dll)

See Also

UndoCaretaker Members | Aveva.Pdms.Utilities.Undo Namespace


UndoCaretaker Members

UndoCaretaker overview

Public Static Methods

ClearAllTransactions | Clear all Undo Transactions as they are no longer valid
RegisterUndoSubscriber | Register a subscriber
RemoveUndoSubscriber | Remove a subscriber
SignificantEventAboutToHappen | Signal that a Significant Event is about to happen. The consequences of this are: a) Clears the redo stack b) Starts a transaction if not already started.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UndoCaretaker Class | Aveva.Pdms.Utilities.Undo Namespace


UndoCaretaker Methods

The methods of the UndoCaretaker class are listed below. For a complete list of UndoCaretaker class members, see the UndoCaretaker Members topic.

Public Static Methods

ClearAllTransactions | Clear all Undo Transactions as they are no longer valid
RegisterUndoSubscriber | Register a subscriber
RemoveUndoSubscriber | Remove a subscriber
SignificantEventAboutToHappen | Signal that a Significant Event is about to happen. The consequences of this are: a) Clears the redo stack b) Starts a transaction if not already started.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UndoCaretaker Class | Aveva.Pdms.Utilities.Undo Namespace


UndoCaretaker.ClearAllTransactions Method

Clear all Undo Transactions as they are no longer valid

public static void ClearAllTransactions();

See Also

UndoCaretaker Class | Aveva.Pdms.Utilities.Undo Namespace


UndoCaretaker.RegisterUndoSubscriber Method

Register a subscriber

public static void RegisterUndoSubscriber(
UndoSubscriber subscriber
);

Parameters

subscriber
subscriber instance

See Also

UndoCaretaker Class | Aveva.Pdms.Utilities.Undo Namespace


UndoCaretaker.RemoveUndoSubscriber Method

Remove a subscriber

public static void RemoveUndoSubscriber(
UndoSubscriber subscriber
);

Parameters

subscriber
subscriber instance

See Also

UndoCaretaker Class | Aveva.Pdms.Utilities.Undo Namespace


UndoCaretaker.SignificantEventAboutToHappen Method

Signal that a Significant Event is about to happen. The consequences of this are: a) Clears the redo stack b) Starts a transaction if not already started.

public static void SignificantEventAboutToHappen();

See Also

UndoCaretaker Class | Aveva.Pdms.Utilities.Undo Namespace


UndoSubscriber Class

The UndoSubscriber class is the base class for components that participate in the undo system. To particpate in the undo system, a new class must be derived from UndoSubscriber. An instance of the class must then be registered in the system via the UndoCaretaker class. For each instance registered, the methods will be invoked as follows:

For a start transaction- GetStartState() will be invoked.

For a end transaction- GetEndState() will be invoked.

For a undo- RestoreStartState() will be invoked.

For a redo- RestoreEndState() will be invoked.

The states returned by GetStartState, GetEndState will be managed by the undo system

For a list of all members of this type, see UndoSubscriber Members.

System.Object
Aveva.Pdms.Utilities.Undo.UndoSubscriber

public abstract class UndoSubscriber

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Utilities.Undo

Assembly: Aveva.Pdms.Utilities (in Aveva.Pdms.Utilities.dll)

See Also

UndoSubscriber Members | Aveva.Pdms.Utilities.Undo Namespace


UndoSubscriber Members

UndoSubscriber overview

Public Instance Constructors

UndoSubscriber Constructor Initializes a new instance of the UndoSubscriber class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBeginState | GetStartState() will be called on start transaction. It should return the current state.
GetEndState | GetStartState() will be called on end transaction. It should return the current state.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RestoreBeginState | RestoreStartState() will be called on undo of that transaction. It should restore the passed state.
RestoreEndState | RestoreEndState() will be called on undo of that transaction. It should restore the passed state.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UndoSubscriber Class | Aveva.Pdms.Utilities.Undo Namespace


UndoSubscriber Constructor

Initializes a new instance of the UndoSubscriber class.

public UndoSubscriber();

See Also

UndoSubscriber Class | Aveva.Pdms.Utilities.Undo Namespace


UndoSubscriber Methods

The methods of the UndoSubscriber class are listed below. For a complete list of UndoSubscriber class members, see the UndoSubscriber Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBeginState | GetStartState() will be called on start transaction. It should return the current state.
GetEndState | GetStartState() will be called on end transaction. It should return the current state.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RestoreBeginState | RestoreStartState() will be called on undo of that transaction. It should restore the passed state.
RestoreEndState | RestoreEndState() will be called on undo of that transaction. It should restore the passed state.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UndoSubscriber Class | Aveva.Pdms.Utilities.Undo Namespace


UndoSubscriber.GetBeginState Method

GetStartState() will be called on start transaction. It should return the current state.

public abstract object GetBeginState();

See Also

UndoSubscriber Class | Aveva.Pdms.Utilities.Undo Namespace


UndoSubscriber.GetEndState Method

GetStartState() will be called on end transaction. It should return the current state.

public abstract object GetEndState();

See Also

UndoSubscriber Class | Aveva.Pdms.Utilities.Undo Namespace


UndoSubscriber.RestoreBeginState Method

RestoreStartState() will be called on undo of that transaction. It should restore the passed state.

public abstract void RestoreBeginState(
object obj
);

See Also

UndoSubscriber Class | Aveva.Pdms.Utilities.Undo Namespace


UndoSubscriber.RestoreEndState Method

RestoreEndState() will be called on undo of that transaction. It should restore the passed state.

public abstract void RestoreEndState(
object obj
);

See Also

UndoSubscriber Class | Aveva.Pdms.Utilities.Undo Namespace


UndoTransaction Class

This class is used to: a) Start and end an UndoTransaction transaction b) Static method to Clear all transactions c) Static method to denote that a significant event is about to happen

For a list of all members of this type, see UndoTransaction Members.

System.Object
Aveva.Pdms.Utilities.Undo.UndoTransaction

public abstract class UndoTransaction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Utilities.Undo

Assembly: Aveva.Pdms.Utilities (in Aveva.Pdms.Utilities.dll)

See Also

UndoTransaction Members | Aveva.Pdms.Utilities.Undo Namespace


UndoTransaction Members

UndoTransaction overview

Public Static Methods

GetUndoTransaction | Get Transaction Object
PerformRedo | Do Redo
PerformUndo | Do Undo

Public Instance Methods

EndTransaction | End an Undo Transaction
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
StartTransaction | Start an Undo Transaction Any existing transaction will be ended
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UndoTransaction Class | Aveva.Pdms.Utilities.Undo Namespace


UndoTransaction Methods

The methods of the UndoTransaction class are listed below. For a complete list of UndoTransaction class members, see the UndoTransaction Members topic.

Public Static Methods

GetUndoTransaction | Get Transaction Object
PerformRedo | Do Redo
PerformUndo | Do Undo

Public Instance Methods

EndTransaction | End an Undo Transaction
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
StartTransaction | Start an Undo Transaction Any existing transaction will be ended
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UndoTransaction Class | Aveva.Pdms.Utilities.Undo Namespace


UndoTransaction.EndTransaction Method

End an Undo Transaction

public abstract void EndTransaction();

See Also

UndoTransaction Class | Aveva.Pdms.Utilities.Undo Namespace


UndoTransaction.GetUndoTransaction Method

Get Transaction Object

public static UndoTransaction GetUndoTransaction();

See Also

UndoTransaction Class | Aveva.Pdms.Utilities.Undo Namespace


UndoTransaction.PerformRedo Method

Do Redo

public static void PerformRedo();

See Also

UndoTransaction Class | Aveva.Pdms.Utilities.Undo Namespace


UndoTransaction.PerformUndo Method

Do Undo

public static void PerformUndo();

See Also

UndoTransaction Class | Aveva.Pdms.Utilities.Undo Namespace


UndoTransaction.StartTransaction Method

Start an Undo Transaction Any existing transaction will be ended

public abstract void StartTransaction(
string description
);

See Also

UndoTransaction Class | Aveva.Pdms.Utilities.Undo Namespace


Aveva.Pdms.Utilities.Units

AVEVA Utilities .NET Public Interface

Aveva.Pdms.Utilities.Units Namespace

Namespace hierarchy

Classes

Class | Description
Bore | Provides access to Nominal Bore methods.


Bore Class

Provides access to Nominal Bore methods.

For a list of all members of this type, see Bore Members.

System.Object
Aveva.Pdms.Utilities.Units.Bore

public abstract class Bore

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Utilities.Units

Assembly: Aveva.Pdms.Utilities (in Aveva.Pdms.Utilities.dll)

See Also

Bore Members | Aveva.Pdms.Utilities.Units Namespace


Bore Members

Bore overview

Public Static Methods

CreateBore Create a PDMS Bore command.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NominalBoreValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Bore Class | Aveva.Pdms.Utilities.Units Namespace


Bore Methods

The methods of the Bore class are listed below. For a complete list of Bore class members, see the Bore Members topic.

Public Static Methods

CreateBore Create a PDMS Bore command.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NominalBoreValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Bore Class | Aveva.Pdms.Utilities.Units Namespace


Bore.CreateBore Method

Create a PDMS Bore command.

public static Bore CreateBore();

Return Value

Bore object

See Also

Bore Class | Aveva.Pdms.Utilities.Units Namespace


Bore.NominalBoreValue Method

public abstract double NominalBoreValue(
double bore,
int hashDimension
);

See Also

Bore Class | Aveva.Pdms.Utilities.Units Namespace


Aveva.Pdms.Utilities.CommandLineHierarchy

AVEVA Utilities .NET Public Interface

Aveva.Pdms.Utilities.CommandLine Hierarchy

System.Object
Aveva.Pdms.Utilities.CommandLine.Command

See Also

Aveva.Pdms.Utilities.CommandLine Namespace


Aveva.Pdms.Utilities.MessagingHierarchy

AVEVA Utilities .NET Public Interface

Aveva.Pdms.Utilities.Messaging Hierarchy

System.Object
Aveva.Pdms.Utilities.Messaging.IMessage
Aveva.Pdms.Utilities.Messaging.PdmsMessage
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aveva.Pdms.Utilities.Messaging.MessageConvert
System.Exception ---- System.Runtime.Serialization.ISerializable
System.ApplicationException
Aveva.Pdms.Utilities.Messaging.PdmsException

See Also

Aveva.Pdms.Utilities.Messaging Namespace


Aveva.Pdms.Utilities.StringUtilitiesHierarchy

AVEVA Utilities .NET Public Interface

Aveva.Pdms.Utilities.StringUtilities Hierarchy

System.Object
Aveva.Pdms.Utilities.StringUtilities.Hash

See Also

Aveva.Pdms.Utilities.StringUtilities Namespace


Aveva.Pdms.Utilities.TracingHierarchy

AVEVA Utilities .NET Public Interface

Aveva.Pdms.Utilities.Tracing Hierarchy

System.Object
Aveva.Pdms.Utilities.Tracing.PdmsTrace
Aveva.Pdms.Utilities.Tracing.TraceEntry ---- System.IDisposable
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aveva.Pdms.Utilities.Tracing.TraceNumber

See Also

Aveva.Pdms.Utilities.Tracing Namespace


Aveva.Pdms.Utilities.UndoHierarchy

AVEVA Utilities .NET Public Interface

Aveva.Pdms.Utilities.Undo Hierarchy

System.Object
Aveva.Pdms.Utilities.Undo.UndoCaretaker
Aveva.Pdms.Utilities.Undo.UndoSubscriber
Aveva.Pdms.Utilities.Undo.UndoTransaction

See Also

Aveva.Pdms.Utilities.Undo Namespace


Aveva.Pdms.Utilities.UnitsHierarchy

AVEVA Utilities .NET Public Interface

Aveva.Pdms.Utilities.Units Hierarchy

System.Object
Aveva.Pdms.Utilities.Units.Bore

See Also

Aveva.Pdms.Utilities.Units Namespace