Aveva.ApplicationFramework

Common Application Framework

Aveva.ApplicationFramework Namespace

Namespace hierarchy

Classes

Class | Description
Addin | Class to represent an ApplicationFramework Addin
AddinEventArgs | Class used to hold the event arguments in Addin related events
AddinManager | Provides properties and methods for the management of ApplicationFramework Addins.
AddinsCollection | Class to represent the collection of loaded ApplicationFramework Addins
ServiceEventArgs | Class used to hold the event arguments in SeviceManager related events
ServiceManager | Provides a means by which the various components of the ApplicationFramework (e.g. Presentation Component) can publish their services. The ServiceManager also acts as a service provider responding to requests for services.
SettingsGroup | Class that represents a named colletion of keyed objects which represent application settings
SettingsGroupsCollection | A collection of SettingsGroup objects
SettingsManager | Class to manage an applications settings

Interfaces

Interface | Description
IAddin | Interface which enables communication between the framework and the addin.

Delegates

Delegate | Description
AddinEventHandler | Represents the method that will handle addin related events.
ServiceEventHandler | Represents the method that will handle service related events.
©AVEVA Solutions Ltd 2007


Addin Class

Class to represent an ApplicationFramework Addin

For a list of all members of this type, see Addin Members.

System.Object
Aveva.ApplicationFramework.Addin

public abstract class Addin

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework

Assembly: Aveva.ApplicationFramework (in Aveva.ApplicationFramework.dll)

See Also

Addin Members | Aveva.ApplicationFramework Namespace


Addin Members

Addin overview

Public Instance Properties

Assembly | Assembly containing the Addin
Description | Addin Description
IsStarted | Get whether the addins Start method has been called.
Name | Addin Name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Calls the Start method on the Addin interface
Stop | Calls the Stop method on the Addin interface
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Addin Class | Aveva.ApplicationFramework Namespace


Addin Properties

The properties of the Addin class are listed below. For a complete list of Addin class members, see the Addin Members topic.

Public Instance Properties

Assembly | Assembly containing the Addin
Description | Addin Description
IsStarted | Get whether the addins Start method has been called.
Name | Addin Name

See Also

Addin Class | Aveva.ApplicationFramework Namespace


Assembly Property

Common Application Framework

Addin.Assembly Property

Assembly containing the Addin

public abstract System.Reflection.Assembly Assembly {get;}

See Also

Addin Class | Aveva.ApplicationFramework Namespace


Description Property

Common Application Framework

Addin.Description Property

Addin Description

public abstract string Description {get;}

See Also

Addin Class | Aveva.ApplicationFramework Namespace


IsStarted Property

Common Application Framework

Addin.IsStarted Property

Get whether the addins Start method has been called.

public abstract bool IsStarted {get;}

See Also

Addin Class | Aveva.ApplicationFramework Namespace


Name Property

Common Application Framework

Addin.Name Property

Addin Name

public abstract string Name {get;}

See Also

Addin Class | Aveva.ApplicationFramework Namespace


Addin Methods

The methods of the Addin class are listed below. For a complete list of Addin class members, see the Addin Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Calls the Start method on the Addin interface
Stop | Calls the Stop method on the Addin interface
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Addin Class | Aveva.ApplicationFramework Namespace


Addin.Start Method

Calls the Start method on the Addin interface

public abstract void Start();

See Also

Addin Class | Aveva.ApplicationFramework Namespace


Addin.Stop Method

Calls the Stop method on the Addin interface

public abstract void Stop();

See Also

Addin Class | Aveva.ApplicationFramework Namespace


AddinEventArgs Class

Class used to hold the event arguments in Addin related events

For a list of all members of this type, see AddinEventArgs Members.

System.Object
System.EventArgs
Aveva.ApplicationFramework.AddinEventArgs

public class AddinEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework

Assembly: Aveva.ApplicationFramework (in Aveva.ApplicationFramework.dll)

See Also

AddinEventArgs Members | Aveva.ApplicationFramework Namespace


AddinEventArgs Members

AddinEventArgs overview

Public Instance Constructors

AddinEventArgs Constructor Constructor for AddinEventArgs

Public Instance Properties

Addin Gets the Addin

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AddinEventArgs Class | Aveva.ApplicationFramework Namespace


AddinEventArgs Constructor

Constructor for AddinEventArgs

public AddinEventArgs(
Addin addin
);

Parameters

addin

See Also

AddinEventArgs Class | Aveva.ApplicationFramework Namespace


AddinEventArgs Properties

The properties of the AddinEventArgs class are listed below. For a complete list of AddinEventArgs class members, see the AddinEventArgs Members topic.

Public Instance Properties

Addin Gets the Addin

See Also

AddinEventArgs Class | Aveva.ApplicationFramework Namespace


Addin Property

Common Application Framework

AddinEventArgs.Addin Property

Gets the Addin

public Addin Addin {get;}

See Also

AddinEventArgs Class | Aveva.ApplicationFramework Namespace


AddinEventHandler Delegate

Represents the method that will handle addin related events.

public delegate void AddinEventHandler(
object sender,
AddinEventArgs args
);

Requirements

Namespace: Aveva.ApplicationFramework

Assembly: Aveva.ApplicationFramework (in Aveva.ApplicationFramework.dll)

See Also

Aveva.ApplicationFramework Namespace


AddinManager Class

Provides properties and methods for the management of ApplicationFramework Addins.

For a list of all members of this type, see AddinManager Members.

System.Object
Aveva.ApplicationFramework.AddinManager

public abstract class AddinManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework

Assembly: Aveva.ApplicationFramework (in Aveva.ApplicationFramework.dll)

See Also

AddinManager Members | Aveva.ApplicationFramework Namespace


AddinManager Members

AddinManager overview

Public Static Properties

Instance Get instance of addin manager

Public Instance Properties

Addins Returns an AddinCollection of Addin objects

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | Loads the Addin defined in the specified assembly
LoadAddins | This method will attempt to load all the addins that are defined in the XML file called 'Application.Name'Addins.xml located in the same directory as the application executable.
StartAddins | This method iterates through the Addins collection and calls the Start method on each of the addins.
StopAddins | This method iterates through the Addins collection and calls the Stop method on each of the addins.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unload | Stop the given Addin and remove it from the Addins collection

Public Instance Events

AddinLoaded | Event fired when an Addin is loaded
AddinStarted | Event fired when an Addin is started
AddinStarting | Event fired when an Addin is starting
AddinUnloaded | Event fired when an Addin is unloaded

See Also

AddinManager Class | Aveva.ApplicationFramework Namespace


AddinManager Properties

The properties of the AddinManager class are listed below. For a complete list of AddinManager class members, see the AddinManager Members topic.

Public Static Properties

Instance Get instance of addin manager

Public Instance Properties

Addins Returns an AddinCollection of Addin objects

See Also

AddinManager Class | Aveva.ApplicationFramework Namespace


Addins Property

Common Application Framework

AddinManager.Addins Property

Returns an AddinCollection of Addin objects

public abstract AddinsCollection Addins {get;}

See Also

AddinManager Class | Aveva.ApplicationFramework Namespace


Instance Property

Common Application Framework

AddinManager.Instance Property

Get instance of addin manager

public static AddinManager Instance {get; set;}

See Also

AddinManager Class | Aveva.ApplicationFramework Namespace


AddinManager Methods

The methods of the AddinManager class are listed below. For a complete list of AddinManager class members, see the AddinManager Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | Loads the Addin defined in the specified assembly
LoadAddins | This method will attempt to load all the addins that are defined in the XML file called 'Application.Name'Addins.xml located in the same directory as the application executable.
StartAddins | This method iterates through the Addins collection and calls the Start method on each of the addins.
StopAddins | This method iterates through the Addins collection and calls the Stop method on each of the addins.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unload | Stop the given Addin and remove it from the Addins collection

See Also

AddinManager Class | Aveva.ApplicationFramework Namespace


AddinManager.Load Method

Loads the Addin defined in the specified assembly

public abstract Addin Load(
string assemblyPath
);

Parameters

assemblyPath
Path to assembly containing the Addin to load

Return Value

See Also

AddinManager Class | Aveva.ApplicationFramework Namespace


AddinManager.LoadAddins Method

This method will attempt to load all the addins that are defined in the XML file called 'Application.Name'Addins.xml located in the same directory as the application executable.

public abstract void LoadAddins();

See Also

AddinManager Class | Aveva.ApplicationFramework Namespace


AddinManager.StartAddins Method

This method iterates through the Addins collection and calls the Start method on each of the addins.

public abstract void StartAddins();

See Also

AddinManager Class | Aveva.ApplicationFramework Namespace


AddinManager.StopAddins Method

This method iterates through the Addins collection and calls the Stop method on each of the addins.

public abstract void StopAddins();

See Also

AddinManager Class | Aveva.ApplicationFramework Namespace


AddinManager.Unload Method

Stop the given Addin and remove it from the Addins collection

public abstract void Unload(
Addin addin
);

Parameters

addin
Addin to be unloaded

See Also

AddinManager Class | Aveva.ApplicationFramework Namespace


AddinManager Events

The events of the AddinManager class are listed below. For a complete list of AddinManager class members, see the AddinManager Members topic.

Public Instance Events

AddinLoaded | Event fired when an Addin is loaded
AddinStarted | Event fired when an Addin is started
AddinStarting | Event fired when an Addin is starting
AddinUnloaded | Event fired when an Addin is unloaded

See Also

AddinManager Class | Aveva.ApplicationFramework Namespace


AddinManager.AddinLoaded Event

Event fired when an Addin is loaded

public event AddinEventHandler AddinLoaded;

Event Data

The event handler receives an argument of type AddinEventArgs containing data related to this event. The following AddinEventArgs property provides information specific to this event.

Property | Description
Addin | Gets the Addin

See Also

AddinManager Class | Aveva.ApplicationFramework Namespace


AddinManager.AddinStarted Event

Event fired when an Addin is started

public event AddinEventHandler AddinStarted;

Event Data

The event handler receives an argument of type AddinEventArgs containing data related to this event. The following AddinEventArgs property provides information specific to this event.

Property | Description
Addin | Gets the Addin

See Also

AddinManager Class | Aveva.ApplicationFramework Namespace


AddinManager.AddinStarting Event

Event fired when an Addin is starting

public event AddinEventHandler AddinStarting;

Event Data

The event handler receives an argument of type AddinEventArgs containing data related to this event. The following AddinEventArgs property provides information specific to this event.

Property | Description
Addin | Gets the Addin

See Also

AddinManager Class | Aveva.ApplicationFramework Namespace


AddinManager.AddinUnloaded Event

Event fired when an Addin is unloaded

public event AddinEventHandler AddinUnloaded;

Event Data

The event handler receives an argument of type AddinEventArgs containing data related to this event. The following AddinEventArgs property provides information specific to this event.

Property | Description
Addin | Gets the Addin

See Also

AddinManager Class | Aveva.ApplicationFramework Namespace


AddinsCollection Class

Class to represent the collection of loaded ApplicationFramework Addins

For a list of all members of this type, see AddinsCollection Members.

System.Object
Aveva.ApplicationFramework.AddinsCollection

public abstract class AddinsCollection : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework

Assembly: Aveva.ApplicationFramework (in Aveva.ApplicationFramework.dll)

See Also

AddinsCollection Members | Aveva.ApplicationFramework Namespace


AddinsCollection Members

AddinsCollection overview

Public Instance Properties

Count | Gets the number of Addins actually contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer which returns the Addin with a given index
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

CopyTo | Copies the collection or a portion of it to a one-dimensional array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the Addin collection
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AddinsCollection Class | Aveva.ApplicationFramework Namespace


AddinsCollection Properties

The properties of the AddinsCollection class are listed below. For a complete list of AddinsCollection class members, see the AddinsCollection Members topic.

Public Instance Properties

Count | Gets the number of Addins actually contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer which returns the Addin with a given index
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

AddinsCollection Class | Aveva.ApplicationFramework Namespace


Count Property

Common Application Framework

AddinsCollection.Count Property

Gets the number of Addins actually contained in the collection.

public abstract int Count {get;}

Implements

ICollection.Count

See Also

AddinsCollection Class | Aveva.ApplicationFramework Namespace


IsSynchronized Property

Common Application Framework

AddinsCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public abstract bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

AddinsCollection Class | Aveva.ApplicationFramework Namespace


Item Property

Common Application Framework

AddinsCollection.Item Property

Indexer which returns the Addin with a given index

public abstract Addin this[
int index
] {get;}

See Also

AddinsCollection Class | Aveva.ApplicationFramework Namespace


SyncRoot Property

Common Application Framework

AddinsCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public abstract object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

AddinsCollection Class | Aveva.ApplicationFramework Namespace


AddinsCollection Methods

The methods of the AddinsCollection class are listed below. For a complete list of AddinsCollection class members, see the AddinsCollection Members topic.

Public Instance Methods

CopyTo | Copies the collection or a portion of it to a one-dimensional array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the Addin collection
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AddinsCollection Class | Aveva.ApplicationFramework Namespace


AddinsCollection.CopyTo Method

Copies the collection or a portion of it to a one-dimensional array.

public abstract void CopyTo(
Array array,
int index
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Implements

ICollection.CopyTo

See Also

AddinsCollection Class | Aveva.ApplicationFramework Namespace


AddinsCollection.GetEnumerator Method

Returns an enumerator that can iterate through the Addin collection

public abstract IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

AddinsCollection Class | Aveva.ApplicationFramework Namespace


IAddin Interface

Interface which enables communication between the framework and the addin.

For a list of all members of this type, see IAddin Members.

public interface IAddin

Requirements

Namespace: Aveva.ApplicationFramework

Assembly: Aveva.ApplicationFramework (in Aveva.ApplicationFramework.dll)

See Also

IAddin Members | Aveva.ApplicationFramework Namespace


IAddin Members

IAddin overview

Public Instance Properties

Description | Description of Addin
Name | Name of Addin

Public Instance Methods

Start | Start the Addin
Stop | Stop the Addn

See Also

IAddin Interface | Aveva.ApplicationFramework Namespace


IAddin Properties

The properties of the IAddin interface are listed below. For a complete list of IAddin interface members, see the IAddin Members topic.

Public Instance Properties

Description | Description of Addin
Name | Name of Addin

See Also

IAddin Interface | Aveva.ApplicationFramework Namespace


Description Property

Common Application Framework

IAddin.Description Property

Description of Addin

string Description {get;}

See Also

IAddin Interface | Aveva.ApplicationFramework Namespace


Name Property

Common Application Framework

IAddin.Name Property

Name of Addin

string Name {get;}

See Also

IAddin Interface | Aveva.ApplicationFramework Namespace


IAddin Methods

The methods of the IAddin interface are listed below. For a complete list of IAddin interface members, see the IAddin Members topic.

Public Instance Methods

Start | Start the Addin
Stop | Stop the Addn

See Also

IAddin Interface | Aveva.ApplicationFramework Namespace


IAddin.Start Method

Start the Addin

void Start(
ServiceManager serviceManager
);

Parameters

serviceManager

See Also

IAddin Interface | Aveva.ApplicationFramework Namespace


IAddin.Stop Method

Stop the Addn

void Stop();

See Also

IAddin Interface | Aveva.ApplicationFramework Namespace


ServiceEventArgs Class

Class used to hold the event arguments in SeviceManager related events

For a list of all members of this type, see ServiceEventArgs Members.

System.Object
System.EventArgs
Aveva.ApplicationFramework.ServiceEventArgs

public class ServiceEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework

Assembly: Aveva.ApplicationFramework (in Aveva.ApplicationFramework.dll)

See Also

ServiceEventArgs Members | Aveva.ApplicationFramework Namespace


ServiceEventArgs Members

ServiceEventArgs overview

Public Instance Constructors

ServiceEventArgs Constructor Initializes a new instance of the ServiceEventArgs class.

Public Instance Properties

Service Gets the service which was added for removed

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ServiceEventArgs Class | Aveva.ApplicationFramework Namespace


ServiceEventArgs Constructor

Initializes a new instance of the ServiceEventArgs class.

public ServiceEventArgs(
Type serviceType
);

Parameters

serviceType

See Also

ServiceEventArgs Class | Aveva.ApplicationFramework Namespace


ServiceEventArgs Properties

The properties of the ServiceEventArgs class are listed below. For a complete list of ServiceEventArgs class members, see the ServiceEventArgs Members topic.

Public Instance Properties

Service Gets the service which was added for removed

See Also

ServiceEventArgs Class | Aveva.ApplicationFramework Namespace


Service Property

Common Application Framework

ServiceEventArgs.Service Property

Gets the service which was added for removed

public System.Type Service {get;}

See Also

ServiceEventArgs Class | Aveva.ApplicationFramework Namespace


ServiceEventHandler Delegate

Represents the method that will handle service related events.

public delegate void ServiceEventHandler(
object sender,
ServiceEventArgs args
);

Requirements

Namespace: Aveva.ApplicationFramework

Assembly: Aveva.ApplicationFramework (in Aveva.ApplicationFramework.dll)

See Also

Aveva.ApplicationFramework Namespace


ServiceManager Class

Provides a means by which the various components of the ApplicationFramework (e.g. Presentation Component) can publish their services. The ServiceManager also acts as a service provider responding to requests for services.

For a list of all members of this type, see ServiceManager Members.

System.Object
Aveva.ApplicationFramework.ServiceManager

public abstract class ServiceManager : IServiceContainer, IServiceProvider

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework

Assembly: Aveva.ApplicationFramework (in Aveva.ApplicationFramework.dll)

See Also

ServiceManager Members | Aveva.ApplicationFramework Namespace


ServiceManager Members

ServiceManager overview

Public Static Properties

Instance Get instance of service manager

Public Instance Properties

ApplicationName Gets the name of the application.

Public Instance Methods

AddService | Overloaded. Adds the specified service to the service container, and optionally promotes the service to parent service containers.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService | Gets the service object of the specified type, if it is available.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveService | Overloaded. Removes the specified service type from the service container, and optionally promotes the service to parent service containers.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ServiceAdded | Event raised when a service is added to the service manager
ServiceRemoved | Event raised when a service is removed from the service manager

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace


ServiceManager Properties

The properties of the ServiceManager class are listed below. For a complete list of ServiceManager class members, see the ServiceManager Members topic.

Public Static Properties

Instance Get instance of service manager

Public Instance Properties

ApplicationName Gets the name of the application.

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace


ApplicationName Property

Common Application Framework

ServiceManager.ApplicationName Property

Gets the name of the application.

public abstract string ApplicationName {get;}

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace


Instance Property

Common Application Framework

ServiceManager.Instance Property

Get instance of service manager

public static ServiceManager Instance {get; set;}

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace


ServiceManager Methods

The methods of the ServiceManager class are listed below. For a complete list of ServiceManager class members, see the ServiceManager Members topic.

Public Instance Methods

AddService | Overloaded. Adds the specified service to the service container, and optionally promotes the service to parent service containers.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetService | Gets the service object of the specified type, if it is available.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveService | Overloaded. Removes the specified service type from the service container, and optionally promotes the service to parent service containers.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace


AddService Method

Common Application Framework

ServiceManager.AddService Method

Adds the specified service to the service container.

Overload List

Adds the specified service to the service container.

public abstract void AddService(Type,ServiceCreatorCallback);

Adds the specified service to the service container, and optionally promotes the service to parent service containers.

public abstract void AddService(Type,ServiceCreatorCallback,bool);

Adds the specified service to the ServiceManager service container.

public abstract void AddService(Type,object);

Adds the specified service to the service container, and optionally promotes the service to any parent service containers.

public abstract void AddService(Type,object,bool);

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace


ServiceManager.AddService Method (Type, ServiceCreatorCallback)

Adds the specified service to the service container.

public abstract void AddService(
Type serviceType,
ServiceCreatorCallback callback
);

Parameters

serviceType
The type of service to add.
callback
A callback object that is used to create the service. This allows a service to be declared as available, but delays the creation of the object until the service is requested.

Implements

IServiceContainer.AddService

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace | ServiceManager.AddService Overload List


ServiceManager.AddService Method (Type, ServiceCreatorCallback, Boolean)

Adds the specified service to the service container, and optionally promotes the service to parent service containers.

public abstract void AddService(
Type serviceType,
ServiceCreatorCallback callback,
bool promoteToParent
);

Parameters

serviceType
The type of service to add.
callback
A callback object that is used to create the service. This allows a service to be declared as available, but delays the creation of the object until the service is requested.
promoteToParent
true to promote this request to any parent service containers; otherwise, false.

Implements

IServiceContainer.AddService

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace | ServiceManager.AddService Overload List


ServiceManager.AddService Method (Type, Object)

Adds the specified service to the ServiceManager service container.

public abstract void AddService(
Type serviceType,
object service
);

Parameters

serviceType
The type of service to add.
service
An instance of the service type to add. This object must implement or inherit from the type indicated by the serviceType parameter.

Implements

IServiceContainer.AddService

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace | ServiceManager.AddService Overload List


ServiceManager.AddService Method (Type, Object, Boolean)

Adds the specified service to the service container, and optionally promotes the service to any parent service containers.

public abstract void AddService(
Type serviceType,
object service,
bool promoteToParent
);

Parameters

serviceType
The type of service to add.
service
An instance of the service type to add. This object must implement or inherit from the type indicated by the serviceType parameter.
promoteToParent
true to promote this request to any parent service containers; otherwise, false.

Implements

IServiceContainer.AddService

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace | ServiceManager.AddService Overload List


ServiceManager.GetService Method

Gets the service object of the specified type, if it is available.

public abstract object GetService(
Type serviceType
);

Parameters

serviceType
The Type of the service to retrieve.

Return Value

Implements

IServiceProvider.GetService

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace


RemoveService Method

Common Application Framework

ServiceManager.RemoveService Method

Removes the specified service type from the serviceManager service container.

Overload List

Removes the specified service type from the serviceManager service container.

public abstract void RemoveService(Type);

Removes the specified service type from the service container, and optionally promotes the service to parent service containers.

public abstract void RemoveService(Type,bool);

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace


ServiceManager.RemoveService Method (Type)

Removes the specified service type from the serviceManager service container.

public abstract void RemoveService(
Type serviceType
);

Parameters

serviceType
The type of service to remove.

Implements

IServiceContainer.RemoveService

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace | ServiceManager.RemoveService Overload List


ServiceManager.RemoveService Method (Type, Boolean)

Removes the specified service type from the service container, and optionally promotes the service to parent service containers.

public abstract void RemoveService(
Type serviceType,
bool removeFromParent
);

Parameters

serviceType
The type of service to remove.
removeFromParent
true to promote this remove request to any parent service containers; otherwise, false.

Implements

IServiceContainer.RemoveService

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace | ServiceManager.RemoveService Overload List


ServiceManager Events

The events of the ServiceManager class are listed below. For a complete list of ServiceManager class members, see the ServiceManager Members topic.

Public Instance Events

ServiceAdded | Event raised when a service is added to the service manager
ServiceRemoved | Event raised when a service is removed from the service manager

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace


ServiceManager.ServiceAdded Event

Event raised when a service is added to the service manager

public event ServiceEventHandler ServiceAdded;

Event Data

The event handler receives an argument of type ServiceEventArgs containing data related to this event. The following ServiceEventArgs property provides information specific to this event.

Property | Description
Service | Gets the service which was added for removed

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace


ServiceManager.ServiceRemoved Event

Event raised when a service is removed from the service manager

public event ServiceEventHandler ServiceRemoved;

Event Data

The event handler receives an argument of type ServiceEventArgs containing data related to this event. The following ServiceEventArgs property provides information specific to this event.

Property | Description
Service | Gets the service which was added for removed

See Also

ServiceManager Class | Aveva.ApplicationFramework Namespace


SettingsGroup Class

Class that represents a named colletion of keyed objects which represent application settings

For a list of all members of this type, see SettingsGroup Members.

System.Object
Aveva.ApplicationFramework.SettingsGroup

public abstract class SettingsGroup : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework

Assembly: Aveva.ApplicationFramework (in Aveva.ApplicationFramework.dll)

See Also

SettingsGroup Members | Aveva.ApplicationFramework Namespace


SettingsGroup Members

SettingsGroup overview

Public Instance Properties

Count | Gets the number of Addins actually contained in the collection.
Directory | The name of the directory into which the settings for this group will be persisted
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer to return the object associated with the given key
Name | Name of settings group
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

CopyTo | Copies the collection or a portion of it to a one-dimensional array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the SettingsGroup.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SettingsGroup Class | Aveva.ApplicationFramework Namespace


SettingsGroup Properties

The properties of the SettingsGroup class are listed below. For a complete list of SettingsGroup class members, see the SettingsGroup Members topic.

Public Instance Properties

Count | Gets the number of Addins actually contained in the collection.
Directory | The name of the directory into which the settings for this group will be persisted
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer to return the object associated with the given key
Name | Name of settings group
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

SettingsGroup Class | Aveva.ApplicationFramework Namespace


Count Property

Common Application Framework

SettingsGroup.Count Property

Gets the number of Addins actually contained in the collection.

public abstract int Count {get;}

Implements

ICollection.Count

See Also

SettingsGroup Class | Aveva.ApplicationFramework Namespace


Directory Property

Common Application Framework

SettingsGroup.Directory Property

The name of the directory into which the settings for this group will be persisted

public abstract string Directory {get;}

See Also

SettingsGroup Class | Aveva.ApplicationFramework Namespace


IsSynchronized Property

Common Application Framework

SettingsGroup.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public abstract bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

SettingsGroup Class | Aveva.ApplicationFramework Namespace


Item Property

Common Application Framework

SettingsGroup.Item Property

Indexer to return the object associated with the given key

public abstract object this[
string key
] {get; set;}

See Also

SettingsGroup Class | Aveva.ApplicationFramework Namespace


Name Property

Common Application Framework

SettingsGroup.Name Property

Name of settings group

public abstract string Name {get;}

See Also

SettingsGroup Class | Aveva.ApplicationFramework Namespace


SyncRoot Property

Common Application Framework

SettingsGroup.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public abstract object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

SettingsGroup Class | Aveva.ApplicationFramework Namespace


SettingsGroup Methods

The methods of the SettingsGroup class are listed below. For a complete list of SettingsGroup class members, see the SettingsGroup Members topic.

Public Instance Methods

CopyTo | Copies the collection or a portion of it to a one-dimensional array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the SettingsGroup.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SettingsGroup Class | Aveva.ApplicationFramework Namespace


SettingsGroup.CopyTo Method

Copies the collection or a portion of it to a one-dimensional array.

public abstract void CopyTo(
Array array,
int index
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Implements

ICollection.CopyTo

See Also

SettingsGroup Class | Aveva.ApplicationFramework Namespace


SettingsGroup.GetEnumerator Method

Returns an enumerator that can iterate through the SettingsGroup.

public abstract IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire SettingsGroup.

Implements

IEnumerable.GetEnumerator

See Also

SettingsGroup Class | Aveva.ApplicationFramework Namespace


SettingsGroupsCollection Class

A collection of SettingsGroup objects

For a list of all members of this type, see SettingsGroupsCollection Members.

System.Object
Aveva.ApplicationFramework.SettingsGroupsCollection

public abstract class SettingsGroupsCollection : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework

Assembly: Aveva.ApplicationFramework (in Aveva.ApplicationFramework.dll)

See Also

SettingsGroupsCollection Members | Aveva.ApplicationFramework Namespace


SettingsGroupsCollection Members

SettingsGroupsCollection overview

Public Instance Properties

Count | Gets the number of Addins actually contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer to resturn the SettingsGroup with the given name.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

CopyTo | Copies the collection or a portion of it to a one-dimensional array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the SettingsGroupCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SettingsGroupsCollection Class | Aveva.ApplicationFramework Namespace


SettingsGroupsCollection Properties

The properties of the SettingsGroupsCollection class are listed below. For a complete list of SettingsGroupsCollection class members, see the SettingsGroupsCollection Members topic.

Public Instance Properties

Count | Gets the number of Addins actually contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer to resturn the SettingsGroup with the given name.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

SettingsGroupsCollection Class | Aveva.ApplicationFramework Namespace


Count Property

Common Application Framework

SettingsGroupsCollection.Count Property

Gets the number of Addins actually contained in the collection.

public abstract int Count {get;}

Implements

ICollection.Count

See Also

SettingsGroupsCollection Class | Aveva.ApplicationFramework Namespace


IsSynchronized Property

Common Application Framework

SettingsGroupsCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public abstract bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

SettingsGroupsCollection Class | Aveva.ApplicationFramework Namespace


Item Property

Common Application Framework

SettingsGroupsCollection.Item Property

Indexer to resturn the SettingsGroup with the given name.

public abstract SettingsGroup this[
string groupName
] {get;}

See Also

SettingsGroupsCollection Class | Aveva.ApplicationFramework Namespace


SyncRoot Property

Common Application Framework

SettingsGroupsCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public abstract object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

SettingsGroupsCollection Class | Aveva.ApplicationFramework Namespace


SettingsGroupsCollection Methods

The methods of the SettingsGroupsCollection class are listed below. For a complete list of SettingsGroupsCollection class members, see the SettingsGroupsCollection Members topic.

Public Instance Methods

CopyTo | Copies the collection or a portion of it to a one-dimensional array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the SettingsGroupCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SettingsGroupsCollection Class | Aveva.ApplicationFramework Namespace


SettingsGroupsCollection.CopyTo Method

Copies the collection or a portion of it to a one-dimensional array.

public abstract void CopyTo(
Array array,
int index
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Implements

ICollection.CopyTo

See Also

SettingsGroupsCollection Class | Aveva.ApplicationFramework Namespace


SettingsGroupsCollection.GetEnumerator Method

Returns an enumerator that can iterate through the SettingsGroupCollection.

public abstract IEnumerator GetEnumerator();

Return Value

An IEnumerator for the entire SettingsGroupCollection.

Implements

IEnumerable.GetEnumerator

See Also

SettingsGroupsCollection Class | Aveva.ApplicationFramework Namespace


SettingsManager Class

Class to manage an applications settings

For a list of all members of this type, see SettingsManager Members.

System.Object
Aveva.ApplicationFramework.SettingsManager

public abstract class SettingsManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework

Assembly: Aveva.ApplicationFramework (in Aveva.ApplicationFramework.dll)

See Also

SettingsManager Members | Aveva.ApplicationFramework Namespace


SettingsManager Members

SettingsManager overview

Public Static Properties

Instance Get instance of settings manager

Public Instance Properties

Directory | Sets the parent directory into which the settings will be serialized. The defaults to C:\Documents and Settings\'User Name'\Local Settings\Application Data\Aveva\'Application Name'
SettingsGroups | Gets the collection of SettingsGroups

Public Instance Methods

AddGroup | Adds a new SettingsGroup with the given name.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadSettings | Loads the settings from serialized data.
SaveSettings | Saves the settings.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SettingsManager Class | Aveva.ApplicationFramework Namespace


SettingsManager Properties

The properties of the SettingsManager class are listed below. For a complete list of SettingsManager class members, see the SettingsManager Members topic.

Public Static Properties

Instance Get instance of settings manager

Public Instance Properties

Directory | Sets the parent directory into which the settings will be serialized. The defaults to C:\Documents and Settings\'User Name'\Local Settings\Application Data\Aveva\'Application Name'
SettingsGroups | Gets the collection of SettingsGroups

See Also

SettingsManager Class | Aveva.ApplicationFramework Namespace


Directory Property

Common Application Framework

SettingsManager.Directory Property

Sets the parent directory into which the settings will be serialized. The defaults to C:\Documents and Settings\'User Name'\Local Settings\Application Data\Aveva\'Application Name'

public abstract string Directory {get; set;}

See Also

SettingsManager Class | Aveva.ApplicationFramework Namespace


Instance Property

Common Application Framework

SettingsManager.Instance Property

Get instance of settings manager

public static SettingsManager Instance {get; set;}

See Also

SettingsManager Class | Aveva.ApplicationFramework Namespace


SettingsGroups Property

Common Application Framework

SettingsManager.SettingsGroups Property

Gets the collection of SettingsGroups

public abstract SettingsGroupsCollection SettingsGroups {get;}

See Also

SettingsManager Class | Aveva.ApplicationFramework Namespace


SettingsManager Methods

The methods of the SettingsManager class are listed below. For a complete list of SettingsManager class members, see the SettingsManager Members topic.

Public Instance Methods

AddGroup | Adds a new SettingsGroup with the given name.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadSettings | Loads the settings from serialized data.
SaveSettings | Saves the settings.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SettingsManager Class | Aveva.ApplicationFramework Namespace


SettingsManager.AddGroup Method

Adds a new SettingsGroup with the given name.

public abstract SettingsGroup AddGroup(
string groupName,
string directory
);

Parameters

groupName
Name of SettingsGroup
directory
The name of the directory where this settings group is saved

Return Value

See Also

SettingsManager Class | Aveva.ApplicationFramework Namespace


SettingsManager.LoadSettings Method

Loads the settings from serialized data.

public abstract void LoadSettings();

See Also

SettingsManager Class | Aveva.ApplicationFramework Namespace


SettingsManager.SaveSettings Method

Saves the settings.

public abstract void SaveSettings();

See Also

SettingsManager Class | Aveva.ApplicationFramework Namespace


Aveva.ApplicationFramework.Presentation

Common Application Framework

Aveva.ApplicationFramework.Presentation Namespace

Namespace hierarchy

Classes

Class | Description
ButtonTool | Represents a ButtonToolt.
CancelClosingEventArgs | Provides data for a cancelable event.
ComboBoxTool | Represents a ComboBoxTool.
Command | Abstract base class which an application must inherit from to create a Command object
CommandBar | Class to represent a CommandBar.
CommandBarEventArgs | Provides data for the CommandBarAdded and CommandBarRemoved events.
CommandBarManager | Class representing a CommandBarManager.
CommandBarsCollection | Class to represent a CommandBarCollection.
CommandEventArgs | Provides data for the CommandAdded and CommandRemoved events.
CommandExecutor | Abstract base class which an application must inherit from to create a CommandExecutor object.
CommandList | An ArrayList use for the list property of Command objects which supports an IsModified property.
CommandManager | Class representing a CommandManager.
CommandsCollection | Class that represents a CommandCollection.
CommandTypesCollection | Class that represents a CommandCollection.
ContainerTool | A tool that contains a Control.
DockedWindow | Class to represent a DockedWindow.
DragDropDirector | A class to help direct drag-drop events.
DropTarget | A class to represent a DragDropTarget.
DropTargetEventArgs | A class to provide information to for drop-drop events.
FontListTool | Represents a FontListTool.
HtmlHelp | A class to control Html Help viewer.
LabelTool | Class to represent a static Label.
ListTool | Represents a ListTool.
MdiWindow | Represents an MDI style window or dialog box.
MdiWindowListTool | Class to respresent the special tool which displays a list of current MDI Windows.
MenuTool | Represents a MenuTool.
PopupColorPickerTool | Represents a PopupColorPicker.
PopupContainerTool | Represents a PopuplContainerTool.
ResourceManager | Provides convenient access to culture-specific resources at runtime.
ResourceSet | Represent a set of culture-specific resource files.
RootToolsCollection | Class representing a RootToolsCollection.
SplashScreen | Provides an application SplashScreen.
StateButtonTool | Represents a StateButtonTool.
StatusBar | Represents a Windows style status bar control.
StatusBarPanelsCollection | Represents a collection of status bar panels.
StatusBarTextPanel | Represents a StatusBarTextPanel.
TaskBar | Class representing a Microsoft Office style "TaskPane" type toolbar.
TaskPaneTool | Class used to represent a single item in a TaskPane.
TextBoxTool | Represents a TextBoxTool.
ThemeColours | Class which provides a number of Theme colours
ToolEventArgs | Provides information for Tool events.
ToolsCollection | Class representing a ToolsCollection.
ValueList | Class representing a ValueList, which is a collection of ValueListItem objects. It is typicall assigned to a ComboBoxTool as the list of options displayed as the dropdown list.
ValueListItem | Class representing a ValueListItem, which can be a member of ValueList.
WindowEventArgs | Provides data for the WindowAdded event.
WindowManager | Provides access to window related facilities.
WindowsCollection | Provides access to a collection of application windows.

Interfaces

Interface | Description
IApplicationInfo | Interface use to supply application information to the framework
IStatusBarPanel | Interface supported by Statusbar panels.
ITool | Interface supported by all Tool clases.
IWindow | Interface supported by supported window types(MDI, Docked).

Delegates

Delegate | Description
CommandBarEventHandler | Represents the method that will handle CommandBar related events.
CommandEventHandler | Represents the method that will handle command related events.
DropTargetEventHandler | Represents the method that will handle DropTarget related events.
ToolEventHandler | Represents the method that will handle Tool related events.
WindowEventHandler | Represents the method that will handle Window related events.

Enumerations

Enumeration | Description
CommandState | Enumeration for various states of a command. This enumeration can be treated as a bit field; that is, a set of flags. Bit fields can be combined using a bitwise OR operation.
CustomizationType | Enumeration of menu and commandbar customisation options
DockedPosition | Enumerator used to specify the location of a toolbar or window docking area.
DockGroupStyle | Enumeration of styles for group docked windows.
DropDownArrowStyle | Enumerator used to specify the style used to draw a popup tool's dropdown arrow. Also determines which part of the tool should be clicked to drop down the tool.
NavigationButtonStyle | Enumeration used to indicate how the navigation buttons are used to navigate the items in a TaskBar
PanelSizingMode | Enumeration of the statusbar panel sizing options.
PopupStyle | Enumerator used to specify the style of popup menus.
StandardImage | Enumeration of standard images
UpdateOptions | Enumerations for the options for automatically updating the state of a MenuTool following state changes to an child StateButtonTool or ButtonTool. This enumeration can be treated as a bit field; that is, a set of flags. Bit fields can be combined using a bitwise OR operation.
ValueListDisplayStyle | Enumeration for specifying what property of a value list item will be displayed in each item of the DropDown list
ValueListSortStyle | Enumeration for specifying how value list items will be sorted when displaying value list items in a drop down list


ButtonTool Class

Represents a ButtonToolt.

For a list of all members of this type, see ButtonTool Members.

System.Object
Aveva.ApplicationFramework.Presentation.ButtonTool

public abstract class ButtonTool : ITool

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

ButtonTool Members | Aveva.ApplicationFramework.Presentation Namespace


ButtonTool Members

ButtonTool overview

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Command | Gets the command object which was associated with the tool when it was created.
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
MenuToolUpdateOptions | Gets or sets how properties of an owning MenuTool will be automatically updated.
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ToolClick Occurs when the ButtonTool is clicked.

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


ButtonTool Properties

The properties of the ButtonTool class are listed below. For a complete list of ButtonTool class members, see the ButtonTool Members topic.

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Command | Gets the command object which was associated with the tool when it was created.
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
MenuToolUpdateOptions | Gets or sets how properties of an owning MenuTool will be automatically updated.
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Caption Property

Common Application Framework

ButtonTool.Caption Property

Gets or sets the tool caption

public abstract string Caption {get; set;}

Implements

ITool.Caption

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Category Property

Common Application Framework

ButtonTool.Category Property

Gets or sets the tools category

public abstract string Category {get; set;}

Implements

ITool.Category

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Command Property

Common Application Framework

ButtonTool.Command Property

Gets the command object which was associated with the tool when it was created.

public abstract Command Command {get;}

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

ButtonTool.Enabled Property

Gets or sets the enabled state of the tool.

public abstract bool Enabled {get; set;}

Implements

ITool.Enabled

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

ButtonTool.Image Property

Gets or sets the image displayed on the tool

public abstract System.Drawing.Image Image {get; set;}

Implements

ITool.Image

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


IsFirstInGroup Property

Common Application Framework

ButtonTool.IsFirstInGroup Property

Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.

public abstract bool IsFirstInGroup {get; set;}

Implements

ITool.IsFirstInGroup

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

ButtonTool.Key Property

The Key of the tool in the RootToolsCollection

public abstract string Key {get;}

Implements

ITool.Key

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


MenuToolUpdateOptions Property

Common Application Framework

ButtonTool.MenuToolUpdateOptions Property

Gets or sets how properties of an owning MenuTool will be automatically updated.

public abstract UpdateOptions MenuToolUpdateOptions {get; set;}

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Shortcut Property

Common Application Framework

ButtonTool.Shortcut Property

Gets or sets the shortcut associated with a tool.

public abstract System.Windows.Forms.Shortcut Shortcut {get; set;}

Implements

ITool.Shortcut

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

ButtonTool.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a tool.

public abstract object Tag {get; set;}

Implements

ITool.Tag

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

ButtonTool.Tooltip Property

Gets or sets the tools tooltip

public abstract string Tooltip {get; set;}

Implements

ITool.Tooltip

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

ButtonTool.Value Property

Gets or sets the value of the tool.

public abstract object Value {get; set;}

Implements

ITool.Value

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

ButtonTool.Visible Property

Gets or sets the visibility of the tool.

public abstract bool Visible {get; set;}

Implements

ITool.Visible

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


ButtonTool Events

The events of the ButtonTool class are listed below. For a complete list of ButtonTool class members, see the ButtonTool Members topic.

Public Instance Events

ToolClick Occurs when the ButtonTool is clicked.

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


ButtonTool.ToolClick Event

Occurs when the ButtonTool is clicked.

public event EventHandler ToolClick;

See Also

ButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


CancelClosingEventArgs Class

Provides data for a cancelable event.

For a list of all members of this type, see CancelClosingEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
Aveva.ApplicationFramework.Presentation.CancelClosingEventArgs

public class CancelClosingEventArgs : CancelEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

CancelClosingEventArgs Members | Aveva.ApplicationFramework.Presentation Namespace


CancelClosingEventArgs Members

CancelClosingEventArgs overview

Public Instance Constructors

CancelClosingEventArgs Constructor

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
ParentClosing | Indicates if the closing event was raised as a result of closing the main window.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CancelClosingEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


CancelClosingEventArgs Constructor

public CancelClosingEventArgs();

See Also

CancelClosingEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


CancelClosingEventArgs Properties

The properties of the CancelClosingEventArgs class are listed below. For a complete list of CancelClosingEventArgs class members, see the CancelClosingEventArgs Members topic.

Public Instance Properties

Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
ParentClosing | Indicates if the closing event was raised as a result of closing the main window.

See Also

CancelClosingEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


ParentClosing Property

Common Application Framework

CancelClosingEventArgs.ParentClosing Property

Indicates if the closing event was raised as a result of closing the main window.

public bool ParentClosing {get; set;}

See Also

CancelClosingEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


ComboBoxTool Class

Represents a ComboBoxTool.

For a list of all members of this type, see ComboBoxTool Members.

System.Object
Aveva.ApplicationFramework.Presentation.ComboBoxTool

public abstract class ComboBoxTool : ITool

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

ComboBoxTool Members | Aveva.ApplicationFramework.Presentation Namespace


ComboBoxTool Members

ComboBoxTool overview

Public Instance Properties

AutoComplete | Gets or sets whether the edit portion is automatically updated to match an item in the list as new characters are typed.
Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Command | Gets the command object which was associated with the tool when it was created.
DisplayText | Gets or sets the text displayed in the tool.
Editable | Gets or sets whether the text portion of the ComboBoxTool is editable.
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
MaxLength | Gets or sets the maximum allowable length of the text that can be entered in the ComboBoxTool.
PasswordChar | Gets or sets a value indicating how the characters typed by a user are displayed.
SelectedIndex | Gets or sets the zero-based index of the selected item in the ValueList.
SelectedValue | Returns the object behind the selected ValueList item.
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
ValueList | Gets the ValueList object associated with the ComboBoxTool.
Visible | Gets or sets the visibility of the tool.
Width | Gets or sets the width of the tool.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AfterCloseup | Occurs after the popup part of the tool is closed.
BeforePopup | Occurs before the popup part of the tool is displayed.
ToolClick | Occurs when Enter key is pressed while display field has focus.
ToolValueChanged | Occurs when the value of the tool changes.

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


ComboBoxTool Properties

The properties of the ComboBoxTool class are listed below. For a complete list of ComboBoxTool class members, see the ComboBoxTool Members topic.

Public Instance Properties

AutoComplete | Gets or sets whether the edit portion is automatically updated to match an item in the list as new characters are typed.
Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Command | Gets the command object which was associated with the tool when it was created.
DisplayText | Gets or sets the text displayed in the tool.
Editable | Gets or sets whether the text portion of the ComboBoxTool is editable.
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
MaxLength | Gets or sets the maximum allowable length of the text that can be entered in the ComboBoxTool.
PasswordChar | Gets or sets a value indicating how the characters typed by a user are displayed.
SelectedIndex | Gets or sets the zero-based index of the selected item in the ValueList.
SelectedValue | Returns the object behind the selected ValueList item.
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
ValueList | Gets the ValueList object associated with the ComboBoxTool.
Visible | Gets or sets the visibility of the tool.
Width | Gets or sets the width of the tool.

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


AutoComplete Property

Common Application Framework

ComboBoxTool.AutoComplete Property

Gets or sets whether the edit portion is automatically updated to match an item in the list as new characters are typed.

public abstract bool AutoComplete {get; set;}

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Caption Property

Common Application Framework

ComboBoxTool.Caption Property

Gets or sets the tool caption

public abstract string Caption {get; set;}

Implements

ITool.Caption

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Category Property

Common Application Framework

ComboBoxTool.Category Property

Gets or sets the tools category

public abstract string Category {get; set;}

Implements

ITool.Category

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Command Property

Common Application Framework

ComboBoxTool.Command Property

Gets the command object which was associated with the tool when it was created.

public abstract Command Command {get;}

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


DisplayText Property

Common Application Framework

ComboBoxTool.DisplayText Property

Gets or sets the text displayed in the tool.

public abstract string DisplayText {get; set;}

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Editable Property

Common Application Framework

ComboBoxTool.Editable Property

Gets or sets whether the text portion of the ComboBoxTool is editable.

public abstract bool Editable {get; set;}

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

ComboBoxTool.Enabled Property

Gets or sets the enabled state of the tool.

public abstract bool Enabled {get; set;}

Implements

ITool.Enabled

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

ComboBoxTool.Image Property

Gets or sets the image displayed on the tool

public abstract System.Drawing.Image Image {get; set;}

Implements

ITool.Image

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


IsFirstInGroup Property

Common Application Framework

ComboBoxTool.IsFirstInGroup Property

Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.

public abstract bool IsFirstInGroup {get; set;}

Implements

ITool.IsFirstInGroup

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

ComboBoxTool.Key Property

The Key of the tool in the RootToolsCollection

public abstract string Key {get;}

Implements

ITool.Key

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


MaxLength Property

Common Application Framework

ComboBoxTool.MaxLength Property

Gets or sets the maximum allowable length of the text that can be entered in the ComboBoxTool.

public abstract int MaxLength {get; set;}

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


PasswordChar Property

Common Application Framework

ComboBoxTool.PasswordChar Property

Gets or sets a value indicating how the characters typed by a user are displayed.

public abstract string PasswordChar {get; set;}

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


SelectedIndex Property

Common Application Framework

ComboBoxTool.SelectedIndex Property

Gets or sets the zero-based index of the selected item in the ValueList.

public abstract int SelectedIndex {get; set;}

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


SelectedValue Property

Common Application Framework

ComboBoxTool.SelectedValue Property

Returns the object behind the selected ValueList item.

public abstract object SelectedValue {get;}

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Shortcut Property

Common Application Framework

ComboBoxTool.Shortcut Property

Gets or sets the shortcut associated with a tool.

public abstract System.Windows.Forms.Shortcut Shortcut {get; set;}

Implements

ITool.Shortcut

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

ComboBoxTool.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a tool.

public abstract object Tag {get; set;}

Implements

ITool.Tag

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

ComboBoxTool.Tooltip Property

Gets or sets the tools tooltip

public abstract string Tooltip {get; set;}

Implements

ITool.Tooltip

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

ComboBoxTool.Value Property

Gets or sets the value of the tool.

public abstract object Value {get; set;}

Implements

ITool.Value

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


ValueList Property

Common Application Framework

ComboBoxTool.ValueList Property

Gets the ValueList object associated with the ComboBoxTool.

public abstract ValueList ValueList {get;}

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

ComboBoxTool.Visible Property

Gets or sets the visibility of the tool.

public abstract bool Visible {get; set;}

Implements

ITool.Visible

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Width Property

Common Application Framework

ComboBoxTool.Width Property

Gets or sets the width of the tool.

public abstract int Width {get; set;}

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


ComboBoxTool Events

The events of the ComboBoxTool class are listed below. For a complete list of ComboBoxTool class members, see the ComboBoxTool Members topic.

Public Instance Events

AfterCloseup | Occurs after the popup part of the tool is closed.
BeforePopup | Occurs before the popup part of the tool is displayed.
ToolClick | Occurs when Enter key is pressed while display field has focus.
ToolValueChanged | Occurs when the value of the tool changes.

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


ComboBoxTool.AfterCloseup Event

Occurs after the popup part of the tool is closed.

public event EventHandler AfterCloseup;

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


ComboBoxTool.BeforePopup Event

Occurs before the popup part of the tool is displayed.

public event EventHandler BeforePopup;

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


ComboBoxTool.ToolClick Event

Occurs when Enter key is pressed while display field has focus.

public event EventHandler ToolClick;

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


ComboBoxTool.ToolValueChanged Event

Occurs when the value of the tool changes.

public event EventHandler ToolValueChanged;

See Also

ComboBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Command Class

Abstract base class which an application must inherit from to create a Command object

For a list of all members of this type, see Command Members.

System.Object
Aveva.ApplicationFramework.Presentation.Command

public abstract class Command

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Command Members | Aveva.ApplicationFramework.Presentation Namespace


Command Members

Command overview

Public Instance Constructors

Command Constructor Command constructor

Public Instance Properties

Checked | Gets or sets if the command is in a checked state. Setting this value will set the CommandExecutor.Checked property on all attached CommandExecutors.
Description | Description for the command
Enabled | Gets or sets if the command is enabled. Setting this value will set the CommandExecutor.Enabled property on all attached CommandExecutors.
ExecuteOnCheckedChange |
Internal | Flag to control the visibility of the command in Customization dialog
IsValid | Gets the IsValid status of the command. A Command may become invalid in some application context. Method can be overriden in a derived class.
Key | The commands key in the CommandCollection
List | ArrayList which can contain data to be presented in the GUI
SelectedIndex | Used to comunicate to the command which item in the list was selected
Value | Setting this value will set the CommandExecutor.Value property on all attached CommandExecutors.
ValueChanged | True if the value of the command has been changed
Visible | Gets or sets if the command is visible. Setting this value will set the CommandExecutor.Visible property on all attached CommandExecutors.

Public Instance Methods

AttachExecutor | Attaches a CommandExecutor derived class to the command
CancelableExecute | Version of Execute which can be cancelled by an BeforeCommandExecute event handler
DetachAllExecutors | Detach all CommandExecutor derived classes from the command
DetachExecutor | Detach a CommandExecutor derived class from the command
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | The command Execute method is normally overridden by a derived class
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetState | Gets the current state of the command
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Overloaded. Call to allow the command to update its visilility or enabled state following a change to the application context.
SetProperty |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

BeforeCommandExecute | Occurs before the command is executed
CommandExecuted | Occurs when the command is executed

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Command Constructor

Command constructor

public Command();

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Command Properties

The properties of the Command class are listed below. For a complete list of Command class members, see the Command Members topic.

Public Instance Properties

Checked | Gets or sets if the command is in a checked state. Setting this value will set the CommandExecutor.Checked property on all attached CommandExecutors.
Description | Description for the command
Enabled | Gets or sets if the command is enabled. Setting this value will set the CommandExecutor.Enabled property on all attached CommandExecutors.
ExecuteOnCheckedChange |
Internal | Flag to control the visibility of the command in Customization dialog
IsValid | Gets the IsValid status of the command. A Command may become invalid in some application context. Method can be overriden in a derived class.
Key | The commands key in the CommandCollection
List | ArrayList which can contain data to be presented in the GUI
SelectedIndex | Used to comunicate to the command which item in the list was selected
Value | Setting this value will set the CommandExecutor.Value property on all attached CommandExecutors.
ValueChanged | True if the value of the command has been changed
Visible | Gets or sets if the command is visible. Setting this value will set the CommandExecutor.Visible property on all attached CommandExecutors.

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Checked Property

Common Application Framework

Command.Checked Property

Gets or sets if the command is in a checked state. Setting this value will set the CommandExecutor.Checked property on all attached CommandExecutors.

public virtual bool Checked {get; set;}

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Description Property

Common Application Framework

Command.Description Property

Description for the command

public string Description {get; set;}

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

Command.Enabled Property

Gets or sets if the command is enabled. Setting this value will set the CommandExecutor.Enabled property on all attached CommandExecutors.

public virtual bool Enabled {get; set;}

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


ExecuteOnCheckedChange Property

Common Application Framework

Command.ExecuteOnCheckedChange Property

public bool ExecuteOnCheckedChange {get; set;}

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Internal Property

Common Application Framework

Command.Internal Property

Flag to control the visibility of the command in Customization dialog

public bool Internal {get; set;}

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


IsValid Property

Common Application Framework

Command.IsValid Property

Gets the IsValid status of the command. A Command may become invalid in some application context. Method can be overriden in a derived class.

public virtual bool IsValid {get;}

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

Command.Key Property

The commands key in the CommandCollection

public string Key {get; set;}

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


List Property

Common Application Framework

Command.List Property

ArrayList which can contain data to be presented in the GUI

public virtual System.Collections.ArrayList List {get;}

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


SelectedIndex Property

Common Application Framework

Command.SelectedIndex Property

Used to comunicate to the command which item in the list was selected

public virtual int SelectedIndex {get; set;}

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

Command.Value Property

Setting this value will set the CommandExecutor.Value property on all attached CommandExecutors.

public virtual object Value {get; set;}

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


ValueChanged Property

Common Application Framework

Command.ValueChanged Property

True if the value of the command has been changed

public virtual bool ValueChanged {get; set;}

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

Command.Visible Property

Gets or sets if the command is visible. Setting this value will set the CommandExecutor.Visible property on all attached CommandExecutors.

public virtual bool Visible {get; set;}

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Command Methods

The methods of the Command class are listed below. For a complete list of Command class members, see the Command Members topic.

Public Instance Methods

AttachExecutor | Attaches a CommandExecutor derived class to the command
CancelableExecute | Version of Execute which can be cancelled by an BeforeCommandExecute event handler
DetachAllExecutors | Detach all CommandExecutor derived classes from the command
DetachExecutor | Detach a CommandExecutor derived class from the command
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | The command Execute method is normally overridden by a derived class
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetState | Gets the current state of the command
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Overloaded. Call to allow the command to update its visilility or enabled state following a change to the application context.
SetProperty |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Command.AttachExecutor Method

Attaches a CommandExecutor derived class to the command

public void AttachExecutor(
CommandExecutor executor
);

Parameters

executor
The CommandExecutor derived class to attach.

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Command.CancelableExecute Method

Version of Execute which can be cancelled by an BeforeCommandExecute event handler

public void CancelableExecute();

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Command.DetachAllExecutors Method

Detach all CommandExecutor derived classes from the command

public void DetachAllExecutors();

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Command.DetachExecutor Method

Detach a CommandExecutor derived class from the command

public void DetachExecutor(
CommandExecutor executor
);

Parameters

executor
The CommandExecutor derived class to detach.

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Command.Execute Method

The command Execute method is normally overridden by a derived class

public virtual void Execute();

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Command.GetState Method

Gets the current state of the command

public virtual CommandState GetState(
string context
);

Parameters

context

Return Value

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Refresh Method

Common Application Framework

Command.Refresh Method

Call to allow the command to update its visilility or enabled state following a change to the application context.

Overload List

Call to allow the command to update its visilility or enabled state following a change to the application context.

public virtual void Refresh();

Call to allow the command to update its visilility or enabled state following a change to the application context.

public virtual void Refresh(string);

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Command.Refresh Method ()

Call to allow the command to update its visilility or enabled state following a change to the application context.

public virtual void Refresh();

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace | Command.Refresh Overload List


Command.Refresh Method (String)

Call to allow the command to update its visilility or enabled state following a change to the application context.

public virtual void Refresh(
string Context
);

Parameters

Context
A string representing the new application context

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace | Command.Refresh Overload List


Command.SetProperty Method

public virtual void SetProperty(
string property,
object value
);

Parameters

property
value

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Command Events

The events of the Command class are listed below. For a complete list of Command class members, see the Command Members topic.

Public Instance Events

BeforeCommandExecute | Occurs before the command is executed
CommandExecuted | Occurs when the command is executed

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Command.BeforeCommandExecute Event

Occurs before the command is executed

public event CancelEventHandler BeforeCommandExecute;

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


Command.CommandExecuted Event

Occurs when the command is executed

public event EventHandler CommandExecuted;

See Also

Command Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBar Class

Class to represent a CommandBar.

For a list of all members of this type, see CommandBar Members.

System.Object
Aveva.ApplicationFramework.Presentation.CommandBar
Aveva.ApplicationFramework.Presentation.TaskBar

public abstract class CommandBar

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

CommandBar Members | Aveva.ApplicationFramework.Presentation Namespace


CommandBar Members

CommandBar overview

Public Instance Properties

AllowCustomize | Gets or sets whether the CommandBar can be customized at run-time by the end user.
AllowFloating | Gets or sets whether the CommandBar can be dragged out of a dock area and floated.
AllowHiding | Gets or sets whether the CommandBar can be hidden at run-time by the end user.
Caption | Gets or sets the description displayed in the customization dialogs and in the caption of the floating CommandBar.
Command | Gets the command object which was associated with the CommandBar when it was created.
DockedColumn | Gets or sets the column (within the dock area) in which the CommandBar is docked.
DockedPosition | Gets or sets the current location of the CommandBar (left, right, top, bottom, floating)
DockedRow | Gets or sets the row (within the dock area) in which the CommandBar is docked.
Enabled | Gets or sets the enabled state of the CommandBar.
FillEntireRow | Gets or sets whether the CommandBar will take up the entire dock area row, even if it doesn't have enough tools to fill the area.
Key | The Key of the CommandBar in the CommandBarCollection
ShowInToolbarList | Gets or sets whether the CommandBar shows up in the customization dialog at runtime.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tools | Gets the ToolsCollection containing the tools to display in the CommandBar.
Visible | Gets or sets whether the CommandBar is visible.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Closed | Event raised when the CommandBar is Closed
Opened | Event raised when the CommandBar is Opened

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBar Properties

The properties of the CommandBar class are listed below. For a complete list of CommandBar class members, see the CommandBar Members topic.

Public Instance Properties

AllowCustomize | Gets or sets whether the CommandBar can be customized at run-time by the end user.
AllowFloating | Gets or sets whether the CommandBar can be dragged out of a dock area and floated.
AllowHiding | Gets or sets whether the CommandBar can be hidden at run-time by the end user.
Caption | Gets or sets the description displayed in the customization dialogs and in the caption of the floating CommandBar.
Command | Gets the command object which was associated with the CommandBar when it was created.
DockedColumn | Gets or sets the column (within the dock area) in which the CommandBar is docked.
DockedPosition | Gets or sets the current location of the CommandBar (left, right, top, bottom, floating)
DockedRow | Gets or sets the row (within the dock area) in which the CommandBar is docked.
Enabled | Gets or sets the enabled state of the CommandBar.
FillEntireRow | Gets or sets whether the CommandBar will take up the entire dock area row, even if it doesn't have enough tools to fill the area.
Key | The Key of the CommandBar in the CommandBarCollection
ShowInToolbarList | Gets or sets whether the CommandBar shows up in the customization dialog at runtime.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tools | Gets the ToolsCollection containing the tools to display in the CommandBar.
Visible | Gets or sets whether the CommandBar is visible.

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


AllowCustomize Property

Common Application Framework

CommandBar.AllowCustomize Property

Gets or sets whether the CommandBar can be customized at run-time by the end user.

public abstract bool AllowCustomize {get; set;}

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


AllowFloating Property

Common Application Framework

CommandBar.AllowFloating Property

Gets or sets whether the CommandBar can be dragged out of a dock area and floated.

public abstract bool AllowFloating {get; set;}

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


AllowHiding Property

Common Application Framework

CommandBar.AllowHiding Property

Gets or sets whether the CommandBar can be hidden at run-time by the end user.

public abstract bool AllowHiding {get; set;}

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


Caption Property

Common Application Framework

CommandBar.Caption Property

Gets or sets the description displayed in the customization dialogs and in the caption of the floating CommandBar.

public abstract string Caption {get; set;}

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


Command Property

Common Application Framework

CommandBar.Command Property

Gets the command object which was associated with the CommandBar when it was created.

public abstract Command Command {get;}

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


DockedColumn Property

Common Application Framework

CommandBar.DockedColumn Property

Gets or sets the column (within the dock area) in which the CommandBar is docked.

public abstract int DockedColumn {get; set;}

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


DockedPosition Property

Common Application Framework

CommandBar.DockedPosition Property

Gets or sets the current location of the CommandBar (left, right, top, bottom, floating)

public abstract DockedPosition DockedPosition {get; set;}

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


DockedRow Property

Common Application Framework

CommandBar.DockedRow Property

Gets or sets the row (within the dock area) in which the CommandBar is docked.

public abstract int DockedRow {get; set;}

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

CommandBar.Enabled Property

Gets or sets the enabled state of the CommandBar.

public abstract bool Enabled {get; set;}

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


FillEntireRow Property

Common Application Framework

CommandBar.FillEntireRow Property

Gets or sets whether the CommandBar will take up the entire dock area row, even if it doesn't have enough tools to fill the area.

public abstract bool FillEntireRow {get; set;}

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

CommandBar.Key Property

The Key of the CommandBar in the CommandBarCollection

public abstract string Key {get;}

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


ShowInToolbarList Property

Common Application Framework

CommandBar.ShowInToolbarList Property

Gets or sets whether the CommandBar shows up in the customization dialog at runtime.

public abstract bool ShowInToolbarList {get; set;}

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

CommandBar.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a tool.

public abstract object Tag {get; set;}

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


Tools Property

Common Application Framework

CommandBar.Tools Property

Gets the ToolsCollection containing the tools to display in the CommandBar.

public abstract ToolsCollection Tools {get;}

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

CommandBar.Visible Property

Gets or sets whether the CommandBar is visible.

public abstract bool Visible {get; set;}

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBar Events

The events of the CommandBar class are listed below. For a complete list of CommandBar class members, see the CommandBar Members topic.

Public Instance Events

Closed | Event raised when the CommandBar is Closed
Opened | Event raised when the CommandBar is Opened

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBar.Closed Event

Event raised when the CommandBar is Closed

public event EventHandler Closed;

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBar.Opened Event

Event raised when the CommandBar is Opened

public event EventHandler Opened;

See Also

CommandBar Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarEventArgs Class

Provides data for the CommandBarAdded and CommandBarRemoved events.

For a list of all members of this type, see CommandBarEventArgs Members.

System.Object
System.EventArgs
Aveva.ApplicationFramework.Presentation.CommandBarEventArgs

public class CommandBarEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

CommandBarEventArgs Members | Aveva.ApplicationFramework.Presentation Namespace


CommandBarEventArgs Members

CommandBarEventArgs overview

Public Instance Constructors

CommandBarEventArgs Constructor Initialize a new instance of a CommandBarEventArgs class

Public Instance Properties

CommandBar Gets the CommandBar object associated with the event

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CommandBarEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarEventArgs Constructor

Initialize a new instance of a CommandBarEventArgs class

public CommandBarEventArgs(
CommandBar cbar
);

Parameters

cbar
The CommandBar object

See Also

CommandBarEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarEventArgs Properties

The properties of the CommandBarEventArgs class are listed below. For a complete list of CommandBarEventArgs class members, see the CommandBarEventArgs Members topic.

Public Instance Properties

CommandBar Gets the CommandBar object associated with the event

See Also

CommandBarEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBar Property

Common Application Framework

CommandBarEventArgs.CommandBar Property

Gets the CommandBar object associated with the event

public CommandBar CommandBar {get;}

See Also

CommandBarEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarEventHandler Delegate

Represents the method that will handle CommandBar related events.

public delegate void CommandBarEventHandler(
object sender,
CommandBarEventArgs args
);

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager Class

Class representing a CommandBarManager.

For a list of all members of this type, see CommandBarManager Members.

System.Object
Aveva.ApplicationFramework.Presentation.CommandBarManager

public abstract class CommandBarManager : ISupportInitialize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

CommandBarManager Members | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager Members

CommandBarManager overview

Public Static Properties

Instance Get instance of commandbar manager

Public Instance Properties

AllowCustomization | Gets or sets the default Customization status for all CommandBars belonging to the CommandBarManager;
CommandBars | Gets the collection of CommandBar objects currently managed by the CommandBarManager.
Controls | Gets a Hashtable which contains controls to use for controls containers.
CustomizationDialog | Gets the non standard customization dialog.
CustomizationType | Gets or sets the type of customization.
Enabled | Get or sets a property which controls the enabled state of all CommandBars
IsUpdating | Gets whether the CommandBarManager is currently in update mode. (i.e. BeginInit() has been called)
MenuBar | Gets the CommandBar object that represents the Main Menu Bar.
RootTools | Gets the collection of RootTool objects currently managed by the CommandBarManager.

Public Instance Methods

AddOptionSet | Create a new OptionSet indentified by the specified Key An OptionSet is a set of StateButtonTools (a radio group) where at most one of the tools can can be in the Down (pressed) state.
AddUICustomizationFile | Adds a new UI Customization file.
AddUICustomizationFromStream | Adds a new UI Customization from the given stream
AddUICustomizationSet | Adds a set of UI Customization files.
BeginInit | ISupportInitialize allows controls to optimize for multiple sets to properties. As a result, you can initialize co-dependent properties or batch set multiple properties at design time. Signal the object that initialization is starting.
EndInit | ISupportInitialize allows controls to optimize for multiple sets to properties. As a result, you can initialize co-dependent properties or batch set multiple properties at design time. Signal that initialization is complete.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadLayout | Load the saved command CommandBars layout from a sttings file.
LoadUI | Creates the Menus,CommandBars and ContextMenus defined by the loaded UICustomization files.
SaveLayout | Save the current command CommandBars layout to a sttings file.
SelectTaskPane | Select the taskpane with the given key
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

CommandBarLayoutLoaded | Event raised when the commandBar layout is loaded
UILoaded | Event raised when the UI (Menus,CommandBars and ContextMenus) have finished loading after a call to LoadUI().

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager Properties

The properties of the CommandBarManager class are listed below. For a complete list of CommandBarManager class members, see the CommandBarManager Members topic.

Public Static Properties

Instance Get instance of commandbar manager

Public Instance Properties

AllowCustomization | Gets or sets the default Customization status for all CommandBars belonging to the CommandBarManager;
CommandBars | Gets the collection of CommandBar objects currently managed by the CommandBarManager.
Controls | Gets a Hashtable which contains controls to use for controls containers.
CustomizationDialog | Gets the non standard customization dialog.
CustomizationType | Gets or sets the type of customization.
Enabled | Get or sets a property which controls the enabled state of all CommandBars
IsUpdating | Gets whether the CommandBarManager is currently in update mode. (i.e. BeginInit() has been called)
MenuBar | Gets the CommandBar object that represents the Main Menu Bar.
RootTools | Gets the collection of RootTool objects currently managed by the CommandBarManager.

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


AllowCustomization Property

Common Application Framework

CommandBarManager.AllowCustomization Property

Gets or sets the default Customization status for all CommandBars belonging to the CommandBarManager;

public abstract bool AllowCustomization {get; set;}

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBars Property

Common Application Framework

CommandBarManager.CommandBars Property

Gets the collection of CommandBar objects currently managed by the CommandBarManager.

public abstract CommandBarsCollection CommandBars {get;}

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


Controls Property

Common Application Framework

CommandBarManager.Controls Property

Gets a Hashtable which contains controls to use for controls containers.

public abstract System.Collections.Hashtable Controls {get;}

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CustomizationDialog Property

Common Application Framework

CommandBarManager.CustomizationDialog Property

Gets the non standard customization dialog.

public abstract System.Windows.Forms.Form CustomizationDialog {get;}

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CustomizationType Property

Common Application Framework

CommandBarManager.CustomizationType Property

Gets or sets the type of customization.

public abstract CustomizationType CustomizationType {get; set;}

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

CommandBarManager.Enabled Property

Get or sets a property which controls the enabled state of all CommandBars

public abstract bool Enabled {get; set;}

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


Instance Property

Common Application Framework

CommandBarManager.Instance Property

Get instance of commandbar manager

public static CommandBarManager Instance {get; set;}

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


IsUpdating Property

Common Application Framework

CommandBarManager.IsUpdating Property

Gets whether the CommandBarManager is currently in update mode. (i.e. BeginInit() has been called)

public abstract bool IsUpdating {get;}

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


MenuBar Property

Common Application Framework

CommandBarManager.MenuBar Property

Gets the CommandBar object that represents the Main Menu Bar.

public abstract CommandBar MenuBar {get;}

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


RootTools Property

Common Application Framework

CommandBarManager.RootTools Property

Gets the collection of RootTool objects currently managed by the CommandBarManager.

public abstract RootToolsCollection RootTools {get;}

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager Methods

The methods of the CommandBarManager class are listed below. For a complete list of CommandBarManager class members, see the CommandBarManager Members topic.

Public Instance Methods

AddOptionSet | Create a new OptionSet indentified by the specified Key An OptionSet is a set of StateButtonTools (a radio group) where at most one of the tools can can be in the Down (pressed) state.
AddUICustomizationFile | Adds a new UI Customization file.
AddUICustomizationFromStream | Adds a new UI Customization from the given stream
AddUICustomizationSet | Adds a set of UI Customization files.
BeginInit | ISupportInitialize allows controls to optimize for multiple sets to properties. As a result, you can initialize co-dependent properties or batch set multiple properties at design time. Signal the object that initialization is starting.
EndInit | ISupportInitialize allows controls to optimize for multiple sets to properties. As a result, you can initialize co-dependent properties or batch set multiple properties at design time. Signal that initialization is complete.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadLayout | Load the saved command CommandBars layout from a sttings file.
LoadUI | Creates the Menus,CommandBars and ContextMenus defined by the loaded UICustomization files.
SaveLayout | Save the current command CommandBars layout to a sttings file.
SelectTaskPane | Select the taskpane with the given key
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager.AddOptionSet Method

Create a new OptionSet indentified by the specified Key An OptionSet is a set of StateButtonTools (a radio group) where at most one of the tools can can be in the Down (pressed) state.

public abstract void AddOptionSet(
bool allowAllUp,
string key
);

Parameters

allowAllUp
Boolean, controlling whether all buttons can be in the Up (unpressed) state simultaneously.
key
Unique key indentifying the OptionSet.

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager.AddUICustomizationFile Method

Adds a new UI Customization file.

public abstract void AddUICustomizationFile(
string pathname,
string name
);

Parameters

pathname
name

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager.AddUICustomizationFromStream Method

Adds a new UI Customization from the given stream

public abstract void AddUICustomizationFromStream(
Stream stream,
string name
);

Parameters

stream
name

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager.AddUICustomizationSet Method

Adds a set of UI Customization files.

public abstract void AddUICustomizationSet(
string pathname,
string[] args
);

Parameters

pathname
args

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager.BeginInit Method

ISupportInitialize allows controls to optimize for multiple sets to properties. As a result, you can initialize co-dependent properties or batch set multiple properties at design time. Signal the object that initialization is starting.

public abstract void BeginInit();

Implements

ISupportInitialize.BeginInit

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager.EndInit Method

ISupportInitialize allows controls to optimize for multiple sets to properties. As a result, you can initialize co-dependent properties or batch set multiple properties at design time. Signal that initialization is complete.

public abstract void EndInit();

Implements

ISupportInitialize.EndInit

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager.LoadLayout Method

Load the saved command CommandBars layout from a sttings file.

public abstract void LoadLayout();

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager.LoadUI Method

Creates the Menus,CommandBars and ContextMenus defined by the loaded UICustomization files.

public abstract void LoadUI();

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager.SaveLayout Method

Save the current command CommandBars layout to a sttings file.

public abstract void SaveLayout();

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager.SelectTaskPane Method

Select the taskpane with the given key

public abstract void SelectTaskPane(
string key
);

Parameters

key

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager Events

The events of the CommandBarManager class are listed below. For a complete list of CommandBarManager class members, see the CommandBarManager Members topic.

Public Instance Events

CommandBarLayoutLoaded | Event raised when the commandBar layout is loaded
UILoaded | Event raised when the UI (Menus,CommandBars and ContextMenus) have finished loading after a call to LoadUI().

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager.CommandBarLayoutLoaded Event

Event raised when the commandBar layout is loaded

public event EventHandler CommandBarLayoutLoaded;

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager.UILoaded Event

Event raised when the UI (Menus,CommandBars and ContextMenus) have finished loading after a call to LoadUI().

public event EventHandler UILoaded;

See Also

CommandBarManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarsCollection Class

Class to represent a CommandBarCollection.

For a list of all members of this type, see CommandBarsCollection Members.

System.Object
Aveva.ApplicationFramework.Presentation.CommandBarsCollection

public abstract class CommandBarsCollection : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

CommandBarsCollection Members | Aveva.ApplicationFramework.Presentation Namespace


CommandBarsCollection Members

CommandBarsCollection overview

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer to get the CommandBar with given Key from the CommandBarCollection.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

AddCommandBar | Overloaded. Create and add to the CommandBarCollection a new CommandBar with given Key and associated CommandId.
AddTaskBar | Create and add a new TaskBar with given Key to the CommandBarCollection.
Clear | Remove all CommandBars from the CommandBarCollection.
Contains | Determine if the CommandBar with the specified Key exists in the CommandBarCollection.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CommandBarCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveCommandBar | Overloaded. Remove the specified CommandBar from the CommandBarCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

CommandBarAdded | Occurs after a CommandBar has been added to the CommandBarCollection.
CommandBarRemoved | Occurs after a CommandBar has been removed from the CommandBarCollection.

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarsCollection Properties

The properties of the CommandBarsCollection class are listed below. For a complete list of CommandBarsCollection class members, see the CommandBarsCollection Members topic.

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer to get the CommandBar with given Key from the CommandBarCollection.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Count Property

Common Application Framework

CommandBarsCollection.Count Property

Gets the number of elements contained in the collection.

public abstract int Count {get;}

Implements

ICollection.Count

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


IsSynchronized Property

Common Application Framework

CommandBarsCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public abstract bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Item Property

Common Application Framework

CommandBarsCollection.Item Property

Indexer to get the CommandBar with given Key from the CommandBarCollection.

public abstract CommandBar this[
string key
] {get;}

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


SyncRoot Property

Common Application Framework

CommandBarsCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public abstract object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarsCollection Methods

The methods of the CommandBarsCollection class are listed below. For a complete list of CommandBarsCollection class members, see the CommandBarsCollection Members topic.

Public Instance Methods

AddCommandBar | Overloaded. Create and add to the CommandBarCollection a new CommandBar with given Key and associated CommandId.
AddTaskBar | Create and add a new TaskBar with given Key to the CommandBarCollection.
Clear | Remove all CommandBars from the CommandBarCollection.
Contains | Determine if the CommandBar with the specified Key exists in the CommandBarCollection.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CommandBarCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveCommandBar | Overloaded. Remove the specified CommandBar from the CommandBarCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


AddCommandBar Method

Common Application Framework

CommandBarsCollection.AddCommandBar Method

Create and add to the CommandBarCollection a new CommandBar with given Key.

Overload List

Create and add to the CommandBarCollection a new CommandBar with given Key.

public abstract CommandBar AddCommandBar(string);

Create and add to the CommandBarCollection a new CommandBar with given Key and associated Command.

public abstract CommandBar AddCommandBar(string,Command);

Create and add to the CommandBarCollection a new CommandBar with given Key and associated CommandId.

public abstract CommandBar AddCommandBar(string,string);

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarsCollection.AddCommandBar Method (String)

Create and add to the CommandBarCollection a new CommandBar with given Key.

public abstract CommandBar AddCommandBar(
string key
);

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | CommandBarsCollection.AddCommandBar Overload List


CommandBarsCollection.AddCommandBar Method (String, Command)

Create and add to the CommandBarCollection a new CommandBar with given Key and associated Command.

public abstract CommandBar AddCommandBar(
string key,
Command command
);

Parameters

key
CommandBar key
command
Command associated with the CommandBar

Return Value

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | CommandBarsCollection.AddCommandBar Overload List


CommandBarsCollection.AddCommandBar Method (String, String)

Create and add to the CommandBarCollection a new CommandBar with given Key and associated CommandId.

public abstract CommandBar AddCommandBar(
string key,
string commandId
);

Parameters

key
CommandBar key
commandId
Id of the command associated with the CommandBar

Return Value

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | CommandBarsCollection.AddCommandBar Overload List


CommandBarsCollection.AddTaskBar Method

Create and add a new TaskBar with given Key to the CommandBarCollection.

public abstract TaskBar AddTaskBar(
string key
);

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarsCollection.Clear Method

Remove all CommandBars from the CommandBarCollection.

public abstract void Clear();

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarsCollection.Contains Method

Determine if the CommandBar with the specified Key exists in the CommandBarCollection.

public abstract bool Contains(
string key
);

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarsCollection.CopyTo Method

Copies the elements of the collection to an Array, starting at a particular Array index.

public abstract void CopyTo(
Array array,
int index
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from collection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Implements

ICollection.CopyTo

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarsCollection.GetEnumerator Method

Returns an enumerator that can iterate through the CommandBarCollection.

public abstract IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RemoveCommandBar Method

Common Application Framework

CommandBarsCollection.RemoveCommandBar Method

Remove the specified CommandBar from the CommandBarCollection.

Overload List

Remove the specified CommandBar from the CommandBarCollection.

public abstract void RemoveCommandBar(CommandBar);

Remove the CommandBar with given Key from the CommandBarCollection.

public abstract void RemoveCommandBar(string);

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarsCollection.RemoveCommandBar Method (CommandBar)

Remove the specified CommandBar from the CommandBarCollection.

public abstract void RemoveCommandBar(
CommandBar commandBar
);

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | CommandBarsCollection.RemoveCommandBar Overload List


CommandBarsCollection.RemoveCommandBar Method (String)

Remove the CommandBar with given Key from the CommandBarCollection.

public abstract void RemoveCommandBar(
string key
);

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | CommandBarsCollection.RemoveCommandBar Overload List


CommandBarsCollection Events

The events of the CommandBarsCollection class are listed below. For a complete list of CommandBarsCollection class members, see the CommandBarsCollection Members topic.

Public Instance Events

CommandBarAdded | Occurs after a CommandBar has been added to the CommandBarCollection.
CommandBarRemoved | Occurs after a CommandBar has been removed from the CommandBarCollection.

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarsCollection.CommandBarAdded Event

Occurs after a CommandBar has been added to the CommandBarCollection.

public event CommandBarEventHandler CommandBarAdded;

Event Data

The event handler receives an argument of type CommandBarEventArgs containing data related to this event. The following CommandBarEventArgs property provides information specific to this event.

Property | Description
CommandBar | Gets the CommandBar object associated with the event

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarsCollection.CommandBarRemoved Event

Occurs after a CommandBar has been removed from the CommandBarCollection.

public event CommandBarEventHandler CommandBarRemoved;

Event Data

The event handler receives an argument of type CommandBarEventArgs containing data related to this event. The following CommandBarEventArgs property provides information specific to this event.

Property | Description
CommandBar | Gets the CommandBar object associated with the event

See Also

CommandBarsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandEventArgs Class

Provides data for the CommandAdded and CommandRemoved events.

For a list of all members of this type, see CommandEventArgs Members.

System.Object
System.EventArgs
Aveva.ApplicationFramework.Presentation.CommandEventArgs

public class CommandEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

CommandEventArgs Members | Aveva.ApplicationFramework.Presentation Namespace


CommandEventArgs Members

CommandEventArgs overview

Public Instance Constructors

CommandEventArgs Constructor Initialize a new instance of a CommandEventArgs class

Public Instance Properties

Command Gets the Command object associated with the event

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CommandEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


CommandEventArgs Constructor

Initialize a new instance of a CommandEventArgs class

public CommandEventArgs(
Command command
);

Parameters

command
The Command object

See Also

CommandEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


CommandEventArgs Properties

The properties of the CommandEventArgs class are listed below. For a complete list of CommandEventArgs class members, see the CommandEventArgs Members topic.

Public Instance Properties

Command Gets the Command object associated with the event

See Also

CommandEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


Command Property

Common Application Framework

CommandEventArgs.Command Property

Gets the Command object associated with the event

public Command Command {get;}

See Also

CommandEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


CommandEventHandler Delegate

Represents the method that will handle command related events.

public delegate void CommandEventHandler(
object sender,
CommandEventArgs args
);

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


CommandExecutor Class

Abstract base class which an application must inherit from to create a CommandExecutor object.

For a list of all members of this type, see CommandExecutor Members.

System.Object
Aveva.ApplicationFramework.Presentation.CommandExecutor

public abstract class CommandExecutor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

CommandExecutor Members | Aveva.ApplicationFramework.Presentation Namespace


CommandExecutor Members

CommandExecutor overview

Public Instance Properties

Checked | Gets or sets the Checked state of the CommandExecutor.
Enabled | Gets or sets the Enabled state of the CommandExecutor.
Value | Gets or sets the value of the CommandExecutor.
Visible | Gets or sets the Visible state of the CommandExecutor.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetProperty | Sets the given property to the given value.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CommandExecutor Class | Aveva.ApplicationFramework.Presentation Namespace


CommandExecutor Properties

The properties of the CommandExecutor class are listed below. For a complete list of CommandExecutor class members, see the CommandExecutor Members topic.

Public Instance Properties

Checked | Gets or sets the Checked state of the CommandExecutor.
Enabled | Gets or sets the Enabled state of the CommandExecutor.
Value | Gets or sets the value of the CommandExecutor.
Visible | Gets or sets the Visible state of the CommandExecutor.

See Also

CommandExecutor Class | Aveva.ApplicationFramework.Presentation Namespace


Checked Property

Common Application Framework

CommandExecutor.Checked Property

Gets or sets the Checked state of the CommandExecutor.

public abstract bool Checked {get; set;}

See Also

CommandExecutor Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

CommandExecutor.Enabled Property

Gets or sets the Enabled state of the CommandExecutor.

public abstract bool Enabled {get; set;}

See Also

CommandExecutor Class | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

CommandExecutor.Value Property

Gets or sets the value of the CommandExecutor.

public abstract object Value {set;}

See Also

CommandExecutor Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

CommandExecutor.Visible Property

Gets or sets the Visible state of the CommandExecutor.

public abstract bool Visible {get; set;}

See Also

CommandExecutor Class | Aveva.ApplicationFramework.Presentation Namespace


CommandExecutor Methods

The methods of the CommandExecutor class are listed below. For a complete list of CommandExecutor class members, see the CommandExecutor Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetProperty | Sets the given property to the given value.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CommandExecutor Class | Aveva.ApplicationFramework.Presentation Namespace


CommandExecutor.SetProperty Method

Sets the given property to the given value.

public abstract void SetProperty(
string property,
object value
);

Parameters

property
value

See Also

CommandExecutor Class | Aveva.ApplicationFramework.Presentation Namespace


CommandList Class

An ArrayList use for the list property of Command objects which supports an IsModified property.

For a list of all members of this type, see CommandList Members.

System.Object
System.Collections.ArrayList
Aveva.ApplicationFramework.Presentation.CommandList

public class CommandList : ArrayList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

CommandList Members | Aveva.ApplicationFramework.Presentation Namespace


CommandList Members

CommandList overview

Public Instance Constructors

CommandList Constructor Default constructor for CommandList.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsModified | Flag which is set to true whenever the list is modified.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item | Gets or sets the element at the specified index.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add | Adds an object to the end of the CommandList.
AddRange | Adds the elements of an ICollection to the end of the CommandList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear | Removes all elements from the CommandList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert | Inserts an element into the CommandList at the specified index.
InsertRange | Inserts the elements of a collection into the CommandList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove | Removes the first occurrence of a specific object from the CommandList.
RemoveAt | Removes the element at the specified index of the CommandList.
RemoveRange | Removes a range of elements from the CommandList.
Reverse | Overloaded. Reverses the order of the elements in the CommandList or a portion of it.
SetRange | Copies the elements of a collection over a range of elements in the CommandList.
Sort | Overloaded. Sorts the elements in the CommandList or a portion of it.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


CommandList Constructor

Default constructor for CommandList.

public CommandList();

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


CommandList Properties

The properties of the CommandList class are listed below. For a complete list of CommandList class members, see the CommandList Members topic.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsModified | Flag which is set to true whenever the list is modified.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item | Gets or sets the element at the specified index.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


IsModified Property

Common Application Framework

CommandList.IsModified Property

Flag which is set to true whenever the list is modified.

public bool IsModified {get; set;}

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


Item Property

Common Application Framework

CommandList.Item Property

Gets or sets the element at the specified index.

public override object this[
int index
] {get; set;}

Implements

IList.Item

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


CommandList Methods

The methods of the CommandList class are listed below. For a complete list of CommandList class members, see the CommandList Members topic.

Public Instance Methods

Add | Adds an object to the end of the CommandList.
AddRange | Adds the elements of an ICollection to the end of the CommandList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear | Removes all elements from the CommandList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert | Inserts an element into the CommandList at the specified index.
InsertRange | Inserts the elements of a collection into the CommandList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove | Removes the first occurrence of a specific object from the CommandList.
RemoveAt | Removes the element at the specified index of the CommandList.
RemoveRange | Removes a range of elements from the CommandList.
Reverse | Overloaded. Reverses the order of the elements in the CommandList or a portion of it.
SetRange | Copies the elements of a collection over a range of elements in the CommandList.
Sort | Overloaded. Sorts the elements in the CommandList or a portion of it.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


CommandList.Add Method

Adds an object to the end of the CommandList.

public override int Add(
object value
);

Parameters

value
The Object to be added to the end of the CommandList

Return Value

Implements

IList.Add

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


CommandList.AddRange Method

Adds the elements of an ICollection to the end of the CommandList.

public override void AddRange(
ICollection c
);

Parameters

c
The ICollection whose elements should be added to the end of the CommandList

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


CommandList.Clear Method

Removes all elements from the CommandList.

public override void Clear();

Implements

IList.Clear

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


CommandList.Insert Method

Inserts an element into the CommandList at the specified index.

public override void Insert(
int index,
object value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The Object to insert.

Implements

IList.Insert

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


CommandList.InsertRange Method

Inserts the elements of a collection into the CommandList at the specified index.

public override void InsertRange(
int index,
ICollection c
);

Parameters

index
The zero-based index at which the new elements should be inserted.
c
The ICollection whose elements should be inserted into the ArrayList.

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


CommandList.Remove Method

Removes the first occurrence of a specific object from the CommandList.

public override void Remove(
object obj
);

Parameters

obj
The Object to remove from the CommandList.

Implements

IList.Remove

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


CommandList.RemoveAt Method

Removes the element at the specified index of the CommandList.

public override void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Implements

IList.RemoveAt

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


CommandList.RemoveRange Method

Removes a range of elements from the CommandList.

public override void RemoveRange(
int index,
int count
);

Parameters

index
The zero-based starting index of the range of elements to remove.
count
The number of elements to remove.

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


Reverse Method

Common Application Framework

CommandList.Reverse Method

Reverses the order of the elements in the CommandList or a portion of it.

Overload List

Reverses the order of the elements in the CommandList or a portion of it.

public override void Reverse();

Reverses the order of the elements in the CommandList or a portion of it.

public override void Reverse(int,int);

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


CommandList.Reverse Method ()

Reverses the order of the elements in the CommandList or a portion of it.

public override void Reverse();

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace | CommandList.Reverse Overload List


CommandList.Reverse Method (Int32, Int32)

Reverses the order of the elements in the CommandList or a portion of it.

public override void Reverse(
int index,
int count
);

Parameters

index
The zero-based starting index of the range to reverse.
count
The number of elements in the range to reverse.

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace | CommandList.Reverse Overload List


CommandList.SetRange Method

Copies the elements of a collection over a range of elements in the CommandList.

public override void SetRange(
int index,
ICollection c
);

Parameters

index
The zero-based ArrayList index at which to start copying the elements of c.
c
The ICollection whose elements to copy to the CommandList.

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


Sort Method

Common Application Framework

CommandList.Sort Method

Sorts the elements in the CommandList or a portion of it.

Overload List

Sorts the elements in the CommandList or a portion of it.

public override void Sort();

Sorts the elements in the CommandList or a portion of it.

public override void Sort(IComparer);

Sorts the elements in the CommandList or a portion of it.

public override void Sort(int,int,IComparer);

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace


CommandList.Sort Method ()

Sorts the elements in the CommandList or a portion of it.

public override void Sort();

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace | CommandList.Sort Overload List


CommandList.Sort Method (IComparer)

Sorts the elements in the CommandList or a portion of it.

public override void Sort(
IComparer comparer
);

Parameters

comparer
The IComparer implementation to use when comparing elements.

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace | CommandList.Sort Overload List


CommandList.Sort Method (Int32, Int32, IComparer)

Sorts the elements in the CommandList or a portion of it.

public override void Sort(
int index,
int count,
IComparer comparer
);

Parameters

index
The zero-based starting index of the range to sort.
count
The length of the range to sort.
comparer
The IComparer implementation to use when comparing elements.

See Also

CommandList Class | Aveva.ApplicationFramework.Presentation Namespace | CommandList.Sort Overload List


CommandManager Class

Class representing a CommandManager.

For a list of all members of this type, see CommandManager Members.

System.Object
Aveva.ApplicationFramework.Presentation.CommandManager

public abstract class CommandManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

CommandManager Members | Aveva.ApplicationFramework.Presentation Namespace


CommandManager Members

CommandManager overview

Public Static Properties

Instance Get instance of command manager

Public Instance Properties

ApplicationContext | Property which holds the current application context, which is used to manage the state of all commands.
Commands | Gets the collection of Command objects currently managed by the CommandManager.
CommandTypes | Property which returns a Hashtable of Command Types
MacroCommand | Property which holds the type of a class which implements a command to execute a macro in the context of the host application. (Eg. A PML command in PDMS)

Public Instance Methods

AddAllCommands | Add to the CommandCollection an instance of each class in the calling assembly which has a base class of type Aveva.ApplicationFramework.Presentation.Command
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CommandManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandManager Properties

The properties of the CommandManager class are listed below. For a complete list of CommandManager class members, see the CommandManager Members topic.

Public Static Properties

Instance Get instance of command manager

Public Instance Properties

ApplicationContext | Property which holds the current application context, which is used to manage the state of all commands.
Commands | Gets the collection of Command objects currently managed by the CommandManager.
CommandTypes | Property which returns a Hashtable of Command Types
MacroCommand | Property which holds the type of a class which implements a command to execute a macro in the context of the host application. (Eg. A PML command in PDMS)

See Also

CommandManager Class | Aveva.ApplicationFramework.Presentation Namespace


ApplicationContext Property

Common Application Framework

CommandManager.ApplicationContext Property

Property which holds the current application context, which is used to manage the state of all commands.

public abstract string ApplicationContext {get; set;}

See Also

CommandManager Class | Aveva.ApplicationFramework.Presentation Namespace


Commands Property

Common Application Framework

CommandManager.Commands Property

Gets the collection of Command objects currently managed by the CommandManager.

public abstract CommandsCollection Commands {get;}

See Also

CommandManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandTypes Property

Common Application Framework

CommandManager.CommandTypes Property

Property which returns a Hashtable of Command Types

public abstract CommandTypesCollection CommandTypes {get;}

See Also

CommandManager Class | Aveva.ApplicationFramework.Presentation Namespace


Instance Property

Common Application Framework

CommandManager.Instance Property

Get instance of command manager

public static CommandManager Instance {get; set;}

See Also

CommandManager Class | Aveva.ApplicationFramework.Presentation Namespace


MacroCommand Property

Common Application Framework

CommandManager.MacroCommand Property

Property which holds the type of a class which implements a command to execute a macro in the context of the host application. (Eg. A PML command in PDMS)

public abstract System.Type MacroCommand {get; set;}

See Also

CommandManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandManager Methods

The methods of the CommandManager class are listed below. For a complete list of CommandManager class members, see the CommandManager Members topic.

Public Instance Methods

AddAllCommands | Add to the CommandCollection an instance of each class in the calling assembly which has a base class of type Aveva.ApplicationFramework.Presentation.Command
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CommandManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandManager.AddAllCommands Method

Add to the CommandCollection an instance of each class in the calling assembly which has a base class of type Aveva.ApplicationFramework.Presentation.Command

public abstract void AddAllCommands();

See Also

CommandManager Class | Aveva.ApplicationFramework.Presentation Namespace


CommandsCollection Class

Class that represents a CommandCollection.

For a list of all members of this type, see CommandsCollection Members.

System.Object
Aveva.ApplicationFramework.Presentation.CommandsCollection

public abstract class CommandsCollection : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

CommandsCollection Members | Aveva.ApplicationFramework.Presentation Namespace


CommandsCollection Members

CommandsCollection overview

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer to get the Command with given Key from the CommandCollection.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Add the given Command to the CommandCollection.
ContainsKey | Determine if the Command with the specified Key exists in the CommandCollection.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CommandBarCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Remove the Command with given Key from the CommandCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

CommandAdded | Occurs after a Command has been added to the CommandCollection.
CommandRemoved | Occurs after a Command has been removed from the CommandCollection.

See Also

CommandsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandsCollection Properties

The properties of the CommandsCollection class are listed below. For a complete list of CommandsCollection class members, see the CommandsCollection Members topic.

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer to get the Command with given Key from the CommandCollection.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

CommandsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Count Property

Common Application Framework

CommandsCollection.Count Property

Gets the number of elements contained in the collection.

public abstract int Count {get;}

Implements

ICollection.Count

See Also

CommandsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


IsSynchronized Property

Common Application Framework

CommandsCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public abstract bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

CommandsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Item Property

Common Application Framework

CommandsCollection.Item Property

Indexer to get the Command with given Key from the CommandCollection.

public abstract Command this[
string key
] {get;}

See Also

CommandsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


SyncRoot Property

Common Application Framework

CommandsCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public abstract object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

CommandsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandsCollection Methods

The methods of the CommandsCollection class are listed below. For a complete list of CommandsCollection class members, see the CommandsCollection Members topic.

Public Instance Methods

Add | Add the given Command to the CommandCollection.
ContainsKey | Determine if the Command with the specified Key exists in the CommandCollection.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CommandBarCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Remove the Command with given Key from the CommandCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CommandsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandsCollection.Add Method

Add the given Command to the CommandCollection.

public abstract void Add(
Command command
);

See Also

CommandsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandsCollection.ContainsKey Method

Determine if the Command with the specified Key exists in the CommandCollection.

public abstract bool ContainsKey(
string key
);

See Also

CommandsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandsCollection.CopyTo Method

Copies the elements of the collection to an Array, starting at a particular Array index.

public abstract void CopyTo(
Array array,
int index
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from collection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Implements

ICollection.CopyTo

See Also

CommandsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandsCollection.GetEnumerator Method

Returns an enumerator that can iterate through the CommandBarCollection.

public abstract IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

CommandsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandsCollection.Remove Method

Remove the Command with given Key from the CommandCollection.

public abstract void Remove(
string key
);

See Also

CommandsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandsCollection Events

The events of the CommandsCollection class are listed below. For a complete list of CommandsCollection class members, see the CommandsCollection Members topic.

Public Instance Events

CommandAdded | Occurs after a Command has been added to the CommandCollection.
CommandRemoved | Occurs after a Command has been removed from the CommandCollection.

See Also

CommandsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandsCollection.CommandAdded Event

Occurs after a Command has been added to the CommandCollection.

public event CommandEventHandler CommandAdded;

Event Data

The event handler receives an argument of type CommandEventArgs containing data related to this event. The following CommandEventArgs property provides information specific to this event.

Property | Description
Command | Gets the Command object associated with the event

See Also

CommandsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandsCollection.CommandRemoved Event

Occurs after a Command has been removed from the CommandCollection.

public event CommandEventHandler CommandRemoved;

Event Data

The event handler receives an argument of type CommandEventArgs containing data related to this event. The following CommandEventArgs property provides information specific to this event.

Property | Description
Command | Gets the Command object associated with the event

See Also

CommandsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandState Enumeration

Enumeration for various states of a command. This enumeration can be treated as a bit field; that is, a set of flags. Bit fields can be combined using a bitwise OR operation.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum CommandState

Members

Member Name | Description | Value
Enabled | Command is enabled. | 1
Disabled | Command is disabled. | 2
Hidden | Command is hidden. | 4
Checked | Command is in checked state. | 8
Unchecked | Command is in unchecked state. | 16

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


CommandTypesCollection Class

Class that represents a CommandCollection.

For a list of all members of this type, see CommandTypesCollection Members.

System.Object
Aveva.ApplicationFramework.Presentation.CommandTypesCollection

public abstract class CommandTypesCollection : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

CommandTypesCollection Members | Aveva.ApplicationFramework.Presentation Namespace


CommandTypesCollection Members

CommandTypesCollection overview

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer to get the Command with given Key from the CommandCollection.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Add the given Command Type to the CommandCollection.
ContainsKey | Determine if the Command with the specified Key exists in the CommandCollection.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CommandBarCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Remove the Command with given Key from the CommandCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CommandTypesCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandTypesCollection Properties

The properties of the CommandTypesCollection class are listed below. For a complete list of CommandTypesCollection class members, see the CommandTypesCollection Members topic.

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer to get the Command with given Key from the CommandCollection.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

CommandTypesCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Count Property

Common Application Framework

CommandTypesCollection.Count Property

Gets the number of elements contained in the collection.

public abstract int Count {get;}

Implements

ICollection.Count

See Also

CommandTypesCollection Class | Aveva.ApplicationFramework.Presentation Namespace


IsSynchronized Property

Common Application Framework

CommandTypesCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public abstract bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

CommandTypesCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Item Property

Common Application Framework

CommandTypesCollection.Item Property

Indexer to get the Command with given Key from the CommandCollection.

public abstract System.Type this[
string key
] {get;}

See Also

CommandTypesCollection Class | Aveva.ApplicationFramework.Presentation Namespace


SyncRoot Property

Common Application Framework

CommandTypesCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public abstract object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

CommandTypesCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandTypesCollection Methods

The methods of the CommandTypesCollection class are listed below. For a complete list of CommandTypesCollection class members, see the CommandTypesCollection Members topic.

Public Instance Methods

Add | Add the given Command Type to the CommandCollection.
ContainsKey | Determine if the Command with the specified Key exists in the CommandCollection.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CommandBarCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Remove the Command with given Key from the CommandCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CommandTypesCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandTypesCollection.Add Method

Add the given Command Type to the CommandCollection.

public abstract void Add(
Type commandType
);

See Also

CommandTypesCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandTypesCollection.ContainsKey Method

Determine if the Command with the specified Key exists in the CommandCollection.

public abstract bool ContainsKey(
string key
);

See Also

CommandTypesCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandTypesCollection.CopyTo Method

Copies the elements of the collection to an Array, starting at a particular Array index.

public abstract void CopyTo(
Array array,
int index
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from collection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Implements

ICollection.CopyTo

See Also

CommandTypesCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandTypesCollection.GetEnumerator Method

Returns an enumerator that can iterate through the CommandBarCollection.

public abstract IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

CommandTypesCollection Class | Aveva.ApplicationFramework.Presentation Namespace


CommandTypesCollection.Remove Method

Remove the Command with given Key from the CommandCollection.

public abstract void Remove(
string key
);

See Also

CommandTypesCollection Class | Aveva.ApplicationFramework.Presentation Namespace


ContainerTool Class

A tool that contains a Control.

For a list of all members of this type, see ContainerTool Members.

System.Object
Aveva.ApplicationFramework.Presentation.ContainerTool

public abstract class ContainerTool : ITool

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

ContainerTool Members | Aveva.ApplicationFramework.Presentation Namespace


ContainerTool Members

ContainerTool overview

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Control | Gets or sets the control displayed in the ContainerTool
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.
Width | Gets or sets the width of the tool.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


ContainerTool Properties

The properties of the ContainerTool class are listed below. For a complete list of ContainerTool class members, see the ContainerTool Members topic.

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Control | Gets or sets the control displayed in the ContainerTool
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.
Width | Gets or sets the width of the tool.

See Also

ContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Caption Property

Common Application Framework

ContainerTool.Caption Property

Gets or sets the tool caption

public abstract string Caption {get; set;}

Implements

ITool.Caption

See Also

ContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Category Property

Common Application Framework

ContainerTool.Category Property

Gets or sets the tools category

public abstract string Category {get; set;}

Implements

ITool.Category

See Also

ContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Control Property

Common Application Framework

ContainerTool.Control Property

Gets or sets the control displayed in the ContainerTool

public abstract System.Windows.Forms.Control Control {get; set;}

See Also

ContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

ContainerTool.Enabled Property

Gets or sets the enabled state of the tool.

public abstract bool Enabled {get; set;}

Implements

ITool.Enabled

See Also

ContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

ContainerTool.Image Property

Gets or sets the image displayed on the tool

public abstract System.Drawing.Image Image {get; set;}

Implements

ITool.Image

See Also

ContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


IsFirstInGroup Property

Common Application Framework

ContainerTool.IsFirstInGroup Property

Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.

public abstract bool IsFirstInGroup {get; set;}

Implements

ITool.IsFirstInGroup

See Also

ContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

ContainerTool.Key Property

The Key of the tool in the RootToolsCollection

public abstract string Key {get;}

Implements

ITool.Key

See Also

ContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Shortcut Property

Common Application Framework

ContainerTool.Shortcut Property

Gets or sets the shortcut associated with a tool.

public abstract System.Windows.Forms.Shortcut Shortcut {get; set;}

Implements

ITool.Shortcut

See Also

ContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

ContainerTool.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a tool.

public abstract object Tag {get; set;}

Implements

ITool.Tag

See Also

ContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

ContainerTool.Tooltip Property

Gets or sets the tools tooltip

public abstract string Tooltip {get; set;}

Implements

ITool.Tooltip

See Also

ContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

ContainerTool.Value Property

Gets or sets the value of the tool.

public abstract object Value {get; set;}

Implements

ITool.Value

See Also

ContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

ContainerTool.Visible Property

Gets or sets the visibility of the tool.

public abstract bool Visible {get; set;}

Implements

ITool.Visible

See Also

ContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Width Property

Common Application Framework

ContainerTool.Width Property

Gets or sets the width of the tool.

public abstract int Width {get; set;}

See Also

ContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


CustomizationType Enumeration

Enumeration of menu and commandbar customisation options

public enum CustomizationType

Members

Member Name | Description
Standard | Use standard Office 2003 style customisation
Custom | Use advanced customisation

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


DockedPosition Enumeration

Enumerator used to specify the location of a toolbar or window docking area.

public enum DockedPosition

Members

Member Name | Description
Top | The docking area is located at the top of the container.
Bottom | The docking area is located at the bottom of the container.
Left | The docking area is located at the left edge of the container.
Right | The docking area is located at the right edge of the container.
Floating | The commandbar or window is floating.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


DockedWindow Class

Class to represent a DockedWindow.

For a list of all members of this type, see DockedWindow Members.

System.Object
Aveva.ApplicationFramework.Presentation.DockedWindow

public abstract class DockedWindow : IWindow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

DockedWindow Members | Aveva.ApplicationFramework.Presentation Namespace


DockedWindow Members

DockedWindow overview

Public Instance Properties

Control | Gets the control displayed in the window.
DockedPosition | Gets the current docked position of the window.
DockGroupStyle | Returns or sets how groups of docked windows should be organised.
Enabled | Gets or sets whether the window is enabled.
Floatable | Gets or sets whether the window is floatable.
Height | Gets or sets the height of the window.
HelpALink | Gets or sets a help link associated with the window.
HelpContextId | Gets or sets the help context id associated with the window.
IsFloating | Gets the floating state of a window.
Key | Gets the Key of the window in the WindowsCollection.
MaximumSize | Get or sets the maximum size of the window.
MinimumSize | Get or sets the minimum size of the window.
SaveLayout | Gets or sets the property which controls if the window should be included in the docked window layout serialization
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a window.
Title | Gets or sets the title of the window.
Visible | Gets or sets the visible state of the window.
Width | Gets or sets the width of the window.

Public Instance Methods

Close | Destroys the window.
Dock | Docks the window within the main window.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Float | Displays the window as a floating window.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GroupWith | Arrange docked windows together as a group.
Hide | Conceals the window from the user.
Show | Displays the window to the user.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Activated | Event which occurs when the window is activated.
Closed | Event which occurs when window is closed.
Closing | Event which occurs when window is closing.
Deactivated | Event which occurs when the window is deactivated.
Reparented | Event which occurs when the window is reparented.

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockedWindow Properties

The properties of the DockedWindow class are listed below. For a complete list of DockedWindow class members, see the DockedWindow Members topic.

Public Instance Properties

Control | Gets the control displayed in the window.
DockedPosition | Gets the current docked position of the window.
DockGroupStyle | Returns or sets how groups of docked windows should be organised.
Enabled | Gets or sets whether the window is enabled.
Floatable | Gets or sets whether the window is floatable.
Height | Gets or sets the height of the window.
HelpALink | Gets or sets a help link associated with the window.
HelpContextId | Gets or sets the help context id associated with the window.
IsFloating | Gets the floating state of a window.
Key | Gets the Key of the window in the WindowsCollection.
MaximumSize | Get or sets the maximum size of the window.
MinimumSize | Get or sets the minimum size of the window.
SaveLayout | Gets or sets the property which controls if the window should be included in the docked window layout serialization
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a window.
Title | Gets or sets the title of the window.
Visible | Gets or sets the visible state of the window.
Width | Gets or sets the width of the window.

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Control Property

Common Application Framework

DockedWindow.Control Property

Gets the control displayed in the window.

public abstract System.Windows.Forms.Control Control {get;}

Implements

IWindow.Control

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockedPosition Property

Common Application Framework

DockedWindow.DockedPosition Property

Gets the current docked position of the window.

public abstract DockedPosition DockedPosition {get;}

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockGroupStyle Property

Common Application Framework

DockedWindow.DockGroupStyle Property

Returns or sets how groups of docked windows should be organised.

public abstract DockGroupStyle DockGroupStyle {get; set;}

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

DockedWindow.Enabled Property

Gets or sets whether the window is enabled.

public abstract bool Enabled {get; set;}

Implements

IWindow.Enabled

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Floatable Property

Common Application Framework

DockedWindow.Floatable Property

Gets or sets whether the window is floatable.

public abstract bool Floatable {get; set;}

Implements

IWindow.Floatable

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Height Property

Common Application Framework

DockedWindow.Height Property

Gets or sets the height of the window.

public abstract int Height {get; set;}

Implements

IWindow.Height

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


HelpALink Property

Common Application Framework

DockedWindow.HelpALink Property

Gets or sets a help link associated with the window.

public abstract string HelpALink {get; set;}

Implements

IWindow.HelpALink

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


HelpContextId Property

Common Application Framework

DockedWindow.HelpContextId Property

Gets or sets the help context id associated with the window.

public abstract string HelpContextId {get; set;}

Implements

IWindow.HelpContextId

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


IsFloating Property

Common Application Framework

DockedWindow.IsFloating Property

Gets the floating state of a window.

public abstract bool IsFloating {get;}

Implements

IWindow.IsFloating

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

DockedWindow.Key Property

Gets the Key of the window in the WindowsCollection.

public abstract string Key {get;}

Implements

IWindow.Key

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MaximumSize Property

Common Application Framework

DockedWindow.MaximumSize Property

Get or sets the maximum size of the window.

public abstract System.Drawing.Size MaximumSize {get; set;}

Implements

IWindow.MaximumSize

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MinimumSize Property

Common Application Framework

DockedWindow.MinimumSize Property

Get or sets the minimum size of the window.

public abstract System.Drawing.Size MinimumSize {get; set;}

Implements

IWindow.MinimumSize

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


SaveLayout Property

Common Application Framework

DockedWindow.SaveLayout Property

Gets or sets the property which controls if the window should be included in the docked window layout serialization

public abstract bool SaveLayout {get; set;}

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

DockedWindow.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a window.

public abstract object Tag {get; set;}

Implements

IWindow.Tag

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Title Property

Common Application Framework

DockedWindow.Title Property

Gets or sets the title of the window.

public abstract string Title {get; set;}

Implements

IWindow.Title

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

DockedWindow.Visible Property

Gets or sets the visible state of the window.

public abstract bool Visible {get; set;}

Implements

IWindow.Visible

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Width Property

Common Application Framework

DockedWindow.Width Property

Gets or sets the width of the window.

public abstract int Width {get; set;}

Implements

IWindow.Width

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockedWindow Methods

The methods of the DockedWindow class are listed below. For a complete list of DockedWindow class members, see the DockedWindow Members topic.

Public Instance Methods

Close | Destroys the window.
Dock | Docks the window within the main window.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Float | Displays the window as a floating window.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GroupWith | Arrange docked windows together as a group.
Hide | Conceals the window from the user.
Show | Displays the window to the user.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockedWindow.Close Method

Destroys the window.

public abstract void Close();

Implements

IWindow.Close

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockedWindow.Dock Method

Docks the window within the main window.

public abstract void Dock();

Implements

IWindow.Dock

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockedWindow.Float Method

Displays the window as a floating window.

public abstract void Float();

Implements

IWindow.Float

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockedWindow.GroupWith Method

Arrange docked windows together as a group.

public abstract void GroupWith(
DockedWindow dockedWindow
);

Parameters

dockedWindow

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockedWindow.Hide Method

Conceals the window from the user.

public abstract void Hide();

Implements

IWindow.Hide

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockedWindow.Show Method

Displays the window to the user.

public abstract void Show();

Implements

IWindow.Show

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockedWindow Events

The events of the DockedWindow class are listed below. For a complete list of DockedWindow class members, see the DockedWindow Members topic.

Public Instance Events

Activated | Event which occurs when the window is activated.
Closed | Event which occurs when window is closed.
Closing | Event which occurs when window is closing.
Deactivated | Event which occurs when the window is deactivated.
Reparented | Event which occurs when the window is reparented.

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockedWindow.Activated Event

Event which occurs when the window is activated.

public event EventHandler Activated;

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockedWindow.Closed Event

Event which occurs when window is closed.

public event EventHandler Closed;

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockedWindow.Closing Event

Event which occurs when window is closing.

public event CancelEventHandler Closing;

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockedWindow.Deactivated Event

Event which occurs when the window is deactivated.

public event EventHandler Deactivated;

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockedWindow.Reparented Event

Event which occurs when the window is reparented.

public event EventHandler Reparented;

See Also

DockedWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DockGroupStyle Enumeration

Enumeration of styles for group docked windows.

public enum DockGroupStyle

Members

Member Name | Description
HorizontalSplit | The child panes are split horizontally.
SlidingGroup | The panes appear as headers in an outlook group bar style interface.
TabGroup | The panes are displayed as tabs items in a tab group.
VerticalSplit | The child panes are split vertically.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


DragDropDirector Class

A class to help direct drag-drop events.

For a list of all members of this type, see DragDropDirector Members.

System.Object
Aveva.ApplicationFramework.Presentation.DragDropDirector

public abstract class DragDropDirector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

DragDropDirector Members | Aveva.ApplicationFramework.Presentation Namespace


DragDropDirector Members

DragDropDirector overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RegisterDropTarget | Registers a new DropTarget with the DragDropDirector.
ToString (inherited from Object) | Returns a String that represents the current Object.
UnregisterDropTarget | Unregisters a DropTarget from the DragDropDirector.

Public Instance Events

DropTargetRegistered | Occurs when a new DropTarget is registered with the DragDropDirector.
DropTargetUnregistered | Occurs when a DropTarget is unregistered from the DragDropDirector.

See Also

DragDropDirector Class | Aveva.ApplicationFramework.Presentation Namespace


DragDropDirector Methods

The methods of the DragDropDirector class are listed below. For a complete list of DragDropDirector class members, see the DragDropDirector Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RegisterDropTarget | Registers a new DropTarget with the DragDropDirector.
ToString (inherited from Object) | Returns a String that represents the current Object.
UnregisterDropTarget | Unregisters a DropTarget from the DragDropDirector.

See Also

DragDropDirector Class | Aveva.ApplicationFramework.Presentation Namespace


DragDropDirector.RegisterDropTarget Method

Registers a new DropTarget with the DragDropDirector.

public abstract DropTarget RegisterDropTarget(
string targetType
);

Parameters

targetType

Return Value

See Also

DragDropDirector Class | Aveva.ApplicationFramework.Presentation Namespace


DragDropDirector.UnregisterDropTarget Method

Unregisters a DropTarget from the DragDropDirector.

public abstract void UnregisterDropTarget(
DropTarget target
);

Parameters

target

See Also

DragDropDirector Class | Aveva.ApplicationFramework.Presentation Namespace


DragDropDirector Events

The events of the DragDropDirector class are listed below. For a complete list of DragDropDirector class members, see the DragDropDirector Members topic.

Public Instance Events

DropTargetRegistered | Occurs when a new DropTarget is registered with the DragDropDirector.
DropTargetUnregistered | Occurs when a DropTarget is unregistered from the DragDropDirector.

See Also

DragDropDirector Class | Aveva.ApplicationFramework.Presentation Namespace


DragDropDirector.DropTargetRegistered Event

Occurs when a new DropTarget is registered with the DragDropDirector.

public event DropTargetEventHandler DropTargetRegistered;

See Also

DragDropDirector Class | Aveva.ApplicationFramework.Presentation Namespace


DragDropDirector.DropTargetUnregistered Event

Occurs when a DropTarget is unregistered from the DragDropDirector.

public event DropTargetEventHandler DropTargetUnregistered;

See Also

DragDropDirector Class | Aveva.ApplicationFramework.Presentation Namespace


DropDownArrowStyle Enumeration

Enumerator used to specify the style used to draw a popup tool's dropdown arrow. Also determines which part of the tool should be clicked to drop down the tool.

public enum DropDownArrowStyle

Members

Member Name | Description
Default | The tool is displayed in its default style.
None | No dropdown arrow is displayed.
Segmented | A standard downward-pointing dropdown arrow is displayed to the right of the tool's image and/or text in a separate boxed-off area when on a toolbar and a standard right-pointing arrow with a dividing line to the left of it is displayed when on a menu. Clicking on the arrow drops down the tool. Clicking on the image and/or text area fires the ToolClick event.
SegmentedStateButton | A standard downward-pointing dropdown arrow is displayed to the right of the tool's image and/or text in a separate boxed-off area when on a toolbar and a standard right-pointing arrow with a dividing line to the left of it is displayed when on a menu. Clicking on the arrow drops down the tool. Clicking on the image and/or text area fires the ToolClick event and toggles the Checked state.
Standard | A standard downward-pointing dropdown arrow is displayed to the right of the tool's image and/or text when on a toolbar, and a standard right-pointing arrow is displayed when on a menu.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


DropTarget Class

A class to represent a DragDropTarget.

For a list of all members of this type, see DropTarget Members.

System.Object
Aveva.ApplicationFramework.Presentation.DropTarget

public abstract class DropTarget

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

DropTarget Members | Aveva.ApplicationFramework.Presentation Namespace


DropTarget Members

DropTarget overview

Public Instance Properties

DropTargetType Gets the DropTarget type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RaiseDragDrop | Raise a DragDrop event for this DropTarget.
RaiseDragEnter | Raise a DragEnter event for this DropTarget.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DragDrop | Occurs when an object is droopped onto the DropTargets.
DragEnter | Occurs when an object is dragged into the DropTargets bounds.

See Also

DropTarget Class | Aveva.ApplicationFramework.Presentation Namespace


DropTarget Properties

The properties of the DropTarget class are listed below. For a complete list of DropTarget class members, see the DropTarget Members topic.

Public Instance Properties

DropTargetType Gets the DropTarget type.

See Also

DropTarget Class | Aveva.ApplicationFramework.Presentation Namespace


DropTargetType Property

Common Application Framework

DropTarget.DropTargetType Property

Gets the DropTarget type.

public abstract string DropTargetType {get;}

See Also

DropTarget Class | Aveva.ApplicationFramework.Presentation Namespace


DropTarget Methods

The methods of the DropTarget class are listed below. For a complete list of DropTarget class members, see the DropTarget Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RaiseDragDrop | Raise a DragDrop event for this DropTarget.
RaiseDragEnter | Raise a DragEnter event for this DropTarget.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DropTarget Class | Aveva.ApplicationFramework.Presentation Namespace


DropTarget.RaiseDragDrop Method

Raise a DragDrop event for this DropTarget.

public abstract void RaiseDragDrop(
DropTargetEventArgs args
);

Parameters

args
Event arguments

See Also

DropTarget Class | Aveva.ApplicationFramework.Presentation Namespace


DropTarget.RaiseDragEnter Method

Raise a DragEnter event for this DropTarget.

public abstract void RaiseDragEnter(
DropTargetEventArgs args
);

Parameters

args
Event arguments

See Also

DropTarget Class | Aveva.ApplicationFramework.Presentation Namespace


DropTarget Events

The events of the DropTarget class are listed below. For a complete list of DropTarget class members, see the DropTarget Members topic.

Public Instance Events

DragDrop | Occurs when an object is droopped onto the DropTargets.
DragEnter | Occurs when an object is dragged into the DropTargets bounds.

See Also

DropTarget Class | Aveva.ApplicationFramework.Presentation Namespace


DropTarget.DragDrop Event

Occurs when an object is droopped onto the DropTargets.

public event DropTargetEventHandler DragDrop;

See Also

DropTarget Class | Aveva.ApplicationFramework.Presentation Namespace


DropTarget.DragEnter Event

Occurs when an object is dragged into the DropTargets bounds.

public event DropTargetEventHandler DragEnter;

See Also

DropTarget Class | Aveva.ApplicationFramework.Presentation Namespace


DropTargetEventArgs Class

A class to provide information to for drop-drop events.

For a list of all members of this type, see DropTargetEventArgs Members.

System.Object
System.EventArgs
Aveva.ApplicationFramework.Presentation.DropTargetEventArgs

public class DropTargetEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

DropTargetEventArgs Members | Aveva.ApplicationFramework.Presentation Namespace


DropTargetEventArgs Members

DropTargetEventArgs overview

Public Instance Constructors

DropTargetEventArgs Constructor Initialize a new instance of a DropTargetEventArgs class

Public Instance Fields

Data | Data object used to encapslate the object being dropped
DragDropEffect | The target drop effect in a drag-and-drop operation.
DragEventArgs | The windows DragEventArgs object
IsValidDropTarget | Boolean used to indicate if drop target is valid for a particular DataObject
Target | The DropTarget object

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DropTargetEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


DropTargetEventArgs Constructor

Initialize a new instance of a DropTargetEventArgs class

public DropTargetEventArgs(
DropTarget target
);

Parameters

target
The DropTaget object

See Also

DropTargetEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


DropTargetEventArgs Fields

The fields of the DropTargetEventArgs class are listed below. For a complete list of DropTargetEventArgs class members, see the DropTargetEventArgs Members topic.

Public Instance Fields

Data | Data object used to encapslate the object being dropped
DragDropEffect | The target drop effect in a drag-and-drop operation.
DragEventArgs | The windows DragEventArgs object
IsValidDropTarget | Boolean used to indicate if drop target is valid for a particular DataObject
Target | The DropTarget object

See Also

DropTargetEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


DropTargetEventArgs.Data Field

Data object used to encapslate the object being dropped

public IDataObject Data;

See Also

DropTargetEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


DropTargetEventArgs.DragDropEffect Field

The target drop effect in a drag-and-drop operation.

public DragDropEffects DragDropEffect;

See Also

DropTargetEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


DropTargetEventArgs.DragEventArgs Field

The windows DragEventArgs object

public DragEventArgs DragEventArgs;

See Also

DropTargetEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


DropTargetEventArgs.IsValidDropTarget Field

Boolean used to indicate if drop target is valid for a particular DataObject

public bool IsValidDropTarget;

See Also

DropTargetEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


DropTargetEventArgs.Target Field

The DropTarget object

public DropTarget Target;

See Also

DropTargetEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


DropTargetEventHandler Delegate

Represents the method that will handle DropTarget related events.

public delegate void DropTargetEventHandler(
object sender,
DropTargetEventArgs args
);

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


FontListTool Class

Represents a FontListTool.

For a list of all members of this type, see FontListTool Members.

System.Object
Aveva.ApplicationFramework.Presentation.FontListTool

public abstract class FontListTool : ITool

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

FontListTool Members | Aveva.ApplicationFramework.Presentation Namespace


FontListTool Members

FontListTool overview

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Command | Gets the command object which was associated with the tool when it was created.
Enabled | Gets or sets the enabled state of the tool.
FontName | Gets the FontName selected.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AfterCloseup | Occurs after the popup part of the tool is closed.
BeforePopup | Occurs before the popup part of the tool is displayed.
ToolClick | Occurs when a font is selected.
ToolValueChanged | Occurs when the value of the tool changes.

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


FontListTool Properties

The properties of the FontListTool class are listed below. For a complete list of FontListTool class members, see the FontListTool Members topic.

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Command | Gets the command object which was associated with the tool when it was created.
Enabled | Gets or sets the enabled state of the tool.
FontName | Gets the FontName selected.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Caption Property

Common Application Framework

FontListTool.Caption Property

Gets or sets the tool caption

public abstract string Caption {get; set;}

Implements

ITool.Caption

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Category Property

Common Application Framework

FontListTool.Category Property

Gets or sets the tools category

public abstract string Category {get; set;}

Implements

ITool.Category

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Command Property

Common Application Framework

FontListTool.Command Property

Gets the command object which was associated with the tool when it was created.

public abstract Command Command {get;}

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

FontListTool.Enabled Property

Gets or sets the enabled state of the tool.

public abstract bool Enabled {get; set;}

Implements

ITool.Enabled

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


FontName Property

Common Application Framework

FontListTool.FontName Property

Gets the FontName selected.

public abstract string FontName {get; set;}

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

FontListTool.Image Property

Gets or sets the image displayed on the tool

public abstract System.Drawing.Image Image {get; set;}

Implements

ITool.Image

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


IsFirstInGroup Property

Common Application Framework

FontListTool.IsFirstInGroup Property

Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.

public abstract bool IsFirstInGroup {get; set;}

Implements

ITool.IsFirstInGroup

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

FontListTool.Key Property

The Key of the tool in the RootToolsCollection

public abstract string Key {get;}

Implements

ITool.Key

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Shortcut Property

Common Application Framework

FontListTool.Shortcut Property

Gets or sets the shortcut associated with a tool.

public abstract System.Windows.Forms.Shortcut Shortcut {get; set;}

Implements

ITool.Shortcut

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

FontListTool.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a tool.

public abstract object Tag {get; set;}

Implements

ITool.Tag

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

FontListTool.Tooltip Property

Gets or sets the tools tooltip

public abstract string Tooltip {get; set;}

Implements

ITool.Tooltip

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

FontListTool.Value Property

Gets or sets the value of the tool.

public abstract object Value {get; set;}

Implements

ITool.Value

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

FontListTool.Visible Property

Gets or sets the visibility of the tool.

public abstract bool Visible {get; set;}

Implements

ITool.Visible

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


FontListTool Events

The events of the FontListTool class are listed below. For a complete list of FontListTool class members, see the FontListTool Members topic.

Public Instance Events

AfterCloseup | Occurs after the popup part of the tool is closed.
BeforePopup | Occurs before the popup part of the tool is displayed.
ToolClick | Occurs when a font is selected.
ToolValueChanged | Occurs when the value of the tool changes.

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


FontListTool.AfterCloseup Event

Occurs after the popup part of the tool is closed.

public event EventHandler AfterCloseup;

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


FontListTool.BeforePopup Event

Occurs before the popup part of the tool is displayed.

public event EventHandler BeforePopup;

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


FontListTool.ToolClick Event

Occurs when a font is selected.

public event EventHandler ToolClick;

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


FontListTool.ToolValueChanged Event

Occurs when the value of the tool changes.

public event EventHandler ToolValueChanged;

See Also

FontListTool Class | Aveva.ApplicationFramework.Presentation Namespace


HtmlHelp Class

A class to control Html Help viewer.

For a list of all members of this type, see HtmlHelp Members.

System.Object
Aveva.ApplicationFramework.Presentation.HtmlHelp

public abstract class HtmlHelp

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

HtmlHelp Members | Aveva.ApplicationFramework.Presentation Namespace


HtmlHelp Members

HtmlHelp overview

Public Static Properties

Instance Get instance of HtmlHelp

Public Instance Properties

ContextHelpIndex | Gets or sets the index file for context lookup
DefaultContextAlias | The default .chm alias to use for context lookups
HelpAboutForm | Gets or sets the form to display for help about.
HelpFile | Gets or sets the application .chm html help file
HelpOnHelpFile | Gets or sets the help file to use for help on help.
OnTop | Gets or sets whether the help window is owned by the application window an will allways be on top.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ShowHelpAbout | Shows the help about form as a modal dialog.
ShowHelpALink | Displays the help window at the topic with the given associative link.
ShowHelpContents | Displays the help window with the contents pane active.
ShowHelpContext | Overloaded. Displays the help window at the topic associated with the given contextId in the given chm file. The help topic is determined via a lookup in the context help index.
ShowHelpIndex | Displays the help window with the index pane active.
ShowHelpKeyword | Displays the help window at the topic with the given keyword.
ShowHelpOnHelp | Show a help window for help on help if a help on help file has been specified.
ShowHelpSearch | Displays the help window with the search pane active.
ShowOnlineLink | Opens a browser window for the given url.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


HtmlHelp Properties

The properties of the HtmlHelp class are listed below. For a complete list of HtmlHelp class members, see the HtmlHelp Members topic.

Public Static Properties

Instance Get instance of HtmlHelp

Public Instance Properties

ContextHelpIndex | Gets or sets the index file for context lookup
DefaultContextAlias | The default .chm alias to use for context lookups
HelpAboutForm | Gets or sets the form to display for help about.
HelpFile | Gets or sets the application .chm html help file
HelpOnHelpFile | Gets or sets the help file to use for help on help.
OnTop | Gets or sets whether the help window is owned by the application window an will allways be on top.

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


ContextHelpIndex Property

Common Application Framework

HtmlHelp.ContextHelpIndex Property

Gets or sets the index file for context lookup

public abstract string ContextHelpIndex {get; set;}

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


DefaultContextAlias Property

Common Application Framework

HtmlHelp.DefaultContextAlias Property

The default .chm alias to use for context lookups

public abstract string DefaultContextAlias {get; set;}

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


HelpAboutForm Property

Common Application Framework

HtmlHelp.HelpAboutForm Property

Gets or sets the form to display for help about.

public abstract System.Windows.Forms.Form HelpAboutForm {get; set;}

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


HelpFile Property

Common Application Framework

HtmlHelp.HelpFile Property

Gets or sets the application .chm html help file

public abstract string HelpFile {get; set;}

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


HelpOnHelpFile Property

Common Application Framework

HtmlHelp.HelpOnHelpFile Property

Gets or sets the help file to use for help on help.

public abstract string HelpOnHelpFile {get; set;}

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


Instance Property

Common Application Framework

HtmlHelp.Instance Property

Get instance of HtmlHelp

public static HtmlHelp Instance {get; set;}

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


OnTop Property

Common Application Framework

HtmlHelp.OnTop Property

Gets or sets whether the help window is owned by the application window an will allways be on top.

public abstract bool OnTop {get; set;}

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


HtmlHelp Methods

The methods of the HtmlHelp class are listed below. For a complete list of HtmlHelp class members, see the HtmlHelp Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ShowHelpAbout | Shows the help about form as a modal dialog.
ShowHelpALink | Displays the help window at the topic with the given associative link.
ShowHelpContents | Displays the help window with the contents pane active.
ShowHelpContext | Overloaded. Displays the help window at the topic associated with the given contextId in the given chm file. The help topic is determined via a lookup in the context help index.
ShowHelpIndex | Displays the help window with the index pane active.
ShowHelpKeyword | Displays the help window at the topic with the given keyword.
ShowHelpOnHelp | Show a help window for help on help if a help on help file has been specified.
ShowHelpSearch | Displays the help window with the search pane active.
ShowOnlineLink | Opens a browser window for the given url.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


HtmlHelp.ShowHelpAbout Method

Shows the help about form as a modal dialog.

public abstract int ShowHelpAbout();

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


HtmlHelp.ShowHelpALink Method

Displays the help window at the topic with the given associative link.

public abstract int ShowHelpALink(
string aLink
);

Parameters

aLink

Return Value

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


HtmlHelp.ShowHelpContents Method

Displays the help window with the contents pane active.

public abstract int ShowHelpContents();

Return Value

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


ShowHelpContext Method

Common Application Framework

HtmlHelp.ShowHelpContext Method

Displays the help window at the topic associated with the given contextId. The help topic is determined via a lookup in the context help index.

Overload List

Displays the help window at the topic associated with the given contextId. The help topic is determined via a lookup in the context help index.

public abstract int ShowHelpContext(string);

Displays the help window at the topic associated with the given contextId in the given chm file. The help topic is determined via a lookup in the context help index.

public abstract int ShowHelpContext(string,string);

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


HtmlHelp.ShowHelpContext Method (String)

Displays the help window at the topic associated with the given contextId. The help topic is determined via a lookup in the context help index.

public abstract int ShowHelpContext(
string contextId
);

Parameters

contextId

Return Value

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace | HtmlHelp.ShowHelpContext Overload List


HtmlHelp.ShowHelpContext Method (String, String)

Displays the help window at the topic associated with the given contextId in the given chm file. The help topic is determined via a lookup in the context help index.

public abstract int ShowHelpContext(
string contextId,
string chmAlias
);

Parameters

contextId
chmAlias

Return Value

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace | HtmlHelp.ShowHelpContext Overload List


HtmlHelp.ShowHelpIndex Method

Displays the help window with the index pane active.

public abstract int ShowHelpIndex();

Return Value

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


HtmlHelp.ShowHelpKeyword Method

Displays the help window at the topic with the given keyword.

public abstract int ShowHelpKeyword(
string keyword
);

Parameters

keyword

Return Value

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


HtmlHelp.ShowHelpOnHelp Method

Show a help window for help on help if a help on help file has been specified.

public abstract int ShowHelpOnHelp();

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


HtmlHelp.ShowHelpSearch Method

Displays the help window with the search pane active.

public abstract int ShowHelpSearch();

Return Value

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


HtmlHelp.ShowOnlineLink Method

Opens a browser window for the given url.

public abstract void ShowOnlineLink(
string url
);

Parameters

url
The url that will be displayed in the browser.

See Also

HtmlHelp Class | Aveva.ApplicationFramework.Presentation Namespace


IApplicationInfo Interface

Interface use to supply application information to the framework

For a list of all members of this type, see IApplicationInfo Members.

public interface IApplicationInfo

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

IApplicationInfo Members | Aveva.ApplicationFramework.Presentation Namespace


IApplicationInfo Members

IApplicationInfo overview

Public Instance Properties

AdditionalInfoDialog | Return a form to display additional application specific information
Copyright | Return the application copyright notice
License | Return the application license information
Name | Return the Application Name
ShortName | Return the Application ShortName;
Version | Return the application version number

See Also

IApplicationInfo Interface | Aveva.ApplicationFramework.Presentation Namespace


IApplicationInfo Properties

The properties of the IApplicationInfo interface are listed below. For a complete list of IApplicationInfo interface members, see the IApplicationInfo Members topic.

Public Instance Properties

AdditionalInfoDialog | Return a form to display additional application specific information
Copyright | Return the application copyright notice
License | Return the application license information
Name | Return the Application Name
ShortName | Return the Application ShortName;
Version | Return the application version number

See Also

IApplicationInfo Interface | Aveva.ApplicationFramework.Presentation Namespace


AdditionalInfoDialog Property

Common Application Framework

IApplicationInfo.AdditionalInfoDialog Property

Return a form to display additional application specific information

System.Windows.Forms.Form AdditionalInfoDialog {get;}

See Also

IApplicationInfo Interface | Aveva.ApplicationFramework.Presentation Namespace


Copyright Property

Common Application Framework

IApplicationInfo.Copyright Property

Return the application copyright notice

string Copyright {get;}

See Also

IApplicationInfo Interface | Aveva.ApplicationFramework.Presentation Namespace


License Property

Common Application Framework

IApplicationInfo.License Property

Return the application license information

string License {get;}

See Also

IApplicationInfo Interface | Aveva.ApplicationFramework.Presentation Namespace


Name Property

Common Application Framework

IApplicationInfo.Name Property

Return the Application Name

string Name {get;}

See Also

IApplicationInfo Interface | Aveva.ApplicationFramework.Presentation Namespace


ShortName Property

Common Application Framework

IApplicationInfo.ShortName Property

Return the Application ShortName;

string ShortName {get;}

See Also

IApplicationInfo Interface | Aveva.ApplicationFramework.Presentation Namespace


Version Property

Common Application Framework

IApplicationInfo.Version Property

Return the application version number

string Version {get;}

See Also

IApplicationInfo Interface | Aveva.ApplicationFramework.Presentation Namespace


IStatusBarPanel Interface

Interface supported by Statusbar panels.

For a list of all members of this type, see IStatusBarPanel Members.

public interface IStatusBarPanel

Types that implement IStatusBarPanel

Type | Description
StatusBarTextPanel | Represents a StatusBarTextPanel.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

IStatusBarPanel Members | Aveva.ApplicationFramework.Presentation Namespace


IStatusBarPanel Members

IStatusBarPanel overview

Public Instance Properties

Enabled | Returns or sets if the panel is enabled.
Image | Returns or sets the image associated with the panel.
Key | Key for the panel.
SizingMode | Returns or sets how the panel can be sized. Fixed - The panel's size is controlled by the width. Automatic - The panel's size is based on its contents. Adjustable - The panel's base size is controlled by the width but the panel may be resized. Spring - The panel size is based on the remaining size remaining after the other visible panes have been sized.
Text | Returns or sets the text associated with the panel.
Tooltip | Returns or sets the tooltip for the panel.
Visible | Returns or sets if the panel is visible.
Width | Returns or sets the width of the panel.

Public Instance Events

PanelClick | Occurs when the panel is clicked
PanelDoubleClick | Occurs when the panel is double clicked

See Also

IStatusBarPanel Interface | Aveva.ApplicationFramework.Presentation Namespace


IStatusBarPanel Properties

The properties of the IStatusBarPanel interface are listed below. For a complete list of IStatusBarPanel interface members, see the IStatusBarPanel Members topic.

Public Instance Properties

Enabled | Returns or sets if the panel is enabled.
Image | Returns or sets the image associated with the panel.
Key | Key for the panel.
SizingMode | Returns or sets how the panel can be sized. Fixed - The panel's size is controlled by the width. Automatic - The panel's size is based on its contents. Adjustable - The panel's base size is controlled by the width but the panel may be resized. Spring - The panel size is based on the remaining size remaining after the other visible panes have been sized.
Text | Returns or sets the text associated with the panel.
Tooltip | Returns or sets the tooltip for the panel.
Visible | Returns or sets if the panel is visible.
Width | Returns or sets the width of the panel.

See Also

IStatusBarPanel Interface | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

IStatusBarPanel.Enabled Property

Returns or sets if the panel is enabled.

bool Enabled {get; set;}

See Also

IStatusBarPanel Interface | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

IStatusBarPanel.Image Property

Returns or sets the image associated with the panel.

System.Drawing.Image Image {get; set;}

See Also

IStatusBarPanel Interface | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

IStatusBarPanel.Key Property

Key for the panel.

string Key {get;}

See Also

IStatusBarPanel Interface | Aveva.ApplicationFramework.Presentation Namespace


SizingMode Property

Common Application Framework

IStatusBarPanel.SizingMode Property

Returns or sets how the panel can be sized. Fixed - The panel's size is controlled by the width. Automatic - The panel's size is based on its contents. Adjustable - The panel's base size is controlled by the width but the panel may be resized. Spring - The panel size is based on the remaining size remaining after the other visible panes have been sized.

PanelSizingMode SizingMode {get; set;}

See Also

IStatusBarPanel Interface | Aveva.ApplicationFramework.Presentation Namespace


Text Property

Common Application Framework

IStatusBarPanel.Text Property

Returns or sets the text associated with the panel.

string Text {get; set;}

See Also

IStatusBarPanel Interface | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

IStatusBarPanel.Tooltip Property

Returns or sets the tooltip for the panel.

string Tooltip {get; set;}

See Also

IStatusBarPanel Interface | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

IStatusBarPanel.Visible Property

Returns or sets if the panel is visible.

bool Visible {get; set;}

See Also

IStatusBarPanel Interface | Aveva.ApplicationFramework.Presentation Namespace


Width Property

Common Application Framework

IStatusBarPanel.Width Property

Returns or sets the width of the panel.

int Width {get; set;}

See Also

IStatusBarPanel Interface | Aveva.ApplicationFramework.Presentation Namespace


IStatusBarPanel Events

The events of the IStatusBarPanel interface are listed below. For a complete list of IStatusBarPanel interface members, see the IStatusBarPanel Members topic.

Public Instance Events

PanelClick | Occurs when the panel is clicked
PanelDoubleClick | Occurs when the panel is double clicked

See Also

IStatusBarPanel Interface | Aveva.ApplicationFramework.Presentation Namespace


IStatusBarPanel.PanelClick Event

Occurs when the panel is clicked

event EventHandler PanelClick;

See Also

IStatusBarPanel Interface | Aveva.ApplicationFramework.Presentation Namespace


IStatusBarPanel.PanelDoubleClick Event

Occurs when the panel is double clicked

event EventHandler PanelDoubleClick;

See Also

IStatusBarPanel Interface | Aveva.ApplicationFramework.Presentation Namespace


ITool Interface

Interface supported by all Tool clases.

For a list of all members of this type, see ITool Members.

public interface ITool

Types that implement ITool

Type | Description
ButtonTool | Represents a ButtonToolt.
ComboBoxTool | Represents a ComboBoxTool.
ContainerTool | A tool that contains a Control.
FontListTool | Represents a FontListTool.
LabelTool | Class to represent a static Label.
ListTool | Represents a ListTool.
MdiWindowListTool | Class to respresent the special tool which displays a list of current MDI Windows.
MenuTool | Represents a MenuTool.
PopupColorPickerTool | Represents a PopupColorPicker.
PopupContainerTool | Represents a PopuplContainerTool.
StateButtonTool | Represents a StateButtonTool.
TaskPaneTool | Class used to represent a single item in a TaskPane.
TextBoxTool | Represents a TextBoxTool.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

ITool Members | Aveva.ApplicationFramework.Presentation Namespace


ITool Members

ITool overview

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

See Also

ITool Interface | Aveva.ApplicationFramework.Presentation Namespace


ITool Properties

The properties of the ITool interface are listed below. For a complete list of ITool interface members, see the ITool Members topic.

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

See Also

ITool Interface | Aveva.ApplicationFramework.Presentation Namespace


Caption Property

Common Application Framework

ITool.Caption Property

Gets or sets the tool caption

string Caption {get; set;}

See Also

ITool Interface | Aveva.ApplicationFramework.Presentation Namespace


Category Property

Common Application Framework

ITool.Category Property

Gets or sets the tools category

string Category {get; set;}

See Also

ITool Interface | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

ITool.Enabled Property

Gets or sets the enabled state of the tool.

bool Enabled {get; set;}

See Also

ITool Interface | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

ITool.Image Property

Gets or sets the image displayed on the tool

System.Drawing.Image Image {get; set;}

See Also

ITool Interface | Aveva.ApplicationFramework.Presentation Namespace


IsFirstInGroup Property

Common Application Framework

ITool.IsFirstInGroup Property

Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.

bool IsFirstInGroup {get; set;}

See Also

ITool Interface | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

ITool.Key Property

The Key of the tool in the RootToolsCollection

string Key {get;}

See Also

ITool Interface | Aveva.ApplicationFramework.Presentation Namespace


Shortcut Property

Common Application Framework

ITool.Shortcut Property

Gets or sets the shortcut associated with a tool.

System.Windows.Forms.Shortcut Shortcut {get; set;}

See Also

ITool Interface | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

ITool.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a tool.

object Tag {get; set;}

See Also

ITool Interface | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

ITool.Tooltip Property

Gets or sets the tools tooltip

string Tooltip {get; set;}

See Also

ITool Interface | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

ITool.Value Property

Gets or sets the value of the tool.

object Value {get; set;}

See Also

ITool Interface | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

ITool.Visible Property

Gets or sets the visibility of the tool.

bool Visible {get; set;}

See Also

ITool Interface | Aveva.ApplicationFramework.Presentation Namespace


IWindow Interface

Interface supported by supported window types(MDI, Docked).

For a list of all members of this type, see IWindow Members.

public interface IWindow

Types that implement IWindow

Type | Description
DockedWindow | Class to represent a DockedWindow.
MdiWindow | Represents an MDI style window or dialog box.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

IWindow Members | Aveva.ApplicationFramework.Presentation Namespace


IWindow Members

IWindow overview

Public Instance Properties

Control | Gets the control displayed in the window.
Enabled | Gets or sets whether the window is enabled.
Floatable | Gets or sets whether the window is floatable.
Height | Gets or sets the height of the window.
HelpALink | Gets or sets a help link associated with the window.
HelpContextId | Gets or sets the help context id associated with the window.
IsFloating | Gets the floating state of a window.
Key | Gets the Key of the window in the WindowsCollection.
MaximumSize | Get or sets the maximum size of the window.
MinimumSize | Get or sets the minimum size of the window.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a window.
Title | Gets or sets the title of the window.
Visible | Gets or sets the visible state of the window.
Width | Gets or sets the width of the window.

Public Instance Methods

Close | Destroys the window.
Dock | Docks the window within the main window.
Float | Displays the window as a floating window.
Hide | Conceals the window from the user.
Show | Displays the window to the user.

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


IWindow Properties

The properties of the IWindow interface are listed below. For a complete list of IWindow interface members, see the IWindow Members topic.

Public Instance Properties

Control | Gets the control displayed in the window.
Enabled | Gets or sets whether the window is enabled.
Floatable | Gets or sets whether the window is floatable.
Height | Gets or sets the height of the window.
HelpALink | Gets or sets a help link associated with the window.
HelpContextId | Gets or sets the help context id associated with the window.
IsFloating | Gets the floating state of a window.
Key | Gets the Key of the window in the WindowsCollection.
MaximumSize | Get or sets the maximum size of the window.
MinimumSize | Get or sets the minimum size of the window.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a window.
Title | Gets or sets the title of the window.
Visible | Gets or sets the visible state of the window.
Width | Gets or sets the width of the window.

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


Control Property

Common Application Framework

IWindow.Control Property

Gets the control displayed in the window.

System.Windows.Forms.Control Control {get;}

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

IWindow.Enabled Property

Gets or sets whether the window is enabled.

bool Enabled {get; set;}

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


Floatable Property

Common Application Framework

IWindow.Floatable Property

Gets or sets whether the window is floatable.

bool Floatable {get; set;}

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


Height Property

Common Application Framework

IWindow.Height Property

Gets or sets the height of the window.

int Height {get; set;}

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


HelpALink Property

Common Application Framework

IWindow.HelpALink Property

Gets or sets a help link associated with the window.

string HelpALink {get; set;}

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


HelpContextId Property

Common Application Framework

IWindow.HelpContextId Property

Gets or sets the help context id associated with the window.

string HelpContextId {get; set;}

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


IsFloating Property

Common Application Framework

IWindow.IsFloating Property

Gets the floating state of a window.

bool IsFloating {get;}

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

IWindow.Key Property

Gets the Key of the window in the WindowsCollection.

string Key {get;}

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


MaximumSize Property

Common Application Framework

IWindow.MaximumSize Property

Get or sets the maximum size of the window.

System.Drawing.Size MaximumSize {get; set;}

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


MinimumSize Property

Common Application Framework

IWindow.MinimumSize Property

Get or sets the minimum size of the window.

System.Drawing.Size MinimumSize {get; set;}

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

IWindow.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a window.

object Tag {get; set;}

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


Title Property

Common Application Framework

IWindow.Title Property

Gets or sets the title of the window.

string Title {get; set;}

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

IWindow.Visible Property

Gets or sets the visible state of the window.

bool Visible {get; set;}

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


Width Property

Common Application Framework

IWindow.Width Property

Gets or sets the width of the window.

int Width {get; set;}

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


IWindow Methods

The methods of the IWindow interface are listed below. For a complete list of IWindow interface members, see the IWindow Members topic.

Public Instance Methods

Close | Destroys the window.
Dock | Docks the window within the main window.
Float | Displays the window as a floating window.
Hide | Conceals the window from the user.
Show | Displays the window to the user.

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


IWindow.Close Method

Destroys the window.

void Close();

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


IWindow.Dock Method

Docks the window within the main window.

void Dock();

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


IWindow.Float Method

Displays the window as a floating window.

void Float();

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


IWindow.Hide Method

Conceals the window from the user.

void Hide();

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


IWindow.Show Method

Displays the window to the user.

void Show();

See Also

IWindow Interface | Aveva.ApplicationFramework.Presentation Namespace


LabelTool Class

Class to represent a static Label.

For a list of all members of this type, see LabelTool Members.

System.Object
Aveva.ApplicationFramework.Presentation.LabelTool

public abstract class LabelTool : ITool

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

LabelTool Members | Aveva.ApplicationFramework.Presentation Namespace


LabelTool Members

LabelTool overview

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.
Width | Gets or sets the width of the tool.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LabelTool Class | Aveva.ApplicationFramework.Presentation Namespace


LabelTool Properties

The properties of the LabelTool class are listed below. For a complete list of LabelTool class members, see the LabelTool Members topic.

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.
Width | Gets or sets the width of the tool.

See Also

LabelTool Class | Aveva.ApplicationFramework.Presentation Namespace


Caption Property

Common Application Framework

LabelTool.Caption Property

Gets or sets the tool caption

public abstract string Caption {get; set;}

Implements

ITool.Caption

See Also

LabelTool Class | Aveva.ApplicationFramework.Presentation Namespace


Category Property

Common Application Framework

LabelTool.Category Property

Gets or sets the tools category

public abstract string Category {get; set;}

Implements

ITool.Category

See Also

LabelTool Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

LabelTool.Enabled Property

Gets or sets the enabled state of the tool.

public abstract bool Enabled {get; set;}

Implements

ITool.Enabled

See Also

LabelTool Class | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

LabelTool.Image Property

Gets or sets the image displayed on the tool

public abstract System.Drawing.Image Image {get; set;}

Implements

ITool.Image

See Also

LabelTool Class | Aveva.ApplicationFramework.Presentation Namespace


IsFirstInGroup Property

Common Application Framework

LabelTool.IsFirstInGroup Property

Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.

public abstract bool IsFirstInGroup {get; set;}

Implements

ITool.IsFirstInGroup

See Also

LabelTool Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

LabelTool.Key Property

The Key of the tool in the RootToolsCollection

public abstract string Key {get;}

Implements

ITool.Key

See Also

LabelTool Class | Aveva.ApplicationFramework.Presentation Namespace


Shortcut Property

Common Application Framework

LabelTool.Shortcut Property

Gets or sets the shortcut associated with a tool.

public abstract System.Windows.Forms.Shortcut Shortcut {get; set;}

Implements

ITool.Shortcut

See Also

LabelTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

LabelTool.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a tool.

public abstract object Tag {get; set;}

Implements

ITool.Tag

See Also

LabelTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

LabelTool.Tooltip Property

Gets or sets the tools tooltip

public abstract string Tooltip {get; set;}

Implements

ITool.Tooltip

See Also

LabelTool Class | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

LabelTool.Value Property

Gets or sets the value of the tool.

public abstract object Value {get; set;}

Implements

ITool.Value

See Also

LabelTool Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

LabelTool.Visible Property

Gets or sets the visibility of the tool.

public abstract bool Visible {get; set;}

Implements

ITool.Visible

See Also

LabelTool Class | Aveva.ApplicationFramework.Presentation Namespace


Width Property

Common Application Framework

LabelTool.Width Property

Gets or sets the width of the tool.

public abstract int Width {get; set;}

See Also

LabelTool Class | Aveva.ApplicationFramework.Presentation Namespace


ListTool Class

Represents a ListTool.

For a list of all members of this type, see ListTool Members.

System.Object
Aveva.ApplicationFramework.Presentation.ListTool

public abstract class ListTool : ITool

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

ListTool Members | Aveva.ApplicationFramework.Presentation Namespace


ListTool Members

ListTool overview

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Command | Gets the command object which was associated with the tool when it was created.
DisplayCheckmark | Returns or sets whether a checkmark should be displayed next to the selected ListToolItem.
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
SelectedItemIndex | Returns the index of the currently selected ListToolItem.
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
ValueList | Gets the ValueList object associated with the ComboBoxTool.
Visible | Gets or sets the visibility of the tool.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

BeforePopup | Occurs before the menu containing the ListTool is displayed
ToolClick | Occurs when the ButtonTool is clicked.

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


ListTool Properties

The properties of the ListTool class are listed below. For a complete list of ListTool class members, see the ListTool Members topic.

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Command | Gets the command object which was associated with the tool when it was created.
DisplayCheckmark | Returns or sets whether a checkmark should be displayed next to the selected ListToolItem.
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
SelectedItemIndex | Returns the index of the currently selected ListToolItem.
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
ValueList | Gets the ValueList object associated with the ComboBoxTool.
Visible | Gets or sets the visibility of the tool.

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Caption Property

Common Application Framework

ListTool.Caption Property

Gets or sets the tool caption

public abstract string Caption {get; set;}

Implements

ITool.Caption

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Category Property

Common Application Framework

ListTool.Category Property

Gets or sets the tools category

public abstract string Category {get; set;}

Implements

ITool.Category

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Command Property

Common Application Framework

ListTool.Command Property

Gets the command object which was associated with the tool when it was created.

public abstract Command Command {get;}

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


DisplayCheckmark Property

Common Application Framework

ListTool.DisplayCheckmark Property

Returns or sets whether a checkmark should be displayed next to the selected ListToolItem.

public abstract bool DisplayCheckmark {get; set;}

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

ListTool.Enabled Property

Gets or sets the enabled state of the tool.

public abstract bool Enabled {get; set;}

Implements

ITool.Enabled

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

ListTool.Image Property

Gets or sets the image displayed on the tool

public abstract System.Drawing.Image Image {get; set;}

Implements

ITool.Image

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


IsFirstInGroup Property

Common Application Framework

ListTool.IsFirstInGroup Property

Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.

public abstract bool IsFirstInGroup {get; set;}

Implements

ITool.IsFirstInGroup

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

ListTool.Key Property

The Key of the tool in the RootToolsCollection

public abstract string Key {get;}

Implements

ITool.Key

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


SelectedItemIndex Property

Common Application Framework

ListTool.SelectedItemIndex Property

Returns the index of the currently selected ListToolItem.

public abstract int SelectedItemIndex {get;}

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Shortcut Property

Common Application Framework

ListTool.Shortcut Property

Gets or sets the shortcut associated with a tool.

public abstract System.Windows.Forms.Shortcut Shortcut {get; set;}

Implements

ITool.Shortcut

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

ListTool.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a tool.

public abstract object Tag {get; set;}

Implements

ITool.Tag

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

ListTool.Tooltip Property

Gets or sets the tools tooltip

public abstract string Tooltip {get; set;}

Implements

ITool.Tooltip

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

ListTool.Value Property

Gets or sets the value of the tool.

public abstract object Value {get; set;}

Implements

ITool.Value

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


ValueList Property

Common Application Framework

ListTool.ValueList Property

Gets the ValueList object associated with the ComboBoxTool.

public abstract ValueList ValueList {get;}

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

ListTool.Visible Property

Gets or sets the visibility of the tool.

public abstract bool Visible {get; set;}

Implements

ITool.Visible

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


ListTool Events

The events of the ListTool class are listed below. For a complete list of ListTool class members, see the ListTool Members topic.

Public Instance Events

BeforePopup | Occurs before the menu containing the ListTool is displayed
ToolClick | Occurs when the ButtonTool is clicked.

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


ListTool.BeforePopup Event

Occurs before the menu containing the ListTool is displayed

public event EventHandler BeforePopup;

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


ListTool.ToolClick Event

Occurs when the ButtonTool is clicked.

public event EventHandler ToolClick;

See Also

ListTool Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow Class

Represents an MDI style window or dialog box.

For a list of all members of this type, see MdiWindow Members.

System.Object
Aveva.ApplicationFramework.Presentation.MdiWindow

public abstract class MdiWindow : IWindow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

MdiWindow Members | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow Members

MdiWindow overview

Public Instance Properties

CommandBarManager | Gets the CommandBarManager for this Mdi window.
Control | Gets the control displayed in the window.
DestroyOnClose | Controls the default behaviour of destorying the window on close. If this is set to false then the default behaviour will be to hide the window.
Enabled | Gets or sets whether the window is enabled.
Floatable | Gets or sets whether the window is floatable.
Form | Returns the underlying Form for the MdiWindow
Height | Gets or sets the height of the window.
HelpALink | Gets or sets a help link associated with the window.
HelpContextId | Gets or sets the help context id associated with the window.
IsFloating | Gets the floating state of a window.
Key | Gets the Key of the window in the WindowsCollection.
Maximized | Gets or sets the maximized state of the window.
MaximumSize | Get or sets the maximum size of the window.
MinimumSize | Get or sets the minimum size of the window.
Resizeable | Gets or sets whether the window is resizeable.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a window.
Title | Gets or sets the title of the window.
Visible | Gets or sets the visible state of the window.
Width | Gets or sets the width of the window.

Public Instance Methods

Close | Destroys the window.
Dock | Docks the window within the main window.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Float | Displays the window as a floating window.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide | Conceals the window from the user.
Show | Displays the window to the user.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Activated | Occurs when the window is activated.
Closed | Event which occurs when window is closed.
Closing | Occurs when this window is closing.
Deactivated | Occurs then the window is deactivated.
Reparented | Occurs when the window is reparented.
Resized | Occurs when the window is resized.

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow Properties

The properties of the MdiWindow class are listed below. For a complete list of MdiWindow class members, see the MdiWindow Members topic.

Public Instance Properties

CommandBarManager | Gets the CommandBarManager for this Mdi window.
Control | Gets the control displayed in the window.
DestroyOnClose | Controls the default behaviour of destorying the window on close. If this is set to false then the default behaviour will be to hide the window.
Enabled | Gets or sets whether the window is enabled.
Floatable | Gets or sets whether the window is floatable.
Form | Returns the underlying Form for the MdiWindow
Height | Gets or sets the height of the window.
HelpALink | Gets or sets a help link associated with the window.
HelpContextId | Gets or sets the help context id associated with the window.
IsFloating | Gets the floating state of a window.
Key | Gets the Key of the window in the WindowsCollection.
Maximized | Gets or sets the maximized state of the window.
MaximumSize | Get or sets the maximum size of the window.
MinimumSize | Get or sets the minimum size of the window.
Resizeable | Gets or sets whether the window is resizeable.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a window.
Title | Gets or sets the title of the window.
Visible | Gets or sets the visible state of the window.
Width | Gets or sets the width of the window.

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


CommandBarManager Property

Common Application Framework

MdiWindow.CommandBarManager Property

Gets the CommandBarManager for this Mdi window.

public abstract CommandBarManager CommandBarManager {get;}

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Control Property

Common Application Framework

MdiWindow.Control Property

Gets the control displayed in the window.

public abstract System.Windows.Forms.Control Control {get;}

Implements

IWindow.Control

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


DestroyOnClose Property

Common Application Framework

MdiWindow.DestroyOnClose Property

Controls the default behaviour of destorying the window on close. If this is set to false then the default behaviour will be to hide the window.

public abstract bool DestroyOnClose {get; set;}

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

MdiWindow.Enabled Property

Gets or sets whether the window is enabled.

public abstract bool Enabled {get; set;}

Implements

IWindow.Enabled

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Floatable Property

Common Application Framework

MdiWindow.Floatable Property

Gets or sets whether the window is floatable.

public abstract bool Floatable {get; set;}

Implements

IWindow.Floatable

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Form Property

Common Application Framework

MdiWindow.Form Property

Returns the underlying Form for the MdiWindow

public abstract System.Windows.Forms.Form Form {get;}

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Height Property

Common Application Framework

MdiWindow.Height Property

Gets or sets the height of the window.

public abstract int Height {get; set;}

Implements

IWindow.Height

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


HelpALink Property

Common Application Framework

MdiWindow.HelpALink Property

Gets or sets a help link associated with the window.

public abstract string HelpALink {get; set;}

Implements

IWindow.HelpALink

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


HelpContextId Property

Common Application Framework

MdiWindow.HelpContextId Property

Gets or sets the help context id associated with the window.

public abstract string HelpContextId {get; set;}

Implements

IWindow.HelpContextId

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


IsFloating Property

Common Application Framework

MdiWindow.IsFloating Property

Gets the floating state of a window.

public abstract bool IsFloating {get;}

Implements

IWindow.IsFloating

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

MdiWindow.Key Property

Gets the Key of the window in the WindowsCollection.

public abstract string Key {get;}

Implements

IWindow.Key

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Maximized Property

Common Application Framework

MdiWindow.Maximized Property

Gets or sets the maximized state of the window.

public abstract bool Maximized {get; set;}

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MaximumSize Property

Common Application Framework

MdiWindow.MaximumSize Property

Get or sets the maximum size of the window.

public abstract System.Drawing.Size MaximumSize {get; set;}

Implements

IWindow.MaximumSize

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MinimumSize Property

Common Application Framework

MdiWindow.MinimumSize Property

Get or sets the minimum size of the window.

public abstract System.Drawing.Size MinimumSize {get; set;}

Implements

IWindow.MinimumSize

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Resizeable Property

Common Application Framework

MdiWindow.Resizeable Property

Gets or sets whether the window is resizeable.

public abstract bool Resizeable {get; set;}

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

MdiWindow.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a window.

public abstract object Tag {get; set;}

Implements

IWindow.Tag

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Title Property

Common Application Framework

MdiWindow.Title Property

Gets or sets the title of the window.

public abstract string Title {get; set;}

Implements

IWindow.Title

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

MdiWindow.Visible Property

Gets or sets the visible state of the window.

public abstract bool Visible {get; set;}

Implements

IWindow.Visible

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


Width Property

Common Application Framework

MdiWindow.Width Property

Gets or sets the width of the window.

public abstract int Width {get; set;}

Implements

IWindow.Width

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow Methods

The methods of the MdiWindow class are listed below. For a complete list of MdiWindow class members, see the MdiWindow Members topic.

Public Instance Methods

Close | Destroys the window.
Dock | Docks the window within the main window.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Float | Displays the window as a floating window.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide | Conceals the window from the user.
Show | Displays the window to the user.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow.Close Method

Destroys the window.

public abstract void Close();

Implements

IWindow.Close

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow.Dock Method

Docks the window within the main window.

public abstract void Dock();

Implements

IWindow.Dock

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow.Float Method

Displays the window as a floating window.

public abstract void Float();

Implements

IWindow.Float

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow.Hide Method

Conceals the window from the user.

public abstract void Hide();

Implements

IWindow.Hide

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow.Show Method

Displays the window to the user.

public abstract void Show();

Implements

IWindow.Show

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow Events

The events of the MdiWindow class are listed below. For a complete list of MdiWindow class members, see the MdiWindow Members topic.

Public Instance Events

Activated | Occurs when the window is activated.
Closed | Event which occurs when window is closed.
Closing | Occurs when this window is closing.
Deactivated | Occurs then the window is deactivated.
Reparented | Occurs when the window is reparented.
Resized | Occurs when the window is resized.

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow.Activated Event

Occurs when the window is activated.

public event EventHandler Activated;

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow.Closed Event

Event which occurs when window is closed.

public event EventHandler Closed;

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow.Closing Event

Occurs when this window is closing.

public event CancelEventHandler Closing;

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow.Deactivated Event

Occurs then the window is deactivated.

public event EventHandler Deactivated;

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow.Reparented Event

Occurs when the window is reparented.

public event EventHandler Reparented;

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindow.Resized Event

Occurs when the window is resized.

public event EventHandler Resized;

See Also

MdiWindow Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindowListTool Class

Class to respresent the special tool which displays a list of current MDI Windows.

For a list of all members of this type, see MdiWindowListTool Members.

System.Object
Aveva.ApplicationFramework.Presentation.MdiWindowListTool

public abstract class MdiWindowListTool : ITool

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

MdiWindowListTool Members | Aveva.ApplicationFramework.Presentation Namespace


MdiWindowListTool Members

MdiWindowListTool overview

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MdiWindowListTool Class | Aveva.ApplicationFramework.Presentation Namespace


MdiWindowListTool Properties

The properties of the MdiWindowListTool class are listed below. For a complete list of MdiWindowListTool class members, see the MdiWindowListTool Members topic.

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

See Also

MdiWindowListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Caption Property

Common Application Framework

MdiWindowListTool.Caption Property

Gets or sets the tool caption

public abstract string Caption {get; set;}

Implements

ITool.Caption

See Also

MdiWindowListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Category Property

Common Application Framework

MdiWindowListTool.Category Property

Gets or sets the tools category

public abstract string Category {get; set;}

Implements

ITool.Category

See Also

MdiWindowListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

MdiWindowListTool.Enabled Property

Gets or sets the enabled state of the tool.

public abstract bool Enabled {get; set;}

Implements

ITool.Enabled

See Also

MdiWindowListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

MdiWindowListTool.Image Property

Gets or sets the image displayed on the tool

public abstract System.Drawing.Image Image {get; set;}

Implements

ITool.Image

See Also

MdiWindowListTool Class | Aveva.ApplicationFramework.Presentation Namespace


IsFirstInGroup Property

Common Application Framework

MdiWindowListTool.IsFirstInGroup Property

Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.

public abstract bool IsFirstInGroup {get; set;}

Implements

ITool.IsFirstInGroup

See Also

MdiWindowListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

MdiWindowListTool.Key Property

The Key of the tool in the RootToolsCollection

public abstract string Key {get;}

Implements

ITool.Key

See Also

MdiWindowListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Shortcut Property

Common Application Framework

MdiWindowListTool.Shortcut Property

Gets or sets the shortcut associated with a tool.

public abstract System.Windows.Forms.Shortcut Shortcut {get; set;}

Implements

ITool.Shortcut

See Also

MdiWindowListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

MdiWindowListTool.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a tool.

public abstract object Tag {get; set;}

Implements

ITool.Tag

See Also

MdiWindowListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

MdiWindowListTool.Tooltip Property

Gets or sets the tools tooltip

public abstract string Tooltip {get; set;}

Implements

ITool.Tooltip

See Also

MdiWindowListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

MdiWindowListTool.Value Property

Gets or sets the value of the tool.

public abstract object Value {get; set;}

Implements

ITool.Value

See Also

MdiWindowListTool Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

MdiWindowListTool.Visible Property

Gets or sets the visibility of the tool.

public abstract bool Visible {get; set;}

Implements

ITool.Visible

See Also

MdiWindowListTool Class | Aveva.ApplicationFramework.Presentation Namespace


MenuTool Class

Represents a MenuTool.

For a list of all members of this type, see MenuTool Members.

System.Object
Aveva.ApplicationFramework.Presentation.MenuTool

public abstract class MenuTool : ITool

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

MenuTool Members | Aveva.ApplicationFramework.Presentation Namespace


MenuTool Members

MenuTool overview

Public Instance Properties

AllowTearaway | Gets or sets whether the menu can be torn off
AutoUpdate | Gets or sets whether the Image, Tooltip and Command are automaticaly updated.
Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Checked | Gets or sets whether the tool is in the checked state.
Command | Gets the command object which was associated with the tool when it was created.
DropDownArrowStyle | Returns or sets the style of the dropdown arrow for the popup menu.
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsContextMenu | Gets or sets whether the menu is a context menu
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
OptionSetKey | Gets or sets the OptionSet key for the tool. Setting the key assigns the tool to the CommandBarManagers OptionSet which has this key.
PopupStyle | Gets or sets the popup style of the menu (Menu or CommandBar)
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tools | Gets the ToolsCollection containing the tools to display in the popup menu.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ShowPopup | Overloaded. Displays the MenuTool as a context popup with given context at the current mouse position.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AfterCloseup | Occurs after the menu is displayed
BeforePopup | Occurs before the menu is displayed
ToolClick | Occurs when the tool is clicked

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


MenuTool Properties

The properties of the MenuTool class are listed below. For a complete list of MenuTool class members, see the MenuTool Members topic.

Public Instance Properties

AllowTearaway | Gets or sets whether the menu can be torn off
AutoUpdate | Gets or sets whether the Image, Tooltip and Command are automaticaly updated.
Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Checked | Gets or sets whether the tool is in the checked state.
Command | Gets the command object which was associated with the tool when it was created.
DropDownArrowStyle | Returns or sets the style of the dropdown arrow for the popup menu.
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsContextMenu | Gets or sets whether the menu is a context menu
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
OptionSetKey | Gets or sets the OptionSet key for the tool. Setting the key assigns the tool to the CommandBarManagers OptionSet which has this key.
PopupStyle | Gets or sets the popup style of the menu (Menu or CommandBar)
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tools | Gets the ToolsCollection containing the tools to display in the popup menu.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


AllowTearaway Property

Common Application Framework

MenuTool.AllowTearaway Property

Gets or sets whether the menu can be torn off

public abstract bool AllowTearaway {get; set;}

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


AutoUpdate Property

Common Application Framework

MenuTool.AutoUpdate Property

Gets or sets whether the Image, Tooltip and Command are automaticaly updated.

public abstract bool AutoUpdate {get; set;}

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


Caption Property

Common Application Framework

MenuTool.Caption Property

Gets or sets the tool caption

public abstract string Caption {get; set;}

Implements

ITool.Caption

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


Category Property

Common Application Framework

MenuTool.Category Property

Gets or sets the tools category

public abstract string Category {get; set;}

Implements

ITool.Category

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


Checked Property

Common Application Framework

MenuTool.Checked Property

Gets or sets whether the tool is in the checked state.

public abstract bool Checked {get; set;}

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


Command Property

Common Application Framework

MenuTool.Command Property

Gets the command object which was associated with the tool when it was created.

public abstract Command Command {get;}

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


DropDownArrowStyle Property

Common Application Framework

MenuTool.DropDownArrowStyle Property

Returns or sets the style of the dropdown arrow for the popup menu.

public abstract DropDownArrowStyle DropDownArrowStyle {get; set;}

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

MenuTool.Enabled Property

Gets or sets the enabled state of the tool.

public abstract bool Enabled {get; set;}

Implements

ITool.Enabled

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

MenuTool.Image Property

Gets or sets the image displayed on the tool

public abstract System.Drawing.Image Image {get; set;}

Implements

ITool.Image

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


IsContextMenu Property

Common Application Framework

MenuTool.IsContextMenu Property

Gets or sets whether the menu is a context menu

public abstract bool IsContextMenu {get; set;}

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


IsFirstInGroup Property

Common Application Framework

MenuTool.IsFirstInGroup Property

Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.

public abstract bool IsFirstInGroup {get; set;}

Implements

ITool.IsFirstInGroup

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

MenuTool.Key Property

The Key of the tool in the RootToolsCollection

public abstract string Key {get;}

Implements

ITool.Key

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


OptionSetKey Property

Common Application Framework

MenuTool.OptionSetKey Property

Gets or sets the OptionSet key for the tool. Setting the key assigns the tool to the CommandBarManagers OptionSet which has this key.

public abstract string OptionSetKey {get; set;}

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


PopupStyle Property

Common Application Framework

MenuTool.PopupStyle Property

Gets or sets the popup style of the menu (Menu or CommandBar)

public abstract PopupStyle PopupStyle {get; set;}

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


Shortcut Property

Common Application Framework

MenuTool.Shortcut Property

Gets or sets the shortcut associated with a tool.

public abstract System.Windows.Forms.Shortcut Shortcut {get; set;}

Implements

ITool.Shortcut

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

MenuTool.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a tool.

public abstract object Tag {get; set;}

Implements

ITool.Tag

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tools Property

Common Application Framework

MenuTool.Tools Property

Gets the ToolsCollection containing the tools to display in the popup menu.

public abstract ToolsCollection Tools {get;}

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

MenuTool.Tooltip Property

Gets or sets the tools tooltip

public abstract string Tooltip {get; set;}

Implements

ITool.Tooltip

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

MenuTool.Value Property

Gets or sets the value of the tool.

public abstract object Value {get; set;}

Implements

ITool.Value

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

MenuTool.Visible Property

Gets or sets the visibility of the tool.

public abstract bool Visible {get; set;}

Implements

ITool.Visible

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


MenuTool Methods

The methods of the MenuTool class are listed below. For a complete list of MenuTool class members, see the MenuTool Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ShowPopup | Overloaded. Displays the MenuTool as a context popup with given context at the current mouse position.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


ShowPopup Method

Common Application Framework

MenuTool.ShowPopup Method

Displays the MenuTool as a context popup at the current mouse position.

Overload List

Displays the MenuTool as a context popup at the current mouse position.

public abstract void ShowPopup();

Displays the MenuTool as a context popup with given context at the current mouse position.

public abstract void ShowPopup(string);

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


MenuTool.ShowPopup Method ()

Displays the MenuTool as a context popup at the current mouse position.

public abstract void ShowPopup();

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace | MenuTool.ShowPopup Overload List


MenuTool.ShowPopup Method (String)

Displays the MenuTool as a context popup with given context at the current mouse position.

public abstract void ShowPopup(
string context
);

Parameters

context

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace | MenuTool.ShowPopup Overload List


MenuTool Events

The events of the MenuTool class are listed below. For a complete list of MenuTool class members, see the MenuTool Members topic.

Public Instance Events

AfterCloseup | Occurs after the menu is displayed
BeforePopup | Occurs before the menu is displayed
ToolClick | Occurs when the tool is clicked

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


MenuTool.AfterCloseup Event

Occurs after the menu is displayed

public event EventHandler AfterCloseup;

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


MenuTool.BeforePopup Event

Occurs before the menu is displayed

public event EventHandler BeforePopup;

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


MenuTool.ToolClick Event

Occurs when the tool is clicked

public event EventHandler ToolClick;

See Also

MenuTool Class | Aveva.ApplicationFramework.Presentation Namespace


NavigationButtonStyle Enumeration

Enumeration used to indicate how the navigation buttons are used to navigate the items in a TaskBar

public enum NavigationButtonStyle

Members

Member Name | Description
Default |
History | The Back and Forward buttons will be used to navigate through the items based on the order in which the items have been selected.
Linear | The Back and Forward buttons will be used to navigate through the items based on their order in the Tools collection.
None | The Back and Forward buttons will not be displayed.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


PanelSizingMode Enumeration

Enumeration of the statusbar panel sizing options.

public enum PanelSizingMode

Members

Member Name | Description
Adjustable | The panel's base size is controlled by the width but the panel may be resized.
Automatic | The panel's size is based on its contents.
Fixed | The panel's size is controlled by the width.
Spring | The panel size is based on the remaining size remaining after the other visible panes have been sized.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


PopupColorPickerTool Class

Represents a PopupColorPicker.

For a list of all members of this type, see PopupColorPickerTool Members.

System.Object
Aveva.ApplicationFramework.Presentation.PopupColorPickerTool

public abstract class PopupColorPickerTool : ITool

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

PopupColorPickerTool Members | Aveva.ApplicationFramework.Presentation Namespace


PopupColorPickerTool Members

PopupColorPickerTool overview

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Checked | Gets or sets whether the tool is in the checked state.
Command | Gets the command object which was associated with the tool when it was created.
DropDownArrowStyle | Returns or sets the style of the dropdown arrow for the popup menu.
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
ReplaceableColor | Returns or sets the color in the PopupColorPickerTool's image that will be replaced with the SelectedColor value. Default is Magenta.
SelectedColor | Returns/sets the selected color in the PopupColorPickerTool.
Shortcut | Gets or sets the shortcut associated with a tool.
ShowAutomaticColor | Returns or sets whether a button representing the color Color.WindowText is displayed in the dropdown.
ShowTransparentColor | Returns or sets whether a button representing the color Color.Transparent is displayed in the dropdown.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ToolClick | Occurs when the PopupColorPickerTool is clicked.
ToolValueChanged | Occurs when the value of the tool changes.

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


PopupColorPickerTool Properties

The properties of the PopupColorPickerTool class are listed below. For a complete list of PopupColorPickerTool class members, see the PopupColorPickerTool Members topic.

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Checked | Gets or sets whether the tool is in the checked state.
Command | Gets the command object which was associated with the tool when it was created.
DropDownArrowStyle | Returns or sets the style of the dropdown arrow for the popup menu.
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
ReplaceableColor | Returns or sets the color in the PopupColorPickerTool's image that will be replaced with the SelectedColor value. Default is Magenta.
SelectedColor | Returns/sets the selected color in the PopupColorPickerTool.
Shortcut | Gets or sets the shortcut associated with a tool.
ShowAutomaticColor | Returns or sets whether a button representing the color Color.WindowText is displayed in the dropdown.
ShowTransparentColor | Returns or sets whether a button representing the color Color.Transparent is displayed in the dropdown.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Caption Property

Common Application Framework

PopupColorPickerTool.Caption Property

Gets or sets the tool caption

public abstract string Caption {get; set;}

Implements

ITool.Caption

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Category Property

Common Application Framework

PopupColorPickerTool.Category Property

Gets or sets the tools category

public abstract string Category {get; set;}

Implements

ITool.Category

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Checked Property

Common Application Framework

PopupColorPickerTool.Checked Property

Gets or sets whether the tool is in the checked state.

public abstract bool Checked {get; set;}

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Command Property

Common Application Framework

PopupColorPickerTool.Command Property

Gets the command object which was associated with the tool when it was created.

public abstract Command Command {get;}

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


DropDownArrowStyle Property

Common Application Framework

PopupColorPickerTool.DropDownArrowStyle Property

Returns or sets the style of the dropdown arrow for the popup menu.

public abstract DropDownArrowStyle DropDownArrowStyle {get; set;}

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

PopupColorPickerTool.Enabled Property

Gets or sets the enabled state of the tool.

public abstract bool Enabled {get; set;}

Implements

ITool.Enabled

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

PopupColorPickerTool.Image Property

Gets or sets the image displayed on the tool

public abstract System.Drawing.Image Image {get; set;}

Implements

ITool.Image

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


IsFirstInGroup Property

Common Application Framework

PopupColorPickerTool.IsFirstInGroup Property

Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.

public abstract bool IsFirstInGroup {get; set;}

Implements

ITool.IsFirstInGroup

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

PopupColorPickerTool.Key Property

The Key of the tool in the RootToolsCollection

public abstract string Key {get;}

Implements

ITool.Key

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


ReplaceableColor Property

Common Application Framework

PopupColorPickerTool.ReplaceableColor Property

Returns or sets the color in the PopupColorPickerTool's image that will be replaced with the SelectedColor value. Default is Magenta.

public abstract System.Drawing.Color ReplaceableColor {get; set;}

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


SelectedColor Property

Common Application Framework

PopupColorPickerTool.SelectedColor Property

Returns/sets the selected color in the PopupColorPickerTool.

public abstract System.Drawing.Color SelectedColor {get; set;}

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Shortcut Property

Common Application Framework

PopupColorPickerTool.Shortcut Property

Gets or sets the shortcut associated with a tool.

public abstract System.Windows.Forms.Shortcut Shortcut {get; set;}

Implements

ITool.Shortcut

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


ShowAutomaticColor Property

Common Application Framework

PopupColorPickerTool.ShowAutomaticColor Property

Returns or sets whether a button representing the color Color.WindowText is displayed in the dropdown.

public abstract bool ShowAutomaticColor {get; set;}

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


ShowTransparentColor Property

Common Application Framework

PopupColorPickerTool.ShowTransparentColor Property

Returns or sets whether a button representing the color Color.Transparent is displayed in the dropdown.

public abstract bool ShowTransparentColor {get; set;}

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

PopupColorPickerTool.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a tool.

public abstract object Tag {get; set;}

Implements

ITool.Tag

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

PopupColorPickerTool.Tooltip Property

Gets or sets the tools tooltip

public abstract string Tooltip {get; set;}

Implements

ITool.Tooltip

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

PopupColorPickerTool.Value Property

Gets or sets the value of the tool.

public abstract object Value {get; set;}

Implements

ITool.Value

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

PopupColorPickerTool.Visible Property

Gets or sets the visibility of the tool.

public abstract bool Visible {get; set;}

Implements

ITool.Visible

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


PopupColorPickerTool Events

The events of the PopupColorPickerTool class are listed below. For a complete list of PopupColorPickerTool class members, see the PopupColorPickerTool Members topic.

Public Instance Events

ToolClick | Occurs when the PopupColorPickerTool is clicked.
ToolValueChanged | Occurs when the value of the tool changes.

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


PopupColorPickerTool.ToolClick Event

Occurs when the PopupColorPickerTool is clicked.

public event EventHandler ToolClick;

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


PopupColorPickerTool.ToolValueChanged Event

Occurs when the value of the tool changes.

public event EventHandler ToolValueChanged;

See Also

PopupColorPickerTool Class | Aveva.ApplicationFramework.Presentation Namespace


PopupContainerTool Class

Represents a PopuplContainerTool.

For a list of all members of this type, see PopupContainerTool Members.

System.Object
Aveva.ApplicationFramework.Presentation.PopupContainerTool

public abstract class PopupContainerTool : ITool

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

PopupContainerTool Members | Aveva.ApplicationFramework.Presentation Namespace


PopupContainerTool Members

PopupContainerTool overview

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Command | Gets the command object which was associated with the tool when it was created.
Control | Gets or sets the control to display in the PopupContainer
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

Public Instance Methods

ClosePopup | Closes the PopupContainer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ShowPopup | Shows the PopupContainer
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AfterCloseup | Occurs after the PopupContainer is displayed
BeforePopup | Occurs before the PopupContiner is displayed
ToolClick | Occurs then the tool is clicked

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


PopupContainerTool Properties

The properties of the PopupContainerTool class are listed below. For a complete list of PopupContainerTool class members, see the PopupContainerTool Members topic.

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Command | Gets the command object which was associated with the tool when it was created.
Control | Gets or sets the control to display in the PopupContainer
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Caption Property

Common Application Framework

PopupContainerTool.Caption Property

Gets or sets the tool caption

public abstract string Caption {get; set;}

Implements

ITool.Caption

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Category Property

Common Application Framework

PopupContainerTool.Category Property

Gets or sets the tools category

public abstract string Category {get; set;}

Implements

ITool.Category

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Command Property

Common Application Framework

PopupContainerTool.Command Property

Gets the command object which was associated with the tool when it was created.

public abstract Command Command {get;}

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Control Property

Common Application Framework

PopupContainerTool.Control Property

Gets or sets the control to display in the PopupContainer

public abstract System.Windows.Forms.Control Control {get; set;}

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

PopupContainerTool.Enabled Property

Gets or sets the enabled state of the tool.

public abstract bool Enabled {get; set;}

Implements

ITool.Enabled

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

PopupContainerTool.Image Property

Gets or sets the image displayed on the tool

public abstract System.Drawing.Image Image {get; set;}

Implements

ITool.Image

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


IsFirstInGroup Property

Common Application Framework

PopupContainerTool.IsFirstInGroup Property

Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.

public abstract bool IsFirstInGroup {get; set;}

Implements

ITool.IsFirstInGroup

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

PopupContainerTool.Key Property

The Key of the tool in the RootToolsCollection

public abstract string Key {get;}

Implements

ITool.Key

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Shortcut Property

Common Application Framework

PopupContainerTool.Shortcut Property

Gets or sets the shortcut associated with a tool.

public abstract System.Windows.Forms.Shortcut Shortcut {get; set;}

Implements

ITool.Shortcut

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

PopupContainerTool.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a tool.

public abstract object Tag {get; set;}

Implements

ITool.Tag

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

PopupContainerTool.Tooltip Property

Gets or sets the tools tooltip

public abstract string Tooltip {get; set;}

Implements

ITool.Tooltip

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

PopupContainerTool.Value Property

Gets or sets the value of the tool.

public abstract object Value {get; set;}

Implements

ITool.Value

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

PopupContainerTool.Visible Property

Gets or sets the visibility of the tool.

public abstract bool Visible {get; set;}

Implements

ITool.Visible

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


PopupContainerTool Methods

The methods of the PopupContainerTool class are listed below. For a complete list of PopupContainerTool class members, see the PopupContainerTool Members topic.

Public Instance Methods

ClosePopup | Closes the PopupContainer
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ShowPopup | Shows the PopupContainer
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


PopupContainerTool.ClosePopup Method

Closes the PopupContainer

public abstract void ClosePopup();

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


PopupContainerTool.ShowPopup Method

Shows the PopupContainer

public abstract void ShowPopup();

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


PopupContainerTool Events

The events of the PopupContainerTool class are listed below. For a complete list of PopupContainerTool class members, see the PopupContainerTool Members topic.

Public Instance Events

AfterCloseup | Occurs after the PopupContainer is displayed
BeforePopup | Occurs before the PopupContiner is displayed
ToolClick | Occurs then the tool is clicked

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


PopupContainerTool.AfterCloseup Event

Occurs after the PopupContainer is displayed

public event EventHandler AfterCloseup;

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


PopupContainerTool.BeforePopup Event

Occurs before the PopupContiner is displayed

public event EventHandler BeforePopup;

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


PopupContainerTool.ToolClick Event

Occurs then the tool is clicked

public event EventHandler ToolClick;

See Also

PopupContainerTool Class | Aveva.ApplicationFramework.Presentation Namespace


PopupStyle Enumeration

Enumerator used to specify the style of popup menus.

public enum PopupStyle

Members

Member Name | Description
Menu | The menu will popup showing menu items as a standard menu would show them.
CommandBar | The menu will popup showing the menu items as images only, arranged as they would be in a floating commandbar.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


ResourceManager Class

Provides convenient access to culture-specific resources at runtime.

For a list of all members of this type, see ResourceManager Members.

System.Object
Aveva.ApplicationFramework.Presentation.ResourceManager

public abstract class ResourceManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

ResourceManager Members | Aveva.ApplicationFramework.Presentation Namespace


ResourceManager Members

ResourceManager overview

Public Static Properties

Instance Get instance of resource manager

Public Instance Properties

ResourceSets Return a list of all loaded ResourceSets

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetIcon | Overloaded. Gets a resource Icon from the named resource set.
GetImage | Overloaded. Gets a resource Image from the named resource set. Uses defaultResourceId if resourceID is not found
GetObject | Overloaded. Gets a resource object from the named resource set.
GetStandardImage | Gets a standard image.
GetString | Overloaded. Gets a resource string from the named resource set.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadResourceFile | Loads the resource file with given base name.
ReleaseAllResources | Release all resource unlocking resource files
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace


ResourceManager Properties

The properties of the ResourceManager class are listed below. For a complete list of ResourceManager class members, see the ResourceManager Members topic.

Public Static Properties

Instance Get instance of resource manager

Public Instance Properties

ResourceSets Return a list of all loaded ResourceSets

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace


Instance Property

Common Application Framework

ResourceManager.Instance Property

Get instance of resource manager

public static ResourceManager Instance {get; set;}

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace


ResourceSets Property

Common Application Framework

ResourceManager.ResourceSets Property

Return a list of all loaded ResourceSets

public abstract System.Collections.Hashtable ResourceSets {get;}

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace


ResourceManager Methods

The methods of the ResourceManager class are listed below. For a complete list of ResourceManager class members, see the ResourceManager Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetIcon | Overloaded. Gets a resource Icon from the named resource set.
GetImage | Overloaded. Gets a resource Image from the named resource set. Uses defaultResourceId if resourceID is not found
GetObject | Overloaded. Gets a resource object from the named resource set.
GetStandardImage | Gets a standard image.
GetString | Overloaded. Gets a resource string from the named resource set.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadResourceFile | Loads the resource file with given base name.
ReleaseAllResources | Release all resource unlocking resource files
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace


GetIcon Method

Common Application Framework

ResourceManager.GetIcon Method

Gets a resource Icon.

Overload List

Gets a resource Icon.

public abstract Icon GetIcon(string);

Gets a resource Icon from the named resource set.

public abstract Icon GetIcon(string,string);

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace


ResourceManager.GetIcon Method (String)

Gets a resource Icon.

public abstract Icon GetIcon(
string resourceID
);

Parameters

resourceID
Resource identifier for the required icon.

Return Value

A resource Icon

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace | ResourceManager.GetIcon Overload List


ResourceManager.GetIcon Method (String, String)

Gets a resource Icon from the named resource set.

public abstract Icon GetIcon(
string resourceID,
string resourceSetName
);

Parameters

resourceID
resourceSetName

Return Value

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace | ResourceManager.GetIcon Overload List


GetImage Method

Common Application Framework

ResourceManager.GetImage Method

Gets a resource Image.

Overload List

Gets a resource Image.

public abstract Image GetImage(string);

Gets a resource Image from the named resource set.

public abstract Image GetImage(string,string);

Gets a resource Image from the named resource set. Uses defaultResourceId if resourceID is not found

public abstract Image GetImage(string,string,string);

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace


ResourceManager.GetImage Method (String)

Gets a resource Image.

public abstract Image GetImage(
string resourceID
);

Parameters

resourceID
Resource identifier for the required Image

Return Value

A resource Image

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace | ResourceManager.GetImage Overload List


ResourceManager.GetImage Method (String, String)

Gets a resource Image from the named resource set.

public abstract Image GetImage(
string resourceID,
string resourceSetName
);

Parameters

resourceID
resourceSetName

Return Value

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace | ResourceManager.GetImage Overload List


ResourceManager.GetImage Method (String, String, String)

Gets a resource Image from the named resource set. Uses defaultResourceId if resourceID is not found

public abstract Image GetImage(
string resourceID,
string resourceSetName,
string defaultResourceID
);

Parameters

resourceID
resourceSetName
defaultResourceID

Return Value

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace | ResourceManager.GetImage Overload List


GetObject Method

Common Application Framework

ResourceManager.GetObject Method

Gets a resource object.

Overload List

Gets a resource object.

public abstract object GetObject(string);

Gets a resource object from the named resource set.

public abstract object GetObject(string,string);

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace


ResourceManager.GetObject Method (String)

Gets a resource object.

public abstract object GetObject(
string resourceID
);

Parameters

resourceID
Resource identifier for the required object

Return Value

A resource object

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace | ResourceManager.GetObject Overload List


ResourceManager.GetObject Method (String, String)

Gets a resource object from the named resource set.

public abstract object GetObject(
string resourceID,
string resourceSetName
);

Parameters

resourceID
resourceSetName

Return Value

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace | ResourceManager.GetObject Overload List


ResourceManager.GetStandardImage Method

Gets a standard image.

public abstract Image GetStandardImage(
StandardImage imageID
);

Parameters

imageID
The identification of the image to return.

Return Value

A standard image

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace


GetString Method

Common Application Framework

ResourceManager.GetString Method

Gets a resource string.

Overload List

Gets a resource string.

public abstract string GetString(string);

Gets a resource string from the named resource set.

public abstract string GetString(string,string);

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace


ResourceManager.GetString Method (String)

Gets a resource string.

public abstract string GetString(
string resourceID
);

Parameters

resourceID
Resource identifier for the required string.

Return Value

A resource string

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace | ResourceManager.GetString Overload List


ResourceManager.GetString Method (String, String)

Gets a resource string from the named resource set.

public abstract string GetString(
string resourceID,
string resourceSetName
);

Parameters

resourceID
resourceSetName

Return Value

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace | ResourceManager.GetString Overload List


ResourceManager.LoadResourceFile Method

Loads the resource file with given base name.

public abstract ResourceManager LoadResourceFile(
string resourceSetName
);

Parameters

resourceSetName

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace


ResourceManager.ReleaseAllResources Method

Release all resource unlocking resource files

public abstract void ReleaseAllResources();

See Also

ResourceManager Class | Aveva.ApplicationFramework.Presentation Namespace


ResourceSet Class

Represent a set of culture-specific resource files.

For a list of all members of this type, see ResourceSet Members.

System.Object
Aveva.ApplicationFramework.Presentation.ResourceSet

public abstract class ResourceSet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

ResourceSet Members | Aveva.ApplicationFramework.Presentation Namespace


ResourceSet Members

ResourceSet overview

Public Instance Properties

Basename | Basename for ResourceSet
Manager | The System.Resources.ResourceManager for the ResourceSet.
Pathname | Path to resource file

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ReleaseResources | Release all resources for this ResourceSet
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ResourceSet Class | Aveva.ApplicationFramework.Presentation Namespace


ResourceSet Properties

The properties of the ResourceSet class are listed below. For a complete list of ResourceSet class members, see the ResourceSet Members topic.

Public Instance Properties

Basename | Basename for ResourceSet
Manager | The System.Resources.ResourceManager for the ResourceSet.
Pathname | Path to resource file

See Also

ResourceSet Class | Aveva.ApplicationFramework.Presentation Namespace


Basename Property

Common Application Framework

ResourceSet.Basename Property

Basename for ResourceSet

public abstract string Basename {get;}

See Also

ResourceSet Class | Aveva.ApplicationFramework.Presentation Namespace


Manager Property

Common Application Framework

ResourceSet.Manager Property

The System.Resources.ResourceManager for the ResourceSet.

public abstract System.Resources.ResourceManager Manager {get;}

See Also

ResourceSet Class | Aveva.ApplicationFramework.Presentation Namespace


Pathname Property

Common Application Framework

ResourceSet.Pathname Property

Path to resource file

public abstract string Pathname {get;}

See Also

ResourceSet Class | Aveva.ApplicationFramework.Presentation Namespace


ResourceSet Methods

The methods of the ResourceSet class are listed below. For a complete list of ResourceSet class members, see the ResourceSet Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ReleaseResources | Release all resources for this ResourceSet
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ResourceSet Class | Aveva.ApplicationFramework.Presentation Namespace


ResourceSet.ReleaseResources Method

Release all resources for this ResourceSet

public abstract void ReleaseResources();

See Also

ResourceSet Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection Class

Class representing a RootToolsCollection.

For a list of all members of this type, see RootToolsCollection Members.

System.Object
Aveva.ApplicationFramework.Presentation.RootToolsCollection

public abstract class RootToolsCollection : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

RootToolsCollection Members | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection Members

RootToolsCollection overview

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer to get the root tool with given Key from the RootToolsCollection as an ITool object.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

AddButtonTool | Overloaded. Create and add a new ButtonTool object to the RootToolsCollection.
AddComboBoxTool | Overloaded. Create and add a new ComboBoxTool object to the RootToolsCollection.
AddContainerTool | Create and add a new ContainerTool object to the RootToolsCollection.
AddFontListTool | Overloaded. Create and add a new FontListTool object in the RootToolsCollection
AddLabelTool | Create and add a new LabelTool object to the RootToolsCollection.
AddListTool | Overloaded. Create and add a new ListTool object in the RootToolsCollection
AddMdiWindowListTool | Create and add a new MdiWindowListTool object in the RootToolsCollection.
AddMenuTool | Overloaded. Create and add a new MenuTool object to the RootToolsCollection.
AddPopupColorPickerTool | Overloaded. Create and add a new PopupColorPickerTool object in the RootToolsCollection
AddPopupContainerTool | Overloaded. Create and add a new PopupContainerTool object to the RootToolsCollection.
AddStateButtonTool | Overloaded. Create and add a new StateButtonTool object to the RootToolsCollection.
AddTaskPaneTool | Create and add a new TaskPaneTool object in the RootToolsCollection.
AddTextBoxTool | Overloaded. Create and add a new TextBoxTool object to the RootToolsCollection.
Clear | Remove all tools from the RootToolsCollection.
Contains | Determine if the tool with the specified Key exists in the RootToolsCollection.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the Collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Remove the tool with the specified Key from the RootToolsCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ToolAdded | Occurs after a tool has been added to the RootToolsCollection.
ToolRemoved | Occurs after a tool has been removed from the RootToolsCollection.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection Properties

The properties of the RootToolsCollection class are listed below. For a complete list of RootToolsCollection class members, see the RootToolsCollection Members topic.

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer to get the root tool with given Key from the RootToolsCollection as an ITool object.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Count Property

Common Application Framework

RootToolsCollection.Count Property

Gets the number of elements contained in the collection.

public abstract int Count {get;}

Implements

ICollection.Count

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


IsSynchronized Property

Common Application Framework

RootToolsCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public abstract bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Item Property

Common Application Framework

RootToolsCollection.Item Property

Indexer to get the root tool with given Key from the RootToolsCollection as an ITool object.

public abstract ITool this[
string key
] {get;}

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


SyncRoot Property

Common Application Framework

RootToolsCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public abstract object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection Methods

The methods of the RootToolsCollection class are listed below. For a complete list of RootToolsCollection class members, see the RootToolsCollection Members topic.

Public Instance Methods

AddButtonTool | Overloaded. Create and add a new ButtonTool object to the RootToolsCollection.
AddComboBoxTool | Overloaded. Create and add a new ComboBoxTool object to the RootToolsCollection.
AddContainerTool | Create and add a new ContainerTool object to the RootToolsCollection.
AddFontListTool | Overloaded. Create and add a new FontListTool object in the RootToolsCollection
AddLabelTool | Create and add a new LabelTool object to the RootToolsCollection.
AddListTool | Overloaded. Create and add a new ListTool object in the RootToolsCollection
AddMdiWindowListTool | Create and add a new MdiWindowListTool object in the RootToolsCollection.
AddMenuTool | Overloaded. Create and add a new MenuTool object to the RootToolsCollection.
AddPopupColorPickerTool | Overloaded. Create and add a new PopupColorPickerTool object in the RootToolsCollection
AddPopupContainerTool | Overloaded. Create and add a new PopupContainerTool object to the RootToolsCollection.
AddStateButtonTool | Overloaded. Create and add a new StateButtonTool object to the RootToolsCollection.
AddTaskPaneTool | Create and add a new TaskPaneTool object in the RootToolsCollection.
AddTextBoxTool | Overloaded. Create and add a new TextBoxTool object to the RootToolsCollection.
Clear | Remove all tools from the RootToolsCollection.
Contains | Determine if the tool with the specified Key exists in the RootToolsCollection.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the Collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Remove the tool with the specified Key from the RootToolsCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


AddButtonTool Method

Common Application Framework

RootToolsCollection.AddButtonTool Method

Create and add a new ButtonTool object to the RootToolsCollection.

Overload List

Create and add a new ButtonTool object to the RootToolsCollection.

public abstract ButtonTool AddButtonTool(string,string,Image);

Create and add a new ButtonTool object to the RootToolsCollection.

public abstract ButtonTool AddButtonTool(string,string,Image,Command);

Create and add a new ButtonTool object to the RootToolsCollection.

public abstract ButtonTool AddButtonTool(string,string,Image,string);

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection.AddButtonTool Method (String, String, Image)

Create and add a new ButtonTool object to the RootToolsCollection.

public abstract ButtonTool AddButtonTool(
string key,
string text,
Image image
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddButtonTool Overload List


RootToolsCollection.AddButtonTool Method (String, String, Image, Command)

Create and add a new ButtonTool object to the RootToolsCollection.

public abstract ButtonTool AddButtonTool(
string key,
string text,
Image image,
Command command
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
command
Command which the tool is associated with.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddButtonTool Overload List


RootToolsCollection.AddButtonTool Method (String, String, Image, String)

Create and add a new ButtonTool object to the RootToolsCollection.

public abstract ButtonTool AddButtonTool(
string key,
string text,
Image image,
string commandId
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
commandId
Identifier of command which the tool is associated with.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddButtonTool Overload List


AddComboBoxTool Method

Common Application Framework

RootToolsCollection.AddComboBoxTool Method

Create and add a new ComboBoxTool object to the RootToolsCollection.

Overload List

Create and add a new ComboBoxTool object to the RootToolsCollection.

public abstract ComboBoxTool AddComboBoxTool(string,string,Image);

Create and add a new ComboBoxTool object to the RootToolsCollection.

public abstract ComboBoxTool AddComboBoxTool(string,string,Image,Command);

Create and add a new ComboBoxTool object to the RootToolsCollection.

public abstract ComboBoxTool AddComboBoxTool(string,string,Image,string);

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection.AddComboBoxTool Method (String, String, Image)

Create and add a new ComboBoxTool object to the RootToolsCollection.

public abstract ComboBoxTool AddComboBoxTool(
string key,
string text,
Image image
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddComboBoxTool Overload List


RootToolsCollection.AddComboBoxTool Method (String, String, Image, Command)

Create and add a new ComboBoxTool object to the RootToolsCollection.

public abstract ComboBoxTool AddComboBoxTool(
string key,
string text,
Image image,
Command command
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
command
Command which the tool is associated with.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddComboBoxTool Overload List


RootToolsCollection.AddComboBoxTool Method (String, String, Image, String)

Create and add a new ComboBoxTool object to the RootToolsCollection.

public abstract ComboBoxTool AddComboBoxTool(
string key,
string text,
Image image,
string commandId
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
commandId
Id of command which the tool is associated with.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddComboBoxTool Overload List


RootToolsCollection.AddContainerTool Method

Create and add a new ContainerTool object to the RootToolsCollection.

public abstract ContainerTool AddContainerTool(
string key,
string text,
Control control
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
control
Control assigned to the tool.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


AddFontListTool Method

Common Application Framework

RootToolsCollection.AddFontListTool Method

Create and add a new FontListTool object in the RootToolsCollection

Overload List

Create and add a new FontListTool object in the RootToolsCollection

public abstract FontListTool AddFontListTool(string,string,Image);

Create and add a new FontListTool object in the RootToolsCollection

public abstract FontListTool AddFontListTool(string,string,Image,Command);

Create and add a new FontListTool object in the RootToolsCollection

public abstract FontListTool AddFontListTool(string,string,Image,string);

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection.AddFontListTool Method (String, String, Image)

Create and add a new FontListTool object in the RootToolsCollection

public abstract FontListTool AddFontListTool(
string key,
string text,
Image image
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddFontListTool Overload List


RootToolsCollection.AddFontListTool Method (String, String, Image, Command)

Create and add a new FontListTool object in the RootToolsCollection

public abstract FontListTool AddFontListTool(
string key,
string text,
Image image,
Command command
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
command
Command which the tool is associated with.

Return Value

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddFontListTool Overload List


RootToolsCollection.AddFontListTool Method (String, String, Image, String)

Create and add a new FontListTool object in the RootToolsCollection

public abstract FontListTool AddFontListTool(
string key,
string text,
Image image,
string commandId
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
commandId
Identifier of command which the tool is associated with.

Return Value

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddFontListTool Overload List


RootToolsCollection.AddLabelTool Method

Create and add a new LabelTool object to the RootToolsCollection.

public abstract LabelTool AddLabelTool(
string key,
string text,
Image image
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


AddListTool Method

Common Application Framework

RootToolsCollection.AddListTool Method

Create and add a new ListTool object in the RootToolsCollection

Overload List

Create and add a new ListTool object in the RootToolsCollection

public abstract ListTool AddListTool(string);

Create and add a new ListTool object in the RootToolsCollection

public abstract ListTool AddListTool(string,Command);

Create and add a new ListTool object in the RootToolsCollection

public abstract ListTool AddListTool(string,string);

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection.AddListTool Method (String)

Create and add a new ListTool object in the RootToolsCollection

public abstract ListTool AddListTool(
string key
);

Parameters

key
Unique key in the RootToolsCollection.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddListTool Overload List


RootToolsCollection.AddListTool Method (String, Command)

Create and add a new ListTool object in the RootToolsCollection

public abstract ListTool AddListTool(
string key,
Command command
);

Parameters

key
Unique key in the RootToolsCollection.
command
Command which the tool is associated with.

Return Value

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddListTool Overload List


RootToolsCollection.AddListTool Method (String, String)

Create and add a new ListTool object in the RootToolsCollection

public abstract ListTool AddListTool(
string key,
string commandId
);

Parameters

key
Unique key in the RootToolsCollection.
commandId
Identifier of command which the tool is associated with.

Return Value

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddListTool Overload List


RootToolsCollection.AddMdiWindowListTool Method

Create and add a new MdiWindowListTool object in the RootToolsCollection.

public abstract MdiWindowListTool AddMdiWindowListTool(
string key
);

Parameters

key
Unique key in the RootToolsCollection.

Return Value

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


AddMenuTool Method

Common Application Framework

RootToolsCollection.AddMenuTool Method

Create and add a new MenuTool object to the RootToolsCollection.

Overload List

Create and add a new MenuTool object to the RootToolsCollection.

public abstract MenuTool AddMenuTool(string,string,Image);

Create and add a new MenuTool object to the RootToolsCollection.

public abstract MenuTool AddMenuTool(string,string,Image,Command);

Create and add a new MenuTool object to the RootToolsCollection.

public abstract MenuTool AddMenuTool(string,string,Image,string);

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection.AddMenuTool Method (String, String, Image)

Create and add a new MenuTool object to the RootToolsCollection.

public abstract MenuTool AddMenuTool(
string key,
string text,
Image image
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddMenuTool Overload List


RootToolsCollection.AddMenuTool Method (String, String, Image, Command)

Create and add a new MenuTool object to the RootToolsCollection.

public abstract MenuTool AddMenuTool(
string key,
string text,
Image image,
Command command
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
command
Command which the tool is associated with.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddMenuTool Overload List


RootToolsCollection.AddMenuTool Method (String, String, Image, String)

Create and add a new MenuTool object to the RootToolsCollection.

public abstract MenuTool AddMenuTool(
string key,
string text,
Image image,
string commandId
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
commandId
Identifier of command which the tool is associated with.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddMenuTool Overload List


AddPopupColorPickerTool Method

Common Application Framework

RootToolsCollection.AddPopupColorPickerTool Method

Create and add a new PopupColorPickerTool object in the RootToolsCollection

Overload List

Create and add a new PopupColorPickerTool object in the RootToolsCollection

public abstract PopupColorPickerTool AddPopupColorPickerTool(string,string,Image);

Create and add a new PopupColorPickerTool object in the RootToolsCollection

public abstract PopupColorPickerTool AddPopupColorPickerTool(string,string,Image,Command);

Create and add a new PopupColorPickerTool object in the RootToolsCollection

public abstract PopupColorPickerTool AddPopupColorPickerTool(string,string,Image,string);

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection.AddPopupColorPickerTool Method (String, String, Image)

Create and add a new PopupColorPickerTool object in the RootToolsCollection

public abstract PopupColorPickerTool AddPopupColorPickerTool(
string key,
string text,
Image image
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddPopupColorPickerTool Overload List


RootToolsCollection.AddPopupColorPickerTool Method (String, String, Image, Command)

Create and add a new PopupColorPickerTool object in the RootToolsCollection

public abstract PopupColorPickerTool AddPopupColorPickerTool(
string key,
string text,
Image image,
Command command
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
command
Command which the tool is associated with.

Return Value

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddPopupColorPickerTool Overload List


RootToolsCollection.AddPopupColorPickerTool Method (String, String, Image, String)

Create and add a new PopupColorPickerTool object in the RootToolsCollection

public abstract PopupColorPickerTool AddPopupColorPickerTool(
string key,
string text,
Image image,
string commandId
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
commandId
Identifier of command which the tool is associated with.

Return Value

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddPopupColorPickerTool Overload List


AddPopupContainerTool Method

Common Application Framework

RootToolsCollection.AddPopupContainerTool Method

Create and add a new PopupContainerTool object to the RootToolsCollection.

Overload List

Create and add a new PopupContainerTool object to the RootToolsCollection.

public abstract PopupContainerTool AddPopupContainerTool(string,string,Image,Control);

Create and add a new PopupContainerTool object to the RootToolsCollection.

public abstract PopupContainerTool AddPopupContainerTool(string,string,Image,Control,Command);

Create and add a new PopupContainerTool object to the RootToolsCollection.

public abstract PopupContainerTool AddPopupContainerTool(string,string,Image,Control,string);

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection.AddPopupContainerTool Method (String, String, Image, Control)

Create and add a new PopupContainerTool object to the RootToolsCollection.

public abstract PopupContainerTool AddPopupContainerTool(
string key,
string text,
Image image,
Control control
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
control
Control assigned to the tool.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddPopupContainerTool Overload List


RootToolsCollection.AddPopupContainerTool Method (String, String, Image, Control, Command)

Create and add a new PopupContainerTool object to the RootToolsCollection.

public abstract PopupContainerTool AddPopupContainerTool(
string key,
string text,
Image image,
Control control,
Command command
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
control
Control assigned to the tool.
command
Command which the tool is associated with.

Return Value

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddPopupContainerTool Overload List


RootToolsCollection.AddPopupContainerTool Method (String, String, Image, Control, String)

Create and add a new PopupContainerTool object to the RootToolsCollection.

public abstract PopupContainerTool AddPopupContainerTool(
string key,
string text,
Image image,
Control control,
string commandId
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
control
Control assigned to the tool.
commandId
Identifier of command which the tool is associated with.

Return Value

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddPopupContainerTool Overload List


AddStateButtonTool Method

Common Application Framework

RootToolsCollection.AddStateButtonTool Method

Create and add a new StateButtonTool object to the RootToolsCollection.

Overload List

Create and add a new StateButtonTool object to the RootToolsCollection.

public abstract StateButtonTool AddStateButtonTool(string,string,Image);

Create and add a new StateButtonTool object to the RootToolsCollection.

public abstract StateButtonTool AddStateButtonTool(string,string,Image,Command);

Create and add a new StateButtonTool object to the RootToolsCollection.

public abstract StateButtonTool AddStateButtonTool(string,string,Image,string);

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection.AddStateButtonTool Method (String, String, Image)

Create and add a new StateButtonTool object to the RootToolsCollection.

public abstract StateButtonTool AddStateButtonTool(
string key,
string text,
Image image
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddStateButtonTool Overload List


RootToolsCollection.AddStateButtonTool Method (String, String, Image, Command)

Create and add a new StateButtonTool object to the RootToolsCollection.

public abstract StateButtonTool AddStateButtonTool(
string key,
string text,
Image image,
Command command
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
command
Command which the tool is associated with.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddStateButtonTool Overload List


RootToolsCollection.AddStateButtonTool Method (String, String, Image, String)

Create and add a new StateButtonTool object to the RootToolsCollection.

public abstract StateButtonTool AddStateButtonTool(
string key,
string text,
Image image,
string commandId
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
commandId
Identifier of command which the tool is associated with.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddStateButtonTool Overload List


RootToolsCollection.AddTaskPaneTool Method

Create and add a new TaskPaneTool object in the RootToolsCollection.

public abstract TaskPaneTool AddTaskPaneTool(
string key
);

Parameters

key
Unique key in the RootToolsCollection.

Return Value

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


AddTextBoxTool Method

Common Application Framework

RootToolsCollection.AddTextBoxTool Method

Create and add a new TextBoxTool object to the RootToolsCollection.

Overload List

Create and add a new TextBoxTool object to the RootToolsCollection.

public abstract TextBoxTool AddTextBoxTool(string,string,Image,string);

Create and add a new TextBoxTool object to the RootToolsCollection.

public abstract TextBoxTool AddTextBoxTool(string,string,Image,string,Command);

Create and add a new TextBoxTool object to the RootToolsCollection.

public abstract TextBoxTool AddTextBoxTool(string,string,Image,string,string);

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection.AddTextBoxTool Method (String, String, Image, String)

Create and add a new TextBoxTool object to the RootToolsCollection.

public abstract TextBoxTool AddTextBoxTool(
string key,
string text,
Image image,
string val
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
val
Textual value to be displayed in the tool.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddTextBoxTool Overload List


RootToolsCollection.AddTextBoxTool Method (String, String, Image, String, Command)

Create and add a new TextBoxTool object to the RootToolsCollection.

public abstract TextBoxTool AddTextBoxTool(
string key,
string text,
Image image,
string val,
Command command
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
val
Textual value to be displayed in the tool.
command
Command which the tool is associated with.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddTextBoxTool Overload List


RootToolsCollection.AddTextBoxTool Method (String, String, Image, String, String)

Create and add a new TextBoxTool object to the RootToolsCollection.

public abstract TextBoxTool AddTextBoxTool(
string key,
string text,
Image image,
string val,
string commandId
);

Parameters

key
Unique key in the RootToolsCollection.
text
Caption for the tool.
image
Icon for the tool.
val
Textual value to be displayed in the tool.
commandId
Identifier of command which the tool is associated with.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | RootToolsCollection.AddTextBoxTool Overload List


RootToolsCollection.Clear Method

Remove all tools from the RootToolsCollection.

public abstract void Clear();

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection.Contains Method

Determine if the tool with the specified Key exists in the RootToolsCollection.

public abstract bool Contains(
string key
);

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection.CopyTo Method

Copies the elements of the collection to an Array, starting at a particular Array index.

public abstract void CopyTo(
Array array,
int index
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from collection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Implements

ICollection.CopyTo

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection.GetEnumerator Method

Returns an enumerator that can iterate through the Collection.

public abstract IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection.Remove Method

Remove the tool with the specified Key from the RootToolsCollection.

public abstract void Remove(
string key
);

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection Events

The events of the RootToolsCollection class are listed below. For a complete list of RootToolsCollection class members, see the RootToolsCollection Members topic.

Public Instance Events

ToolAdded | Occurs after a tool has been added to the RootToolsCollection.
ToolRemoved | Occurs after a tool has been removed from the RootToolsCollection.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection.ToolAdded Event

Occurs after a tool has been added to the RootToolsCollection.

public event ToolEventHandler ToolAdded;

Event Data

The event handler receives an argument of type ToolEventArgs containing data related to this event. The following ToolEventArgs property provides information specific to this event.

Property | Description
Key | The tools key.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


RootToolsCollection.ToolRemoved Event

Occurs after a tool has been removed from the RootToolsCollection.

public event ToolEventHandler ToolRemoved;

Event Data

The event handler receives an argument of type ToolEventArgs containing data related to this event. The following ToolEventArgs property provides information specific to this event.

Property | Description
Key | The tools key.

See Also

RootToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


SplashScreen Class

Provides an application SplashScreen.

For a list of all members of this type, see SplashScreen Members.

System.Object
Aveva.ApplicationFramework.Presentation.SplashScreen

public abstract class SplashScreen

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

SplashScreen Members | Aveva.ApplicationFramework.Presentation Namespace


SplashScreen Members

SplashScreen overview

Public Instance Properties

Status Get or set the splashscreen status prompt.

Public Instance Methods

Close | Close the splashscreen
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Show | Overloaded. Display a splashscreen with the image defined by the given path or resource id
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SplashScreen Class | Aveva.ApplicationFramework.Presentation Namespace


SplashScreen Properties

The properties of the SplashScreen class are listed below. For a complete list of SplashScreen class members, see the SplashScreen Members topic.

Public Instance Properties

Status Get or set the splashscreen status prompt.

See Also

SplashScreen Class | Aveva.ApplicationFramework.Presentation Namespace


Status Property

Common Application Framework

SplashScreen.Status Property

Get or set the splashscreen status prompt.

public abstract string Status {get; set;}

See Also

SplashScreen Class | Aveva.ApplicationFramework.Presentation Namespace


SplashScreen Methods

The methods of the SplashScreen class are listed below. For a complete list of SplashScreen class members, see the SplashScreen Members topic.

Public Instance Methods

Close | Close the splashscreen
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Show | Overloaded. Display a splashscreen with the image defined by the given path or resource id
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SplashScreen Class | Aveva.ApplicationFramework.Presentation Namespace


SplashScreen.Close Method

Close the splashscreen

public abstract void Close();

See Also

SplashScreen Class | Aveva.ApplicationFramework.Presentation Namespace


Show Method

Common Application Framework

SplashScreen.Show Method

Display a splashscreen with the given image.

Overload List

Display a splashscreen with the given image.

public abstract void Show(Image);

Display a splashscreen with the image defined by the given path or resource id

public abstract void Show(string);

Display a splashscreen with the image defined by the given path or resource id

public abstract void Show(string,IApplicationInfo);

See Also

SplashScreen Class | Aveva.ApplicationFramework.Presentation Namespace


SplashScreen.Show Method (Image)

Display a splashscreen with the given image.

public abstract void Show(
Image image
);

Parameters

image
The image to display.

See Also

SplashScreen Class | Aveva.ApplicationFramework.Presentation Namespace | SplashScreen.Show Overload List


SplashScreen.Show Method (String)

Display a splashscreen with the image defined by the given path or resource id

public abstract void Show(
string imagePathOrID
);

Parameters

imagePathOrID
The path or resource id of the image to display.

See Also

SplashScreen Class | Aveva.ApplicationFramework.Presentation Namespace | SplashScreen.Show Overload List


SplashScreen.Show Method (String, IApplicationInfo)

Display a splashscreen with the image defined by the given path or resource id

public abstract void Show(
string imagePathOrID,
IApplicationInfo applicationInfo
);

Parameters

imagePathOrID
The path or resource id of the image to display
applicationInfo
Application information to display on splashscreen

See Also

SplashScreen Class | Aveva.ApplicationFramework.Presentation Namespace | SplashScreen.Show Overload List


StandardImage Enumeration

Enumeration of standard images

public enum StandardImage

Members

Member Name | Description
AppWindow |
Arrow |
Color |
Copy |
Cut |
Delete |
DeleteFolder |
Document |
Filter |
Find |
FindNext |
FullScreen |
Help |
HTMLPage |
Hyperlink |
Information |
NavBack |
NavForward |
NewDocument |
NewFolder |
NewWindow |
Open |
OpenFolder |
Options |
Paste |
Print |
PrintPreview |
Properties |
Redo |
Save |
SaveAll |
Search |
Undo |
User |
Zoom |

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


StateButtonTool Class

Represents a StateButtonTool.

For a list of all members of this type, see StateButtonTool Members.

System.Object
Aveva.ApplicationFramework.Presentation.StateButtonTool

public abstract class StateButtonTool : ITool

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

StateButtonTool Members | Aveva.ApplicationFramework.Presentation Namespace


StateButtonTool Members

StateButtonTool overview

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Checked | Gets or sets whether the tool is in the checked state.
Command | Gets the command object which was associated with the tool when it was created.
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
MenuToolUpdateOptions | Gets or sets how properties of an owning MenuTool will be automatically updated
OptionSetKey | Gets or sets the OptionSet key for the tool. Setting the key assigns the tool to the CommandBarManagers OptionSet which has this key.
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ToolClick Occurs when the tool is clicked.

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


StateButtonTool Properties

The properties of the StateButtonTool class are listed below. For a complete list of StateButtonTool class members, see the StateButtonTool Members topic.

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Checked | Gets or sets whether the tool is in the checked state.
Command | Gets the command object which was associated with the tool when it was created.
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
MenuToolUpdateOptions | Gets or sets how properties of an owning MenuTool will be automatically updated
OptionSetKey | Gets or sets the OptionSet key for the tool. Setting the key assigns the tool to the CommandBarManagers OptionSet which has this key.
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Caption Property

Common Application Framework

StateButtonTool.Caption Property

Gets or sets the tool caption

public abstract string Caption {get; set;}

Implements

ITool.Caption

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Category Property

Common Application Framework

StateButtonTool.Category Property

Gets or sets the tools category

public abstract string Category {get; set;}

Implements

ITool.Category

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Checked Property

Common Application Framework

StateButtonTool.Checked Property

Gets or sets whether the tool is in the checked state.

public abstract bool Checked {get; set;}

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Command Property

Common Application Framework

StateButtonTool.Command Property

Gets the command object which was associated with the tool when it was created.

public abstract Command Command {get;}

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

StateButtonTool.Enabled Property

Gets or sets the enabled state of the tool.

public abstract bool Enabled {get; set;}

Implements

ITool.Enabled

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

StateButtonTool.Image Property

Gets or sets the image displayed on the tool

public abstract System.Drawing.Image Image {get; set;}

Implements

ITool.Image

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


IsFirstInGroup Property

Common Application Framework

StateButtonTool.IsFirstInGroup Property

Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.

public abstract bool IsFirstInGroup {get; set;}

Implements

ITool.IsFirstInGroup

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

StateButtonTool.Key Property

The Key of the tool in the RootToolsCollection

public abstract string Key {get;}

Implements

ITool.Key

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


MenuToolUpdateOptions Property

Common Application Framework

StateButtonTool.MenuToolUpdateOptions Property

Gets or sets how properties of an owning MenuTool will be automatically updated

public abstract UpdateOptions MenuToolUpdateOptions {get; set;}

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


OptionSetKey Property

Common Application Framework

StateButtonTool.OptionSetKey Property

Gets or sets the OptionSet key for the tool. Setting the key assigns the tool to the CommandBarManagers OptionSet which has this key.

public abstract string OptionSetKey {get; set;}

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Shortcut Property

Common Application Framework

StateButtonTool.Shortcut Property

Gets or sets the shortcut associated with a tool.

public abstract System.Windows.Forms.Shortcut Shortcut {get; set;}

Implements

ITool.Shortcut

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

StateButtonTool.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a tool.

public abstract object Tag {get; set;}

Implements

ITool.Tag

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

StateButtonTool.Tooltip Property

Gets or sets the tools tooltip

public abstract string Tooltip {get; set;}

Implements

ITool.Tooltip

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

StateButtonTool.Value Property

Gets or sets the value of the tool.

public abstract object Value {get; set;}

Implements

ITool.Value

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

StateButtonTool.Visible Property

Gets or sets the visibility of the tool.

public abstract bool Visible {get; set;}

Implements

ITool.Visible

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


StateButtonTool Events

The events of the StateButtonTool class are listed below. For a complete list of StateButtonTool class members, see the StateButtonTool Members topic.

Public Instance Events

ToolClick Occurs when the tool is clicked.

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


StateButtonTool.ToolClick Event

Occurs when the tool is clicked.

public event EventHandler ToolClick;

See Also

StateButtonTool Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBar Class

Represents a Windows style status bar control.

For a list of all members of this type, see StatusBar Members.

System.Object
Aveva.ApplicationFramework.Presentation.StatusBar

public abstract class StatusBar

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

StatusBar Members | Aveva.ApplicationFramework.Presentation Namespace


StatusBar Members

StatusBar overview

Public Instance Properties

Panels | Gets the collection of application defined statusbar panels.
Progress | Gets or sets the progress bar value [0-100].
ProgressText | Gets or Sets the text that is displayed with the progress bar.
ShowCapsLock | Gets or sets whether the panel showing the CapsLock state is displayed on the statusbar.
ShowDateTime | Gets or sets whether the Date and Time should be displayed on the statusbar.
ShowInsertMode | Gets or sets whether the panel showing the IntertMode is displayed on the statusbar.
ShowNumLock | Gets or sets whether the panel showing the NumLock state is displayed on the statusbar.
ShowScrollLock | Gets or sets whether the panel showing the ScrollLock state is displayed on the statusbar.
Text | Gets or sets the text to display in the statusbar text pane.
Visible | Gets or sets the visibility of the statusbar.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StatusBar Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBar Properties

The properties of the StatusBar class are listed below. For a complete list of StatusBar class members, see the StatusBar Members topic.

Public Instance Properties

Panels | Gets the collection of application defined statusbar panels.
Progress | Gets or sets the progress bar value [0-100].
ProgressText | Gets or Sets the text that is displayed with the progress bar.
ShowCapsLock | Gets or sets whether the panel showing the CapsLock state is displayed on the statusbar.
ShowDateTime | Gets or sets whether the Date and Time should be displayed on the statusbar.
ShowInsertMode | Gets or sets whether the panel showing the IntertMode is displayed on the statusbar.
ShowNumLock | Gets or sets whether the panel showing the NumLock state is displayed on the statusbar.
ShowScrollLock | Gets or sets whether the panel showing the ScrollLock state is displayed on the statusbar.
Text | Gets or sets the text to display in the statusbar text pane.
Visible | Gets or sets the visibility of the statusbar.

See Also

StatusBar Class | Aveva.ApplicationFramework.Presentation Namespace


Panels Property

Common Application Framework

StatusBar.Panels Property

Gets the collection of application defined statusbar panels.

public abstract StatusBarPanelsCollection Panels {get;}

See Also

StatusBar Class | Aveva.ApplicationFramework.Presentation Namespace


Progress Property

Common Application Framework

StatusBar.Progress Property

Gets or sets the progress bar value [0-100].

public abstract int Progress {get; set;}

See Also

StatusBar Class | Aveva.ApplicationFramework.Presentation Namespace


ProgressText Property

Common Application Framework

StatusBar.ProgressText Property

Gets or Sets the text that is displayed with the progress bar.

public abstract string ProgressText {get; set;}

See Also

StatusBar Class | Aveva.ApplicationFramework.Presentation Namespace


ShowCapsLock Property

Common Application Framework

StatusBar.ShowCapsLock Property

Gets or sets whether the panel showing the CapsLock state is displayed on the statusbar.

public abstract bool ShowCapsLock {get; set;}

See Also

StatusBar Class | Aveva.ApplicationFramework.Presentation Namespace


ShowDateTime Property

Common Application Framework

StatusBar.ShowDateTime Property

Gets or sets whether the Date and Time should be displayed on the statusbar.

public abstract bool ShowDateTime {get; set;}

See Also

StatusBar Class | Aveva.ApplicationFramework.Presentation Namespace


ShowInsertMode Property

Common Application Framework

StatusBar.ShowInsertMode Property

Gets or sets whether the panel showing the IntertMode is displayed on the statusbar.

public abstract bool ShowInsertMode {get; set;}

See Also

StatusBar Class | Aveva.ApplicationFramework.Presentation Namespace


ShowNumLock Property

Common Application Framework

StatusBar.ShowNumLock Property

Gets or sets whether the panel showing the NumLock state is displayed on the statusbar.

public abstract bool ShowNumLock {get; set;}

See Also

StatusBar Class | Aveva.ApplicationFramework.Presentation Namespace


ShowScrollLock Property

Common Application Framework

StatusBar.ShowScrollLock Property

Gets or sets whether the panel showing the ScrollLock state is displayed on the statusbar.

public abstract bool ShowScrollLock {get; set;}

See Also

StatusBar Class | Aveva.ApplicationFramework.Presentation Namespace


Text Property

Common Application Framework

StatusBar.Text Property

Gets or sets the text to display in the statusbar text pane.

public abstract string Text {get; set;}

See Also

StatusBar Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

StatusBar.Visible Property

Gets or sets the visibility of the statusbar.

public abstract bool Visible {get; set;}

See Also

StatusBar Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBarPanelsCollection Class

Represents a collection of status bar panels.

For a list of all members of this type, see StatusBarPanelsCollection Members.

System.Object
Aveva.ApplicationFramework.Presentation.StatusBarPanelsCollection

public abstract class StatusBarPanelsCollection : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

StatusBarPanelsCollection Members | Aveva.ApplicationFramework.Presentation Namespace


StatusBarPanelsCollection Members

StatusBarPanelsCollection overview

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer which returns an IStatusBarPanel interface for the panel with the given key.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

AddTextPanel | Overloaded. Create and add a new StartsBarTextPanel to the collection
ContainsKey | Determines whether the StatusBarPanelsCollection contains a specific key.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Remove the panel with the given key from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StatusBarPanelsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBarPanelsCollection Properties

The properties of the StatusBarPanelsCollection class are listed below. For a complete list of StatusBarPanelsCollection class members, see the StatusBarPanelsCollection Members topic.

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer which returns an IStatusBarPanel interface for the panel with the given key.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

StatusBarPanelsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Count Property

Common Application Framework

StatusBarPanelsCollection.Count Property

Gets the number of elements contained in the collection.

public abstract int Count {get;}

Implements

ICollection.Count

See Also

StatusBarPanelsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


IsSynchronized Property

Common Application Framework

StatusBarPanelsCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public abstract bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

StatusBarPanelsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Item Property

Common Application Framework

StatusBarPanelsCollection.Item Property

Indexer which returns an IStatusBarPanel interface for the panel with the given key.

public abstract IStatusBarPanel this[
string key
] {get;}

See Also

StatusBarPanelsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


SyncRoot Property

Common Application Framework

StatusBarPanelsCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public abstract object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

StatusBarPanelsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBarPanelsCollection Methods

The methods of the StatusBarPanelsCollection class are listed below. For a complete list of StatusBarPanelsCollection class members, see the StatusBarPanelsCollection Members topic.

Public Instance Methods

AddTextPanel | Overloaded. Create and add a new StartsBarTextPanel to the collection
ContainsKey | Determines whether the StatusBarPanelsCollection contains a specific key.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Remove the panel with the given key from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StatusBarPanelsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


AddTextPanel Method

Common Application Framework

StatusBarPanelsCollection.AddTextPanel Method

Create and add a new StartsBarTextPanel to the collection

Overload List

Create and add a new StartsBarTextPanel to the collection

public abstract StatusBarTextPanel AddTextPanel(string,string);

Create and add a new StartsBarTextPanel to the collection

public abstract StatusBarTextPanel AddTextPanel(string,string,Image);

See Also

StatusBarPanelsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBarPanelsCollection.AddTextPanel Method (String, String)

Create and add a new StartsBarTextPanel to the collection

public abstract StatusBarTextPanel AddTextPanel(
string key,
string text
);

Parameters

key
Panel Key
text
Panel Text

Return Value

See Also

StatusBarPanelsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | StatusBarPanelsCollection.AddTextPanel Overload List


StatusBarPanelsCollection.AddTextPanel Method (String, String, Image)

Create and add a new StartsBarTextPanel to the collection

public abstract StatusBarTextPanel AddTextPanel(
string key,
string text,
Image image
);

Parameters

key
Panel Key
text
Panel Text
image
Panel Image

Return Value

See Also

StatusBarPanelsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | StatusBarPanelsCollection.AddTextPanel Overload List


StatusBarPanelsCollection.ContainsKey Method

Determines whether the StatusBarPanelsCollection contains a specific key.

public abstract bool ContainsKey(
string key
);

Parameters

key
The key to locate in the StatusBarPanelsCollection.

Return Value

See Also

StatusBarPanelsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBarPanelsCollection.CopyTo Method

Copies the elements of the collection to an Array, starting at a particular Array index.

public abstract void CopyTo(
Array array,
int index
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from collection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Implements

ICollection.CopyTo

See Also

StatusBarPanelsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBarPanelsCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

public abstract IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

StatusBarPanelsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBarPanelsCollection.Remove Method

Remove the panel with the given key from the collection.

public abstract void Remove(
string key
);

Parameters

key
The key of the window to remove.

See Also

StatusBarPanelsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBarTextPanel Class

Represents a StatusBarTextPanel.

For a list of all members of this type, see StatusBarTextPanel Members.

System.Object
Aveva.ApplicationFramework.Presentation.StatusBarTextPanel

public abstract class StatusBarTextPanel : IStatusBarPanel

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

StatusBarTextPanel Members | Aveva.ApplicationFramework.Presentation Namespace


StatusBarTextPanel Members

StatusBarTextPanel overview

Public Instance Properties

AlertTextChange | Controls if a change in the value of the text panel cause it to start flashing to alert the user. Flashing will stop when the cursor enters the panel.
Enabled | Returns or sets if the panel is enabled.
HotTrack | Determines whether the a panel's appearance changes when the mouse passes over it. This is only valid for panels which have a PanelClick event handler
Image | Returns or sets the image associated with the panel.
Key | Key for the panel.
SizingMode | Returns or sets how the panel can be sized.
Text | Returns or sets the text associated with the panel.
Tooltip | Returns or sets the tooltip for the panel.
Visible | Returns or sets if the panel is visible.
Width | Returns or sets the width of the panel.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
StopAlert | Stop text panel flashing following a text change when AlertTextChange is turned on.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

PanelClick | Occurs when the panel is clicked
PanelDoubleClick | Occurs when the panel is double clicked

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBarTextPanel Properties

The properties of the StatusBarTextPanel class are listed below. For a complete list of StatusBarTextPanel class members, see the StatusBarTextPanel Members topic.

Public Instance Properties

AlertTextChange | Controls if a change in the value of the text panel cause it to start flashing to alert the user. Flashing will stop when the cursor enters the panel.
Enabled | Returns or sets if the panel is enabled.
HotTrack | Determines whether the a panel's appearance changes when the mouse passes over it. This is only valid for panels which have a PanelClick event handler
Image | Returns or sets the image associated with the panel.
Key | Key for the panel.
SizingMode | Returns or sets how the panel can be sized.
Text | Returns or sets the text associated with the panel.
Tooltip | Returns or sets the tooltip for the panel.
Visible | Returns or sets if the panel is visible.
Width | Returns or sets the width of the panel.

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


AlertTextChange Property

Common Application Framework

StatusBarTextPanel.AlertTextChange Property

Controls if a change in the value of the text panel cause it to start flashing to alert the user. Flashing will stop when the cursor enters the panel.

public abstract bool AlertTextChange {get; set;}

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

StatusBarTextPanel.Enabled Property

Returns or sets if the panel is enabled.

public abstract bool Enabled {get; set;}

Implements

IStatusBarPanel.Enabled

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


HotTrack Property

Common Application Framework

StatusBarTextPanel.HotTrack Property

Determines whether the a panel's appearance changes when the mouse passes over it. This is only valid for panels which have a PanelClick event handler

public abstract bool HotTrack {get; set;}

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

StatusBarTextPanel.Image Property

Returns or sets the image associated with the panel.

public abstract System.Drawing.Image Image {get; set;}

Implements

IStatusBarPanel.Image

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

StatusBarTextPanel.Key Property

Key for the panel.

public abstract string Key {get;}

Implements

IStatusBarPanel.Key

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


SizingMode Property

Common Application Framework

StatusBarTextPanel.SizingMode Property

Returns or sets how the panel can be sized.

public abstract PanelSizingMode SizingMode {get; set;}

Implements

IStatusBarPanel.SizingMode

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


Text Property

Common Application Framework

StatusBarTextPanel.Text Property

Returns or sets the text associated with the panel.

public abstract string Text {get; set;}

Implements

IStatusBarPanel.Text

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

StatusBarTextPanel.Tooltip Property

Returns or sets the tooltip for the panel.

public abstract string Tooltip {get; set;}

Implements

IStatusBarPanel.Tooltip

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

StatusBarTextPanel.Visible Property

Returns or sets if the panel is visible.

public abstract bool Visible {get; set;}

Implements

IStatusBarPanel.Visible

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


Width Property

Common Application Framework

StatusBarTextPanel.Width Property

Returns or sets the width of the panel.

public abstract int Width {get; set;}

Implements

IStatusBarPanel.Width

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBarTextPanel Methods

The methods of the StatusBarTextPanel class are listed below. For a complete list of StatusBarTextPanel class members, see the StatusBarTextPanel Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
StopAlert | Stop text panel flashing following a text change when AlertTextChange is turned on.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBarTextPanel.StopAlert Method

Stop text panel flashing following a text change when AlertTextChange is turned on.

public abstract void StopAlert();

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBarTextPanel Events

The events of the StatusBarTextPanel class are listed below. For a complete list of StatusBarTextPanel class members, see the StatusBarTextPanel Members topic.

Public Instance Events

PanelClick | Occurs when the panel is clicked
PanelDoubleClick | Occurs when the panel is double clicked

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBarTextPanel.PanelClick Event

Occurs when the panel is clicked

public event EventHandler PanelClick;

Implements

IStatusBarPanel.PanelClick

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBarTextPanel.PanelDoubleClick Event

Occurs when the panel is double clicked

public event EventHandler PanelDoubleClick;

Implements

IStatusBarPanel.PanelDoubleClick

See Also

StatusBarTextPanel Class | Aveva.ApplicationFramework.Presentation Namespace


TaskBar Class

Class representing a Microsoft Office style "TaskPane" type toolbar.

For a list of all members of this type, see TaskBar Members.

System.Object
Aveva.ApplicationFramework.Presentation.CommandBar
Aveva.ApplicationFramework.Presentation.TaskBar

public abstract class TaskBar : CommandBar

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

TaskBar Members | Aveva.ApplicationFramework.Presentation Namespace


TaskBar Members

TaskBar overview

Public Instance Properties

AllowCustomize (inherited from CommandBar) | Gets or sets whether the CommandBar can be customized at run-time by the end user.
AllowFloating (inherited from CommandBar) | Gets or sets whether the CommandBar can be dragged out of a dock area and floated.
AllowHiding (inherited from CommandBar) | Gets or sets whether the CommandBar can be hidden at run-time by the end user.
Caption (inherited from CommandBar) | Gets or sets the description displayed in the customization dialogs and in the caption of the floating CommandBar.
Command (inherited from CommandBar) | Gets the command object which was associated with the CommandBar when it was created.
DockedColumn (inherited from CommandBar) | Gets or sets the column (within the dock area) in which the CommandBar is docked.
DockedContentExtent | Return or sets the size of the taskbar. Either its width or height depending on where it is docked.
DockedPosition (inherited from CommandBar) | Gets or sets the current location of the CommandBar (left, right, top, bottom, floating)
DockedRow (inherited from CommandBar) | Gets or sets the row (within the dock area) in which the CommandBar is docked.
Enabled (inherited from CommandBar) | Gets or sets the enabled state of the CommandBar.
FillEntireRow (inherited from CommandBar) | Gets or sets whether the CommandBar will take up the entire dock area row, even if it doesn't have enough tools to fill the area.
HomeTaskPaneToolKey | Returns or sets the key of the tool representing the "home" item. The SelectedTaskPaneToolKey will be set to the HomeTaskPaneToolKey when the home navigation button is pressed.
Key (inherited from CommandBar) | The Key of the CommandBar in the CommandBarCollection
NavigationButtonStyle | Returns or sets a value indicating how the navigation buttons are used to navigate the items in a TaskPane and can also be used to hide the navigation buttons.
SelectedTaskPaneToolKey | Returns or sets the key of the currently selected task pane tool.
ShowHomeButton | Returns or sets a value indicating whether the home navigation button will be displayed.
ShowInToolbarList (inherited from CommandBar) | Gets or sets whether the CommandBar shows up in the customization dialog at runtime.
Tag (inherited from CommandBar) | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tools (inherited from CommandBar) | Gets the ToolsCollection containing the tools to display in the CommandBar.
Visible (inherited from CommandBar) | Gets or sets whether the CommandBar is visible.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AfterTaskPaneToolSelected | Event raised after a task pane tool is selected
Closed (inherited from CommandBar) | Event raised when the CommandBar is Closed
Opened (inherited from CommandBar) | Event raised when the CommandBar is Opened

See Also

TaskBar Class | Aveva.ApplicationFramework.Presentation Namespace


TaskBar Properties

The properties of the TaskBar class are listed below. For a complete list of TaskBar class members, see the TaskBar Members topic.

Public Instance Properties

AllowCustomize (inherited from CommandBar) | Gets or sets whether the CommandBar can be customized at run-time by the end user.
AllowFloating (inherited from CommandBar) | Gets or sets whether the CommandBar can be dragged out of a dock area and floated.
AllowHiding (inherited from CommandBar) | Gets or sets whether the CommandBar can be hidden at run-time by the end user.
Caption (inherited from CommandBar) | Gets or sets the description displayed in the customization dialogs and in the caption of the floating CommandBar.
Command (inherited from CommandBar) | Gets the command object which was associated with the CommandBar when it was created.
DockedColumn (inherited from CommandBar) | Gets or sets the column (within the dock area) in which the CommandBar is docked.
DockedContentExtent | Return or sets the size of the taskbar. Either its width or height depending on where it is docked.
DockedPosition (inherited from CommandBar) | Gets or sets the current location of the CommandBar (left, right, top, bottom, floating)
DockedRow (inherited from CommandBar) | Gets or sets the row (within the dock area) in which the CommandBar is docked.
Enabled (inherited from CommandBar) | Gets or sets the enabled state of the CommandBar.
FillEntireRow (inherited from CommandBar) | Gets or sets whether the CommandBar will take up the entire dock area row, even if it doesn't have enough tools to fill the area.
HomeTaskPaneToolKey | Returns or sets the key of the tool representing the "home" item. The SelectedTaskPaneToolKey will be set to the HomeTaskPaneToolKey when the home navigation button is pressed.
Key (inherited from CommandBar) | The Key of the CommandBar in the CommandBarCollection
NavigationButtonStyle | Returns or sets a value indicating how the navigation buttons are used to navigate the items in a TaskPane and can also be used to hide the navigation buttons.
SelectedTaskPaneToolKey | Returns or sets the key of the currently selected task pane tool.
ShowHomeButton | Returns or sets a value indicating whether the home navigation button will be displayed.
ShowInToolbarList (inherited from CommandBar) | Gets or sets whether the CommandBar shows up in the customization dialog at runtime.
Tag (inherited from CommandBar) | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tools (inherited from CommandBar) | Gets the ToolsCollection containing the tools to display in the CommandBar.
Visible (inherited from CommandBar) | Gets or sets whether the CommandBar is visible.

See Also

TaskBar Class | Aveva.ApplicationFramework.Presentation Namespace


DockedContentExtent Property

Common Application Framework

TaskBar.DockedContentExtent Property

Return or sets the size of the taskbar. Either its width or height depending on where it is docked.

public abstract int DockedContentExtent {get; set;}

See Also

TaskBar Class | Aveva.ApplicationFramework.Presentation Namespace


HomeTaskPaneToolKey Property

Common Application Framework

TaskBar.HomeTaskPaneToolKey Property

Returns or sets the key of the tool representing the "home" item. The SelectedTaskPaneToolKey will be set to the HomeTaskPaneToolKey when the home navigation button is pressed.

public abstract string HomeTaskPaneToolKey {get; set;}

See Also

TaskBar Class | Aveva.ApplicationFramework.Presentation Namespace


NavigationButtonStyle Property

Common Application Framework

TaskBar.NavigationButtonStyle Property

Returns or sets a value indicating how the navigation buttons are used to navigate the items in a TaskPane and can also be used to hide the navigation buttons.

public abstract NavigationButtonStyle NavigationButtonStyle {get; set;}

See Also

TaskBar Class | Aveva.ApplicationFramework.Presentation Namespace


SelectedTaskPaneToolKey Property

Common Application Framework

TaskBar.SelectedTaskPaneToolKey Property

Returns or sets the key of the currently selected task pane tool.

public abstract string SelectedTaskPaneToolKey {get; set;}

See Also

TaskBar Class | Aveva.ApplicationFramework.Presentation Namespace


ShowHomeButton Property

Common Application Framework

TaskBar.ShowHomeButton Property

Returns or sets a value indicating whether the home navigation button will be displayed.

public abstract bool ShowHomeButton {get; set;}

See Also

TaskBar Class | Aveva.ApplicationFramework.Presentation Namespace


TaskBar Events

The events of the TaskBar class are listed below. For a complete list of TaskBar class members, see the TaskBar Members topic.

Public Instance Events

AfterTaskPaneToolSelected | Event raised after a task pane tool is selected
Closed (inherited from CommandBar) | Event raised when the CommandBar is Closed
Opened (inherited from CommandBar) | Event raised when the CommandBar is Opened

See Also

TaskBar Class | Aveva.ApplicationFramework.Presentation Namespace


TaskBar.AfterTaskPaneToolSelected Event

Event raised after a task pane tool is selected

public event ToolEventHandler AfterTaskPaneToolSelected;

Event Data

The event handler receives an argument of type ToolEventArgs containing data related to this event. The following ToolEventArgs property provides information specific to this event.

Property | Description
Key | The tools key.

See Also

TaskBar Class | Aveva.ApplicationFramework.Presentation Namespace


TaskPaneTool Class

Class used to represent a single item in a TaskPane.

For a list of all members of this type, see TaskPaneTool Members.

System.Object
Aveva.ApplicationFramework.Presentation.TaskPaneTool

public abstract class TaskPaneTool : ITool

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

TaskPaneTool Members | Aveva.ApplicationFramework.Presentation Namespace


TaskPaneTool Members

TaskPaneTool overview

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Control | Gets or sets the control displayed in the TaskPaneTool. NOTE: The Control must also be added to the main windows controls collection.
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ToolClick Occurs when the TaskPaneTool is selected.

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


TaskPaneTool Properties

The properties of the TaskPaneTool class are listed below. For a complete list of TaskPaneTool class members, see the TaskPaneTool Members topic.

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Control | Gets or sets the control displayed in the TaskPaneTool. NOTE: The Control must also be added to the main windows controls collection.
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


Caption Property

Common Application Framework

TaskPaneTool.Caption Property

Gets or sets the tool caption

public abstract string Caption {get; set;}

Implements

ITool.Caption

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


Category Property

Common Application Framework

TaskPaneTool.Category Property

Gets or sets the tools category

public abstract string Category {get; set;}

Implements

ITool.Category

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


Control Property

Common Application Framework

TaskPaneTool.Control Property

Gets or sets the control displayed in the TaskPaneTool. NOTE: The Control must also be added to the main windows controls collection.

public abstract System.Windows.Forms.Control Control {get; set;}

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

TaskPaneTool.Enabled Property

Gets or sets the enabled state of the tool.

public abstract bool Enabled {get; set;}

Implements

ITool.Enabled

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

TaskPaneTool.Image Property

Gets or sets the image displayed on the tool

public abstract System.Drawing.Image Image {get; set;}

Implements

ITool.Image

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


IsFirstInGroup Property

Common Application Framework

TaskPaneTool.IsFirstInGroup Property

Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.

public abstract bool IsFirstInGroup {get; set;}

Implements

ITool.IsFirstInGroup

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

TaskPaneTool.Key Property

The Key of the tool in the RootToolsCollection

public abstract string Key {get;}

Implements

ITool.Key

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


Shortcut Property

Common Application Framework

TaskPaneTool.Shortcut Property

Gets or sets the shortcut associated with a tool.

public abstract System.Windows.Forms.Shortcut Shortcut {get; set;}

Implements

ITool.Shortcut

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

TaskPaneTool.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a tool.

public abstract object Tag {get; set;}

Implements

ITool.Tag

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

TaskPaneTool.Tooltip Property

Gets or sets the tools tooltip

public abstract string Tooltip {get; set;}

Implements

ITool.Tooltip

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

TaskPaneTool.Value Property

Gets or sets the value of the tool.

public abstract object Value {get; set;}

Implements

ITool.Value

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

TaskPaneTool.Visible Property

Gets or sets the visibility of the tool.

public abstract bool Visible {get; set;}

Implements

ITool.Visible

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


TaskPaneTool Events

The events of the TaskPaneTool class are listed below. For a complete list of TaskPaneTool class members, see the TaskPaneTool Members topic.

Public Instance Events

ToolClick Occurs when the TaskPaneTool is selected.

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


TaskPaneTool.ToolClick Event

Occurs when the TaskPaneTool is selected.

public event EventHandler ToolClick;

See Also

TaskPaneTool Class | Aveva.ApplicationFramework.Presentation Namespace


TextBoxTool Class

Represents a TextBoxTool.

For a list of all members of this type, see TextBoxTool Members.

System.Object
Aveva.ApplicationFramework.Presentation.TextBoxTool

public abstract class TextBoxTool : ITool

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

TextBoxTool Members | Aveva.ApplicationFramework.Presentation Namespace


TextBoxTool Members

TextBoxTool overview

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Command | Gets the command object which was associated with the tool when it was created.
DisplayText | Gets or sets the text displayed in the tool.
Editable | Gets or sets whether the TextBoxTool is editable
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
MaxLength | Gets or sets the maximum allowable length of the text that can be entered in the TextBoxTool
PasswordChar | Gets or sets a value indicating how the characters typed by a user are displayed.
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.
Width | Gets or sets the width of the tool.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ToolClick | Occurs when Enter key is pressed while text field has focus.
ToolValueChanged | Occurs when the value of the TextBoxTool changes

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


TextBoxTool Properties

The properties of the TextBoxTool class are listed below. For a complete list of TextBoxTool class members, see the TextBoxTool Members topic.

Public Instance Properties

Caption | Gets or sets the tool caption
Category | Gets or sets the tools category
Command | Gets the command object which was associated with the tool when it was created.
DisplayText | Gets or sets the text displayed in the tool.
Editable | Gets or sets whether the TextBoxTool is editable
Enabled | Gets or sets the enabled state of the tool.
Image | Gets or sets the image displayed on the tool
IsFirstInGroup | Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.
Key | The Key of the tool in the RootToolsCollection
MaxLength | Gets or sets the maximum allowable length of the text that can be entered in the TextBoxTool
PasswordChar | Gets or sets a value indicating how the characters typed by a user are displayed.
Shortcut | Gets or sets the shortcut associated with a tool.
Tag | Gets or sets the tag property which can be used to logically attach another object or value to a tool.
Tooltip | Gets or sets the tools tooltip
Value | Gets or sets the value of the tool.
Visible | Gets or sets the visibility of the tool.
Width | Gets or sets the width of the tool.

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Caption Property

Common Application Framework

TextBoxTool.Caption Property

Gets or sets the tool caption

public abstract string Caption {get; set;}

Implements

ITool.Caption

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Category Property

Common Application Framework

TextBoxTool.Category Property

Gets or sets the tools category

public abstract string Category {get; set;}

Implements

ITool.Category

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Command Property

Common Application Framework

TextBoxTool.Command Property

Gets the command object which was associated with the tool when it was created.

public abstract Command Command {get;}

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


DisplayText Property

Common Application Framework

TextBoxTool.DisplayText Property

Gets or sets the text displayed in the tool.

public abstract string DisplayText {get; set;}

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Editable Property

Common Application Framework

TextBoxTool.Editable Property

Gets or sets whether the TextBoxTool is editable

public abstract bool Editable {get; set;}

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

TextBoxTool.Enabled Property

Gets or sets the enabled state of the tool.

public abstract bool Enabled {get; set;}

Implements

ITool.Enabled

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

TextBoxTool.Image Property

Gets or sets the image displayed on the tool

public abstract System.Drawing.Image Image {get; set;}

Implements

ITool.Image

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


IsFirstInGroup Property

Common Application Framework

TextBoxTool.IsFirstInGroup Property

Gets or sets a flag which indicated whether an instance tool is the first in a tool group. A separator will be displayed before a tool if this property is set to true.

public abstract bool IsFirstInGroup {get; set;}

Implements

ITool.IsFirstInGroup

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

TextBoxTool.Key Property

The Key of the tool in the RootToolsCollection

public abstract string Key {get;}

Implements

ITool.Key

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


MaxLength Property

Common Application Framework

TextBoxTool.MaxLength Property

Gets or sets the maximum allowable length of the text that can be entered in the TextBoxTool

public abstract int MaxLength {get; set;}

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


PasswordChar Property

Common Application Framework

TextBoxTool.PasswordChar Property

Gets or sets a value indicating how the characters typed by a user are displayed.

public abstract string PasswordChar {get; set;}

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Shortcut Property

Common Application Framework

TextBoxTool.Shortcut Property

Gets or sets the shortcut associated with a tool.

public abstract System.Windows.Forms.Shortcut Shortcut {get; set;}

Implements

ITool.Shortcut

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tag Property

Common Application Framework

TextBoxTool.Tag Property

Gets or sets the tag property which can be used to logically attach another object or value to a tool.

public abstract object Tag {get; set;}

Implements

ITool.Tag

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Tooltip Property

Common Application Framework

TextBoxTool.Tooltip Property

Gets or sets the tools tooltip

public abstract string Tooltip {get; set;}

Implements

ITool.Tooltip

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Value Property

Common Application Framework

TextBoxTool.Value Property

Gets or sets the value of the tool.

public abstract object Value {get; set;}

Implements

ITool.Value

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Visible Property

Common Application Framework

TextBoxTool.Visible Property

Gets or sets the visibility of the tool.

public abstract bool Visible {get; set;}

Implements

ITool.Visible

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


Width Property

Common Application Framework

TextBoxTool.Width Property

Gets or sets the width of the tool.

public abstract int Width {get; set;}

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


TextBoxTool Events

The events of the TextBoxTool class are listed below. For a complete list of TextBoxTool class members, see the TextBoxTool Members topic.

Public Instance Events

ToolClick | Occurs when Enter key is pressed while text field has focus.
ToolValueChanged | Occurs when the value of the TextBoxTool changes

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


TextBoxTool.ToolClick Event

Occurs when Enter key is pressed while text field has focus.

public event EventHandler ToolClick;

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


TextBoxTool.ToolValueChanged Event

Occurs when the value of the TextBoxTool changes

public event EventHandler ToolValueChanged;

See Also

TextBoxTool Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours Class

Class which provides a number of Theme colours

For a list of all members of this type, see ThemeColours Members.

System.Object
Aveva.ApplicationFramework.Presentation.ThemeColours

public class ThemeColours

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

ThemeColours Members | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours Members

ThemeColours overview

Public Static Fields

HighlightMouseDownGradientDark | Theme Colour
HighlightMouseDownGradientLight | Theme Colour
HighlightNotPressedGradientDark | Theme Colour
HighlightNotPressedGradientLight | Theme Colour
HighlightPressedGradientDark | Theme Colour
HighlightPressedGradientLight | Theme Colour
MainMenuBarGradientDark | Theme Colour
MainMenuBarGradientLight | Theme Colour
PressedGradientDark | Theme Colour
PressedGradientLight | Theme Colour
SplitterBorder | Theme Colour
ToolbarGradientDark | Theme Colour
ToolbarGradientLight | Theme Colour

Public Instance Constructors

ThemeColours Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours Constructor

public ThemeColours();

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours Fields

The fields of the ThemeColours class are listed below. For a complete list of ThemeColours class members, see the ThemeColours Members topic.

Public Static Fields

HighlightMouseDownGradientDark | Theme Colour
HighlightMouseDownGradientLight | Theme Colour
HighlightNotPressedGradientDark | Theme Colour
HighlightNotPressedGradientLight | Theme Colour
HighlightPressedGradientDark | Theme Colour
HighlightPressedGradientLight | Theme Colour
MainMenuBarGradientDark | Theme Colour
MainMenuBarGradientLight | Theme Colour
PressedGradientDark | Theme Colour
PressedGradientLight | Theme Colour
SplitterBorder | Theme Colour
ToolbarGradientDark | Theme Colour
ToolbarGradientLight | Theme Colour

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours.HighlightMouseDownGradientDark Field

Theme Colour

public static Color HighlightMouseDownGradientDark;

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours.HighlightMouseDownGradientLight Field

Theme Colour

public static Color HighlightMouseDownGradientLight;

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours.HighlightNotPressedGradientDark Field

Theme Colour

public static Color HighlightNotPressedGradientDark;

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours.HighlightNotPressedGradientLight Field

Theme Colour

public static Color HighlightNotPressedGradientLight;

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours.HighlightPressedGradientDark Field

Theme Colour

public static Color HighlightPressedGradientDark;

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours.HighlightPressedGradientLight Field

Theme Colour

public static Color HighlightPressedGradientLight;

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours.MainMenuBarGradientDark Field

Theme Colour

public static Color MainMenuBarGradientDark;

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours.MainMenuBarGradientLight Field

Theme Colour

public static Color MainMenuBarGradientLight;

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours.PressedGradientDark Field

Theme Colour

public static Color PressedGradientDark;

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours.PressedGradientLight Field

Theme Colour

public static Color PressedGradientLight;

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours.SplitterBorder Field

Theme Colour

public static Color SplitterBorder;

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours.ToolbarGradientDark Field

Theme Colour

public static Color ToolbarGradientDark;

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ThemeColours.ToolbarGradientLight Field

Theme Colour

public static Color ToolbarGradientLight;

See Also

ThemeColours Class | Aveva.ApplicationFramework.Presentation Namespace


ToolEventArgs Class

Provides information for Tool events.

For a list of all members of this type, see ToolEventArgs Members.

System.Object
System.EventArgs
Aveva.ApplicationFramework.Presentation.ToolEventArgs

public class ToolEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

ToolEventArgs Members | Aveva.ApplicationFramework.Presentation Namespace


ToolEventArgs Members

ToolEventArgs overview

Public Instance Constructors

ToolEventArgs Constructor

Public Instance Properties

Key The tools key.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ToolEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


ToolEventArgs Constructor

public ToolEventArgs(
string key
);

Parameters

key

See Also

ToolEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


ToolEventArgs Properties

The properties of the ToolEventArgs class are listed below. For a complete list of ToolEventArgs class members, see the ToolEventArgs Members topic.

Public Instance Properties

Key The tools key.

See Also

ToolEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


Key Property

Common Application Framework

ToolEventArgs.Key Property

The tools key.

public string Key {get;}

See Also

ToolEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


ToolEventHandler Delegate

Represents the method that will handle Tool related events.

public delegate void ToolEventHandler(
object sender,
ToolEventArgs args
);

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


ToolsCollection Class

Class representing a ToolsCollection.

For a list of all members of this type, see ToolsCollection Members.

System.Object
Aveva.ApplicationFramework.Presentation.ToolsCollection

public abstract class ToolsCollection : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

ToolsCollection Members | Aveva.ApplicationFramework.Presentation Namespace


ToolsCollection Members

ToolsCollection overview

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Overloaded. Indexer to get the instance of the tool at the specified index of the ToolsCollection as an ITool object.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

AddTool | Create an instance of a root tool and add it to the ToolsCollection, with the same Key.
Clear | Remove all tool instances from the ToolsCollection.
Contains | Determine if the tool instance with the specified Key exists in the ToolsCollection.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the Collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Get the index of the tool with given Key from the ToolsCollection. Returns -1 if tool is not in the collection.
InsertTool | Create an instance of a root tool and insert it into the ToolsCollection at the given index, with the same Key.
Remove | Remove the tool instance with the specified Key from the ToolsCollection.
RemoveAt | Remove the tool instance at the specified index position from the ToolsCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


ToolsCollection Properties

The properties of the ToolsCollection class are listed below. For a complete list of ToolsCollection class members, see the ToolsCollection Members topic.

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Overloaded. Indexer to get the instance of the tool at the specified index of the ToolsCollection as an ITool object.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Count Property

Common Application Framework

ToolsCollection.Count Property

Gets the number of elements contained in the collection.

public abstract int Count {get;}

Implements

ICollection.Count

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


IsSynchronized Property

Common Application Framework

ToolsCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public abstract bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Item Property

Common Application Framework

ToolsCollection.Item Property

Indexer to get the instance of the tool at the specified index of the ToolsCollection as an ITool object.

Overload List

Indexer to get the instance of the tool at the specified index of the ToolsCollection as an ITool object.

public abstract ITool this[int] {get;}

Indexer to get the instance of the tool with given Key from the ToolsCollection as an ITool object.

public abstract ITool this[string] {get;}

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Item Property (Int32)

Common Application Framework

ToolsCollection.Item Property (Int32)

Indexer to get the instance of the tool at the specified index of the ToolsCollection as an ITool object.

public abstract ITool this[
int index
] {get;}

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | ToolsCollection.Item Overload List


Item Property (String)

Common Application Framework

ToolsCollection.Item Property (String)

Indexer to get the instance of the tool with given Key from the ToolsCollection as an ITool object.

public abstract ITool this[
string key
] {get;}

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace | ToolsCollection.Item Overload List


SyncRoot Property

Common Application Framework

ToolsCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public abstract object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


ToolsCollection Methods

The methods of the ToolsCollection class are listed below. For a complete list of ToolsCollection class members, see the ToolsCollection Members topic.

Public Instance Methods

AddTool | Create an instance of a root tool and add it to the ToolsCollection, with the same Key.
Clear | Remove all tool instances from the ToolsCollection.
Contains | Determine if the tool instance with the specified Key exists in the ToolsCollection.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the Collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Get the index of the tool with given Key from the ToolsCollection. Returns -1 if tool is not in the collection.
InsertTool | Create an instance of a root tool and insert it into the ToolsCollection at the given index, with the same Key.
Remove | Remove the tool instance with the specified Key from the ToolsCollection.
RemoveAt | Remove the tool instance at the specified index position from the ToolsCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


ToolsCollection.AddTool Method

Create an instance of a root tool and add it to the ToolsCollection, with the same Key.

public abstract ITool AddTool(
string key
);

Parameters

key
Key of the root tool in the RootToolsCollection.

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


ToolsCollection.Clear Method

Remove all tool instances from the ToolsCollection.

public abstract void Clear();

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


ToolsCollection.Contains Method

Determine if the tool instance with the specified Key exists in the ToolsCollection.

public abstract bool Contains(
string key
);

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


ToolsCollection.CopyTo Method

Copies the elements of the collection to an Array, starting at a particular Array index.

public abstract void CopyTo(
Array array,
int index
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from collection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Implements

ICollection.CopyTo

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


ToolsCollection.GetEnumerator Method

Returns an enumerator that can iterate through the Collection.

public abstract IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


ToolsCollection.IndexOf Method

Get the index of the tool with given Key from the ToolsCollection. Returns -1 if tool is not in the collection.

public abstract int IndexOf(
string key
);

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


ToolsCollection.InsertTool Method

Create an instance of a root tool and insert it into the ToolsCollection at the given index, with the same Key.

public abstract ITool InsertTool(
string key,
int index
);

Parameters

key
Key of the root tool in the RootToolsCollection.
index
Position which tool instance will have in ToolsCollection.

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


ToolsCollection.Remove Method

Remove the tool instance with the specified Key from the ToolsCollection.

public abstract void Remove(
string key
);

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


ToolsCollection.RemoveAt Method

Remove the tool instance at the specified index position from the ToolsCollection.

public abstract void RemoveAt(
int index
);

See Also

ToolsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


UpdateOptions Enumeration

Enumerations for the options for automatically updating the state of a MenuTool following state changes to an child StateButtonTool or ButtonTool. This enumeration can be treated as a bit field; that is, a set of flags. Bit fields can be combined using a bitwise OR operation.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum UpdateOptions

Members

Member Name | Description | Value
None | No automatic updating. | 0
Image | Update image of MenuTool. | 1
ToolTip | Update tooltip of MenuTool. | 2
Command | Update associated command of MenuTool. | 4
CheckedState | Update Checked state of MenuTool. | 8
All | Update Image, Tooltip, Command and CheckedState. | 15
ResetOnUncheck | Restore MenuTool state after unchecking a child StateButtonTool. | 16

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


ValueList Class

Class representing a ValueList, which is a collection of ValueListItem objects. It is typicall assigned to a ComboBoxTool as the list of options displayed as the dropdown list.

For a list of all members of this type, see ValueList Members.

System.Object
Aveva.ApplicationFramework.Presentation.ValueList

public abstract class ValueList : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

ValueList Members | Aveva.ApplicationFramework.Presentation Namespace


ValueList Members

ValueList overview

Public Instance Properties

Count | Gets the number of elements contained in the collection.
DisplayStyle | Set the DisplayStyle for the ValueList. ValueListDisplayStyle enumeration specifies what properties of ValueListItems will be displayed.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Overloaded. Indexer to get the ValuListItem at the given postion index from the ValueList.
SortStyle | Set the SortStyle for the ValueList. ValueListSortStyle enumeration specifies how the ValueListItems will be sorted for display.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Overloaded. Create and add a new ValueListItem object to the ValueList.
Clear | Remove all ValueListItems from the ValueList.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the Collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Overloaded. Create and insert a new ValueListItem object into the ValueList.
Remove | Overloaded. Remove the ValueListItem at the specified index position from the ValueList.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace


ValueList Properties

The properties of the ValueList class are listed below. For a complete list of ValueList class members, see the ValueList Members topic.

Public Instance Properties

Count | Gets the number of elements contained in the collection.
DisplayStyle | Set the DisplayStyle for the ValueList. ValueListDisplayStyle enumeration specifies what properties of ValueListItems will be displayed.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Overloaded. Indexer to get the ValuListItem at the given postion index from the ValueList.
SortStyle | Set the SortStyle for the ValueList. ValueListSortStyle enumeration specifies how the ValueListItems will be sorted for display.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace


Count Property

Common Application Framework

ValueList.Count Property

Gets the number of elements contained in the collection.

public abstract int Count {get;}

Implements

ICollection.Count

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace


DisplayStyle Property

Common Application Framework

ValueList.DisplayStyle Property

Set the DisplayStyle for the ValueList. ValueListDisplayStyle enumeration specifies what properties of ValueListItems will be displayed.

public abstract ValueListDisplayStyle DisplayStyle {get; set;}

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace


IsSynchronized Property

Common Application Framework

ValueList.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public abstract bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace


ValueListItem Class

Class representing a ValueListItem, which can be a member of ValueList.

For a list of all members of this type, see ValueListItem Members.

System.Object
Aveva.ApplicationFramework.Presentation.ValueListItem

public abstract class ValueListItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

ValueListItem Members | Aveva.ApplicationFramework.Presentation Namespace


Item Property (Int32)

Common Application Framework

ValueList.Item Property (Int32)

Indexer to get the ValuListItem at the given postion index from the ValueList.

public abstract ValueListItem this[
int index
] {get;}

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace | ValueList.Item Overload List


Item Property (String)

Common Application Framework

ValueList.Item Property (String)

Indexer to get the ValuListItem with given DisplayText from the ValueList.

public abstract ValueListItem this[
string DisplayText
] {get;}

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace | ValueList.Item Overload List


SortStyle Property

Common Application Framework

ValueList.SortStyle Property

Set the SortStyle for the ValueList. ValueListSortStyle enumeration specifies how the ValueListItems will be sorted for display.

public abstract ValueListSortStyle SortStyle {get; set;}

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace


SyncRoot Property

Common Application Framework

ValueList.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public abstract object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace


ValueList Methods

The methods of the ValueList class are listed below. For a complete list of ValueList class members, see the ValueList Members topic.

Public Instance Methods

Add | Overloaded. Create and add a new ValueListItem object to the ValueList.
Clear | Remove all ValueListItems from the ValueList.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the Collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert | Overloaded. Create and insert a new ValueListItem object into the ValueList.
Remove | Overloaded. Remove the ValueListItem at the specified index position from the ValueList.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace


Add Method

Common Application Framework

ValueList.Add Method

Create and add a new ValueListItem object to the ValueList. Note that the ValueListItem created will contain the given DisplayText and a default DataValue with value (object)DislayText.

Overload List

Create and add a new ValueListItem object to the ValueList. Note that the ValueListItem created will contain the given DisplayText and a default DataValue with value (object)DislayText.

public abstract ValueListItem Add(string);

Create and add a new ValueListItem object to the ValueList.

public abstract ValueListItem Add(string,object);

Create and add a new ValueListItem object to the ValueList.

public abstract ValueListItem Add(string,object,Image);

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace


ValueList.Add Method (String)

Create and add a new ValueListItem object to the ValueList. Note that the ValueListItem created will contain the given DisplayText and a default DataValue with value (object)DislayText.

public abstract ValueListItem Add(
string DisplayText
);

Parameters

DisplayText
ValueListItem display text.

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace | ValueList.Add Overload List


ValueList.Add Method (String, Object)

Create and add a new ValueListItem object to the ValueList.

public abstract ValueListItem Add(
string DisplayText,
object DataValue
);

Parameters

DisplayText
ValueListItem display text.
DataValue
ValueListItem DataValue object.

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace | ValueList.Add Overload List


ValueList.Add Method (String, Object, Image)

Create and add a new ValueListItem object to the ValueList.

public abstract ValueListItem Add(
string DisplayText,
object DataValue,
Image image
);

Parameters

DisplayText
ValueListItem display text.
DataValue
ValueListItem DataValue object.
image
ValueListItem display icon.

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace | ValueList.Add Overload List


ValueList.Clear Method

Remove all ValueListItems from the ValueList.

public abstract void Clear();

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace


ValueList.CopyTo Method

Copies the elements of the collection to an Array, starting at a particular Array index.

public abstract void CopyTo(
Array array,
int index
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from collection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Implements

ICollection.CopyTo

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace


ValueList.GetEnumerator Method

Returns an enumerator that can iterate through the Collection.

public abstract IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace


Insert Method

Common Application Framework

ValueList.Insert Method

Create and insert a new ValueListItem object into the ValueList. Note that the ValueListItem created will contain the given DisplayText and a default DataValue with value (object)DislayText.

Overload List

Create and insert a new ValueListItem object into the ValueList. Note that the ValueListItem created will contain the given DisplayText and a default DataValue with value (object)DislayText.

public abstract ValueListItem Insert(string,int);

Create and insert a new ValueListItem object into the ValueList.

public abstract ValueListItem Insert(string,object,Image,int);

Create and insert a new ValueListItem object into the ValueList.

public abstract ValueListItem Insert(string,object,int);

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace


ValueList.Insert Method (String, Int32)

Create and insert a new ValueListItem object into the ValueList. Note that the ValueListItem created will contain the given DisplayText and a default DataValue with value (object)DislayText.

public abstract ValueListItem Insert(
string DisplayText,
int index
);

Parameters

DisplayText
ValueListItem display text.
index
Index position of new ValueListItem in the ValueList

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace | ValueList.Insert Overload List


ValueList.Insert Method (String, Object, Image, Int32)

Create and insert a new ValueListItem object into the ValueList.

public abstract ValueListItem Insert(
string DisplayText,
object DataValue,
Image image,
int index
);

Parameters

DisplayText
ValueListItem display text.
DataValue
ValueListItem DataValue object.
image
ValueListItem display icon.
index
Index position of new ValueListItem in the ValueList

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace | ValueList.Insert Overload List


ValueList.Insert Method (String, Object, Int32)

Create and insert a new ValueListItem object into the ValueList.

public abstract ValueListItem Insert(
string DisplayText,
object DataValue,
int index
);

Parameters

DisplayText
ValueListItem display text.
DataValue
ValueListItem DataValue object.
index
Index position of new ValueListItem in the ValueList

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace | ValueList.Insert Overload List


Remove Method

Common Application Framework

ValueList.Remove Method

Remove the specified ValueListItem object from the ValueList.

Overload List

Remove the specified ValueListItem object from the ValueList.

public abstract void Remove(ValueListItem);

Remove the ValueListItem at the specified index position from the ValueList.

public abstract void Remove(int);

Remove the ValueListItem with the specified DisplayText from the ValueList.

public abstract void Remove(string);

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace


ValueList.Remove Method (ValueListItem)

Remove the specified ValueListItem object from the ValueList.

public abstract void Remove(
ValueListItem valueListItem
);

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace | ValueList.Remove Overload List


ValueList.Remove Method (Int32)

Remove the ValueListItem at the specified index position from the ValueList.

public abstract void Remove(
int index
);

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace | ValueList.Remove Overload List


ValueList.Remove Method (String)

Remove the ValueListItem with the specified DisplayText from the ValueList.

public abstract void Remove(
string DisplayText
);

See Also

ValueList Class | Aveva.ApplicationFramework.Presentation Namespace | ValueList.Remove Overload List


ValueListDisplayStyle Enumeration

Enumeration for specifying what property of a value list item will be displayed in each item of the DropDown list

public enum ValueListDisplayStyle

Members

Member Name | Description
DataValue | Text associated with the data value is display in the drop down list.
DataValueAndPicture | Text associated with the data value and also picture that a value list item's appearance object is assigned to will be displayed.
Default | Default value list display style.
DisplayText | Display text value assigned to the value list item will be displayed in each item of the drop down list.
DisplayTextAndPicture | Display text and also picture that a value list item's appearance object is assigned to will be displayed.
Picture | Only the picture will be displayed in each item of the drop down list.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


ValueListItem Members

ValueListItem overview

Public Instance Properties

DataValue | Gets or sets the DataValue Object for this item in the ValueList.
DisplayText | Gets or sets the text which will be displayed for this item in the ValueList.
Image | Gets or sets the Icon which may be displayed for this item in the ValueList.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ValueListItem Class | Aveva.ApplicationFramework.Presentation Namespace


ValueListItem Properties

The properties of the ValueListItem class are listed below. For a complete list of ValueListItem class members, see the ValueListItem Members topic.

Public Instance Properties

DataValue | Gets or sets the DataValue Object for this item in the ValueList.
DisplayText | Gets or sets the text which will be displayed for this item in the ValueList.
Image | Gets or sets the Icon which may be displayed for this item in the ValueList.

See Also

ValueListItem Class | Aveva.ApplicationFramework.Presentation Namespace


DataValue Property

Common Application Framework

ValueListItem.DataValue Property

Gets or sets the DataValue Object for this item in the ValueList.

public abstract object DataValue {get; set;}

See Also

ValueListItem Class | Aveva.ApplicationFramework.Presentation Namespace


DisplayText Property

Common Application Framework

ValueListItem.DisplayText Property

Gets or sets the text which will be displayed for this item in the ValueList.

public abstract string DisplayText {get; set;}

See Also

ValueListItem Class | Aveva.ApplicationFramework.Presentation Namespace


Image Property

Common Application Framework

ValueListItem.Image Property

Gets or sets the Icon which may be displayed for this item in the ValueList.

public abstract System.Drawing.Image Image {get; set;}

See Also

ValueListItem Class | Aveva.ApplicationFramework.Presentation Namespace


ValueListSortStyle Enumeration

Enumeration for specifying how value list items will be sorted when displaying value list items in a drop down list

public enum ValueListSortStyle

Members

Member Name | Description
Ascending | Sort ascending by display text.
AscendingByValue | Sort ascending by value.
Descending | Sort descending by display text.
DescendingByValue | Sort descending by value.
None | No sorting.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


WindowEventArgs Class

Provides data for the WindowAdded event.

For a list of all members of this type, see WindowEventArgs Members.

System.Object
System.EventArgs
Aveva.ApplicationFramework.Presentation.WindowEventArgs

public class WindowEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

WindowEventArgs Members | Aveva.ApplicationFramework.Presentation Namespace


WindowEventArgs Members

WindowEventArgs overview

Public Instance Constructors

WindowEventArgs Constructor Initialize a new instance of a WindowEventArgs class

Public Instance Properties

Window Gets the Window object associated with the event

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WindowEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


WindowEventArgs Constructor

Initialize a new instance of a WindowEventArgs class

public WindowEventArgs(
IWindow window
);

Parameters

window
The IWindow object

See Also

WindowEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


WindowEventArgs Properties

The properties of the WindowEventArgs class are listed below. For a complete list of WindowEventArgs class members, see the WindowEventArgs Members topic.

Public Instance Properties

Window Gets the Window object associated with the event

See Also

WindowEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


Window Property

Common Application Framework

WindowEventArgs.Window Property

Gets the Window object associated with the event

public IWindow Window {get;}

See Also

WindowEventArgs Class | Aveva.ApplicationFramework.Presentation Namespace


WindowEventHandler Delegate

Represents the method that will handle Window related events.

public delegate void WindowEventHandler(
object sender,
WindowEventArgs args
);

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

Aveva.ApplicationFramework.Presentation Namespace


WindowManager Class

Provides access to window related facilities.

For a list of all members of this type, see WindowManager Members.

System.Object
Aveva.ApplicationFramework.Presentation.WindowManager

public abstract class WindowManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

WindowManager Members | Aveva.ApplicationFramework.Presentation Namespace


WindowManager Members

WindowManager overview

Public Static Properties

Instance Get instance of window manager

Public Instance Properties

Enabled | Get or set a property which controls the enabled state of all docked windows
MainForm | Gets the main application Form
SplashScreen | Gets the splashscreen object.
StatusBar | Gets the StatusBar object.
TabbedMdi | Gets or sets whether MDI windows are displayed as tabbed windows.
Windows | Gets the WindowCollection object.

Public Instance Methods

CreateDockedWindow | Creates and adds to the WindowsCollection a new DockedWindow.
CreateMdiWindow | Creates and adds to the WindowsCollection a new MdiWindow
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadWindowLayout | Loads the docked window layout.
SaveWindowLayout | Saves the docked window layout.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

WindowAdded | Event Raised when a new window is added.
WindowLayoutLoaded | Event Raised when window layout is loaded

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


WindowManager Properties

The properties of the WindowManager class are listed below. For a complete list of WindowManager class members, see the WindowManager Members topic.

Public Static Properties

Instance Get instance of window manager

Public Instance Properties

Enabled | Get or set a property which controls the enabled state of all docked windows
MainForm | Gets the main application Form
SplashScreen | Gets the splashscreen object.
StatusBar | Gets the StatusBar object.
TabbedMdi | Gets or sets whether MDI windows are displayed as tabbed windows.
Windows | Gets the WindowCollection object.

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


Enabled Property

Common Application Framework

WindowManager.Enabled Property

Get or set a property which controls the enabled state of all docked windows

public abstract bool Enabled {get; set;}

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


Instance Property

Common Application Framework

WindowManager.Instance Property

Get instance of window manager

public static WindowManager Instance {get; set;}

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


MainForm Property

Common Application Framework

WindowManager.MainForm Property

Gets the main application Form

public abstract System.Windows.Forms.Form MainForm {get;}

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


SplashScreen Property

Common Application Framework

WindowManager.SplashScreen Property

Gets the splashscreen object.

public abstract SplashScreen SplashScreen {get;}

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


StatusBar Property

Common Application Framework

WindowManager.StatusBar Property

Gets the StatusBar object.

public abstract StatusBar StatusBar {get;}

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


TabbedMdi Property

Common Application Framework

WindowManager.TabbedMdi Property

Gets or sets whether MDI windows are displayed as tabbed windows.

public abstract bool TabbedMdi {get; set;}

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


Windows Property

Common Application Framework

WindowManager.Windows Property

Gets the WindowCollection object.

public abstract WindowsCollection Windows {get;}

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


WindowManager Methods

The methods of the WindowManager class are listed below. For a complete list of WindowManager class members, see the WindowManager Members topic.

Public Instance Methods

CreateDockedWindow | Creates and adds to the WindowsCollection a new DockedWindow.
CreateMdiWindow | Creates and adds to the WindowsCollection a new MdiWindow
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadWindowLayout | Loads the docked window layout.
SaveWindowLayout | Saves the docked window layout.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


WindowManager.CreateDockedWindow Method

Creates and adds to the WindowsCollection a new DockedWindow.

public abstract DockedWindow CreateDockedWindow(
string key,
string title,
Control control,
DockedPosition position
);

Parameters

key
Window key in the WindowsCollection.
title
Window title.
control
Control to display in the docked window.
position
Window DockPosition.

Return Value

New DockedWindow created.

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


WindowManager.CreateMdiWindow Method

Creates and adds to the WindowsCollection a new MdiWindow

public abstract MdiWindow CreateMdiWindow(
string key,
string title,
Control control
);

Parameters

key
Window key in the WindowsCollection.
title
Window title.
control
Control to display in the docked window.

Return Value

New MdiWindow created

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


WindowManager.LoadWindowLayout Method

Loads the docked window layout.

public abstract void LoadWindowLayout();

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


WindowManager.SaveWindowLayout Method

Saves the docked window layout.

public abstract void SaveWindowLayout();

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


WindowManager Events

The events of the WindowManager class are listed below. For a complete list of WindowManager class members, see the WindowManager Members topic.

Public Instance Events

WindowAdded | Event Raised when a new window is added.
WindowLayoutLoaded | Event Raised when window layout is loaded

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


WindowManager.WindowAdded Event

Event Raised when a new window is added.

public event WindowEventHandler WindowAdded;

Event Data

The event handler receives an argument of type WindowEventArgs containing data related to this event. The following WindowEventArgs property provides information specific to this event.

Property | Description
Window | Gets the Window object associated with the event

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


WindowManager.WindowLayoutLoaded Event

Event Raised when window layout is loaded

public event EventHandler WindowLayoutLoaded;

See Also

WindowManager Class | Aveva.ApplicationFramework.Presentation Namespace


WindowsCollection Class

Provides access to a collection of application windows.

For a list of all members of this type, see WindowsCollection Members.

System.Object
Aveva.ApplicationFramework.Presentation.WindowsCollection

public abstract class WindowsCollection : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.ApplicationFramework.Presentation

Assembly: Aveva.ApplicationFramework.Presentation (in Aveva.ApplicationFramework.Presentation.dll)

See Also

WindowsCollection Members | Aveva.ApplicationFramework.Presentation Namespace


WindowsCollection Members

WindowsCollection overview

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer which returns an IWindow interface for the window with the given key.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

ContainsKey | Determines whether the WindowCollection contains a specific key.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Remove the window with the given key from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WindowsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


WindowsCollection Properties

The properties of the WindowsCollection class are listed below. For a complete list of WindowsCollection class members, see the WindowsCollection Members topic.

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Indexer which returns an IWindow interface for the window with the given key.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

WindowsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Count Property

Common Application Framework

WindowsCollection.Count Property

Gets the number of elements contained in the collection.

public abstract int Count {get;}

Implements

ICollection.Count

See Also

WindowsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


IsSynchronized Property

Common Application Framework

WindowsCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public abstract bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

WindowsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Item Property

Common Application Framework

WindowsCollection.Item Property

Indexer which returns an IWindow interface for the window with the given key.

public abstract IWindow this[
string key
] {get;}

See Also

WindowsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


SyncRoot Property

Common Application Framework

WindowsCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public abstract object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

WindowsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


WindowsCollection Methods

The methods of the WindowsCollection class are listed below. For a complete list of WindowsCollection class members, see the WindowsCollection Members topic.

Public Instance Methods

ContainsKey | Determines whether the WindowCollection contains a specific key.
CopyTo | Copies the elements of the collection to an Array, starting at a particular Array index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Remove the window with the given key from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WindowsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


WindowsCollection.ContainsKey Method

Determines whether the WindowCollection contains a specific key.

public abstract bool ContainsKey(
string key
);

Parameters

key
The key to locate in the WindowCollection.

Return Value

See Also

WindowsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


WindowsCollection.CopyTo Method

Copies the elements of the collection to an Array, starting at a particular Array index.

public abstract void CopyTo(
Array array,
int index
);

Parameters

array
The one-dimensional Array that is the destination of the elements copied from collection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Implements

ICollection.CopyTo

See Also

WindowsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


WindowsCollection.GetEnumerator Method

Returns an enumerator that can iterate through the collection.

public abstract IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

WindowsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


WindowsCollection.Remove Method

Remove the window with the given key from the collection.

public abstract void Remove(
string key
);

Parameters

key
The key of the window to remove.

See Also

WindowsCollection Class | Aveva.ApplicationFramework.Presentation Namespace


Aveva.ApplicationFramework.PresentationHierarchy

Common Application Framework

Aveva.ApplicationFramework.Presentation Hierarchy

System.Object
Aveva.ApplicationFramework.Presentation.ButtonTool ---- Aveva.ApplicationFramework.Presentation.ITool
Aveva.ApplicationFramework.Presentation.ComboBoxTool ---- Aveva.ApplicationFramework.Presentation.ITool
Aveva.ApplicationFramework.Presentation.Command
Aveva.ApplicationFramework.Presentation.CommandBar
Aveva.ApplicationFramework.Presentation.TaskBar
Aveva.ApplicationFramework.Presentation.CommandBarManager ---- System.ComponentModel.ISupportInitialize
Aveva.ApplicationFramework.Presentation.CommandBarsCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
Aveva.ApplicationFramework.Presentation.CommandExecutor
Aveva.ApplicationFramework.Presentation.CommandManager
Aveva.ApplicationFramework.Presentation.CommandsCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
Aveva.ApplicationFramework.Presentation.CommandTypesCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
Aveva.ApplicationFramework.Presentation.ContainerTool ---- Aveva.ApplicationFramework.Presentation.ITool
Aveva.ApplicationFramework.Presentation.DockedWindow ---- Aveva.ApplicationFramework.Presentation.IWindow
Aveva.ApplicationFramework.Presentation.DragDropDirector
Aveva.ApplicationFramework.Presentation.DropTarget
Aveva.ApplicationFramework.Presentation.FontListTool ---- Aveva.ApplicationFramework.Presentation.ITool
Aveva.ApplicationFramework.Presentation.HtmlHelp
Aveva.ApplicationFramework.Presentation.IApplicationInfo
Aveva.ApplicationFramework.Presentation.IStatusBarPanel
Aveva.ApplicationFramework.Presentation.ITool
Aveva.ApplicationFramework.Presentation.IWindow
Aveva.ApplicationFramework.Presentation.LabelTool ---- Aveva.ApplicationFramework.Presentation.ITool
Aveva.ApplicationFramework.Presentation.ListTool ---- Aveva.ApplicationFramework.Presentation.ITool
Aveva.ApplicationFramework.Presentation.MdiWindow ---- Aveva.ApplicationFramework.Presentation.IWindow
Aveva.ApplicationFramework.Presentation.MdiWindowListTool ---- Aveva.ApplicationFramework.Presentation.ITool
Aveva.ApplicationFramework.Presentation.MenuTool ---- Aveva.ApplicationFramework.Presentation.ITool
Aveva.ApplicationFramework.Presentation.PopupColorPickerTool ---- Aveva.ApplicationFramework.Presentation.ITool
Aveva.ApplicationFramework.Presentation.PopupContainerTool ---- Aveva.ApplicationFramework.Presentation.ITool
Aveva.ApplicationFramework.Presentation.ResourceManager
Aveva.ApplicationFramework.Presentation.ResourceSet
Aveva.ApplicationFramework.Presentation.RootToolsCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
Aveva.ApplicationFramework.Presentation.SplashScreen
Aveva.ApplicationFramework.Presentation.StateButtonTool ---- Aveva.ApplicationFramework.Presentation.ITool
Aveva.ApplicationFramework.Presentation.StatusBar
Aveva.ApplicationFramework.Presentation.StatusBarPanelsCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
Aveva.ApplicationFramework.Presentation.StatusBarTextPanel ---- Aveva.ApplicationFramework.Presentation.IStatusBarPanel
Aveva.ApplicationFramework.Presentation.TaskPaneTool ---- Aveva.ApplicationFramework.Presentation.ITool
Aveva.ApplicationFramework.Presentation.TextBoxTool ---- Aveva.ApplicationFramework.Presentation.ITool
Aveva.ApplicationFramework.Presentation.ThemeColours
Aveva.ApplicationFramework.Presentation.ToolsCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
Aveva.ApplicationFramework.Presentation.ValueList ---- System.Collections.ICollection, System.Collections.IEnumerable
Aveva.ApplicationFramework.Presentation.ValueListItem
Aveva.ApplicationFramework.Presentation.WindowManager
Aveva.ApplicationFramework.Presentation.WindowsCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
System.Collections.ArrayList ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
Aveva.ApplicationFramework.Presentation.CommandList
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aveva.ApplicationFramework.Presentation.CommandBarEventHandler
Aveva.ApplicationFramework.Presentation.CommandEventHandler
Aveva.ApplicationFramework.Presentation.DropTargetEventHandler
Aveva.ApplicationFramework.Presentation.ToolEventHandler
Aveva.ApplicationFramework.Presentation.WindowEventHandler
System.EventArgs
Aveva.ApplicationFramework.Presentation.CommandBarEventArgs
Aveva.ApplicationFramework.Presentation.CommandEventArgs
Aveva.ApplicationFramework.Presentation.DropTargetEventArgs
Aveva.ApplicationFramework.Presentation.ToolEventArgs
Aveva.ApplicationFramework.Presentation.WindowEventArgs
System.ComponentModel.CancelEventArgs
Aveva.ApplicationFramework.Presentation.CancelClosingEventArgs
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aveva.ApplicationFramework.Presentation.CommandState
Aveva.ApplicationFramework.Presentation.CustomizationType
Aveva.ApplicationFramework.Presentation.DockedPosition
Aveva.ApplicationFramework.Presentation.DockGroupStyle
Aveva.ApplicationFramework.Presentation.DropDownArrowStyle
Aveva.ApplicationFramework.Presentation.NavigationButtonStyle
Aveva.ApplicationFramework.Presentation.PanelSizingMode
Aveva.ApplicationFramework.Presentation.PopupStyle
Aveva.ApplicationFramework.Presentation.StandardImage
Aveva.ApplicationFramework.Presentation.UpdateOptions
Aveva.ApplicationFramework.Presentation.ValueListDisplayStyle
Aveva.ApplicationFramework.Presentation.ValueListSortStyle

See Also

Aveva.ApplicationFramework.Presentation Namespace


Aveva.ApplicationFrameworkHierarchy

Common Application Framework

Aveva.ApplicationFramework Hierarchy

System.Object
Aveva.ApplicationFramework.Addin
Aveva.ApplicationFramework.AddinManager
Aveva.ApplicationFramework.AddinsCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
Aveva.ApplicationFramework.IAddin
Aveva.ApplicationFramework.ServiceManager ---- System.ComponentModel.Design.IServiceContainer, System.IServiceProvider
Aveva.ApplicationFramework.SettingsGroup ---- System.Collections.ICollection, System.Collections.IEnumerable
Aveva.ApplicationFramework.SettingsGroupsCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
Aveva.ApplicationFramework.SettingsManager
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aveva.ApplicationFramework.AddinEventHandler
Aveva.ApplicationFramework.ServiceEventHandler
System.EventArgs
Aveva.ApplicationFramework.AddinEventArgs
Aveva.ApplicationFramework.ServiceEventArgs

See Also

Aveva.ApplicationFramework Namespace