Aveva.Pdms.Piping.Fabrication

AVEVA Piping .NET Public Interface

Aveva.Pdms.Piping.Fabrication Namespace

Namespace hierarchy

Classes

Class | Description
BendingMachineResult | Summary description for BendingMachineResult.
FabricationMachineManager | Summary description for FabricationMachineManager.
PipePieceManager | Pipe Piece Manager.
PipeSpoolManager | Summary description for PipeSpoolManager.
WeldingMachineResult | Summary description for WeldingMachineResult.

Enumerations

Enumeration | Description
FabricationMachineManager.ClutchEndPriorityType |
©AVEVA Solutions Ltd 2007


BendingMachineResult Class

Summary description for BendingMachineResult.

For a list of all members of this type, see BendingMachineResult Members.

System.Object
Aveva.Pdms.Piping.Fabrication.BendingMachineResult

public abstract class BendingMachineResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Piping.Fabrication

Assembly: Aveva.Pdms.Piping (in Aveva.Pdms.Piping.dll)

See Also

BendingMachineResult Members | Aveva.Pdms.Piping.Fabrication Namespace


BendingMachineResult Members

BendingMachineResult overview

Public Instance Properties

AllBendsSameRadius
BendingDirectionForward
BendingMachine
BendsNotMitred
CutLength
EndsExcessPassed
FailureResolvable
FeedExcessModificationsRequired
FeedExcessPassed
FinishedLength
FlangeModifiedPassed
ModificationsRequired
Pass
PipePieceEndExcess
PipePieceEndFlangeManuallyWelded
PipePieceFeedExcess
PipePieceStartExcess
PipePieceStartFlangeManuallyWelded
ValidBendRadius
ValidInitialFeedLength
ValidMaterial
ValidOD
ValidWallThickness
WithinCollisionPlanes

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


BendingMachineResult Properties

The properties of the BendingMachineResult class are listed below. For a complete list of BendingMachineResult class members, see the BendingMachineResult Members topic.

Public Instance Properties

AllBendsSameRadius
BendingDirectionForward
BendingMachine
BendsNotMitred
CutLength
EndsExcessPassed
FailureResolvable
FeedExcessModificationsRequired
FeedExcessPassed
FinishedLength
FlangeModifiedPassed
ModificationsRequired
Pass
PipePieceEndExcess
PipePieceEndFlangeManuallyWelded
PipePieceFeedExcess
PipePieceStartExcess
PipePieceStartFlangeManuallyWelded
ValidBendRadius
ValidInitialFeedLength
ValidMaterial
ValidOD
ValidWallThickness
WithinCollisionPlanes

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


AllBendsSameRadius Property

BendingMachineResult.AllBendsSameRadius Property

public abstract bool AllBendsSameRadius {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


BendingDirectionForward Property

BendingMachineResult.BendingDirectionForward Property

public abstract bool BendingDirectionForward {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


BendingMachine Property

BendingMachineResult.BendingMachine Property

public abstract Aveva.Pdms.Database.DbElement BendingMachine {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


BendsNotMitred Property

BendingMachineResult.BendsNotMitred Property

public abstract bool BendsNotMitred {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


CutLength Property

BendingMachineResult.CutLength Property

public abstract double CutLength {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


EndsExcessPassed Property

BendingMachineResult.EndsExcessPassed Property

public abstract bool EndsExcessPassed {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


FailureResolvable Property

BendingMachineResult.FailureResolvable Property

public abstract bool FailureResolvable {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


FeedExcessModificationsRequired Property

BendingMachineResult.FeedExcessModificationsRequired Property

public abstract bool FeedExcessModificationsRequired {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


FeedExcessPassed Property

BendingMachineResult.FeedExcessPassed Property

public abstract bool FeedExcessPassed {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


FinishedLength Property

BendingMachineResult.FinishedLength Property

public abstract double FinishedLength {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


FlangeModifiedPassed Property

BendingMachineResult.FlangeModifiedPassed Property

public abstract bool FlangeModifiedPassed {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


ModificationsRequired Property

BendingMachineResult.ModificationsRequired Property

public abstract bool ModificationsRequired {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


Pass Property

BendingMachineResult.Pass Property

public abstract bool Pass {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


PipePieceEndExcess Property

BendingMachineResult.PipePieceEndExcess Property

public abstract double PipePieceEndExcess {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


PipePieceEndFlangeManuallyWelded Property

BendingMachineResult.PipePieceEndFlangeManuallyWelded Property

public abstract bool PipePieceEndFlangeManuallyWelded {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


PipePieceFeedExcess Property

BendingMachineResult.PipePieceFeedExcess Property

public abstract double[] PipePieceFeedExcess {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


PipePieceStartExcess Property

BendingMachineResult.PipePieceStartExcess Property

public abstract double PipePieceStartExcess {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


PipePieceStartFlangeManuallyWelded Property

BendingMachineResult.PipePieceStartFlangeManuallyWelded Property

public abstract bool PipePieceStartFlangeManuallyWelded {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


ValidBendRadius Property

BendingMachineResult.ValidBendRadius Property

public abstract bool ValidBendRadius {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


ValidInitialFeedLength Property

BendingMachineResult.ValidInitialFeedLength Property

public abstract bool ValidInitialFeedLength {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


ValidMaterial Property

BendingMachineResult.ValidMaterial Property

public abstract bool ValidMaterial {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


ValidOD Property

BendingMachineResult.ValidOD Property

public abstract bool ValidOD {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


ValidWallThickness Property

BendingMachineResult.ValidWallThickness Property

public abstract bool ValidWallThickness {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


WithinCollisionPlanes Property

BendingMachineResult.WithinCollisionPlanes Property

public abstract bool WithinCollisionPlanes {get;}

See Also

BendingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


FabricationMachineManager Class

Summary description for FabricationMachineManager.

For a list of all members of this type, see FabricationMachineManager Members.

System.Object
Aveva.Pdms.Piping.Fabrication.FabricationMachineManager

public abstract class FabricationMachineManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Piping.Fabrication

Assembly: Aveva.Pdms.Piping (in Aveva.Pdms.Piping.dll)

See Also

FabricationMachineManager Members | Aveva.Pdms.Piping.Fabrication Namespace


FabricationMachineManager Members

FabricationMachineManager overview

Public Static Properties

AddEndExcess
AddExcessBetweenBends
ChangeFlangeToManual
CheckStockLength
ClutchEndPriority
DisplaySimulation
FirstFeedNegative
MaximumMaterialLength

Public Static Methods

BendingMachineAcceptsPipePiece |
CanFabricatePipePiece |
GetBendingMachineResult | Overloaded.
GetWeldingMachineResult | Overloaded.
RevalidatePipePiece |
ScanElements |
SetBendingMachine |
SetWeldingMachine |
WeldingMachineAcceptsPipePiece |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


FabricationMachineManager Properties

The properties of the FabricationMachineManager class are listed below. For a complete list of FabricationMachineManager class members, see the FabricationMachineManager Members topic.

Public Static Properties

AddEndExcess
AddExcessBetweenBends
ChangeFlangeToManual
CheckStockLength
ClutchEndPriority
DisplaySimulation
FirstFeedNegative
MaximumMaterialLength

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


AddEndExcess Property

FabricationMachineManager.AddEndExcess Property

public static bool AddEndExcess {get; set;}

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


AddExcessBetweenBends Property

FabricationMachineManager.AddExcessBetweenBends Property

public static bool AddExcessBetweenBends {get; set;}

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


ChangeFlangeToManual Property

FabricationMachineManager.ChangeFlangeToManual Property

public static bool ChangeFlangeToManual {get; set;}

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


CheckStockLength Property

FabricationMachineManager.CheckStockLength Property

public static bool CheckStockLength {get; set;}

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


ClutchEndPriority Property

FabricationMachineManager.ClutchEndPriority Property

public static FabricationMachineManager.ClutchEndPriorityType ClutchEndPriority {get; set;}

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


DisplaySimulation Property

FabricationMachineManager.DisplaySimulation Property

public static bool DisplaySimulation {get; set;}

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


FirstFeedNegative Property

FabricationMachineManager.FirstFeedNegative Property

public static bool FirstFeedNegative {get; set;}

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


MaximumMaterialLength Property

FabricationMachineManager.MaximumMaterialLength Property

public static double MaximumMaterialLength {get; set;}

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


FabricationMachineManager Methods

The methods of the FabricationMachineManager class are listed below. For a complete list of FabricationMachineManager class members, see the FabricationMachineManager Members topic.

Public Static Methods

BendingMachineAcceptsPipePiece |
CanFabricatePipePiece |
GetBendingMachineResult | Overloaded.
GetWeldingMachineResult | Overloaded.
RevalidatePipePiece |
ScanElements |
SetBendingMachine |
SetWeldingMachine |
WeldingMachineAcceptsPipePiece |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


FabricationMachineManager.BendingMachineAcceptsPipePiece Method

public static bool BendingMachineAcceptsPipePiece(
DbElement pipePiece
);

Parameters

pipePiece

Return Value

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


FabricationMachineManager.CanFabricatePipePiece Method

public static bool CanFabricatePipePiece(
DbElement pipePiece
);

Parameters

pipePiece

Return Value

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


GetBendingMachineResult Method

FabricationMachineManager.GetBendingMachineResult Method

Overload List

public static BendingMachineResult GetBendingMachineResult();

public static BendingMachineResult GetBendingMachineResult(DbElement);

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


FabricationMachineManager.GetBendingMachineResult Method ()

public static BendingMachineResult GetBendingMachineResult();

Return Value

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace | FabricationMachineManager.GetBendingMachineResult Overload List


FabricationMachineManager.GetBendingMachineResult Method (DbElement)

public static BendingMachineResult GetBendingMachineResult(
DbElement pipePiece
);

Parameters

pipePiece

Return Value

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace | FabricationMachineManager.GetBendingMachineResult Overload List


GetWeldingMachineResult Method

FabricationMachineManager.GetWeldingMachineResult Method

Overload List

public static WeldingMachineResult GetWeldingMachineResult();

public static WeldingMachineResult GetWeldingMachineResult(DbElement);

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


FabricationMachineManager.GetWeldingMachineResult Method ()

public static WeldingMachineResult GetWeldingMachineResult();

Return Value

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace | FabricationMachineManager.GetWeldingMachineResult Overload List


FabricationMachineManager.GetWeldingMachineResult Method (DbElement)

public static WeldingMachineResult GetWeldingMachineResult(
DbElement pipePiece
);

Parameters

pipePiece

Return Value

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace | FabricationMachineManager.GetWeldingMachineResult Overload List


FabricationMachineManager.RevalidatePipePiece Method

public static bool RevalidatePipePiece(
DbElement pipePiece
);

Parameters

pipePiece

Return Value

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


FabricationMachineManager.ScanElements Method

public static DbElement[] ScanElements(
DbElement ce,
DbElementType type
);

Parameters

ce
type

Return Value

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


FabricationMachineManager.SetBendingMachine Method

public static void SetBendingMachine(
DbElement machine
);

Parameters

machine

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


FabricationMachineManager.SetWeldingMachine Method

public static void SetWeldingMachine(
DbElement machine
);

Parameters

machine

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


FabricationMachineManager.WeldingMachineAcceptsPipePiece Method

public static bool WeldingMachineAcceptsPipePiece(
DbElement pipePiece
);

Parameters

pipePiece

Return Value

See Also

FabricationMachineManager Class | Aveva.Pdms.Piping.Fabrication Namespace


FabricationMachineManager.ClutchEndPriorityType Enumeration

public enum FabricationMachineManager.ClutchEndPriorityType

Members

Member Name | Description
CLUTCH_DONT_CARE |
CLUTCH_FLANGE |
CLUTCH_NO_FLANGE |

Requirements

Namespace: Aveva.Pdms.Piping.Fabrication

Assembly: Aveva.Pdms.Piping (in Aveva.Pdms.Piping.dll)

See Also

Aveva.Pdms.Piping.Fabrication Namespace


PipePieceManager Class

Pipe Piece Manager.

For a list of all members of this type, see PipePieceManager Members.

System.Object
Aveva.Pdms.Piping.Fabrication.PipePieceManager

public abstract class PipePieceManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Piping.Fabrication

Assembly: Aveva.Pdms.Piping (in Aveva.Pdms.Piping.dll)

See Also

PipePieceManager Members | Aveva.Pdms.Piping.Fabrication Namespace


PipePieceManager Members

PipePieceManager overview

Public Static Methods

GeneratePipePieces
GetLastError
GetPipePieces
RemovePipePieces

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PipePieceManager Class | Aveva.Pdms.Piping.Fabrication Namespace


PipePieceManager Methods

The methods of the PipePieceManager class are listed below. For a complete list of PipePieceManager class members, see the PipePieceManager Members topic.

Public Static Methods

GeneratePipePieces
GetLastError
GetPipePieces
RemovePipePieces

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PipePieceManager Class | Aveva.Pdms.Piping.Fabrication Namespace


PipePieceManager.GeneratePipePieces Method

public static bool GeneratePipePieces(
DbElement element
);

Parameters

element

See Also

PipePieceManager Class | Aveva.Pdms.Piping.Fabrication Namespace


PipePieceManager.GetLastError Method

public static PdmsMessage GetLastError();

Return Value

See Also

PipePieceManager Class | Aveva.Pdms.Piping.Fabrication Namespace


PipePieceManager.GetPipePieces Method

public static DbElement[] GetPipePieces(
DbElement element
);

Parameters

element

Return Value

See Also

PipePieceManager Class | Aveva.Pdms.Piping.Fabrication Namespace


PipePieceManager.RemovePipePieces Method

public static bool RemovePipePieces(
DbElement pipe
);

Parameters

pipe

See Also

PipePieceManager Class | Aveva.Pdms.Piping.Fabrication Namespace


PipeSpoolManager Class

Summary description for PipeSpoolManager.

For a list of all members of this type, see PipeSpoolManager Members.

System.Object
Aveva.Pdms.Piping.Fabrication.PipeSpoolManager

public abstract class PipeSpoolManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Piping.Fabrication

Assembly: Aveva.Pdms.Piping (in Aveva.Pdms.Piping.dll)

See Also

PipeSpoolManager Members | Aveva.Pdms.Piping.Fabrication Namespace


PipeSpoolManager Members

PipeSpoolManager overview

Public Static Methods

GeneratePipeSpoolsForPipe
GetLastError
GetPipePiecesForSpool
GetPipeSpoolForElement
RemovePipeSpools

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PipeSpoolManager Class | Aveva.Pdms.Piping.Fabrication Namespace


PipeSpoolManager Methods

The methods of the PipeSpoolManager class are listed below. For a complete list of PipeSpoolManager class members, see the PipeSpoolManager Members topic.

Public Static Methods

GeneratePipeSpoolsForPipe
GetLastError
GetPipePiecesForSpool
GetPipeSpoolForElement
RemovePipeSpools

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PipeSpoolManager Class | Aveva.Pdms.Piping.Fabrication Namespace


PipeSpoolManager.GeneratePipeSpoolsForPipe Method

public static bool GeneratePipeSpoolsForPipe(
DbElement pipe
);

Parameters

pipe

See Also

PipeSpoolManager Class | Aveva.Pdms.Piping.Fabrication Namespace


PipeSpoolManager.GetLastError Method

public static PdmsMessage GetLastError();

Return Value

See Also

PipeSpoolManager Class | Aveva.Pdms.Piping.Fabrication Namespace


PipeSpoolManager.GetPipePiecesForSpool Method

public static DbElement[] GetPipePiecesForSpool(
DbElement spool
);

Parameters

spool

Return Value

See Also

PipeSpoolManager Class | Aveva.Pdms.Piping.Fabrication Namespace


PipeSpoolManager.GetPipeSpoolForElement Method

public static DbElement[] GetPipeSpoolForElement(
DbElement element
);

Parameters

element

Return Value

See Also

PipeSpoolManager Class | Aveva.Pdms.Piping.Fabrication Namespace


PipeSpoolManager.RemovePipeSpools Method

public static bool RemovePipeSpools(
DbElement pipe
);

Parameters

pipe

Return Value

See Also

PipeSpoolManager Class | Aveva.Pdms.Piping.Fabrication Namespace


WeldingMachineResult Class

Summary description for WeldingMachineResult.

For a list of all members of this type, see WeldingMachineResult Members.

System.Object
Aveva.Pdms.Piping.Fabrication.WeldingMachineResult

public abstract class WeldingMachineResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Piping.Fabrication

Assembly: Aveva.Pdms.Piping (in Aveva.Pdms.Piping.dll)

See Also

WeldingMachineResult Members | Aveva.Pdms.Piping.Fabrication Namespace


WeldingMachineResult Members

WeldingMachineResult overview

Public Instance Properties

MaxWeldedFlanges
Pass
ValidEndFlangeGroup
ValidMaterial
ValidMaximumLength
ValidMinimumLength
ValidOD
ValidStartFlangeGroup
WeldingMachine

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WeldingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


WeldingMachineResult Properties

The properties of the WeldingMachineResult class are listed below. For a complete list of WeldingMachineResult class members, see the WeldingMachineResult Members topic.

Public Instance Properties

MaxWeldedFlanges
Pass
ValidEndFlangeGroup
ValidMaterial
ValidMaximumLength
ValidMinimumLength
ValidOD
ValidStartFlangeGroup
WeldingMachine

See Also

WeldingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


MaxWeldedFlanges Property

WeldingMachineResult.MaxWeldedFlanges Property

public abstract int MaxWeldedFlanges {get;}

See Also

WeldingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


Pass Property

WeldingMachineResult.Pass Property

public abstract bool Pass {get;}

See Also

WeldingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


ValidEndFlangeGroup Property

WeldingMachineResult.ValidEndFlangeGroup Property

public abstract bool ValidEndFlangeGroup {get;}

See Also

WeldingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


ValidMaterial Property

WeldingMachineResult.ValidMaterial Property

public abstract bool ValidMaterial {get;}

See Also

WeldingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


ValidMaximumLength Property

WeldingMachineResult.ValidMaximumLength Property

public abstract bool ValidMaximumLength {get;}

See Also

WeldingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


ValidMinimumLength Property

WeldingMachineResult.ValidMinimumLength Property

public abstract bool ValidMinimumLength {get;}

See Also

WeldingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


ValidOD Property

WeldingMachineResult.ValidOD Property

public abstract bool ValidOD {get;}

See Also

WeldingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


ValidStartFlangeGroup Property

WeldingMachineResult.ValidStartFlangeGroup Property

public abstract bool ValidStartFlangeGroup {get;}

See Also

WeldingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


WeldingMachine Property

WeldingMachineResult.WeldingMachine Property

public abstract Aveva.Pdms.Database.DbElement WeldingMachine {get;}

See Also

WeldingMachineResult Class | Aveva.Pdms.Piping.Fabrication Namespace


Aveva.Pdms.Piping.FabricationHierarchy

Aveva.Pdms.Piping.Fabrication Hierarchy

System.Object
Aveva.Pdms.Piping.Fabrication.BendingMachineResult
Aveva.Pdms.Piping.Fabrication.FabricationMachineManager
Aveva.Pdms.Piping.Fabrication.PipePieceManager
Aveva.Pdms.Piping.Fabrication.PipeSpoolManager
Aveva.Pdms.Piping.Fabrication.WeldingMachineResult
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aveva.Pdms.Piping.Fabrication.FabricationMachineManager.ClutchEndPriorityType

See Also

Aveva.Pdms.Piping.Fabrication Namespace