Aveva.Pdms.Shared

AVEVA Shared .NET Public Interface

Aveva.Pdms.Shared Namespace

Namespace hierarchy

Classes

Class | Description
Clipboard | Summary description for Clipboard.
CurrentElement |
CurrentElementChangedEventArgs | Event arguments for Current Element Changed event.
DatalListing | Summary description for DatalListing.
DatalListingEventArgs | Event arguments for Selection Changed event.
DatalListingForm | Summary description for DatalListing.
Selection | Summary description for Selection.
SelectionChangedEventArgs | Event arguments for Selection Changed event.

Delegates

Delegate | Description
CurrentElementChangedEventHandler | Current Element Changed event handler delegate.
InputAbortEventHandler | INPUT ABORT event handler delegate.
InputBeginEventHandler | INPUT BEGIN event handler delegate.
InputEndEventHandler | INPUT END event handler delegate.
SelectionChangedEventHandler | Selection Changed event handler delegate.

Enumerations

Enumeration | Description
EditMode |
©AVEVA Solutions Ltd 2007


Clipboard Class

Summary description for Clipboard.

For a list of all members of this type, see Clipboard Members.

System.Object
Aveva.Pdms.Shared.Clipboard

public abstract class Clipboard

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Shared

Assembly: Aveva.Pdms.Shared (in Aveva.Pdms.Shared.dll)

See Also

Clipboard Members | Aveva.Pdms.Shared Namespace


Clipboard Members

Clipboard overview

Public Static Fields

CurrentClipboard

Public Instance Properties

Members
Mode

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Clipboard Class | Aveva.Pdms.Shared Namespace


Clipboard Fields

The fields of the Clipboard class are listed below. For a complete list of Clipboard class members, see the Clipboard Members topic.

Public Static Fields

CurrentClipboard

See Also

Clipboard Class | Aveva.Pdms.Shared Namespace


Clipboard.CurrentClipboard Field

public static readonly Clipboard CurrentClipboard;

See Also

Clipboard Class | Aveva.Pdms.Shared Namespace


Clipboard Properties

The properties of the Clipboard class are listed below. For a complete list of Clipboard class members, see the Clipboard Members topic.

Public Instance Properties

Members
Mode

See Also

Clipboard Class | Aveva.Pdms.Shared Namespace


Members Property

AVEVA Shared .NET Public Interface

Clipboard.Members Property

public abstract Aveva.Pdms.Database.DbElement[] Members {get; set;}

See Also

Clipboard Class | Aveva.Pdms.Shared Namespace


Mode Property

AVEVA Shared .NET Public Interface

Clipboard.Mode Property

public abstract EditMode Mode {get; set;}

See Also

Clipboard Class | Aveva.Pdms.Shared Namespace


CurrentElement Class

For a list of all members of this type, see CurrentElement Members.

System.Object
Aveva.Pdms.Shared.CurrentElement

public abstract class CurrentElement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Shared

Assembly: Aveva.Pdms.Shared (in Aveva.Pdms.Shared.dll)

See Also

CurrentElement Members | Aveva.Pdms.Shared Namespace


CurrentElement Members

CurrentElement overview

Public Static Properties

Element Current Element (CE).

Public Static Methods

RaiseCurrentElementChanged Raise the Current Element Changed event.

Public Static Events

CurrentElementChanged Current Element Changed event.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CurrentElement Class | Aveva.Pdms.Shared Namespace


CurrentElement Properties

The properties of the CurrentElement class are listed below. For a complete list of CurrentElement class members, see the CurrentElement Members topic.

Public Static Properties

Element Current Element (CE).

See Also

CurrentElement Class | Aveva.Pdms.Shared Namespace


Element Property

AVEVA Shared .NET Public Interface

CurrentElement.Element Property

Current Element (CE).

public static Aveva.Pdms.Database.DbElement Element {get; set;}

See Also

CurrentElement Class | Aveva.Pdms.Shared Namespace


CurrentElement Methods

The methods of the CurrentElement class are listed below. For a complete list of CurrentElement class members, see the CurrentElement Members topic.

Public Static Methods

RaiseCurrentElementChanged Raise the Current Element Changed event.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CurrentElement Class | Aveva.Pdms.Shared Namespace


CurrentElement.RaiseCurrentElementChanged Method

Raise the Current Element Changed event.

public static void RaiseCurrentElementChanged(
object sender,
CurrentElementChangedEventArgs e
);

Parameters

sender
Object raising the event
e
Event arguments

See Also

CurrentElement Class | Aveva.Pdms.Shared Namespace


CurrentElement Events

The events of the CurrentElement class are listed below. For a complete list of CurrentElement class members, see the CurrentElement Members topic.

Public Static Events

CurrentElementChanged Current Element Changed event.

See Also

CurrentElement Class | Aveva.Pdms.Shared Namespace


CurrentElement.CurrentElementChanged Event

Current Element Changed event.

public static event CurrentElementChangedEventHandler CurrentElementChanged;

Event Data

The event handler receives an argument of type CurrentElementChangedEventArgs containing data related to this event. The following CurrentElementChangedEventArgs property provides information specific to this event.

Property | Description
Element | Element associated with event.

See Also

CurrentElement Class | Aveva.Pdms.Shared Namespace


CurrentElementChangedEventArgs Class

Event arguments for Current Element Changed event.

For a list of all members of this type, see CurrentElementChangedEventArgs Members.

System.Object
System.EventArgs
Aveva.Pdms.Shared.CurrentElementChangedEventArgs

public class CurrentElementChangedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Shared

Assembly: Aveva.Pdms.Shared (in Aveva.Pdms.Shared.dll)

See Also

CurrentElementChangedEventArgs Members | Aveva.Pdms.Shared Namespace


CurrentElementChangedEventArgs Members

CurrentElementChangedEventArgs overview

Public Instance Constructors

CurrentElementChangedEventArgs Constructor Constructor.

Public Instance Properties

Element Element associated with event.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CurrentElementChangedEventArgs Class | Aveva.Pdms.Shared Namespace


CurrentElementChangedEventArgs Constructor

Constructor.

public CurrentElementChangedEventArgs(
DbElement ele
);

Parameters

ele
Element to associate with event

See Also

CurrentElementChangedEventArgs Class | Aveva.Pdms.Shared Namespace


CurrentElementChangedEventArgs Properties

The properties of the CurrentElementChangedEventArgs class are listed below. For a complete list of CurrentElementChangedEventArgs class members, see the CurrentElementChangedEventArgs Members topic.

Public Instance Properties

Element Element associated with event.

See Also

CurrentElementChangedEventArgs Class | Aveva.Pdms.Shared Namespace


Element Property

AVEVA Shared .NET Public Interface

CurrentElementChangedEventArgs.Element Property

Element associated with event.

public Aveva.Pdms.Database.DbElement Element {get; set;}

See Also

CurrentElementChangedEventArgs Class | Aveva.Pdms.Shared Namespace


CurrentElementChangedEventHandler Delegate

Current Element Changed event handler delegate.

public delegate void CurrentElementChangedEventHandler(
object sender,
CurrentElementChangedEventArgs e
);

Requirements

Namespace: Aveva.Pdms.Shared

Assembly: Aveva.Pdms.Shared (in Aveva.Pdms.Shared.dll)

See Also

Aveva.Pdms.Shared Namespace


DatalListing Class

Summary description for DatalListing.

For a list of all members of this type, see DatalListing Members.

System.Object
Aveva.Pdms.Shared.DatalListing

public abstract class DatalListing

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Shared

Assembly: Aveva.Pdms.Shared (in Aveva.Pdms.Shared.dll)

See Also

DatalListing Members | Aveva.Pdms.Shared Namespace


DatalListing Members

DatalListing overview

Public Static Fields

Instance Instance of Abstract class

Public Static Methods

RaiseInputAbort | Raise the INPUT ABORT event.
RaiseInputBegin | Raise the INPUT BEGIN event.
RaiseInputEnd | Raise the INPUT BEGIN event.

Public Static Events

InputAbort | INPUT ABORT event.
InputBegin | INPUT BEGIN event.
InputEnd | INPUT END event.

Public Instance Properties

changes | True for Output Changes only (default false)
Elements | Array of DB Elements
fileName | Optional filename for output
LocateParentInTarget | If True, Output will create data under same named Parent element in Target db (default false)
ReplaceInTarget | If True, Output will Replace element of same name in Target db (default false)
screen | True for screen output, default false
session | Session to compare with

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
inputAbort | Special case input abort
inputBegin | Special case input begin
inputEnd | Special case input end
OutputListing | Output Datal to File and screen
ShowOptionsForm | Show Options Form
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


DatalListing Fields

The fields of the DatalListing class are listed below. For a complete list of DatalListing class members, see the DatalListing Members topic.

Public Static Fields

Instance Instance of Abstract class

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


DatalListing.Instance Field

Instance of Abstract class

public static readonly DatalListing Instance;

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


DatalListing Properties

The properties of the DatalListing class are listed below. For a complete list of DatalListing class members, see the DatalListing Members topic.

Public Instance Properties

changes | True for Output Changes only (default false)
Elements | Array of DB Elements
fileName | Optional filename for output
LocateParentInTarget | If True, Output will create data under same named Parent element in Target db (default false)
ReplaceInTarget | If True, Output will Replace element of same name in Target db (default false)
screen | True for screen output, default false
session | Session to compare with

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


changes Property

AVEVA Shared .NET Public Interface

DatalListing.changes Property

True for Output Changes only (default false)

public abstract bool changes {get; set;}

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


Elements Property

AVEVA Shared .NET Public Interface

DatalListing.Elements Property

Array of DB Elements

public abstract Aveva.Pdms.Database.DbElement[] Elements {get; set;}

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


fileName Property

AVEVA Shared .NET Public Interface

DatalListing.fileName Property

Optional filename for output

public abstract string fileName {get; set;}

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


LocateParentInTarget Property

AVEVA Shared .NET Public Interface

DatalListing.LocateParentInTarget Property

If True, Output will create data under same named Parent element in Target db (default false)

public abstract bool LocateParentInTarget {get; set;}

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


ReplaceInTarget Property

AVEVA Shared .NET Public Interface

DatalListing.ReplaceInTarget Property

If True, Output will Replace element of same name in Target db (default false)

public abstract bool ReplaceInTarget {get; set;}

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


screen Property

AVEVA Shared .NET Public Interface

DatalListing.screen Property

True for screen output, default false

public abstract bool screen {get; set;}

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


session Property

AVEVA Shared .NET Public Interface

DatalListing.session Property

Session to compare with

public abstract int session {get; set;}

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


DatalListing Methods

The methods of the DatalListing class are listed below. For a complete list of DatalListing class members, see the DatalListing Members topic.

Public Static Methods

RaiseInputAbort | Raise the INPUT ABORT event.
RaiseInputBegin | Raise the INPUT BEGIN event.
RaiseInputEnd | Raise the INPUT BEGIN event.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
inputAbort | Special case input abort
inputBegin | Special case input begin
inputEnd | Special case input end
OutputListing | Output Datal to File and screen
ShowOptionsForm | Show Options Form
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


DatalListing.InputAbort Event

INPUT ABORT event.

public static event InputAbortEventHandler InputAbort;

Event Data

The event handler receives an argument of type DatalListingEventArgs containing data related to this event. The following DatalListingEventArgs property provides information specific to this event.

Property | Description
Elements |

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


DatalListing.InputBegin Event

INPUT BEGIN event.

public static event InputBeginEventHandler InputBegin;

Event Data

The event handler receives an argument of type DatalListingEventArgs containing data related to this event. The following DatalListingEventArgs property provides information specific to this event.

Property | Description
Elements |

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


DatalListing.InputEnd Event

INPUT END event.

public static event InputEndEventHandler InputEnd;

Event Data

The event handler receives an argument of type DatalListingEventArgs containing data related to this event. The following DatalListingEventArgs property provides information specific to this event.

Property | Description
Elements |

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


DatalListing.OutputListing Method

Output Datal to File and screen

public abstract void OutputListing();

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


DatalListing.RaiseInputAbort Method

Raise the INPUT ABORT event.

public static void RaiseInputAbort(
object sender,
DatalListingEventArgs e
);

Parameters

sender
Object raising the event
e
Event arguments

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


DatalListing.RaiseInputBegin Method

Raise the INPUT BEGIN event.

public static void RaiseInputBegin(
object sender,
DatalListingEventArgs e
);

Parameters

sender
Object raising the event
e
Event arguments

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


DatalListing.RaiseInputEnd Method

Raise the INPUT BEGIN event.

public static void RaiseInputEnd(
object sender,
DatalListingEventArgs e
);

Parameters

sender
Object raising the event
e
Event arguments

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


DatalListing.ShowOptionsForm Method

Show Options Form

public abstract void ShowOptionsForm();

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


DatalListing Events

The events of the DatalListing class are listed below. For a complete list of DatalListing class members, see the DatalListing Members topic.

Public Static Events

InputAbort | INPUT ABORT event.
InputBegin | INPUT BEGIN event.
InputEnd | INPUT END event.

See Also

DatalListing Class | Aveva.Pdms.Shared Namespace


DatalListingEventArgs Class

Event arguments for Selection Changed event.

For a list of all members of this type, see DatalListingEventArgs Members.

System.Object
System.EventArgs
Aveva.Pdms.Shared.DatalListingEventArgs

public class DatalListingEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Shared

Assembly: Aveva.Pdms.Shared (in Aveva.Pdms.Shared.dll)

See Also

DatalListingEventArgs Members | Aveva.Pdms.Shared Namespace


DatalListingEventArgs Members

DatalListingEventArgs overview

Public Instance Constructors

DatalListingEventArgs Overloaded. Initializes a new instance of the DatalListingEventArgs class.

Public Instance Properties

Elements

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DatalListingEventArgs Class | Aveva.Pdms.Shared Namespace


DatalListingEventArgs Constructor

Constructor.

Overload List

Constructor.

public DatalListingEventArgs();

Constructor.

public DatalListingEventArgs(DbElement[]);

See Also

DatalListingEventArgs Class | Aveva.Pdms.Shared Namespace


DatalListingEventArgs Constructor ()

Constructor.

public DatalListingEventArgs();

See Also

DatalListingEventArgs Class | Aveva.Pdms.Shared Namespace | DatalListingEventArgs Constructor Overload List


DatalListingEventArgs Constructor (DbElement[])

Constructor.

public DatalListingEventArgs(
DbElement[] elements
);

See Also

DatalListingEventArgs Class | Aveva.Pdms.Shared Namespace | DatalListingEventArgs Constructor Overload List


DatalListingEventArgs Properties

The properties of the DatalListingEventArgs class are listed below. For a complete list of DatalListingEventArgs class members, see the DatalListingEventArgs Members topic.

Public Instance Properties

Elements

See Also

DatalListingEventArgs Class | Aveva.Pdms.Shared Namespace


Elements Property

AVEVA Shared .NET Public Interface

DatalListingEventArgs.Elements Property

public Aveva.Pdms.Database.DbElement[] Elements {get;}

See Also

DatalListingEventArgs Class | Aveva.Pdms.Shared Namespace


DatalListingForm Class

Summary description for DatalListing.

For a list of all members of this type, see DatalListingForm Members.

System.Object
Aveva.Pdms.Shared.DatalListingForm

public abstract class DatalListingForm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Shared

Assembly: Aveva.Pdms.Shared (in Aveva.Pdms.Shared.dll)

See Also

DatalListingForm Members | Aveva.Pdms.Shared Namespace


DatalListingForm Members

DatalListingForm overview

Public Static Fields

Instance Instance of Abstract class

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Show | Show Datal Listing form
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DatalListingForm Class | Aveva.Pdms.Shared Namespace


DatalListingForm Fields

The fields of the DatalListingForm class are listed below. For a complete list of DatalListingForm class members, see the DatalListingForm Members topic.

Public Static Fields

Instance Instance of Abstract class

See Also

DatalListingForm Class | Aveva.Pdms.Shared Namespace


DatalListingForm.Instance Field

Instance of Abstract class

public static readonly DatalListingForm Instance;

See Also

DatalListingForm Class | Aveva.Pdms.Shared Namespace


DatalListingForm Methods

The methods of the DatalListingForm class are listed below. For a complete list of DatalListingForm class members, see the DatalListingForm Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Show | Show Datal Listing form
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DatalListingForm Class | Aveva.Pdms.Shared Namespace


DatalListingForm.Show Method

Show Datal Listing form

public abstract void Show();

See Also

DatalListingForm Class | Aveva.Pdms.Shared Namespace


EditMode Enumeration

public enum EditMode

Members

Member Name | Description
None |
Move |
Copy |

Requirements

Namespace: Aveva.Pdms.Shared

Assembly: Aveva.Pdms.Shared (in Aveva.Pdms.Shared.dll)

See Also

Aveva.Pdms.Shared Namespace


InputAbortEventHandler Delegate

INPUT ABORT event handler delegate.

public delegate void InputAbortEventHandler(
object sender,
DatalListingEventArgs e
);

Requirements

Namespace: Aveva.Pdms.Shared

Assembly: Aveva.Pdms.Shared (in Aveva.Pdms.Shared.dll)

See Also

Aveva.Pdms.Shared Namespace


InputBeginEventHandler Delegate

INPUT BEGIN event handler delegate.

public delegate void InputBeginEventHandler(
object sender,
DatalListingEventArgs e
);

Requirements

Namespace: Aveva.Pdms.Shared

Assembly: Aveva.Pdms.Shared (in Aveva.Pdms.Shared.dll)

See Also

Aveva.Pdms.Shared Namespace


InputEndEventHandler Delegate

INPUT END event handler delegate.

public delegate void InputEndEventHandler(
object sender,
DatalListingEventArgs e
);

Requirements

Namespace: Aveva.Pdms.Shared

Assembly: Aveva.Pdms.Shared (in Aveva.Pdms.Shared.dll)

See Also

Aveva.Pdms.Shared Namespace


Selection Class

Summary description for Selection.

For a list of all members of this type, see Selection Members.

System.Object
Aveva.Pdms.Shared.Selection

public abstract class Selection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Shared

Assembly: Aveva.Pdms.Shared (in Aveva.Pdms.Shared.dll)

See Also

Selection Members | Aveva.Pdms.Shared Namespace


Selection Members

Selection overview

Public Static Fields

CurrentSelection

Public Static Methods

RaiseSelectionChanged Raise the Selection Changed event.

Public Static Events

SelectionChanged Current Element Changed event.

Public Instance Properties

Members

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Selection Class | Aveva.Pdms.Shared Namespace


Selection Fields

The fields of the Selection class are listed below. For a complete list of Selection class members, see the Selection Members topic.

Public Static Fields

CurrentSelection

See Also

Selection Class | Aveva.Pdms.Shared Namespace


Selection.CurrentSelection Field

public static readonly Selection CurrentSelection;

See Also

Selection Class | Aveva.Pdms.Shared Namespace


Selection Properties

The properties of the Selection class are listed below. For a complete list of Selection class members, see the Selection Members topic.

Public Instance Properties

Members

See Also

Selection Class | Aveva.Pdms.Shared Namespace


Members Property

AVEVA Shared .NET Public Interface

Selection.Members Property

public abstract Aveva.Pdms.Database.DbElement[] Members {get; set;}

See Also

Selection Class | Aveva.Pdms.Shared Namespace


Selection Methods

The methods of the Selection class are listed below. For a complete list of Selection class members, see the Selection Members topic.

Public Static Methods

RaiseSelectionChanged Raise the Selection Changed event.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Selection Class | Aveva.Pdms.Shared Namespace


Selection.RaiseSelectionChanged Method

Raise the Selection Changed event.

public static void RaiseSelectionChanged(
object sender,
SelectionChangedEventArgs e
);

Parameters

sender
Object raising the event
e
Event arguments

See Also

Selection Class | Aveva.Pdms.Shared Namespace


Selection Events

The events of the Selection class are listed below. For a complete list of Selection class members, see the Selection Members topic.

Public Static Events

SelectionChanged Current Element Changed event.

See Also

Selection Class | Aveva.Pdms.Shared Namespace


Selection.SelectionChanged Event

Current Element Changed event.

public static event SelectionChangedEventHandler SelectionChanged;

See Also

Selection Class | Aveva.Pdms.Shared Namespace


SelectionChangedEventArgs Class

Event arguments for Selection Changed event.

For a list of all members of this type, see SelectionChangedEventArgs Members.

System.Object
System.EventArgs
Aveva.Pdms.Shared.SelectionChangedEventArgs

public class SelectionChangedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Shared

Assembly: Aveva.Pdms.Shared (in Aveva.Pdms.Shared.dll)

See Also

SelectionChangedEventArgs Members | Aveva.Pdms.Shared Namespace


SelectionChangedEventArgs Members

SelectionChangedEventArgs overview

Public Instance Constructors

SelectionChangedEventArgs Constructor Constructor.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SelectionChangedEventArgs Class | Aveva.Pdms.Shared Namespace


SelectionChangedEventArgs Constructor

Constructor.

public SelectionChangedEventArgs();

See Also

SelectionChangedEventArgs Class | Aveva.Pdms.Shared Namespace


SelectionChangedEventHandler Delegate

Selection Changed event handler delegate.

public delegate void SelectionChangedEventHandler(
object sender,
SelectionChangedEventArgs e
);

Requirements

Namespace: Aveva.Pdms.Shared

Assembly: Aveva.Pdms.Shared (in Aveva.Pdms.Shared.dll)

See Also

Aveva.Pdms.Shared Namespace


Aveva.Pdms.SharedHierarchy

AVEVA Shared .NET Public Interface

Aveva.Pdms.Shared Hierarchy

System.Object
Aveva.Pdms.Shared.Clipboard
Aveva.Pdms.Shared.CurrentElement
Aveva.Pdms.Shared.DatalListing
Aveva.Pdms.Shared.DatalListingForm
Aveva.Pdms.Shared.Selection
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aveva.Pdms.Shared.CurrentElementChangedEventHandler
Aveva.Pdms.Shared.InputAbortEventHandler
Aveva.Pdms.Shared.InputBeginEventHandler
Aveva.Pdms.Shared.InputEndEventHandler
Aveva.Pdms.Shared.SelectionChangedEventHandler
System.EventArgs
Aveva.Pdms.Shared.CurrentElementChangedEventArgs
Aveva.Pdms.Shared.DatalListingEventArgs
Aveva.Pdms.Shared.SelectionChangedEventArgs
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aveva.Pdms.Shared.EditMode

See Also

Aveva.Pdms.Shared Namespace