Aveva.Pdms.Graphics

AVEVA Graphics .NET Public Interface

Aveva.Pdms.Graphics Namespace

Namespace hierarchy

Classes

Class | Description
Colour | Summary description for PdmsColour.
Colours | Summary description for Colours.
DrawList | Summary description for DrawList.
DrawListEventArgs | Summary description for DrawListEventArgs.
DrawListManager | Summary description for DrawListManager.
DrawListMember | Summary description for DrawListMember.
Units | Units formatting.

Delegates

Delegate | Description
DrawListEventHandler |

Enumerations

Enumeration | Description
DrawListChange |
©AVEVA Solutions Ltd 2007


Colour Class

Summary description for PdmsColour.

For a list of all members of this type, see Colour Members.

System.Object
Aveva.Pdms.Graphics.Colour

public abstract class Colour

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Graphics

Assembly: Aveva.Pdms.Graphics (in Aveva.Pdms.Graphics.dll)

See Also

Colour Members | Aveva.Pdms.Graphics Namespace


Colour Members

Colour overview

Public Instance Properties

Blue
Green
Index
Name
Red

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Colour Class | Aveva.Pdms.Graphics Namespace


Colour Properties

The properties of the Colour class are listed below. For a complete list of Colour class members, see the Colour Members topic.

Public Instance Properties

Blue
Green
Index
Name
Red

See Also

Colour Class | Aveva.Pdms.Graphics Namespace


Blue Property

AVEVA Graphics .NET Public Interface

Colour.Blue Property

public abstract int Blue {get;}

See Also

Colour Class | Aveva.Pdms.Graphics Namespace


Green Property

AVEVA Graphics .NET Public Interface

Colour.Green Property

public abstract int Green {get;}

See Also

Colour Class | Aveva.Pdms.Graphics Namespace


Index Property

AVEVA Graphics .NET Public Interface

Colour.Index Property

public abstract int Index {get;}

See Also

Colour Class | Aveva.Pdms.Graphics Namespace


Name Property

AVEVA Graphics .NET Public Interface

Colour.Name Property

public abstract string Name {get;}

See Also

Colour Class | Aveva.Pdms.Graphics Namespace


Red Property

AVEVA Graphics .NET Public Interface

Colour.Red Property

public abstract int Red {get;}

See Also

Colour Class | Aveva.Pdms.Graphics Namespace


Colours Class

Summary description for Colours.

For a list of all members of this type, see Colours Members.

System.Object
Aveva.Pdms.Graphics.Colours

public abstract class Colours

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Graphics

Assembly: Aveva.Pdms.Graphics (in Aveva.Pdms.Graphics.dll)

See Also

Colours Members | Aveva.Pdms.Graphics Namespace


Colours Members

Colours overview

Public Static Methods

ColourTable

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Colours Class | Aveva.Pdms.Graphics Namespace


Colours Methods

The methods of the Colours class are listed below. For a complete list of Colours class members, see the Colours Members topic.

Public Static Methods

ColourTable

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Colours Class | Aveva.Pdms.Graphics Namespace


Colours.ColourTable Method

public static Colour[] ColourTable();

Return Value

See Also

Colours Class | Aveva.Pdms.Graphics Namespace


DrawList Class

Summary description for DrawList.

For a list of all members of this type, see DrawList Members.

System.Object
Aveva.Pdms.Graphics.DrawList

public abstract class DrawList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Graphics

Assembly: Aveva.Pdms.Graphics (in Aveva.Pdms.Graphics.dll)

See Also

DrawList Members | Aveva.Pdms.Graphics Namespace


DrawList Members

DrawList overview

Public Instance Methods

Add | Overloaded.
AddOnly | Overloaded.
AddReferences |
AddWithinVolume |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists |
GetDrawListMember |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVisualProperties |
GetWithinVolume |
Highlight | Overloaded.
Members |
Remove | Overloaded.
RemoveAll |
RemoveOnly | Overloaded.
SetColour |
SetEdges |
SetTransparency |
SetVisibility |
SetVisualProperties | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unhighlight | Overloaded.
VisibleAll |

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList Methods

The methods of the DrawList class are listed below. For a complete list of DrawList class members, see the DrawList Members topic.

Public Instance Methods

Add | Overloaded.
AddOnly | Overloaded.
AddReferences |
AddWithinVolume |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists |
GetDrawListMember |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVisualProperties |
GetWithinVolume |
Highlight | Overloaded.
Members |
Remove | Overloaded.
RemoveAll |
RemoveOnly | Overloaded.
SetColour |
SetEdges |
SetTransparency |
SetVisibility |
SetVisualProperties | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.
Unhighlight | Overloaded.
VisibleAll |

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


Add Method

AVEVA Graphics .NET Public Interface

DrawList.Add Method

Overload List

public abstract void Add(DbElement);

public abstract void Add(DbElement[]);

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList.Add Method (DbElement)

public abstract void Add(
DbElement element
);

Parameters

element

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.Add Overload List


DrawList.Add Method (DbElement[])

public abstract void Add(
DbElement[] elements
);

Parameters

elements

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.Add Overload List


AddOnly Method

AVEVA Graphics .NET Public Interface

DrawList.AddOnly Method

Overload List

public abstract void AddOnly(DbElement);

public abstract void AddOnly(DbElement[]);

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList.AddOnly Method (DbElement)

public abstract void AddOnly(
DbElement element
);

Parameters

element

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.AddOnly Overload List


DrawList.AddOnly Method (DbElement[])

public abstract void AddOnly(
DbElement[] elements
);

Parameters

elements

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.AddOnly Overload List


DrawList.AddReferences Method

public abstract void AddReferences(
DbElement element
);

Parameters

element

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList.AddWithinVolume Method

public abstract void AddWithinVolume(
DbElement element
);

Parameters

element

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList.Exists Method

public abstract bool Exists(
DbElement element
);

Parameters

element

Return Value

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList.GetDrawListMember Method

public abstract DrawListMember GetDrawListMember(
DbElement element
);

Parameters

element

Return Value

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList.GetVisualProperties Method

public abstract void GetVisualProperties(
ref bool autoColour,
ref double autoColorRed,
ref double autoColorGreen,
ref double autoColorBlue,
ref int transparency,
ref bool edges
);

Parameters

autoColour
autoColorRed
autoColorGreen
autoColorBlue
transparency
edges

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList.GetWithinVolume Method

public abstract DbElement[] GetWithinVolume(
DbElement element
);

Parameters

element

Return Value

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


Highlight Method

AVEVA Graphics .NET Public Interface

DrawList.Highlight Method

Overload List

public abstract void Highlight(DbElement);

public abstract void Highlight(DbElement[]);

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList.Highlight Method (DbElement)

public abstract void Highlight(
DbElement element
);

Parameters

element

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.Highlight Overload List


DrawList.Highlight Method (DbElement[])

public abstract void Highlight(
DbElement[] elements
);

Parameters

elements

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.Highlight Overload List


DrawList.Members Method

public abstract DrawListMember[] Members();

Return Value

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


Remove Method

AVEVA Graphics .NET Public Interface

DrawList.Remove Method

Overload List

public abstract void Remove(DbElement);

public abstract void Remove(DbElement[]);

public abstract void Remove(DrawListMember);

public abstract void Remove(DrawListMember[]);

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList.Remove Method (DbElement)

public abstract void Remove(
DbElement element
);

Parameters

element

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.Remove Overload List


DrawList.Remove Method (DbElement[])

public abstract void Remove(
DbElement[] elements
);

Parameters

elements

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.Remove Overload List


DrawList.Remove Method (DrawListMember)

public abstract void Remove(
DrawListMember member
);

Parameters

member

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.Remove Overload List


DrawList.Remove Method (DrawListMember[])

public abstract void Remove(
DrawListMember[] members
);

Parameters

members

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.Remove Overload List


DrawList.RemoveAll Method

public abstract void RemoveAll();

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


RemoveOnly Method

AVEVA Graphics .NET Public Interface

DrawList.RemoveOnly Method

Overload List

public abstract void RemoveOnly(DbElement);

public abstract void RemoveOnly(DbElement[]);

public abstract void RemoveOnly(DrawListMember);

public abstract void RemoveOnly(DrawListMember[]);

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList.RemoveOnly Method (DbElement)

public abstract void RemoveOnly(
DbElement element
);

Parameters

element

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.RemoveOnly Overload List


DrawList.RemoveOnly Method (DbElement[])

public abstract void RemoveOnly(
DbElement[] elements
);

Parameters

elements

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.RemoveOnly Overload List


DrawList.RemoveOnly Method (DrawListMember)

public abstract void RemoveOnly(
DrawListMember member
);

Parameters

member

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.RemoveOnly Overload List


DrawList.RemoveOnly Method (DrawListMember[])

public abstract void RemoveOnly(
DrawListMember[] members
);

Parameters

members

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.RemoveOnly Overload List


DrawList.SetColour Method

public abstract void SetColour(
DrawListMember[] members,
int colour
);

Parameters

members
colour

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList.SetEdges Method

public abstract void SetEdges(
DrawListMember[] members,
bool edges
);

Parameters

members
edges

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList.SetTransparency Method

public abstract void SetTransparency(
DrawListMember[] members,
int transparency
);

Parameters

members
transparency

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList.SetVisibility Method

public abstract void SetVisibility(
DrawListMember[] members,
bool visibility
);

Parameters

members
visibility

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


SetVisualProperties Method

AVEVA Graphics .NET Public Interface

DrawList.SetVisualProperties Method

Overload List

public abstract void SetVisualProperties(DrawListMember[],bool,int,int,bool);

public abstract void SetVisualProperties(bool,int,int,bool);

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList.SetVisualProperties Method (DrawListMember[], Boolean, Int32, Int32, Boolean)

public abstract void SetVisualProperties(
DrawListMember[] members,
bool visibility,
int colour,
int transparency,
bool edges
);

Parameters

members
visibility
colour
transparency
edges

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.SetVisualProperties Overload List


DrawList.SetVisualProperties Method (Boolean, Int32, Int32, Boolean)

public abstract void SetVisualProperties(
bool autoColour,
int colour,
int transparency,
bool edges
);

Parameters

autoColour
colour
transparency
edges

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.SetVisualProperties Overload List


Unhighlight Method

AVEVA Graphics .NET Public Interface

DrawList.Unhighlight Method

Overload List

public abstract void Unhighlight(DbElement);

public abstract void Unhighlight(DbElement[]);

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawList.Unhighlight Method (DbElement)

public abstract void Unhighlight(
DbElement element
);

Parameters

element

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.Unhighlight Overload List


DrawList.Unhighlight Method (DbElement[])

public abstract void Unhighlight(
DbElement[] elements
);

Parameters

elements

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace | DrawList.Unhighlight Overload List


DrawList.VisibleAll Method

public abstract void VisibleAll();

See Also

DrawList Class | Aveva.Pdms.Graphics Namespace


DrawListChange Enumeration

public enum DrawListChange

Members

Member Name | Description
None |
Visual |
Members |
Graphics |

Requirements

Namespace: Aveva.Pdms.Graphics

Assembly: Aveva.Pdms.Graphics (in Aveva.Pdms.Graphics.dll)

See Also

Aveva.Pdms.Graphics Namespace


DrawListEventArgs Class

Summary description for DrawListEventArgs.

For a list of all members of this type, see DrawListEventArgs Members.

System.Object
System.EventArgs
Aveva.Pdms.Graphics.DrawListEventArgs

public class DrawListEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Graphics

Assembly: Aveva.Pdms.Graphics (in Aveva.Pdms.Graphics.dll)

See Also

DrawListEventArgs Members | Aveva.Pdms.Graphics Namespace


DrawListEventArgs Members

DrawListEventArgs overview

Public Instance Constructors

DrawListEventArgs Constructor

Public Instance Properties

EventType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DrawListEventArgs Class | Aveva.Pdms.Graphics Namespace


DrawListEventArgs Constructor

public DrawListEventArgs(
DrawListChange eventType
);

Parameters

eventType

See Also

DrawListEventArgs Class | Aveva.Pdms.Graphics Namespace


DrawListEventArgs Properties

The properties of the DrawListEventArgs class are listed below. For a complete list of DrawListEventArgs class members, see the DrawListEventArgs Members topic.

Public Instance Properties

EventType

See Also

DrawListEventArgs Class | Aveva.Pdms.Graphics Namespace


EventType Property

AVEVA Graphics .NET Public Interface

DrawListEventArgs.EventType Property

public DrawListChange EventType {get;}

See Also

DrawListEventArgs Class | Aveva.Pdms.Graphics Namespace


DrawListEventHandler Delegate

public delegate void DrawListEventHandler(
object sender,
DrawListEventArgs e
);

Requirements

Namespace: Aveva.Pdms.Graphics

Assembly: Aveva.Pdms.Graphics (in Aveva.Pdms.Graphics.dll)

See Also

Aveva.Pdms.Graphics Namespace


DrawListManager Class

Summary description for DrawListManager.

For a list of all members of this type, see DrawListManager Members.

System.Object
Aveva.Pdms.Graphics.DrawListManager

public abstract class DrawListManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Graphics

Assembly: Aveva.Pdms.Graphics (in Aveva.Pdms.Graphics.dll)

See Also

DrawListManager Members | Aveva.Pdms.Graphics Namespace


DrawListManager Members

DrawListManager overview

Public Static Fields

Instance

Public Static Methods

FireChangedEvent

Public Static Events

Changed

Public Instance Properties

CurrentDrawList

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getDrawList |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DrawListManager Class | Aveva.Pdms.Graphics Namespace


DrawListManager Fields

The fields of the DrawListManager class are listed below. For a complete list of DrawListManager class members, see the DrawListManager Members topic.

Public Static Fields

Instance

See Also

DrawListManager Class | Aveva.Pdms.Graphics Namespace


DrawListManager.Instance Field

public static readonly DrawListManager Instance;

See Also

DrawListManager Class | Aveva.Pdms.Graphics Namespace


DrawListManager Properties

The properties of the DrawListManager class are listed below. For a complete list of DrawListManager class members, see the DrawListManager Members topic.

Public Instance Properties

CurrentDrawList

See Also

DrawListManager Class | Aveva.Pdms.Graphics Namespace


CurrentDrawList Property

AVEVA Graphics .NET Public Interface

DrawListManager.CurrentDrawList Property

public abstract DrawList CurrentDrawList {get;}

See Also

DrawListManager Class | Aveva.Pdms.Graphics Namespace


DrawListManager Methods

The methods of the DrawListManager class are listed below. For a complete list of DrawListManager class members, see the DrawListManager Members topic.

Public Static Methods

FireChangedEvent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getDrawList |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DrawListManager Class | Aveva.Pdms.Graphics Namespace


DrawListManager.FireChangedEvent Method

public static void FireChangedEvent(
DrawListEventArgs e
);

See Also

DrawListManager Class | Aveva.Pdms.Graphics Namespace


DrawListManager.getDrawList Method

public abstract DrawList getDrawList(
int viewWindowId
);

Parameters

viewWindowId

See Also

DrawListManager Class | Aveva.Pdms.Graphics Namespace


DrawListManager Events

The events of the DrawListManager class are listed below. For a complete list of DrawListManager class members, see the DrawListManager Members topic.

Public Static Events

Changed

See Also

DrawListManager Class | Aveva.Pdms.Graphics Namespace


DrawListManager.Changed Event

public static event DrawListEventHandler Changed;

Event Data

The event handler receives an argument of type DrawListEventArgs containing data related to this event. The following DrawListEventArgs property provides information specific to this event.

Property | Description
EventType |

See Also

DrawListManager Class | Aveva.Pdms.Graphics Namespace


DrawListMember Class

Summary description for DrawListMember.

For a list of all members of this type, see DrawListMember Members.

System.Object
Aveva.Pdms.Graphics.DrawListMember

public abstract class DrawListMember

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Graphics

Assembly: Aveva.Pdms.Graphics (in Aveva.Pdms.Graphics.dll)

See Also

DrawListMember Members | Aveva.Pdms.Graphics Namespace


DrawListMember Members

DrawListMember overview

Public Instance Properties

Colour
DbElement
Edges
Transparency
Visibility

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVisualProperties |
SetVisualProperties |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DrawListMember Class | Aveva.Pdms.Graphics Namespace


DrawListMember Properties

The properties of the DrawListMember class are listed below. For a complete list of DrawListMember class members, see the DrawListMember Members topic.

Public Instance Properties

Colour
DbElement
Edges
Transparency
Visibility

See Also

DrawListMember Class | Aveva.Pdms.Graphics Namespace


Colour Property

AVEVA Graphics .NET Public Interface

DrawListMember.Colour Property

public abstract int Colour {get; set;}

See Also

DrawListMember Class | Aveva.Pdms.Graphics Namespace


DbElement Property

AVEVA Graphics .NET Public Interface

DrawListMember.DbElement Property

public abstract Aveva.Pdms.Database.DbElement DbElement {get;}

See Also

DrawListMember Class | Aveva.Pdms.Graphics Namespace


Edges Property

AVEVA Graphics .NET Public Interface

DrawListMember.Edges Property

public abstract bool Edges {get; set;}

See Also

DrawListMember Class | Aveva.Pdms.Graphics Namespace


Transparency Property

AVEVA Graphics .NET Public Interface

DrawListMember.Transparency Property

public abstract int Transparency {get; set;}

See Also

DrawListMember Class | Aveva.Pdms.Graphics Namespace


Visibility Property

AVEVA Graphics .NET Public Interface

DrawListMember.Visibility Property

public abstract bool Visibility {get; set;}

See Also

DrawListMember Class | Aveva.Pdms.Graphics Namespace


DrawListMember Methods

The methods of the DrawListMember class are listed below. For a complete list of DrawListMember class members, see the DrawListMember Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVisualProperties |
SetVisualProperties |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DrawListMember Class | Aveva.Pdms.Graphics Namespace


DrawListMember.GetVisualProperties Method

public abstract void GetVisualProperties(
ref bool visibility,
ref int colour,
ref int transparency,
ref bool edges
);

Parameters

visibility
colour
transparency
edges

See Also

DrawListMember Class | Aveva.Pdms.Graphics Namespace


DrawListMember.SetVisualProperties Method

public abstract void SetVisualProperties(
bool visibility,
int colour,
int transparency,
bool edges
);

Parameters

visibility
colour
transparency
edges

See Also

DrawListMember Class | Aveva.Pdms.Graphics Namespace


Units Class

Units formatting.

For a list of all members of this type, see Units Members.

System.Object
Aveva.Pdms.Graphics.Units

public abstract class Units

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aveva.Pdms.Graphics

Assembly: Aveva.Pdms.Graphics (in Aveva.Pdms.Graphics.dll)

See Also

Units Members | Aveva.Pdms.Graphics Namespace


Units Members

Units overview

Public Static Methods

CreateUnits

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Format |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Units Class | Aveva.Pdms.Graphics Namespace


Units Methods

The methods of the Units class are listed below. For a complete list of Units class members, see the Units Members topic.

Public Static Methods

CreateUnits

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Format |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Units Class | Aveva.Pdms.Graphics Namespace


Units.CreateUnits Method

public static Units CreateUnits();

Return Value

See Also

Units Class | Aveva.Pdms.Graphics Namespace


Units.Format Method

public abstract string Format(
double value
);

Parameters

value

Return Value

See Also

Units Class | Aveva.Pdms.Graphics Namespace


Units.GetValue Method

public abstract double GetValue(
string input
);

Parameters

input

Return Value

See Also

Units Class | Aveva.Pdms.Graphics Namespace


Aveva.Pdms.GraphicsHierarchy

AVEVA Graphics .NET Public Interface

Aveva.Pdms.Graphics Hierarchy

System.Object
Aveva.Pdms.Graphics.Colour
Aveva.Pdms.Graphics.Colours
Aveva.Pdms.Graphics.DrawList
Aveva.Pdms.Graphics.DrawListManager
Aveva.Pdms.Graphics.DrawListMember
Aveva.Pdms.Graphics.Units
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aveva.Pdms.Graphics.DrawListEventHandler
System.EventArgs
Aveva.Pdms.Graphics.DrawListEventArgs
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aveva.Pdms.Graphics.DrawListChange

See Also

Aveva.Pdms.Graphics Namespace